IP : IP アプリケーション サービス

HSRP(Hot Stanby Router Protocol)を使用したロード シェアリング

2002 年 11 月 22 日 - ライター翻訳版
その他のバージョン: PDFpdf | 機械翻訳版 (2013 年 8 月 21 日) | 英語版 (2005 年 8 月 10 日) | フィードバック

目次

概要
はじめに
     表記法
     前提条件
     使用するコンポーネント
     背景理論
設定
     ネットワーク ダイアグラム
     設定例
     重要な注意事項
確認
トラブルシューティング
関連するシスコ サポート コミュニティ ディスカッション
関連情報

概要

この文書では、特定の宛先への複数のパスを利用するために Hot Standby Router Protocol(HSRP; ホットスタンバイ ルータ プロトコル)をどのように設定すればよいかについて、具体例を示します。

はじめに

表記法

文書の表記法の詳細は、「シスコ テクニカル ティップスの表記法」を参照してください。

前提条件

この文書に関する特別な前提条件はありません。

使用するコンポーネント

この文書は特定のソフトウェアやハードウェアのバージョンに限定されるものではありません。

この文書の情報は、特定のラボ環境にあるデバイスに基づいて作成されています。 この文書内で使用されているデバイスはすべて、クリアな状態(デフォルト)から設定作業を始めています。 コマンドを実行する前に、実稼動中のネットワークに与える影響について理解しておいてください。

背景理論

HSRP は多くの場合、ネットワークの復元力を向上させるために使用されますが、HSRP が原因でネットワークの効率が低下する場合があります。 下記の例では、ホスト ネットワークからサーバ ネットワークに対して 2 つのパスがあります。 冗長化のために R1 と R2 の間で HSRP が動作しています。R1 と R2 のどちらか一方がアクティブ ルータになり、HSRP 仮想 IP アドレスの「所有権」を取得します。 もう 1 台のルータはスタンバイ ルータになり、現在のアクティブ ルータがダウンした場合のみ、アクティブ ルータになります。 アクティブ ルータとスタンバイ ルータの詳細については、「standby preempt および standby track コマンドの使用方法」を参照してください。

ホストのデフォルト ゲートウェイ アドレスには HSRP 仮想 IP アドレスを割り当てています。 ホストがサーバ ネットワークにパケットを送信するときは、デフォルト ゲートウェイ、つまりアクティブ状態にあるルータに対してパケットが送信されます。 1 台のルータのみがアクティブであるため、ホストからサーバへのパケットは、2 つの使用可能なパスのうち、どちらか一方のみを通過します。

注:サーバからホストに戻るパケットは、R3 の設定方法に応じて両方のリターン パスを使用することも、一方のみを使用することもあります。  また、サーバからホストに戻るパケットは、必ずしもアクティブ ルータを通過する必要はありません。

ホスト ネットワークからサーバ ネットワークへのパスを両方とも利用するために、R1 と R2 の間で Multigroup HSRP(MHSRP)を設定できます。 基本的に、R1 には 2 つの HSRP グループ(グループ 1 および グループ 2 とします)を設定し、R2 にも同じ HSRP グループを設定します。 グループ 1 では、R1 がアクティブ ルータで、R2 がスタンバイ ルータです。 グループ 2 では、R2 がアクティブ ルータで、R1 がスタンバイ ルータです。 半数のホストのデフォルト ゲートウェイには HSRP グループ 1 の仮想 IP アドレスを設定し、残りの半数には HSRP グループ 2 の仮想 IP アドレスを設定します。

設定

このセクションでは、この文書で説明されている機能を設定するための情報を提示します。

注:この文書で使用されるコマンドの追加情報を検索するには、Command Lookup ツールを使用してください。 

ネットワーク ダイアグラム

この文書では、次の図に示されるネットワーク セットアップを使用します。

7a.gif

設定例

この文書では、次に示す設定を使用します。

R1 の MHSRP 設定

Current configuration:
   interface Ethernet0
           ip address 171.16.6.5 255.255.255.0
           standby 1 preempt
           standby 1 ip 171.16.6.100
           standby 1 track Serial0
           standby 2 preempt
           standby 2 ip 171.16.6.200
           standby 2 track serial 0
           standby 2 priority 95

R2 の MHSRP 設定

Current configuration:
   interface Ethernet0
          ip address 171.16.6.6 255.255.255.0
          standby 1 preempt
          standby 1 ip 171.16.6.100
          standby 1 track Serial0
          standby 1 priority 95
          standby 2 preempt
          standby 2 ip 171.16.6.200
          standby 2 track serial 0

上記の設定例から、2 台のルータが HSRP の実行を開始したとき、R1 は、グループ 1 に対する優先順位がデフォルトの 100 であり、グループ 2 に対する優先順位が 95 です。R2 は、グループ 2 に対する優先順位がデフォルトの 100 であり、グループ 1 に対する優先順位が 95 です。したがって、グループ 1 では R1、グループ 2 では R2 がそれぞれアクティブ ルータになります。この例は、MHSRP によってロード シェアリングが実現可能であることを示しています。 ただし、これを実現するには、HSRP 優先順位を使用してトラフィックを優先的に割り当てる必要があります。 HSRP は、リターン トラフィックには影響を及ぼしません。

重要な注意事項

ローエンド製品に搭載されているイーサネット(Lance および QUICC)コントローラによっては、アドレス フィルタ内にユニキャスト Media Access Control(MAC; メディア アクセス制御)アドレスを 1 つしか設定できません。 これらのプラットフォームは HSRP グループを 1 つだけ許可し、そのグループがアクティブになると、インターフェイス アドレスを HSRP 仮想 MAC アドレスに変更します。 この制限のあるプラットフォームでは、HSRP を使用したロード シェアリングは実現できません。 上記のようなローエンド製品で HSRP を実行する際に発生する問題を回避するために、use-bia コマンドが導入されました。 たとえば、同じインターフェイス上で HSRP と DECnet を実行すると、DECnet と HSRP が MAC アドレスを変更しようとするため、問題が生じます。 use-bia コマンドを使用すれば、DECnet プロセスで生成された MAC アドレスを使用するように HSRP を設定できます。 ただし、use-bia コマンドには次のような欠点があることを認識しておく必要があります。

  • ルータがアクティブになると、仮想 IP アドレスが異なる MAC アドレスに移動します。 新しいアクティブ ルータは gratuitous Address Resolution Protocol(ARP)応答を送信しますが、必ずしもすべてのホスト実装が gratuitous ARP を正しく処理できるとは限りません。

  • use-bia を設定すると、プロキシ ARP を使用できません。 スタンバイ ルータは、故障したルータのプロキシ ARP データベースが失われた場合、それを補うことができません。

確認

現在のところ、この設定を確認する手順はありません。

トラブルシューティング

現在のところ、この設定に関する特定のトラブルシューティング情報はありません。


関連するシスコ サポート コミュニティ ディスカッション

シスコ サポート コミュニティは、どなたでも投稿や回答ができる情報交換スペースです。


関連情報


Document ID: 13781