IP : IP マルチキャスト

マルチキャスト クイックスタート コンフィギュレーション ガイド

2008 年 8 月 26 日 - ライター翻訳版
その他のバージョン: PDFpdf | 機械翻訳版 (2013 年 8 月 21 日) | 英語版 (2005 年 8 月 30 日) | フィードバック

目次

概要
前提条件
      要件
      使用するコンポーネント
      表記法
稠密モード
RP が 1 つの希薄モード
RP が複数の希薄モード
RP が 1 つの Auto-RP
RP が複数の Auto-RP
DVMRP
MBGP
MSDP
スタブ マルチキャスト ルーティング
衛星回線向け IGMP UDLR
PIMv2 BSR
CGMP
IGMP スヌーピング
PGM
MRM
トラブルシューティング
関連するシスコ サポート コミュニティ ディスカッション
関連情報

概要

IP マルチキャストは、無数の企業の受信者や家庭に対して単一の情報ストリームを同時配信することによりトラフィックが軽減される、帯域幅節減のためのテクノロジーです。マルチキャストの応用例としては、ビデオ会議、企業間通信、遠距離学習、ソフトウェア、株価、ニュースの配信などがあります。このドキュメントでは、各種のネットワーキング事例に応じたマルチキャストのコンフィギュレーション方法の基礎について説明しています。

前提条件

要件

このドキュメントの読者は、インターネット プロトコル(IP)マルチキャストの基本的な知識を習得しているが推奨されます。

注:詳細は、『IP マルチキャスト』ドキュメントを参照してください。

使用するコンポーネント

このドキュメントは、特定のソフトウェアやハードウェアのバージョンに限定されるものではありません。

表記法

ドキュメント表記の詳細は、『シスコ テクニカル ティップスの表記法』を参照してください。

稠密(dense)モード

特に新規の導入では、Protocol Independent Multicast(PIM)希薄(sparse)モード、とりわけ Auto-RP をできる限り使用することを推奨いたします。しかし、稠密モードが望ましい場合は、グローバル コマンド ip multicast-routing とインターフェイス コマンド ip pim sparse-dense-mode を、マルチキャスト トラフィックを処理する必要のあるインターフェイスごとに設定してください。このドキュメント内のすべての設定では、マルチキャストをグローバルに設定し、インターフェイスで PIM を設定することが、共通の必要条件となっています。Cisco IOS(R) ソフトウェア リリース 11.1 では、インターフェイス コマンド ip pim dense-mode および ip pim sparse-mode を、ip pim sparse-dense-mode コマンドと並行して設定できます。このモードでは、グループが稠密モードならばインターフェイスは稠密モードとして扱われます。グループが希薄モードならば(RP が既知の場合など)、インターフェイスは希薄モードとして扱われます。

注:このドキュメントのすべての例では、「送信側」はマルチキャスト トラフィックの送信元を表し、「受信側」はマルチキャスト トラフィックの受信先を表しています。

mcast1.gif

Router A の設定

ip multicast-routing 

interface ethernet0 
ip address <address> <mask>
ip pim sparse-dense-mode  

interface serial0 
ip address <address> <mask>
ip pim sparse-dense-mode

Router B の設定

ip multicast-routing 

interface serial0 
ip address <address> <mask>
ip pim sparse-dense-mode 

interface ethernet0 
ip address <address> <mask>
ip pim sparse-dense-mode 

RP が 1 つの希薄モード

通常、RP は送信元に最も近いルータであり、この例では、Router A が RP です。スタティック RP コンフィギュレーションでは、PIM ドメイン内のすべてのルータで同じ ip pim rp-address コマンドが設定されている必要があります。RP は複数設定できますが、特定のグループごとに許される RP は 1 つだけです。

mcast2.gif

Router A の設定

ip multicast-routing 
ip pim rp-address 1.1.1.1
 

interface ethernet0 
ip address <address> <mask>
ip pim sparse-dense-mode 

interface serial0 
ip address 1.1.1.1 255.255.255.0 
ip pim sparse-dense-mode 

Router B の設定

ip multicast-routing 
ip pim rp-address 1.1.1.1 


interface serial0 
ip address <address> <mask>
ip pim sparse-dense-mode 

interface ethernet0 
ip address <address> <mask>
ip pim sparse-dense-mode 

RP が複数の希薄モード

この例では、Source-A は 224.1.1.1、224.1.1.2、および 224.1.1.3 に送信します。Source-B は 224.2.2.2、224.2.2.3、および 224.2.2.4 に送信します。RP 1 または RP 2 のどちらかのルータ 1 台をすべてのグループの RP にすることができます。ただし、異なる RP で異なるグループを処理する場合は、どのグループが RP の処理対象となるのかを含めたかたちですべてのルータを設定する必要があります。この種のスタティック RP コンフィギュレーションでは、PIM ドメイン内のすべてのルータで同じ ip pim rp-address <address> <acl> コマンドが設定されている必要があります。Auto-RP を使用することもできます。こちらの方が同じセットアップを実現するのに設定が簡単です。

mcast3.gif

RP 1 の設定

ip multicast-routing 
 
ip pim RP-address 1.1.1.1 2
ip pim RP-address 2.2.2.2 3 
 
access-list 2 permit 224.1.1.1 
access-list 2 permit 224.1.1.2 
access-list 2 permit 224.1.1.3
access-list 3 permit 224.2.2.2 
access-list 3 permit 224.2.2.3 
access-list 3 permit 224.2.2.4

RP 2 の設定

ip multicast-routing
  
ip pim RP-address 1.1.1.1 2 
ip pim RP-address 2.2.2.2  3
 
access-list 2 permit 224.1.1.1 
access-list 2 permit 224.1.1.2 
access-list 2 permit 224.1.1.3 
access-list 3 permit 224.2.2.2 
access-list 3 permit 224.2.2.3 
access-list 3 permit 224.2.2.4 

Router 3 と 4 の設定
ip multicast-routing 
ip pim RP-address 1.1.1.1  2 
ip pim RP-address 2.2.2.2  3
 

access-list 2 permit 224.1.1.1 
access-list 2 permit 224.1.1.2 
access-list 2 permit 224.1.1.3 
access-list 3 permit 224.2.2.2 
access-list 3 permit 224.2.2.3 
access-list 3 permit 224.2.2.4 

RP が 1 つの Auto-RP

Auto-RP では、各 RP のアベイラビリティを RP およびマッピング エージェントとしてアナウンスするよう個々の RP を設定する必要があります。RP は 224.0.1.39 を使用して各自のアナウンスメントを送信します。RP マッピング エージェントはアナウンスされたパケットを受信した後、ディスカバリ メッセージの中で RP 対グループのマッピングを送信します。ディスカバリ メッセージは 224.0.1.40 に送信されます。残りのルータはこれらのディスカバリ メッセージを使用して、各自の RP 対グループのマッピングを行います。1 つの RP をマッピング エージェントとしても機能するようにできます。また、冗長化の目的で複数の RP と複数のマッピング エージェントを設定することも可能です。

RP アナウンスメントの送信元となるインターフェイスを選択する際には、物理インターフェイスでなくループバックなどのインターフェイスを使用することを推奨いたします。また、Switched VLAN Interface(SVI)を使用することも可能です。RP アドレスをアナウンスするために VLAN インターフェイスが使用される場合は、ip pim [vrf vrf-name] send-rp-announce {interface-type interface-number | ip-address} scope ttl-value コマンドの interface-type オプションに VLAN インターフェイスと VLAN 番号が含まれる必要があります。たとえば、コマンドは ip pim send-rp-announce Vlan500 scope 100 のようになります。物理インターフェイスを選択する場合は、そのインターフェイスが常にアップしていることが前提となります。物理インターフェイスは常にアップしているとは限らないため、物理インターフェイスがダウンすると、ルータは RP としてのルータ自体のアドバタイジングを中止します。ループバック インターフェイスを使用すると、常にアップした状態でダウンすることがないため、RP が使用可能な任意のインターフェイスを通して自身を RP としてアドバタイズし続けることが保証されます。1 つまたは複数の物理インターフェイスで障害が発生した場合でも同様です。ループバック インターフェイスは、PIM が有効にされ Interior Gateway Protocol(IGP)によってアドバタイズされるか、またはスタティック ルーティングを使用して到達できる必要があります。

mcast4.gif

Router A の設定

ip multicast-routing 
 
ip pim send-rp-announce loopback0 scope 16
ip pim send-rp-discovery scope 16 

interface loopback0
ip address <address> <mask>
ip pim sparse-dense-mode 
 
interface ethernet0 
ip address <address> <mask>
ip pim sparse-dense-mode 

interface serial0 
ip address <address> <mask>
ip pim sparse-dense-mode 

Router B の設定

ip multicast-routing 


interface ethernet0 
ip address <address> <mask>
ip pim sparse-dense-mode 

interface serial0 
ip address <address> <mask>
ip pim sparse-dense-mode 

RP が複数の Auto-RP

この例のアクセス リストにより、RP を必要なグループだけの RP にすることができます。アクセス リストを設定しなければ、RP はすべてグループの RP として使用されます。2 つの RP が各自のアベイラビリティを同じグループの RP としてアナウンスする場合、マッピング エージェントは「最も大きな IP アドレスを優先する」という規則を使用してこれらの競合を解決します。

2 つの RP がそのグループに対してアナウンスする際に、どのルータが特定のグループの RP なのかが指定されるように、それぞれのルータをループバック アドレスに設定できます。優先される RP に最大の IP アドレスを設定し、それからループバック インターフェイスをアナウンス パケットの送信元として使用します。たとえば ip pim send-RP-announce loopback0 などとします。マッピング エージェントを複数使用すると、各エージェントにより RP マッピングに対する同じグループが 224.0.1.40 ディスカバリグループにアドバタイズされます。

mcast5.gif

RP 1 の設定

ip multicast-routing
 
interface loopback0
ip address <address> <mask>
ip pim sparse-dense-mode  
 
ip pim send-RP-announce loopback0 scope 16 group-list 1
ip pim send-RP-discovery scope 16 


access-list 1 permit 239.0.0.0 0.255.255.255 

RP 2 の設定

ip multicast-routing
 
interface loopback0
ip address <address> <mask>
ip pim sparse-dense-mode 
 
ip pim send-RP-announce loopback0 scope 16 group-list 1
ip pim send-RP-discovery scope 16 


access-list 1 deny 239.0.0.0 0.255.255.255 
access-list 1 permit 224.0.0.0 15.255.255.255 

Auto-RP についての詳細は、『Auto-RP 設定および診断ガイド』を参照してください。

DVMRP

インターネット サービス プロバイダー(ISP)から、インターネット内のマルチキャスト バックボーン(MBONE)にアクセスできるようにするため、ISP への Distance Vector Multicast Routing Protocol(DVMRP; ディスタンスベクトル マルチキャスト ルーティング プロトコル)トンネルを作成するように提案されることがあります。DVMRP トンネルの設定に必要な最低限のコマンドを次に示します。

interface tunnel0  
ip unnumbered <any pim interface>
tunnel source <address of source>
tunnel destination <address of ISPs mrouted box> 
tunnel mode dvmrp  
ip pim sparse-dense-mode

通常は、ISP の指示に従い、「mrouted」(DVMRP)が実行されている UNIX コンピュータにトンネル伝送します。ISP から別の Cisco デバイスにトンネル伝送するよう指示された場合は、デフォルトの GRE トンネル モードを使用してください。

マルチキャスト パケットを受信するのではなく、MBONE の他のノードで参照されるマルチキャスト パケットを生成する場合は、送信元のサブネットをアドバタイズする必要があります。マルチキャストの発信元のホスト アドレスが 131.108.1.1 であれば、そのサブネットの存在を MBONE にアドバタイズする必要があります。デフォルトでは、直接接続ネットワークはメトリック 1 でアドバタイズされます。送信元が DVMRP トンネルでルータに直接接続されていない場合は、インターフェイス tunnel0 の下で次のように設定します。

ip dvmrp metric 1 list 3  
access-list 3 permit 131.108.1.0 0.0.0.255

注:ユニキャスト ルーティング テーブル全体が MBONE にアドバタイズされないように、このコマンドを使用してアクセス リストを追加する必要があります。

セットアップがここに示したものと同様の場合で、ドメインを通じて DVMRP ルートを伝搬する場合は、Router A および Router B の serial0 インターフェイスで ip dvmrp unicast-routing コマンドを設定します。この処理により、DVMRP ルートが PIM ネイバーに転送され、次にそこで DVMRP ルーティング テーブルが Reverse Path Forwarding(RPF)に使用されます。DVMRP の学習ルートは、直接接続ルートを除いて、RPF では他のすべてのプロトコルで優先されます。

mcast6.gif

MBGP

Multiprotocol Border Gateway Protocol(MBGP)は、ユニキャスト ルーティング用に設定されたルートと、マルチキャスト ルーティング用に設定されたルートの、2 組のルートを搬送するための基本的な方式です。MBGP は、マルチキャスト パケットがどこを流れることを許可するかを決めるのに必要な制御機能を提供します。マルチキャスト ルーティングに関連付けられたルートは、データ配送ツリーを構築するために PIM で使用されます。MBGP は RPF パスを提供しますが、マルチキャスト ステートは作成しません。マルチキャスト パケットの転送のために PIM が引き続き必要になります。

mcast7.gif

Router A の設定

ip multicast-routing 


interface loopback0 
ip pim sparse-dense-mode 
ip address 192.168.2.2 255.255.255.0 


interface serial0 
ip address 192.168.100.1 255.255.255.0 


interface serial1 
ip pim sparse-dense-mode 
ip address 192.168.200.1 255.255.255.0 


router bgp 123 
network 192.168.100.0 nlri unicast 
network 192.168.200.0 nlri multicast 
neighbor 192.168.1.1 remote-as 321 nlri unicast multicast 
neighbor 192.168.1.1 ebgp-multihop 255 
neighbor 192.168.100.2 update-source loopback0 
neighbor 192.168.1.1 route-map setNH out 


route-map setNH permit 10 
match nlri multicast 
set ip next-hop 192.168.200.1 


route-map setNH permit 20 

Router B の設定

ip multicast-routing 


interface loopback0 
ip pim sparse-dense-mode 
ip address 192.168.1.1 255.255.255.0 


interface serial0 
ip address 192.168.100.2 255.255.255.0 


interface serial1 
ip pim sparse-dense-mode 
ip address 192.168.200.2 255.255.255.0 


router bgp 321 
network 192.168.100.0 nlri unicast 
network 192.168.200.0 nlri multicast 
neighbor 192.168.2.2 remote-as 123 nlri unicast multicast 
neighbor 192.168.2.2 ebgp-multihop 255 
neighbor 192.168.100.1 update-source loopback0 
neighbor 192.168.2.2 route-map setNH out 


route-map setNH permit 10 
match nlri multicast 
set ip next-hop 192.168.200.2 


route-map set NH permit 20 

ユニキャストのトポロジとマルチキャストのトポロジが一致している場合(同じリンクを通過しているなど)、設定の主な違いは nlri unicast multicast コマンドによるものです。ここに例を示します。

network 192.168.100.0 nlri unicast multicast

トポロジが一致する場合の MBGP の使用には利点があります。つまり、トラフィックが同じパスを通過する場合でもユニキャスト BGP とマルチキャスト BGP とで異なるポリシーを適用できるという点です。

MBGP についての詳細は、『MBGP について』を参照してください。

MSDP

Multicast Source Discovery Protocol(MSDP)は複数の PIM-SM ドメイン同士を接続します。PIM-SM ドメインはそれぞれ独立した RP を使用するため、他のドメインの RP に依存する必要がありません。ドメインは MSDP を使用することで、マルチキャストの発信元を他のドメインから検出できます。MSDP ピアと BGP ピア関係を確立する場合は、MSDP に対して BGP で使用したものと同じ IP アドレスを使用する必要があります。MSDP では、ピア RPF チェックを実行する際、BGP/MBGP が SA メッセージで指定されている RP でルート テーブル検索を実行する時に BGP/MBGP から与えられたものと MSDP ピアのアドレスが同じアドレスであることを前提とします。ただし、MSDP ピアの間に BGP/MBGP パスがある場合、MSDP ピアとの間で BGP/MBGP を実行する必要はありません。BGP/MBGP パスが存在せず、MSDP ピアが複数存在する場合は、ip msdp default-peer コマンドを使用する必要があります。ここの例では、RP A および RP B はそれぞれのドメイン用の RP です。

mcast8.gif

Router A の設定

ip multicast-routing 


ip pim send-RP-announce loopback0 scope 16
ip pim send-RP-discovery scope 16 


ip msdp peer 192.168.100.2 
ip msdp sa-request 192.168.100.2 

interface loopback0
ip address <address> <mask>
ip pim sparse-dense-mode 
 
interface serial0 
ip address 192.168.100.1 255.255.255.0 
ip pim sparse-dense-mode 

Router B の設定

ip multicast-routing 

ip pim send-RP-announce loopback0 scope 16 
ip pim send-RP-discovery scope 16 


ip msdp peer 192.168.100.1 
ip msdp sa-request 192.168.100.1 

interface loopback0
ip address <address> <mask>
ip pim sparse-dense-mode 
 
interface serial0 
ip address 192.168.100.2 255.255.255.0 
ip pim sparse-dense-mode 

スタブ マルチキャスト ルーティング

スタブ マルチキャスト ルーティングを使用すると、リモート ルータまたはスタブ ルータを IGMP プロキシ エージェントとして設定できます。これらのスタブ ルータは、PIM に全面的に参加するのではなく、ホストからアップストリームのマルチキャスト ルータに IGMP メッセージを転送します。

mcast9.gif

Router 1 の設定

int s0 
ip pim sparse-dense-mode 
ip pim neighbor-filter 1 


access-list 1 deny 140.1.1.1

Router 1 が Router 2 を PIM ネイバーとして認識しないようにするため、ip pim neighbor-filter コマンドが必要になります。Router 1 を希薄モードで設定した場合は、ネイバー フィルタは不要です。Router 2 は希薄モードでは実行しないでください。稠密モードでは、スタブ マルチキャストの発信元はバックボーン ルータにフラッディングできます。

Router 2 の設定

ip multicast-routing 
int e0 
ip pim sparse-dense-mode 
ip igmp helper-address 140.1.1.2 


int s0 
ip pim sparse-dense-mode 

衛星回線向け IGMP UDLR

UniDirectional Link Routing(UDLR)は、単方向の衛星回線を経由して、バック チャネルを持つスタブ ネットワークにマルチキャスト パケットを転送するための手段を提供します。この仕組みはスタブ マルチキャスト ルーティングに似ています。この機能がない場合、ダウンリンク ルータは送り返すことができないため、アップリンク ルータはどの IP マルチキャスト グループ アドレスを単方向の回線を経由して転送するのかを動的に学習できなくなります。

mcast10.gif

Uplink-rtr の設定

ip multicast-routing 


interface Ethernet0 
description Typical IP multicast enabled interface 
ip address 12.0.0.1 255.0.0.0 
ip pim sparse-dense-mode 


interface Ethernet1 
description Back channel which has connectivity to downlink-rtr 
ip address 11.0.0.1 255.0.0.0 
ip pim sparse-dense-mode 


interface Serial0 
description Unidirectional to downlink-rtr 
ip address 10.0.0.1 255.0.0.0 
ip pim sparse-dense-mode 
ip igmp unidirectional-link 
no keepalive 

Downlink-rtr の設定

ip multicast-routing 


interface Ethernet0 
description Typical IP multicast enabled interface 
ip address 14.0.0.2 255.0.0.0 
ip pim sparse-dense-mode 
ip igmp helper-address udl serial0 


interface Ethernet1 
description Back channel which has connectivity to downlink-rtr 
ip address 13.0.0.2 255.0.0.0 
ip pim sparse-dense-mode 


interface Serial0 
description Unidirectional to uplink-rtr 
ip address 10.0.0.2 255.0.0.0 
ip pim sparse-dense-mode 
ip igmp unidirectional-link 
no keepalive 

PIMv2 BSR

ネットワークのすべてのルータで PIMv2 が実行されている場合は、Auto-RP の代わりに BSR を設定できます。BSR と Auto-RP はよく似ています。BSR コンフィギュレーションでは、BSR 候補(Auto-RP での RP アナウンスに類似)と BSR(Auto-RP のマッピング エージェントに類似)を設定する必要があります。BSR を設定するには次の手順に従います。

  1. 候補 BSR で次を設定します。

    ip pim bsr-candidate interface hash-mask-len pref
    

    ここで、interface には BSR 候補の IP アドレスを指定します。必ずしもそうする必要はありませんが、hash-mask-Len はすべての BSR 候補で同じにすることを推奨いたします。最大の pref 値を持つ BSR 候補が、このドメインの BSR として選出されます。

    コマンドの使用例を次に示します。

    ip pim bsr-candidate ethernet0 30 4
    

    PIMv2 BSR は、RP 候補の情報を収集して、各グループ プレフィクスに関連付けられた RP セット情報を伝搬します。シングル ポイント障害を回避するために、ドメイン内の複数のルータを BSR 候補として設定できます。

    設定されたプリファレンス値をもとに、BSR 候補の中から BSR が自動的に選出されます。BSR 候補として機能するためには、ルータが接続され、ネットワークのダイヤルアップ エリア内ではなく、ネットワークのバックボーン内に設置する必要があります。

  2. RP 候補ルータを設定します。次の例は、admin-scope アドレス範囲全体に対する、インターフェイス ethernet0 上の候補 RP を示したものです。

    access-list 11 permit 239.0.0.0 0.255.255.255
    ip pim rp-candidate ethernet0 group-list 11
    

CGMP

Group Management Protocol(CGMP)を設定するには、スイッチに面しているルータ インターフェイスで次のように設定します。

ip pim sparse-dense-mode 
ip cgmp

そして、スイッチで次のように設定します。

set cgmp enable

IGMP スヌーピング

Internet Group Management Protocol(IGMP; インターネット グループ管理プロトコル)スヌーピングは、Catalyst 5000 のリリース 4.1 で使用できます。IGMP スヌーピングには、Supervisor III カードが必要です。ルータに IGMP スヌーピングを設定するには、PIM 以外の設定は必要ありません。IGMP クエリーを提供するために、IGMP スヌーピングではルータが引き続き必要になります。

ここに掲載した例は、スイッチで IGMP スヌーピングを有効にする方法を示したものです。

Console> (enable) set igmp enable  
IGMP Snooping is enabled.  
CGMP is disabled. 

IGMP を有効にしようとして CGMP がすでに有効であると、次のメッセージが表示されます。

Console> (enable) set igmp enable  
Disable CGMP to enable IGMP Snooping feature. 

PGM

Pragmatic General Multicast(PGM)は、複数の発信元から複数の受信側に対してマルチキャスト データを正しい順序で重複なく配信することを必要とするアプリケーションにとって、信頼性の高いマルチキャスト トランスポート プロトコルです。PGM により、グループ内の受信側がすべて送信または再送信されたデータ パケットを受信すること、あるいは修復不可能なデータ パケットの損失を検出できることが保証されます。

PGM 用のグローバル コマンドはありません。PGM は ip pgm コマンドを使用してインターフェイスごとに設定します。インターフェイスで PIM を有効にするとともに、ルータでマルチキャスト ルーティングを有効にする必要があります。

MRM

Multicast Routing Monitor(MRM)により、大規模なマルチキャスト ルーティング インフラストラクチャでの自動障害検出が可能になります。MRM はマルチキャスト ルーティングの問題をネットワーク管理者にほぼリアルタイムで警告します。

MRM には MRM テスターと MRM マネージャの 2 つのコンポーネントがあります。MRM テスターは送信側または受信側になります。

MRM は Cisco IOS ソフトウェア リリース 12.0(5)T 以降で使用できます。MRM テスターと MRM マネージャでは、MRM サポート版の Cisco IOS が稼働している必要があります。

mcast11.gif

テスト送信側の設定

interface Ethernet0 
  ip mrm test-sender 

テスト受信側の設定

interface Ethernet0 
  ip mrm test-receiver 

テスト マネージャの設定

ip mrm manager test1 
 manager e0 group 239.1.1.1 
 senders 1 
 receivers 2 sender-list 1 


 access-list 1 permit 10.1.1.2 
 access-list 2 permit 10.1.4.2 

テスト マネージャでの show ip mrm manager コマンドからの出力を次に示します。

Test_Manager# show ip mrm manager 
   Manager:test1/10.1.2.2 is not running 
     Beacon interval/holdtime/ttl:60/86400/32 
     Group:239.1.1.1, UDP port test-packet/status-report:16384/65535 
     Test sender: 
       10.1.1.2 
     Test receiver: 
       10.1.4.2

ここに示したコマンドを使用してテストを開始します。テスト マネージャは、テスト パラメータで設定されたとおりに、テスト送信側とテスト受信側にコントロール メッセージを送信します。テスト受信側はグループに加入し、テスト送信側から送信されるテスト パケットを監視します。

Test_Manager# mrm start test1 
 *Feb  4 10:29:51.798: IP MRM test test1 starts ......  
Test_Manager#

テスト マネージャのステータス レポートを表示するには、次のコマンドを入力します。

Test_Manager# show ip mrm status  

IP MRM status report cache:  
Timestamp        Manager          Test Receiver   Pkt Loss/Dup (%)       Ehsr  
*Feb  4 14:12:46 10.1.2.2         10.1.4.2        1            (4%)      29  
*Feb  4 18:29:54 10.1.2.2         10.1.4.2        1            (4%)      15  
Test_Manager#

この出力は、表示されているタイムスタンプ時に受信側から 2 つのステータス レポート(それぞれ 1 行ずつ)が送られたことを示しています。レポートにはそれぞれインターバル時間内(デフォルトは 1 秒)におけるパケット喪失が 1 つずつ含まれています。「Ehsr」の値は、テスト送信側からの次のシーケンス推定数値を示しています。テスト受信側で重複パケットが検出されると、「Pkt Loss/Dup」の欄に負数が示されます。

テストを終了するには次のコマンドを入力します。

Test_Manager# mrm stop test1 
*Feb  4 10:30:12.018: IP MRM test test1 stops  
Test_Manager# 

テストの実行中、MRM の送信側は設定されたグループ アドレスに対して、RTP パケットを 200 ミリ秒のデフォルト間隔で送信し始めます。受信側は、同じパケットが同じデフォルトの間隔で送信されてくることをモニタ(予期)します。受信側が 5 秒のデフォルト時間インターバルの間にパケット喪失を検出した場合、受信側から MRM マネージャにレポートが送られます。受信側からのステータス レポートは、マネージャで show ip mrm status コマンドを発行して表示できます。

トラブルシューティング

ネットワークで IP マルチキャストを実装する場合に発生する最も一般的な問題には、ルータが RPF の障害または TTL 設定のためにマルチキャスト トラフィックを転送しないことがあります。これらの問題やその他のよくある問題、症状、および解決策についての詳細は、『IP マルチキャストのトラブルシューティング ガイド』を参照してください。


関連するシスコ サポート コミュニティ ディスカッション

シスコ サポート コミュニティは、どなたでも投稿や回答ができる情報交換スペースです。


関連情報


Document ID: 9356