IP : IP マルチキャスト

GRE トンネル経由でのマルチキャスト

2003 年 8 月 21 日 - ライター翻訳版
その他のバージョン: PDFpdf | 機械翻訳版 (2013 年 8 月 21 日) | 英語版 (2005 年 12 月 21 日) | フィードバック

目次

概要
はじめに
     表記法
     前提条件
     使用するコンポーネント
設定
     ネットワーク ダイアグラム
     設定
確認
トラブルシューティング
関連するシスコ サポート コミュニティ ディスカッション
関連情報

概要

この文書では、Generic Routing Encapsulation(GRE)トンネル経由によるマルチキャストの設定例を提供します。

多くのネットワーク シナリオでは、GRE トンネルを使うようにネットワークを設定して、ルータ間での Protocol Independent Multicast(PIM)とマルチキャスト トラフィックの送信を行います。通常、これが発生するのは、マルチキャスト送信元と受信側が IP クラウドで隔てられており、この IP クラウドが IP マルチキャスト ルーティング用に設定されていない場合です。このようなネットワーク シナリオでは、IP クラウドに PIM を有効にしたトンネルを設定することにより、受信側にマルチキャスト パケットを転送します。 この文書では、GRE トンネル経由でのマルチキャストに関連する設定、確認、および、問題について説明します。

はじめに

表記法

文書の表記法の詳細は、「シスコ テクニカル ティップスの表記法」を参照してください。

前提条件

マルチキャストと PIM についての基本的な知識が役に立ちます。マルチキャストと PIM についての詳細情報は『マルチキャストのクイックスタート設定ガイド』を参照してください。

使用するコンポーネント

この文書は特定のソフトウェアやハードウェアのバージョンに限定されるものではありません。

この文書の情報は、特定のラボ環境にあるデバイスに基づいて作成されています。この文書内で使用されているデバイスはすべて、クリアな状態(デフォルト)から設定作業を始めています。コマンドを実行する前に、実稼動中のネットワークに与える影響について理解しておいてください。

設定

次のネットワーク ダイアグラムに示すように、マルチキャスト送信元(10.1.1.1)は R102 に接続されており、マルチキャスト グループ 239.1.1.20 に設定されています。マルチキャスト受信側(10.2.2.3)は R104 に接続されており、グループ 239.1.1.20 へのマルチキャスト パケットを受信するように設定されています。R102 と R104 は IP クラウドで隔てられており、この IP クラウドはマルチキャスト ルーティング用には設定されていません。

それぞれのループバック インターフェイスをソースとして R102 と R104 の間にトンネルが設定されています。トンネル インターフェイスでは ip pim sparse-dense mode コマンドが設定されており、R102 と R104 ではマルチキャスト ルーティングが有効になっています。トンネル インターフェイスで希薄/稠密モードを設定することにより、グループの Rendezvous Point(RP)設定に応じて、希薄モード、あるいは、稠密モードのパケットをトンネル経由で転送できます。

注:  稠密モード:トンネルに PIM 稠密モードが設定されていると、ip mroute 10.1.1.0 255.255.255.0 tunnel 0 コマンドが R104 に設定され、マルチキャスト送信元アドレス 10.1.1.1 の RPF 機能が保証されます。トンネル 0(Tu0)経由で着信する(10.1.1.1, 239.1.1.20)マルチキャスト パケットは、この mroute ステートメントにより Reverse Path Forwarding(RPF)のチェックを受けます。チェックが完了すると、マルチキャスト パケットは Outgoing Interface List(OIL)インターフェイスに転送されます。

注:  希薄モード:トンネルに PIM 希薄モードが設定されていると、次の点への対応がなされていることを確認します。

  • RP からの共有ツリー(*,G)を流れるマルチキャスト トラフィックの RPF 確認を成功させるために、ip mroute rp-address nexthop コマンドをその RP アドレス用に設定して、トンネル インターフェイスを指すようにする必要があります。

    R102 が RP(RP アドレス 2.2.2.2)であると仮定すると、mroute コマンドは ip mroute 2.2.2.2 255.255.255.255 tunnel 0 のようになり、共有ツリーを流れるトラフィックの RPF 確認の成功が保証されます。

  • Shortest Path Tree(SPT; 最短パス ツリー)を流れるマルチキャスト(S,G)トラフィックの RPF 確認を成功させるために、ip mroute source-address nexthop コマンドをマルチキャスト送信元用に設定して、トンネル インターフェイスを指すようにする必要があります。

    この場合、SPT トラフックがトンネル インターフェイスを流れる際に、R104 で ip mroute 10.1.1.0 255.255.255.0 tunnel 0 コマンドが設定され、Tu0 インターフェイス経由で着信する(10.1.1.1, 239.1.1.20)マルチキャスト パケットの RPF 確認の成功が保証されます。

この文書で使用されているコマンドの詳細を調べるには、「Command Lookup ツール」を使用してください(登録ユーザのみ)。

一部ツールについては、ゲスト登録のお客様にはアクセスできない場合がありますことを、ご了承ください。

ネットワーク ダイアグラム

この文書では、次の図に示すネットワーク設定を使用しています。

mcast-gre2.gif

設定例

この文書で使用する設定を次に示します。

  • R102

  • R104

R102

r102#
  version 12.2
  !
  hostname r102
  !
  !
  ip subnet-zero
  no ip domain-lookup
  
  !--- これにより IP ドメインのルックアップが停止し、show コマンドの応答時間が改善されます。
  
  !
  ip multicast-routing
  
  !--- IP マルチキャスト ルーティングを有効にします。
  
  !
  interface Loopback0
   ip address 2.2.2.2 255.255.255.255
  
  !--- トンネル送信元インターフェイス。
  
  !
  interface Tunnel0
  
  !--- PIM 用に設定され R104 へのマルチキャスト パケットを運ぶトンネル インターフェイス。
   
   ip address 192.168.24.1 255.255.255.252
   ip pim sparse-dense-mode
   tunnel source Loopback0
   tunnel destination 4.4.4.4
  !
  interface Ethernet0/0
  
  !--- 送信元に接続されたインターフェイス。
  
   ip address 10.1.1.2 255.255.255.0
   ip pim sparse-dense-mode
  !
  !
  interface Serial8/0
   ip address 192.168.23.1 255.255.255.252
  
  !--- IP PIM 希薄/稠密 モードはシリアル インターフェイスには設定されていない点に注意。
  
  !
  router ospf 1
   log-adjacency-changes
   network 2.2.2.2 0.0.0.0 area 0
   network 10.1.1.0 0.0.0.255 area 0
   network 192.168.23.0 0.0.0.255 area 0
  !
  ip classless
  ip pim bidir-enable
  !         
  line con 0
  line aux 0
  line vty 0 4
   login
  !
  end

  

R104

r104#
  version 12.2
  !
  hostname r104
  !
  !
  ip subnet-zero
  no ip domain-lookup
  
  !--- これにより IP ドメインのルックアップが停止し、show コマンドの応答時間が改善されます。
  
  !
  ip multicast-routing
  
  !--- IP マルチキャスト ルーティングを有効にします。
  
  !
  interface Loopback0
   ip address 4.4.4.4 255.255.255.255
  
  !--- トンネル送信元インターフェイス。
  
  !
  interface Tunnel0
   ip address 192.168.24.2 255.255.255.252
  
  !--- PIM 用に設定され、マルチキャスト パケットを伝送するトンネル インターフェイス。
  
   ip pim sparse-dense-mode
   tunnel source Loopback0
   tunnel destination 2.2.2.2
  !
  interface Ethernet0/0
   ip address 10.2.2.2 255.255.255.0
   ip pim sparse-dense-mode
  !
  interface Serial9/0
   ip address 192.168.34.1 255.255.255.252
  
  !--- IP PIM 希薄/稠密 モードはシリアル インターフェイスには設定されていない点に注意。
  
  !
  !
  router ospf 1
   log-adjacency-changes
   network 4.4.4.4 0.0.0.0 area 0
   network 10.2.2.0 0.0.0.255 area 0
   network 192.168.34.0 0.0.0.255 area 0
  !
  ip classless
  no ip http server
  ip pim bidir-enable
  ip mroute 10.1.1.0 255.255.255.0 Tunnel0
  
  !--- この Mroute は送信元から流れてくるパケットの RPF 確認の成功を保証します。
  
  
  !---10.1.1.1 へは、稠密モードの場合は共有ツリー、希薄モードの場合は SPT を使用します。
  
  !
  ip mroute 2.2.2.2 255.255.255.255 tunnel 0
  
  !--- この Mroute は、SPT スイッチオーバーの前に、希薄モードのマルチキャスト トラフィックが
  !--- RP(RP として 2.2.2.2 を伴う R102 を仮定)から受信側へトンネル経由で流れる場合の
  !--- RPF チェックに必要です。
  
  line con 0
  line aux 0
  line vty 0 4
   login
  !
  end

  

確認

次の手順を実行して、設定を確認します。

  1. show ip igmp group コマンドを使って、グループ 239.1.1.20 への IGMP 加入メンバーシップ要求を受信側が R104 に送ったことを確認します。

    r104# show ip igmp groups 
      IGMP Connected Group Membership
      Group Address    Interface      Uptime    Expires   Last Reporter
      239.1.1.20       Ethernet0/0    00:00:04  00:02:55  10.2.2.3
      
  2. 次に示すように、show ip mroute group-address コマンドを使って、送信元 10.1.1.1 がグループ 239.1.1.20 のパケットのマルチキャスティングを開始する場合に、R102 が自分の mroute テーブルに(*, 239.1.1.20)と(10.1.1.1, 239.1.1.20)のエントリをインストールするのを表示します。

    r102# show ip mroute 239.1.1.20
      IP Multicast Routing Table
      Flags: D - Dense, S - Sparse, B - Bidir Group, s - SSM Group, C - Connected,
             L - Local, P - Pruned, R - RP-bit set, F - Register flag,
             T - SPT-bit set, J - Join SPT, M - MSDP created entry,
             X - Proxy Join Timer Running, A - Candidate for MSDP Advertisement,
             U - URD, I - Received Source Specific Host Report
      Outgoing interface flags: H - Hardware switched
      Timers: Uptime/Expires
      Interface state: Interface, Next-Hop or VCD, State/Mode
      (*, 239.1.1.20), 00:00:09/00:02:59, RP 0.0.0.0, flags: D
        Incoming interface: Null, RPF nbr 0.0.0.0
        Outgoing interface list:
          Tunnel0, Forward/Sparse-Dense, 00:00:09/00:00:00
          Ethernet0/0, Forward/Sparse-Dense, 00:00:09/00:00:00
      (10.1.1.1, 239.1.1.20), 00:00:09/00:02:58, flags: T
        Incoming interface: Ethernet0/0, RPF nbr 0.0.0.0
        Outgoing interface list:
          Tunnel0, Forward/Sparse-Dense, 00:00:09/00:00:00
      

    注:(10.1.1.1, 239.1.1.20)のエントリでは、OIL はトンネル 0 です。 

  3. 次に示すように、show ip mroute group-address コマンドを使って、R104 が 10.1.1.1 を送信元とする、グループ 239.1.1.20 のマルチキャスト パケットを転送している間、(*, 239.1.1.20)と(10.1.1.1, 239.1.1.20)のエントリを保持していることを確認します。

    r104# show ip mroute 239.1.1.20
      IP Multicast Routing Table
      Flags: D - Dense, S - Sparse, B - Bidir Group, s - SSM Group, C - Connected,
             L - Local, P - Pruned, R - RP-bit set, F - Register flag,
             T - SPT-bit set, J - Join SPT, M - MSDP created entry,
             X - Proxy Join Timer Running, A - Candidate for MSDP Advertisement,
             U - URD, I - Received Source Specific Host Report
      Outgoing interface flags: H - Hardware switched
      Timers: Uptime/Expires
      Interface state: Interface, Next-Hop or VCD, State/Mode
      (*, 239.1.1.20), 00:07:10/00:00:00, RP 0.0.0.0, flags: DCL
        Incoming interface: Null, RPF nbr 0.0.0.0
        Outgoing interface list:
          Tunnel0, Forward/Sparse-Dense, 00:07:10/00:00:00
          Ethernet0/0, Forward/Sparse-Dense, 00:07:10/00:00:00
      (10.1.1.1, 239.1.1.20), 00:01:13/00:02:24, flags: CLT
        Incoming interface: Tunnel0, RPF nbr 192.168.24.1, Mroute
        Outgoing interface list:
          Ethernet0/0, Forward/Sparse-Dense, 00:01:13/00:00:00

    注:(10.1.1.1, 239.1.1.20)では着信インターフェイスはトンネル 0 で、RPF の隣接は 192.168.24.1、つまり R102 のトンネル ヘッドエンドです。  RPF 確認は R104 で設定された Mroute に基づいて行われ、マルチキャスト パケットがイーサネット 0/0 インターフェイスで接続された受信側への OIL にプッシュされます。

  4. show ip rpf ip-address コマンドを使って、10.1.1.1 を送信元とするパケットの RPF 確認を行います。次の例では、10.1.1.1 の RPF がトンネル 0 経由で、そこでマルチキャスト(S,G)パケットを受信していることを確認します。

    r104> show ip rpf 10.1.1.1
      RPF information for ? (10.1.1.1)
        RPF interface: Tunnel0
        RPF neighbor: ? (192.168.24.1)
        RPF route/mask: 10.1.1.1/24
        RPF type: static
        RPF recursion count: 0
        Doing distance-preferred lookups across tables

    特定の show コマンドは、Output Interpreter ツール登録ユーザのみ)でサポートされています。このツールを使用すると、show コマンドの出力を分析できます。

  5. 一部ツールについては、ゲスト登録のお客様にはアクセスできない場合がありますことを、ご了承ください。

トラブルシューティング

GRE トンネル経由のマルチキャストが機能しない場合には、次の原因が考えられます。

  • トンネルが UP/UP になっていない:トンネルの両端で、トンネルの送信元と受信側が不一致。たとえば、R102 でトンネルの宛先が 2.2.2.2 ではなく、IP アドレス 10.2.2.2 に変更されており、R104 での設定に変更がない場合は、トンネルはアップしません。トンネルの状態を確認するには、show interface tunnel 0 コマンドを使用します。

  • RPF の障害:show ip mroute count コマンドを使用して、RPF 障害によるマルチキャスト パケットの廃棄を確認します。show ip mroute count コマンド、および、RPF 障害により増加しているカウンタの出力例を次に太字で示します。

    r104# show ip mroute count
      IP Multicast Statistics
      3 routes using 1642 bytes of memory
      2 groups, 0.50 average sources per group
      Forwarding Counts: Pkt Count/Pkts per second/Avg Pkt Size/Kilobits per second
      Other counts: Total/RPF failed/Other drops(OIF-null, rate-limit etc)
      Group: 224.0.1.40, Source count: 0, Packets forwarded: 0, Packets received: 0
      Group: 239.1.1.20, Source count: 1, Packets forwarded: 11, Packets received: 45
        Source: 10.1.1.1/32, Forwarding: 11/0/100/0, Other: 25/14/0
      
      !--- 時間を置いて show ip mroute count コマンドが再発行されます。
      !--- RPF 障害カウンタが増加しているのがわかります。
      
      r104# show ip mroute count
      IP Multicast Statistics
      3 routes using 1642 bytes of memory
      2 groups, 0.50 average sources per group
      Forwarding Counts: Pkt Count/Pkts per second/Avg Pkt Size/Kilobits per second
      Other counts: Total/RPF failed/Other drops(OIF-null, rate-limit etc)
      Group: 224.0.1.40, Source count: 0, Packets forwarded: 0, Packets received: 0
      Group: 239.1.1.20, Source count: 1, Packets forwarded: 11, Packets received: 50
        Source: 10.1.1.1/32, Forwarding: 11/0/100/0, Other: 30/19/0
      r104#
      

    show ip rpf source コマンドを使って、RPF インターフェイスが、送信元マルチキャスト パケットが受信されている(この例ではトンネル 0)インターフェイスと同一であることを確認します。RPF 障害に関する詳細情報は『IP マルチキャスト トラブルシューティング ガイド』を参照してください。

  • PIM 隣接ルータ:ルータ R102 からは PIM 隣接ルータの R104 が見えていないので、ルータ R102 はトンネル 0 のインターフェイス経由での転送を行っていません。R102 で show ip pim neighbor コマンドを使うと、トンネル経由で隣接の R104 が見えます。さらに show ip pim int コマンドを使うと、隣接ルータを表示できます。インターフェイス レベルの ip pim sparse-dense-mode コマンドがトンネルの両端で設定されていること、および、IP マルチキャスト ルーティングが有効になっていることを確認します。


関連するシスコ サポート コミュニティ ディスカッション

シスコ サポート コミュニティは、どなたでも投稿や回答ができる情報交換スペースです。


関連情報


Document ID: 43584