IP : IP アプリケーション サービス

ip unnumbered コマンドの設定

2010 年 8 月 30 日 - ライター翻訳版
その他のバージョン: PDFpdf | 機械翻訳版 (2013 年 8 月 21 日) | 英語版 (2005 年 10 月 26 日) | フィードバック

ip unnumbered コマンドの説明と設定 [IP アプリケーション サービス]:シスコシステムズ

目次

概要
前提条件
      要件
      使用するコンポーネント
      表記法
アンナンバード インターフェイスとは
IP と IP アンナンバード
設定例
      メジャー ネットは同一、サブネットは異なる
      メジャー ネットは異なり、サブネットがない
      サブネットのあるメジャー ネット、サブネットのないメジャー ネット
      2 つの異なるメジャー ネットとそれらに対応するサブネット
関連するシスコ サポート コミュニティ ディスカッション
関連情報

概要

このドキュメントでは、IP アンナンバードの概念について説明し、参照のためにいくつかの設定例を示します。ip unnumbered コンフィギュレーション コマンドでは、シリアル インターフェイスに明示的な IP アドレスを割り当てることなく IP 処理をイネーブルにできます。ip アンナンバード インターフェイスは、ルータ上にすでに設定されている別のインターフェイスの IP アドレスを「借りる」ことができ、これがネットワークとアドレス レンジを維持します。



前提条件

要件

このドキュメントに関する特別な要件はありません。



使用するコンポーネント

このドキュメントは、特定のソフトウェアやハードウェアに限定されるものではありません。



表記法

ドキュメント表記の詳細は、『シスコ テクニカル ティップスの表記法』を参照してください。



アンナンバード インターフェイスとは

次に示すネットワークを検討します。ルータ A には、シリアル インターフェイス S0 とイーサネット インターフェイス E0 があります。

/image/gif/paws/13786/20a_new.gif

ルータ A のイーサネット 0 インターフェイスは、次に示すように IP アドレスで設定できます。

interface Ethernet0
ip address 172.16.10.254 255.255.255.0

論理的には、インターフェイス S0 で IP をイネーブルにするには、それに一意の IP アドレスを設定する必要があります。ただし、シリアル インターフェイスの IP をイネーブルにして、一意の IP アドレスを割り当てることなくそれをアップすることも可能です。これは、ルータの他のインターフェイスですでに設定されている IP アドレスを借りることによって行われます。IP アドレスを借りるために、次に示すように ip unnumbered インターフェイス モード コマンドを使用します。

interface Serial 0
ip unnumbered Ethernet 0

ip unnumbered <type> <number> インターフェイス モード コマンドは、指定インターフェイスから、コマンドが設定済みのインターフェイスに IP アドレスを借ります。ip unnumbered コマンドを使用すると、結果として IP アドレスが 2 つのインターフェイスによって共有されます。そして、例では、イーサネット インターフェイス上に設定された IP アドレスは、シリアル インターフェイスにも割り当てられ、どちらのインターフェイスも機能を正常に含んでいました。これは、次に示すように、show ip interface brief コマンドの出力を使用して確認できます。

RouterA# show ip interface brief 

Interface    IP-Address      OK?    Method   Status   Protocol
Ethernet0    172.16.10.254   YES    manual   up       up
Serial0      172.16.10.254   YES    manual   up       up

上記の show ip interface brief コマンドの出力からもわかるように、シリアル インターフェイスの IP アドレスはイーサネット インターフェイスと同じであり、両方のインターフェイスは十分に機能します。ルータの、機能している他のインターフェイスの 1 つからその IP アドレスを借りているインターフェイスを「アンナンバード インターフェイス」と呼びます。例では、Serial 0 がアンナンバード インターフェイスです。

アンナンバード インターフェイスの唯一の実際的な欠点は、それがリモートのテストと管理には利用できないことです。また、アンナンバード インターフェイスは、稼動して設定できる状態になっているインターフェイスからそのアドレスを借りる必要もあります。機能していないインターフェイス(つまり、「Interface Status」が「up」、「Protocol」が「up」を示していないインターフェイス)をポイントしている場合、そのアンナンバード インターフェイスは機能しません。これが、アンナンバード インターフェイスはループバック インターフェイスをポイントすることを推奨する大きな理由です(ループバックは失敗しないため)。最後に、ip unnumbered コマンドがポイントツーポイント インターフェイスだけで動作することにも注目してください。マルチアクセス インターフェイス(つまり、イーサネット)またはループバック インターフェイスにこのコマンドを設定すると、次のメッセージが表示されます。

RouterA(config)# int e0 
RouterA(config-if)# ip unnumbered serial 0 
Point-to-point (non-multi-access) interfaces only 
RouterA(config-if)# ip unnumbered loopback 0 
Point-to-point (non-multi-access) interfaces only  


IP と IP アンナンバード

Cisco ルータでは、ネットワーク セグメントに接続しているそれぞれのインターフェイスが一意のサブセットに属している必要があります。直接接続されたルータには、同じネットワーク セグメントに接続されているインターフェイスがあり、同じサブネットから IP アドレスが割り当てられています。ルータは、直接接続されていないネットワークにデータを送信する必要がある場合、そのルーティング テーブルを検索して、宛先に対して次に直接接続されているホップにパケットを転送します。ルーティング テーブルにルートが存在しない場合には、ルータはラスト リゾートのゲートウェイにパケットを転送します。最終宛先に直接接続されているルータがパケットを受信すると、そのルータはエンド ホストに直接パケットを配信します。

IP ルーティング テーブルには、サブネット ルートまたはメジャー ネットワーク ルートのいずれかが含まれています。それぞれのルートには 1 つ以上の直接接続されたネクストホップ アドレスがあります。サブネット ルートは、ルーティング テーブルのサイズを減らすために、デフォルトでメジャー ネットワーク境界で集約され、まとめられます。

注:前述の集約スキームは、Routing Information Protocol(RIP)や Interior Gateway Routing Protocol(IGRP)などの従来のディスタンスベクトル ルーティング プロトコルを想定しています。

8 ビットのサブネット化を使用してサブネットになっているクラス B ネットワークを使用するルータのインターフェイスに IP アドレスを割り当てる場合を検討してみましょう。それぞれのインターフェイスでは一意のサブネットが必要になります。それぞれのポイントツーポイント シリアル接続にはアドレスに対して 2 つのエンド ポイントだけがあるため、サブネット全体をそれぞれのシリアル インターフェイスに割り当ててしまうと、2 つのアドレスだけが必要なそれぞれのインターフェイスに対して利用できる 254 ものアドレスを使用することになります。それぞれのシリアル インターフェイスに IP アンナンバードを使用すると、アドレス レンジを節約することになります。つまり、LAN インターフェイスのアドレスは「借りられ」、シリアル インターフェイスから発信されたルーティング アップデートとパケット用のソース アドレスとして使用されます。このように、アドレス レンジが節約されます。IP アンナンバードは、ポイントツーポイント リンクの場合にだけ意味を持ちます。

ルーティング アップデートを受信するルータは、ルーティング テーブルにネクストホップとしてそのアップデートのソース アドレスをインストールします。通常、ネクストホップは直接接続されたネットワーク ノードです。IP アンナンバードを使用する場合、これは当てはまらなくなります。その理由は、それぞれのシリアル インターフェイスが、異なるサブネット内や異なるメジャー ネットワーク内にある可能性もある、異なる LAN インターフェイスからその IP アドレスを「借りる」ためです。IP アンナンバードが設定されると、IP アンナンバード インターフェイス経由で習得されたルートには、ルーティング アップデートのソース アドレスではなく、ネクストホップとしてのインターフェイスがあります。つまり、直接接続されていないネクストホップから来るルーティング アップデートのソースによる、不正なネクストホップ アドレスの問題は避けることになります。



設定例

注:次の設定例の情報は、Cisco IOS® ソフトウェア バージョン 12.2(10b) に基づくものであり、Cisco 2500 シリーズ ルータでテストされたものです。

IP アンナンバードの 4 つの異なる設定例を見てみましょう。

注:イーサネット インターフェイスの代わりに、ループバック インターフェイスを使用することもできました。



メジャー ネットは同一、サブネットは異なる

図 1 は、シリアル リンクのどちらの側にも、異なるサブネットの同一のメジャー ネットがあることを示しています。

図 1:ネットワーク ダイアグラム

20a.gif

ルータ 1.1.1.1

ルータ 2.2.2.2

Current configuration:

interface Ethernet0
 ip address 171.68.178.196 255.255.255.192 

interface Serial0
 ip unnumbered Ethernet0

router igrp 10
 network 171.68.0.0 

Current configuration:

interface Ethernet 0
 ip address 171.68.179.1 255.255.255.192
 
interface Serial 0
 ip unnumbered Ethernet0 

router igrp 10
 network 171.68.0.0 

Router 1.1.1.1# show ip route

     171.68.0.0/26 is subnetted, 3 subnets
I       171.68.179.0 [100/8976] via 171.68.179.1, 00:00:02, Serial0
C       171.68.178.192 is directly connected, Ethernet0
I       171.68.0.0 [100/8976] via 171.68.179.1, 00:00:02, Serial0

Router 1.1.1.1# ping 171.68.179.1

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 171.68.179.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 28/30/32 ms


Router 2.2.2.2# show ip route

     171.68.0.0/26 is subnetted, 3 subnets
C       171.68.179.0 is directly connected, Ethernet0
I       171.68.178.192 [100/8976] via 171.68.178.196, 00:00:02, Serial0
I       171.68.0.0 [100/8976] via 171.68.178.196, 00:00:02, Serial0
     
Router 2.2.2.2# ping 171.68.178.196

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 171.68.178.196, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 32/32/32 ms

サブネットに関するルート情報は、このシナリオでは正しく保持されています。



メジャー ネットは異なり、サブネットがない

図 2 は、シリアル リンクのどちらの側にも、異なるメジャー ネットがあり、サブネットがないことを示しています。

図 2:ネットワーク ダイアグラム

/image/gif/paws/13786/20b.gif

ルータ 1.1.1.1

ルータ 2.2.2.2

Current configuration:

interface Ethernet0
 ip address 171.68.178.196 255.255.0.0 

interface Serial0
 ip unnumbered Ethernet0 
 
router igrp 10
 network 171.68.0.0 
Current configuration:

interface Ethernet 0
 ip address 172.68.1.1 255.255.0.0 

interface Serial 0
 ip unnumbered Ethernet0 
 
router igrp 10
 network 172.68.0.0

Router 1.1.1.1# show ip route

C    171.68.0.0/16 is directly connected, Ethernet0
I    172.68.0.0/16 [100/8976] via 172.68.1.1, 00:01:26, Serial0

Router 1.1.1.1# ping 172.68.1.1

Sending 5, 100-byte ICMP Echos to 172.68.1.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 28/28/28 ms


Router 2.2.2.2# show ip route

I    171.68.0.0/16 [100/8976] via 171.68.178.196, 00:00:21, Serial0
C    172.68.0.0/16 is directly connected, Ethernet0

Router 2.2.2.2# ping 171.68.178.196

Sending 5, 100-byte ICMP Echos to 171.68.178.196, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 28/29/32 ms



サブネットのあるメジャー ネット、サブネットのないメジャー ネット

図 3 は、シリアル リンクの一方の側にサブネットのあるメジャー ネットがあり、もう一方の側にサブネットのないメジャー ネットがあることを示しています。

図 3:ネットワーク ダイアグラム

/image/gif/paws/13786/20c.gif

ルータ 1.1.1.1

ルータ 2.2.2.2

Current configuration:

interface Ethernet0
 ip address 171.68.178.196 255.255.255.192

interface Serial0
 ip unnumbered Ethernet0 
 
router igrp 10
 network 171.68.0.0 
Current configuration:

interface Ethernet 0
 ip address 172.68.1.1 255.255.0.0

interface Serial 0
 ip unnumbered Ethernet0 
 
router igrp 10
 network 172.68.0.0

Router 1.1.1.1# show ip route

     171.68.0.0/26 is subnetted, 1 subnets
C       171.68.178.192 is directly connected, Ethernet0
I    172.68.0.0/16 [100/8976] via 172.68.1.1, 00:00:03, Serial0

Router 1.1.1.1# ping 172.68.1.1

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 172.68.1.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 28/31/32 ms


Router 2.2.2.2# show ip route

     171.68.0.0/16 is variably subnetted, 2 subnets, 2 masks
I       171.68.178.192/32 [100/8976] via 171.68.178.196, 00:00:48, Serial0
I       171.68.0.0/16 [100/8976] via 171.68.178.196, 00:00:48, Serial0
C    172.68.0.0/16 is directly connected, Ethernet0

Router 2.2.2.2# ping 171.68.178.196

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 171.68.178.196, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 28/29/32 ms

注:Cisco IOS ソフトウェア バージョン 11.0(2) よりも前では、ルータ 2.2.2.2 にメジャー ネット 171.68.0.0/16 用のスタティック ルートを入れる必要があります。

このシナリオでは、サブネット情報は、ホスト ルートとして扱われるため、失われます。Cisco IOS ソフトウェア バージョン 11.0(2) 以降では、Interior Gateway Routing Protocol(IGRP)および Routing Information Protocol(RIP)が、アンナンバードのポイントツーポイント リンク経由のメジャーネットにサマリー ルートを送信することで、この問題を修正しています。



2 つの異なるメジャー ネットとそれらに対応するサブネット

図 4 は、シリアル リンクの両側に、対応するサブネットのある 2 つの異なるメジャー ネットがあることを示しています。

図 4:ネットワーク ダイアグラム

/image/gif/paws/13786/20d.gif

ルータ 1.1.1.1

ルータ 2.2.2.2

Current configuration:

interface Ethernet0
 ip address 171.68.178.196 255.255.255.192 

interface Serial0
 ip unnumbered Ethernet0 
 
router igrp 10
 network 171.68.0.0
Current configuration:

interface Ethernet 0
 ip address 172.68.1.1 255.255.255.192 
 
interface Serial 0
 ip unnumbered Ethernet0 
 
router igrp 10
 network 172.68.0.0 

Router 1.1.1.1# show ip route

     171.68.0.0/26 is subnetted, 1 subnets
C       171.68.178.192 is directly connected, Ethernet0
     172.68.0.0/16 is variably subnetted, 2 subnets, 2 masks
I       172.68.0.0/16 [100/8976] via 172.68.1.1, 00:00:02, Serial0
I       172.68.1.0/32 [100/8976] via 172.68.1.1, 00:00:02, Serial0

Router 1.1.1.1# ping 172.68.1.1

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 172.68.1.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 32/81/280 ms


Router 2.2.2.2# show ip route

     171.68.0.0/16 is variably subnetted, 2 subnets, 2 masks
I       171.68.178.192/32 [100/8976] via 171.68.178.196, 00:00:22, Serial0
I       171.68.0.0/16 [100/8976] via 171.68.178.196, 00:00:22, Serial0
     172.68.0.0/26 is subnetted, 1 subnets
C       172.68.1.0 is directly connected, Ethernet0

Router 2.2.2.2# ping 171.68.178.196

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 171.68.178.196, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 28/31/32 ms

注:Cisco IOS ソフトウェア バージョンが 11.0(2) よりも前のものでは、ルータ 2.2.2.2 でメジャー ネット 171.68.0.0/16 用、ルータ 1.1.1.1 で 172.68.0.0/16 用のスタティック ルートを入れる必要があります。

このシナリオでは、サブネット情報は、ホスト ルートとして扱われるため、失われます。Cisco IOS ソフトウェア バージョン 11.0(2) 以降では、IGRP および RIP が、アンナンバードのポイントツーポイント リンク経由のメジャーネットにサマリー ルートを送信することで、この問題を修正しています。




関連するシスコ サポート コミュニティ ディスカッション

シスコ サポート コミュニティは、どなたでも投稿や回答ができる情報交換スペースです。


関連情報




Document ID: 13786