アプリケーション ネットワーキング サービス : Cisco 500 シリーズ キャッシュ エンジン

Content Services Switch を使用した、透過セットアップでの Cache Engine における IP スプーフィングの設定

2003 年 9 月 5 日 - ライター翻訳版
その他のバージョン: PDFpdf | 機械翻訳版 (2013 年 8 月 21 日) | 英語版 (2004 年 9 月 1 日) | フィードバック

目次

概要
はじめに
     表記法
     前提条件
     使用するコンポーネント
     背景理論
設定
     ネットワーク ダイアグラム
     設定
確認
トラブルシューティング
関連するシスコ サポート コミュニティ ディスカッション
関連情報

概要

この文書では、Cisco Cache Engine および Cisco Content Services Switch(CSS; コンテンツ サービス スイッチ)11000 または CSS 11500 ロード バランサで Web Cache Communication Protocol(WCCP; ウェブ キャッシュ通信プロトコル)を使用することなく、透過キャッシングと IP スプーフィングを同時に行う設定例を説明します。

はじめに

表記法

文書表記の詳細については、「シスコ テクニカル ティップスの表記法」を参照してください。

前提条件

この文書に関する特別な前提条件はありません。

使用するコンポーネント

この文書の情報は、次のソフトウェアとハードウェアのバージョンに基づいています。

  • Application and Content Networking System(ACNS)4.2 以降が動作する Cache Engine(CE)500

  • CSS 11000 または CSS 11500

この文書の情報は、特定のラボ環境にあるデバイスに基づいて作成されています。この文書内で使用されているデバイスはすべて、クリアーな状態(デフォルト)から設定作業を始めています。実稼動中のネットワークで作業をしている場合、実際にコマンドを使用する前に、その潜在的な影響について理解しておく必要があります。

背景理論

透過キャッシングとは、クライアントからサーバへのトラフィックが、ルータまたはレイヤ 4 スイッチにより、キャッシュ デバイス(この場合は Cisco Cache Engine)に自動的にリダイレクトされることを意味します。

キャッシュ デバイスに、クライアントが探しているコンテンツのコピーがすでに存在する場合、サーバの代わりにキャッシュが応答します。コンテンツがキャッシュに存在しない場合は、デバイスはクライアント要求に応答する前に、サーバからのコンテンツの取得を試みます。

デフォルトでは、キャッシュは自分自身の IP アドレスを使用して、サーバにコンタクトします。ただし、場合によってはクライアントの IP アドレスを使用しなければならないこともあります。これは、IP スプーフィングを設定することで実現できます。

設定

この項では、この文書で説明する機能を設定するために必要な情報を提供します。

ネットワーク ダイアグラム

この文書では次の図に示すネットワーク構成を使用しています。

ip_spoofing-a.gif

設定

この文書で使用する設定を次に示します。

  • CSS 11000

  • Cache Engine 500

CSS 11000

  !Generated on 04/18/2003 09:30:41
  !Active version: ap10500007s
  
  configure
  
  !*************************** GLOBAL ***************************
    no restrict web-mgmt 
    no restrict xml 
    bridge spanning-tree disabled 
    persistence reset remap 
    acl enable 
  
  !--- Access Control List(ACL; アクセス コントロール リスト)が必要です。ACL を有効にします。
  
   
    ip route 0.0.0.0 0.0.0.0 10.48.66.1 1 
    ip route 192.168.10.0 255.255.255.0 192.168.20.100 1 
    ip route 192.168.20.0 255.255.255.0 10.48.66.31 1 
    ip route 192.168.20.0 255.255.255.0 192.168.30.3 1
   
  
  !--- 重要 !!!!
  !--- CSS の ECMP 機能が動作するためには、
  !--- アップストリーム ルータを指す 1 つの経路と、
  !--- キャッシュを指す 1 つの同じ経路が必要です。
  !--- CSS は、トラフィックが最初に着信する場所に基づいて、
  !--- どの経路を使用するかを認識します。
  
  
  !************************* INTERFACE *************************
  interface e1
    phy 100Mbits-FD 
  
  interface e2
    bridge vlan 149 
    phy 100Mbits-FD 
  
  interface e3
    bridge vlan 161 
    phy 100Mbits-FD 
  
  !************************** CIRCUIT **************************
  circuit VLAN1
  
    ip address 10.48.66.130 255.255.254.0 
  
  circuit VLAN149
  
    ip address 192.168.10.70 255.255.255.0 
  
  circuit VLAN161
  
    ip address 192.168.30.1 255.255.255.0 
  
  !************************** SERVICE **************************
  service agra 
  
  !--- キャッシュ デバイスの定義。
  
    ip address 192.168.30.3 
    type transparent-cache
  
  !--- CSS が宛先アドレスに NAT を適用しないように、
  !--- タイプを transparent-cache に設定することが重要です。
  
  
    port 80 
    active 
  !**************************** EQL ****************************
  eql CacheMe 
  
  !--- どのオブジェクトがキャッシュ可能であるかの定義。
  
    extension gif 
    extension html 
    extension pdf 
    extension zip 
    extension gz 
  
  !*************************** OWNER ***************************
  owner gilles 
    content ToCache 
  
  !--- トラフィックをリダイレクトするコンテンツ ルールの定義。
  !--- すべての HTTP トラフィックを代行受信する必要があるため、VIP アドレスは指定されていません。
  
    
      protocol tcp 
      port 80 
      url "/*" eql CacheMe 
  
  !--- キャッシュ可能なオブジェクトのすべての要求をリダイレクトします。
  	 
      add service agra 
      active 
  !**************************** ACL ****************************
  acl 1 
    clause 10 bypass tcp any destination 192.168.10.2 eq 80
  
  !--- キャッシュ自身からの HTTP 要求がコンテンツ ルールにより代行受信
  !--- されないようにするため、この ACL が必要です。
  
  
    clause 20 permit any any destination any 
    apply circuit-(VLAN161) 
  acl 2 
  
  !--- その他のインターフェイスに対するすべてのトラフィックを許可します。
  
    clause 20 permit any any destination any 
    apply circuit-(VLAN149) 
    apply circuit-(VLAN1) 

Cache Engine 500

 
  hostname CE500
  ! 
  http l4-switch enable
  
  !--- すべての IP 宛先のトラフィックを受け入れるよう、Cache Engine に通知します。
  
  !
  !
  !
  !
  !
  !
  exec-timeout 0
  !
  !
  !
  interface FastEthernet 0/0
   ip address 192.168.30.3 255.255.255.0
   exit
  interface FastEthernet 0/1
   shutdown
   exit
  !
  !
  ip default-gateway 192.168.30.1
  !
  primary-interface FastEthernet 0/0
  !
  !
  !
  logging console enable
  !
  !
  !
  !
  !
  !
  !
  wccp version 2
  wccp spoof-client-ip enable
  
  !--- このコマンドは IP スプーフィングを有効にするため、WCCP を使用しない
  !--- 場合であっても、IP スプーフィングは機能します。
  
  !
  !
  CE500#
  

確認

この項では、設定が正常に動作しているかどうかを確認する際に役立つ情報を示します。

特定の show コマンドは、Output Interpreter ツール登録ユーザのみ)でサポートされています。このツールを使用すると、show コマンドの出力の分析を見ることができます。

CSS 11000 の show コマンド

  • show summary:CSS がトラフィックを受信し、リダイレクトしているかどうかを確認するため、コンテンツ ルールのヒット カウンタを表示します。

  • show service name:サービスのステータスを表示します。

Cache Engine のコマンド

  • show stat http request name:キャッシュにより受信された HTTP 要求の数を表示します。

  • show stat http savings name:Cache Engine でのヒットおよびミスの数を表示します。

トラブルシューティング

この問題のトラブルシューティングには、上記のコマンドを使用します。ただし多くの場合、トラフィックの正確な経路を見つけるために、スニファを使用する必要があります。

また、デバッグ モードで使用可能な CSS の flow trace コマンドを発行することもできます。ただし、スニファを使用した方が良好な結果が得られます。

一部ツールについては、ゲスト登録のお客様にはアクセスできない場合がありますことを、ご了承ください。

関連するシスコ サポート コミュニティ ディスカッション

シスコ サポート コミュニティは、どなたでも投稿や回答ができる情報交換スペースです。


関連情報


Document ID: 42162