アプリケーション ネットワーキング サービス : Cisco 500 シリーズ コンテンツ エンジン

ルータの ACL を使用したキャッシュ エンジンのバイパス方法

2003 年 7 月 24 日 - ライター翻訳版
その他のバージョン: PDFpdf | 機械翻訳版 (2013 年 8 月 21 日) | 英語版 (2007 年 1 月 8 日) | フィードバック

目次

概要
はじめに
     表記法
     前提条件
     使用するコンポーネント
設定
     ネットワーク ダイアグラム
     設定
確認
トラブルシューティング
関連するシスコ サポート コミュニティ ディスカッション
関連情報

概要

この文書では、簡単なルータの設定と Access Control List(ACL; アクセス コントロール リスト)を併用して、Cisco Cache Engine へのトラフィックを許可または拒否する方法について説明します。

C1(172.18.124.193)および C2(10.27.3.4)から発信され、任意のホストを宛先とするすべてのトラフィックは、ACL により指定されたキャッシュ エンジンをバイパスします。その他のすべてのトラフィックは転送されます。

はじめに

表記法

文書表記の詳細については、「シスコ テクニカル ティップスの表記法」を参照してください。

前提条件

この文書に関する特別な前提条件はありません。

使用するコンポーネント

この文書の情報は、次のソフトウェアとハードウェアのバージョンに基づいています。

  • 設定をクリアーにしたラボ環境にある Cisco Cache Engine 505

  • Cisco 2611 ルータ

  • Cisco IOS(R) ソフトウェア リリース 12.1(3)T

この文書の情報は、特定のラボ環境にあるデバイスに基づいて作成されています。この文書内で使用されているデバイスはすべて、クリアーな状態(デフォルト)から設定作業を始めています。実稼動中のネットワークで作業をしている場合、実際にコマンドを使用する前に、その潜在的な影響について理解しておく必要があります。

設定

この項では、この文書で説明する機能を設定するために必要な情報を提供します。

注: この文書で使用されているコマンドの詳細を調べるには、Command Lookup ツールを使用してください(登録ユーザのみ)。

ネットワーク ダイアグラム

この文書では次の図に示すネットワーク構成を使用しています。

ce_acl-1.gif

設定

ルータの ACL を使用したキャッシュ エンジンのバイパス方法

  
  
  !--- コマンド行は、次のように記述する必要があります。
  
  router# configure terminal
  router(config)# ip wccp web-cache redirect-list 120
  router(config)# access-list 120 deny ip host 172.18.124.193 any
  router(config)# access-list 120 deny ip host 10.27.3.4 any
  router(config)# access-list 120 permit ip any any
  

確認

この項では、設定が正常に動作しているかどうかを確認する際に役立つ情報を示します。

特定の show コマンドは、Output Interpreter ツール登録ユーザのみ)でサポートされています。このツールを使用すると、show コマンドの出力の分析を見ることができます。

  • show version:ルータで実行されているソフトウェア、さらにその他のコンポーネントについてもシステム動作期間(コードが以前にブートされた地点やコードがコンパイルされた日付など)として表示します。

           33-ns-gateway#show version
           Cisco Internetwork Operating System Software
           IOS (tm) C2600 Software (C2600-I-M), Version 12.1(3)T,  RELEASE SOFTWARE (fc1)
           Copyright (c) 1986-2000 by cisco Systems, Inc.
           Compiled Wed 19-Jul-00 16:02 by ccai
           Image text-base: 0x80008088, data-base: 0x808A9264
            
           ROM: System Bootstrap, Version 11.3(2)XA4, RELEASE SOFTWARE (fc1)
            
           33-Ns-gateway uptime is 1 day, 1 hour, 1 minute
           System returned to ROM by reload
           System restarted at 11:03:21 UTC Thu May 17 2001
           System image file is "flash:c2600-i-mz.121-3.T"
            
           cisco 2610 (MPC860) processor (revision 0x203) with 
    44032K/5120K bytes of memory.
           Processor board ID JAD04330MR6 (3648101504)
           M860 processor: part number 0, mask 49
           Bridging software.
           X.25 software, Version 3.0.0.
           5 Ethernet/IEEE 802.3 interface(s)
           32K bytes of non-volatile configuration memory.
           16384K bytes of processor board System flash (Read/Write)
            
           Configuration register is 0x2102
  • show running-config:ルータで実行されている設定を表示します。

           33-Ns-gateway#show running-config
           Building configuration...
           Current configuration:
           !
           ! Last configuration change at 12:04:57 UTC Fri May 18 2001
           ! NVRAM config last updated at 11:01:10 UTC Fri May 18 2001
           !
           version 12.1
           service timestamps debug datetime msec
           service timestamps log datetime msec
           no service password-encryption
           !
           hostname 33-Ns-gateway
           !
           logging buffered 64000 debugging
           enable secret 5 $1$IWJr$nI.NcIr/b9DN7jEQQC17R/
           !
           !
           !
           !
           !
           ip subnet-zero
           ip wccp web-cache redirect-list 120
           ip cef
           no ip domain-lookup
           ip domain-name cisco.com
           ip name-server 161.44.11.21
           ip name-server 161.44.11.206
           !
           !
           !
           !
           interface Ethernet0/0
            ip address 10.1.3.50 255.255.255.0
            no ip route-cache cef
           !
           interface Ethernet1/0
            description interface to the CE .5
            bandwidth 100
            ip address 10.27.2.1 255.255.255.0
            full-duplex
           !
           interface Ethernet1/1
            description inter to DMZ
            ip address 172.18.124.211 255.255.255.0
            ip wccp web-cache redirect out
            no ip route-cache cef
            no ip route-cache
            no ip mroute-cache
           !
           interface Ethernet1/2
            description Preconfigured for recreates 10.27.3.0/24 net
            ip address 10.27.3.1 255.255.255.0
            no ip route-cache cef
           !
           interface Ethernet1/3
            no ip address
            shutdown
           !
           ip classless
           ip route 0.0.0.0 0.0.0.0 172.18.124.1
           no ip http server
           !
           access-list 120 deny   ip host 172.18.124.193 any log-input
           access-list 120 deny   ip host 10.27.3.4 any log-input
           access-list 120 permit ip any any log
           !
           line con 0
            exec-timeout 0 0
            transport input none
           line aux 0
            exec-timeout 0 0
           line vty 0 4
            exec-timeout 0 0
            password ww
            login
           !
           no scheduler allocate
           end
  • show access-lists:ルータ設定の access-list コマンド文を一覧表示します。またこのコマンドは、access-list コマンド検索においてある要素が一致した回数を示すヒット カウントも一覧表示します。

           2.33-ns-gateway#show access-lists 120
           Extended IP access list 120
           deny ip host 172.18.124.193 any log-input (114 matches)
           deny ip host 10.27.3.4 any log-input (30 matches)
           permit ip any any log
  • show log:ルータのシステム エラー ログを表示します。

           3.33-ns-gateway#show log
           Syslog logging: enabled (0 messages dropped, 0 flushes, 0 overruns)
           Console logging: level debugging, 906 messages logged
           Monitor logging: level debugging, 165 messages logged
           Buffer logging: level debugging, 267 messages logged
           Trap logging: level informational, 114 message lines logged 
           Log Buffer (64000 bytes):
           May 18 09:57:00.837: %CLEAR-5-COUNTERS: 
    Clear counter on all interfaces by vty2 
           (172.18.124.193)
           May 18 10:24:53.218: %SEC-6-IPACCESSLOGP: 
    list 120 denied tcp 172.18.124.193(0) 
           -> 216.4.77.193(0), 1 packet
           May 18 10:28:44.890: %SEC-6-IPACCESSLOGP: 
    list 120 denied tcp 10.27.3.4(0) 
           -> 64.224.45.130(0), 1 packet
           May 18 10:29:08.861: %SEC-6-IPACCESSLOGP: 
    list 120 denied tcp 172.18.124.193(0) 
           -> 212.20.160.80(0), 1 packet
           May 18 10:29:53.563: %SEC-6-IPACCESSLOGP: 
    list 120 denied tcp 172.18.124.193(0) 
           -> 216.4.77.193(0), 19 packets
           May 18 10:33:53.672: %SEC-6-IPACCESSLOGP: 
    list 120 denied tcp 10.27.3.4(0) 
           -> 216.4.77.193(0), 1 packet

トラブルシューティング

現在、この設定に使用可能なトラブルシューティングの情報はありません。

一部ツールについては、ゲスト登録のお客様にはアクセスできない場合がありますことを、ご了承ください。

関連するシスコ サポート コミュニティ ディスカッション

シスコ サポート コミュニティは、どなたでも投稿や回答ができる情報交換スペースです。


関連情報


Document ID: 12561