ブロードバンド ケーブル : データオーバーケーブル サービス インターフェイス仕様(DOCSIS)

DOCSIS および CMTS における max-cpe コマンドの使用

2003 年 8 月 11 日 - ライター翻訳版
その他のバージョン: PDFpdf | 機械翻訳版 (2013 年 8 月 21 日) | 英語版 (2005 年 10 月 4 日) | フィードバック

目次

概要
はじめに
     表記法
     前提条件
     使用するコンポーネント
     背景説明
実装
関連するシスコ サポート コミュニティ ディスカッション
関連情報

概要

この文書では、新しい cable modem max-cpe n コマンドと、Data-over-Cable Service Interface Specifications(DOCSIS)コンフィギュレーション ファイルで指定した MAX-CPE パラメータの違いについて説明します。 DOCSIS コンフィギュレーション ファイルは、ケーブル モデムに読み込まれ、Cisco IOS(R) ソフトウェア リリース 12.1(2)EC1 以降が動作している uBR7200 シリーズでコード化できます。

はじめに

表記法

文書の表記法については、「Cisco テクニカル ティップス:表記法」を参照してください。

前提条件

この文書は、次の項目に関する十分な知識のある読者を対象としています。

  • この文書の情報は、シスコのハードウェアである uBR7246(NPE150)プロセッサ(リビジョン B)と、Cisco IOS ソフトウェア(UBR7200-IST-M)バージョン 12.1(2)EC1 に基づいています。

  • この文書では、ブリッジ モードでのケーブル モデムについて言及しています。

使用するコンポーネント

この文書は、特定のソフトウェアおよびハードウェアのバージョンに制限されません。

この文書の情報は、特定のラボ環境にあるデバイスに基づいて作成されています。 この文書内で使用されているデバイスはすべて、クリアーな状態(デフォルト)から設定作業を始めています。 コマンドを実行する前に、実稼動中のネットワークに与える影響について理解しておいてください。

背景説明

ケーブルのお客様からは、ケーブル モデムのコンフィギュレーション ファイルの値ではホストの数を制限しても、Cable Modem Termination System(CMTS; ケーブル モデム終端システム)に対して、ケーブル モデムに接続できる CPE の数を増やしたいという要望があります。 ケーブルモデムに接続する CPE を増やす変更は、Cisco IOS ソフトウェア リリース 12.0(9.5)SC および Cisco IOS ソフトウェア リリース 12.1(1.0.3)EC1 IOS トレインの CSCdp52029登録ユーザ専用)から組み込まれています。

一部ツールについては、ゲスト登録のお客様にはアクセスできない場合がありますことを、ご了承ください。

この要望の理由としては、ケーブル モデムでは、割り当てられた CPE の数を CMTS カウントで同時に保持できないことがあります。 ケーブル モデムを初期化する場合、唯一 MAX-CPE と CMTS が同期できるのは、登録要求フローでケーブル モデムが MAX-CPE カウントを CMTS へ送信した場合です。

ケーブル モデムがリロードされる場合、割り当てられた CPE のカウントをゼロにすると通知する CMTS へのフローは発生しません。 しかし、ケーブル モデムはゼロから再スタートします。 ケーブル モデムの背後にある新規の CPE から、オンラインになる要求があった場合、ケーブル モデムの MAX-CPE カウントが今はゼロであるため、これを許可します。 ただし、MAX-CPE カウントが 0 以外の CMTS では、要求は失敗し、CMTS に次のメッセージが表示されます。

 
  %UBR7200-5-MAXHOST: New host with IP address x.x.x.x 
   and MAC yyyy.yyyy.yyyy on SID 3 (CM zzzz.zzzz.zzzz) is ignored.

これは、指定しなかった場合、DOCSIS 構成ファイル内のデフォルトの MAX-CPE エントリは 1 に設定されるという事実によってさらに深刻なものとなります。

この例としては、ケーブル モデムから CMTS に、登録要求内の MAX-CPE カウントが 1 であることを通知した場合などです。 ケーブルのお客様からは、ケーブル モデムの電源をオン/オフすることによって、設置作業者のラップトップをケーブル モデムからはずして、エンド ユーザの PC をケーブル モデムの接続に復帰する機能が望まれています。 失敗の原因を次に示します。 リロード後、ケーブル モデムの MAX-CPE カウントは 0 に設定されますが、CMTS にはインストーラのラップトップ エントリ(MAX-CPE カウントが 1)が記憶されているためです。

clear cable host x.x.x.x コマンドを実行することによって、回避策が利用できます。ここで、 x.x.x.x は、CMTS 上でクリアしなければならないホストの IP アドレスまたは MAC アドレスと一致します。 ただし、この回避策は、ケーブル ユーザには不評です。

実装

CMTS に新しい設定コマンドが追加されました。 モデム 1 台当たりの許容最大ホスト数(ケーブル モデムのコンフィギュレーション ファイル内の MAX-CPE 値)を指定するため、ケーブル インターフェイス設定モードで、cable modem max-cpe n コマンドを実行します。 n は 1 〜 255 です。

1 台のケーブル モデムに対して、最大 n 台のホストがイネーブルになります。 制限なしを設定するか、 n が、ケーブル モデムのコンフィギュレーション ファイル内の MAX-CPE 値より大きい場合、このコマンドによりコンフィギュレーション ファイルの値が無効になります。 DHCP サーバにより、1 台のケーブル モデムの背後にあるホストに割り当てられた IP アドレスの数が制御されます。

ケーブル モデムのコンフィギュレーション ファイルで n よりも大きなホスト数が指定された場合、コンフィギュレーション ファイルの設定が優先されます。 アクティブなホストの数の制御は、ケーブル モデムに依存します。

cable modem max-cpe unlimited コマンドを実行することにより、1 台のケーブル モデムに接続する CPE 数が CMTS によって制限されることはなくなります。 無制限に設定することで、CPE の最大数の管理はケーブル モデムに任され、1 台のケーブル モデムの背後にある CPE に割り当てられる IP アドレスの数の管理は DHCP サーバに任されます。

caution 注意:cable modem max-cpe unlimited コマンドを不用意に使用すると、DoS 攻撃を可能にしてシステムのセキュリティ ホールが開放される場合があります。 具体的には、ユーザが大量の IP アドレスを取得できるようになるため、1 人のユーザによって有効な IP アドレスがすべて予約されてしまい、ネットワーク全体が停止することがあります。 このため、cable modem max-cpe unlimited コマンドを有効にする場合、1 台のケーブル モデムの背後にある CPE に割り当てる IP アドレスの数を、DHCP サーバで厳しく管理することを推奨します。

no cable modem max-cpe コマンドを実行すると、デフォルト設定が有効になります。 コンフィギュレーション ファイルにあるMAX-CPE の値は、1 台のケーブル モデムに接続される CPE の数を CMTS によって制限するために使用されます。

show cable modem detail を実行すると、ケーブル モデムに対する DOCSIS コンフィギュレーション ファイル内で設定されている MAX-CPE の値が表示され、可能であれば、cable modem max-cpen 実行時に、この値が設定されます。

次のサンプル ログ出力を参照してください。 CMTS は、 MAX-CPE が 4 の場合、および MAX-CPE が非制限の場合に対して設定されています。

  test-cmts#show cable modem detail 
  Interface ...... SID MAC address .... Max CPE Concatenation Rx SNR
  Cable4/0/U0 1 .... 0001.9659.47bb 1 ............. yes ................ 37.37
  Cable4/0/U0 2 .... 0001.9659.47ab 1 ............. yes ................ 33.70
  Cable4/0/U0 3 .... 0001.9659.47bf .1 ............. yes ................ 30.67
  Cable4/0/U0 4 .... 0001.9659.3ef7 .1 ............. yes ................ 28.84
  Cable4/0/U0 5 .... 0001.9659.47eb 1 ............. yes ................ 30.89
  
  test-cmts#conf t
  Enter configuration commands, one per line. End with CNTL/Z.
  test-cmts(config)#cable modem max-cpe ?
  <1-255> Number
  unlimited Max CPE not enforced
  
  test-cmts(config)#cable modem max-cpe 4
  test-cmts(config)#end
  test-cmts#
  00:05:11: %SYS-5-CONFIG_I: Configured from console by console
  
  
  test-cmts#show cable modem detail
  Interface ...... SID MAC address .... Max CPE Concatenation Rx SNR
  Cable4/0/U0 1 .... 0001.9659.47bb 1 (4) .........yes ................37.00
  Cable4/0/U0 2 .... 0001.9659.47ab 1 (4) ........ yes ................33.54
  Cable4/0/U0 3 .... 0001.9659.47bf .1 (4) ........ yes ................30.70
  Cable4/0/U0 4 .... 0001.9659.3ef7 .1 (4) ........ yes ................ 29.00
  Cable4/0/U0 5 .... 0001.9659.47eb 1 (4) ........ yes ................ 30.92
  
  test-cmts#conf t
  Enter configuration commands, one per line. End with CNTL/Z.
  test-cmts(config)#cable modem max
  test-cmts(config)#cable modem max-cpe ?
  <1-255> Number
  unlimited Max CPE not enforced
  
  test-cmts(config)#cable modem max-cpe unli
  test-cmts(config)#cable modem max-cpe unlimited 
  test-cmts(config)#^Z 
  test-cmts#
  00:06:06: %SYS-5-CONFIG_I: Configured from console by console
  
  
  test-cmts#show cable modem detail
  Interface ...... SID MAC address .... Max CPE Concatenation Rx SNR
  Cable4/0/U0 1 .... 0001.9659.47bb 1 (ul) .........yes ............... 36.64
  Cable4/0/U0 2 .... 0001.9659.47ab 1 (ul) ........ yes ............... 33.26
  Cable4/0/U0 3 .... 0001.9659.47bf. 1 (ul) ....... .yes ............... 30.73
  Cable4/0/U0 4 .... 0001.9659.3ef7 .1 (ul) ...... . yes ............... 29.15
  Cable4/0/U0 5 .... 0001.9659.47eb 1 (ul) ...... . yes ............... 30.95
  
  test-cmts#wr t
  Building configuration...
  
  Current configuration:
  !
  version 12.1
  service timestamps debug uptime
  service timestamps log uptime
  no service password-encryption
  !
  hostname test-cmts
  !
  boot system flash ubr7200-ist-mz.121-2.EC1
  no logging buffered
  !
  cable modem max-cpe 4
  ip subnet-zero 
  !
  interface FastEthernet0/0
  ip address 10.200.68.4 255.255.255.0
  half-duplex
  !
  interface Cable4/0
  ip address 10.200.69.49 255.255.255.240 secondary
  ip address 10.200.69.33 255.255.255.240
  ip accounting precedence input
  ip accounting precedence output
  no keepalive
  cable max-hosts 10
  cable downstream annex B
  cable downstream modulation 64qam
  cable downstream interleave-depth 32
  cable upstream 0 frequency 20000000
  cable upstream 0 power-level 0
  cable upstream 0 rate-limit
  no cable upstream 0 shutdown
  cable upstream 1 shutdown
  cable upstream 2 shutdown
  cable upstream 3 shutdown
  cable upstream 4 shutdown
  cable upstream 5 frequency 20000000
  cable upstream 5 power-level 0
  cable upstream 5 rate-limit
  cable upstream 5 shutdown
  cable dhcp-giaddr policycable
  helper-addrress 10.200.68.11
  ! 
  router rip
  network 10.0.0.0
  !
  ip classless
  ip route 0.0.0.0 0.0.0.0 10.200.68.1
  ip route 10.200.32.0 255.255.224.0 10.200.68.2
  no ip http server
  !
  line con 0
  exec-timeout 0 0
  password ww
  login
  transport input none
  line aux 0
  line vty 0 4
  password ww
  login
  !
  end
  
  test-cmts#

関連するシスコ サポート コミュニティ ディスカッション

シスコ サポート コミュニティは、どなたでも投稿や回答ができる情報交換スペースです。


関連情報


Document ID: 22177