ブロードバンド ケーブル : ケーブル モデム終端システム(CMTS)

シスコ CMTS での DHCP、ToD、TFTP サービスの設定:オールインワン設定

2003 年 2 月 12 日 - ライター翻訳版
その他のバージョン: PDFpdf | 機械翻訳版 (2013 年 8 月 21 日) | 英語版 (2006 年 11 月 8 日) | フィードバック

目次

概要
はじめに
     表記法
     前提条件
     使用するコンポーネント
説明
     CMTS での Cisco IOS(R) ダイナミック ホスト コンフィギュレーション プロトコル(DHCP)サービス
     DHCP サーバのその他の機能
     Cisco IOS Time of Day(ToD)サービス
     Cisco IOS トリビアル ファイル転送プロトコル(TFTP)サービス
     内部 DOCSIS コンフィギュレーション ファイル ジェネレータ
サンプル ダイアグラム
設定
     基本的なオールインワン設定
基本設定の検証に関するヒント
     高度なオールインワン設定
高度な設定の検証に関するヒント
関連するシスコ サポート コミュニティ ディスカッション
関連情報

概要

この文書では、Dynamic Host Configuration Protocol(DHCP; ダイナミック ホスト制御プロトコル)、ToD、および TFTP サーバとして動作するシスコの Cable Modem Termination System(CMTS; ケーブル モデム終端システム)の設定について説明します。 また、CMTS での CLI による DOCSIS コンフィギュレーション ファイルの構築方法についても説明します。 この設定は、「シスコ CMTS のオールインワン設定」と呼ばれます。

はじめに

表記法

文書の表記法の詳細は、「シスコ テクニカル ティップスの表記法」を参照してください。

前提条件

本書の読者は、uBR シリーズ ルータにおける DOCSIS プロトコルと Cisco IOS のコマンドラインの基本事項について、理解している必要があります。

使用するコンポーネント

この文書で使用するハードウェアは、Cisco uBR7200、uBR7100、または uBR10k CMTS と、DOCSIS 準拠のケーブル モデムです。

説明

DOCSIS 準拠のケーブル モデムは、正常にオンラインになるために 3 種類のサーバへの接続を必要とします。

  • 1 つめはケーブル モデムを備えた DHCP サーバであり、このケーブル モデムには IP アドレス、サブネット マスク、および IP に関連するその他のパラメータが与えられています。

  • 2 つめは RFC868 準拠の Time of Day(ToD)サーバで、モデムに現在の時刻を知らせるものです。 ケーブル モデムは、自身のイベント ログに正確なタイムスタンプを正しく付加するために時刻を知る必要があります。

  • 3 つめは Trivial File Transfer Protocol(TFTP; トリビアル ファイル転送プロトコル)サーバで、ケーブル モデム特有の動作パラメータが含まれている DOCSIS コンフィギュレーション ファイルをケーブル モデムにダウンロードするためのものです。

CATV 事業者のほとんどは、Cisco Network Registrar(CNR)を DHCP、DNS、および TFTP サーバとして使用しています。 ToD サーバは CNR には含まれていません。 ToD サーバは、システムのプラットフォームの種類によって使用されるかどうかが決まります。 ToD は、RFC868 に準拠している必要があります。 UNIX システムの場合、ToD は Solaris に含まれており、「/etc」ディレクトリにある「inetd.conf」に次の行が含まれていることを確認するためだけのものです。

# Time service is used for clock synchronization.
   #
   time    stream  tcp     nowait  root    internal
   time    dgram   udp     wait    root    internal

Windows の場合、最も一般的に使用されているソフトウェアは、Greyware leavingcisco.com または Tardis leavingcisco.com です。

次のテーブルでは、CMTS に各サーバ機能が追加された Cisco IOS ソフトウェア リリースのバージョンを示しています。

サーバ機能

Cisco IOS ソフトウェア リリース

DHCP

12.0(1)T

ToD

12.0(4)XI 

TFTP

11.0(全プラットフォーム対応)

  

この文書では、これらの各機能について説明します。 これらの機能すべてを備えた CMTS に対する設定は、「CMTS のオールインワン設定」と呼ばれています。 この設定がされていれば、ケーブル プラントで高速インターネット アクセスを行うためのテストに、他のサーバを必要としません。

また、TFTP サーバではなく CMTS 上にある DOCSIS コンフィギュレーション ファイルを設定できるようになります。 リリース ノートによると、この機能を使用するには、Cisco IOS ソフトウェア リリース 12.1(2)EC1 以上が必要です。

この「オールインワン設定」は、ラボ環境、初期テスト、小規模な配備、およびトラブルシューティングにとっては非常に便利ですが、非常に多数のケーブル モデムのサポートには対応していません。 そのため、多数のケーブル モデムを使用する稼働中のケーブル プラントでは、この設定の使用は推奨しません。

TAC のエンジニアは、ケーブル モデムのトラブルシューティングの際、可変要素を排除するためにこの設定を頻繁に使用しています。

CMTS での Cisco IOS(R) ダイナミック ホスト コンフィギュレーション プロトコル(DHCP)サービス

Cisco IOS ソフトウェア リリースの 12.0(1)T 以降を実行している Cisco ルータには、DHCP サーバとして動作する機能があります。 この DHCP サービスは、ケーブル モデムや PC や ワークステーションなどの Customer Premise Equipment(CPE; 顧客宅内機器)に DHCP リースを提供するために設定されることがあります。

ケーブル モデムがオンラインになるために一般的に必要な DHCP オプションの最小セットがあります。 内容は次のとおりです。

  • IP アドレス(DHCP パケット ヘッダの yiaddr フィールド)

  • サブネット マスク(DHCP オプション 1)

  • GMT からの現地時間のタイム オフセット(秒)(DHCP オプション 2)

  • デフォルト ルータ(DHCP オプション 3)

  • ToD サーバの IP アドレス(DHCP オプション 4)

  • ログ サーバ(DHCP オプション 7)

  • TFTP サーバの IP アドレス(DHCP パケット ヘッダの siaddr フィールド)

  • DOCSIS コンフィギュレーション ファイルの名前(DHCP パケット ヘッダの file フィールド)

  • DHCP リース時間(秒)(DHCP オプション 51)

ルータでは、次のように設定されます。

!
   ip dhcp pool cm-platinum
      network 10.1.4.0 255.255.255.0
      bootfile platinum.cm
      next-server 10.1.4.1 
      default-router 10.1.4.1 
      option 7 ip 10.1.4.1 
      option 4 ip 10.1.4.1 
      option 2 hex 0000.7e90
      lease 7 0 10
   !

各コマンドの説明は次のとおりです。

  • dhcp pool コマンドは、スコープの名前を定義します(cm-platinum は、ケーブル モデムに対するプラチナ サービスを意味します)。

  • network は IP アドレスとサブネット マスクを示します(DHCP オプション 1)。

  • bootfile は、ブート ファイル名を示し、ここでは platinum.cm が指定されています。

  • next-server コマンドでは、TFTP サーバの IP アドレスを指定します(この場合、インターフェイス c4/0 のプライマリ IP アドレスです)。

  • default-router はデフォルト ゲートウェイであり、この場合はインターフェイス c4/0 のプライマリ IP アドレスです(オプション 3)。

  • option 7 はログ サーバの dhcp オプションです。

  • Option 4 は ToD サーバの IP アドレスです(インターフェイス c4/0 のプライマリ IP アドレス)。

  • option 2 は GMT + 9 hr というタイム オフセットを表すオプションです(+9 時間 = +32400 秒 = 16 進数で 0000.7e90)。

  • リース時間(lease)は 7 日と 0 時間 10 分です。

注: タイム オフセットの値を 10 進数から 16 進数に変換する方法の詳細は、「DHCP オプション 2(タイム オフセット)の 16 進数値の計算方法」のテクニカル ティップスを参照してください。

次のオプションが、CPE デバイスが正しく動作するための最小の設定になります。

  • IP アドレス(DHCP パケット ヘッダの yiaddr フィールド)

  • サブネット マスク(DHCP オプション 1)

  • デフォルト ルータ(DHCP オプション 3)

  • 1 台または複数台のドメイン ネーム サーバの IP アドレス(DHCP オプション 6)

  • ドメイン名(DHCP オプション 15)

  • DHCP リース時間(秒)(DHCP オプション 51)

!
   ip dhcp pool pcs-c4 
   
   ! -- ホストのスコープ
   
       network 172.16.29.0 255.255.255.224
   
   ! -- ホストの IP アドレスとマスク
   
       next-server 172.16.29.1
   
   ! -- tftp サーバ、この場合、セカンダリ サーバを入力します。
   
       default-router 172.16.29.1
       dns-server 172.16.30.2
   
   ! -- dns サーバ(この CMTS では設定されません)
   
       domain-name cisco.com
       lease 7 0 10
   !

dhcp pool を設定する場合、cable dhcp-giaddr policy コマンドをケーブル インターフェイスの設定に含めることが重要です。 このコマンドには、DHCP サーバを管理して、ケーブル インターフェイスのプライマリ ネットワーク番号に対応するケーブル モデムと、ケーブル インターフェイスのセカンダリ ネットワーク番号に対応する CPE に、リースを割り当てるという機能があります。 このコマンドが設定されていない場合、すべての DHCP リースは、ケーブル インターフェイスのプライマリ ネットワーク番号に対応するプールが元になります。 また、次に示すインターフェイスの設定の部分を見ると、スコープ cm-platinum はインターフェイス ケーブル 4/0 に定義されているプライマリ アドレスに関連付けられ、スコープ pcs-c4 はセカンダリ アドレスのネットワークにあります。

!
   interface Cable4/0
      ip address 172.16.29.1 255.255.255.224 secondary
   
   ! -- CPE ネットワーク
   
      ip address 10.1.4.1 255.255.255.0
   
   ! -- ケーブル モデム ネットワーク
   
      cable dhcp-giaddr policy
   !

このケーブル インターフェイスには、cable helper-address コマンドまたは ip helper-address コマンド がないことに注意してください。 これは、内部 IOS DHCP サーバが使用されている場合、DHCP 要求は外部サーバへ転送する必要がないためです。 このコマンドがこのインターフェイスの下に追加され、外部 DHCP サーバが設定されている場合、その外部 DHCP の設定にケーブル モデムが登録されます。

DHCP サーバのその他の機能

Cisco IOS DHCP サーバの使用によって使用可能になるその他の機能には、次のものがあります。

  • ip dhcp ping:DHCP サーバが既に使用されている IP アドレスに対するリースを発行しないようにするためのリース機能の前に、ping を実行します。

  • ip dhcp database:外部データベースにある DHCP バインディングのための記憶域。これは CMTS の電源のオン→オフを行っても、MAC アドレスと IP アドレスの関係を維持するために使用します。

  • show ip dhcp:DHCP サーバの動作を監視するために使用する一連のコマンド。

  • debug ip dhcp server: DHCP サーバの動作をトラブルシューティングするために使用する一連のコマンド。

これらの追加機能やフィーチャについては、すべて「Cisco IOS DHCP サーバ」の Cisco IOS DHCP サーバ機能のリリース ノートで説明されています。

Cisco IOS Time of Day(ToD)サービス

ケーブル モデムが問題なく DHCP リースを取得すると、次は ToD サーバとの接続に進みます。 Cisco IOS ソフトウェア リリース 12.0(4)XI 以降を実行しているシスコの CMTS 製品では、RFC868 ToD サービスを提供することができます。

ケーブル モデムがオンラインになる場合に使用する必要のある ToD サービスは、Cisco ルータで一般的に設定されている Network Time Protocol(NTP; ネットワーク タイム プロトコル)サービスと同じであると、一般的に誤解されています。 NTP サービスと ToD サービスには互換性がありません。 ケーブル モデムは NTP サーバとは対話できません。 ケーブル モデムがオンラインになる過程の一部として Time of Day サーバへの接続を試みる必要があるとき、DOCSIS 1.0 RFI 仕様の最新版に準拠しているモデムは、ToD サーバに到達できない場合でもオンラインになります。

この仕様の最新リリースによれば、ケーブル モデムが ToD サーバに接続できない場合でも、オンラインになる処理が継続される場合があります。 ただし、接続が成功するまで、ToD サーバへの接続が試行され続ける場合もあります。 DOCSIS 1.0 RFI 仕様の古いバージョンでは、ケーブル モデムが ToD サーバに接続できない場合は、そのモデムはオンラインにはなれません。 古いファームウェアを実行しているケーブル モデムでは、この古いバージョンの仕様に準拠している場合があることに注意してください。

注: ベンダーのケーブル モデムによっては、Cisco IOS Time of Day サービスとの相互運用ができない場合があります。 これらのモデムが DOCSIS 1.0 RFI 仕様の最新バージョンに準拠していれば、オンラインになる処理を継続できます。 この相互運用性に関する問題は、Cisco Bug ID CSCdt24107 で解決されています。

注: シスコの CMTS で ToD を設定するのに必要なグローバル コマンドは、次の 2 つだけです。

service udp-small-servers max-servers no-limit
   !
   cable time-server
   !

Cisco IOS トリビアル ファイル転送プロトコル(TFTP)サービス

ケーブル モデムの ToD サーバへの接続が試みられた後は、DOCSIS コンフィギュレーション ファイルをダウンロードするために TFTP サーバへの接続に進みます。 バイナリ形式の DOCSIS コンフィギュレーション ファイルがシスコ CMTS のフラッシュ デバイスにコピーできる場合は、ルータはそのファイルに対する TFTP サーバとして動作できます。

DOCSIS コンフィギュレーション ファイルをフラッシュにダウンロードする手順は次のとおりです。

初めに、DOCSIS コンフィギュレーション ファイルがあるサーバに CMTS が到達できるようにします。

   7246VXR#ping 172.16.30.2
   
   Type escape sequence to abort.
   Sending 5, 100-byte ICMP Echos to 172.16.30.2, timeout is 2 seconds:
   !!!!!
   
   Success rate is 100 percent (5/5), round-trip min/avg/max = 1/1/4 ms
   
   

次に、ファイルをコピーします。ここでは、silver.cm というファイルを CMTS のフラッシュにコピーします。

   7246VXR#copy tftp flash
   Address or name of remote host []? 172.16.30.2
   Source filename []? silver.cm
   Destination filename [silver.cm]? 
   
   Accessing tftp://172.16.30.2/silver.cm...
   Loading silver.cm from 172.16.30.2 (via Ethernet2/0): !
   [OK - 76/4096 bytes]
   
   76 bytes copied in 0.152 secs

最後に、必ずフラッシュの内容をチェックし、ファイルのサイズが正しいことを確認するようにします。 これを行うには、show flash を実行します。

   7246VXR#show flash
   -#- ED --type-- --crc--- -seek-- nlen -length- -----date/time------ name
   1   .. unknown  2D6C7818   200CC    9       74 Feb 28 2001 7:39:09 silver.cm
   2   .. unknown  1CB785DC   20258    7       62 Feb 20 2001 15:44:11 test.cm
   3   .. image    4350A04F  7A0CC8   24  7866864 Feb 27 2001 09:36:40 ubr7200-ik1s-mz.121-4.EC
   4   .. unknown  36E5D6D3  7A0D94    7       76 Feb 28 2001 07:23:12 gold.cm
   
   8516204 bytes available (7867796 bytes used)

CMTS で TFTP サービスを有効にするには、グローバル設定モードに次のコマンドを追加するだけです。

tftp-server slot0:silver.cm alias silver.cm

このコマンドを実行すると、その後、設定に次のように表示されます。

!
   tftp-server slot0:silver.cm alias silver.cm
   tftp-server server  
   !

ルータでの tftp サーバの設定に関する詳細は、「その他のファイル転送コマンド」を参照してください。

内部 DOCSIS コンフィギュレーション ファイル ジェネレータ

Cisco IOS ソフトウェア リリース 12.1(2)EC 以降(EC リリース群)を実行しているシスコ CMTS 製品は、DOCSIS コンフィギュレーション ファイルを作成し、内部に保存するよう設定できます。 この機能を使用すると、外部の DOCSIS コンフィギュレーション ファイル作成ツールにアクセスする必要がなくなるので便利です。 内部の設定ツールを使用して DOCSIS コンフィギュレーション ファイルを作成する場合、そのファイルは TFTP を経由して自動的に有効になります。 さらに、直接接続されたケーブル インターフェイス上のケーブル モデムからだけは、このコンフィギュレーション ファイルをダウンロードできます。

次の設定例では、DOCSIS コンフィギュレーション ファイルを 2 つ作成しています。

1 つめは disable.cm という名前で、ケーブル モデムがオンラインになることを許可するものの、接続されている CPE デバイスがサービス プロバイダのネットワークへアクセスしないようにするものです。 この例では、「access-denied」というコマンドが使用されています。 この例では、ダウンストリーム側とアップストリーム側のスピードは共に 1Kbps で、最大バースト サイズは 1600 バイトであることに注意してください。

cable config-file disable.cm
    access-denied
    service-class 1 max-upstream 1
    service-class 1 max-downstream 1600
    timestamp
   !

CATV 事業者がこの「disable.cm」DOCSIS コンフィギュレーション ファイルを使用する理由は、ケーブル モデムがオンラインになる途中でケーブル モデムの背後にある CPE へのアクセスを拒否するためです。 この方法は、CNR で「exclude」オプションを使用する CPE サービスを拒否するより効果的な方法です。このオプションが指定されていると、ケーブル モデムがオンラインになることができないため、ケーブル モデムが繰り返しオンラインになろうとして帯域幅を消費してしまいます。

この DOCSIS コンフィギュレーション ファイルを取得するケーブル モデムは、show cable modem コマンドを実行すると、次のように表示されます。

Cable4/0/U0 10   online(d)  2287    0.50  6   0   10.1.4.65       0010.7bed.9b45

「online(d)」というステータスは、ケーブル モデムがオンラインであるが、アクセスは拒否されていることを示しています。

2 つめの例では、「platinum.cm」という名前の DOCSIS コンフィギュレーション ファイル名が作成されています。 この場合、アップストリームの最大速度が 1Mbps であり、保証されているアップストリームは 100Kpbs になっています。また、ダウンストリームの最大速度は 10Mbps で、最大で 30 の CPE デバイスを接続できます。

cable config-file platinum.cm
    service-class 1 max-upstream 1000
    service-class 1 guaranteed-upstream 100
    service-class 1 max-downstream 10000
    service-class 1 max-burst 1600
    cpe max 30
    timestamp
   !

CMTS で DOCSIS コンフィギュレーション ファイルを設定する際には、「tftp server slot0:platinum.cm alias platinum.cm」という文は必要ありません。これは、メモリ上に「.cm」ファイルが保存されておらず、設定の中にあるためです。 内部 DOCSIS コンフィギュレーション ファイルのツールに関する詳細は、「ケーブル モデム終端システムのコマンド」に記載されています。

サンプル ダイアグラム

次の図では、一般的なラボで設定されるトポロジを示しています。

all_in_one_config1.gif

>>画像拡大

設定

この設定は、シスコの CMTS プラットフォームすべてでサポートされています。 これには、uBR7200、uBR7246 VXR、uBR7100、および uBR10000 が含まれます。

DOCSIS コンフィギュレーション ファイルの設定など、オールインワン設定をサポートしている Cisco IOS ソフトウェア リリースは、Cisco IOS ソフトウェア リリース 12.1(2)EC とそれ以降の EC 群のリリースです。

以下の設定は、uBR7246 VXR で行ったものであり、Cisco IOS ソフトウェア リリース 12.1(4)EC を使用し、NPE300 を搭載しています。 初めに基本的な設定について説明し、その後でより高度な設定について説明します。

基本的なオールインワン設定

以下に示す設定は、この文書で説明したすべての項目について要約したものです。 この設定には 2 つの dhcp スコープがあります。1 つはケーブル モデム用、もう 1 つはケーブル モデムの背後にあるホスト用のものです。

platinum.cm という名前の DOCSIS コンフィギュレーション ファイルが 1 つ作成されます。このファイルは、cm-platinum という DHCP プールに適用されます。 もう 1 つの DOCSIS コンフィギュレーション ファイルである disabled.cm の適用先は、この場合はありません。

この例では、DHCP プールが 2 つ設定されます。1 つはケーブル モデム用で、もう 1 つはケーブル モデムの背後にある PC 用です。

注: オールインワン設定コマンドは、太字で表されています。

7246VXR での基本的な「オールインワン設定」

7246VXR#show run
   
   version 12.1
   no service pad
   service timestamps debug datetime msec localtime
   
   ! -- すべてのログ メッセージに対して、適切なタイムスタンプを設定
   
   service timestamps log datetime localtime
   no service password-encryption
   service linenumber
   service udp-small-servers max-servers no-limit
   
   ! -- 多数のモデムおよびホストが即座に接続できるようサポート
   
   !
   hostname 7246VXR
   !
   logging buffered 1000000 debugging
   enable password cable
   !
   cable qos profile 8
   cable qos profile 10
   cable qos profile 10 grant-size 1500
   cable qos profile 12 guaranteed-upstream 100000
   no cable qos permission create
   no cable qos permission update
   cable qos permission modems
   cable time-server
   
   ! -- ケーブル モデムが uBR7246VXR から Time of Day(ToD)を取得することを許可
   
   !
   cable config-file disable.cm
    access-denied
    service-class 1 max-upstream 1
    service-class 1 max-downstream 1600
    cpe max 1
    timestamp
   !
   cable config-file platinum.cm
    service-class 1 max-upstream 128
    service-class 1 guaranteed-upstream 10
    service-class 1 max-downstream 10000
    service-class 1 max-burst 1600
    cpe max 10
    timestamp
   !
   clock timezone JST +9
   clock calendar-valid
   ip subnet-zero
   ip cef
   
   ! -- cef スイッチングおよびルーティングなど、プロセス交換以外のすべてをオンにする(no ip route-cache)
   
   ip cef accounting per-prefix 
   no ip finger
   ip tcp synwait-time 5
   no ip domain-lookup
   
   ! -- コマンドの入力ミスの際に、cmts がドメイン名を検索したり、 
   ! -- マシンへの接続を試みたりしないようにする
   
   ip host vxr 172.16.26.103
   ip domain-name cisco.com
   ip name-server 171.68.10.70
   ip name-server 171.69.2.132
   ip name-server 171.68.200.250
   no ip dhcp relay information check
   !
   !
   !  
   ip dhcp pool cm-platinum
   
   ! -- dhcp プールの名前 このスコープは、インターフェイス ケーブル 4/0 に接続されている
   ! -- ケーブルモデム用です。
   
      network 10.1.4.0 255.255.255.0
   
   ! -- スコープ modems-c4/0 用のアドレス プール
   
      bootfile platinum.cm
   
   ! -- このプールに関連付けられている DOCSIS コンフィギュレーション ファイル名
   
      next-server 10.1.4.1
   
   ! -- ブートファイルを送信する TFTP サーバの IP アドレス
   
      default-router 10.1.4.1
   
   ! -- ケーブル モデムのデフォルト ゲートウェイ。DOCSIS ファイルの取得に必要。
   
      option 7 ip 10.1.4.1
   
   ! -- ログ サーバの DHCP オプション
   
      option 4 ip 10.1.4.1
   
   ! -- ToD サーバの IP アドレス
   
      option 2 hex 0000.7e90
   
   ! -- ToD のためのタイム オフセット。GMT からの時差を 16 進数による秒数で表現。+32,400 = JST = 0000.7e90。
   
      lease 7 0 10
   
   ! -- リース時間は 7 日と 0 時間 10 分
   ip dhcp pool pcs-c4
   
   ! -- dhcp プールの名前 このスコープは、インターフェイス ケーブル 4/0 に接続されている
   ! -- ケーブル モデムに取り付ける CPE 用です。
   
      network 172.16.29.0 255.255.255.224
   
   ! -- スコープ pcs-c4 用のアドレス プール(セカンダリ アドレスに関連)
   
      next-server 172.16.29.1 
      default-router 172.16.29.1
      dns-server 172.16.30.2 
      domain-name cisco.com 
      lease 7 0 10      
   !
   !
   interface Ethernet2/0
    ip address 172.16.30.4 255.255.255.192
    no ip mroute-cache
    half-duplex
   !
   interface Cable4/0
    ip address 172.16.29.1 255.255.255.224 secondary
   
   ! -- PC がこのネットワーク上で IP アドレスを取得するために、スコープ pcs-c4 用に使用。
   
    ip address 10.1.4.1 255.255.255.0
   
   ! -- ケーブル モデムがこのネットワーク上で IP アドレスを取得するために、スコープ modems-c4/0 用に使用。
   
    no ip route-cache cef
    no keepalive
    cable downstream rate-limit token-bucket shaping
    cable downstream annex B
    cable downstream modulation 64qam
    cable downstream interleave-depth 32
    cable downstream frequency 555000000
    cable upstream 0 frequency 40000000
    cable upstream 0 power-level 0
    no cable upstream 0 shutdown
    cable upstream 1 shutdown
    cable upstream 2 shutdown
    cable upstream 3 shutdown
    cable upstream 4 shutdown
    cable upstream 5 shutdown
    cable dhcp-giaddr policy
   
   ! -- リレー IP アドレスを持つ DHCPDISCOVER および DHCPREQUEST パケットが DHCP サーバへ
   ! -- 転送される前に、その GIADDR フィールドを変更するために使用。
   
   !         
   !         
   router eigrp 202
    redistribute connected
    redistribute static
    network 10.0.0.0
    network 172.16.0.0
    no auto-summary
    no eigrp log-neighbor-changes
   !         
   router rip
    version 2
    redistribute connected
    redistribute static
    network 10.0.0.0
    network 172.16.0.0
    no auto-summary
   !         
   ip default-gateway 172.16.30.1
   ip classless
   ip route 0.0.0.0 0.0.0.0 172.16.30.1
   ip route 172.16.30.0 255.255.255.0 Ethernet2/0
   ip http server
   ip http authentication local
   !         
   snmp-server engineID local 00000009020000E01ED77E40
   snmp-server community public RO
   snmp-server community private RW
   tftp-server server
   
   ! -- cmts が tftp サーバとして動作できるようにイネーブルにする
   
   tftp-server slot0:silver.cm alias silver.cm
   
   ! -- フラッシュに事前にダウンロードされている DOCSIS コンフィギュレーション ファイル silver.cm を取得。
   ! -- この DOCSIS コンフィギュレーション ファイルは、DOCSIS CPE Configurator を使用して構築されています。
   
   !         
   line con 0
    exec-timeout 0 0
    transport input none
   line aux 0
    speed 19200
   line vty 0 4
    session-timeout 60 
    login
   !
   ntp clock-period 17179977
   ntp server 172.16.135.51
   end

  

基本設定の検証に関するヒント

初めに、コマンドが Cisco IOS ソフトウェア リリースでサポートされていることを確認する必要があります。 これを確認するには、show version を実行します。

   7246VXR#show version
   Cisco Internetwork Operating System Software 
   IOS (tm) 7200 Software (UBR7200-IK1S-M), Version 12.1(4)EC, EARLY DEPLOYMENT RELEASE SOFTWARE (fc1)
   Copyright (c) 1986-2000 by cisco Systems, Inc.
   Compiled Fri 08-Dec-00 17:35 by ninahung
   Image text-base: 0x60008950, data-base: 0x612AA000
   
   ROM: System Bootstrap, Version 12.0(19990210:195103) [12.0XE 105], DEVELOPMENT SOFTWARE
   BOOTFLASH: 7200 Software (UBR7200-BOOT-M), Version 12.0(7)T,  RELEASE SOFTWARE (fc2)
   
   7246VXR uptime is 9 minutes
   System returned to ROM by reload at 09:47:00 JST Tue Feb 27 2001
   System restarted at 09:48:26 JST Tue Feb 27 2001
   System image file is "slot0:ubr7200-ik1s-mz.121-4.EC"
   
   cisco uBR7246VXR (NPE300) processor (revision C) with 253952K/40960K bytes of memory.
   Processor board ID SAB03500058
   R7000 CPU at 262Mhz, Implementation 39, Rev 1.0, 256KB L2, 2048KB L3 Cache
   6 slot VXR midplane, Version 2.0
   
   Last reset from power-on
   Bridging software.
   X.25 software, Version 3.0.0.
   4 Ethernet/IEEE 802.3 interface(s)
   1 FastEthernet/IEEE 802.3 interface(s)
   5 Cable Modem network interface(s)
   125K bytes of non-volatile configuration memory.
   
   16384K bytes of Flash PCMCIA card at slot 0 (Sector size 128K).
   4096K bytes of Flash internal SIMM (Sector size 256K).
   Configuration register is 0x2102

DOCSIS コンフィギュレーション ファイルがフラッシュにあることを確認する必要があります。

   7246VXR#show flash
   -#- ED --type-- --crc--- -seek-- nlen -length- -----date/time------ name
   1   .. unknown  2D6C7818   200CC    9       74 Feb 28 2001 7:39:09 silver.cm
   2   .. unknown  1CB785DC   20258    7       62 Feb 20 2001 15:44:11 test.cm
   3   .. image    4350A04F  7A0CC8   24  7866864 Feb 27 2001 09:36:40 ubr7200-ik1s-mz.121-4.EC
   4   .. unknown  36E5D6D3  7A0D94    7       76 Feb 28 2001 07:23:12 gold.cm
   
   8516204 bytes available (7867796 bytes used)

ファイル「silver.cm」は、DOCSIS CPE Configurator ツールを使用して作成されました。 CMTS 設定で作成された platunum.cm ファイルの場合には、「tftp server slot0:platinum.cm alias platinum.cm」という文は必要ありません。これは、「Cm」ファイルがなく、設定の中にあるためです。

次のステップは、ケーブル モデムがオンラインであることを確認します。 これを行うには、show cable modem コマンドを使用します。

   7246VXR#show cable modem
   Interface   Prim Online     Timing Rec    QoS CPE IP address      MAC address
               Sid  State      Offset Power
   Cable4/0/U0 75   online     2290    0.00  5   1   10.1.4.2        0010.7bed.9b23
   Cable4/0/U0 76   online     2809    0.00  5   0   10.1.4.3        0002.fdfa.0a63
   Cable4/0/U0 77   online     2288    0.25  5   1   10.1.4.5        0010.7bed.9b45
   Cable4/0/U0 78   online     2810    0.50  5   0   10.1.4.4        0004.2752.ddd5
   Cable4/0/U0 79   online     2813    0.25  5   0   10.1.4.6        0002.1685.b5db
   Cable4/0/U0 80   online     2812   -0.50  5   0   10.1.4.7        0001.64ff.e47d
   
   
   

すべてのケーブル モデムがオンラインであることに注意してください。 インターフェイス ケーブル 4/0/U0 に接続されているものは、ネットワーク 10.1.4.0 にあります。 これらの IP アドレスは、「cm-platinum」という dhcp プールから取得されることが設定から分かります。

また、各々 Mac アドレス 0010.7bed.9b23、および 0010.7bed.9b45 を持つケーブル モデムが、背後に CPE を持っていることに注意してください。 これらのケーブル モデムはデフォルトのブリッジング設定によってオンラインになります。 これらの PC は DHCP で設定されているため、IP アドレスはネットワークから取得できます。

   7246VXR#show interface cable 4/0 modem 0
   SID   Priv bits  Type      State     IP address    method    MAC address
   75    00         host      unknown   172.16.29.2   static    00c0.4f97.61c5
   75    00         modem     up        10.1.4.2      dhcp      0010.7bed.9b23
   76    00         modem     up        10.1.4.3      dhcp      0002.fdfa.0a63
   77    00         host      unknown   172.16.29.3   dhcp      00a0.243c.eff5
   77    00         modem     up        10.1.4.5      dhcp      0010.7bed.9b45
   78    00         modem     up        10.1.4.4      dhcp      0004.2752.ddd5
   79    00         modem     up        10.1.4.6      dhcp      0002.1685.b5db
   80    00         modem     up        10.1.4.7      dhcp      0001.64ff.e47d

次の図では、これらの PC が IP アドレスを「pcs-c4」というプールから取得していることを示しています。

all_in_one_config2.gif

また、この PC では、IP アドレスを自動的に取得するように TCP/IP 設定が行われていることが分かります。

all_in_one_config3.gif

高度なオールインワン設定

このセクションでは、dhcp プールに階層機能を組み込んだ、より高度な設定例について説明します。 DHCP プールの階層が動作する方法は、ある DHCP プールが他の DHCP プールのネットワーク番号のサブセットになっているネットワーク番号を持ち、他のプールの特性をすべて継承するというものです。 これにより、DHCP サーバ設定の繰り返しを減らすことができます。 ただし、異なるパラメータを持つ同じ項目が設定されている場合は、そのパラメータは上書きされます。 この例では、platinum.cm というブートファイルがある一般用プールについて説明します。このプールのサブセットに disable.cm というブートファイルが作成されます。

基本例で作成した DHCP プールの他に、この例では 2 台のケーブル モデムに対する要件があります。

ケーブル モデム 0010.7bed.9b45 はアクセスを拒否されます。 このことは、このケーブル モデムは IP アドレスを付与されるものの、オンラインにはならないことを意味します。 このため、次のようなプールを作成します。

ip dhcp pool cm-0010.7bed.9b45
      host 10.1.4.65 255.255.255.0
      client-identifier 0100.107b.ed9b.45
      bootfile disable.cm

この設定例で最も注目に値する機能は、個々のケーブル モデムの MAC アドレスに対応する特別な DHCP プールを指定する箇所です。 このため、これらのモデムに対して DHCP サーバから一意の DHCP オプションを送信できます。 特定のケーブル モデムを指定するには、「client-identifier」パラメータが使用されます。 "client-identifier" には、エントリに対応するデバイスの MAC アドレスの先頭に 01 を付加して設定します。 01 は、DHCP に対するイーサネットのハードウェア タイプに相当します。

注: モデムのコンフィギュレーション ファイルを変更する場合は、次の作業を行って、ケーブル モデムが手動で設定したパラメータを取得するようにします。

  • clear ip dhcp binding <ip address> コマンドを使用して、ip dhcp バインディング テーブルをクリアします。

  • clear cable modem <mac address > res コマンドを使用して、問題のケーブル モデムをリセットします。

ケーブル モデム 0010.7bed.9b23 にも特別な要件があります。 このモデムは、異なる QOS を取得します。 したがって、このスコープには別のブートファイルが関連付けられます。 次に示す設定の一部を参照してください。

ip dhcp pool cm-0010.7bed.9b23
      host 10.1.4.66 255.255.255.0
      client-identifier 0100.107b.ed9b.23
      bootfile silver.cm
   
   !

特定のケーブル モデムに対して DHCP プールを設定する場合には、常に関連のある名前を付けることをお勧めします。 また、host コマンドを使用して特定の IP アドレスをプールに割り当てるため、グローバル コマンドの ip dhcp exclude 10.1.4.60 10.1.4.70 を追加する必要があります。 このコマンドは、DHCP からこの範囲に属するアドレスが分配されないようにします。

7246VXR での高度な「オールインワン設定」

7246VXR# show run
   
   version 12.1
   no service pad
   service timestamps debug datetime msec localtime
   service timestamps log datetime localtime
   no service password-encryption
   service linenumber
   service udp-small-servers max-servers no-limit
   !
   hostname 7246VXR
   !
   logging buffered 1000000 debugging
   !
   cable qos profile 8
   cable qos profile 10
   cable qos profile 10 grant-size 1500
   cable qos profile 12 guaranteed-upstream 100000
   no cable qos permission create
   no cable qos permission update
   cable qos permission modems
   cable time-server
   !
   cable config-file disable.cm
    access-denied
    service-class 1 max-upstream 1
    service-class 1 max-downstream 1600
    cpe max 1
    timestamp
   !
   cable config-file platinum.cm
    service-class 1 max-upstream 128
    service-class 1 guaranteed-upstream 10
    service-class 1 max-downstream 10000
    service-class 1 max-burst 1600
    cpe max 10
    timestamp
   !
   clock timezone JST -8
   clock calendar-valid
   ip subnet-zero
   no ip finger
   no ip domain-lookup
   ip host vxr 172.16.26.103
   ip domain-name cisco.com
   ip name-server 171.68.10.70
   ip name-server 171.69.2.132
   ip name-server 171.68.200.250
   ip dhcp excluded-address 10.1.4.60 10.1.4.70
   !
   ip dhcp pool cm-platinum
      network 10.1.4.0 255.255.255.0
      bootfile platinum.cm
      next-server 10.1.4.1 
      default-router 10.1.4.1 
      option 7 ip 10.1.4.1 
      option 4 ip 10.1.4.1 
      option 2 hex 0000.7e90
      lease 7 0 10
   !
   ip dhcp pool pcs-c4
      network 172.16.29.0 255.255.255.224
      next-server 172.16.29.1 
      default-router 172.16.29.1 
      dns-server 172.16.30.2 
      domain-name cisco.com
      lease 7 0 10
   !
   ip dhcp pool cm-0010.7bed.9b45
      host 10.1.4.65 255.255.255.0
      client-identifier 0100.107b.ed9b.45
      bootfile disable.cm
   !
   ip dhcp pool cm-0010.7bed.9b23
      host 10.1.4.66 255.255.255.0
      client-identifier 0100.107b.ed9b.23
      bootfile silver.cm
   !
   !
   interface Ethernet2/0
    ip address 172.16.30.4 255.255.255.192
    no ip mroute-cache
    half-duplex
   !
   interface Cable4/0
    ip address 172.16.29.1 255.255.255.224 secondary
    ip address 10.1.4.1 255.255.255.0
    no keepalive
    cable downstream rate-limit token-bucket shaping
    cable downstream annex B
    cable downstream modulation 64qam
    cable downstream interleave-depth 32
    cable downstream frequency 555000000
    cable upstream 0 frequency 40000000
    cable upstream 0 power-level 0
    no cable upstream 0 shutdown
    cable upstream 1 shutdown
    cable upstream 2 shutdown
    cable upstream 3 shutdown
    cable upstream 4 shutdown
    cable upstream 5 shutdown
    cable dhcp-giaddr policy
   !
   router eigrp 202
    redistribute connected
    redistribute static
    network 10.0.0.0
    network 172.16.0.0
    no auto-summary
    no eigrp log-neighbor-changes
   !
   router rip
    version 2
    redistribute connected
    redistribute static
    network 10.0.0.0
    network 172.16.0.0
    no auto-summary
   !
   ip default-gateway 172.16.30.1
   ip classless
   ip route 0.0.0.0 0.0.0.0 172.16.30.1
   ip route 172.16.30.0 255.255.255.0 Ethernet2/0
   ip http server
   ip http authentication local
   !
   access-list 188 permit tcp any any eq www log
   access-list 188 permit ip any any
   route-map docsis permit 10
   !
   snmp-server engineID local 00000009020000E01ED77E40
   snmp-server community public RO
   snmp-server community private RW
   tftp-server slot0:silver.cm alias silver.cm
   tftp-server server
   
   line con 0
    exec-timeout 0 0
    transport input none
   line aux 0
    speed 19200
   line vty 0 4
    session-timeout 60 
    exec-timeout 0 0
    login
   !
   ntp clock-period 17179973
   end

  

高度な設定の検証に関するヒント

この設定の検証は、ケーブル モデム、特に 0010.7bed.9b45 と 0010.7bed.9b23 が取得するサービスに重点を置きます。 これらのモデムが、手動で設定されたアドレスとサービスを取得していることを確認する必要があります。

最初のテストは、0010.7bed.9b45 がオンラインになっているが、サービスが拒否されていることの確認です。 これを行うには、show cable modem コマンドの結果を参照します。

   7246VXR#show cable modem
   Interface   Prim Online     Timing Rec    QoS CPE IP address      MAC address
               Sid  State      Offset Power
   Cable4/0/U0 7    online     2813    0.00  7   0   10.1.4.7        0002.1685.b5db
   Cable4/0/U0 8    online     2809    0.25  7   0   10.1.4.10       0002.fdfa.0a63
   Cable4/0/U0 9    online     2288   -0.25  5   1   10.1.4.66       0010.7bed.9b23
   Cable4/0/U0 10   online(d)  2287    0.50  6   0   10.1.4.65       0010.7bed.9b45
   Cable4/0/U0 11   online     2809   -0.50  7   0   10.1.4.6        0001.64ff.e47d
   Cable4/0/U0 12   online     2812   -0.50  7   0   10.1.4.9        0004.2752.ddd5
   
   

ここでは、次の点に注意します。

  • ケーブル モデム 0010.7bed.9b23 が、スコープ cm-0010.7bed.9b23 で指定された IP アドレス 10.1.4.66 を取得しています。 このモデムに接続されたコンピュータがあり、このコンピュータは自身の IP アドレスをプール pcs-c4 から取得しています。

  • ケーブル モデム 0010.7bed.9b23 は、異なる QoS を取得しています。

  • ケーブル モデム 0010.7bed.9b45 が、スコープ cm-0010.7bed.9b45 で指定された IP アドレス 10.1.4.65 を取得しています。 このモデムに接続されたコンピュータがありますが、その CPE 値は 0 です。この理由は、サービスが拒否されているためです。

  • 0010.7bed.9b45 のオンライン状態は online(d) であり、これはこのケーブル モデムがオンラインになっているものの、そのケーブル ネットワークへのアクセスが拒否されていることを示しています。 ケーブル モデムからの debug cable mac log verbose の出力を見てください。

21:52:16:  78736.550 CMAC_LOG_RESET_RANGING_ABORTED              
   21:52:16:  78736.554 CMAC_LOG_STATE_CHANGE                       reset_interface_state
   21:52:16:  78736.558 CMAC_LOG_STATE_CHANGE                       reset_hardware_state
   21:52:17:  78737.024 CMAC_LOG_STATE_CHANGE                       wait_for_link_up_state
   21:52:17:  78737.028 CMAC_LOG_DRIVER_INIT_IDB_RESET              0x082B9CA8
   21:52:17:  78737.032 CMAC_LOG_LINK_DOWN                          
   21:52:17:  78737.034 CMAC_LOG_LINK_UP                            
   21:52:17:  78737.040 CMAC_LOG_STATE_CHANGE                       ds_channel_scanning_state
   21:52:17: %LINEPROTO-5-UPDOWN: Line protocol on Interface cable-modem0, changed state to down
   21:52:18:  78738.386 CMAC_LOG_UCD_MSG_RCVD                       1
   21:52:19:  78739.698 CMAC_LOG_DS_64QAM_LOCK_ACQUIRED             747000000
   21:52:19:  78739.702 CMAC_LOG_DS_CHANNEL_SCAN_COMPLETED          
   21:52:19:  78739.704 CMAC_LOG_STATE_CHANGE                       wait_ucd_state
   21:52:20:  78740.368 CMAC_LOG_UCD_MSG_RCVD                       1
   21:52:22:  78742.396 CMAC_LOG_UCD_MSG_RCVD                       1
   21:52:22:  78742.398 CMAC_LOG_ALL_UCDS_FOUND                     
   21:52:22:  78742.402 CMAC_LOG_STATE_CHANGE                       wait_map_state
   21:52:22:  78742.406 CMAC_LOG_FOUND_US_CHANNEL                   1
   21:52:24:  78744.412 CMAC_LOG_UCD_MSG_RCVD                       1
   21:52:24:  78744.416 CMAC_LOG_UCD_NEW_US_FREQUENCY               39984000
   21:52:24:  78744.420 CMAC_LOG_SLOT_SIZE_CHANGED                  8
   21:52:24:  78744.500 CMAC_LOG_UCD_UPDATED                        
   21:52:24:  78744.560 CMAC_LOG_MAP_MSG_RCVD                       
   21:52:24:  78744.564 CMAC_LOG_INITIAL_RANGING_MINISLOTS          41
   21:52:24:  78744.566 CMAC_LOG_STATE_CHANGE                       ranging_1_state
   21:52:24:  78744.570 CMAC_LOG_RANGING_OFFSET_SET_TO              9610
   21:52:24:  78744.574 CMAC_LOG_POWER_LEVEL_IS                     55.0  dBmV (commanded)
   21:52:24:  78744.578 CMAC_LOG_STARTING_RANGING                   
   21:52:24:  78744.580 CMAC_LOG_RANGING_BACKOFF_SET                0
   21:52:24:  78744.586 CMAC_LOG_RNG_REQ_QUEUED                     0
   21:52:24:  78744.622 CMAC_LOG_RNG_REQ_TRANSMITTED                
   21:52:24:  78744.626 CMAC_LOG_RNG_RSP_MSG_RCVD                   
   21:52:24:  78744.628 CMAC_LOG_RNG_RSP_SID_ASSIGNED               10
   21:52:24:  78744.632 CMAC_LOG_ADJUST_RANGING_OFFSET              2286
   21:52:24:  78744.636 CMAC_LOG_RANGING_OFFSET_SET_TO              11896
   21:52:24:  78744.638 CMAC_LOG_STATE_CHANGE                       ranging_2_state
   21:52:24:  78744.644 CMAC_LOG_RNG_REQ_QUEUED                     10
   21:52:25:  78745.654 CMAC_LOG_RNG_REQ_TRANSMITTED                
   21:52:25:  78745.658 CMAC_LOG_RNG_RSP_MSG_RCVD                   
   21:52:25:  78745.660 CMAC_LOG_RANGING_SUCCESS                    
   21:52:25:  78745.680 CMAC_LOG_STATE_CHANGE                       dhcp_state
   21:52:25:  78745.820 CMAC_LOG_DHCP_ASSIGNED_IP_ADDRESS           10.1.4.65
   21:52:25:  78745.824 CMAC_LOG_DHCP_TFTP_SERVER_ADDRESS           10.1.4.1
   21:52:25:  78745.826 CMAC_LOG_DHCP_TOD_SERVER_ADDRESS            10.1.4.1
   21:52:25:  78745.830 CMAC_LOG_DHCP_SET_GATEWAY_ADDRESS           
   21:52:25:  78745.834 CMAC_LOG_DHCP_TZ_OFFSET                     -28800
   21:52:25:  78745.836 CMAC_LOG_DHCP_CONFIG_FILE_NAME              disable.cm
   21:52:25:  78745.840 CMAC_LOG_DHCP_ERROR_ACQUIRING_SEC_SVR_ADDR  
   21:52:25:  78745.846 CMAC_LOG_DHCP_COMPLETE                      
   21:52:25:  78745.968 CMAC_LOG_STATE_CHANGE                       establish_tod_state
   21:52:25:  78745.978 CMAC_LOG_TOD_REQUEST_SENT                   
   21:52:26:  78746.010 CMAC_LOG_TOD_REPLY_RECEIVED                 3192525217
   21:52:26:  78746.018 CMAC_LOG_TOD_COMPLETE                       
   21:52:26:  78746.020 CMAC_LOG_STATE_CHANGE                       security_association_state
   21:52:26:  78746.024 CMAC_LOG_SECURITY_BYPASSED                  
   21:52:26:  78746.028 CMAC_LOG_STATE_CHANGE                       configuration_file_state
   21:52:26:  78746.030 CMAC_LOG_LOADING_CONFIG_FILE                disable.cm
   21:52:26: %LINEPROTO-5-UPDOWN: Line protocol on Interface cable-modem0, changed state to up
   21:52:27:  78747.064 CMAC_LOG_CONFIG_FILE_PROCESS_COMPLETE       
   21:52:27:  78747.066 CMAC_LOG_STATE_CHANGE                       registration_state
   21:52:27:  78747.070 CMAC_LOG_REG_REQ_MSG_QUEUED                 
   21:52:27:  78747.076 CMAC_LOG_REG_REQ_TRANSMITTED                
   21:52:27:  78747.080 CMAC_LOG_REG_RSP_MSG_RCVD                   
   21:52:27:  78747.082 CMAC_LOG_COS_ASSIGNED_SID                   1/10
   21:52:27:  78747.088 CMAC_LOG_RNG_REQ_QUEUED                     10
   21:52:27:  78747.090 CMAC_LOG_NETWORK_ACCESS_DENIED              
   21:52:27:  78747.094 CMAC_LOG_REGISTRATION_OK                    
   21:52:27:  78747.096 CMAC_LOG_STATE_CHANGE                       establish_privacy_state
   21:52:27:  78747.100 CMAC_LOG_PRIVACY_NOT_CONFIGURED             
   21:52:27:  78747.102 CMAC_LOG_STATE_CHANGE                       maintenance_state
   21:52:31:  78751.122 CMAC_LOG_RNG_REQ_TRANSMITTED                
   21:52:31:  78751.124 CMAC_LOG_RNG_RSP_MSG_RCVD                   
   21:52:37:  78757.164 CMAC_LOG_RNG_REQ_TRANSMITTED                
   21:52:37:  78757.168 CMAC_LOG_RNG_RSP_MSG_RCVD                   
   21:52:43:  78763.206 CMAC_LOG_RNG_REQ_TRANSMITTED                
   21:52:43:  78763.210 CMAC_LOG_RNG_RSP_MSG_RCVD                   
   21:52:49:  78769.250 CMAC_LOG_RNG_REQ_TRANSMITTED                
   21:52:49:  78769.252 CMAC_LOG_RNG_RSP_MSG_RCVD

このデバッグ出力から、ネットワーク アクセス(Network Access)が拒否(Denied)されていることが分かります。

   7246VXR#show cable modem detail
   Interface   SID  MAC address    Max CPE  Concatenation  Rx SNR
   Cable4/0/U0 7    0002.1685.b5db 10       yes            33.52
   Cable4/0/U0 8    0002.fdfa.0a63 10       yes            33.24
   Cable4/0/U0 9    0010.7bed.9b23 1        no             33.29
   Cable4/0/U0 10   0010.7bed.9b45 1        no             33.23
   Cable4/0/U0 11   0001.64ff.e47d 10       yes            33.20
   Cable4/0/U0 12   0004.2752.ddd5 10       yes            33.44
   
   

特別なスコープを持つケーブル モデムの Max CPE の値が 1 で、他が 10 であることに注意してください。スコープ platinum.cm の設定を見ると、10 台の CPE が指定されていますが、スコープ disable.cm には 1 つの CPE しかありません。 事前設定された DOCSIS コンフィギュレーション ファイル silver.cm にも、CPE は 1 つしか指定されていません。

   7246VXR#show interface cable 4/0 modem 0
   SID   Priv bits  Type      State     IP address    method    MAC address
   7     00         modem     up        10.1.4.7      dhcp      0002.1685.b5db
   8     00         modem     up        10.1.4.10     dhcp      0002.fdfa.0a63
   9     00         host      unknown   172.16.29.2   static    00c0.4f97.61c5
   9     00         modem     up        10.1.4.66     dhcp      0010.7bed.9b23
   10    00         modem     up        10.1.4.65     dhcp      0010.7bed.9b45
   11    00         modem     up        10.1.4.6      dhcp      0001.64ff.e47d
   12    00         modem     up        10.1.4.9      dhcp      0004.2752.ddd5
   
   

ケーブル モデムが正しいレベルのサービスを取得していることを調べるには、show cable qos profile コマンドの出力を参照します。

   7246VXR#show cable qos profile
   ID  Prio Max       Guarantee Max        Max   TOS  TOS   Create  B     IP prec.
            upstream  upstream  downstream tx    mask value by      priv  rate
            bandwidth bandwidth bandwidth  burst                    enab  enab
   1   0    0         0         0          0     0x0  0x0   cmts(r) no    no      
   2   0    64000     0         1000000    0     0x0  0x0   cmts(r) no    no      
   3   7    31200     31200     0          0     0x0  0x0   cmts    yes   no      
   4   7    87200     87200     0          0     0x0  0x0   cmts    yes   no      
   5   4    64000     0         512000     0     0x0  0x0   cm      no    no      
   6   0    1000      0         1600000    0     0x0  0x0   cm      no    no      
   7   0    128000    10000     10000000   1600  0x0  0x0   cm      no    no      
   8   0    0         0         0          0     0x0  0x0   mgmt    no    no      
   10  0    0         0         0          0     0x0  0x0   mgmt    no    no      
   12  0    0         100000000 0          0     0x0  0x0   mgmt    no    no

qos ID 7 が platinum.cm の設定に一致していることに注意します。

cable config-file platinum.cm
    service-class 1 max-upstream 128
    service-class 1 guaranteed-upstream 10
    service-class 1 max-downstream 10000
    service-class 1 max-burst 1600
    cpe max 10
    timestamp

同様のことが、disable.cm の DOCSIS 設定でも起きています。

   7246VXR#show ip dhcp binding
   IP address       Hardware address        Lease expiration        Type
   10.1.4.6         0100.0164.ffe4.7d       Mar 08 2001 07:58 AM    Automatic
   10.1.4.7         0100.0216.85b5.db       Mar 08 2001 07:58 AM    Automatic
   10.1.4.9         0100.0427.52dd.d5       Mar 08 2001 07:58 AM    Automatic
   10.1.4.10        0100.02fd.fa0a.63       Mar 08 2001 08:36 AM    Automatic
   10.1.4.65        0100.107b.ed9b.45       Infinite                Manual
   10.1.4.66        0100.107b.ed9b.23       Infinite                Manual
   
   

関連するシスコ サポート コミュニティ ディスカッション

シスコ サポート コミュニティは、どなたでも投稿や回答ができる情報交換スペースです。


関連情報


Document ID: 28990