ブロードバンド ケーブル : ケーブル モデム終端システム(CMTS)

cable modem remote-query コマンドの設定

2003 年 4 月 29 日 - ライター翻訳版
その他のバージョン: PDFpdf | 機械翻訳版 (2013 年 2 月 10 日) | 英語版 (2006 年 5 月 23 日) | フィードバック

目次


概要

cable modem remote-query は、Cisco IOS(R) ソフトウェア リリース 12.0(7)XR および 12.1(2)T で導入されました。このコマンドを使用すると、ケーブル モデムのパフォーマンス統計を uBR Cable Modem Termination System(CMTS; ケーブル モデム終端システム)から直接照会することができます。 このコマンドの目的は、Simple Network Management Protocol(SNMP; 簡易ネットワーク管理プロトコル)を使ってケーブル モデムに対して定期的にポーリングを実行し、CMTS 上の IP アドレス、MAC アドレス、S/N 比、アップストリーム転送能力などの情報をキャッシュすることです。(出力を参照) この情報により、オペレータは一目で 1 台のモデムの状態の概要や、プラントの全体的な状態を把握することができます。

設定

リモート クエリーの設定行は数行のみです。

ケーブル モデムで、SNMP コミュニティ ストリングを設定する必要があります。 この操作は、 次のいずれかの方法で実行できます。

  • 手動設定: snmp-server community <ストリング> global 設定コマンドの追加
  • Data-over-Cable Service Interface Specification(DOCSIS)設定 ファイルを使用して、強制的に CM による IOS 設定ファイル のダウンロードを行う。
  • DOCSIS 設定ファイルで定義した SNMP Object IDentifier(OID; オブジェクト識別子)を使った CM コミュニティの設定


CMTS では、次の順番でグローバル設定コマンドを 実行する必要があります。

snmp-server community <コミュニティ ストリング>

snmp-server manager

cable modem remote-query [ポーリング間隔] [コミュニティ ストリング] [ポーリング [間隔] は、クエリーの実行間隔を定義します。 たとえば、30 はクエリーが 30 秒ごとに実行されることを意味します。 [コミュニティ ストリング] は、コミュニティ ストリングを定義します。

cable remote-query を設定する場合、次のすべてのコミュニティ ストリングを一致させる必要があります。

  • CM で設定された snmp-server コミュニティ ストリング
  • CMTS で設定された snmp-server コミュニティ ストリング
  • cable modem remote-query [ポーリング間隔] [コミュニティ ストリング] コマンドで設定した snmp コミュニティ ストリング
注:「!-- 青」で示されているのは、上の行に関するコメントです。

Current configuration : 3473 bytes
!
version 12.1
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname big-cmts
!
!
cable modem remote-query 30 test
! -- コミュニティ ストリング「test」を使って、30 秒ごとに、リモート クエリーを実行するように、 CMTS を設定します。
no cable qos permission create
no cable qos permission update
cable qos permission modems
cable time-server
ip subnet-zero
no ip finger
no ip domain-lookup
ip dhcp relay information option
no ip dhcp relay information check
!
interface Ethernet2/0
ip address 10.200.68.3 255.255.255.0
!
interface Cable3/0
ip address 10.200.71.17 255.255.255.240 secondary
ip address 10.200.71.1 255.255.255.240
no keepalive
  cable downstream annex B
cable downstream modulation 64qam
cable downstream interleave-depth 32
cable upstream 0 frequency 20000000
cable upstream 0 power-level 0
no cable upstream 0 shutdown
cable dhcp-giaddr policy
cable helper-address 10.200.68.200
!

ip classless
ip route 0.0.0.0 0.0.0.0 10.200.68.1
no ip http server
!
snmp-server community test RO
! -- コミュニティ ストリングは、CM で設定されたストリング、および 前述の cable modem remote-query コマンドで設定したストリングと一致させる必要があります。
snmp-server manager
! -- CMTS を SNMP マネージャとして設定する必要があるため、 CM 上の SNMP エージェントに対する要求を CMTS で生成することができます。
line con 0
transport input none
line aux 0
line vty 0 4
login
!
end

ケーブル モデムの場合、次のグローバル コマンドを追加して、 工場出荷値をデフォルト設定しました。

snmp-server community test RO
 

確認とデバッグ

赤は強調のために使用します。

収集した情報の出力は、次のとおりです。

big-cmts#show cable modem remote-query

IP address      MAC address     S/N    US     DS    Tx Time Micro (dB) Modem
                               Ratio  Power  Power Offset  Reflection State

10.200.71.8     0001.9659.47af  36.6   31.0    0.0  12352   17        online
10.200.71.4     0001.9659.47c7  36.6   37.0    0.0  12352   17        online
10.200.71.6     0001.9611.b9a3  36.6   37.0    0.0  12353   15        online
10.200.71.3     0001.9659.47a9  36.6   37.0    0.0  12351   16        online
10.200.71.2     0001.9659.47c1   0.0    0.0    0.0  0       0         online !-- このモデムは、SNMP クエリーに対して 応答していません。

最後のモデムが SNMP クエリーに応答しない場合、  動作を確認するために若干のデバッグが必要です。

big-cmts#debug cable remote-query

CMTS remote-query debugging is on

*Sep 26 01:30:41.677:

For IP address 10.200.71.2 !-- show cable modem remote-query 出力で、 すべて 0 を示しているモデムの IP アドレス

*Sep 26 01:30:41.677:

!--SNMP proxy exec got event,but queue is empty

上記メッセージは、モデムに対してクエリーが実行されたにもかかわらず、 応答を受信しなかったことを意味します。 SNMP レベルを確認することによって、詳細情報を 取得できます。

big-cmts#show snmp sessions

Destination: 10.200.71.2.161, V1 community: test !-- "V1": SNMP バージョン - "test": モデムに対するクエリーの実行に使用するコミュニティ ストリング

  Round-trip-times: 0/0/0 (min/max/last)

  packets output

    2147 Gets, 0 GetNexts, 0 GetBulks, 0 Sets, 0 Informs !-- モデムに対して発行される SNMP GETS の数

    2146 Timeouts, 0 Drops !-- タイムアウトとなった全 SNMP GETS

  packets input

    0 Traps, 0 Informs, 0 Responses (0 errors)

これは、リモート クエリーに応答するモデムに対する debug cable remote-query コマンドの出力です。

*Sep 26 01:30:49.709:

For IP address 10.200.71.8

*Sep 26 01:30:49.713:  docsIfSignalQualityEntry.5.3 = 366

*Sep 26 01:30:49.713:  docsIfMibObjects.2.2.1.3.2 = 310

*Sep 26 01:30:49.717:  docsIfDownstreamChannelEntry. 6.3 = 0

*Sep 26 01:30:49.717:  docsIfUpstreamChannelEntry.6. 4 = 12352

*Sep 26 01:30:49.721:  docsIfSignalQualityEntry.6.3 = 17

これは、同じモデムに対する SNMP セッションの詳細情報です。 gets の数が タイムアウトやドロップが発生しなかった応答数と一致する点に注意してください。

Destination: 10.200.71.8.161, V1 community: test, Expires in 581 secs

  Round-trip-times: 1/1/1 (min/max/last)

  packets output

    5421 Gets, 0 GetNexts, 0 GetBulks, 0 Sets, 0 Informs

    0 Timeouts, 0 Drops

  packets input

    0 Traps, 0 Informs, 5421 Responses (0 errors)
 

リモート クエリーに対して定義されたコミュニティ ストリングと CMTS snmp-server コミュニティ行の不一致は、 次の出力で確認できます。

big-cmts#sh snmp

Chassis: 6888364

0 SNMP packets input

    0 Bad SNMP version errors

    30 Unknown community name !-- コミュニティ ストリングの不一致

    0 Illegal operation for community name supplied

    0 Encoding errors

    0 Number of requested variables

    0 Number of altered variables

    0 Get-request PDUs

    0 Get-next PDUs

    0 Set-request PDUs

3944 SNMP packets output

    0 Too big errors (Maximum packet size 1500)

    0 No such name errors

    0 Bad values errors

    0 General errors

    0 Response PDUs

    0 Trap PDUs

障害時の対応

最も一般的な問題は、cable modem remote-query [ポーリング間隔] [コミュニティ ストリング] コマンド パラメータの変更により、 ケーブル モデムの障害や誤動作が発生することです。 したがって、最初に no cable modem remote-query でこのコマンドを削除してから、 元の状態に戻すことを推奨します。

また、snmp-server community <ストリング> で定義したコミュニティ ストリングを 変更しなければならない場合、まず cable modem remote-query [ポーリング間隔] [コミュニティ ストリング] コマンドを削除してから、コミュニティ ストリングを変更し、 cable modem remote-query [ポーリング間隔] [コミュニティ ストリング] を再設定します。


Cisco サポート コミュニティ - 特集対話

Cisco サポート コミュニティでは、フォーラムに参加して情報交換することができます。現在、このドキュメントに関連するトピックについて次のような対話が行われています。


関連情報


Document ID: 12209