ブロードバンド ケーブル : ケーブル モデム終端システム(CMTS)

シスコ CMTS CLI を使用して IOS コンフィギュレーション ファイルをシスコのケーブル モデムにダウンロードする方法

2003 年 9 月 29 日 - ライター翻訳版
その他のバージョン: PDFpdf | 機械翻訳版 (2013 年 8 月 21 日) | 英語版 (2006 年 1 月 11 日) | フィードバック

目次

概要
はじめに
     表記法
     前提条件
     使用するコンポーネント
ベンダー固有情報(オプション 43)DHCP オプション
DHCP オプション 43 を含むオールインワン設定の設定方法
     ステップ 1 : オプション 43 ストリングを正確に使用して DOCSIS コンフィギュレーション ファイルを作成
     ステップ 2 : DHCP サーバの設定用に DHCP プールを作成
     ステップ 3 : CMTS を TFTP サーバとして設定
     ステップ 4 : CMTS を ToD サーバとして設定
CMTS の設定
     設定の検証
重要な注意事項
関連するシスコ サポート コミュニティ ディスカッション
関連情報

概要

Cisco IOS(R) ソフトウェアのコンフィギュレーション ファイルは、ルータに送信するコンフィギュレーションが書き込まれたテキスト ファイルです。 シスコのケーブル モデムでは、送信されるコンフィギュレーションには、アクセス リスト、ホスト名、SNMP コミュニティ ストリング、パスワード、または、デフォルトのブリッジ設定と異なるルーティング設定が含まれるのが一般的です。 Cisco IOS のコンフィギュレーション ファイルを送信するには、ファイルを Data-over-Cable Service Interface Specifications(DOCSIS)のコンフィギュレーション ファイルに組み込む必要があります。DOCSIS のコンフィギュレーション ファイルは、ケーブル モデムによって初期化プロセスの TFTP 部分で使用されます。

Cisco IOS のコンフィギュレーション ファイルをシスコのケーブル モデムにダウンロードするには、2 つの方法があります。

一般的に使用される 1 つ目の方法は、DOCSIS CPE Configurator ツールを使用する方法です。 「Cisco DOCSIS CPE Configurator」(登録ユーザのみ)を参照してください。 「Cisco DOCSIS CPE Configurator V3.2 を使用した DOCSIS 1.0 対応 DOCSIS コンフィギュレーション ファイルの作成方法」(登録ユーザのみ)には、この方法の詳細な説明が記載されています。

同じ処理を行う 2 つ目の方法は、Cable Modem Termination System(CMTS; ケーブル モデム終端システム)の Cisco IOS の Command Line Interface(CLI; コマンドライン インターフェイス)を使用する方法です。

この文書では、DOCSIS Configurator ツールを使用せず、この 2 つ目の方法を使用して IOS のコンフィギュレーション ファイルをシスコのケーブル モデムにダウンロードする方法について詳細に説明します。 この処理には、「オールインワン設定」の拡張版を使用します。これを使用すると、Cisco CMTS で CMTS 自体の DOCSIS コンフィギュレーション ファイルを設定する他、Cisco CMTS を DHCP、ToD、および TFTP サーバとして設定することができます。

CLI を使用してケーブル モデムにコンフィギュレーション ファイルを送信し、DOCSIS コンフィギュレーション ファイルを設定する場合には、DHCP option called DHCP Vendor Specific Information Option leavingcisco.comを追加することが必要です。これはオプション 43 とも呼ばれます。

この方法でケーブル モデムを設定することの利点は、すべてを Cisco の CMTS で行うことができ、他のサーバ(DHCP、TFTP、ToD)やソフトウェア(DOCSIS CPE Configurator Tool)を使用しなくても、Cisco IOS のコンフィギュレーションを Cisco のケーブル モデムに送信し、カスタム化した設定で動作するようにできることです。

はじめに

表記法

文書表記の詳細については、「シスコ テクニカル ティップスの表記法」を参照してください。

前提条件

この文書の読者には、次の項目について基本的な知識があることが必要です。

  • DOCSIS プロトコル

  • uBR シリーズ ルータでの Cisco IOS コマンドライン インターフェイス(CLI)

  • UNIX

  • ダイナミック ホスト コンフィギュレーション プロトコル(DHCP)

使用するコンポーネント

次の「DHCP オプション 43 を含むオールインワン設定の設定方法」を参照してください。

ベンダー固有情報(オプション 43)DHCP オプション

オプション 43 は、クライアントとサーバでベンダー固有の情報を交換するために使用される DHCP オプションです。 このオプションの書式は RFC 2132 leavingcisco.com で定義されていますが、このオプションによって返される値の定義は、関係するベンダーによって指定されています。

RFC 2132 leavingcisco.com の 8.4 項によれば、通常このオプションは「Type-Length-Value」形式で書式化されます。この形式では、異なる長さの情報を、異なるサブオプションのタイプで表現します。 「Value」フィールドの意味は、エンド デバイスのメーカーによって定義されます。 図 1 は、オプション 43 を図示したものです。

タイプ

長さ

   

タイプ

長さ

   

T1

n

d1

d2

.........

T2

n

D1

D2

........

   

図 1 : オプション 43 で送信されるデータの Type-Length-Value 構造

Cisco IOS コンフィギュレーション ファイルをシスコのケーブル モデムにダウンロードするには、Vendor IDVendor Specific Information Option(VSIF)という 2 つのサブオプションを使用します。

Vendor ID サブオプションのタイプは 8 です。ベンダーに関する 3 バイトの Organization Unique Identifier(OUI)は、通常はケーブル モデムの MAC アドレスの最初の 3 バイトになります。 この値は、通常は 16 進数の数値として表現されます。 シスコシステムズ製の装置の場合、このフィールドは 00:00:0C(16 進数)である必要があります。 次の 図 2 では、ベンダー ID サブオプションの 16 進数の値を示しています。

タイプ

長さ

08

03

00:00:0C

   

図 2 : サブオプション Vendor ID(16 進数値)

使用する 2 つ目のサブオプションは Vendor Specific Information Field(VSIF)です。 このサブオプションのタイプは 128 で、ケーブル モデムのメーカーによって定義された任意の値が設定されます。 シスコのケーブル モデムでは、ルータにダウンロード(必要であれば)する Cisco IOS のコンフィギュレーション ファイル名を識別するために、このフィールドを使用しています。

任意の Cisco IOS コマンドも、このフィールドで指定されることがあります。 このフィールドは、通常はドット付き 10 進数で表現されます。 ドット付き 10 進数による表記とは、各文字の 10 進数値が決められている ASCII 規格を使用して、文字を 10 進数で表すものです。 「ドット」は、10 進数を区切って分かりやすくするために使用されます。

この文書では、ios.cf という Cisco IOS コンフィギュレーション ファイルをダウンロードする方法について説明します。 このファイルの名前は、ASCII からドット付き 10 進数に変換されます。

ASCII とドット付き 10 進数との変換がどのようなものかを知るには、次に示す UNIX コマンドの man ascii を使用できます。 このコマンドでは、いくつかの変換表が表示されます。 ここでは、Decimal - Character の表を見ます。

sj-cse-494% man ascii
 Reformatting page.  Wait... done
 
 ASCII(5)           Headers, Tables, and Macros           ASCII(5)
 
 NAME
      ASCII - map of ASCII character set
 .... (skip the beginning)
 
  	 Decimal - Character
 
      |  0 NUL|  1 SOH|  2 STX|  3 ETX|  4 EOT|  5 ENQ|  6 ACK|  7 BEL|
      |  8 BS |  9 HT | 10 NL | 11 VT | 12 NP | 13 CR | 14 SO | 15 SI |
      | 16 DLE| 17 DC1| 18 DC2| 19 DC3| 20 DC4| 21 NAK| 22 SYN| 23 ETB|
      | 24 CAN| 25 EM | 26 SUB| 27 ESC| 28 FS | 29 GS | 30 RS | 31 US |
      | 32 SP | 33  ! | 34  " | 35  # | 36  $ | 37  % | 38  & | 39  ' |
      | 40  ( | 41  ) | 42  * | 43  + | 44  , | 45  - | 46  . | 47  / |
      | 48  0 | 49  1 | 50  2 | 51  3 | 52  4 | 53  5 | 54  6 | 55  7 |
      | 56  8 | 57  9 | 58  : | 59  ; | 60  < | 61  = | 62  > | 63  ? |
      | 64  @ | 65  A | 66  B | 67  C | 68  D | 69  E | 70  F | 71  G |
      | 72  H | 73  I | 74  J | 75  K | 76  L | 77  M | 78  N | 79  O |
      | 80  P | 81  Q | 82  R | 83  S | 84  T | 85  U | 86  V | 87  W |
      | 88  X | 89  Y | 90  Z | 91  [ | 92  \ | 93  ] | 94  ^ | 95  _ |
      | 96  ` | 97  a | 98  b | 99  c |100  d |101  e |102  f |103  g |
      |104  h |105  i |106  j |107  k |108  l |109  m |110  n |111  o |
      |112  p |113  q |114  r |115  s |116  t |117  u |118  v |119  w |
      |120  x |121  y |122  z |123  { |124  | |125  } |126  ~ |127 DEL|
 

上記のことから、図 3 で示すように、ios.cf のドット付き 10 進数での表記は 105.111.115.46.99.102 になります。

i

o

s

.

c

f

105

111

115

46

99

192

   

図 3 : ファイル名 ios.cf のドット付き 10 進数による表記

VSIF は Type- Length-Value の書式であるため、ios.cf という名前の Cisco IOS コンフィギュレーション ファイルのドット付き 10 進数による表現は 128.6.105.111.115.46.99.192 になります。 ここで分かるように、ios.cf のドット付き 10 進数による表現の前に 128.6 が追加されています。「128」はタイプで、「6」は長さになります。

したがって、次の図 4 に示すように、DOCSIS CPE Configurator Tool V3.2 の Vendor Info Tab にある VSIF フィールドに入力される値は 128.6.105.111.115.46.99.192 になります。

iosconfig_option43.jpg

図 4 : DOCSIS CPE Configurator Tool の Vendor Info フィールド

しかし、DHCP オプション 43 を使用して Cisco IOS でこの機能を実行する場合、Type-Length-Value(TLV)情報は 16 進数の値で表現される必要があります。 ここでは、この 16 進数表現について詳しく説明します。

ASCII 文字列の 16 進数表現を調べるには、次の Unix コマンドを使用できます。

 echo -n "ios.cf" | od -t x1 | cut -s -d' ' -f2- | tr ' ' ':'
 
 sj-cse-494% echo -n "ios.cf" | OD -t x1 | cut -s -d' ' -f2- | tr ' ' ':'
 69:6f:73:2e:63:66

あるいは、先に説明した UNIX コマンドの man ascii を実行して、「Hexadecimal - Character」の表を参照してください。

sj-cse-494% man ASCII
 Reformatting page.  Wait... done
 
 ASCII(5)           Headers, Tables, and Macros           ASCII(5)
 
 NAME
      ASCII - map of ASCII character set
 .... (skip the beginning)
 
 
      Hexadecimal - Character
 
      | 00 NUL| 01 SOH| 02 STX| 03 ETX| 04 EOT| 05 ENQ| 06 ACK| 07 BEL|
      | 08 BS | 09 HT | 0A NL | 0B VT | 0C NP | 0D CR | 0E SO | 0F SI |
      | 10 DLE| 11 DC1| 12 DC2| 13 DC3| 14 DC4| 15 NAK| 16 SYN| 17 ETB|
      | 18 CAN| 19 EM | 1A SUB| 1B ESC| 1C FS | 1D GS | 1E RS | 1F US |
      | 20 SP | 21  ! | 22  " | 23  # | 24  $ | 25  % | 26  & | 27  ' |
      | 28  ( | 29  ) | 2A  * | 2B  + | 2C  , | 2D  - | 2E  . | 2F  / |
      | 30  0 | 31  1 | 32  2 | 33  3 | 34  4 | 35  5 | 36  6 | 37  7 |
      | 38  8 | 39  9 | 3A  : | 3B  ; | 3C  < | 3D  = | 3E  > | 3F  ? |
      | 40  @ | 41  A | 42  B | 43  C | 44  D | 45  E | 46  F | 47  G |
      | 48  H | 49  I | 4A  J | 4B  K | 4C  L | 4D  M | 4E  N | 4F  O |
      | 50  P | 51  Q | 52  R | 53  S | 54  T | 55  U | 56  V | 57  W |
      | 58  X | 59  Y | 5A  Z | 5B  [ | 5C  \ | 5D  ] | 5E  ^ | 5F  _ |
      | 60  ` | 61  a | 62  b | 63  c | 64  d | 65  e | 66  f | 67  g |
      | 68  h | 69  i | 6A  j | 6B  k | 6C  l | 6D  m | 6E  n | 6F  o |
      | 70  p | 71  q | 72  r | 73  s | 74  t | 75  u | 76  v | 77  w |
      | 78  x | 79  y | 7A  z | 7B  { | 7C  | | 7D  } | 7E  ~ | 7F DEL|

次の図 5 では、Vendor Specific Information Field(VSIF; ベンダー特定情報フィールド)のドット付き 10 進数による表現と 16 進数による表現を要約しています。

   

タイプ

長さ

ドット付き 10 進数

128

6

105.111.115.46.99.102

16 進数

80

06

69:6F:73:2E:63:66

   

図 5 : サブオプション VSIF のドット付き 10 進数と 16 進数での表現

DHCP オプション 43 を含むオールインワン設定の設定方法

この設定は、次のソフトウェアとハードウェアのバージョンを使用して作成およびテストされています。

  • 12.2(2)XF を実行する Cisco uBR10012

  • 12.2(2)XA を実行する Cisco CVA120

この文書の情報は、特定のラボ環境にある装置に基づいて作成されています。 また、この文書で使用するデバイスは、すべて初期(デフォルト)の設定で起動しています。 実稼動中のネットワークで作業をしている場合、実際に Cisco IOS のコマンドを使用する前に、その潜在的な影響について理解しておく必要があります。

ステップ 1 : オプション 43 ストリングを正確に使用して DOCSIS コンフィギュレーション ファイルを作成

オプション 43 を設定する最初のステップは、Vendor ID に必要な 16 進数の値と、DHCP オプション 43 の VSIF サブオプションに必要な 16 進数の値を調べることです。

次の表では、ベンダー固有情報の項で詳しく説明したこれらの値が要約されています。

   

Vendor ID サブオプション

VSIF サブオプション

TLV

タイプ

長さ

タイプ

長さ

16 進数

08

03

00:00:0C

80

06

69:6F:73:2E:63:66

意味

ベンダー ID のタイプ

ベンダー ID の長さ

シスコの ID

VSIF のタイプ

VSIF の長さ

(ファイル名)ios.cf

   

図 6

入力する値が分かったら、シスコの CMTS の CLI を使用して、DHCP オプション 43 などの DOCSIS コンフィギュレーション ファイルに必要なすべてのプロパティを作成する必要があります。

DOCSIS コンフィギュレーション ファイルを作成するには、グローバル コマンドの cable config-file < name of the DOCSIS file> を入力する必要があります。 次の出力は、platinum.cm という名前の DOCSIS コンフィギュレーション ファイルの作成を示しています。 platinum.cm の設定は、すべて次で説明します。

注: 
 !-- コメントは青で示します。
 
 
 cable config-file platinum.cm  
   
 !  DOCSIS コンフィギュレーション ファイル の名前は platinum.cm です
 
   service-class 1 priority 2  
   
 !  アップストリーム チャネルのプライオリティは 2 です
 
   service-class 1 max-upstream 128 
   
 !  アップストリームの最大値は 128Kbps です
 
   service-class 1 guaranteed-upstream 10
   
 !  保証されているアップストリームは 10 Kbps です
 
   service-class 1 max-downstream 10000 
   
 !  ダウンストリームの最大値は 10Mbps です
 
   service-class 1 max-burst 1600
   
 !  アップストリーム伝送バーストの最大は 1600 bytes です
 
   cpe max 10 
   
 !  CPE の最大数は 10 です
 
   timestamp
   
 !  タイムスタンプの生成をイネーブルにします
 
   option 43 hex 08:03:00:00:0C:80:06:69:6F:73:2E:63:66  
   
 !  オプション 43 を使用して、IOS コンフィギュレーション ファイル「ios.cf」を
   !  ケーブル モデムに送信します。
 
 

caution 注意: cable config-file コマンドは、Cisco IOS バージョン 12.1(2)EC1 では uBR7200 用および uBR7100 用に、Cisco IOS バージョン 12.2(1)XF1 では uBR10K 用に導入されました。

注: 16 進数のオプションを使用する場合は、TLV データが正しく入力されていることを確認してください。 データが誤って入力されていると、CM がリセット、オフライン、あるいはハングする場合があり、作業を続けるために電源のオフ/オンが必要になります。

ステップ 2 : DHCP サーバの設定用に DHCP プールを作成

DOCSIS コンフィギュレーション ファイル platinum.cm を作成したら、次は CMTS が DHCP サーバになるよう設定し、DHCP の機能に必要なオプションを設定する必要があります。 「CMTS での Cisco IOS ダイナミック ホスト コンフィギュレーション プロトコル(DHCP)サービス」では、DHCP プールの作成に使用する各コマンドの意味が説明されています。 ここでは、設定を要約し、簡単な説明だけを行います。

DHCP プールの設定は次のとおりです。

 ip dhcp pool surf
   
 ! -- dhcp プールの名前。 このスコープは、インターフェイス ケーブル 5/0/0 に接続されている
   !  ケーブルモデム用です。
 
   network 10.1.4.0 255.255.255.0
   
 !  インターフェイス c5/0/0 のスコープ用のアドレス  プールです
 
   bootfile platinum.cm
   
 !  このプールに関連付けられている DOCSIS コンフィギュレーション ファイル名
 
   next-server 10.1.4.1
   
 !  ブートファイルを送信する TFTP サーバの IP アドレス
 
   default-router 10.1.4.1
   
 !  ケーブル モデムのデフォルト ゲートウェイ。DOCSIS ファイルの取得に必要。
 
   option 7 ip 10.1.4.1
   
 !  ログ サーバの DHCP オプション
 
   option 4 ip 10.1.4.1
   
 !  ToD サーバの IP アドレス
 
   option 2 hex ffff.8f80
   
 !  ToD のためのタイム オフセット。GMT を基準に 16 進数による秒数で表現。-28,000 = PST = ffff.8f80。
 
   lease 7 0 10
   
 !  リース時間は 7 日と 0 時間 10 分
 
   ! 

ステップ 3 : CMTS を TFTP サーバとして設定

3 番目のステップは、CMTS が TFTP サーバになるように設定することです。 この処理を行うには、次の操作が必要です。

  1. tftp-server コマンドを使用します

  2. TFTP サーバにファイル ios.cf の場所を設定します。

この処理を行うには、tftp-server disk0:ios.cf alias ios.cf コマンドを使用します。 このコマンドでは、ファイル ios.cf が disk0 に配置されることに注意してください。

 tftp-server server
 
 ! -- cmts が tftp サーバとして動作できるようにイネーブルにする
 
 tftp-server disk0:ios.cf alias ios.cf
 
 ! -- disk0 に事前にダウンロードされている IOS コンフィギュレーション ファイル ios.cf を取得します
 ! -- この IOS コンフィギュレーション ファイルは、テキスト エディタで作成され、disk0  へ tftp によって転送されたものです
 
 
 

ios.cf ファイルをフラッシュまたは disk0 に配置するには(uBR10012 の場合)、テキスト ファイル エディタで作成したファイルを tftp で転送する必要があります。 この処理を行うには、まず初めに、Cisco IOS コンフィギュレーション ファイルが保存されている tftp サーバに対して ping が実行できるようにします。

次に、グローバル コマンドの copy tftp <device> を入力して、そのファイルを CMTS にコピーできるようにします。 通常、uBR7200、uBR7100、または uBR10K の場合はフラッシュが 使用されますが、この例では uBR10012 に disk0 を使用する方法について説明します。

schooner#copy tftp disk0
 Address or name of remote host []? 172.16.30.2
 Source filename []? ios.cf
 Destination filename [ios.cf]? 
 
 Accessing tftp://172.16.30.2/ios.cf...
 Loading ios.cf from 172.16.30.2 (via FastEthernet0/0/0): !
 [OK - 173/4096 bytes]
 
 173 bytes copied in 0.152 secs

IOS コンフィギュレーション ファイルが CMTS に保存されていることを確認するには、dir コマンドを実行します。

schooner#dir
 Directory of disk0:/
     3  -rw-    11606084   Sep 17 2001 13:31:38  ubr10k-k8p6-mz.122-2.XF.bin
  2839  -rw-         173   Oct 01 2001 23:29:44  ios.cf
 47890432 bytes total (36274176 bytes free)

ios.cf ファイルで設定されているコマンドを表示するには、次のように CMTS で more <filename> コマンドを使用します。

schooner#more ios.cf
 hostname SUCCEED
 service linenumber
 enable password cisco
 interface ethernet 0
 load 30
 no shut
 interface cable 0
 load 30
 no shut
 line vty 0 4
 password cisco
 end

ステップ 4 : CMTS を ToD サーバとして設定

シスコの CMTS で ToD を設定するために必要なグローバル コマンドは、service udp-small-servers max-servers no-limitcable time-server の 2 つだけです。 次のように設定します。

 service udp-small-servers max-servers no-limit
 
 ! -- 多数のモデムおよびホストが即座に接続できるようサポートします
 
 cable timeserver
 
 ! -- ケーブル モデムが uBR10012 から Time of Day(ToD)を取得することを許可します
 
 
 

CMTS の設定

uBR10012 の完全な設定は次のとおりです。 太字で説明されているコマンドは、すべてこの文書での目的に関連するコマンドです。

Schooner#show run
 Building configuration...
 
 Current configuration : 3522 bytes
 !
 version 12.2
 no parser cache
 no service single-slot-reload-enable
 no service pad
 service timestamps debug uptime
 service timestamps log uptime
 no service password-encryption
 service udp-small-servers max-servers no-limit
 !
 hostname schooner
 !
 logging rate-limit console all 10 except critical
 enable secret 5 $1$cM7F$ryXH7z/Ly6QCnD2LQ.gZs/
 !
 no cable qos permission create
 no cable qos permission update
 cable qos permission modems
 cable timeserver
 !
 cable config-file platinum.cm
  service-class 1 priority 2
  service-class 1 max-upstream 128
  service-class 1 guaranteed-upstream 10
  service-class 1 max-downstream 10000
  service-class 1 max-burst 1600
  cpe max 10
  timestamp
  option 43 hex 08:03:00:00:0C:80:06:69:6F:73:2E:63:66
 !
 redundancy
  main-cpu
   auto-sync standard
 facility-alarm intake-temperature major 49
 facility-alarm intake-temperature minor 40
 facility-alarm core-temperature major 53
 facility-alarm core-temperature minor 45
 card 1/0 1oc12pos-1
 card 1/1 2cable-tccplus
 card 2/0 1gigethernet-1
 card 5/0 2cable-mc28
 card 7/0 2cable-mc28
 ip subnet-zero
 no ip domain-lookup
 !
 ip dhcp pool surf
    network 10.1.4.0 255.255.255.0
    bootfile platinum.cm
    next-server 10.1.4.1 
    default-router 10.1.4.1 
    option 7 ip 10.1.4.1 
    option 4 ip 10.1.4.1 
    option 2 hex ffff.8f80
    lease 7 0 10
 !
 interface FastEthernet0/0/0
  ip address 172.16.30.50 255.255.255.192
 !
 interface POS1/0/0
  no ip address
  crc 32   
  pos report all
  POs flag j0 1
 !
 interface GigabitEthernet2/0/0
  no ip address
  negotiation auto
 !
 interface Cable5/0/0
  ip address 10.1.4.1 255.255.255.0
  cable downstream annex B
  cable downstream modulation 64qam
  cable downstream interleave-depth 32
  cable upstream 0 frequency 40000000
  cable upstream 0 power-level 0
  no cable upstream 0 shutdown
  cable upstream 1 shutdown
  cable upstream 2 shutdown
  cable upstream 3 shutdown
 !
 ip classless
 ip route 0.0.0.0 0.0.0.0 172.16.30.1
 no ip http server
 !
 no cdp run
 snmp-server community public RO
 snmp-server community private RW
 snmp-server trap-source Cable5/0/0
 snmp-server packetsize 2048
 snmp-server enable traps cable
 snmp-server host 172.16.30.8 public  cable snmp
 snmp-server manager
 tftp-server server
 tftp-server ios.cf alias ios.cf
 !
 alias exec scm show cable modem
 !
 line con 0
 line aux 0
 line vty 0 4
 !
 end
 
 schooner#

他の CMTS ベンダーでは、そのベンダーの CMTS コマンドだけを使っても全項目を設定できない場合がありますが、Cisco IOS では完全に設定することができます。

Cisco IOS のコンフィギュレーション ファイル ios.cf で設定されたコマンドが、ケーブル モデムで受け入れられるようにするには、そのケーブル モデムをリブートする必要があります。 これを行うには、CMTS の CLI から clear cable modem <ip address/MAC address> reset コマンドを実行します。

Schooner#clear cable modem 10.1.4.4 reset
 

caution 注意: 使用しているネットワークの規模が大きく、プラント内のすべてのケーブル モデムに対して異なるコンフィギュレーション ファイルを送信したい場合は、段階的に行うことをお勧めします。 段階的に行うことで、数千台ものケーブル モデムが一斉にオンラインになろうとするときに、互いに阻害し合うような影響を最小限に留めることができます。

設定の検証

設定を検証するには、clear cable modem コマンドを使用して、ケーブル モデムをクリアします。 ケーブル モデムがオンライン状態に戻ったら、telnet 接続を行って設定を調べます。

Schooner#show cable modem 
 MAC Address    IP Address      I/F       MAC         Prim RxPwr Timing Num  BPI
                                          State       Sid  (db)  Offset CPEs Enbld
 0004.27ca.0e9b 10.1.4.6        C5/0/0/U0 online      1  *0.00   2820   0    no 
 0090.9600.703d 10.1.4.2        C5/0/0/U0 online      2   -0.75  2816   0    no 
 0003.e38f.f9b5 10.1.4.3        C5/0/0/U0 online      3  *0.00   2822   0    no 
 0001.64ff.e4b5 10.1.4.4        C5/0/0/U0 online      4  *0.00   2812   0    no 
 <!-- CVA120
  
 0020.4086.2704 10.1.4.5        C5/0/0/U0 online      5   -0.50  2808   0    no 
 0020.4086.3324 10.1.4.7        C5/0/0/U0 online      6   -0.50  2808   0    no 
 0020.4079.feb4 10.1.4.8        C5/0/0/U0 online      7   0.00   2805   0    no 
 0020.4085.d06a 10.1.4.9        C5/0/0/U0 online      8   -0.50  2807   0    no 

この例では、ios.cf ファイルからケーブル モデムに対して、SUCCEED というホスト名を使用するよう命令が出されています。これはこのケーブル モデムに telnet 接続したときに見られるファイル名です。

Schooner#telnet 10.1.4.4
 Trying 10.1.4.4 ... Open
 
 SUCCEED line 1 
 
 
 User Access Verification
 
 Password: 
 SUCCEED>en
 Password: 
 SUCCEED#

Cisco IOS コンフィギュレーション ファイルがケーブル モデムに正しくダウンロードされたことを確認するには、show version コマンドを使用します。 次の出力では、ios.cf ファイルに関係する情報が太字で示されています。

SUCCEED#show  version
 Cisco Internetwork Operating System Software 
 IOS (tm) 120 Software (CVA120-K8V4Y5-M), Version 12.2(2)XA, EARLY DEPLOYMENT RELEASE SOFTWARE (fc1)
 TAC:Home:SW:IOS:Specials for info
 Copyright (c) 1986-2001 by cisco Systems, Inc.
 Compiled Wed 27-Jun-01 02:02 by hwcheng
 Image text-base: 0x800100A0, data-base: 0x80782844
 ROM: System Bootstrap, Version 12.0(20001010:025045) [spaulsen-blue-3105 3108], DEVELOPMENT SOFTWARE
 ROM: 120 Software (CVA120-K8V4Y5-M), Version 12.2(2)XA, EARLY DEPLOYMENT RELEASE SOFTWARE (fc1)
 
 SUCCEED uptime is 3 days, 3 hours, 21 minutes
 System returned to ROM by reload at 05:52:09 - Sat Jan 1 2000
 System restarted at 05:58:30 - Sat Oct 6 2001
 System image file is "flash:cva120-k8v4y5-mz.122-2.XA.bin"
 Host configuration file is "tftp://10.1.4.1/ios.cf"
 
 cisco CVA122 CM (MPC850) processor (revision 3.r) with 32256K/1024K bytes of memory.
 Processor board ID SAD043708GK
 Bridging software.
 1 Ethernet/IEEE 802.3 interface(s)
 1 Cable Modem network interface(s)
 1 Universal Serial Bus (USB) interface(s)
 8192K bytes of processor board System flash (Read/Write)
 7296K bytes of processor board Boot flash (Read/Write)
 
 Configuration register is 0x2

CVA120 の設定は次のとおりです。 太字で示されたコマンドは、ios.cf ファイルの行に対応することに注意してください。

SUCCEED#show run
 Building configuration...
 
 Current configuration : 1429 bytes
 !
 ! Last configuration change at 11:22:22 - Tue Oct 9 2001
 !
 version 12.1
 no service single-slot-reload-enable
 no service pad
 service timestamps debug uptime
 service timestamps log uptime
 no service password-encryption
 service linenumber
 service internal
 !
 hostname SUCCEED
 !
 no logging buffered
 no logging buffered
 logging rate-limit console 10 except errors
 enable password cisco
 !
 clock timezone - -8
 ip subnet-zero
 no ip routing
 no ip finger
 !
 interface Ethernet0
  ip address 10.1.4.11 255.255.255.0
  no ip route-cache
  no ip mroute-cache
  load-interval 30
  bridge-group 59
  bridge-group 59 spanning-disabled
 !
 interface cable-modem0
  ip address docsis
  no ip route-cache
  no ip mroute-cache
  load-interval 30
  cable-modem boot admin 2
  cable-modem boot oper 5
  cable-modem downstream mode annex-b
  cable-modem Mac-timer t2 40000
  bridge-group 59
  bridge-group 59 spanning-disabled
 !
 interface USB0
  ip address 10.1.4.11 255.255.255.0
  no ip route-cache
  no ip mroute-cache
  arp timeout 0
  bridge-group 59
  bridge-group 59 spanning-disabled
 !
 ip classless
 no ip http server
 no ip http cable-monitor
 !
 snmp-server packetsize 4096
 snmp-server chassis-id 
 snmp-server manager
 !
 voice-port 0
  input gain -2
 !
 voice-port 1
  input gain -2
 !
 mgcp modem passthrough voaal2 mode 
 no mgcp timer receive-rtcp
 !
 mgcp profile default
 !
 line con 0
  transport input none
 line vty 0 4
  password cisco
  login
 !
 end
 

重要な注意事項

次のコマンドによって有効な設定が行われると想定しているため、cable config-file 用の option コマンドが壊れているように見えます。

option 43 instance 8 hex 00:00:0c
 option 43 instance 128 ASCII ios.cf

これらのコマンドは受け入れられるものの、正しい Cisco IOS コンフィギュレーション ファイルは生成されません。 これはバグではありません。 ここでの問題は、「instance」という用語が「サブオプション」としてどのように解釈されたかですが、これはサブオプションとは解釈されません。

「instance」を使用すると、様々なベンダー向けのオプション 43 のインスタンスが複数ある場合のように、同じオプションを複数回繰り返すことができます。 次に例を示します。

option 43 instance 1 hex 08:03:00:00:0C:80:07:69:6F:73:2E:63:66:67 
 !-- シスコの CM 用のファイルを設定
 
 option 43 instance 2 hex 08:03:11:22:33:80:07:69:6F:73:2E:63:66:67 
 !-- 他の CM に対するオプション
 
 

11:22:33 は架空の会社による無作為の Vendor ID であることに注意してください。 実際の Vender ID に一致したとしても、全くの偶然です。

「instance」という用語は、TLV サブオプション フィールドを反映することが想定され、実際 に TLV サブオプション フィールドがあるため、ストリング全体を 16 進数値で入力しなくてはならなくなります。


関連するシスコ サポート コミュニティ ディスカッション

シスコ サポート コミュニティは、どなたでも投稿や回答ができる情報交換スペースです。


関連情報


Document ID: 8323