クラウドおよびシステム管理 : Cisco Network Registrar

Cisco Network Registrar によるケーブル モデムの基本的なインストール方法

2003 年 3 月 31 日 - ライター翻訳版
その他のバージョン: PDFpdf | 機械翻訳版 (2013 年 8 月 21 日) | 英語版 (2005 年 10 月 26 日) | フィードバック

目次


概要

このテクニカル ノートの目的は、ラボ環境での Cable Modem(CM; ケーブル モデム)ネットワークの設定に関する完全なガイドラインを提供することです。 この設定は、カスタマー ネットワークを展開する前の最初のステップとして使用されます。 ラボ環境で問題なく設定ができたとしても、カスタマー ネットワークでも問題なく設定ができるとは限らないことに注意してください。 管理されたラボ環境ではノイズが問題にならなくても、実環境では大きな問題になることがあります。 しかし、この手順を使用することにより、Cisco IOS(R) ソフトウェアのバージョン、設定、ハードウェア、および Radio Frequency(RF; 無線周波数)が原因で発生する問題を排除できます。

ラボのトポロジ


 

図 1:ラボのネットワーク設定

上の図は、Cable Modem Termination System(CMTS; ケーブル モデム終端システム)を示しています。このシステムは、Cisco IOS ソフトウェア リリース 12.1(2)T を実行し、MC16C モデム カードを装着した uBR7246、Cisco IOS ソフトウェア リリース バージョン 12.0(7)T を実行している Cable Modem(CM; ケーブル モデム)uBR904、アップコンバータ、低波長から高波長を分離するためのダイプレックス フィルタ、Cisco Network Registrar(CNR)バージョン 3.5(3)、3 方向スプリッタ、および Customer Premises Equipment(CPE; 顧客宅内機器)(この場合はラップトップ)で構成されています。

注:上記の RF の設定は、初期基準値として使用できますが、これをカスタマー サイトに展開した後は、適切な値に変更することも可能です。 RF の測定はこの文書の対象範囲外です。RF の正しい設定と測定については、「ケーブル ヘッドエンドの接続と設定」を参照してください。

前提条件:

  • アップコンバータは取り付け済みで、正しく設定されていることです。 設定にはベンダーのマニュアルを参照してください。 GI アップコンバータを使用している場合は、当該の NTSC チャネルの中心周波数より 1.75 MHz 低く設定する必要があることに注意してください。
  • CM の背後には適切に設定された CPE があり、DHCP サーバから IP アドレスを取得していることです。
  • CNR は、同じ IP アドレス 172.17.110.136 を持つ DHCP サーバおよび TFTP サーバとして使用されます。
  • Time of Day サーバ ソフトウェアは、CNR と同一の NT サーバで実行されていることです。

以下の項では、以下のコンポーネントの設定に必要なステップについて説明します。

  • Cisco Network Registrar(CNR)
  • Data Over Cable Service Interface Specification(DOCSIS)のコンフィギュレーション ファイル
  • ケーブル モデム終端システム(CMTS)
  • ケーブル モデム(CM)

ネットワーク ダイアグラム

>>画像拡大

図 2: このテクニカル ノートで使用する IP アドレスと名称を示すネットワーク ダイヤグラム

Cisco Network Registrar の設定

  1. 最初に、スタート メニューから CNR を起動します。
  2. メニュー バーで Add タブをクリックし、新しいクラスタを追加します。 図 3 を参照してください。
  3. クラスタ名を入力します。 この場合、IP アドレスを名称として使用します。
  4. 接続を許可するボックスの内容を確認します。
  5. OK をクリックします。

図 3:CNR のクラスタ名と IP アドレスのウィンドウ

ユーザ名とパスワードの入力が求められたら、adminchangeme を使用してください。 図 4 を参照してください。

図 4:CNR のユーザ名とパスワードのウィンドウ

上図のウィンドウで OK をクリックすると、図 5 のようなウィンドウが表示されます。
 

図 5: CNR の Server Manager ウィンドウ。 このウィンドウには、設定されているクラスタの名前または IP アドレスが表示されています。

DHCP@172.17.110.136 をダブルクリックして、DHCP@172.17.110.136 Properties ウィンドウを表示します。PoliciesNew の順にクリックして、新しいポリシーを作成します。 図 6 は、このステップの画面を示しています。

図 6:Cable Modems という名前のポリシーを追加し、デフォルトのポリシーからアトリビュートをコピーします。

ポリシーの名前を入力してください。 この例では、名前は Cable Modems です。これが新規のポリシーである場合は、Copy from default を選択して、OK をクリックします。

 次に、Edit options をクリックして、DHCP オプションを指定します。 Cable Modems というポリシーには、次のオプションを追加する必要があります(図 7 を参照)。

  • dhcp-lease-time はデフォルトでアクティブにされており、604800 秒に設定されています。これは 1 週間に相当する秒数です。
  • routers は CMTS ケーブル インターフェイスの IP アドレスで、この場合は 10.1.1.10 です。 詳細は「CMTS の設定」を参照してください。
  • CM の time-offset には、Universal Coordinated Time (UTC; 世界標準時)からの時差を指定します(「タイム オフセット、オプション 2」を参照)。 この値は、CM によってエラー ログにタイム スタンプを行うためのローカル時間の計算に使用されます。
  • time-servers には ToD(Time of Day)サーバの IP アドレスを指定します。ここでは、172.17.110.136 です。
  • packet-siaddr は TFTP サーバの IP アドレスで、ここでは 172.17.110.136 です。
  • packet-file-name は、「DOCSIS CPE Configurator」(CCO アカウントのあるシスコ ユーザのみ使用可能)で設定された DOCSIS コンフィギュレーション ファイルです。このファイルは、TFTP サーバの tftpboot ディレクトリにあることが必要です。

図 7: Cable Modem ポリシーに与えられたアトリビュートが表示されている Edit Options ウィンドウ。

注: BOOTP クライアントがある場合は、Send to BOOTP clients と表示されるボックスをチェックしてください。 また、Always send to DHCP clients をチェックすることを強く推奨します。

ここで、ラップトップなどの CM の背後にある CPE と関連する別のポリシーを作成する必要があります。Cable Modems ポリシーを作成したときと同じ手順に従ってください。 ここでは、デフォルトではなく、プルダウン リストから Copy from Cable Modems ポリシーを選択してコピーします。 この例では、新しいポリシーの名前は Cable Modem Clients とします。 図 8 を参照してください。
 

図 8: Cable Modem Clients という名前のポリシーを追加し、既存の Cable Modems ポリシーからアトリビュートをコピーします。

OK をクリックした後、Edit option ボタンを押して、アクティブなオプションを選択します。 CPE ポリシーの場合は、dhcp-lease-time オプションと routers オプション以外のすべてのオプションをアクティブ リストから削除します。 オプションを削除するには、Active ウィンドウで削除するプロパティを選択して、Remove ボタンをクリックします。 routers オプションの IP アドレスは 192.168.1.10 に変更する必要があります。これは CMTS ルータに設定されているセカンダリ IP アドレスです。 詳細は「CMTS の設定」を参照してください。

図 9: routers のアトリビュートに IP アドレスを追加します。 この IP アドレスは、CMTS でこのポリシーが適用されるケーブル インターフェイスに設定されているセカンダリ IP アドレスである必要があります。

注: この例では、CMTS のセカンダリ アドレスおよび Cable Modems Client ポリシーにプライベート IP アドレスを使用しています。 NAT が使用されている場合を除き、実稼働環境では CPE デバイスにパブリック IP アドレスを使用して、インターネットにアクセスできるようにする必要があります。

最後のステップは、スコープを作成して Cable Modems ポリシーと Cable Modem Clients ポリシーに関連付けることです。 新しいスコープを作成するには、メイン メニューから DHCP@172.17.110.136 をクリックし、次に Add タブをクリックします。 この操作によって、新しいスコープを作成できます。

図 10 に示すように、新しいスコープの名前を入力し、適切な Policy を選択します。この例では、Cable Modems にスコープを設定し、IP アドレスの範囲を 10.1.1.20 から 10.1.1.30 にします。

図 10: ケーブル モデム用のスコープの名前は Cable Modems とします。

上記の手順を、Cable Modem Clients 用のスコープについて繰り返します。 この例では、プライベート IP アドレスの 192.168.1.20 から 192.168.1.30 の範囲を使用します。 図 11 を参照してください。

図 11: ケーブル モデムの背後にある CPE 機器用のスコープの名前は、Cable Modem Clients とします。

CPE デバイス用のスコープには、ステップがもう 1 つ必要です。 Cable Modem Clients スコープを作成したら、そのスコープをダブルクリックして、図 12 のウィンドウを表示します。

図 12:Cable Modem Clients スコープのウィンドウ

図 12 で示すウィンドウで Advanced タブをクリックして、セカンダリ スコープをプライマリ スコープに関連付ける必要があります。 これを行うには、Make this scope a secondary ボックスをチェックします。 プルダウン メニューが空白の場合は適切なプライマリ スコープを選択します。ここでは、Cable Modems スコープになります。 図 13 を参照してください。

図 13: Cable Modem Clients スコープをセカンダリにして、プライマリ スコープに関連付けられるようにします。

最後に DHCP サーバを再起動して、変更が適用されるようにします。 メイン メニューで DHCP@172.17.110.136 を選択し、一番上にある Control タブをクリックして図 14 で示す画面が表示されるようにします。これにより、DHCP サーバがリロードされます。

図 14: ウィンドウをリロードして、CNR に変更を適用します。

DOCSIS コンフィギュレーション ファイル

ケーブル ネットワークの設定に必要な次のステップは、コンフィギュレーション ファイルの作成です。 ケーブル モデムがオンラインになるためには、TFTP サーバ経由で DHCP サーバからコンフィギュレーション ファイルをダウンロードする必要があります。 この例では、TFTP サーバと DHCP サーバの提供に CNR を使用しています。 コンフィギュレーション ファイルを設定するための最低限の要件の詳細は、「ケーブル モデムのための DHCP および DOCSIS コンフィギュレーション ファイル(DOCSIS 1.0)」を参照してください。 このファイルは、Web ベースのツールである「CPE DOCSIS Configurator」を使用して設定することができます。 登録ユーザであり、ログインしている場合は、このツールのスタンドアローン バージョンにアクセスできます。これはDOCSIS CPE Configurator からダウンロードできます。 以下の「CM(uBR904)の場合」の項で使用されている DOCSIS コンフィギュレーション ファイルの名前は platinum.cm です。

: コンフィギュレーション ファイルを作成したら、このファイルが TFTP サーバにコピーされていることを確認します。 CNR による TFTP サーバの場合には、TFTP サーバが起動していることも確認してください。 これを行うには、TFTP@172.17.110.136 を選択し、Control タブをクリックします。 この操作によって TFTP@172.17.110.136 Control 画面が表示され、ここでサーバを起動できます。 TFTP サーバの機能はデフォルトで off になっています。 ブート時に TFTP サーバが自動的に起動するようにするには、NRCMD(CNR 用のコマンドライン インターフェイス)を起動して、次のように入力します。

server tftp set start-on-reboot=enabled 
 save   


ヘッドエンド(CMTS)の設定

uBR7246 の基本設定の全体を次に示します。

注: !-- コメントは青で示します。


 
 Current configuration:
 !
 version 12.1
 service timestamps debug uptime
 service timestamps log uptime
 no service password-encryption
 !
 hostname Sydney
 !
 boot system flash ubr7200-ik1s-mz_121-2_T.bin
 no logging buffered
 enable password <deleted>
 !
 no cable qos permission create
 !  デフォルト  
 no cable qos permission update
 !  デフォルト
 cable qos permission modems
 !  デフォルト
 !
 !
 !         
 ip subnet-zero
 no ip domain-lookup
 !
 !
 interface FastEthernet0/0
  no ip address
  shutdown
  half-duplex
 !
 interface Ethernet1/0
  ip address 172.17.110.139 255.255.255.224
 !  CNR と同じ LAN セグメントにあるインターフェイスの IP アドレス
 !
 interface Ethernet1/1
  no ip address
  shutdown
 !
 interface Ethernet1/2
  no ip address
  shutdown
 !
 interface Ethernet1/3
  no ip address
  shutdown
 !
 interface Ethernet1/4
  no ip address
  shutdown
 !
 interface Ethernet1/5
  no ip address
  shutdown
 !
 interface Ethernet1/6
  no ip address
  shutdown
 !
 interface Ethernet1/7
  no ip address
  shutdown
 !
  interface Cable2/0
  ip address 192.168.1.1 255.255.255.0 secondary   
 ! CNR で CPE のスコープにセカンダリ IP アドレスが使用されています
  ip address 10.1.1.10 255.255.255.0  
 ! CNR で CM のスコープにプライマリ IP アドレスが使用されています           
  no keepalive
  cable downstream annex B             
 ! DOCSIS 互換のケーブル プラントに対するデフォルト。Euro-DOCSIS では annex A を使用します。  
  cable downstream modulation 64qam    
 !  デフォルト 
  cable downstream interleave-depth 32 
 !  デフォルト 
  cable downstream frequency 451250000 
 ! uBR7100 以外では表面的な設定です。 アップコンバータの周波数には影響ありません。 
 ! アップコンバータで使用されている周波数の覚えとして使用します。 
  cable upstream 0 frequency 28000000  
 ! アップストリーム周波数の設定。 これは、リターン パスのノイズ レベルを慎重に
 ! 解析した後で選択してください。
  cable upstream 0 power-level 0
  no cable upstream 0 shutdown  
 ! このコマンドにより、upstream 0 のポートがイネーブルになります。
  cable upstream 1 shutdown
  cable upstream 2 shutdown
  cable upstream 3 shutdown
  cable upstream 4 shutdown
  cable upstream 5 shutdown
  cable dhcp-giaddr policy             
 ! !-- DHCPDISCOVER パケットと DHCPREQUEST パケットの GIADDR フィールドを変更。
  cable helper-address 172.17.110.136  
 ! UDP ブロードキャスト DHCP パケットの宛先 IP アドレスを指定
 !
 interface Cable3/0
  no ip address
  no keepalive
  shutdown
  cable downstream annex B
  cable downstream modulation 64qam
  cable downstream interleave-depth 32
  cable upstream 0 shutdown
  cable upstream 1 shutdown
  cable upstream 2 shutdown
  cable upstream 3 shutdown
  cable upstream 4 shutdown
  cable upstream 5 shutdown
 !
 ip classless
 ip route 0.0.0.0 0.0.0.0 172.17.110.129
 no ip http server
 !
 line con 0
  exec-timeout 0 0
  transport input none
 line aux 0
 line vty 0
  exec-timeout 0 0
   transport input none
 line aux 0
 line vty 0
  exec-timeout 0 0
  password cisco
  login
 line vty 1 4
  password cisco
  login
 !
 end
 
 Sydney#


CM の設定

通常、ケーブル モデムにはオンライン状態になるためのユーザ設定は(出荷時のデフォルト設定を除き)必要ありません。 この設定は、CM がブリッジとして使用される場合にのみ該当するものです。 以下に示すものは、uBR ケーブル モデムの設定の出力であり、オンラインになった後に自動的に取得されるものです。
version 12.0
 no service pad
 service timestamps debug uptime
 service timestamps log uptime
 no service password-encryption
 !
 hostname Router
 !
 clock timezone - 0
 ip subnet-zero
 no ip routing
 !
 !
 interface Ethernet0
  ip address 10.1.1.25 255.255.255.0
  no ip directed-broadcast
  no ip route-cache
  bridge-group 59
  bridge-group 59 spanning-disabled
 !
 interface cable-modem0
  ip address negotiated
  no ip directed-broadcast
  no ip route-cache
  cable-modem downstream saved channel 453000000 20 1
  cable-modem mac-timer t2 40000
  bridge-group 59
  bridge-group 59 spanning-disabled
 !
 ip default-gateway 10.1.1.10
 ip classless
 no ip http server
 !
 !
 line con 0
  transport input none
 line vty 0 4
 !
 end
 
 Router#

検証とトラブルシューティング

次に示すコマンドは、ケーブル ネットワークの正常な動作を確認するために使用するものです。

CMTS(uBR7246)の場合

ケーブル モデムがオンラインであるようにしてください。

Sydney#show cable modem 
 Interface   Prim Online     Timing Rec    QoS CPE IP address      MAC address
             Sid  State      Offset Power
 Cable2/0/U0    online     2290   -0.25  6   1   10.1.1.25       0050.7366.2223
 

ケーブル モデムが init(d) で停止している場合は、CMTS ケーブルのインターフェイスと DHCP サーバとの間が接続されていないことを意味しています。

CMTS のケーブル インターフェイスから拡張 ping を実行できるようにするには、次の手順に従ってください。

Sydney#ping ip
 Target IP address: 172.17.110.136
 Repeat count [5]: 
 Datagram size [100]: 
 Timeout in seconds [2]: 
 Extended commands [n]: y
 Source address or interface: 10.1.1.10
 Type of service [0]: 
 Set DF bit in IP header? [no]: 
 Validate reply data? [no]: 
 Data pattern [0xABCD]: 
 Loose, Strict, Record, Timestamp, Verbose[none]: 
 Sweep range of sizes [n]: 
 Type escape sequence to abort.
 Sending 5, 100-byte ICMP Echos to 172.17.110.136, timeout is 2 seconds:
 !!!!!
 Success rate is 100 percent (5/5), round-trip min/avg/max = 8/12/24 ms
    

ping に失敗する場合は、IP ルーティングを確認してください。 また、CNR を実行している NT サーバに、デフォルト ゲートウェイと CMTS へ戻るルートが正しく設定されていることも確認してください。 CNR から ping を実行する方法もあります。

CMTS でケーブル モデムと CPE の接続性を確認するためのもう 1 つの方法は、show interface cable 2/0 modem 0 です。

 
 Sydney#show interfaces cable 2/0 modem 0
 SID   Priv bits  Type      State     IP address    method    MAC address
 2     00         host      unknown   192.168.1.20  dhcp      0010.a4e6.d04d 
 ! lP アドレスを取得しているラップトップ
 2     00         modem     up        10.1.1.25     dhcp      0050.7366.2223 
 !  ケーブル モデム


CM(uBR904)の場合

ケーブル モデム側でも接続性をチェックすることができます。 接続性の確認は、show ip interface brief コマンドでも行えます。この場合、インターフェイスが次に示すように up/up の状態であるようにします。


 
 Router#show ip interface brief
 Interface                  IP-Address      OK? Method Status                Protocol
 Ethernet0                  10.1.1.25       YES unset  up                    up    
 cable-modem0               10.1.1.25       YES unset  up                    up      
 
 
 
 Router#show controllers cable-modem 0 
 BCM Cable interface 0: 
 CM unit 0, idb 0x2010AC, ds 0x86213E0, regaddr = 0x800000, reset_mask 0x80
 station address 0050.7366.2223  default station address 0050.7366.2223
 PLD VERSION: 32
 
 
 MAC State is maintenance_state, Prev States = 15
 
 
 MAC mcfilter 01E02F00  data mcfilter 01000000
 
 
 MAC extended header ON
 DS: BCM 3116 Receiver: Chip id = 2
 US: BCM 3037 Transmitter: Chip id = 30AC
 
 
 Tuner: status=0x00
 Rx: tuner_freq 453000000, symbol_rate 5055880, local_freq 11520000
     snr_estimate 35210, ber_estimate 0, lock_threshold 26000
     QAM in lock, FEC in lock, qam_mode QAM_64
 Tx: TX_freq 27984000, power_level 0x30 (24.0 dBmV), symbol_rate 8 (1280000 sym/sec)
 
 DHCP: TFTP server = 172.17.110.136, TOD server = 172.17.110.136
       Security server = 0.0.0.0, Timezone Offest = 0
       Config filename = platinum.cm
 buffer size 1600
 
 
 RX data PDU ring with 32 entries at 0x202130
    rx_head = 0x202168 (7), rx_p = 0x8621418 (7)
 
 
 RX MAC message ring with 8 entries at 0x202270
   rx_head_mac = 0x2022A0 (6), rx_p_Mac = 0x86214BC (6)
 
 
 TX BD ring with 8 entries at 0x2023A8, TX_count = 0
   TX_head = 0x2023C8 (4), head_txp = 0x8621548 (4)
   TX_tail = 0x2023C8 (4), tail_txp = 0x8621548 (4)
 
 
 TX PD ring with 8 entries at 0x202428, TX_count = 0
   TX_head_pd = 0x202C28 (4)
   TX_tail_pd = 0x202C28 (4)
 
 
 Global control and status:
   global_ctrl_status=0x00
 interrupts:
   irq_pend=0x0008, irq_mask=0x00F7
 
 
 Router#
 
 


CM から DHCP サーバに ping を発行して、IP 接続をテストします。

Router#ping 172.17.110.136
 Type escape sequence to abort.
 Sending 5, 100-byte ICMP Echos to 172.17.110.136, timeout is 2 seconds:
 !!!!!
 Success rate is 100 percent (5/5), round-trip min/avg/max = 8/12/24 ms

uBR7246

Sydney#show version 
 Cisco Internetwork Operating System Software 
 IOS (tm) 7200 Software (UBR7200-IK1S-M), Version 12.1(2)T,  RELEASE SOFTWARE (fc1)
 Copyright (c) 1986-2000 by cisco Systems, Inc.
 Compiled Tue 16-May-00 13:36 by ccai
 Image text-base: 0x60008900, data-base: 0x613E8000
 
 ROM: System Bootstrap, Version 11.1(10) [dschwart 10], RELEASE SOFTWARE (fc1)
 BOOTFLASH: 7200 Software (UBR7200-BOOT-M), Version 12.0(10)SC, EARLY DEPLOYMENT RELEASE SOFTWARE (fc1)
 
 
 Sydney uptime is 4 days, 40 minutes
 System returned to ROM by reload
 System image file is "slot0:ubr7200-ik1s-mz_121-2_T.bin"
 
 cisco uBR7223 (NPE150) processor (revision B) with 57344K/8192K bytes of memory.
 Processor board ID SAB0249006T
 R4700 CPU at 150Mhz, Implementation 33, Rev 1.0, 512KB L2 Cache
 3 slot midplane, Version 1.0
 
 Last reset from power-on
 Bridging software.
 X.25 software, Version 3.0.0.
 8 Ethernet/IEEE 802.3 interface(s)
 1 FastEthernet/IEEE 802.3 interface(s)
 2 Cable Modem network interface(s)
 125K bytes of non-volatile configuration memory.
 1024K bytes of packet SRAM memory.
 
 
 20480K bytes of Flash PCMCIA card at slot 0 (Sector size 128K).
 4096K bytes of Flash internal SIMM (Sector size 256K).
 Configuration register is 0x2102
 
 
 Sydney#


uBR 904

Router#show version
 Cisco Internetwork Operating System Software
 IOS (TM) 900 Software (UBR900-K1OY556I-M), Version 12.0(7)T,  RELEASE SOFTWARE (fc2)
 Copyright (c) 1986-1999 by cisco Systems, Inc.
 Compiled Tue 07-Dec-99 02:01 by phanguye
 Image text-base: 0x08004000, database: 0x0852E888
 
 
 ROM: System Bootstrap, Version 11.2(19980518:195057), RELEASED SOFTWARE
 ROM: 900 Software (UBR900-RBOOT-M), Version 11.3(7)NA, EARLY DEPLOYMENT RELEASE SOFTWARE (fc1) 
 
 
 Router uptime is 1 hour, 6 minutes
 System returned to ROM by reload at 11:20:43 - Thu Oct 12 2001
 System restarted at 11:21:53 - Thu Oct 12 2001
 System image file is "flash:ubr900-k1oy556i-mz.120-7.T.bin"
 
 cisco uBR900 CM (68360) processor (revision D) with 8192K bytes of memory.
 Processor board ID FAA0315Q07M
 Bridging software.
 1 Ethernet/IEEE 802.3 interface(s)
 1 Cable Modem network interface(s)
 4096K bytes of processor board System flash (Read/Write)
 2048K bytes of processor board Boot flash (Read/Write)
         
 
 Configuration register is 0x2102
 
 Router#


CNR に関する問題をトラブルシューティングする必要がある場合の CNR デバッグの使用法の詳細は、「Cisco Network Registrar のデバッグを使用したケーブル ネットワークにおける DHCP 問題のトラブルシューティング」を参照してください。 クライアント クラスの設定については、「クライアントクラスの設定」を参照してください。


関連するシスコ サポート コミュニティ ディスカッション

シスコ サポート コミュニティは、どなたでも投稿や回答ができる情報交換スペースです。


関連情報


Document ID: 12547