アプリケーション ネットワーキング サービス : Cisco LocalDirector 400 シリーズ

LocalDirector での HTTP リダイレクションの設定方法(サーバのアベイラビリティをチェックする)

2003 年 7 月 1 日 - ライター翻訳版
その他のバージョン: PDFpdf | 機械翻訳版 (2013 年 8 月 21 日) | 英語版 (2006 年 1 月 31 日) | フィードバック

目次


概要

この文書では、Cisco LocalDirector で、サーバのアベイラビリティをチェックできる Hypertext Transfer Protocol(HTTP; ハイパーテキスト転送プロトコル)のリダイレクションの設定方法について説明します。 HTTP リダイレクションでは、直接の呼び出しやブラウズ行うために、direct IP(DIP; 直接 IP)アドレスに対する別のアドレスが必要です。

この設定の開発およびテストには、次のソフトウェアおよびハードウェアのバージョンを使用しました。

  • ラボ環境にあり、設定項目に変更のない(デフォルト設定の)LocalDirector 416
  • LocalDirector ソフトウェア リリース 4.2.1
  • Microsoft Internet Explorer 5.5
  • Netscape Communicator 4.7

この文書の情報は、特定のラボ環境にある装置に基づいて作成されています。 また、この文書で使用するデバイスは、すべて初期(デフォルト)の設定で起動しています。 実稼動中のネットワークで作業をしている場合、実際にコマンドを使用する前に、その潜在的な影響について理解しておく必要があります。

ネットワーク ダイアグラム

サーバのアベイラビリティをチェックする HTTP リダイレクションの設定方法

LocalDirector を設定するには、次の手順を使用します。

  1. 次のものに対して、「A」レコードを作成します。
     
     test.testdomain.com <-> 172.18.124.209 VIP
     
     ns-ms1-dip.testdomain.com <-> 172.18.124.212 DIP 
     
     ns-ms2-dip.testdomain.com <-> 172.18.124.211 DIP
     
     ns-ms1.cisco.com <-> 172.18.124.207 REAL 
     
     ns-ms2.cisco.com <-> 172.18.124.206 REAL
     
     172.18.124.211 DIP virtual for 172.18.124.206 REAL (aka s2)
     
     172.18.124.212 DIP virtual for 172.18.124.207 REAL (aka s1)
     
     

    注:ポートバインド型の Virtual IP(VIP; 仮想 IP)、DIP、および実アドレスが必要ですが、実サーバへの発信接続が許可されるようにするために、実アドレスごとに 2 つの IP アドレスも必要です。 これによって、 リセット(RST)が設定された安全なVIP アドレスを不良ポートへ送信することができます。 また、DIP の仮想アドレスに代替 IP アドレスを使用して、DIP アドレスへ向かう他のコールが実アドレスを直接通過するようにすることも可能です。

  2. (ポートバインド型)VIP アドレスを作成します。 Domain Name System(DNS; ドメイン ネーム システム)に「A」レコード エントリがある必要があります。
    virtual 172.18.124.209:80:0:tcp is 
     
     
  3. VIP アドレスへの呼び出しを受け入れる各「実サーバ」に対して、DIP を作成します。 この文の最初の部分には、「追加の IP 番号」を使用します。
     
     direct-ip 172.18.124.211:80:0:tcp 172.18.124.206:80:0:tcp is
     
     direct-ip 172.18.124.212:80:0:tcp 172.18.124.207:80:0:tcp is
     
     
    このシステムは次のように作成されます。
     
     real 172.18.124.207:80:0:tcp is
     
     real 172.18.124.206:80:0:tcp is
     
     bind 172.18.124.211:80:0:tcp 172.18.124.206:80:0:tcp
     
     bind 172.18.124.212:80:0:tcp 172.18.124.207:80:0:tcp
     
     
  4. それぞれの実サーバに対して、Uniform Resource Locator(URL)リダイレクションを作成します。 これは、VIP がヒットされたときに、クライアントがリダイレクトされる場所です。
     
     url s2 http://ns-ms2-dip.testdomain.com/%p 302
     
     url s1 http://ns-ms1-dip.testdomain.com/%p 302
     
     

    注: 「%p」はページを表しています。

  5. 各 DIP に対して共通の VIP を指定する backup コマンドを作成します。 これによってブックマークの問題が解決します。 クライアントがこの DIP の URL をブックマークしているとき、DIP(実サーバ)が使用不能(FAILED として起動)であると、backup コマンドによってクライアントから VIP が再度呼び出されます。
     
     backup 172.18.124.211:80:0:tcp 172.18.124.209:80:0:tcp
     
     backup 172.18.124.212:80:0:tcp 172.18.124.209:80:0:tcp
     
     

    注: HTTPS リダイレクションでは、別の方法で backup を使用します。

  6. VIP を各 URL コマンドにバインドします。

     
     bind 172.18.124.209:80:0:tcp s2
     
     bind 172.18.124.209:80:0:tcp s1
     
     
  7. 各 URL から DIP の最初の部分への link コマンドを作成します。 これにより、DIP とニックネームに関連付けられている URL との間の関係が構築されます(s1 など)。 link コマンドは、DIP が使用不可の場合に、その DIP を呼び出す URL へ LocalDirector からクライアントがリダイレクトされないようにします(DIP は実 IP アドレスによって 1 対 1 でマップされています)。
     
     link s2 172.18.124.211:80:0:tcp
     
     link s1 172.18.124.212:80:0:tcp
     
     

show コマンドとその出力例

show version コマンド

show version コマンドは、LocalDirector で実行されているソフトウェアのバージョンを表示します。

 
 localdirector# show version
 
 LocalDirector 416 Version 4.2.1

show configuration コマンド

show configuration コマンドは、LocalDirector の現在の設定を表示します。

 
 localdirector# show configuration
 
 : Saved
 
 : LocalDirector 416 Version 4.2.1
 
 syslog output 20.7
 
 no syslog console
 
 enable password 000000000000000000000000000000 encrypted
 
 hostname localdirector
 
 no shutdown ethernet 0
 
 no shutdown ethernet 1
 
 no shutdown ethernet 2
 
 interface ethernet 0 auto
 
 interface ethernet 1 auto
 
 interface ethernet 2 auto
 
 mtu 0 1500
 
 mtu 1 1500
 
 mtu 2 1500
 
 multiring all
 
 no secure  0
 
 no secure  1
 
 no secure  2
 
 ping-allow 0
 
 ping-allow 1
 
 no ping-allow 2
 
 ip address 172.18.124.210 255.255.255.0
 
 route 0.0.0.0 0.0.0.0 172.18.124.1 1
 
 arp timeout 30
 
 no rip passive
 
 rip version 1
 
 failover ip address 0.0.0.0
 
 no failover
 
 failover hellotime 30
 
 password dfeaf10390e560aea745ccba53e044ed encrypted
 
 telnet 172.18.124.0 255.255.255.0
 
 telnet 64.105.0.0 255.255.0.0
 
 snmp-server enable traps
 
 snmp-server community public
 
 no snmp-server contact
 
 no snmp-server location
 
 virtual 172.18.124.209:80:0:tcp is
 
 predictor 172.18.124.209:80:0:tcp roundrobin
 
 real 172.18.124.207:80:0:tcp is
 
 real 172.18.124.206:80:0:tcp is
 
 direct-ip 172.18.124.211:80:0:tcp   172.18.124.206:80:0:tcp is
 
 direct-ip 172.18.124.212:80:0:tcp   172.18.124.207:80:0:tcp is
 
 url s2 http://ns-ms2-dip.testdomain.com/%p 302
 
 url s1 http://ns-ms1-dip.testdomain.com/%p 302
 
 backup 172.18.124.211:80:0:tcp 172.18.124.209:80:0:tcp
 
 backup 172.18.124.212:80:0:tcp 172.18.124.209:80:0:tcp
 
 bind 172.18.124.211:80:0:tcp 172.18.124.206:80:0:tcp
 
 bind 172.18.124.212:80:0:tcp 172.18.124.207:80:0:tcp
 
 bind 172.18.124.209:80:0:tcp s2
 
 bind 172.18.124.209:80:0:tcp s1
 
 link s2 172.18.124.211:80:0:tcp
 
 link s1 172.18.124.212:80:0:tcp
 
 

show statistics コマンド

show statistics コマンドは、実サーバと仮想サーバの統計情報を表示します。

localdirector(config)# show statistics
 
           Real Machine(s)              Bytes      Packets   Connections
 
 (DIP) 172.18.124.207:80:0:tcp           1092            8             2
 
 (DIP) 172.18.124.206:80:0:tcp            960            7             1
 
 
 
 
 
        Virtual Machine(s)              Bytes      Packets   Connections
 
 (DIP) 172.18.124.211:80:0:tcp            960            7             1
 
 (DIP) 172.18.124.212:80:0:tcp           1092            8             1
 
   172.18.124.209:80:0:tcp               3296           26             2
 
 localdirector(config)#

show url コマンド

show url コマンドは、URL に関する接続情報を表示します。

 
 localdirector(config)# show url
 
 Urls:
 
 
 
              Id  Connect    Rcode   State                     Url
 
              s2        1      302     IS http://ns-ms2-dip.testdomain.com/%p
 
              s1        0      302     IS http://ns-ms1-dip.testdomain.com/%p
 
 localdirector(config)#
 
 

show syslog コマンド

show syslog コマンドは、ロギング情報(日付、時刻、レベル、出力など)を表示します。

 
 <165> May 30 11:35:14 LD-NOTICE Virtual machine '172.18.124.209:80:0:tcp': 
 
 Edited from In Service to Out Of Service.
 
 <165> May 30 11:35:24 LD-NOTICE Real machine '172.18.124.207:80:0:tcp': 
 
 Edited from In Service to Out Of Service.
 
 <165> May 30 11:35:24 LD-NOTICE Real machine '172.18.124.206:80:0:tcp': 
 
 Edited from In Service to Out Of Service.
 
 <165> May 30 11:35:28 LD-NOTICE Real machine '172.18.124.207:80:0:tcp': 
 
 Edited from Out Of Service to In Service.
 
 <162> May 30 11:35:28 LD-CRIT Switching '172.18.124.212:80:0:tcp' 
 
 from 'leastconns' to 'slowstart'
 
 <165> May 30 11:35:28 LD-NOTICE Real machine '172.18.124.206:80:0:tcp': 
 
 Edited from Out Of Service to In Service.
 
 <162> May 30 11:35:28 LD-CRIT Switching '172.18.124.211:80:0:tcp' 
 
 from 'leastconns' to 'slowstart'
 
 <165> May 30 11:35:34 LD-NOTICE Virtual machine '172.18.124.209:80:0:tcp': 
 
 Edited from Out Of Service to In Service.
 
 <162> May 30 11:36:23 LD-CRIT Switching '172.18.124.212:80:0:tcp' 
 
 from 'slowstart' to 'leastconns'
 
 <162> May 30 11:41:24 LD-CRIT Switching '172.18.124.211:80:0:tcp' 
 
 from 'slowstart' to 'leastconns'
 
   

設定の検証

設定を確認するには、次のコマンドを使用します。

  • show real : 実サーバの統計情報と状態を表示します。

  • show virtual : 仮想サーバのリスト、その状態、接続の数、およびロード バランシングのアルゴリズムを表示します。

  • show statistics上記を参照してください。.

設定のトラブルシューティング

syslog コマンド

syslog [host ip | console | output facility.level] コマンドは、デバッグまたはトラブルシューティングの目的で使用できます。

この例では、http://test.testdomain.com が http://ns-ms2-dip.testdomain.com/ にリダイレクトされています。

次の例は、syslog console および syslog output 20.7 から出力されたものです。

 
 localdirector(config)# syslog console
 
 localdirector(config)# <162> May 30 11:36:23 LD-CRIT Switching '172.18.124.212:80:0:tcp'
 
  from 'slowstart' to 'leastconns'
 
 localdirector(config)# <162> May 30 11:41:24 LD-CRIT Switching '172.18.124.211:80:0:tcp'
 
  from 'slowstart' to 'leastconns'  


関連するシスコ サポート コミュニティ ディスカッション

シスコ サポート コミュニティは、どなたでも投稿や回答ができる情報交換スペースです。


関連情報


Document ID: 46222