Cisco インターフェイスとモジュール : ???? ?????

コンテント スイッチ モジュールでの透過キャッシュの設定

2002 年 10 月 30 日 - ライター翻訳版
その他のバージョン: PDFpdf | 機械翻訳版 (2013 年 8 月 21 日) | 英語版 (2006 年 1 月 30 日) | フィードバック

目次


概要

この文書では、Cisco Cache Engine を使用した、コンテント スイッチ モジュールでの透過キャッシュの設定方法について説明します。 透過キャッシュは、ユーザとサーバの間に位置します。 コンテント スイッチ モジュール(CSM)は、ユーザとキャッシュの間に導入されます。 CSM はレイヤ 5 の機能によってコンテンツを動的に解析し、キャッシュが可能かどうかを判断するという高度な機能を備えています。
  • コンテンツがキャッシュ可能であれば、CSM は、設定されているプレディクタをベースにして、そのキャッシュ サービスに対する要求のロード バランスを行います。
  • キャッシュが不可能な場合は、CSM は要求を元のサーバに直接送信します。したがって、キャッシュ不可能なオブジェクトがキャッシュに送られても、キャッシュから要求が元のサーバにリダイレクトされるだけであり、効率がよくなることはありません。
キャッシュ上にデータをどのように配分するかによって、いくつかのバランシング方法があります(たとえば、URL 全体、URL ストリングなど)。

キャッシュへ送るファイル拡張子のリストを使用して CSM を設定することもできます。 このリストは Extension Qualifier List(EQL; 拡張子修飾子リスト)といいます。 vserver TRANSPARENT で slb-policy CACHE-POLICY を設定すると、マップ CACHEABLE url リストに登録されているファイル拡張子をもつ要求だけがキャッシュに送られます。 マップ CACHEABLE url リストにリストされたファイル拡張子がリストから外されると、要求は slb-policy NONCACHE-POLICY にヒットするようになります。

ハードウェアおよびソフトウェアのバージョン

この構成は、次に示すソフトウェアとハードウェアのバージョンを使用して作成およびテストされたものです。
  • MSFC1 を搭載したスーパバイザ エンジン 1 用(c6sup11-dsv-mz.121-8a.EX) の Catalyst 6000 ファミリ スーパーバイザ Cisco IOS(R) ソフトウェア リリース 12.1(8)EX
  • Catalyst 6000 ファミリ CSM ソフトウェア リリース 2.1(2)(c6slb-apc.2-1-2.bin)
  • Cisco Cache Engine 550、Cisco Cache Software リリース 2.5.1 を実行

ネットワーク ダイアグラム

Network Diagram
>>画像拡大

設定

注: !--- コメントを青字で表示します。
 
コンテント スイッチ モジュールの設定
Current configuration:
cat#sh run
Building configuration...

Current configuration : 4500 bytes
!
version 12.1
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname cat
!
boot buffersize 126968
enable password cisco
!
redundancy
 main-cpu
  auto-sync standard
ip subnet-zero
!
!
ip name-server 10.107.241.185
!
!--- コンテント スイッチ モジュールはスロット 3 にあります。 モジュールはアクティブとして動作中です。
!--- キャッシュおよびクライアント側は同じ CSM vlan100 にあります。
!--- エンド ユーザは CSM vlan 200 上にあります。
!
module ContentSwitchingModule 3 
 vlan 100 client
  ip address 10.107.249.251 255.255.255.248
  gateway 10.107.249.249
!
 vlan 200 server
  ip address 10.107.249.251 255.255.255.248
!
!--- 設定を調査し、キャッシュ エンジンが使用可能かどうかを 確認します。 
!--- デフォルトのプローブ値。 300 秒間隔
!
 probe CACHEPROBE tcp
!
!--- Serverfarm CACHE
!--- 注: nat サーバは使用しません。 CSM はレイヤ 2 の 書き換えを行う必要があります。
!--- バランシング プレディクタはハッシュ url です。 
!
 serverfarm CACHE
  no nat server 
  no nat client
  predictor hash url
  real 10.107.249.254
   inservice
  real 10.107.249.252
   inservice
  probe CACHEPROBE
!
!--- Serverfarm OUTBOUND
!--- 注: Serverfarm OUTBOUND を使用して、キャッシュを バイパスします。
!--- CACHEABLE url リストに一致しない要求は、 Serverfarm OUTBOUND を使用します
!--- 実サーバが設定されていないため、Nat サーバに 影響はありません。
!--- バランシング プレディクタの転送
!
 serverfarm OUTBOUND
  nat server 
  no nat client
  predictor forward
!
!--- CACHEABLE url のマップ
!--- 拡張子修飾子リスト(EQL)
!
 map CACHEABLE url
  match protocol http url *.pdf
  match protocol http url *.fdf
  match protocol http url *.au
  match protocol http url *.bmp
  match protocol http url *.z
  match protocol http url *.gif
  match protocol http url *.html
  match protocol http url *.js
  match protocol http url *.mocha
  match protocol http url *.jpeg
  match protocol http url *.jpg
  match protocol http url *.jpe
  match protocol http url *.jfif
  match protocol http url *.pjpeg
  match protocol http url *.pjp
  match protocol http url *.mp2
  match protocol http url *.mpa
  match protocol http url *.abs
  match protocol http url *.mpeg
  match protocol http url *.mpg
  match protocol http url *.mpe
  match protocol http url *.mpv
  match protocol http url *.vbs
  match protocol http url *.m1v
  match protocol http url *.pcx
  match protocol http url *.txt
  match protocol http url *.text
  match protocol http url *.mov
  match protocol http url *.tiff
  match protocol http url *.tar
  match protocol http url *.avi
  match protocol http url *.wav
  match protocol http url *.gz
  match protocol http url *.zip
!
 map NONCACHABLE url
  match protocol http url *
!
 policy CACHE-POLICY
  url-map CACHEABLE
  serverfarm CACHE
!
 policy NONCACHE-POLICY
  url-map NONCACHABLE
  serverfarm OUTBOUND
!
!--- Vserver TRANSPARENT
!--- 注: 仮想 IP はすべてゼロです。
!--- HTTP 1.1 に persistence rebalance を使用します。
!--- parse-lengh を 2000 バイトに設定します。
!--- vserver TRANSPARENT に 2 つのポリシーを追加します。
!
 vserver TRANSPARENT
  virtual 0.0.0.0 0.0.0.0 tcp www
  serverfarm CACHE
  persistent rebalance
  parse-length 2000
  slb-policy CACHE-POLICY
  slb-policy NONCACHE-POLICY
  inservice
!
!--- フォールト トレランス グループ 1 は、
!--- モジュール 3 と 4 との間の冗長性を設定するために使用します。
!
 ft group 1 vlan 250 
  priority 20 
!
!--- コンテント スイッチ モジュールはスロット 4 にあります。 モジュールはスタンバイとして動作中です。
!--- キャッシュおよびクライアント側は同じ CSM vlan100 にあります。
!--- エンド ユーザは CSM vlan 200 上にあります。
!--- 注: モジュール 3 および 4 の vlan ip アドレスは異なります。 
!
module ContentSwitchingModule 4 
 vlan 100 client
  ip address 10.107.249.253 255.255.255.248
  gateway 10.107.249.249
!
 vlan 200 server
  ip address 10.107.249.253 255.255.255.248
!
!--- 設定を調査し、キャッシュ エンジンが使用可能かどうかを 確認します。 
!--- デフォルトのプローブ値。 300 秒間隔
!
 probe CACHEPROBE tcp
!
!--- Serverfarm CACHE
!--- 注: nat サーバは使用しません。 CSM はレイヤ 2 の 書き換えを行う必要があります。
!--- バランシング プレディクタはハッシュ url です。 
!
 serverfarm CACHE
  no nat server 
  no nat client
  predictor hash url
  real 10.107.249.254
   inservice
  real 10.107.249.252
   inservice
  probe CACHEPROBE
!
!--- Serverfarm OUTBOUND
!--- 注: Serverfarm OUTBOUND を使用して、キャッシュを バイパスします。
!--- CACHEABLE url リストに一致しない要求は、 Serverfarm OUTBOUND を使用します。
!--- 実サーバが設定されていないため、Nat サーバに 影響はありません。
!--- バランシング プレディクタの転送
!
 serverfarm OUTBOUND
  nat server 
  no nat client
  predictor forward
!
!--- CACHEABLE url のマップ
!--- 拡張子修飾子リスト(EQL)
!
 map CACHEABLE url
  match protocol http url *.pdf
  match protocol http url *.fdf
  match protocol http url *.au
  match protocol http url *.bmp
  match protocol http url *.z
  match protocol http url *.gif
  match protocol http url *.html
  match protocol http url *.js
  match protocol http url *.mocha
  match protocol http url *.jpeg
  match protocol http url *.jpg
  match protocol http url *.jpe
  match protocol http url *.jfif
  match protocol http url *.pjpeg
  match protocol http url *.pjp
  match protocol http url *.mp2
  match protocol http url *.mpa
  match protocol http url *.abs
  match protocol http url *.mpeg
  match protocol http url *.mpg
  match protocol http url *.mpe
  match protocol http url *.mpv
  match protocol http url *.vbs
  match protocol http url *.m1v
  match protocol http url *.pcx
  match protocol http url *.txt
  match protocol http url *.text
  match protocol http url *.mov
  match protocol http url *.tiff
  match protocol http url *.tar
  match protocol http url *.avi
  match protocol http url *.wav
  match protocol http url *.gz
  match protocol http url *.zip

 map NONCACHABLE url
  match protocol http url *
!
 policy CACHE-POLICY
  url-map CACHEABLE
  serverfarm CACHE
!
 policy NONCACHE-POLICY
  url-map NONCACHABLE
  serverfarm OUTBOUND
!
!--- Vserver TRANSPARENT
!--- 注: 仮想 IP はすべてゼロです。
!--- HTTP 1.1 に persistence rebalance を使用します。
!--- parse-lengh を 2000 バイトに設定します。
!--- vserver TRANSPARENT に 2 つのポリシーを追加します。
!
 vserver TRANSPARENT
  virtual 0.0.0.0 0.0.0.0 tcp www
  serverfarm CACHE
  persistent rebalance
  parse-length 2000
  slb-policy CACHE-POLICY
  slb-policy NONCACHE-POLICY
  inservice
!
!--- フォールト トレランス グループ 1 は、
!--- モジュール 3 と 4 との間の冗長性を設定するために使用します。
!
 ft group 1 vlan 250 
!
interface GigabitEthernet1/1
 no ip address
 shutdown
!
interface GigabitEthernet1/2
 no ip address
 shutdown

!--- CSM クライアント側の vlan
!--- インターネットへのアップリンク
!
interface FastEthernet2/1
 no ip address
 switchport
 switchport access vlan 100
!
interface FastEthernet2/2
 no ip address
 shutdown
!
!--- Fa2/3 および Fa2/4 へ接続されているキャッシュ エンジン 
!--- CSM クライアント側の vlan
!
interface FastEthernet2/3
 no ip address
 duplex full
 speed 100
 switchport
 switchport access vlan 100
!
interface FastEthernet2/4
 no ip address
 duplex full
 speed 100
 switchport
 switchport access vlan 100

!--- CSM サーバー側の vlan
!--- エンド ユーザへの接続

interface FastEthernet2/5
 no ip address
 switchport
 switchport access vlan 200
!
!--- MSFC vlan 100
!--- キャッシュ エンジンとクライアントがデフォルト ゲートウェイとしてこのアドレスを使用します。
!
interface Vlan100
 ip address 10.107.249.250 255.255.255.248
!
ip classless
ip route 0.0.0.0 0.0.0.0 10.107.249.249
no ip http server
!
line con 0
line vty 0 4
password cisco
login
!
end
!

 

キャッシュ エンジンの設定
Building configuration...
Current configuration:
!
user add admin uid 0  capability admin-access
!
hostname ce1
!
interface ethernet 0
 ip address 10.107.249.254 255.255.255.248
 ip broadcast-address 10.107.249.255
 bandwidth 100
 fullduplex
 exit
!
interface ethernet 1
 exit
!
ip default-gateway 10.107.249.250
ip name-server 10.107.241.185
ip domain-name cisco.com
ip route 0.0.0.0 0.0.0.0 10.107.249.250
cron file /local/etc/crontab
!
!--- http proxy incoming 80 をイネーブルにします。 
!--- http l4-switching がキャッシュ上でイネーブルにされている必要があります。
!
http proxy incoming 80
http l4-switch enable
!
authentication login local enable
authentication configuration local enable
rule no-cache url-regex .*cgi-bin.*
rule no-cache url-regex .*aw-cgi.*
!
end
ce1#

debug および show コマンド

debug コマンドを発行する前に、「debug コマンドに関する重要な情報」を参照してください。

CSM の debug コマンドと show コマンドは次のとおりです。

コマンドは、cat#show module csm 3 (コマンド) の形で使用します。

  • arp -- SLB arp キャッシュのリスト
  • conns --  SLB 接続の情報
  • dfp --  SLB DFP マネージャの情報
  • ft --  SLB ft の情報
  • map --  SLB マップの情報
  • memory --  SLB メモリの情報
  • natpools --  SLB クライアントの nat プールの情報
  • policy --  SLB ポリシーの情報
  • probe --  SLB プローブの情報
  • reals --  SLB の実サーバの情報
  • serverfarms --  SLB サーバ ファームの情報
  • static --  SLB スタティック サーバの NAT の情報
  • stats --  SLB の統計情報
  • status --  SLB ステータスの情報
  • sticky --  SLB スティッキ データベース
  • sticky --  SLB スティッキ データベース
  • tech-support --  SLB の技術的なデバッグ情報
  • vlan --  SLB vlan の情報
  • vservers --  SLB 仮想サーバの情報
CSM  フォールト トレランス情報

cat#show module csm 3 ft
FT group 1, vlan 250
 This box is active
 priority 20, heartbeat 1, failover 3, preemption is off

cat#show module csm 4 ft
FT group 1, vlan 250
 This box is in standby state
 priority 10, heartbeat 1, failover 3, preemption is off

CSM vserver の詳細情報

cat#show module csm 3 vservers name transparent detail
TRANSPARENT, state = OPERATIONAL, v_index = 10
  virtual = 0.0.0.0/0:80, TCP, service = NONE, advertise = FALSE
  idle = 3600, replicate csrp = none, vlan = ALL
  max parse len = 2000, persist rebalance = TRUE
  conns = 0, total conns = 47
  Default policy:
    server farm = CACHE
    sticky: timer = 0, subnet = 0.0.0.0, group id = 0
  Policy           Tot Conn     Client pkts  Server pkts
  ------------------------------------------------------
  CACHE-POLICY     44           249          203
  NONCACHE-POLICY  37           111          37
  (default)        0            0            0

コマンドの要約

CSM に透過キャッシングを設定するために使用するコマンド

設定する CSM の位置を指定します。

次のコマンドを使用します。

cat(config)#module csm ?
<1-6>  CSM モジュールがあるスロット

仮想サーバを設定します。

cat(config-module-csm)#vserver proxy
cat(config-slb-vserver)#?

  • advertise --  仮想 IP アドレスをアドバタイズする
  • client --  クライアントの IP アドレス
  • default -- コマンドをデフォルトに設定する
  • exit --  サーバのロード バランシングのサブモードを終了
  • idle --  アイドル タイマー
  • inservice --  この仮想サーバに対するサービスを有効にする
  • no --  コマンドの取り消し、またはコマンドをデフォルトに設定
  • parse-length --  最大 L7 の 解析長
  • persistent --  固定接続をイネーブルまたはディセーブルにする
  • replicate --  vserver のフォールト トレランスの複製を設定
  • serverfarm --  実サーバのファーム
  • slb-policy --  サーバのロード バランシング ポリシー
  • sticky --  スティッキ タイマー
  • url-hash --  url ハッシュ アルゴリズムに一致するプレフィクス/サフィクスを設定
  • virtual --  仮想サーバを設定
serverfarm の設定

cat(config-module-csm)#serverfarm cache
cat(config-slb-sfarm)#?
 

  • bindid --  DFP のためのバインド ID
  • default --  コマンドをデフォルトに設定する
  • exit --  slb サーバのファーム サブモードを終了
  • failaction --  実サーバに障害が発生したときにとるアクション
  • nat --  SLB に対するアドレス変換
  • no --  コマンドの取り消し、またはコマンドをデフォルトに設定
  • predictor --  ロード バランシングの予測アルゴリズム
  • probe --  プローブを使用
  • real --  実サーバを設定
  • redirect-vserver --  SLB リダイレクトの仮想サーバを設定

キャッシュからのサンプル出力

キャッシュ エンジンからの節約率を表示

ce1#show statistics http savings

                          Statistics - Savings
                       Requests           Bytes
-----------------------------------------------------------
Total:               635                   2764599
Hits:                 113                   254517
Miss:                505                   2483555
Savings:            17.8 %              9.2 %

113 回のヒットがあったことが分かります。


関連するシスコ サポート コミュニティ ディスカッション

シスコ サポート コミュニティは、どなたでも投稿や回答ができる情報交換スペースです。


関連情報


Document ID: 19680