Cisco インターフェイスとモジュール : ???? ?????

CSM でのセキュア(ルータ)モードの設定

2003 年 1 月 15 日 - ライター翻訳版
その他のバージョン: PDFpdf | 機械翻訳版 (2013 年 8 月 21 日) | 英語版 (2004 年 5 月 3 日) | フィードバック

目次

概要
はじめに
     表記法
     前提条件
     使用するコンポーネント
操作モード
ネットワーク ダイアグラム
設定
show コマンド
     show module csm [slot#] status コマンド
     show module csm [slot#] vserver コマンド
     show module csm [slot#] reals コマンド
     show module csm [slot#] serverfarm コマンド
     show module csm [slot#] vlan コマンド
トラブルシューティング
関連するシスコ サポート コミュニティ ディスカッション
関連情報

概要

Content Switching Module(CSM; コンテント スイッチ モジュール)では、ネットワーク ユーザとサーバ ファーム間での高パフォーマンスの接続を、レイヤ 4 から 7 の情報に基づいて実現します。 実サーバのグループ(サーバ ファーム)を 1 つのサーバのインスタンス(仮想サーバ)として表現し、サーバのロード バランシング方法のいずれかを選択してサーバへのトラフィックのバランスを取り、個々のサーバ(スティッキ接続)やサーバ ファーム(ポリシー)へのトラフィックを制限します。 この設定例では、Catalyst 6000 ファミリの CSM における server load balancing(SLB; サーバ ロード バランシング)の設定方法について説明します。

はじめに

表記法

文書の表記法の詳細は、「シスコ テクニカル ティップスの表記法」を参照してください。

前提条件

この文書に関する特別な前提条件はありません。

使用するコンポーネント

この文書の情報は、次のソフトウェアとハードウェアのバージョンに基づいています。

  • MSFC1 を搭載したスーパバイザ エンジン 1 用(c6sup11-jsv-mz.121-8.EX) Catalyst 6000 ファミリ スーパーバイザ IOS ソフトウェア リリース 12.1(8)EX

  • Catalyst 6000 ファミリ CSM ソフトウェア リリース 2.1(0)(c6slb-apc.2-1-1.bin)

CSM は、Cisco IOS リリース 12.1(6)E 以降で動作します。 スーパーバイザ エンジン 2 を使用している場合は、Cisco IOS リリース 12.1(8a)E 以降を使用する必要があります。

操作モード

CSM を介したクライアントとサーバの接続では、レイヤ 2 またはレイヤ 3 スイッチングを使用できます。 クライアントは、クライアント側の VLAN に接続し、サーバはサーバ側の VLAN に接続します。 サーバとクライアントは異なるサブネット上にあります。 サーバは、1ホップ以上離れた場所に位置しており、ルータを経由してサーバ側の VLAN に接続することもできます。 この場合、サーバのデフォルト ゲートウェイと、サーバから CSM サーバ側の VLAN へのネットワークを介したルーティングは、サーバから CSM を介してすべてのロード バランスされたトラフィックを送り出すか、サーバ ファームのクライアント NAT を、サーバ ファーム内のサーバ宛のすべてのトラフィック用に CSM で設定する必要があります。 クライアントは要求を VIP アドレス宛てに送信し、CSM ではこの要求を満たすことのできるサーバに自動転送します。  サーバは CSM に応答を自動転送します。 CSM はクライアントに応答を自動転送します。

クライアント側とサーバ側の VLAN が異なるサブネット上にある場合は、CSM をセキュア(ルータ)モードに設定できます。 この設定例では、「セキュア(ルータ)モードの設定」について説明します。 クライアント側とサーバ側の VLAN が同じサブネット上にある場合は、CSM をシングル サブネット(ブリッジ)モードで動作するように設定できます。 設定例については、「シングル サブネット(ブリッジ)モードの設定」を参照してください。

ネットワーク ダイアグラム

セキュア(ルータ)モードでは、クライアント側とサーバ側の VLAN が異なるサブネット上にあります。 このダイアグラムでは、セキュア(ルータ)モードの設定の設定方法を示しています。

csm_router.gif
>>画像拡大

設定

コンテント スイッチ モジュールをセキュア(複数サブネット)モードに設定するには、次のようにします。

  1. linecard module configuration にはいります。

    cat(config)# module csm [slot #]
  2. クライアントとサーバの VLAN をデータベース内に作成します。 既存の vlan データベース モードで、設定変更が適用されます。

    cat# vlan database
    cat(vlan)# vlan 100
    VLAN 100 added: Name: VLAN0100
    cat(vlan)# vlan 200
    VLAN 200 added: Name: VLAN0200
    cat(vlan)# exit
    APPLY completed.
    Exiting....
     
  3. クライアントに接続する物理インターフェイス(アップリンク)を対応する VLAN に対して設定します。

    cat(config)# inter fastEthernet 2/1
    cat(config-if)# switchport 
    cat(config-if)# switchport access vlan 100 
    cat(config-if)# no shut
    
  4. サーバに接続する物理インターフェイスを対応する VLAN に対して設定します。

    cat(config)# inter fastEthernet 2/3 
    cat(config-if)# switchport
    cat(config-if)# switchport access vlan 200 
    cat(config-if)# no shutdown 
    cat(config)# inter fastEthernet 2/4
    cat(config-if)# switchport 
    cat(config-if)# switchport access vlan 200
    cat(config-if)# no shutdown
    
  5. クライアント側の VLAN とゲートウェイを作成します。

    cat(config-module-csm)#vlan 100 client
    cat(config-slb-vlan-client)#ip address 172.17.63.217 255.255.255.192
    cat(config-slb-vlan-client)#gateway 172.17.63.210
    
  6. サーバ側の VLAN を作成します。

    cat(config-slb-vlan-client)#vlan 200 server
    cat(config-slb-vlan-server)#ip address 10.1.1.251 255.255.255.0
    cat(config-slb-vlan-server)#alias 10.1.1.250 255.255.255.0
    
  7. Serverfarm を作成します。

    cat(config-slb-vlan-server)#serverfarm WWWFARM
    cat(config-slb-sfarm)#real 10.1.1.3
    cat(config-slb-real)#inservice
    cat(config-slb-real)#real 10.1.1.5
    cat(config-slb-real)#inservice
    
  8. Vserver を作成し、serverfarm に関連付けます。

    cat(config-slb-real)#vserver SERVER
    cat(config-slb-vserver)#virtual 172.17.63.241 tcp www
    cat(config-slb-vserver)#serverfarm WWWFARM
    cat(config-slb-vserver)#inservice
    

Cisco Catalyst 6500 と CSM を使用したサーバのロード バランシングの設定例を次に示します。

CSM (WS-X6066-SLB-APC) の実行設定

Current configuration : 3791 bytes
!
version 12.1
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname cat
!
boot buffersize 126968
boot system flash slot0:c6sup11-jsv-mz.121-8.EX.bin
!
redundancy
 main-cpu
  auto-sync standard
ip subnet-zero
!



!--- linecard configuration mode
module ContentSwitchingModule 2

!--- クライアント側の VLAN 設定
!--- 重要: ゲートウェイアドレスは VLAN 100 のインターフェイスを指しています。

vlan 100 client
 ip address 172.17.63.217 255.255.255.192
 gateway 172.17.63.210
!

!--- サーバ側の VLAN 設定。

vlan 200 server
 ip address 10.1.1.251 255.255.255.0
 alias 10.1.1.250 255.255.255.0
!

!--- Serverfarm の設定。

serverfarm WWWFARM
 nat server
 no nat client
real 10.1.1.3
  inservice
 real 10.1.1.5
  inservice
!

!--- VServerの設定。

vserver SERVER
 virtual 172.17.63.241 tcp www
 serverfarm WWWFARM
 persistent rebalance
 inservice
!
interface GigabitEthernet1/1
 no ip address
 shutdown
!
interface GigabitEthernet1/2
 no ip address
 shutdown
!



!--- FastEthernet 2/1 に接続されたクライアント(アップリンク)。 

interface FastEthernet2/1
 no ip address
 switchport
 switchport access vlan 100
 switchport mode access
!
interface FastEthernet2/2
 no ip address
 shutdown
!

 

!--- FastEthernet 2/3 および 2/4 に接続されたサーバ。

  
interface FastEthernet2/3
 no ip address
 switchport
 switchport access vlan 200
 switchport mode access
!
interface FastEthernet2/4
 no ip address
 switchport
 switchport access vlan 200
 switchport mode access ...
interface FastEthernet2/48
 no ip address
 shutdown
!
interface Vlan1
 no ip address
 shutdown
!
interface Vlan100
 ip address 172.17.63.210 255.255.255.192
!
ip default-gateway 172.17.63.193
ip classless
ip route 0.0.0.0 0.0.0.0 172.17.63.193
no ip http server
!
line con 0
line vty 0 4
 login
!
end

show コマンド

注: 一部の show コマンドは、アウトプットインタープリタ登録ユーザのみ)でサポートされています。このツールを使用すると、show コマンドの出力を分析できます。

show module csm [slot#] status コマンド

show module csm [slot#] status コマンドでは、SLB モジュールのステータスが表示されます。モジュールはオンライン状態であることが必要です。

 cat#show module csm 2 status
 SLB Module is online in slot 2.
 Configuration Download state: COMPLETE, SUCCESS

show module csm [slot#] vserver コマンド

Show module csm [slot#] vserver コマンドでは、仮想サーバの情報が表示されます。以下では、仮想サーバの状態と接続の数も分かります。

cat#show module csm 2 vserver
vserver         type  prot virtual                  vlan state        conns
---------------------------------------------------------------------------
SERVER          SLB   TCP  172.17.63.241/32:80      ALL  OPERATIONAL  0

show module csm [slot#] reals コマンド

show module csm [slot#] reals コマンドでは、それぞれの実サーバの情報が表示されます。表示される情報には、それぞれのサーバが位置するサーバ ファーム、サーバの状態、しきい値、および接続などが含まれます。

cat#show module csm 2 reals
real                  server farm      weight  state          conns/hits
-------------------------------------------------------------------------
10.1.1.3              WWWFARM          8       OPERATIONAL    0
10.1.1.5              WWWFARM          8       OPERATIONAL    0

show module csm [slot#] serverfarm コマンド

show module csm [slot#] serverfarm コマンドでは、サーバ ファームの情報が表示されます。 このコマンドでは、ロード バランシングに使用されているプレディクタが表示されます。 この例では、デフォルトのラウンドロビンが使用されています。

cat#show module csm 2 serverfarm
server farm      type     predictor    nat   reals   redirect  bind id
----------------------------------------------------------------------
WWWFARM          SLB      RoundRobin   S     2       0         0



 

show module csm [slot#] vlan コマンド

show module csm [slot#] vlan コマンドでは、クライアントとサーバに関する VLAN 情報が表示されます。

cat#show module csm 2 vlan
vlan   IP address       IP mask          type
---------------------------------------------------
100    172.17.63.217    255.255.255.192  CLIENT
200    10.1.1.251       255.255.255.0    SERVER



 

トラブルシューティング

Cat 6500 から ping module csm [slot#] コマンドを使用して、実サーバにのみ ping を送ることができます。

 cat6#ping module csm 2 10.1.1.3
 IP address       Reachable
 --------------------------
 10.1.1.3         Yes
 

関連するシスコ サポート コミュニティ ディスカッション

シスコ サポート コミュニティは、どなたでも投稿や回答ができる情報交換スペースです。


関連情報


Document ID: 5448