非同期転送モード(ATM) : IP-ATM 間サービス クラス

ブリッジド ATM PVC での QoS サービス ポリシーと CBWFQ/LLQ の適用

2008 年 1 月 25 日 - ライター翻訳版
その他のバージョン: PDFpdf | 機械翻訳版 (2012 年 6 月 18 日) | 英語版 (2008 年 2 月 15 日) | フィードバック

目次


概要

この文書では、RFC 1483 leaving cisco.com ブリッジフォーマットの Protocol Data Unit(PDU; プロトコル データ ユニット)を受け入れるよう設定された ATM インターフェイスでの、Class-Based Weighted Fair Queueing(CBWFQ; クラスベース均等化キューイング)や Low Latency Queueing(LLQ; 低遅延キューイング)などの、高度なキューイング オプションの設定例を説明します。

Cisco IOS(R) ソフトウェアは、RFC 1483 ブリッジ アプリケーションにおいて(異なる IP ネットワーク番号に対する)オフネットワークをルーティングするための、3 つのプロトコルをサポートしています。これらのプロトコルは、Integrated Routing and Bridging(IRB)、Route-Bridge Encapsulation(RBE)、ブリッジ型の Permanent Virtual Circuit(PVC; 相手先固定接続)です。これらすべてのプロトコルにより、ATM PVC はブリッジフォーマットの PDU を受信することができます。この文書では、ブリッジ プロトコルを使用して設定された PVC を、ブリッジド PVC と呼びます。

モジュラ Quality of Service(QOS)Command Line Interface(CLI; コマンドライン インターフェイス)(MQC)を使用して設定されたサービス ポリシーは、QoS メカニズムを、インターフェイス、サブインターフェイス、または VC に適用します。ブリッジド PVC では、高度なキューイング メカニズムを適用するサービス ポリシーは、RBE でのみサポートされています。IRB を実行するよう設定された ATM VC のサービス ポリシーは、サポートされていません。このような VC では、IP Access Control List(ACL; アクセス コントロール リスト)に基づいたマッチングを行う class-map を定義した場合、このクラスとのパケットのマッチングは発生せず、すべてのパケットはデフォルト クラスに分類されます。

表記法

文書の表記法の詳細は、「シスコ テクニカル ティップスの表記法」を参照してください。

背景理論

QoS サービス ポリシーは、キュー項目数を管理し、トラフィックをマークし、VC 単位でクリティカルでないトラフィックを識別します。特に、次の目的を達成します。

  • Network Based Application Recognition(NBAR)を使用して、Napster などのビジネス クリティカルではないトラフィックを分類する。
  • Weighted Random Early Detection(WRED; 重み付けランダム早期検出)を適用して、キュー項目数を管理する。

    注:service-policy output コマンドと random-detect-group コマンドは、PVC のレベルでは、互いに排他的で同時には使用できません。サービス ポリシーの適用によって CBWFQ を有効にした VC に、WRED グループを適用することはできません。ただし、ポリシーマップ 内部のクラスで random-detect コマンドを設定することで、両方の機能を適用できます。

  • set コマンドを使用し、トラフィック タイプに基づいて次の IP 優先順位値をマークして、クラスベースのマーキングを適用する。

    優先順位値 トラフィック タイプ
    1 Napster などの非ビジネス クリティカル
    4 デフォルト、通常のトラフィックに使用。
    5 Voice over IP(VoIP)などの将来のリアルタイム トラフィック用に予約済。
    6 および 7 ネットワーク制御トラフィック用に予約済。

輻輳が発生しうるポイントは、DSL 接続ユーザに情報を供給する ATM VC です。IP フローは、最大 100 Mbps でファースト イーサネット インターフェイスに着信し、ATM VC から外部に送出されます。これらは、T1 インターフェイス(1.544 Mbps)のデフォルトの Peak Cell Rate(PCR; ピーク セルレート)を使用して、Unspecified Bit Rate(UBR; 未指定ビット レート)ATM サービス カテゴリ用に設定されています。したがって、QoS service-policy により、ファースト イーサネット インターフェイスに着信するトラフィックがマークされます。 続いて、マークされた値は、IP 優先順位に基づいてサービス クラスを作成し、クラスごとの固有の廃棄レベルを介して差別化サービスを提供するため、WRED により使用されます。

設定

この項では、この文書で説明する機能を設定するために必要な情報を提供します。

注:この文書で使用されているコマンドの詳細を調べるには、「Command Lookup ツール」を使用してください(登録済みのユーザ専用)。

前提条件

設定を開始する前に、次の前提条件を満たしていることを確認してください。

制約事項

IRB の設定では、VC 単位の CBWFQ または LLQ はサポートされません。  CBWFQ または LLQ の実装を試みる前に、設定を移行する必要があります。

使用するコンポーネント

この設定は、次のソフトウェアとハードウェアのバージョンを使用して作成およびテストされています。

  • 4 ポート ATM Inverse Multiplexing over ATM(IMA; ATM 逆多重化)ネットワーク モジュールを搭載した Cisco 2620 ルータ。この設定では、1 つの ATM T1 インターフェイスを、IMA 機能を持たないストレート T1 として使用します。
  • Cisco IOS ソフトウェア リリース 12.2(7a)。

この文書の情報は、特定のラボ環境にあるデバイスに基づいて作成されています。また、この文書で使用するデバイスは、すべて初期(デフォルト)の設定で起動しています。実稼動中のネットワークで作業をしている場合、実際にコマンドを使用する前に、その潜在的な影響について理解しておく必要があります。

ネットワーク ダイアグラム

この文書では次の図に示すネットワーク設定を使用しています。

Network Diagram

注:UBR サービス カテゴリの ATM VC は、定義上、最小帯域幅を提供しません。 そのため、CBWFQ または LLQ を適用して UBR VC に帯域幅を保証することはできません。帯域幅を保証するには、ATM サービス カテゴリを、VBR-nrt や ABR など、UBR 以外のものに変更する必要があります。

設定

この文書で使用する設定を次に示します。

Cisco 2600 ルータ
  
  class-map match-any HTTP-HACKS  
  
     match protocol http url "*.ida*"  
  
     match protocol http url "*cmd.exe*"  
  
     match protocol http url "*root.exe*"  
  
     match protocol http url "*Admin.dll*"  
  
     match protocol http url "*readme.eml*"  
  
  class-map match-any JUNK  
  
     match protocol napster  
  
     match protocol fasttrack  
  
  class-map DEFAULT 
  
     match ip any 
  
  ! 
  
  policy-map LAN-IN  
  
    class HTTP-HACKS  
  
       police 8000 1000 1000 conform-action drop exceed-action
  
         drop  
  
    class JUNK  
  
     set ip precedence 1  
  
    class DEFAULT  
  
     set ip precedence 4  
  
  ! 
  
  policy-map DSL-OUT  
  
     class class-default  
  
      bandwidth percent 1 
  
      !-- class-default を WFQ システム内の 1 つの FIFO キューにするために 
  
      !-- 使用されます。   
  
      random-detect  
  
      random-detect exponential-weighting-constant 7  
  
      random-detect precedence 0   20    40    10  
  
      random-detect precedence 1   22    40    10 
  
      random-detect precedence 2   24    40    10 
  
      random-detect precedence 3   26    40    10 
  
      random-detect precedence 4   28    40    10  
  
      random-detect precedence 5   31    40    10  
  
      random-detect precedence 6   33    40    10  
  
      random-detect precedence 7   35    40    10  
  
      random-detect precedence rsvp   37    40    10 
  
  ! 
  
  interface Loopback1  
  
    ip address 172.16.1.1 255.255.255.0  
  
  !  
  
  interface FastEthernet0/0  
  
    ip address 10.1.1.1 255.255.255.192  
  
    service-policy input LAN-IN  
  
  !  
  
  interface ATM1/0  
  
    no ip address  
  
    no atm ilmi-keepalive 
  
  !  
  
  interface ATM1/0.4 point-to-point  
  
    ip unnumbered Loopback1  
  
    no ip redirects  
  
    no ip unreachables  
  
    no ip mroute-cache  
  
    atm route-bridged ip  
  
    pvc 1/35  
  
     service-policy output DSL-OUT  
  
    ! 
  
  !  
  
  interface ATM1/0.5 point-to-point  
  
    ip unnumbered Loopback1  
  
    no ip redirects  
  
    no ip unreachables  
  
    no ip mroute-cache  
  
    atm route-bridged ip  
  
    pvc 1/36  
  
     service-policy output DSL-OUT 
  
  end
  
  

確認

この項では、設定が正常に動作しているかどうかを確認する際に役立つ情報を示します。

特定の show コマンドは、Output Interpreter登録ユーザのみ)でサポートされています。このツールを使用すると、show コマンドの出力を分析できます。

  • show queueing interface atm:インターフェイス上の特定の VC のキューに関する統計情報を表示します。IP フローがレイヤ 3 キューにキューイングされている場合、輻輳が発生している間、アクティブな「カンバセーション」にはゼロ以外の値が表示されます。
  • 2620A#show queueing interface atm1/1.3 Interface ATM1/1.3 VC 2/34 Queueing strategy: weighted fair Total output drops per VC: 1573 Output queue: 0/512/64/1573 (size/max total/threshold/drops) Conversations 0/1/64 (active/max active/max total) Reserved Conversations 1/1 (allocated/max allocate)
  • show policy-map interface atm:サービス ポリシーを監視する際には、このコマンドを使用して次の項目をチェックします。

    • パケットの増分値がクラスにマッチしていること。これが機能していない場合は、CEF が有効で、パケットが CEF スイッチング パスを通っていることを確認します。パケットに CEF スイッチが適用されているかどうかを表示するには、show interface statistics コマンドを使用します。
    • 「packets」値を「pkts matched」値と比較します。「pkts matched」値が増加するのは、輻輳が発生している間のみです。詳細については、「show policy-map interface の出力にあるパケット カウンタについて」を参照してください。
    • ランダム廃棄の数を訂正します。「mean queue depth」フィールドの値を監視し、最小しきい値を超えた値に達しているかどうかを調べます。mean queue depth が、特定の IP 優先順位レベルの最小しきい値を上回った場合、WRED はランダムなパケットの廃棄を開始します。
  • 2620A#show policy-map interface atm1/1.3 ATM1/1.3: VC 2/34 - Service-policy output: DSL-OUT Class-map: class-default (match-any) 1139233 packets, 816228177 bytes 5 minute offered rate 186000 bps, drop rate 0 bps Match: any Weighted Fair Queueing Output Queue: Conversation 73 Bandwidth 1 (%) (pkts matched/bytes matched) 110536/105990742 (depth/total drops/no-buffer drops) 21/1573/0 exponential weight: 7 mean queue depth: 13 class Transmitted Random drop Tail drop Minimum Maximum Mark pkts/bytes pkts/bytes pkts/bytes thresh thresh prob 0 101/7474 0/0 0/0 20 40 1/4 1 124000/111124750 721/999546 56/82848 22 40 1/5 2 265667/350592898 432/566259 74/83774 24 40 1/6 36902/9718053 3/4580 0/0 26 40 1/8 4 741098/343003900 251/123634 36/13490 28 40 1/10 5 0/0 0/0 0/0 31 40 1/10 6 32/2688 0/0 0/0 33 40 1/10 7 0/0 0/0 0/0 35 40 1/10 rsvp0/0 0/0

トラブルシューティング

現時点では、この設定に対して使用可能な特定のトラブルシューティング情報はありません。


Cisco サポート コミュニティ - 特集対話

Cisco サポート コミュニティでは、フォーラムに参加して情報交換することができます。現在、このドキュメントに関連するトピックについて次のような対話が行われています。


関連情報