IP : IP ルーティング

OSPF からスタブ エリアまたは完全スタブ エリアにデフォルト ルートを挿入する方法

2003 年 6 月 10 日 - ライター翻訳版
その他のバージョン: PDFpdf | 機械翻訳版 (2013 年 8 月 21 日) | 英語版 (2005 年 8 月 10 日) | フィードバック

この設定例では、OSPF からスタブ エリアまたは完全スタブ エリアにデフォルト ルートを挿入する方法について説明します。 例として次のネットワーク ダイアグラムを確認します。

ネットワーク ダイアグラム

Network Diagram

設定

ルータ 1.1.1.1
   
   Current configuration:
   
   
   
   hostname r1.1.1.1
   
   
   
   interface Loopback0
   
    ip address 1.1.1.1 255.0.0.0
   
   
   
   interface Serial2/1/0
   
    ip address 5.0.0.1 255.0.0.0
   
    
   
   router ospf 2
   
    network 5.0.0.0 0.255.255.255 area 1
   
    area 1 stub
   
   
   
   end
   
   
ルータ 2.2.2.2
   
   Current configuration:
   
   
   
   hostname r2.2.2.2
   
   
   
   interface Loopback0
   
    ip address 2.2.2.2 255.0.0.0
   
    
   
   interface Serial0/1/0
   
    ip address 5.0.0.2 255.0.0.0
   
   
   
   interface ATM1/0.20
   
    ip address 6.0.0.2 255.0.0.0
   
    
   
   router ospf 2
   
    network 5.0.0.0 0.255.255.255 area 1
   
    network 6.0.0.0 0.255.255.255 area 0
   
    area 1 stub
   
   
   
   end
   
   

スタブ エリアでの OSPF データベースの検査

スタブ エリア用の area border router(ABR; エリア境界ルータ)は、リンク ID が 0.0.0.0 の集約 link-state advertisement(LSA; リンクステート アドバタイズメント)を発信します。 この LSA は、デフォルト ルートがない場合でも発信されます。 これを確認するには、show ip ospf database コマンドを使用します。

   
   r2.2.2.2#show ip ospf database 
   
   
   
          OSPF Router with ID (2.2.2.2) (Process ID 2) 
   
   
   
                   Router Link States (Area 0) 
   
   
   
   Link ID        ADV Router      Age        Seq#               Checksum     Link count 
   
   2.2.2.2         2.2.2.2        19         0x80000001         0x8F8B           1 
   
   
   
                   Summary Net Link States (Area 0) 
   
   
   
   Link ID        ADV Router      Age         Seq#               Checksum 
   
   5.0.0.0         2.2.2.2        9           0x80000001         0x8E61 
   
   
   
                   Router Link States (Area 1) 
   
   
   
   Link ID        ADV Router      Age         Seq#               Checksum     Link count 
   
   1.1.1.1         1.1.1.1        1335        0x80000059         0x56DA           2 
   
   2.2.2.2         2.2.2.2        4           0x80000013         0x7FF3           2 
   
   
   
                   Summary Net Link States (Area 1) 
   
   
   
   Link ID        ADV Router      Age         Seq#               Checksum 
   
   0.0.0.0         2.2.2.2        20          0x80000001         0x75C0 
   
   6.0.0.0         2.2.2.2        13          0x80000001         0x2709 
   
   
   
   
   
   r2.2.2.2#show ip ospf database summary 0.0.0.0 
   
   
   
          OSPF Router with ID (2.2.2.2) (Process ID 2) 
   
     
   
   
   
                   Summary Net Link States (Area 1) 
   
   
   
     LS age: 184 
   
     Options: (No TOS-capability, DC) 
   
     LS Type: Summary Links(Network) 
   
     Link State ID: 0.0.0.0 (summary Network Number)
   
     !-- ABR(ルータ 2.2.2.2)からデフォルト ルートが
   
     !-- スタブ エリアに挿入されます。 
   
     Advertising Router: 2.2.2.2 
   
     LS Seq Number: 80000001 
   
     Checksum: 0x75C0 
   
     Length: 28 
   
     Network Mask: /0 
   
           TOS: 0  Metric: 1 
   
     
   
   
   
   r2.2.2.2#show ip route 0.0.0.0 
   
   % Network not in table
   
   !-- ABR(ルータ 2.2.2.2)のルーティング テーブルにはデフォルト ルートが
   
   !-- ありません。
   
   
   
   
   
   r1.1.1.1#show ip route ospf 
   
   O IA 6.0.0.0/8 [110/65] via 5.0.0.2, 00:04:23, Serial2/1/0 
   
   O*IA 0.0.0.0/0 [110/65] via 5.0.0.2, 00:04:23, Serial2/1/0 
   
   

完全スタブ エリアでの OSPF データベースの検査

上の例で、エリア 1 をスタブ エリアから完全スタブ エリアに変更しても、ABR は依然として 0.0.0.0 の集約 LSA をエリア 1 に挿入します。唯一の違いは、他の集約 LSA が完全スタブ エリアには送信されないことです。

: ABR の設定のみを変更します。 次のように、OSPF の設定に「no-summary」文を追加します。 area 1 stub no-summary

次の出力は、完全スタブ エリアで OSPF データベースがどのように見えるかについて示しています。

   
   r2.2.2.2#show ip ospf database
   
   
   
          OSPF Router with ID (2.2.2.2) (Process ID 2) 
   
   
   
                   Router Link States (Area 0) 
   
   
   
   Link ID        ADV Router      Age         Seq#               Checksum     Link count 
   
   2.2.2.2         2.2.2.2        617         0x80000001         0x8F8B           1 
   
   
   
                   Summary Net Link States (Area 0) 
   
   
   
   Link ID        ADV Router      Age         Seq#               Checksum 
   
   5.0.0.0         2.2.2.2        608         0x80000001         0x8E61 
   
   
   
                   Summary ASB Link States (Area 0) 
   
   
   
   Link ID        ADV Router      Age         Seq#               Checksum 
   
   1.1.1.1         2.2.2.2        243         0x80000003         0x8F5E 
   
   
   
                   Router Link States (Area 1) 
   
   
   
   Link ID        ADV Router      Age         Seq#               Checksum     Link count 
   
   1.1.1.1         1.1.1.1        1934        0x80000059         0x56DA           2 
   
   2.2.2.2         2.2.2.2        247         0x80000015         0x7BF5           2 
   
   
   
                   Summary Net Link States (Area 1) 
   
   
   
   Link ID        ADV Router      Age         Seq#               Checksum 
   
   0.0.0.0         2.2.2.2        249         0x80000003         0x71C2  
   
   !-- これは完全スタブ 領域での唯一の集約 LSA であることに
   
   !-- 注意してください。
   
   
   
   r1.1.1.1#show ip route ospf 
   
   O*IA 0.0.0.0/0 [110/65] via 5.0.0.2, 00:04:11, Serial2/1/0 
   
   

ABR から 6.0.0.0/8 に関する集約 LSA が発信されないため、結果としてルータ 1.1.1.1 には 6.0.0.0/8 に対するルート情報がなくなります。このルータが保持する唯一のエリア間ルートは、デフォルト ルートです。


関連情報


前のセクションへ戻る 目次へ戻る 次のセクションへ進む

関連するシスコ サポート コミュニティ ディスカッション

シスコ サポート コミュニティは、どなたでも投稿や回答ができる情報交換スペースです。


Document ID: 47869