IP : IP ルーティング

OSPF での Not-So-Stubby Area のタイプ 7 からタイプ 5 へのリンクステート アドバタイズメントの変換

2002 年 10 月 29 日 - ライター翻訳版
その他のバージョン: PDFpdf | 機械翻訳版 (2013 年 8 月 21 日) | 英語版 (2005 年 8 月 10 日) | フィードバック

この設定例では、OSPF で Not-So-Stubby Area(NSSA)のタイプ 7 の link-state advertisement(LSA; リンクステート アドバタイズメント)からタイプ 5 の LSA に変換する方法について説明します。

ネットワーク ダイアグラム

Network Diagram

設定

ルータ 1.1.1.1
  
  Current configuration:
  
  
  
  hostname r1.1.1.1
  
  
  
  interface Loopback0
  
   ip address 1.1.1.1 255.0.0.0
  
  
  
  interface Serial2/1/0
  
   ip address 5.0.0.1 255.0.0.0
  
    
  
  interface Ethernet2/0/0
  
   ip address 4.0.0.1 255.0.0.0
  
   
  
  router ospf 4
  
   redistribute static metric 5 metric-type 1
  
   network 5.0.0.0 0.255.255.255 area 1
  
   network 4.0.0.0 0.255.255.255 area 1
  
   area 1 nssa
  
   
  
  ip route 9.0.0.0 255.0.0.0 4.0.0.2
  
  
  
  end
  
  
ルータ 2.2.2.2
  
  Current configuration:
  
  
  
  hostname r2.2.2.2
  
  
  
  interface Loopback0
  
   ip address 2.2.2.2 255.0.0.0
  
   
  
  interface Serial0/1/0
  
   ip address 5.0.0.2 255.0.0.0
  
  
  
  interface ATM1/0.20
  
   ip address 6.0.0.2 255.0.0.0
  
   
  
  router ospf 2
  
   network 5.0.0.0 0.255.255.255 area 1
  
   network 6.0.0.0 0.255.255.255 area 0
  
   area 1 nssa
  
  
  
  end
  
  
ルータ 3.3.3.3
  
  Current configuration:
  
  
  
  hostname r3.3.3.3
  
  
  
  interface Loopback0
  
   ip address 3.3.3.3 255.0.0.0
  
  
  
  interface ATM2/0.20 point-to-point
  
   ip address 6.0.0.3 255.0.0.0
  
   
  
  router ospf 2
  
   network 6.0.0.0 0.255.255.255 area 0
  
  
  
  end
  
  

OSPF データベースの検査

show ip ospf database コマンドを使用して、このネットワーク環境の情報が OSPF データベースにどのように格納されているかを見てみましょう。

  
  r2.2.2.2#show ip ospf database 
  
  
  
         OSPF Router with ID (2.2.2.2) (Process ID 2) 
  
  
  
                  Router Link States (Area 0) 
  
  
  
  Link ID        ADV Router          Age         Seq#                Checksum     Link count 
  
  2.2.2.2         2.2.2.2            1235        0x8000001D          0xD9FF           2 
  
  3.3.3.3         3.3.3.3            1100        0x8000000B          0x9455           2 
  
  
  
                  Summary Net Link States (Area 0) 
  
  
  
  Link ID        ADV Router      Age         Seq#               Checksum 
  
  4.0.0.0         2.2.2.2        1979        0x80000002         0xFDE7 
  
  5.0.0.0         2.2.2.2        1483        0x80000004         0x8864 
  
  
  
                  Router Link States (Area 1) 
  
  
  
  Link ID        ADV Router      Age         Seq#               Checksum     Link count 
  
  1.1.1.1         1.1.1.1        319         0x8000000C         0xAFA8           3 
  
  2.2.2.2         2.2.2.2        220         0x8000002F         0xD478           2 
  
  
  
                  Summary Net Link States (Area 1) 
  
  
  
  Link ID        ADV Router      Age         Seq#                Checksum 
  
  6.0.0.0         2.2.2.2        1483        0x8000001C          0x7894 
  
  
  
                  Type-7 AS External Link States (Area 1) 
  
  
  
  Link ID        ADV Router      Age         Seq#               Checksum     Tag 
  
  9.0.0.0         1.1.1.1        334         0x80000005         0xD738        0 
  
  
  
                  Type-5 AS External Link States 
  
  
  
  Link ID        ADV Router      Age         Seq#               Checksum     Tag 
  
  9.0.0.0         2.2.2.2        1725        0x80000004         0x50C6        0 
  
  

外部ルートを NSSA にアドバタイズするために、autonomous system boundary router(ASBR; 自律システム境界ルータ)によって NSSA の外部 LSA(タイプ 7)が作成されます。

  
  r2.2.2.2#show ip ospf database nssa-external 9.0.0.0 
  
  
  
         OSPF Router with ID (2.2.2.2) (Process ID 2) 
  
  
  
                  Type-7 AS External Link States (Area 1) 
  
  
  
    Routing Bit Set on this LSA 
  
    LS age: 381 
  
    Options: (No TOS-capability, Type 7/5 translation, DC)
  
    !-- これはエリア境界ルータ(ABR)によってタイプ 5 LSA に
  
    !-- 変換することができます。 
  
    LS Type: AS External Link 
  
    Link State ID: 9.0.0.0 (External Network Number ) 
  
    !-- ASBR(ルータ 1.1.1.1)によって、9.0.0.0/8 がアドバタイズされます。
  
    !-- 9.0.0.0/8 
  
    Advertising Router: 1.1.1.1
  
    !-- ASBR のルータ ID です。 
  
    LS Seq Number: 80000005 
  
    Checksum: 0xD738 
  
    Length: 36 
  
    Network Mask: /8 
  
          Metric Type: 1 (Comparable directly to link state metric) 
  
          TOS: 0 
  
          Metric: 5 
  
          Forward Address: 4.0.0.1
  
  		!-- 転送先のアドレスが ASBR 上のインターフェイスとして
  
  		!-- 誤って指定されています。
  
  

ABR によってタイプ 7 の LSA がタイプ 5 の LSA に変換され、ノーマル エリアにタイプ 5 の LSA が伝搬されます。

  
  r2.2.2.2#show ip ospf database external 9.0.0.0 
  
  
  
         OSPF Router with ID (2.2.2.2) (Process ID 2) 
  
  
  
                  Type-5 AS External Link States 
  
  
  
    LS age: 1782 
  
    Options: (No TOS-capability, DC) 
  
    LS Type: AS External Link 
  
    Link State ID: 9.0.0.0 (External Network Number )
  
    !-- ルータ 2.2.2.2 によって 9.0.0.0/8 がアドバタイズされます。 
  
    Advertising Router: 2.2.2.2 
  
    !-- 変換が完了すると、アドバタイジング ルータ ID が
  
    !-- ABR ルータ ID  になります。
  
    !-- これはこのタイプ 5 の LSA が ABR によって発信されているためです。
  
    LS Seq Number: 80000004 
  
    Checksum: 0x50C6 
  
    Length: 36 
  
    Network Mask: /8 
  
          Metric Type: 1 (Comparable directly to link state metric) 
  
          TOS: 0 
  
          Metric: 5 
  
          Forward Address: 4.0.0.1 
  
          External Route Tag: 0 
  
    
  
  
  
  r2.2.2.2#show ip ospf database router 1.1.1.1 
  
  
  
         OSPF Router with ID (2.2.2.2) (Process ID 2) 
  
  
  
                  Router Link States (Area 1) 
  
  
  
    Routing Bit Set on this LSA 
  
    LS age: 426 
  
    Options: (No TOS-capability, DC) 
  
    LS Type: Router Links 
  
    Link State ID: 1.1.1.1
  
    !--- ルータ リンクの Link State ID は常に
  
    !-- Advertising Router(次の行)と同じです。
  
    Advertising Router: 1.1.1.1
  
    LS Seq Number: 8000000C 
  
    Checksum: 0xAFA8 
  
    Length: 60 
  
    AS Boundary Router
  
    !-- ルータ LSA のビット E は、このルータが外部の LSA を
  
    !-- 発信していることを示しています。 
  
     Number of Links: 3
  
     !-- エリア 1 には 3 つのリンクがあります。 
  
  
  
      Link connected to: a Stub Network
  
  	!-- これはイーサネット セグメント 4.0.0.0/8 を表します。 
  
       (Link ID) Network/subnet number: 4.0.0.0 
  
       (Link Data) Network Mask: 255.0.0.0 
  
        Number of TOS metrics: 0 
  
         TOS 0 Metrics: 10
  
  	   !-- このイーサネット セグメントの OSPF コストです。 
  
  
  
      Link connected to: another Router (point-to-point) 
  
  	!-- ルータ 1.1.1.1 はルータ 2.2.2.2 の
  
  	!-- 近接ルータであることを示しています。 
  
       (Link ID) Neighboring Router ID: 2.2.2.2 
  
       (Link Data) Router Interface address: 5.0.0.1
  
  	 !-- ルータ 2.2.2.2 と接続しているインターフェイスのアドレスは
  
  	 !-- 5.0.0.1 です。 
  
        Number of TOS metrics: 0 
  
         TOS 0 Metrics: 64
  
  	   !-- 2 台のルータを接続しているリンクの
  
     				!-- OSPF コストです。 
  
  
  
      Link connected to: a Stub Network 
  
  	!-- これはシリアル リンク 5.0.0.0/8 を表しています。 
  
       (Link ID) Network/subnet number: 5.0.0.0 
  
       (Link Data) Network Mask: 255.0.0.0 
  
        Number of TOS metrics: 0 
  
         TOS 0 Metrics: 64
  
  	   !-- シリアル リンクの OSPF コストです。
  
  

次の出力の中の太字の部分が示すように、ルータ 2.2.2.2 の設定では redistribute 文がない場合も、依然として ASBR であることが分かります。これは、タイプ 7 の LSA から タイプ 5 の LSA への変換が行われているためです。

  
  r2.2.2.2#show ip ospf database router 2.2.2.2 
  
  
  
         OSPF Router with ID (2.2.2.2) (Process ID 2) 
  
  
  
                  Router Link States (Area 0) 
  
  
  
    LS age: 1361 
  
    Options: (No TOS-capability, DC) 
  
    LS Type: Router Links 
  
    Link State ID: 2.2.2.2 
  
    Advertising Router: 2.2.2.2 
  
    LS Seq Number: 8000001D 
  
    Checksum: 0xD9FF 
  
    Length: 48 
  
    Area Border Router 
  
    !-- ビット B はルータ LSA で設定され、このルータが
  
    !-- ABR であることを示しています。 
  
    AS Boundary Router
  
    !-- ルータ LSA のビット E は、このルータが外部の LSA を
  
       !-- 発信していることを示しています。 
  
     Number of Links: 2 
  
     !-- エリア 0 には 2 つのリンクがあります。 
  
  
  
      Link connected to: another Router (point-to-point) 
  
       (Link ID) Neighboring Router ID: 3.3.3.3 
  
       (Link Data) Router Interface address: 6.0.0.2 
  
        Number of TOS metrics: 0 
  
         TOS 0 Metrics: 1 
  
  
  
      Link connected to: a Stub Network 
  
       (Link ID) Network/subnet number: 6.0.0.0 
  
       (Link Data) Network Mask: 255.0.0.0 
  
        Number of TOS metrics: 0 
  
         TOS 0 Metrics: 1 
  
    
  
    
  
  
  
                  Router Link States (Area 1) 
  
  
  
    LS age: 346 
  
    Options: (No TOS-capability, DC) 
  
    LS Type: Router Links 
  
    Link State ID: 2.2.2.2 
  
    Advertising Router: 2.2.2.2 
  
    LS Seq Number: 8000002F 
  
    Checksum: 0xD478 
  
    Length: 48 
  
    Area Border Router 
  
    AS Boundary Router 
  
     Number of Links: 2 
  
  
  
      Link connected to: another Router (point-to-point) 
  
       (Link ID) Neighboring Router ID: 1.1.1.1 
  
       (Link Data) Router Interface address: 5.0.0.2 
  
        Number of TOS metrics: 0 
  
         TOS 0 Metrics: 64 
  
  
  
      Link connected to: a Stub Network 
  
       (Link ID) Network/subnet number: 5.0.0.0 
  
       (Link Data) Network Mask: 255.0.0.0 
  
        Number of TOS metrics: 0 
  
         TOS 0 Metrics: 64 
  
    
  
  
  
  r2.2.2.2#show ip ospf database router 3.3.3.3 
  
  
  
         OSPF Router with ID (2.2.2.2) (Process ID 2) 
  
  
  
                  Router Link States (Area 0) 
  
  
  
    LS age: 1245 
  
    Options: (No TOS-capability, DC) 
  
    LS Type: Router Links 
  
    Link State ID: 3.3.3.3 
  
    Advertising Router: 3.3.3.3 
  
    LS Seq Number: 8000000B 
  
    Checksum: 0x9455 
  
    Length: 48 
  
     Number of Links: 2 
  
  
  
      Link connected to: another Router (point-to-point) 
  
       (Link ID) Neighboring Router ID: 2.2.2.2 
  
       (Link Data) Router Interface address: 6.0.0.3 
  
        Number of TOS metrics: 0 
  
         TOS 0 Metrics: 1 
  
  
  
      Link connected to: a Stub Network 
  
       (Link ID) Network/subnet number: 6.0.0.0 
  
       (Link Data) Network Mask: 255.0.0.0 
  
        Number of TOS metrics: 0 
  
         TOS 0 Metrics: 1 
  
  

あるエリアから他のエリアへのルートをアドバタイズするために、ABR で集約 LSA(タイプ 3)が作成されます。

  
  r2.2.2.2#show ip ospf database summary 4.0.0.0 
  
  
  
         OSPF Router with ID (2.2.2.2) (Process ID 2) 
  
  
  
                  Summary Net Link States (Area 0) 
  
  
  
    LS age: 172 
  
    Options: (No TOS-capability, DC) 
  
    LS Type: Summary Links(Network) 
  
    Link State ID: 4.0.0.0 (summary Network Number)
  
    !-- ABR(ルータ 2.2.2.2)によって 4.0.0.0/8 が
  
    !-- エリア 0 にアドバタイズされます。
  
    Advertising Router: 2.2.2.2 
  
    LS Seq Number: 80000003 
  
    Checksum: 0xFBE8 
  
    Length: 28 
  
    Network Mask: /8 
  
          TOS: 0  Metric: 74 
  
  
  
  r2.2.2.2#show ip ospf database summary 5.0.0.0 
  
  
  
         OSPF Router with ID (2.2.2.2) (Process ID 2) 
  
  
  
                  Summary Net Link States (Area 0) 
  
  
  
    LS age: 1687 
  
    Options: (No TOS-capability, DC) 
  
    LS Type: Summary Links(Network) 
  
    Link State ID: 5.0.0.0 (summary Network Number)
  
    !-- ABR(ルータ 2.2.2.2)によって 5.0.0.0/8 が
  
       !-- エリア 0 にアドバタイズされます。
  
    Advertising Router: 2.2.2.2 
  
    LS Seq Number: 80000004 
  
    Checksum: 0x8864 
  
    Length: 28 
  
    Network Mask: /8 
  
          TOS: 0  Metric: 64 
  
  
  
  r2.2.2.2#show ip ospf database summary 6.0.0.0 
  
  
  
         OSPF Router with ID (2.2.2.2) (Process ID 2) 
  
  
  
                  Summary Net Link States (Area 1) 
  
  
  
    LS age: 1697 
  
    Options: (No TOS-capability, DC) 
  
    LS Type: Summary Links(Network) 
  
    Link State ID: 6.0.0.0 (summary Network Number)
  
    !-- ABR(ルータ 2.2.2.2)によって 6.0.0.0/8 が
  
       !-- エリア 1 にアドバタイズされます。
  
    Advertising Router: 2.2.2.2 
  
    LS Seq Number: 8000001C 
  
    Checksum: 0x7894 
  
    Length: 28 
  
    Network Mask: /8 
  
          TOS: 0  Metric: 1 
  
  

この場合、ABR が外部 LSA を発信し、さらに ABR がエリア 0 内で到達可能であるため、ASBR 集約 LSA は必要ありません。「OSPF が複数エリアへの外部ルートを伝搬する方法」のデータベースの例を参照して、この例を NSSA がノーマル エリアにある場合と比較してください。

次のルーティング テーブルの出力では、9.0.0.0 が各ルータによって検知されている別のタイプの OSPF ルータを示しています。

  
  r1.1.1.1#show ip route 9.0.0.0 
  
  Routing entry for 9.0.0.0/8 
  
    Known via "static", distance 1, metric 0 
  
    Redistributing via ospf 4 
  
    Advertised by ospf 4 metric 5 metric-type 1 
  
    Routing Descriptor Blocks: 
  
    * 4.0.0.2 
  
        Route metric is 0, traffic share count is 1
  
  
  
  r2.2.2.2#show ip route ospf 
  
  O    4.0.0.0/8 [110/74] via 5.0.0.1, 01:10:13, Serial0/1/0 
  
  O N1 9.0.0.0/8 [110/79] via 5.0.0.1, 01:07:20, Serial0/1/0 
  
  
  
  R3.3.3.3#show ip route ospf
  
  O IA 4.0.0.0/8 [110/75] via 6.0.0.2, 02:11:14, ATM2/0.20 
  
  O IA 5.0.0.0/8 [110/65] via 6.0.0.2, 03:10:41, ATM2/0.20 
  
  O E1 9.0.0.0/8 [110/80] via 6.0.0.2, 02:08:11, ATM2/0.20 
  
  


関連情報


前のセクションへ戻る 目次へ戻る 次のセクションへ進む

関連するシスコ サポート コミュニティ ディスカッション

シスコ サポート コミュニティは、どなたでも投稿や回答ができる情報交換スペースです。


Document ID: 47867