IP : IP ルーティング

OSPF 仮想リンク

2002 年 6 月 1 日 - ライター翻訳版
その他のバージョン: PDFpdf | 機械翻訳版 (2013 年 8 月 21 日) | 英語版 (2007 年 1 月 4 日) | フィードバック

目次


概要

OSPF 自律システム内のエリアはすべて、バックボーン エリア(エリア 0)に物理的に接続されている必要があります。これが不可能な場合は、仮想リンクを使用し、バックボーン エリア以外を経由してバックボーンに接続できます。仮想リンクは、分割されたバックボーンの 2 つの部分を、バックボーン エリア以外を経由して接続する際にも使用できます。仮想リンクを中継するように設定されたエリア(トランジット エリアと呼ぶ)には完全なルーティング情報が必要です。スタブ エリアをトランジット エリアにすることはできません。このドキュメントでは、仮想リンク環境の OSPF データベースについて詳しく見ていきます。仮想リンクの詳細については、「OSPF デザイン ガイド」を参照してください。

ネットワーク ダイアグラム

設定例

ルータ 1.1.1.1
Current configuration:
  
  hostname r1.1.1.1
  
  interface Loopback0
   ip address 1.1.1.1 255.0.0.0
  
  interface Ethernet2/0/0
   ip address 4.0.0.1 255.0.0.0
  
  interface Serial2/1/0
   ip address 5.0.0.1 255.0.0.0
  
  router ospf 2
   network 4.0.0.0 0.255.255.255 area 0
   network 5.0.0.0 0.255.255.255 area 1
   area 1 virtual-link 3.3.3.3
  
  end
  
ルータ 2.2.2.2
Current configuration:
  
  hostname r2.2.2.2
  
  interface Loopback0
   ip address 2.2.2.2 255.0.0.0
  
  interface Serial0/1/0
   ip address 5.0.0.2 255.0.0.0
  
  interface ATM1/0.20 point-to-point
   ip address 6.0.0.2 255.0.0.0
  
  router ospf 2
   network 6.0.0.0 0.255.255.255 area 1
   network 5.0.0.0 0.255.255.255 area 1
  
  end
  
ルータ 3.3.3.3
Current configuration:
  
  hostname r3.3.3.3
  
  interface Loopback0
   ip address 3.3.3.3 255.0.0.0
  
  interface Ethernet0/0
   ip address 12.0.0.3 255.0.0.0
  
  interface ATM2/0.20 point-to-point
   ip address 6.0.0.3 255.0.0.0
  
  router ospf 2
   network 12.0.0.0 0.255.255.255 area 2
   network 6.0.0.0 0.255.255.255 area 1
   area 1 virtual-link 1.1.1.1
  
  end
  

OSPF データベースの検査

show ip ospf database コマンドを使用して、このネットワーク環境の情報が OSPF データベースにどのように格納されているかを見てみましょう。

r1.1.1.1#show ip ospf database
  
         OSPF Router with ID (1.1.1.1) (Process ID 2)
  
                  Router Link States (Area 0)
  
  Link ID         ADV Router              Age             Seq#               Checksum     Link count
  1.1.1.1         1.1.1.1                 919             0x80000003         0xD5DF           2
  3.3.3.3         3.3.3.3                 5     (DNA)     0x80000002         0x3990           1
  
                  Summary Net Link States (Area 0)
  
  Link ID         ADV Router              Age                 Seq#               Checksum
  5.0.0.0         1.1.1.1                 1945                0x80000002         0xAA48
  5.0.0.0         3.3.3.3                 9     (DNA)         0x80000001         0x7A70
  6.0.0.0         1.1.1.1                 1946                0x80000002         0xA749
  6.0.0.0         3.3.3.3                 9     (DNA)         0x80000001         0xEA3F
  12.0.0.0        3.3.3.3                 9     (DNA)         0x80000001         0xF624
  
                  Router Link States (Area 1)
  
  Link ID         ADV Router              Age             Seq#               Checksum     Link count
  1.1.1.1         1.1.1.1                 1946            0x80000005         0xDDA6           2
  2.2.2.2         2.2.2.2                 10              0x80000009         0x64DD           4
  3.3.3.3         3.3.3.3                 930             0x80000006         0xA14C           2
  
                  Summary Net Link States (Area 1)
  
  Link ID         ADV Router              Age             Seq#               Checksum
  4.0.0.0         1.1.1.1                 1947            0x80000002         0x9990
  4.0.0.0         3.3.3.3                 911             0x80000001         0xEBF5
  12.0.0.0        1.1.1.1                 913             0x80000001         0xBF22
  12.0.0.0        3.3.3.3                 931             0x80000001         0xF624
  
  
  r2.2.2.2#show ip ospf database
  
         OSPF Router with ID (2.2.2.2) (Process ID 2)
  
                  Router Link States (Area 1)
  
  Link ID         ADV Router              Age             Seq#               Checksum     Link count
  1.1.1.1         1.1.1.1                 1988            0x80000005         0xDDA6           2
  2.2.2.2         2.2.2.2                 50              0x80000009         0x64DD           4
  3.3.3.3         3.3.3.3                 969             0x80000006         0xA14C           2
  
                  Summary Net Link States (Area 1)
  
  Link ID         ADV Router              Age                 Seq#               Checksum
  4.0.0.0         1.1.1.1                 1988                0x80000002         0x9990
  4.0.0.0         3.3.3.3                 950                 0x80000001         0xEBF5
  12.0.0.0        1.1.1.1                 955                 0x80000001         0xBF22
  12.0.0.0        3.3.3.3                 970                 0x80000001         0xF624
  
  
  r3.3.3.3#show ip ospf database
  
         OSPF Router with ID (3.3.3.3) (Process ID 2)
  
                  Router Link States (Area 0)
  
  Link ID         ADV Router              Age          Seq#               Checksum        Link count
  1.1.1.1         1.1.1.1                 6   (DNA)    0x80000003         0xD5DF              2
  3.3.3.3         3.3.3.3                 977          0x80000002         0x3990              1
  
                  Summary Net Link States (Area 0)
  
  Link ID         ADV Router              Age            Seq#              Checksum
  5.0.0.0         1.1.1.1                 1027  (DNA)    0x80000002        0xAA48
  5.0.0.0         3.3.3.3                 986            0x80000001        0x7A70
  6.0.0.0         1.1.1.1                 1027  (DNA)    0x80000002        0xA749
  6.0.0.0         3.3.3.3                 987            0x80000001        0xEA3F
  12.0.0.0        3.3.3.3                 987            0x80000001        0xF624
  
                  Router Link States (Area 1)
  
  Link ID         ADV Router              Age         Seq#               Checksum     Link count
  1.1.1.1         1.1.1.1                 2007        0x80000005         0xDDA6           2
  2.2.2.2         2.2.2.2                 68          0x80000009         0x64DD           4
  3.3.3.3         3.3.3.3                 987         0x80000006         0xA14C           2
  
                  Summary Net Link States (Area 1)
  
  Link ID         ADV Router              Age                Seq#                   Checksum
  4.0.0.0         1.1.1.1                 2007               0x80000002             0x9990
  4.0.0.0         3.3.3.3                 967                0x80000001             0xEBF5
  12.0.0.0        1.1.1.1                 973                0x80000001             0xBF22
  12.0.0.0        3.3.3.3                 987                0x80000001             0xF624
  
  
                  Router Link States (Area 2)
  
  Link ID         ADV Router              Age         Seq#                   Checksum     Link count
  3.3.3.3         3.3.3.3                 987         0x80000003             0xCF5            1
  
                  Summary Net Link States (Area 2)
  
  Link ID         ADV Router              Age                 Seq#               Checksum
  4.0.0.0         3.3.3.3                 968                 0x80000001         0xEBF5
  5.0.0.0         3.3.3.3                 988                 0x80000001         0x7A70
  6.0.0.0         3.3.3.3                 988                 0x80000001         0xEA3F
  

仮想リンクを通じて学習された Link-State Advertisement(LSA; リンクステート アドバタイズメント)には「do not age」オプションがついている点に注意してください。仮想リンクはデマンド回線のように取り扱われています。

r1.1.1.1#show ip ospf database router 1.1.1.1
  
         OSPF Router with ID (1.1.1.1) (Process ID 2)
  
                  Router Link States (Area 0)
  
    LS age: 1100
    Options: (No TOS-capability, DC)
    LS Type: Router Links
    Link State ID: 1.1.1.1
    !-- ルータ リンクの場合、Link State Id は常に 
    !-- Advertising Router と同じです。
    Advertising Router: 1.1.1.1
    !-- これは、この LSA を作成した
    !-- ルータのルータ ID です。
    LS Seq Number: 80000003
    Checksum: 0xD5DF
    Length: 48
    Area Border Router
    !-- ルータ LSA 内のビット B は、このルータが 
    !-- Area Border Router(ABR; エリア境界ルータ)であることを示しています。
     Number of Links: 2
     !-- エリア 0 には 2 つのリンクがあります。
  
      Link connected to: a Virtual Link
       (Link ID) Neighboring Router ID: 3.3.3.3
  	 !-- 仮想リンクの相手側にある近接ルータ
       !-- のルータ ID
       (Link Data) Router Interface address: 5.0.0.1
  	 !-- このルータが近接ルータへのパケットの送信に
       !-- 使用するインターフェイス
        Number of TOS metrics: 0
         TOS 0 Metrics: 65
  	   !-- メトリックは、このルータが近接ルータに 
  	   !-- 到達するためのコストから算出されます。
  	   !-- ATM リンクのコストは 1、 
         !-- シリアル リンクのコストは 64 です。
  
      Link connected to: a Stub Network
  	!-- これはイーサネット セグメント 4.0.0.0/8 を表します。 
       (Link ID) Network/subnet number: 4.0.0.0
       (Link Data) Network Mask: 255.0.0.0
        Number of TOS metrics: 0
         TOS 0 Metrics: 10
  
  
                  Router Link States (Area 1)
  
    LS age: 122
    Options: (No TOS-capability, DC)
    LS Type: Router Links
    Link State ID: 1.1.1.1
    Advertising Router: 1.1.1.1
    LS Seq Number: 80000006
    Checksum: 0xDBA7
    Length: 48
    Area Border Router
     Number of Links: 2
     !-- エリア 1 には 2 つのリンクがあります。 
  
      Link connected to: another Router (point-to-point)
       (Link ID) Neighboring Router ID: 2.2.2.2
       (Link Data) Router Interface address: 5.0.0.1
        Number of TOS metrics: 0
         TOS 0 Metrics: 64
  
      Link connected to: a Stub Network
       (Link ID) Network/subnet number: 5.0.0.0
       (Link Data) Network Mask: 255.0.0.0
        Number of TOS metrics: 0
         TOS 0 Metrics: 64
  
  
  r1.1.1.1#show ip ospf database router  2.2.2.2
  
         OSPF Router with ID (1.1.1.1) (Process ID 2)
  
                  Router Link States (Area 1)
  
    LS age: 245
    Options: (No TOS-capability, DC)
    LS Type: Router Links
    Link State ID: 2.2.2.2
    Advertising Router: 2.2.2.2
    LS Seq Number: 80000009
    Checksum: 0x64DD
    Length: 72
     Number of Links: 4
  
      Link connected to: another Router (point-to-point)
       (Link ID) Neighboring Router ID: 3.3.3.3
       (Link Data) Router Interface address: 6.0.0.2
        Number of TOS metrics: 0
         TOS 0 Metrics: 1
  
      Link connected to: a Stub Network
       (Link ID) Network/subnet number: 6.0.0.0
       (Link Data) Network Mask: 255.0.0.0
        Number of TOS metrics: 0
         TOS 0 Metrics: 1
  
      Link connected to: another Router (point-to-point)
       (Link ID) Neighboring Router ID: 1.1.1.1
       (Link Data) Router Interface address: 5.0.0.2
        Number of TOS metrics: 0
         TOS 0 Metrics: 64
  
      Link connected to: a Stub Network
       (Link ID) Network/subnet number: 5.0.0.0
       (Link Data) Network Mask: 255.0.0.0
        Number of TOS metrics: 0
         TOS 0 Metrics: 64
  
  
  r1.1.1.1#show ip ospf database router 3.3.3.3
  
         OSPF Router with ID (1.1.1.1) (Process ID 2)
  
                  Router Link States (Area 0)
  
    Routing Bit Set on this LSA
    LS age: 5 (DoNotAge)
    Options: (No TOS-capability, DC)
    LS Type: Router Links
    Link State ID: 3.3.3.3
    Advertising Router: 3.3.3.3
    LS Seq Number: 80000002
    Checksum: 0x3990
    Length: 36
    Area Border Router
     Number of Links: 1
  
      Link connected to: a Virtual Link
       (Link ID) Neighboring Router ID: 1.1.1.1
       (Link Data) Router Interface address: 6.0.0.3
        Number of TOS metrics: 0
         TOS 0 Metrics: 65
  
  
                  Router Link States (Area 1)
  
    Routing Bit Set on this LSA
    LS age: 1137
    Options: (No TOS-capability, DC)
    LS Type: Router Links
    Link State ID: 3.3.3.3
    Advertising Router: 3.3.3.3
    LS Seq Number: 80000006
    Checksum: 0xA14C
    Length: 48
    Area Border Router
     Number of Links: 2
  
      Link connected to: another Router (point-to-point)
       (Link ID) Neighboring Router ID: 2.2.2.2
       (Link Data) Router Interface address: 6.0.0.3
        Number of TOS metrics: 0
         TOS 0 Metrics: 1
  
      Link connected to: a Stub Network
       (Link ID) Network/subnet number: 6.0.0.0
       (Link Data) Network Mask: 255.0.0.0
        Number of TOS metrics: 0
         TOS 0 Metrics: 1
  

ルータ 3.3.3.3 にはエリア 0 へのリンク(仮想リンク)があるため、ルータ 3.3.3.3 は自身を ABR と見なします。その結果、ルータ 3.3.3.3 はエリア 1 とエリア 0 で 12.0.0.0 の要約 LSA を生成します。これは、show ip ospf database summary コマンドを使用して確認できます。

r3.3.3.3#show ip ospf database summary 12.0.0.0
  
         OSPF Router with ID (3.3.3.3) (Process ID 2)
  
                  Summary Net Link States (Area 0)
  
    LS age: 1779
    Options: (No TOS-capability, DC)
    LS Type: Summary Links(Network)
    Link State ID: 12.0.0.0 (summary Network Number)
    Advertising Router: 3.3.3.3
    LS Seq Number: 80000001
    Checksum: 0xF624
    Length: 28
    Network Mask: /8
          TOS: 0  Metric: 10
  
  
                  Summary Net Link States (Area 1)
  
    LS age: 1766
    Options: (No TOS-capability, DC)
    LS Type: Summary Links(Network)
    Link State ID: 12.0.0.0 (summary Network Number)
    Advertising Router: 1.1.1.1
    LS Seq Number: 80000001
    Checksum: 0xBF22
    Length: 28
    Network Mask: /8
          TOS: 0  Metric: 75
  
    LS age: 1781
    Options: (No TOS-capability, DC)
    LS Type: Summary Links(Network)
    Link State ID: 12.0.0.0 (summary Network Number)
    Advertising Router: 3.3.3.3
    LS Seq Number: 80000001
    Checksum: 0xF624
    Length: 28
    Network Mask: /8
          TOS: 0  Metric: 10
  

また、ルータ 3.3.3.3 はエリア 2 内で、エリア 0 とエリア 1 から学習したすべての情報の要約 LSA を作成する点にも注意してください。

r3.3.3.3#show ip ospf database summary self-originate
  
         OSPF Router with ID (3.3.3.3) (Process ID 2)
  
  
                  Summary Net Link States (Area 0)
  
    LS age: 155
    Options: (No TOS-capability, DC)
    LS Type: Summary Links(Network)
    Link State ID: 5.0.0.0 (summary Network Number)
    Advertising Router: 3.3.3.3
    LS Seq Number: 80000002
    Checksum: 0x7871
    Length: 28
    Network Mask: /8
          TOS: 0  Metric: 65
  
    LS age: 155
    Options: (No TOS-capability, DC)
    LS Type: Summary Links(Network)
    Link State ID: 6.0.0.0 (summary Network Number)
    Advertising Router: 3.3.3.3
    LS Seq Number: 80000002
    Checksum: 0xE840
    Length: 28
    Network Mask: /8
          TOS: 0  Metric: 1
  
    LS age: 156
    Options: (No TOS-capability, DC)
    LS Type: Summary Links(Network)
    Link State ID: 12.0.0.0 (summary Network Number)
    Advertising Router: 3.3.3.3
    LS Seq Number: 80000002
    Checksum: 0xF425
    Length: 28
    Network Mask: /8
          TOS: 0  Metric: 10
  
  
                  Summary Net Link States (Area 1)
  
    LS age: 157
    Options: (No TOS-capability, DC)
    LS Type: Summary Links(Network)
    Link State ID: 4.0.0.0 (summary Network Number)
    Advertising Router: 3.3.3.3
    LS Seq Number: 80000002
    Checksum: 0xE9F6
    Length: 28
    Network Mask: /8
          TOS: 0  Metric: 75
  
    LS age: 165
    Options: (No TOS-capability, DC)
    LS Type: Summary Links(Network)
    Link State ID: 12.0.0.0 (summary Network Number)
    Advertising Router: 3.3.3.3
    LS Seq Number: 80000002
    Checksum: 0xF425
    Length: 28
    Network Mask: /8
          TOS: 0  Metric: 10
  
                  Summary Net Link States (Area 2)
  
    LS age: 167
    Options: (No TOS-capability, DC)
    LS Type: Summary Links(Network)
    Link State ID: 4.0.0.0 (summary Network Number)
    Advertising Router: 3.3.3.3
    LS Seq Number: 80000002
    Checksum: 0xE9F6
    Length: 28
    Network Mask: /8
          TOS: 0  Metric: 75
  
    LS age: 168
    Options: (No TOS-capability, DC)
    LS Type: Summary Links(Network)
    Link State ID: 5.0.0.0 (summary Network Number)
    Advertising Router: 3.3.3.3
    LS Seq Number: 80000002
    Checksum: 0x7871
    Length: 28
    Network Mask: /8
          TOS: 0  Metric: 65
  
    LS age: 168
    Options: (No TOS-capability, DC)
    LS Type: Summary Links(Network)
    Link State ID: 6.0.0.0 (summary Network Number)
    Advertising Router: 3.3.3.3
    LS Seq Number: 80000002
    Checksum: 0xE840
    Length: 28
    Network Mask: /8
          TOS: 0  Metric: 1
  

仮想リンクの動作の仕組み

最初は、ルータ 1.1.1.1 がルータ 3.3.3.3(仮想リンクの相手側)への到達方法を知らないため、仮想リンクはダウンしています。ルータ 1.1.1.1 がエリア 1 経由でのルータ 3.3.3.3 への到達方法を知るには、エリア 1 内のすべての LSA がフラッディングされ、3 台のルータすべてによってエリア 1 内で Shortest Path First(SPF; 最短パス優先)アルゴリズムが実行される必要があります。

両方のルータはトランジット エリアを介して互いに到達する方法を学習した後、仮想リンクを通じて隣接関係を確立しようとします。仮想リンクの両端の間を流れる OSPF パケットはマルチキャスト パケットではありません。これらのパケットは仮想リンクの相手側にトンネル伝送されるため、トンネル パケットになります。

仮想リンク上でルータ同士が隣接関係を確立すると、ルータ 3.3.3.3 は自身を ABR と見なします。これは、ルータ 3.3.3.3 にエリア 0 へのリンクが確立されたためです。その結果、ルータ 3.3.3.3 はエリア 0 とエリア 1 で 12.0.0.0/8 の要約 LSA を作成します。

なんらかの理由で仮想リンクが正しく設定されない場合は、ルータ 3.3.3.3 にエリア 0 に属するインターフェイスがないため、ルータ 3.3.3.3 は自身を ABR と見なしません。この場合、ルータ 3.3.3.3 はエリア 1 で要約 LSA を作成しません。つまり、エリア 1 に 12.0.0.0/8 はアドバタイズされません。

最短パスの計算

ここでは、ルータ 2.2.2.2 の観点から最短パスを計算してみます。

ルータ 2.2.2.2 は自身の LSA を参照し、ルータ 3.3.3.3 が近接ルータであることを認識します。続いてルータ 3.3.3.3 の LSA を参照し、ルータ 3.3.3.3 がルータ 2.2.2.2 を近接ルータとして認識していることを確認します。両方のルータが互いに近接ルータとして認識しあっている場合、両ルータは到達可能と見なされます。

さらに各ルータはローカルの近接ルータ テーブル(show ip ospf neighbor コマンドで表示できる)をチェックし、自身のインターフェイスと近接ルータのインターフェイスが共通の IP サブネット上にあることを確認します。

:このチェックは非番号インターフェイスでは行われません。

両方のルータが共通のサブネット上にある場合、両ルータは近接ルータのルータ LSA にリストされているスタブ ネットワークへの経路を開設します。このドキュメントの例では、ルータ 3.3.3.3 のエリア 1 の LSA にリストされているスタブ ネットワークは 6.0.0.0/8 だけであり、ルータ 2.2.2.2 はこのネットワークにすでに直接接続されています。

ルータ 3.3.3.3 はルータ 1.1.1.1 の LSA に対して同じ検査を実施しますが、ルータ 1.1.1.1 の LSA には有効なスタブ ネットワークはありません。

エリア 1 内の到達可能なルータ LSA すべてについて検査した後、ルータ 2.2.2.2 はデータベースに保持されている要約 LSA を参照します。エリア 1 では 12.0.0.0/8 の要約 LSA が 2 つ見つかるため、合計コストの小さい方を選択します。合計コストとは、アドバタイジング ルータに到達するためのメトリックと要約 LSA のメトリックを加えたものです。

  • ルータ 2.2.2.2 がルータ 1.1.1.1 を経由して 12.0.0.0 に到達するときのコストは、64 + 75 = 139 です。

  • ルータ 2.2.2.2 がルータ 3.3.3.3 を経由して 12.0.0.0 に到達するときのコストは、1 + 10 = 11 です。

ルータ 2.2.2.2 はルーティング テーブル内にルータ 3.3.3.3 を経由した経路をメトリック 11 で開設します。

次の出力は、上記の各ルータのルーティング テーブルに格納された OSPF 経路を示しています。

r1.1.1.1#show ip route ospf
  O    6.0.0.0/8 [110/65] via 5.0.0.2, 00:38:12, Serial2/1/0
  O IA 12.0.0.0/8 [110/75] via 5.0.0.2, 00:38:02, Serial2/1/0
  
  r2.2.2.2#show ip route ospf
  O IA 4.0.0.0/8 [110/74] via 5.0.0.1, 00:38:08, Serial0/1/0
  O IA 12.0.0.0/8 [110/11] via 6.0.0.3, 00:38:12, ATM1/0.20
  !-- これは上記の例で示した経路です。
  
  r3.3.3.3#show ip route ospf
  O    4.0.0.0/8 [110/75] via 6.0.0.2, 00:38:18, ATM2/0.20
  O    5.0.0.0/8 [110/65] via 6.0.0.2, 00:38:28, ATM2/0.20
  

仮想リンクの代用としての GRE トンネルの使用

ルータ 1.1.1.1 とルータ 3.3.3.3 の間に Generic Routing Encapsulation(GRE; 総称ルーティング カプセル化)トンネルを作成して、エリア 0 にトンネルを通すこともできます。GRE トンネルと仮想リンクの主な違いを次の表に示します。

GRE トンネル 仮想リンク
トンネル内のトラフィックはすべて、トンネル エンドポイントでカプセル化およびカプセル化解除されます。 ルーティング更新はトンネル伝送されますが、データ トラフィックはそのまま送信されます。
すべてのパケットのトンネル ヘッダーがオーバーヘッドを引き起こします。 データ トラフィックはトンネル オーバーヘッドの影響を受けません。
トンネルはスタブ エリアを通過できます。 スタブ エリア内のルータは外部の宛先への経路を持たないため、スタブ エリアをトランジット エリアにすることはできません。データはそのまま送信されるため、トランジット エリアを兼務するスタブ エリアに外部の宛先へのパケットが送信された場合、そのパケットは正しくルーティングされません。スタブ エリア内のルータが外部の特定の宛先への経路を持つことはありません。

debug および show コマンド

debug コマンドを発行する前に、「debug コマンドに関する重要な情報」を参照してください。

  • show ip ospf database - Link State Advertisement(LSA; リンクステート アドバタイズメント)のリストを表示し、それらをリンク ステート データベースに挿入します。このリストは LSA ヘッダー内の情報だけを示します。

  • show ip ospf database [router] [link-state-id] - データベース内に保持されている、特定のルータの LSA すべてを一覧表示します。LSA はすべてのルータによって生成されます。これらの基本的な LSA には、ルータのリンクまたはインターフェイスすべてと、そのリンクの状態および発信コストが含まれています。これらの LSA は生成されたエリア内にだけフラッディングされます。

  • show ip ospf [process-id [area-id]] database [summary] [link-state-id] - データベース内に保持されている、ネットワーク要約 LSA の情報だけを表示します。

  • show ip ospf database summary self-originate - 自身が発信した(ローカル ルータからの)LSA だけを表示します。

  • debug ip ospf adjacency - OSPF の隣接関係の構築または解除に関連するイベントを表示します。

debug の出力例

ルータは物理リンクと同じように、仮想リンクを使用して隣接関係を確立し、LSA を交換します。隣接関係を確認するには、ルータ LSA か、または debug ip ospf adjacency コマンドの出力を調べます。次に例を示します。

1w2d: OSPF: Rcv hello from 1.1.1.1 area 0 from OSPF_VL3 5.0.0.1
  1w2d: OSPF: 2 Way Communication to 1.1.1.1 on OSPF_VL3, state 2WAY
  1w2d: OSPF: Send DBD to 1.1.1.1 on OSPF_VL3 seq 0xD1C opt 0x62 flag 0x7 len 32
  1w2d: OSPF: End of hello processing
  1w2d: OSPF: Rcv DBD from 1.1.1.1 on OSPF_VL3 seq 0x1617 opt 0x22 flag 0x7 len 32  mtu 0 state EXSTART
  1w2d: OSPF: First DBD and we are not SLAVE
  1w2d: OSPF: Rcv DBD from 1.1.1.1 on OSPF_VL3 seq 0xD1C opt 0x22 flag 0x2 len 172  mtu 0 state EXSTART
  1w2d: OSPF: NBR Negotiation Done. We are the MASTER
  1w2d: OSPF: Send DBD to 1.1.1.1 on OSPF_VL3 seq 0xD1D opt 0x62 flag 0x3 len 172
  1w2d: OSPF: Database request to 1.1.1.1
  1w2d: OSPF: sent LS REQ packet to 5.0.0.1, length 36
  1w2d: OSPF: Rcv DBD from 1.1.1.1 on OSPF_VL3 seq 0xD1D opt 0x22 flag 0x0 len 32  mtu 0 state EXCHANGE
  1w2d: OSPF: Send DBD to 1.1.1.1 on OSPF_VL3 seq 0xD1E opt 0x62 flag 0x1 len 32
  1w2d: OSPF: Rcv DBD from 1.1.1.1 on OSPF_VL3 seq 0xD1E opt 0x22 flag 0x0 len 32  mtu 0 state EXCHANGE
  1w2d: OSPF: Exchange Done with 1.1.1.1 on OSPF_VL3
  1w2d: OSPF: Synchronized with 1.1.1.1 on OSPF_VL3, state FULL
  1w2d: OSPF: Build router LSA for area 0, router ID 3.3.3.3, seq 0x80000029
  1w2d: OSPF: Dead event ignored for 1.1.1.1 on demand circuit OSPF_VL3
  
  TAG-7505-1#show ip ospf neighbor
  Neighbor ID       Pri       State               Dead Time       Address         Interface
  2.2.2.2           1         FULL/  -            00:00:38        6.0.0.2         ATM2/0.20
  

仮想リンク上の隣接関係は、show ip ospf neighbor コマンドの出力中には表示されない点に注意してください。仮想リンク上の隣接関係を確認するには、ルータ LSA を表示する、隣接関係が確立されたときの debug コマンドを観察する、show ip ospf virtual-links コマンドを使用する、のいずれかの方法を使用します。


関連するシスコ サポート コミュニティ ディスカッション

シスコ サポート コミュニティは、どなたでも投稿や回答ができる情報交換スペースです。


関連情報


前のセクションに戻る 目次に戻る 次のセクションに進む

Document ID: 47866