IP : IP ルーティング

OSPF が複数エリアへの外部ルートを伝搬する方法

2002 年 10 月 29 日 - ライター翻訳版
その他のバージョン: PDFpdf | 機械翻訳版 (2013 年 8 月 21 日) | 英語版 (2005 年 8 月 10 日) | フィードバック

この設定例では、OSPF で外部ルートを複数のネットワーク エリアに伝搬する方法について説明します。

ネットワーク ダイアグラム

Network Diagram

設定

ルータ 1.1.1.1
 
 Current configuration:
 
 
 
 hostname r1.1.1.1
 
 
 
 interface Loopback0
 
  ip address 1.1.1.1 255.0.0.0
 
 
 
 interface Serial2/1/0
 
  ip address 5.0.0.1 255.0.0.0
 
 
 
 interface Ethernet2/0/0
 
  ip address 4.0.0.1 255.0.0.0
 
  
 
 router ospf 4
 
  redistribute static metric 5 metric-type 1
 
  network 5.0.0.0 0.255.255.255 area 1
 
 
 
 ip route 9.0.0.0 255.0.0.0 4.0.0.2
 
 
 
 end
 
 
ルータ 2.2.2.2
 
 Current configuration:
 
 
 
 hostname r2.2.2.2
 
 
 
 interface Loopback0
 
  ip address 2.2.2.2 255.0.0.0
 
  
 
 interface Serial0/1/0
 
  ip address 5.0.0.2 255.0.0.0
 
 
 
 interface ATM1/0.20
 
  ip address 6.0.0.2 255.0.0.0
 
  
 
 router ospf 2
 
  network 5.0.0.0 0.255.255.255 area 1
 
  network 6.0.0.0 0.255.255.255 area 0
 
 
 
 end
 
 
ルータ 3.3.3.3
 
 Current configuration:
 
 
 
 hostname r3.3.3.3
 
 
 
 interface Loopback0
 
  ip address 3.3.3.3 255.0.0.0
 
 
 
 interface ATM2/0.20 point-to-point
 
  ip address 6.0.0.3 255.0.0.0
 
  
 
 router ospf 2
 
  network 6.0.0.0 0.255.255.255 area 0
 
 
 
 end
 
 

OSPF データベースの検査

show ip ospf database コマンドを使用して、このネットワーク環境の情報が OSPF データベースにどのように格納されているかを見てみましょう。

 
 r2.2.2.2#show ip ospf database
 
   
 
        OSPF Router with ID (2.2.2.2) (Process ID 2) 
 
   
 
                 Router Link States (Area 0) 
 
   
 
 Link ID            ADV Router      Age            Seq#               Checksum     Link count 
 
 2.2.2.2             2.2.2.2        93             0x80000020         0xCD0B           2 
 
 3.3.3.3             3.3.3.3        1225           0x8000000D         0x9057           2 
 
   
 
                 Summary Net Link States (Area 0) 
 
   
 
 Link ID         ADV Router          Age         Seq#                   Checksum 
 
 4.0.0.0          2.2.2.2            73          0x80000001             0xFFE6 
 
 5.0.0.0          2.2.2.2            1651        0x80000006             0x8466 
 
   
 
                 Summary ASB Link States (Area 0) 
 
   
 
 Link ID         ADV Router          Age         Seq#                   Checksum 
 
 1.1.1.1          2.2.2.2            74          0x80000001             0x935C 
 
   
 
                 Router Link States (Area 1) 
 
   
 
 Link ID         ADV Router          Age         Seq#               Checksum     Link count 
 
 1.1.1.1          1.1.1.1            89          0x80000011         0xFF59           3 
 
 2.2.2.2          2.2.2.2            88          0x80000033         0x2130           2 
 
   
 
                 Summary Net Link States (Area 1) 
 
   
 
 Link ID         ADV Router          Age         Seq#               Checksum 
 
 6.0.0.0          2.2.2.2            94          0x8000001F         0xCC43 
 
   
 
                 Type-5 AS External Link States 
 
   
 
 Link ID         ADV Router          Age         Seq#               Checksum     Tag 
 
 9.0.0.0         1.1.1.1             135         0x80000001         0x3AE8        0 
 
   
 
 
 
 r2.2.2.2#show ip ospf database router 1.1.1.1 
 
   
 
        OSPF Router with ID (2.2.2.2) (Process ID 2) 
 
   
 
                 Router Link States (Area 1) 
 
   
 
   Routing Bit Set on this LSA 
 
   LS age: 109 
 
   Options: (No TOS-capability, DC) 
 
   LS Type: Router Links 
 
   Link State ID: 1.1.1.1
 
   !--- ルータ リンクの Link State ID は常に
 
   !-- Advertising Router と同じです。
 
   Advertising Router: 1.1.1.1
 
   !-- これは、この LSA を作成した
 
   !-- ルータのルータ ID です。
 
   LS Seq Number: 80000011 
 
   Checksum: 0xFF59 
 
   Length: 60 
 
   AS Boundary Router
 
   !-- ルータ LSA のビット E は、このルータが外部の LSA を
 
   !-- 発行しています。 
 
    Number of Links: 3
 
    !-- エリア 1 には 3 つのリンクがあります。 
 
   
 
     Link connected to: a Stub Network
 
 	!-- この行はイーサネット セグメント 4.0.0.0/8 を表します。
 
     !-- 4.0.0.0/8 
 
      (Link ID) Network/subnet number: 4.0.0.0 
 
      (Link Data) Network Mask: 255.0.0.0 
 
       Number of TOS metrics: 0 
 
        TOS 0 Metrics: 10
 
 	   !-- このイーサネット セグメントの OSPF コストです。 
 
   
 
     Link connected to: another Router (point-to-point)
 
 	!-- この行は、ルータ 1.1.1.1 が ルータ 2.2.2.2 の
 
 	!-- 近接ルータであることを示しています。 
 
      (Link ID) Neighboring Router ID: 2.2.2.2 
 
      (Link Data) Router Interface address: 5.0.0.1
 
 	 !-- ルータ 2.2.2.2 に接続しているインターフェイスのアドレスは
 
 	 !-- 5.0.0.1 です。 
 
       Number of TOS metrics: 0 
 
        TOS 0 Metrics: 64
 
 	   !-- OSPF cost of the link connecting the two routers 
 
   
 
     Link connected to: a Stub Network
 
 	!-- この行は、シリアル リンク 5.0.0.0/8 を表しています。 
 
      (Link ID) Network/subnet number: 5.0.0.0 
 
      (Link Data) Network Mask: 255.0.0.0 
 
       Number of TOS metrics: 0 
 
        TOS 0 Metrics: 64
 
 	   !-- このシリアル リンクの OSPF コストです。 
 
   
 
 r2.2.2.2#show ip ospf database router 2.2.2.2 
 
   
 
        OSPF Router with ID (2.2.2.2) (Process ID 2) 
 
   
 
                 Router Link States (Area 0) 
 
   
 
   LS age: 135 
 
   Options: (No TOS-capability, DC) 
 
   LS Type: Router Links 
 
   Link State ID: 2.2.2.2 
 
   Advertising Router: 2.2.2.2 
 
   LS Seq Number: 80000020 
 
   Checksum: 0xCD0B 
 
   Length: 48 
 
   Area Border Router
 
    Number of Links: 2
 
   
 
     Link connected to: another Router (point-to-point) 
 
      (Link ID) Neighboring Router ID: 3.3.3.3 
 
      (Link Data) Router Interface address: 6.0.0.2 
 
       Number of TOS metrics: 0 
 
        TOS 0 Metrics: 1 
 
   
 
     Link connected to: a Stub Network 
 
      (Link ID) Network/subnet number: 6.0.0.0 
 
      (Link Data) Network Mask: 255.0.0.0 
 
       Number of TOS metrics: 0 
 
        TOS 0 Metrics: 1 
 
   
 
   
 
                 Router Link States (Area 1) 
 
   
 
   LS age: 130 
 
   Options: (No TOS-capability, DC) 
 
   LS Type: Router Links 
 
   Link State ID: 2.2.2.2 
 
   Advertising Router: 2.2.2.2 
 
   LS Seq Number: 80000033 
 
   Checksum: 0x2130 
 
   Length: 48 
 
   Area Border Router
 
    Number of Links: 2
 
   
 
     Link connected to: another Router (point-to-point) 
 
      (Link ID) Neighboring Router ID: 1.1.1.1 
 
      (Link Data) Router Interface address: 5.0.0.2 
 
       Number of TOS metrics: 0 
 
        TOS 0 Metrics: 64 
 
   
 
     Link connected to: a Stub Network 
 
      (Link ID) Network/subnet number: 5.0.0.0 
 
      (Link Data) Network Mask: 255.0.0.0 
 
       Number of TOS metrics: 0 
 
        TOS 0 Metrics: 64 
 
   
 
 
 
 r2.2.2.2#show ip ospf database router 3.3.3.3 
 
   
 
        OSPF Router with ID (2.2.2.2) (Process ID 2) 
 
   
 
                 Router Link States (Area 0) 
 
   
 
 
 
   LS age: 1280 
 
   Options: (No TOS-capability, DC) 
 
   LS Type: Router Links 
 
   Link State ID: 3.3.3.3 
 
   Advertising Router: 3.3.3.3 
 
   LS Seq Number: 8000000D 
 
   Checksum: 0x9057 
 
   Length: 48 
 
    Number of Links: 2 
 
   
 
     Link connected to: another Router (point-to-point) 
 
      (Link ID) Neighboring Router ID: 2.2.2.2 
 
      (Link Data) Router Interface address: 6.0.0.3 
 
       Number of TOS metrics: 0 
 
        TOS 0 Metrics: 1 
 
   
 
     Link connected to: a Stub Network 
 
      (Link ID) Network/subnet number: 6.0.0.0 
 
      (Link Data) Network Mask: 255.0.0.0 
 
       Number of TOS metrics: 0 
 
        TOS 0 Metrics: 1 
 
 

あるエリアから他のエリアへのルートをアドバタイズするために、ABR で(タイプ 3)集約 LSA が作成されます。

 
 r2.2.2.2#show ip ospf database summary 4.0.0.0 
 
   
 
        OSPF Router with ID (2.2.2.2) (Process ID 2) 
 
   
 
                 Summary Net Link States (Area 0) 
 
   
 
   LS age: 184 
 
   Options: (No TOS-capability, DC) 
 
   LS Type: Summary Links(Network) 
 
   Link State ID: 4.0.0.0 (summary Network Number)
 
   !--4.0.0.0/8 は、ABR(ルータ 2.2.2.2)によって
 
   !-- エリア 0 にアドバタイズされます。 
 
   Advertising Router: 2.2.2.2 
 
   LS Seq Number: 80000001 
 
   Checksum: 0xFFE6 
 
   Length: 28 
 
   Network Mask: /8 
 
         TOS: 0  Metric: 74 
 
 
 
 
 
 
 
 r2.2.2.2#show ip ospf database summary 5.0.0.0 
 
   
 
        OSPF Router with ID (2.2.2.2) (Process ID 2) 
 
   
 
                 Summary Net Link States (Area 0) 
 
   
 
   LS age: 1768 
 
   Options: (No TOS-capability, DC) 
 
   LS Type: Summary Links(Network) 
 
   Link State ID: 5.0.0.0 (summary Network Number)
 
   !--5.0.0.0/8 は、ABR(ルータ 2.2.2.2)によって
 
   !-- エリア 0 にアドバタイズされます。 
 
   Advertising Router: 2.2.2.2 
 
   LS Seq Number: 80000006 
 
   Checksum: 0x8466 
 
   Length: 28 
 
   Network Mask: /8 
 
         TOS: 0  Metric: 64 
 
 
 
 
 
 
 
 r2.2.2.2#show ip ospf database summary 6.0.0.0 
 
   
 
        OSPF Router with ID (2.2.2.2) (Process ID 2) 
 
   
 
                 Summary Net Link States (Area 1) 
 
   
 
   LS age: 216 
 
   Options: (No TOS-capability, DC) 
 
   LS Type: Summary Links(Network) 
 
   Link State ID: 6.0.0.0
 
   !--6.0.0.0/8 はエリア 1 にアドバタイズされます。                 by the ABR(2.2.2.2) 
 
   Advertising Router: 2.2.2.2 
 
   LS Seq Number: 8000001F 
 
   Checksum: 0xCC43 
 
   Length: 28 
 
   Network Mask: /8 
 
         TOS: 0  Metric: 1 
 
 

外部ルートを OSPF にアドバタイズするために、autonomous system boundary router(ASBR;
自律システム境界ルータ)によって(タイプ 5)外部 LSA が作成されます。

 
 r2.2.2.2#show ip ospf database external 9.0.0.0 
 
   
 
        OSPF Router with ID (2.2.2.2) (Process ID 2) 
 
   
 
                 Type-5 AS External Link States 
 
   
 
   Routing Bit Set on this LSA 
 
   LS age: 286 
 
   Options: (No TOS-capability, DC) 
 
   LS Type: AS External Link 
 
   Link State ID: 9.0.0.0 (External Network Number )
 
   !--9.0.0.0/8 は、ASBR(ルータ 1.1.1.1)によって
 
   !-- アドバタイズされます。 
 
   Advertising Router: 1.1.1.1 
 
   LS Seq Number: 80000001 
 
   Checksum: 0x3AE8 
 
   Length: 36 
 
   Network Mask: /8 
 
         Metric Type: 1 (Comparable directly to link state metric) 
 
         TOS: 0 
 
         Metric: 5 
 
         Forward Address: 0.0.0.0
 
 		!-- ルータ 1.1.1.1 のイーサネットには OSPF 近接ルータがないため、
 
  		!-- 転送先アドレスは指定されません。 
 
         External Route Tag: 0 
 
 

ASBR が他のエリアに到達する可能性をアドバタイズするために、ABR は(タイプ 4)ASBR 集約 LSA を作成します。

 
 r2.2.2.2#show ip ospf database asbr-summary 1.1.1.1 
 
   
 
        OSPF Router with ID (2.2.2.2) (Process ID 2) 
 
   
 
                 Summary ASB Link States (Area 0) 
 
   
 
   LS age: 266 
 
   Options: (No TOS-capability, DC) 
 
   LS Type: Summary Links(AS Boundary Router) 
 
   Link State ID: 1.1.1.1 (AS Boundary Router address)
 
   !--- ABR(Router 2.2.2.2)は、ASBR(Router 1.1.1.1)への到達方法を
 
   !-- 検知していることをアドバタイズします。 
 
   Advertising Router: 2.2.2.2 
 
   LS Seq Number: 80000001 
 
   Checksum: 0x935C 
 
   Length: 28 
 
   Network Mask: /0 
 
         TOS: 0  Metric: 64
 
 		!--- ABR が ASBR に到達するコストです。 
 
 

ABR(ルータ 2.2.2.2)は、ASBR(ルータ 1.1.1.1)から学習した外部ルートをすでに設定し、エリア 1 からエリア 0 に外部 LSA をフラッドしました(外部 LSA は、変更されないでエリアに対してフラッドされます)。 ただし、ASBR がエリア 0 ではないため、エリア 0 にあるルータでは ASBR への到達方法が検知できません。 ABR が ASBR 集約 LSA を作成し、ルータ 1.1.1.1 への到達可能性をエリア 0 にアドバタイズするのはこのためです。

最短パスの計算

ここでは、ルータ 3.3.3.3 の観点から最短パスを計算してみます。

ルータ 3.3.3.3 は自身の LSA を参照し、ルータ 2.2.2.2 が近接ルータであることを認識します。 続いてルータ 2.2.2.2 の LSA を参照し、ルータ 2.2.2.2 がルータ 3.3.3.3 を近接ルータとして認識していることを確認します。 両方のルータが互いに近接ルータとして認識しあっている場合、両ルータは到達可能と見なされます。

さらに各ルータはローカルの近接ルータ テーブル(show ip ospf neighbor コマンドで表示できる)をチェックし、自身のインターフェイスと近接ルータのインターフェイスが共通の IP サブネット上にあることを確認します。

: このチェックは番号なしインターフェイスでは行われません。

インターフェイスが共通のサブセットにある場合、ルータは近接ルータの LSA にリストされているすべてのスタブ ネットワークへのルートを設定します。 この文書の例では、エリア 1 の ルータ 2.2.2.2 の LSA にリストされているスタブ ネットワークは 60.0.0.0/8 だけであり、ルータ 3.3.3.3 はこのネットワークにすでに直接接続されています。

エリア 1 内の到達可能なルータ LSA すべてについて検査した後、ルータ 3.3.3.3 はデータベースに保持されている集約 LSA を参照します。 4.0.0.0/8 と 5.0.0.0/8 に関する集約 LSA が見つかります。ルータ 3.3.3.3 でこの集約 LSA を作成したアドバタイジング ルータへの到達方法が分かっている場合は、そのルートを自身のルーティング テーブルに設定します。 この例では、アドバタイジング ルータはルータ 2.2.2.2 であり、ルータ 3.3.3.3 ではこのルータへの到達方法が分かっています。したがって、4.0.0.0/8 と 5.0.0.0/8 へのルートがルーティング テーブルに設定されます。 これらのルートへのメトリックは、アドバタイジング ルータへ到達するまでのメトリックに、集約 LSA のメトリックを足したものになります。 集約 LSA のメトリックは、集約 LSA を作成するときの対象となるエリア内ルートまたはエリア間ルートに到達するコストから計算されます。

すべての内部 OSPF ルート(エリア内およびエリア間)を計算した後、ルータ 3.3.3.3 は外部 LSA を検査します。 最初に ASBR 1.1.1.1 によって作成された外部 LSA 9.0.0.0/8 を検査し、次にこの ASBR までの到達方法を計算します。 ルータ 3.3.3.3 によってルータ 1.1.1.1 に対する ASBR 集約 LSA が検査されます。これは ABR(ルータ 2.2.2.2)によって作成されたものです。 これにより、ルータ 3.3.3.3 では ABR を経由して ASBR に到達可能であることが判明します。 この結果、ルータ 3.3.3.3 は 9.0.0.0/8 へのルートを自身のルーティング テーブルに設定します。 この例では、これが E1 ルートです。したがって、メトリックは、ルータ 3.3.3.3 が ABR に到達するためのメトリックと、ABR が ASBR に到達するためのメトリック、および外部 LSA のメトリックを足し合わせたものになります。

次の出力は、上記の各ルータのルーティング テーブルに格納された OSPF 経路を示しています。

 
 r3.3.3.3#show ip route ospf 
 
 O IA 4.0.0.0/8 [110/75] via 6.0.0.2, 00:07:59, ATM2/0.20 
 
 O IA 5.0.0.0/8 [110/65] via 6.0.0.2, 00:07:59, ATM2/0.20 
 
 O E1 9.0.0.0/8 [110/70] via 6.0.0.2, 00:07:59, ATM2/0.20 
 
   
 
 
 
 r2.2.2.2#show ip route ospf 
 
 O    4.0.0.0/8 [110/74] via 5.0.0.1, 00:06:55, Serial0/1/0 
 
 O E1 9.0.0.0/8 [110/69] via 5.0.0.1, 00:06:55, Serial0/1/0 
 
   
 
 
 
 r1.1.1.1#show ip route 9.0.0.0 
 
 Routing entry for 9.0.0.0/8 
 
   Known via "static", distance 1, metric 0 
 
   Redistributing via ospf 4 
 
   Advertised by ospf 4 metric 5 metric-type 1 
 
   Routing Descriptor Blocks: 
 
   * 4.0.0.2 
 
       Route metric is 0, traffic share count is 1 
 
 


関連情報


前のセクションへ戻る 目次へ戻る 次のセクションへ進む

関連するシスコ サポート コミュニティ ディスカッション

シスコ サポート コミュニティは、どなたでも投稿や回答ができる情報交換スペースです。


Document ID: 47865