IP : IP ルーティング

マルチアクセス ネットワークで接続されている OSPF ルータ

2002 年 10 月 29 日 - ライター翻訳版
その他のバージョン: PDFpdf | 機械翻訳版 (2013 年 8 月 21 日) | 英語版 (2005 年 8 月 10 日) | フィードバック

この設定例では、マルチアクセス ネットワークで接続されている 2 台の OSPF ルータについて説明します。

ネットワーク ダイアグラム

Network Diagram

設定

ルータ 1.1.1.1 ルータ 2.2.2.2
   
   Current configuration:
   
   
   
   hostname r1.1.1.1
   
   
   
   interface Loopback0
   
    ip address 1.1.1.1 255.0.0.0
   
    
   
   interface Ethernet2/0/0
   
    ip address 4.0.0.1 255.0.0.0
   
    
   
   interface Ethernet2/0/2
   
    ip address 5.0.0.1 255.0.0.0
   
    
   
   router ospf 1
   
    network 4.0.0.0 0.255.255.255 area 0
   
    network 5.0.0.0 0.255.255.255 area 0
   
   
   
   end
   
   
   
   Current configuration:
   
   
   
   hostname r2.2.2.2
   
   
   
   interface Loopback0
   
    ip address 2.2.2.2 255.0.0.0
   
    
   
   interface Ethernet0/0/4
   
    ip address 6.0.0.2 255.0.0.0
   
    
   
   interface Ethernet0/0/2
   
    ip address 5.0.0.2 255.0.0.0
   
    
   
   router ospf 2
   
    network 6.0.0.0 0.255.255.255 area 0
   
    network 5.0.0.0 0.255.255.255 area 0
   
   
   
   end
   
   

OSPF データベースの検査

このネットワーク環境の情報が OSPF データベースにどのように格納されているかを確認するには、show ip ospf database コマンドの出力を調べます。

   
    r2.2.2.2#show ip ospf database 
   
   
   
          OSPF Router with ID (2.2.2.2) (Process ID 2) 
   
   
   
                   Router Link States (Area 0) 
   
   
   
   Link ID         ADV Router      Age         Seq#               Checksum     Link count 
   
   1.1.1.1         1.1.1.1         107         0x80000018         0x7966           2 
   
   2.2.2.2         2.2.2.2         106         0x80000015         0x6770           2 
   
   
   
                   Net Link States (Area 0) 
   
   
   
   Link ID         ADV Router      Age         Seq#               Checksum 
   
   5.0.0.2         2.2.2.2         102         0x80000004         0x7E9D 
   
     
   
   
   
   r2.2.2.2#show ip ospf database router 1.1.1.1 
   
   
   
          OSPF Router with ID (2.2.2.2) (Process ID 2) 
   
   
   
                   Router Link States (Area 0) 
   
   
   
     LS age: 147 
   
     Options: (No TOS-capability, DC) 
   
     LS Type: Router Links 
   
     Link State ID: 1.1.1.1
   
     !--- ルータ リンクの Link State ID は常に
   
     !-- Advertising Router と同じです。 
   
     Advertising Router: 1.1.1.1
   
     !-- これは、この LSA を作成した
   
     !-- ルータのルータ ID です。
   
     LS Seq Number: 80000018 
   
     Checksum: 0x7966 
   
     Length: 48 
   
      Number of Links: 2 
   
   
   
       Link connected to: a Transit Network
   
       !-- このルータ(1.1.1.1)には、次にリストされている代表ルータ(DR)と
   
       !-- バックアップ代表ルータ(BDR)を持つトランジット ネットワークに
   
       !-- 接続されているリンクがあります。  
   
        (Link ID) Designated Router address: 5.0.0.2
   
   	 !-- The DR's interface IP address is 5.0.0.2 
   
        (Link Data) Router Interface address: 5.0.0.1
   
   	 !-- DR に接続されているこのルータ(1.1.1.1)のインターフェイス アドレスは、
   
        !-- 5.0.0.1 です。 
   
         Number of TOS metrics: 0 
   
          TOS 0 Metrics: 10
   
          !-- このリンクの ospf コストは 10 です。 
   
   
   
       Link connected to: a Stub Network 
   
       !-- この行はイーサネット セグメントのサブネット 4.0.0.0/8 を示しています。
   
       !-- 4.0.0.0/8 
   
        (Link ID) Network/subnet number: 4.0.0.0 
   
        (Link Data) Network Mask: 255.0.0.0 
   
         Number of TOS metrics: 0 
   
          TOS 0 Metrics: 10
   
          !-- このリンクのコストは 10 です。 
   
   
   
   r2.2.2.2#show ip ospf database router 2.2.2.2 
   
   
   
          OSPF Router with ID (2.2.2.2) (Process ID 2) 
   
   
   
                   Router Link States (Area 0) 
   
   
   
     LS age: 162 
   
     Options: (No TOS-capability, DC) 
   
     LS Type: Router Links 
   
     Link State ID: 2.2.2.2 
   
     Advertising Router: 2.2.2.2 
   
     LS Seq Number: 80000015 
   
     Checksum: 0x6770 
   
     Length: 48 
   
      Number of Links: 2 
   
   
   
       Link connected to: a Transit Network 
   
        (Link ID) Designated Router address: 5.0.0.2
   
        !-- DR のインターフェイス IP アドレスは 5.0.0.2 です。 
   
        (Link Data) Router Interface address: 5.0.0.2
   
        !-- これらの値が等しいため、このルータ(2.2.2.2)が
   
        !-- DR になります。 
   
         Number of TOS metrics: 0 
   
          TOS 0 Metrics: 10 
   
   
   
       Link connected to: a Stub Network 
   
        (Link ID) Network/subnet number: 6.0.0.0 
   
        (Link Data) Network Mask: 255.0.0.0 
   
         Number of TOS metrics: 0 
   
          TOS 0 Metrics: 10 
   
     
   
   
   
   r2.2.2.2#show ip ospf database network 5.0.0.2 
   
   
   
          OSPF Router with ID (2.2.2.2) (Process ID 2) 
   
   
   
                   Net Link States (Area 0) 
   
   
   
     Routing Bit Set on this LSA 
   
     LS age: 182 
   
     Options: (No TOS-capability, DC) 
   
     LS Type: Network Links 
   
     Link State ID: 5.0.0.2 (address of Designated Router)
   
     !-- これは DR の IP アドレスです
   
     !--(ルータ ID ではありません)。 
   
     Advertising Router: 2.2.2.2
   
     !-- これは、この LSA を作成したルータの
   
     !--- ルータ ID です。
   
     LS Seq Number: 80000004 
   
     Checksum: 0x7E9D 
   
     Length: 32 
   
     Network Mask: /8
   
     !-- ネットワーク 5.0.0.0/8 に到達するためのバイナリおよび DR の
   
     !-- マスク付きのインターフェイス アドレスです。 
   
           Attached Router: 2.2.2.2
   
   	!-- DR のルータ ID と、トランジット ネットワークに隣接する
   
       !-- ルータのリストです。 
   
           Attached Router: 1.1.1.1 
   
   

最短パスの計算

ここでは、ルータ 1.1.1.1 の観点から最短パス ツリーを計算してみます。

ルータ 1.1.1.1 は自身の LSA を調べ、DR のインターフェイス アドレスが 5.0.0.2 であるトランジット ネットワークへのリンクがあることを確認します。 次に、link state ID が 5.0.0.2 のネットワーク LSA を探します。 ネットワーク LSA には接続されているルータのリスト(ルータ 1.1.1.1 と 2.2.2.2)があります。 これは、これらのルータがこのトランジット ネットワーク経由で到達可能であることを意味しています。 ルータ 1.1.1.1 は、自身の ID がリスト内にあることを検証できたため、これらの接続されている各ルータを経由するルートを計算することができます。

ルータ 1.1.1.1 はルータ 2.2.2.2 の LSA を探して、同じトランジット ネットワーク 5.0.0.2 に接続されているリンクが含まれていることを確認します。 この時点で、ルータ 1.1.1.1 はルータ 2.2.2.2 の LSA にあるすべてのスタブ ネットワークへのルートを開設できます。

ルータ 1.1.1.1 は、ルーティング テーブルに 6.0.0.0/8 へのルートを設定します。これは、6.0.0.0/8 が自身の LSA にスタブ ネットワークとしてリストされているためです。

   
   r1.1.1.1#show ip route ospf 
   
   O    6.0.0.0/8 [110/20] via 5.0.0.2, 00:03:35, Ethernet2/0/2 
   
   
   
   r2.2.2.2#show ip route ospf 
   
   O    4.0.0.0/8 [110/20] via 5.0.0.1, 00:03:18, Ethernet0/0/2 
   
   

OSPF リンクステート データベースは、ブロードキャスト ネットワークまたは非ブロードキャスト ネットワークの場合には同一に見えます。 主な違いは近隣探索メカニズムです。 ブロードキャスト ネットワークでは、近接ルータはマルチキャスト hello パケットによって検出されます。 非ブロードキャスト ネットワークの場合、近接ルータはスタティックに設定され、近接ルータ間の隣接関係を確立するためにユニキャスト hello パケットが送出されます。

非ブロードキャスト マルチアクセス ネットワークでのネクストホップ

Nonbroadcast Multiaccess(NBMA; 非ブロードキャスト マルチアクセス)ネットワークでのネクストホップの問題を考察するために、次の例を使用します。 これらはトランジット ネットワーク上にある 3 台のルータです(ルータ non_DR_a、ルータ non_DR_b、およびルータ DR)。 これはフレームリレー、Asynchronous Transfer Mode(ATM)、または X.25 のような NBMA メディア上にあるハブアンドスポーク トポロジです。

Network Diagram

ルータ non_DR_a がルータ non_DR_b 経由のルートを計算する場合、ルータ non_DR_b をネクストホップとします。 ただし、ルータ non_DR_a にはルータ non_DR_b への virtual circuit(VC; 仮想回線)がないため、これらのルータが互いに ping を実行することはできません。 このことは、到達できないネクストホップが OSPF によってルーティング テーブルに設定されていることを意味します。

この問題の解決策は、2 つ目の frame-relay map 文を追加して、ルータ DR に繋がる VC を経由してすべての近接ルータが到達可能になるようにすることです。たとえば、次のようにします。

   
   interface Serial0 
   
    frame-relay map ip 1.1.1.1 700 broadcast
   
    !-- これは DR に対するマップです。 
   
    frame-relay map ip 1.1.1.2 700 broadcast
   
    !-- non-DR ルータに対する同一の VC データリンク接続識別子
   
    !--(DLCI)に対するマップです。 
   
   

この動作を Intermediate System-to-Intermediate System(IS-IS)プロトコルの動作と比較してみましょう。 ネクストホップが近接ルータでない限り、ルータはネクストホップを経由する IS-IS ルートを設定しません。 このことは、ルータがフル メッシュでない場合は、マルチポイント インターフェイスで IS-IS は動作しないことを意味しています。

OSPF では、ネクストホップが近接ルータでなく、レイヤ 2 経由での到達が不可能な場合でもルートを設定します。ただし、この問題は map 文を複数設定することで解決できます。


関連情報


前のセクションへ戻る 目次へ戻る 次のセクションへ進む

関連するシスコ サポート コミュニティ ディスカッション

シスコ サポート コミュニティは、どなたでも投稿や回答ができる情報交換スペースです。


Document ID: 47863