IP : IP ルーティング

ポイントツーマルチポイント リンクによって接続された OSPF ルータ

2002 年 10 月 29 日 - ライター翻訳版
その他のバージョン: PDFpdf | 機械翻訳版 (2013 年 8 月 21 日) | 英語版 (2005 年 8 月 10 日) | フィードバック

この設定例では、ポイントツーマルチポイント リンクによって接続されている 2 台の OSPF ルータについて説明します。

ネットワーク ダイアグラム

Network Diagram

設定

ルータ 1.1.1.1 ルータ 2.2.2.2
   
   Current configuration:
   
   
   
   hostname r1.1.1.1
   
   
   
   interface Loopback0
   
    ip address 1.1.1.1 255.0.0.0
   
    
   
   interface Ethernet2/0/0
   
    ip address 4.0.0.1 255.0.0.0
   
    
   
   interface Serial2/1/0
   
    ip address 5.0.0.1 255.0.0.0
   
    ip ospf network point-to-multipoint
   
    
   
   router ospf 1
   
    network 4.0.0.0 0.255.255.255 area 0
   
    network 5.0.0.0 0.255.255.255 area 0
   
   
   
   end
   
   
   
   Current configuration:
   
   
   
   hostname r2.2.2.2
   
   
   
   interface Loopback0
   
    ip address 2.2.2.2 255.0.0.0
   
    
   
   interface Ethernet0/0/4
   
    ip address 6.0.0.2 255.0.0.0
   
    
   
   interface Serial2/1/0
   
    ip address 5.0.0.2 255.0.0.0
   
    ip ospf network point-to-multipoint
   
    
   
   router ospf 2
   
    network 6.0.0.0 0.255.255.255 area 0
   
    network 5.0.0.0 0.255.255.255 area 0
   
   
   
   end
   
   

OSPF データベースの検査

このネットワーク環境の情報が OSPF データベースにどのように格納されているかを確認するには、show ip ospf database コマンドの出力を調べます。

   
   r2.2.2.2#show ip ospf database 
   
   
   
          OSPF Router with ID (2.2.2.2) (Process ID 2) 
   
   
   
                   Router Link States (Area 0) 
   
   
   
   Link ID         ADV Router      Age             Seq#           Checksum     Link count 
   
   1.1.1.1         1.1.1.1         206             0x8000000A     0x158C         3 
   
   2.2.2.2         2.2.2.2         206             0x8000000B     0x791          3 
   
   
   
   r2.2.2.2#show ip ospf database router 1.1.1.1 
   
   
   
          OSPF Router with ID (2.2.2.2) (Process ID 2) 
   
   
   
                   Router Link States (Area 0) 
   
   
   
     LS age: 224 
   
     Options: (No TOS-capability, DC) 
   
     LS Type: Router Links 
   
     Link State ID: 1.1.1.1
   
     !--- ルータ リンクの Link State ID は常に
   
     !-- Advertising Router(次の行)と同じです。
   
     Advertising Router: 1.1.1.1
   
     !-- これは、この LSA を作成した
   
     !-- ルータのルータ ID です。
   
     LS Seq Number: 8000000A 
   
     Checksum: 0x158C 
   
     Length: 60 
   
      Number of Links: 3 
   
   
   
       Link connected to: another Router (point-to-point) 
   
       !-- この行は、ルータ(1.1.1.1)が 2.2.2.2 の近接ルータに
   
   	!-- なっていることを示しています。
   
        (Link ID) Neighboring Router ID: 2.2.2.2 
   
        (Link Data) Router Interface address: 5.0.0.1 
   
        !-- この行は、近接ルータ(2.2.2.2)に接続されているこのルータ 1.1.1.1)の
   
   	 !-- インターフェイスを示しています。
   
         Number of TOS metrics: 0 
   
          TOS 0 Metrics: 64  
   
          !-- このリンクの ospf コストは 64です。
   
   
   
       Link connected to: a Stub Network 
   
       !-- このルータ(1.1.1.1)のインターフェイスは、ポイントツーマルチポイント ネットワークに
   
       !-- 接続されています。 
   
        (Link ID) Network/subnet number: 5.0.0.1 
   
        (Link Data) Network Mask: 255.255.255.255
   
        !-- マスクに注意してください。サブネット全体ではなく、このインターフェイスだけが
   
        !-- アドバタイズされています。 
   
         Number of TOS metrics: 0 
   
          TOS 0 Metrics: 0
   
          !-- このルータが自身のインターフェイスに到達するための OSPF コストは
   
          !-- ゼロです。 
   
   
   
       Link connected to: a Stub Network
   
   	!-- イーサネット セグメント のサブネット 4.0.0.0/8 を表しています。 
   
        (Link ID) Network/subnet number: 4.0.0.0 
   
        (Link Data) Network Mask: 255.0.0.0 
   
         Number of TOS metrics: 0 
   
          TOS 0 Metrics: 10
   
   	   !-- このリンクのコストは 10 です。
   
   
   
   r2.2.2.2#show ip ospf database router 2.2.2.2 
   
   
   
          OSPF Router with ID (2.2.2.2) (Process ID 2) 
   
   
   
                   Router Link States (Area 0) 
   
   
   
     LS age: 253 
   
     Options: (No TOS-capability, DC) 
   
     LS Type: Router Links 
   
     Link State ID: 2.2.2.2 
   
     Advertising Router: 2.2.2.2 
   
     LS Seq Number: 8000000B 
   
     Checksum: 0x791 
   
     Length: 60 
   
      Number of Links: 3 
   
   
   
       Link connected to: another Router (point-to-point) 
   
        (Link ID) Neighboring Router ID: 1.1.1.1 
   
        (Link Data) Router Interface address: 5.0.0.2 
   
         Number of TOS metrics: 0 
   
          TOS 0 Metrics: 64 
   
   
   
       Link connected to: a Stub Network 
   
        (Link ID) Network/subnet number: 5.0.0.2 
   
        (Link Data) Network Mask: 255.255.255.255 
   
         Number of TOS metrics: 0 
   
          TOS 0 Metrics: 0 
   
   
   
       Link connected to: a Stub Network 
   
        (Link ID) Network/subnet number: 6.0.0.0 
   
        (Link Data) Network Mask: 255.0.0.0 
   
         Number of TOS metrics: 0 
   
          TOS 0 Metrics: 10
   
   

最短パスの計算

ここでは、ルータ 2.2.2.2 の観点から最短パス ツリーを計算してみます。

ルータ 2.2.2.2 は自身の LSA を参照し、ルータ 1.1.1.1 が近接ルータであることを認識します。 ルータ 2.2.2.2 がルータ 1.1.1.1 の LSA を参照し、1.1.1.1 が 2.2.2.2 を近接ルータとして認識していることを確認します。 両方のルータが互いに近接ルータとして認識しあっている場合、両ルータは到達可能と見なされます。

さらに各ルータはローカルの近接ルータ テーブル(show ip ospf neighbor コマンドで表示できる)をチェックし、自身のインターフェイスと近接ルータのインターフェイスが共通の IP サブネット上にあることを確認します。 確認ができたら、両ルータは近接ルータの LSA にリストされているスタブ ネットワークへのルートを設定します。

この例では、ルータ 1.1.1.1 のルータ LSA 内にスタブ ネットワークとして 4.0.0.0/8 がリストされているため、ルータ 2.2.2.2 は自身のルーティング テーブル内に 4.0.0.0/8 へのルートを設定します。 ルータ 1.1.1.1 では 5.0.0.1/32 もスタブとしてリストされています。これはポイントツーマルチポイント ネットワークに対するインターフェイスです。 そのため、ルータ 2.2.2.2 は自身のルーティング テーブルに 5.0.0.1/32 への OSPF ルートを設定します。

   
   Router 2.2.2.2#show ip route ospf 
   
   O    4.0.0.0/8 [110/74] via 5.0.0.1, 00:09:26, Serial0/1/0 
   
   O    5.0.0.1/32 [110/64] via 5.0.0.1, 00:09:26, Serial0/1/0
   
     
   
   Router 1.1.1.1#show ip route ospf 
   
   O    6.0.0.0/8 [110/74] via 5.0.0.2, 00:00:49, Serial2/1/0 
   
   O    5.0.0.2/32 [110/64] via 5.0.0.2, 00:00:49, Serial2/1/0
   
   


関連情報


前のセクションへ戻る 目次へ戻る 次のセクションへ進む

関連するシスコ サポート コミュニティ ディスカッション

シスコ サポート コミュニティは、どなたでも投稿や回答ができる情報交換スペースです。


Document ID: 47862