IP : IP ルーティング

番号付きポイントツーポイント リンクによって接続された OSPF ルータ

2002 年 10 月 29 日 - ライター翻訳版
その他のバージョン: PDFpdf | 機械翻訳版 (2013 年 8 月 21 日) | 英語版 (2005 年 8 月 10 日) | フィードバック

この設定例では、番号付きポイントツーポイント リンクによって接続されている 2 台の OSPF ルータについて説明します。

ネットワーク ダイアグラム

Network Diagram

設定

ルータ 1.1.1.1 ルータ 2.2.2.2
  
  Current configuration:
  
  
  
  hostname r1.1.1.1
  
  
  
  interface Loopback0
  
   ip address 1.1.1.1 255.0.0.0
  
   
  
  interface Ethernet2/0/0
  
   ip address 4.0.0.1 255.0.0.0
  
   
  
  interface Serial2/1/0
  
   ip address 5.0.0.1 255.0.0.0
  
   
  
  router ospf 1
  
   network 4.0.0.0 0.255.255.255 area 0
  
   network 5.0.0.0 0.255.255.255 area 0
  
  
  
  end
  
  
  
  Current configuration:
  
  
  
  hostname r2.2.2.2
  
  
  
  interface Loopback0
  
   ip address 2.2.2.2 255.0.0.0
  
   
  
  interface Ethernet0/0/4
  
   ip address 6.0.0.2 255.0.0.0
  
   
  
  interface Serial2/1/0
  
   ip address 5.0.0.2 255.0.0.0
  
   
  
  router ospf 2
  
   network 6.0.0.0 0.255.255.255 area 0
  
   network 5.0.0.0 0.255.255.255 area 0
  
  
  
  end
  
  

OSPF データベースの検査

このネットワーク環境の情報が OSPF データベースにどのように格納されているかを確認するには、show ip ospf database コマンドの出力を調べます。

  
  r2.2.2.2#show ip ospf database 
  
  
  
         OSPF Router with ID (2.2.2.2) (Process ID 2) 
  
  
  
                  Router Link States (Area 0) 
  
  
  
  Link ID         ADV Router        Age         Seq#               Checksum     Link count 
  
  1.1.1.1         1.1.1.1           522         0x80000002         0x96D3           3 
  
  2.2.2.2         2.2.2.2           401         0x80000003         0x9FC2           3 
  
  
  
  r2.2.2.2#show ip ospf database router 1.1.1.1 
  
  
  
         OSPF Router with ID (2.2.2.2) (Process ID 2) 
  
  
  
                  Router Link States (Area 0) 
  
  
  
    LS age: 540 
  
    Options: (No TOS-capability, DC) 
  
    LS Type: Router Links 
  
    Link State ID: 1.1.1.1
  
    !--- ルータ リンクの Link State ID は常に
  
    !-- Advertising Router(次の行)と同じです。
  
    Advertising Router: 1.1.1.1
  
    !-- これは、この LSA を作成した
  
    !-- ルータのルータ ID です。 
  
    LS Seq Number: 80000002 
  
    Checksum: 0x96D3 
  
    Length: 60 
  
     Number of Links: 3 
  
  
  
      Link connected to: another Router (point-to-point)
  
      !--- このエントリは、このルータ(1.1.1.1)が 2.2.2.2 の
  
      !--- 近接ルータであることを示しています。
  
       (Link ID) Neighboring Router ID: 2.2.2.2 
  
       (Link Data) Router Interface address: 5.0.0.1
  
       !-- このルータ(1.1.1.1)のインターフェイスは、
  
       !---近隣ルータ(2.2.2.2)に接続します。
  
        Number of TOS metrics: 0 
  
         TOS 0 Metrics: 64
  
       	!-- このリンクの ospf コストは 64 です。
  
  
  
      Link connected to: a Stub Network
  
  	!-- シリアル リンク 5.0.0.0/8 のサブネットを表しています。 
  
       (Link ID) Network/subnet number: 5.0.0.0 
  
       (Link Data) Network Mask: 255.0.0.0 
  
        Number of TOS metrics: 0 
  
         TOS 0 Metrics: 64
  
  		!-- このリンクの ospf コストは 64 です。
  
  
  
      Link connected to: a Stub Network
  
  	!-- This represents the subnet of the Ethernet segment 4.0.0.0/8
  
       (Link ID) Network/subnet number: 4.0.0.0 
  
       (Link Data) Network Mask: 255.0.0.0 
  
        Number of TOS metrics: 0 
  
         TOS 0 Metrics: 10
  
  		!-- このリンクの ospf コストは 10 です。
  
    
  
  
  
  r2.2.2.2#show ip ospf database router 2.2.2.2 
  
  
  
         OSPF Router with ID (2.2.2.2) (Process ID 2) 
  
  
  
                  Router Link States (Area 0) 
  
  
  
    LS age: 424 
  
    Options: (No TOS-capability, DC) 
  
    LS Type: Router Links 
  
    Link State ID: 2.2.2.2 
  
    Advertising Router: 2.2.2.2 
  
    LS Seq Number: 80000003 
  
    Checksum: 0x9FC2 
  
    Length: 60 
  
     Number of Links: 3 
  
  
  
      Link connected to: a Stub Network 
  
       (Link ID) Network/subnet number: 6.0.0.0 
  
       (Link Data) Network Mask: 255.0.0.0 
  
        Number of TOS metrics: 0 
  
         TOS 0 Metrics: 10 
  
  
  
      Link connected to: another Router (point-to-point) 
  
       (Link ID) Neighboring Router ID: 1.1.1.1 
  
       (Link Data) Router Interface address: 5.0.0.2 
  
        Number of TOS metrics: 0 
  
         TOS 0 Metrics: 64 
  
    
  
      Link connected to: a Stub Network 
  
       (Link ID) Network/subnet number: 5.0.0.0 
  
       (Link Data) Network Mask: 255.0.0.0 
  
        Number of TOS metrics: 0 
  
         TOS 0 Metrics: 64
  
  

最短パスの計算

ここでは、ルータ 2.2.2.2 の観点から最短パス ツリーを計算してみます。

ルータ 2.2.2.2 は自身の LSA を参照し、ルータ 1.1.1.1 が近接ルータであることを認識します。 ルータ 2.2.2.2 がルータ 1.1.1.1 の LSA を参照し、1.1.1.1 が 2.2.2.2 を近接ルータとして認識していることを確認します。 両方のルータが互いに近接ルータとして認識しあっている場合、両ルータは到達可能と見なされます。

さらに各ルータはローカルの近接ルータ テーブル(show ip ospf neighbor コマンドで表示できる)をチェックし、自身のインターフェイスと近接ルータのインターフェイスが共通の IP サブネット上にあることを確認します。 確認ができたら、両ルータは近接ルータの LSA にリストされているスタブ ネットワークへのルートを設定します。

この例では、ルータ 1.1.1.1 のルータ LSA 内にスタブ ネットワークとして 4.0.0.0/8 がリストされているため、ルータ 2.2.2.2 は自身のルーティング テーブル内に 4.0.0.0/8 への経路を開設します。 ルータ 1.1.1.1 では 5.0.0.0/8 もスタブ ネットワークとしてリストされていますが、ルータ 2.2.2.2 には 5.0.0.0/8 に接続されたルートがあるため、5.0.0.0/8 への OSPF ルートは開設されません(接続されているルートは、ダイナミックに学習されたルートよりも常に優先されます)。

  
  Router 2_2_2_2#show ip route ospf 
  
  O    4.0.0.0/8 [110/74] via 5.0.0.1, 00:09:26, Serial0/1/0 
  
  
  
  Router 1_1_1_1#show ip route ospf 
  
  O    6.0.0.0/8 [110/74] via 5.0.0.2, 00:00:49, Serial2/1/0  
  
  


関連情報


前のセクションへ戻る 目次へ戻る 次のセクションへ進む

関連するシスコ サポート コミュニティ ディスカッション

シスコ サポート コミュニティは、どなたでも投稿や回答ができる情報交換スペースです。


Document ID: 47861