IP : IP ルーティング

非番号シリアル リンクによって接続された OSPF ルータ

2002 年 6 月 1 日 - ライター翻訳版
その他のバージョン: PDFpdf | 機械翻訳版 (2013 年 8 月 21 日) | 英語版 (2005 年 5 月 19 日) | フィードバック

目次


概要

ip unnumbered 設定コマンドを使用すると、シリアル インターフェイスに明示的な IP アドレスを割り当てずに IP 処理を行うことができます。IP 非番号インターフェイスはルータにすでに設定されている別のインターフェイスの IP アドレスを「借用」できるため、ネットワーク空間とアドレス空間を節約できます。この設定例は非番号シリアル リンクによって接続されている 2 台の OSPF ルータを示しています。

ネットワーク ダイアグラム

ネットワーク ダイアグラム

設定例

ルータ 1.1.1.1 ルータ 2.2.2.2
Current configuration:
   
   hostname r1.1.1.1
   
   interface Loopback0
    ip address 1.1.1.1 255.0.0.0
   
   interface Ethernet2/0/0
    ip address 4.0.0.1 255.0.0.0
   
   interface Serial2/1/0
    ip unnumbered Ethernet2/0/0
   
   router ospf 1
    network 4.0.0.0 0.255.255.255 area 0
   
   end
   
Current configuration:
   
   hostname r2.2.2.2
   
   interface Loopback0
    ip address 2.2.2.2 255.0.0.0
   
   interface Ethernet0/0/4
    ip address 6.0.0.2 255.0.0.0
   
   interface Serial2/1/0
    ip unnumbered Ethernet0/0/4
   
   router ospf 2
    network 6.0.0.0 0.255.255.255 area 0
   
   end
   

show コマンド

  • show ip ospf database - Link State Advertisement(LSA; リンクステート アドバタイズメント)のリストを表示し、それらをリンク ステート データベースに挿入します。このリストは LSA ヘッダー内の情報だけを示します。

  • show ip ospf database [router] [link-state-id] - データベース内に保持されている、特定のルータの LSA すべてを一覧表示します。LSA はすべてのルータによって生成されます。これらの基本的な LSA には、ルータのリンク(つまり、インターフェイス)すべてと、そのリンクの状態および発信コストが含まれています。これらの LSA は生成されたエリア内でだけフラッディングされます。

OSPF データベースの検査

このネットワーク環境の情報が OSPF データベースにどのように格納されているかを確認するには、show ip ospf database コマンドの出力を調べます。

r2.2.2.2#show ip ospf database
   
          OSPF Router with ID (2.2.2.2) (Process ID 2)
   
                   Router Link States (Area 0)
   
   Link ID         ADV Router      Age         Seq#           Checksum     Link count
   1.1.1.1         1.1.1.1         254         0x8000001A     0xA6FA           2
   2.2.2.2         2.2.2.2         253         0x80000017     0x4858           2
   
r2.2.2.2#show ip ospf database router 1.1.1.1
   
          OSPF Router with ID (2.2.2.2) (Process ID 2)
   
   
                   Router Link States (Area 0)
   
     LS age: 279
     Options: (No TOS-capability, DC)
     LS Type: Router Links
     Link State ID: 1.1.1.1
     !--- ルータ リンクの場合、Link State Id は常に 
     !--- Advertising Router(次の行)と同じです。
     Advertising Router: 1.1.1.1
     !--- これは、この Link-State Advertisement(LSA; リンクステート アドバタイズメント)
     !--- を作成したルータのルータ ID です。
     LS Seq Number: 8000001A
     Checksum: 0xA6FA
     Length: 48
      Number of Links: 2
    
       Link connected to: another Router (point-to-point)
   	!--- この行は、このルータ(1.1.1.1)が 2.2.2.2 の 
     	!--- 近接ルータであることを示します。
        (Link ID) Neighboring Router ID: 2.2.2.2
        (Link Data) Router Interface address: 0.0.0.12
   		 !--- 非番号リンクの場合は MIB II IfIndex 値
            !--- (通常は 0 から始まる)を使用します。
         Number of TOS metrics: 0
          TOS 0 Metrics: 64 
   	   !--- これは 2 台のルータを接続しているリンクの OSPF コストです。
   
       Link connected to: a Stub Network 
   	!--- このエントリはイーサネット セグメント 4.0.0.0/8 を表します。
        (Link ID) Network/subnet number: 4.0.0.0
        (Link Data) Network Mask: 255.0.0.0
         Number of TOS metrics: 0
          TOS 0 Metrics: 10
   	     !--- これはイーサネット セグメントの OSPF コストです。
   
   
   r2.2.2.2#show ip ospf database router 2.2.2.2
   
          OSPF Router with ID (2.2.2.2) (Process ID 2)
   
   
                   Router Link States (Area 0)
   
     LS age: 295
     Options: (No TOS-capability, DC)
     LS Type: Router Links
     Link State ID: 2.2.2.2
     Advertising Router: 2.2.2.2
     LS Seq Number: 80000017
     Checksum: 0x4858
     Length: 48
      Number of Links: 2
   
       Link connected to: another Router (point-to-point)
        (Link ID) Neighboring Router ID: 1.1.1.1
        (Link Data) Router Interface address: 0.0.0.10
         Number of TOS metrics: 0
          TOS 0 Metrics: 64
   
       Link connected to: a Stub Network
        (Link ID) Network/subnet number: 6.0.0.0
        (Link Data) Network Mask: 255.0.0.0
         Number of TOS metrics: 0
          TOS 0 Metrics: 10
   

最短パスの計算

ここでは、ルータ 2.2.2.2 の観点から最短パス ツリーを計算してみます。

ルータ 2.2.2.2 は自身の LSA を参照し、ルータ 1.1.1.1 が近接ルータであることを認識します。続いてルータ 1.1.1.1 の LSA を参照し、1.1.1.1 が 2.2.2.2 を近接ルータとして認識していることを確認します。両方のルータが互いに近接ルータとして認識しあっている場合、両ルータは到達可能と見なされます。そのため、両ルータは近接ルータの LSA にリストされているスタブ ネットワークへの経路を開設します。

この例では、ルータ 1.1.1.1 の LSA 内にスタブ ネットワークとして 4.0.0.0/8 がリストされているため、ルータ 2.2.2.2 は自身のルーティング テーブル内に 4.0.0.0/8 への経路を開設します。これを確認するには、show ip route ospf コマンドを使用します。

r2.2.2.2#show ip route ospf
   O    4.0.0.0/8 [110/74] via 4.0.0.1, 00:06:01, Serial0/1/0
   
   r1.1.1.1#show ip route ospf
   O    6.0.0.0/8 [110/74] via 6.0.0.2, 00:06:16, Serial2/1/0
   


関連するシスコ サポート コミュニティ ディスカッション

シスコ サポート コミュニティは、どなたでも投稿や回答ができる情報交換スペースです。


関連情報


目次に戻る 次のセクションに進む

Document ID: 47860