IP : IP ルーティング

IS-IS over IPv6 の設定

2003 年 6 月 5 日 - ライター翻訳版
その他のバージョン: PDFpdf | 機械翻訳版 (2013 年 8 月 21 日) | 英語版 (2005 年 8 月 10 日) | フィードバック

目次

概要
はじめに
     表記法
     前提条件
     使用するコンポーネント
設定
     ネットワーク ダイアグラム
     設定
確認
トラブルシューティング
     トラブルシューティング手順
関連するシスコ サポート コミュニティ ディスカッション
関連情報

概要

この文書では、IP version 6(IPv6)上での Intermediate System-to-Intermediate System(IS-IS)の設定例について説明します。また、設定の確認とトラブルシューティングの方法についても説明します。

はじめに

表記法

文書の表記法の詳細は、「シスコ テクニカル ティップスの表記法」を参照してください。

前提条件

設定を開始する前に、次の前提条件を満たしていることを確認してください。

使用するコンポーネント

この文書の情報は、次のソフトウェアおよびハードウェアのバージョンに基づいています。

  • Enterprise フィーチャ セットを搭載する 12.2(13)T

  • Cisco 7200 プラットフォーム

この資料の情報は、特定の実験環境内のデバイスから作成されました。また、この文書で使用するデバイスは、すべて初期(デフォルト)の設定で起動しています。実稼動中のネットワークで作業をしている場合、実際にコマンドを使用する前に、その潜在的な影響について理解しておく必要があります。

設定

この項では、この文書で説明する機能の設定に必要な情報を提供します。

注: この文書で使用されているコマンドの詳細を調べるには、Command Lookup ツールを使用してください(登録ユーザのみ)。

ネットワーク ダイアグラム

この文書では次の図に示すネットワーク設定を使用しています。

ipv6_sample_config.gif

設定

この文書で使用する設定を次に示します。

c7200-1

c7200-1#show run
  
  ipv6 unicast-routing 
  ! Enable the forwarding of IPv6 unicast datagrams
  !
  interface Loopback0
   no ip address
   ipv6 address 2000:1::1/96
  
  !--- ループバックの唯一の目的がルータ ID である場合、
  !--- /128 が適しています。
  !--- ここでは、IS-IS を介してこのルートをアドバタイズするために、/96 を使用します。
  
   ipv6 router isis alpha
  
  !--- エリア "alpha" のインターフェイスで IS-IS を有効にします。
  
  !
  interface FastEthernet3/0
   ip address 172.16.88.51 255.255.255.224
   duplex half
   ipv6 address 1000:1:1:1:1:1:1:1/112
   ipv6 router isis alpha
  !
  router isis alpha
  
  !--- エリア "alpha" の IS-IS ルーティング プロセスを有効にします。
  
   net 49.1111.2220.3330.4440.00
  
  !--- IS-IS エリアのエリア アドレスとルータのシステム ID を定義します。
  !--- 49.1111 は area id で、SysID は 2220.3330.4440 です。
  
  !
  end
  

c7200-2

c7200-2#show run
  ipv6 unicast-routing
  !
  interface Loopback0
   no ip address
   ipv6 address 3000:1::1/96
   ipv6 router isis alpha
  !
  interface FastEthernet0/0
   ip address 172.16.88.50 255.255.255.224
   duplex auto
   speed auto
   ipv6 address 1000:1:1:1:1:1:1:2/112
   ipv6 router isis alpha
  !
   router isis alpha
   net 49.1111.2222.3333.4444.00
   !
  end
  

確認

この項では、設定が正常に動作しているかどうかを確認する際に役立つ情報を示します。

特定の show コマンドは、Output Interpreter ツール登録ユーザのみ)でサポートされたもので、show コマンド出力の分析を表示できます。

  • show clns interface:インターフェイスに関する Connectionless Network Service(CLNS; コネクションレス型ネットワーク サービス)固有の情報の表示に使用します。

    c7200-1#show clns int fa3/0 
      FastEthernet3/0 is up, line protocol is up 
        Checksums enabled, MTU 1497, Encapsulation SAP 
        ERPDUs enabled, min. interval 10 msec. 
        CLNS fast switching enabled 
        CLNS SSE switching disabled 
      
        DEC compatibility mode OFF for this interface 
        Next ESH/ISH in 43 seconds 
        Routing Protocol: IS-IS 
          Circuit Type: level-1-2 
          Interface number 0x0, local circuit ID 0x1 
          Level-1 Metric: 10, Priority: 64, Circuit ID: c7200-1.01      
          Number of active level-1 adjacencies: 1 
          Level-2 Metric: 10, Priority: 64, Circuit ID: c7200-1.01      
          Number of active level-2 adjacencies: 1 
          Next IS-IS LAN Level-1 Hello in 1 seconds 
          Next IS-IS LAN Level-2 Hello in 1 seconds
  • show clns neighbors:CLNS ネイバの状態の表示に使用します。

    c7200-1#show clns neighbors
      System Id      Interface   SNPA State  Holdtime  Type Protocol 
      c7200-2        Fa3/0       0004.281e.e008 Up      25        L1L2 IS-IS
      
  • show ipv6 route:IPv6 でルートが存在するかどうかの確認に使用します。

    c7200-1#show ipv6 route 
           IPv6 Routing Table - 7 entries 
           Codes: C - Connected, L - Local, S - Static, R - RIP, B - BGP 
        U - Per-user Static route 
        I1 - ISIS L1, I2 - ISIS L2, IA - ISIS      interarea 
           L   1000:1:1:1:1:1:1:1/128 [0/0] 
      via ::, FastEthernet3/0 
           C   1000:1:1:1:1:1:1:0/112 [0/0] 
      via ::, FastEthernet3/0 
           L   2000:1::1/128 [0/0] 
      via ::, Loopback0 
           C   2000:1::/96 [0/0] 
      via ::, Loopback0 
           I1  3000:1::/96 [115/20] 
      via FE80::204:28FF:FE1E:E008, FastEthernet3/0 
           L   FE80::/10 [0/0] 
      via ::, Null0 
           L   FF00::/8 [0/0] 
      via ::, Null0
      
      c7200-1#show ipv6 route 3000:1::1 
           IPv6 Routing Table - 7 entries 
           Codes: C - Connected, L - Local, S - Static, R - RIP, B - BGP 
        U - Per-user Static route 
        I1 - ISIS L1, I2 - ISIS L2, IA - ISIS      interarea 
           I1  3000:1::/96 [115/20] 
      via FE80::204:28FF:FE1E:E008, FastEthernet3/0 
  • show isis database detail:IS-IS データベースの詳細の表示に使用します。

    c7200-1#show isis database detail
      IS-IS Level-1 Link State Database: 
           LSPID  LSP Seq Num  LSP Checksum  LSP Holdtime ATT/P/OL 
           c7200-1.00-00       * 0x000000DB        0xC383        1103         0/0/0 
             Area Address: 49.1111 
             NLPID:        0x8E 
             Hostname: c7200-1 
             IPv6 Address: 2000:1::1 
             Metric: 10         IPv6 1000:1:1:1:1:1:1:0/112      
             Metric: 10         IPv6 2000:1::/96      
             Metric: 10         IS c7200-1.01      
           c7200-1.01-00       * 0x000000D8        0x5C9A        1078         0/0/0 
             Metric: 0IS      c7200-1.00 
             Metric: 0IS      c7200-2.00 
           c7200-2.00-00         0x000000DD        0x0219        7570/0/0 
             Area Address: 49.1111 
             NLPID:        0x8E 
             Hostname: c7200-2 
             IPv6 Address: 3000:1::1 
             Metric: 10         IPv6 1000:1:1:1:1:1:1:0/112      
             Metric: 10         IPv6 3000:1::/96      
             Metric: 10         IS c7200-1.01      
           IS-IS Level-2 Link State Database: 
           LSPID  LSP Seq Num  LSP Checksum  LSP Holdtime ATT/P/OL 
           c7200-1.00-00       * 0x000000DC        0x2569        8930/0/0 
             Area Address: 49.1111 
             NLPID:        0x8E 
             Hostname: c7200-1 
             IPv6 Address: 2000:1::1 
             Metric: 10         IS c7200-1.01      
             Metric: 10         IPv6 1000:1:1:1:1:1:1:0/112      
             Metric: 10         IPv6 2000:1::/96      
             Metric: 20         IPv6 3000:1::/96      
           c7200-1.01-00       * 0x000000D9        0xE994        7730/0/0 
             Metric: 0IS      c7200-1.00 
             Metric: 0IS      c7200-2.00 
           c7200-2.00-00         0x000000DF        0x88E8        9370/0/0 
             Area Address: 49.1111 
             NLPID:        0x8E 
             Hostname: c7200-2 
             IPv6 Address: 3000:1::1 
             Metric: 10         IS c7200-1.01      
             Metric: 10         IPv6 1000:1:1:1:1:1:1:0/112      
             Metric: 20         IPv6 2000:1::/96      
             Metric: 10         IPv6 3000:1::/96
      
  • ping:リモート ホストがアクティブ/非アクティブのどちらであるか、およびホストとの通信における往復の遅延の判別に使用します。

    7200-2#ping 1000:1:1:1:1:1:1:1
      
      Type escape sequence to abort.
      Sending 5, 100-byte ICMP Echos to 1000:1:1:1:1:1:1:1, timeout is 2 seconds:
      !!!!!
      Success rate is 100 percent (5/5), round-trip min/avg/max = 1/1/4 ms 

トラブルシューティング

この項では、設定のトラブルシューティングに役立つ情報を説明します。

  • debug isis adj-packets:CLNS のネイバを通過する IS-IS Hello(IIH)パケットの表示に使用します。

トラブルシューティング手順

次に示すトラブルシューティング情報は、この設定に関係するものです。IPv6 IS-IS が正常に機能していない場合は、次の手順に従って設定のトラブルシューティングを行います。

  1. ネイバに ping を送信して、ping が正常に動作することを確認します。ping が失敗した場合、アドレスが同じサブネット内にあることを確認し、またレイヤ 1 とレイヤ 2 も確認します。各インターフェイスで IPv4 アドレスを使用すると便利です。IPv4 の ping が正常に動作するかどうかを確認すると、レイヤ 1 とレイヤ 2 の問題を除外するのに役立ちます。

  2. 設定が正しいかどうかを確認します。この文書の「設定」の項にある設定例を参照してください。設定が正しいと思われる場合は、debug clns adj-packets コマンドを発行します。

    次に示す debug の出力例のように、両方向の IIH パケットが確認できるはずです。

    注: 実稼働ネットワークで debug コマンドを発行する前に、「debug コマンドに関する重要な情報」を参照してください。

    c7200-1# debug isis adj-packets 
      IS-IS Adjacency related packets debugging is on 
      
      5d23h: ISIS-Adj: Sending L1 LAN IIH on FastEthernet3/0, length 1497 
      5d23h: ISIS-Adj: Sending L2 LAN IIH on Loopback0, length 1514n 
      5d23h: ISIS-Adj: Sending L2 LAN IIH on FastEthernet3/0, length 1497 
      5d23h: ISIS-Adj: Rec L1 IIH from 0004.281e.e008 (FastEthernet3/0), cir type L1L2,
       cir id 2220.3330.4440.01, length 1497
      

IPv6 での IS-IS の設定の詳細については、「Cisco IPv6 IS-IS コンフィギュレーション ガイド」を参照してください。


関連するシスコ サポート コミュニティ ディスカッション

シスコ サポート コミュニティは、どなたでも投稿や回答ができる情報交換スペースです。


関連情報


Document ID: 40262