LAN スイッチング : バーチャル LAN/VLAN トランキング プロトコル(VLAN/VTP)

CatOS を動作する Catalyst スイッチと統合 Cisco IOS(ネイティブ モード)間の ISL トランキングの設定

2002 年 12 月 30 日 - ライター翻訳版
その他のバージョン: PDFpdf | 機械翻訳版 (2013 年 8 月 21 日) | 英語版 (2006 年 4 月 25 日) | フィードバック

目次

概要
はじめに
     表記法
     前提条件
     使用するコンポーネント
     背景理論
     重要事項
設定
     ネットワーク ダイアグラム
     設定
確認
     debug コマンドと show コマンド
     show コマンドの出力例
トラブルシューティング
関連するシスコ サポート コミュニティ ディスカッション
関連情報

概要

この文書では、Cisco Catalyst Operating System(CatOS)を動作する Cisco Catalyst 5000 スイッチと、統合 Cisco IOS(ネイティブ モード)を動作する Cisco Catalyst 6500 スイッチ間の Inter-Switch Link(ISL; スイッチ間リンク)トラッキングの設定例を紹介します。このシナリオでは、CatOS を動作する Catalyst 5000 または 6000 ファミリ メンバ、および統合 Cisco IOS(ネイティブ モード)を動作する Catalyst 4000 または 6000 ファミリ メンバのどの組み合せを使用しても、同じ結果が得られます。

はじめに

表記法

文書表記の詳細については、「シスコ テクニカル ティップスの表記法」を参照してください。

前提条件

この文書に関する特別な前提条件はありません。

使用するコンポーネント

  • Catalyst OS 6.1(1)ソフトウェアを動作する Catalyst 5000 スイッチ

  • Cisco IOS(R) 12.1(4)E1 を動作する Catalyst 6509 スイッチ

この文書で使用する設定は、隔離されたラボ環境で実装されました。実際の使用環境では、ネットワーク上の設定やコマンドの影響を受ける可能性があります。各デバイスがデフォルト設定値を持つことを保証するため、すべてのデバイスで clear config all および write erase コマンドを使用して設定をクリアしました。

背景理論

トランキングとは、複数の VLAN からのトラフィックを、2 台のデバイス間のポイントツーポイント リンクで伝送する方法です。イーサネット トランキングは次の 2 つの方法で実装可能です。

  • ISL(シスコの特許プロトコル)

  • 802.1q(IEEE 標準)

この文書では、スイッチからのコンフィギュレーション ファイルと、関連の show コマンドからの出力例のみを示します。Catalyst スイッチ間に ISL トランクを設定する方法の詳細は、次の文書を参照してください。ブラウザの Find 機能を使用して、下記に示す各項を検索してください。

重要事項

  • CatOS を動作する Catalyst 4000 ファミリ(Catalyst 2948G や Catalyst 2980G を含む)では、ISL トランキングではなく、802.1q トランキングだけがサポートされます。

  • スーパーバイザ III 以降を搭載する Catalyst 4000 スイッチは、デフォルトで統合 Cisco IOS(ネイティブ モード)を実行しており、WS-X4418-GB および S-X4412-2GB-T モジュールのブロッキング状態のギガビット ポートを除くすべてのインターフェイスで ISL および 802.1q のトランキング モードを両方サポートします。これらのギガビットポートでは、802.1q トランキングしかサポートしません。ポート 3 〜 18 は、WS-X4418-GB モジュールでギガビット ポートをブロックします。ポート 1 〜 12 は、WS-X4412-2GB-T モジュールでギガビット ポートをブロックしています。ブロッキング状態のポートとは、バックプレーンへのポート接続が加入過多であることを意味します。

  • Catalyst 6000 ファミリ メンバのイーサネット ポートはすべて、802.1q と ISL のカプセル化をサポートします。

  • Catalyst 5000 のトランク対応ポートは、モジュールに応じて ISL カプセル化だけをサポートする場合と、ISL と 802.1q の両方をサポートする場合があります。サポートされるカプセル化タイプを判定する最良の方法は、show port capabilities コマンドを使用することです。トランキングのキャパシティは、下記の例に示すように明示的に記述されます。

    cat5000> show port capabilities 3
      Model                    WS-X5225R
      Port                     3/1
      Type                     10/100BaseTX
      Speed                    auto,10,100
      Duplex                   half,full
      Trunk encap type         802.1Q, ISL
      
      !--- この特定のポートでは、802.1Q と ISL の両方がサポートされます。
      
      Trunk mode               on,off,desirable,auto,nonegotiate
      Channel                  3/1-2,3/1-4
      Broadcast suppression    percentage(0-100)
      Flow control             receive-(off,on),send-(off,on)
      Security                 yes
      Membership               static,dynamic
      Fast start               yes
      QOS scheduling           rx-(none),tx-(none)
      CoS rewrite              yes
      ToS rewrite              IP-Precedence
      Rewrite                  no
      UDLD                     yes
      AuxiliaryVlan            1..1000,1025..4094,untagged,dot1p,none
      SPAN                     source,destination
      
  • トランキング モードがトランク リンク間で一致していることを確認してください。リンクの片側が ISL トランクとして設定されている場合、反対側も ISL として設定する必要があります。同様に、リンクの片側が 802.1q として設定されている場合、反対側も 802.1q として設定する必要があります。

設定

この項では、この文書で説明する機能の設定に必要な情報を提供します。

注:この文書で使用されているコマンドの詳細は、Command Lookup ツールで検索してください。

ネットワーク ダイアグラム

この文書では、下図に示すネットワーク設定を使用します。

66a.gif

設定

コメントおよび説明は、青字のイタリック体で示します。

Catalyst 5000 スイッチ

#version 6.1(1)
  !
  set option fddi-user-pri enabled
  set password $2$h/BN$i3S54iNvIXknFelh6gOve0
  set enablepass $2$DpAu$/mw1ZxL5I8ymR.yn85ovB/
  !
  #errordetection
  set errordetection portcounter enable
  !
  #system
  set system name  cat5000
  !
  #frame distribution method
  set port channel all distribution mac both
  !
  #vtp
  
  !--- この例では、VTP モードを透過に設定しました。
  !--- ネットワークに応じて適切に VTP モードを設定します。
  
  set vtp mode transparent
  !--- VTP の詳細に関しては、「Catalyst スイッチでの VTP の設定」を参照してください。
  
  set vlan 1 name default type ethernet mtu 1500 said 100001 state active
  set vlan 1002 name fddi-default type fddi mtu 1500 said 101002 state active
  set vlan 1004 name fddinet-default type fddinet mtu 1500 said 101004 state active stp ieee
  set vlan 1005 name trnet-default type trbrf mtu 1500 said 101005 state active stp ibm
  set vlan 2
  set vlan 1003 name token-ring-default type trcrf mtu 1500 said 101003 state acti
  ve mode srb aremaxhop 7 stemaxhop 7 backupcrf off
  !
  #ip
  !--- 管理用の IP アドレス
  Set interface sc0 1 10.10.10.2/255.255.255.0 10.10.10.255
  
  !
  #set boot command
  set boot config-register 0x10f
  set boot system flash bootflash:cat5000-sup3.6-1-1.bin
  !
  #mls
  set mls nde disable
  !
  # default port status is enable
  !
  !
  #module 1 : 0-port Supervisor III
  !
  #module 2 empty
  !
  #module 3 : 9-port Gigabit Ethernet
  !
  #module 4 : 24-port 10/100BaseTX Ethernet
  !
  #module 5 : 24-port 10/100BaseTX Ethernet
  
  !-- ポート 5/13 〜 24 は VLAN 2 に割り当てられています。
  
  set vlan 2    5/13-24
  
  
  !--- この例では、ISL トランキング モードを「on」に設定しています。
  !--- トランキング モードは、ネットワークと要件に応じて設定します。
  
  Set trunk 5/1  on isl 1-1005
  
  !--- 各トランキング モードの詳細は、次の項目を参照してください。
  !--- 「ファースト イーサネットとギガビット イーサネット ポートでの VLAN トランクの設定
  
  
  
  !--- Portfast は、ワークステーションに接続しているポート上で有効になっています。
  
  Set spantree portfast    5/2-24 enable
  
  !--- Portfast を有効にする詳しい理由については、下記を参照してください。
  !---
  
  end
  
  

Catalyst 6500 スイッチ

Current configuration : 4207 bytes
  !
  version 12.1
  service timestamps debug uptime
  service timestamps log uptime
  no service password-encryption
  !
  hostname cat6000
  !
  boot buffersize 126968
  boot bootldr bootflash:c6msfc-boot-mz.121-4.E1.bin
  no logging console
  
  !--- この例で使用する特権モードのパスワード
  
  enable password mysecret
  !
  redundancy
   main-cpu
    auto-sync standard
  ip subnet-zero
  no ip domain-lookup
  !
  ip cef
  cns event-service server
  !
  !
  !
  interface GigabitEthernet1/1
   no ip address
   shutdown
  !
  interface GigabitEthernet1/2
   no ip address
   shutdown
  !
  interface FastEthernet9/1
   no ip address
  
  
  !--- switchport コマンドをキーワードなしで一度入力し、
  !--- Catalyst 6500 のレイヤ 2 ポートとしてインターフェイスを設定する必要があります。
  !--- 詳細は、「Catalyst 6500 のレイヤ 2 イーサネット インターフェイスの設定」を参照してください。
  !--- 統合 Cisco IOS(ネイティブ モード)を実行している Catalyst 4000 スイッチでは、
  !--- すべてのポートは、デフォルトでレイヤ 2 ポートです。
  !--- デフォルト設定を変更しない場合は、
  !--- switchport コマンドを入力する必要はありません。
  !--- 詳細は、「Catalyst 4000 のレイヤ 2 イーサネット インターフェイスの設定」を参照してください。
  
  .
   switchport
  !--- トランク カプセル化を ISL として設定します。
   switchport trunk encapsulation isl
  
  
  !--- インターフェイスでトランキングを有効にします。
  
   switchport mode trunk
  !
  
  
  !--- インターフェイスの FastEthernet 9/2 〜 9/24 は、アクセス モードで設定されます。
  !--- 詳細は、「レイヤ 2 イーサネット インターフェイスの設定」の
  !--- 「レイヤ 2 インターフェイス モード」の項を参照してください。
  
  interface FastEthernet9/2
   no ip address
   switchport
   switchport mode access
  !
  interface FastEthernet9/3
   no ip address
   switchport
   switchport mode access
  !
  
  (...output suppressed)
  
  !
  interface FastEthernet9/11
   no ip address
   switchport
   switchport mode access
  !
  interface FastEthernet9/12
   no ip address
   switchport
   switchport mode access
  !
  
  
  !--- インターフェイス FastEthernet 9/13 〜 9/24 は、VLAN 2 に配置されます。
  
  interface FastEthernet9/13
   no ip address
   switchport
   switchport access vlan 2
   switchport mode access
  !
  interface FastEthernet9/14
   no ip address
   switchport
   switchport access vlan 2
   switchport mode access
  !
  
  (...output suppressed)
  
  !
  interface FastEthernet9/23
   no ip address
   switchport
   switchport access vlan 2
   switchport mode access
  !
  interface FastEthernet9/24
   no ip address
   switchport
   switchport access vlan 2
   switchport mode access
  !
  interface FastEthernet9/25
   no ip address
   shutdown
  !
  
  (...output suppressed)
  
  !
  interface FastEthernet9/48
   no ip address
   shutdown
  !
  interface Vlan1
  
  !--- 管理用の IP アドレス
  
   ip address 10.10.10.3 255.255.255.0
  !
  !
  ip classless
  no ip http server
  !
  !
  !
  line con 0
   transport input none
  line vty 0 4
  !--- この例で使用する Telnet のパスワード
   password mysecret
  login
  !
  end

注:存在しない VLAN にインターフェイスを割り当てた場合、その VLAN を VLAN データベース内に作成するまで、インターフェイスはシャットダウンされます。詳細は、「VLAN の設定」の「イーサネット VLAN の作成または変更」の項を参照してください。

確認

debug コマンドと show コマンド

この項では、設定が適切に機能しているかを確認する際に使用する情報を提供します。

一部の show コマンドは、show コマンド出力の分析を表示する Output Interpreter ツールでサポートされています。

CatOS を動作する Catalyst 5000/6000 スイッチでは、次のコマンドを使用してください。

  • show port capabilities<module/port>

  • show port<module/port>

  • show trunk<module/port>

  • show vtp domain

Catalyst 6000 スイッチまたは統合 Cisco IOS(ネイティブ モード)を実行している Catalyst 4000 では、次のコマンドを使用してください。

  • show interfaces <interface type><module/port> trunk

  • show vlan

show コマンドの出力例

Catalyst 5000 スイッチ

show port capabilities<module/port>

このコマンドを使用して、ポートにトランキング機能があるかを確認します。

cat5000> (enable) show port capabilities 5/1
  Model                    WS-X5234
  Port                     5/1
  Type                     10/100BaseTX
  Speed                    auto,10,100
  Duplex                   half,full
  Trunk encap type         802.1Q,ISL
  Trunk mode               on,off,desirable,auto,nonegotiate
  Channel                  5/1-2,5/1-4
  Broadcast suppression    percentage(0-100)
  Flow control             receive-(off,on),send-(off,on)
  Security                 yes
  Membership               static,dynamic
  Fast start               yes
  QOS scheduling           rx-(none),TX(1q4t)
  COs rewrite              yes
  ToS rewrite              IP-Precedence
  Rewrite                  yes
  UDLD                     yes
  AuxiliaryVlan            1..1000,1025..4094,untagged,dot1p,none
  SPAN                     source,destination
  

show port<module/port>

このコマンドは、特定のポートのステータスを表示するとともに、そのステータスがトランキングであるかを示します。

cat5000> (enable) show port 5/1
  Port  Name               Status     Vlan       Level  Duplex Speed Type
  ----- ------------------ ---------- ---------- ------ ------ ----- ------------
   5/1                     connected  trunk      normal a-full a-100 10/100BaseTX
  
  Port  AuxiliaryVlan AuxVlan-Status
  ----- ------------- --------------
   5/1  none          none
  
  
  Port  Security Violation Shutdown-Time Age-Time Max-Addr Trap     IfIndex
  ----- -------- --------- ------------- -------- -------- -------- -------
   5/1  disabled  shutdown             0        0        1 disabled      66
  
  Port  Num-Addr Secure-Src-Addr   Age-Left Last-Src-Addr     Shutdown/Time-Left
  ----- -------- ----------------- -------- ----------------- ------------------
   5/1         0                 -        -                 -        -         -
  
  ...(output suppressed)
  
  

show trunk<module/port>

このコマンドでは、トランキング ステータスと設定を確認します。

cat5000> (enable) show trunk
  * - indicates vtp domain mismatch
  Port      Mode         Encapsulation  Status        Native vlan
  --------  -----------  -------------  ------------  -----------
   5/1      on           isl            trunking      1
  
  Port      Vlans allowed on trunk
  --------  ---------------------------------------------------------------------
   5/1      1-1005
  
  Port      Vlans allowed and active in management domain
  --------  ---------------------------------------------------------------------
   5/1      1-2
  
  Port      Vlans in spanning tree forwarding state and not pruned
  --------  ---------------------------------------------------------------------
   5/1      1-2
  

show vtp domain

このコマンドは、VTP 情報の確認に使用します。

cat5000> (enable) show vtp domain
  Domain Name                      Domain Index VTP Version Local Mode  Password
  -------------------------------- ------------ ----------- ----------- ----------
                                   1            2           Transparent -
  
  Vlan-count Max-vlan-storage Config Revision Notifications
  ---------- ---------------- --------------- -------------
  6          1023             0               disabled
  
  Last Updater    V2 Mode  Pruning  PruneEligible on Vlans
  --------------- -------- -------- -------------------------
  10.10.10.2      disabled disabled 2-1000
  

Catalyst 6500 スイッチ

show interfaces <interface type><module/port> trunk

このコマンドは、ポートがトランキングしているかどうかを表示します。

cat6000#show interfaces fa9/1 trunk
  
  Port      Mode         Encapsulation  Status        Native vlan
  Fa9/1     on           isl            trunking      1
  
  Port      Vlans allowed on trunk
  Fa9/1     1-1005
  
  Port      Vlans allowed and active in management domain
  Fa9/1     1-2,1002-1005
  
  Port      Vlans in spanning tree forwarding state and not pruned
  Fa9/1     1-2,1002-1005
  
  

show vlan

このコマンドでは、VLAN に関する情報と、特定の VLAN に属するポートの情報が提供されます。

cat6000#show vlan
  
  VLAN Name                             Status    Ports
  ---- -------------------------------- --------- -------------------------------
  1    default                          active    Fa9/2, Fa9/3, Fa9/4, Fa9/5
                                                  Fa9/6, Fa9/7, Fa9/8, Fa9/9
                                                  Fa9/10, Fa9/11, Fa9/12
  2    VLAN0002                         active    Fa9/13, Fa9/14, Fa9/15, Fa9/16
                                                  Fa9/17, Fa9/18, Fa9/19, Fa9/20
                                                  Fa9/21, Fa9/22, Fa9/23, Fa9/24
  1002 fddi-default                     active
  1003 token-ring-default               active
  1004 fddinet-default                  active
  1005 trnet-default                    active
  
  
  (...output suppressed)
  
  
  

注:レイヤ 2 の非トランク ポートとして設定されているポートだけが表示されます。詳細は、「レイヤ 2 イーサネット インターフェイスの設定」の「レイヤ 2 スイッチング用のイーサネット インターフェイスの設定」を参照してください。

トラブルシューティング

現在、この設定に使用可能な確認手順はありません。


関連するシスコ サポート コミュニティ ディスカッション

シスコ サポート コミュニティは、どなたでも投稿や回答ができる情報交換スペースです。


関連情報


Document ID: 8759