ダイヤルとアクセス : ダイヤルオンデマンド ルーティング(DDR)

ISDN BRI を使用した複数サイトへのダイヤルのルータへの設定

2010 年 6 月 10 日 - ライター翻訳版
その他のバージョン: PDFpdf | 機械翻訳版 (2013 年 8 月 21 日) | 英語版 (2010 年 2 月 4 日) | フィードバック

目次

概要
前提条件
      要件
      使用するコンポーネント
      表記法
      関連製品
設定
      ネットワーク ダイアグラム
      設定
確認
トラブルシューティング
      トラブルシューティングのためのコマンド
      デバッグ出力
関連するシスコ サポート コミュニティ ディスカッション
関連情報

概要

特定の状況では、複数のサイトにダイヤルするようにルータを設定する必要があります。たとえば、会社のネットワークの一部に接続するために 1 つのルータにダイヤルし、インターネットに接続するためにインターネット サービス プロバイダー(ISP)にダイヤルする必要がある場合があります。

このドキュメントでは、中央のルータがインターネットにアクセスしていて、リモート オフィスでは Integrated Services Digital Network(ISDN)を使用している設定例を紹介しています。リモート オフィスでは、中央のルータへのアクセスと中央のルータ経由でのインターネットへのアクセスも可能です。



前提条件

要件

この設定を開始する前に、必ず次の項目を実行してください。

  • ISDN レイヤ 1 および 2 が機能していることを確認する。詳細は、『show isdn status コマンドを使用した BRI のトラブルシューティング』を参照してください。

  • Challenge Handshake Authentication Protocol(CHAP)や Password Authentication Protocol(PAP)などの認証方式、ユーザ名とパスワード、ダイヤルする番号、ダイヤラ インターフェイスの IP アドレス(ネゴシエートされたアドレスがインターフェイスで使用されていない場合)などの必要な情報を ISP から取得する。さらに、複数のホストに接続するのに NAT が必要かどうかを ISP に確認する。

  • リモートのルータから、認証方式、ユーザ名とパスワード、ダイヤルする番号、および IP アドレスを取得する。



使用するコンポーネント

このドキュメントの情報は、次のソフトウェアとハードウェアのバージョンに基づくものです。

  • Cisco IOS(R) ソフトウェア リリース 12.1(11) IP Plus が稼働している Cisco 803 ルータ

    注:NAT を設定する必要がある場合は、IP Plus フィーチャ セットがあることを確認してください(IOS ファイル名に「is」が付いています)。

  • Cisco IOS ソフトウェア リリース 12.2(5) が稼働するリモート オフィスの Cisco 2501 ルータ

注:この設定には ISP のルータは含まれていません。設定例は、『アクセス テクノロジー サポート ページ』を参照してください。

このドキュメントの情報は、特定のラボ環境にあるデバイスに基づいて作成されたものです。このドキュメントで使用するすべてのデバイスは、クリアな(デフォルト)設定で作業を開始しています。対象のネットワークが実稼動中である場合には、どのような作業についても、その潜在的な影響について確実に理解しておく必要があります。



表記法

ドキュメント表記の詳細は、『シスコ テクニカル ティップスの表記法』を参照してください。



関連製品

この設定は、どのルータでも Basic Rate Interface(BRI; 基本速度インターフェイス)のインターフェイスに使用できます。これには、Cisco 800(801、802、803、804 など)と Cisco 1600(1603-R および 1604-R)シリーズのルータなどの BRI インターフェイス組み込みのルータが含まれます。1600、1700、2600、および 3600 シリーズのような、BRI WAN インターフェイス カード(WIC)やネットワーク モジュールが取り付け可能なルータも、これに含まれます。BRI WIC やネットワーク モジュールの詳細は、『Cisco 1600、1700、2600、3600、および 3700 シリーズ ルータ向け WAN Interface Card(WIC)とプラットフォーム ハードウェアの互換性マトリックス』を参照してください。

注:使用しているルータに BRI インターフェイスが備わっていることを確認するには、show version コマンドを使用します。



設定

このセクションでは、このドキュメントで説明する機能の設定に必要な情報を提供します。

注:このドキュメントで使用されているコマンドの詳細を調べるには、Command Lookup Tool登録ユーザ専用)を使用してください。一部ツールについては、ゲスト登録のお客様にはアクセスできない場合がありますことをご了承ください。



ネットワーク ダイアグラム

このドキュメントでは、次のネットワーク構成を使用しています。

isdn800_14562.gif



設定

この設定では、中央のルータは「central」と名付けられ、リモート オフィスは「remote」と名付けられています。

中央では、dialer interface 1 がインターネットにアクセスするように設定されています。IP アドレスは ISP によりダイナミックに割り当てられます。中央の LAN、リモートの LAN、および中央とリモートの WAN の IP ネットワークが、ダイナミックに割り当てられたある IP アドレスによりインターネットにアクセスできるようにするために NAT が使用されます。NAT が必要かどうかを調べるには、お客様の ISP にお問い合せください。

注:ISP の設定に依存するため、PAP と CHAP の両方を設定してあります(実際に使用されるのは一方です)。

central

 version 12.1 
  no parser cache 
  service timestamps debug datetime msec 
  service timestamps log datetime msec 
  ! 
  hostname central 
  ! 
  username remote password 0 remote
 
!--- ルータ(remote)のユーザ名と共有秘密パスワード
  !--- (CHAP 認証で使用)。
  !--- 共有秘密パスワードは両側で同じにする必要があります。

  ! 
  isdn switch-type basic-net3
  !  
  ! 
  interface Ethernet0 
   ip address 10.1.0.1 255.255.255.0 
   ip nat inside 

   !--- Ethernet 0 は Inside NAT インターフェイスです。
   !--- このネットワークからのトラフィックはすべて変換されます。

   no cdp enable 
  ! 
  interface BRI0

   !--- 追加の BRI がある場合は、この BRI 0 の設定を他の BRI にコピーします。

   no ip address 
   encapsulation ppp 
   dialer pool-member 1

   !--- dialer pool 1 のメンバとして BRI0 を割り当てます。
   !--- dialer pool 1 は、インターフェイス Dialer 1 で指定されます。

   dialer pool-member 2 

   !--- dialer pool 2 のメンバとして BRI0 を割り当てます。
   !--- dialer pool 2 は、インターフェイス Dialer 2 で指定されます。

   isdn switch-type basic-net3     

   !--- これは国により異なります。 

   no cdp enable 
   ppp authentication chap pap callin

   !--- 単方向の CHAP および PAP による認証を許可します。
   !--- 認証を物理インターフェイスとダイヤラ インターフェイスの両方で設定します。

  ! 
  interface Dialer1 

  !--- 接続する必要のある各デバイスにダイヤラ インターフェイスを作成します。

   description CONNECTION TO INTERNET 
   ip address negotiated 
   
!--- この IP アドレスは ISP から取得されるものです。ISP でスタティック アドレスが
   !--- 許可される場合は、代わりにそのアドレスを設定します。

   ip nat outside 

   !--- Outside NAT インターフェイス。このインターフェイスには IP アドレスが 1 つだけあるため、
   !--- Inside のネットワークからのトラフィックはすべてポート アドレス変換(PAT)されます。

   encapsulation ppp 
   dialer pool 1 

   !--- ダイヤラ プロファイル 1。インターフェイス BRI 0 はこのプロファイルのメンバであることを
想起してください。

   dialer remote-name ISP  
   dialer idle-timeout 180 
   dialer string 6122 

   !--- ISP へのダイヤルに使用される番号。

   dialer-group 1 
   
!--- dialer-list 1 から対象トラフィックの定義を適用します。

   no cdp enable 
   ppp authentication chap pap callin 
   ppp chap hostname XXXXX   

   !--- XXXXX は、このルータの認証に ISP で求められるユーザ名です。
   !--- 詳細は、ppp chap hostname に関するドキュメントを参照してください。

   ppp chap password YYYYY    
  
 !--- YYYYY は、このルータの認証に ISP で求められるパスワードです。

   ppp pap sent-username XXXXX password YYYYY 

   !--- PAP のユーザ名およびパスワード。 
   !--- これは、ISP で CHAP がサポートされていない場合にだけ必要です。

  ! 
  interface Dialer2 
   description CONNECTION TO REMOTE OFFICE 
   ip address 192.168.17.2 255.255.255.252

   !--- リモート オフィスへの接続のための IP アドレス。
   !--- リモート オフィスの BRI インターフェイスは同じサブネット内にあります。

ip nat inside

   !--- dialer 2 は Inside NAT インターフェイスです。
   !--- この設定では、リモート オフィスからのトラフィックは
   !--- ISP に送信される前に変換されます。

   encapsulation ppp 
   dialer pool 2 

   !--- ダイヤラ プロファイル 2。インターフェイス BRI 0 はこのプロファイルのメンバであることを
想起してください。

   dialer remote-name remote 

   !--- リモート ルータ名(remote)を指定します。
   !--- この名前は、リモート ルータによって自身を認証するために使用される名前と一致する必要があります。
   !--- 前にルータのユーザ名とパスワードを設定したことを想起してください。

   dialer idle-timeout 180 
   dialer string 6121 

   !--- リモート オフィスのルータへのダイヤルに使用される番号。

   dialer-group 1 

   !--- dialer-list 1 から対象トラフィックの定義を適用します。

   no cdp enable 
   ppp authentication chap callin 
  ! 
  ip nat inside source list 101 interface Dialer1 overload 

  !--- アクセス リスト 101 によって識別されるアドレスに対して、
  !--- (PAT による)ダイナミック ソース変換を確立します。

   no ip http server 
   ip classless 
   ip route 0.0.0.0 0.0.0.0 Dialer1 

  !--- デフォルト ルート。このようなトラフィックでは ISP に dialer 1 が使用されます。

   ip route 10.2.0.0 255.255.255.0 Dialer2 

  !--- リモートからリモートへのルータ ネットワーク。10.2.0.0/24 のトラフィックでは dialer2 が
使用されます。

  ! 
  access-list 101 permit ip 10.1.0.0 0.0.0.255 any 
  access-list 101 permit ip 10.2.0.0 0.0.0.255 any 
  access-list 101 permit ip 192.168.17.0 0.0.0.3 any 
  
!--- 変換対象のアドレスを許可するアクセス リストを定義します。
  !--- ethernet 0 のネットワーク、リモート ルータのネットワーク、および
  !--- BRI のネットワーク(ルータとリモート ルータ間)が変換されることに注意してください。

  dialer-list 1 protocol ip permit 

  !--- 対象トラフィック定義。
  !--- この定義は、両方の接続に適用されます。
  !--- 各接続に別の対象トラフィックを定義する必要がある場合は、
  !--- 2 つのダイヤラリストを作成して、ダイヤラグループで各ダイヤラ プロファイルに 1 つ適用します。

  no cdp run 
  ! 
  line con 0 
  exec-timeout 3 0 
  line vty 0 4 
  exec-timeout 3 0 
  ! 
  !  
  end

remote

version 12.2 
  service timestamps debug datetime msec 
  service timestamps log datetime msec 
  ! 
  hostname remote 
  ! 
  username central password 0 remote 

  !--- ルータ(central)のユーザ名と共有秘密パスワード
  !--- (CHAP 認証で使用)。
  !--- 共有秘密鍵は両側で同じにする必要があります。 

  ! 
  isdn switch-type basic-net3
  ! 
  interface Ethernet0 
   ip address 10.2.0.1 255.255.255.0 

   !--- このネットワークは中央の NAT 設定に含まれていることを想起してください。

   no cdp enable 
  ! 
  interface BRI0 
     no ip address 
   encapsulation ppp 
   dialer pool-member 1 

   !--- dialer pool 1 のメンバとして BRI0 を割り当てます。
   !--- dialer pool 1 は、インターフェイス Dialer 1 で指定されます。

   isdn switch-type basic-net3 
   no cdp enable 
   ppp authentication chap 
 ! 
 interface Dialer1 
   ip address 192.168.17.1 255.255.255.252 
   encapsulation ppp 
   dialer pool 1 

   !--- ダイヤラ プロファイル 1。インターフェイス BRI 0 はこのプロファイルのメンバであることを
想起してください。  

   dialer remote-name central 

   !--- もう一方のルータの名前(central)を指定します。
   !--- この名前は、リモート ルータによって自身を認証するために使用される名前と一致する必要があります。
   !--- 前にルータのユーザ名とパスワードを設定したことを想起してください。

  dialer string 6131

   !--- 中央のルータへのダイヤルに使用される番号。 

   dialer-group 1 
   
!--- dialer-list 1 から対象トラフィックの定義を適用します。

   pulse-time 0 
   no cdp enable 
   ppp authentication chap callin 
  ! 
  ip classless 
  ip route 0.0.0.0 0.0.0.0 Dialer1 

  !--- デフォルト ルート。このようなトラフィックでは中央のルータに dialer 1 が使用されます。

  no ip http server 
  ! 
  dialer-list 1 protocol ip permit

  !--- その他の IP トラフィックはすべて対象とします。 

  ! 
  line con 0 
   exec-timeout 3 0 
  line aux 0 
  line vty 0 4 
   exec-timeout 3 0 
  ! 
  end



確認

このセクションでは、設定が正常に動作しているかどうかを確認する際に役立つ情報を提供しています。

特定の show コマンドは、アウトプットインタープリタ登録ユーザ専用)でサポートされています。このツールを使用すると、show コマンドの出力を分析できます。一部ツールについては、ゲスト登録のお客様にはアクセスできない場合がありますことをご了承ください。

  • show isdn active:コールの発信に使用した ISDN 番号を表示して、そのコールがインバウンドかアウトバウンドかを示します。

  • show caller ip:指定した IP アドレスの発信者情報の概要を表示します。

  • show ip interface dialer 1 | include Internet:ダイヤラ インターフェイスの IP 情報とステータスの要約をリストします。

  • show dialer [interface type number]:ダイヤルオンデマンド ルーティング(DDR)に設定されたインターフェイスの一般的な診断情報を表示します。ダイヤラが正常に立ち上がると、次のメッセージが表示されます。

    Dialer state is data link layer up

    physical layer up が表示された場合、回線プロトコルは立ち上がりましたが、Network Control Protocol(NCP; ネットワーク制御プロトコル)は立ち上がっていません。ダイヤリングを開始したパケットのソース アドレスと宛先アドレスが、dial reason 行に表示されます。この show コマンドでは、タイマーの設定と接続がタイムアウトするまでの時間も表示されます。



トラブルシューティング

このセクションでは、設定のトラブルシューティングに役立つ情報を紹介します。



トラブルシューティングのためのコマンド

特定の show コマンドは、アウトプットインタープリタ登録ユーザ専用)でサポートされています。このツールを使用すると、show コマンドの出力を分析できます。一部ツールについては、ゲスト登録のお客様にはアクセスできない場合がありますことをご了承ください。

注:debug コマンドを発行する前に、『debug コマンドの重要な情報』を参照してください。

  • debug dialer:ダイヤラ インターフェイスのパケットまたはイベントに関するデバッグ情報を表示します。

  • debug isdn q931:ローカル ルータ(ユーザ側)とネットワーク間の ISDN ネットワーク接続(レイヤ 3)のコールの確立とティアダウンに関する情報を表示します。

  • debug ppp negiotation:PPP コンポーネントのネゴシエーション中における Point to Point Protocol(PPP; ポイントツーポイント プロトコル)トラフィックおよび交換に関する情報を表示します。これには、Link Control Protocol(LCP; リンク コントロール プロトコル)、認証、Network Control Program(NCP; ネットワーク コントロール プログラム)の情報が含まれています。正常な PPP のネゴシエーションでは、最初に LCP の状態をオープンし、次に認証を行い、最後に NCP のネゴシエートを実行します。

  • debug ppp authentication:CHAP パケット交換および Password Authentication Protocol(PAP; パスワード認証プロトコル)交換を含む認証プロトコル メッセージが debug ppp コマンドで表示されます。

  • debug ip peer:ピアの情報が含まれます。



デバッグ出力

設定のトラブルシューティングには、次の debug コマンドを使用します。

   central#debug isdn q931 
   ISDN Q931 packets debugging is on 
   
   central#debug dialer 
   Dial on demand events debugging is on 
   
   central#debug ppp negotation 
   PPP protocol negotiation debugging is on 
   
   central#debug ppp authentication 
   PPP authentication debugging is on 
   
   central#debug ip peer 
   IP peer address activity debugging is on 

central と呼ばれるルータがインターネットへのコールを開始します。198.133.219.25 がインターネットでの IP アドレスです。

   central#ping 198.133.219.25

   :.!!!! 
   Success rate is 80 percent (4/5), round-trip min/avg/max = 40/41/44 ms 

   *Mar 1 00:06:12.984:BR0 DDR:rotor dialout [priority] 
   *Mar 1 00:06:12.988:BR0 DDR:Dialing cause ip (s=172.17.243.115, 
   d=198.133.219.25)    
   *Mar 1 00:06:12.988:BR0 DDR:Attempting to dial 6122 
   *Mar 1 00:06:12.996:ISDN BR0:TX -> SETUP pd = 8 callref = 0x01 

   !--- central から ISDN 番号 6122 へのコールを開始します。 

   *Mar 1 00:06:13.000:Bearer Capability i = 0x8890 
   *Mar 1 00:06:13.008:Channel ID i = 0x83 
   *Mar 1 00:06:13.008:Called Party Number i = 0x80, '6122', Plan:Unknown,
   Type:Unknown 
   *Mar 1 00:06:13.088:ISDN BR0:RX <- CALL_PROC pd = 8 callref = 0x81 
   *Mar 1 00:06:13.092:Channel ID i = 0x89 
   *Mar 1 00:06:13.244:ISDN BR0:RX <- CONNECT pd = 8 callref = 0x81 

   !--- central では接続メッセージを受信します。ISDN B チャネルが確立されています。 

   *Mar 1 00:06:13.252:ISDN BR0:TX -> CONNECT_ACK pd = 8 callref = 0x01 
   *Mar 1 00:06:13.260:%LINK-3-UPDOWN:Interface BRI0:1, changed state to up 
   *Mar 1 00:06:13.268:BR0:1:interface must be fifo queue, force FIFO 
   *Mar 1 00:06:13.272:%DIALER-6-BIND:Interface BR0:1 bound to profile Di1 
   *Mar 1 00:06:13.280:BR0:1 PPP:Treating connection as a callout 
   *Mar 1 00:06:13.280:BR0:1 PPP:Phase is ESTABLISHING, Active Open 
   *Mar 1 00:06:13.284:BR0:1 PPP:No remote authentication for call-out 
   *Mar 1 00:06:13.284:BR0:1 LCP:O CONFREQ [Closed] id 1 len 10 
   *Mar 1 00:06:13.284:BR0:1 LCP:MagicNumber 0x108130DD (0x0506108130DD) 
   *Mar 1 00:06:13.300:BR0:1 LCP:I CONFREQ [REQsent] id 132 Len 15 
   *Mar 1 00:06:13.300:BR0:1 LCP:AuthProto CHAP (0x0305C22305) 

   !--- ISP では CHAP 認証を使用することになっています。 

   *Mar 1 00:06:13.304:BR0:1 LCP:MagicNumber 0xE4225290 (0x0506E4225290) 
   *Mar 1 00:06:13.304:BR0:1 LCP:O CONFACK [REQsent] id 132 Len 15 
   *Mar 1 00:06:13.308:BR0:1 LCP:AuthProto CHAP (0x0305C22305) 
   *Mar 1 00:06:13.308:BR0:1 LCP:MagicNumber 0xE4225290 (0x0506E4225290) 
   *Mar 1 00:06:13.308:BR0:1 LCP:I CONFACK [ACKsent] id 1 Len 10 
   *Mar 1 00:06:13.312:BR0:1 LCP:MagicNumber 0x108130DD (0x0506108130DD) 
   *Mar 1 00:06:13.312:BR0:1 LCP:State is Open 
   *Mar 1 00:06:13.320:BR0:1 PPP:Phase is AUTHENTICATING, by the peer 
   *Mar 1 00:06:13.328:BR0:1 AUTH:Started process 0 pid 22 
   *Mar 1 00:06:13.328:BR0:1 CHAP:I CHALLENGE id 118 Len 27 from "posets"    
   *Mar 1 00:06:13.332:BR0:1 CHAP:Using alternate hostname XXXXX 
   *Mar 1 00:06:13.332:BR0:1 CHAP:Username posets not found 
   *Mar 1 00:06:13.336:BR0:1 CHAP:Using default password 
   *Mar 1 00:06:13.336:BR0:1 CHAP:O RESPONSE id 118 Len 26 from "XXXXX"    
   *Mar 1 00:06:13.360:BR0:1 CHAP:I SUCCESS id 118 Len 4 
   
!--- central では ISP からの CHAP SUCCESS を受信します。 

   *Mar 1 00:06:13.360:BR0:1 PPP:Phase is UP 
   *Mar 1 00:06:13.364:BR0:1 IPCP:O CONFREQ [Not negotiated] id 1 Len 10 
   *Mar 1 00:06:13.364:BR0:1 IPCP:Address 0.0.0.0 (0x030600000000) 
   *Mar 1 00:06:13.368:BR0:1 IPCP:I CONFREQ [REQsent] id 108 Len 10 
   *Mar 1 00:06:13.368:BR0:1 IPCP:Address 194.183.201.1 (0x0306C2B7C901) 
   *Mar 1 00:06:13.368:BR0:1:IPPOOL:validate address = 194.183.201.1 
   *Mar 1 00:06:13.372:BR0:1 set_ip_peer(3):new address 194.183.201.1 
   *Mar 1 00:06:13.372:BR0:1 IPCP:O CONFACK [REQsent] id 108 Len 10 
   *Mar 1 00:06:13.376:BR0:1 IPCP:Address 194.183.201.1 (0x0306C2B7C901) 
   *Mar 1 00:06:13.380:BR0:1 IPCP:I CONFNAK [ACKsent] id 1 Len 10 
   *Mar 1 00:06:13.380:BR0:1 IPCP:Address 194.183.201.3 (0x0306C2B7C903) 

   !--- dialer 1 に対して ISP により 194.183.201.3 が割り当てられます。 

   *Mar 1 00:06:13.384:BR0:1 IPCP:O CONFREQ [ACKsent] id 2 Len 10 
   *Mar 1 00:06:13.384:BR0:1 IPCP:Address 194.183.201.3 (0x0306C2B7C903) 
   *Mar 1 00:06:13.396:BR0:1 IPCP:I CONFACK [ACKsent] id 2 Len 10 
   *Mar 1 00:06:13.400:BR0:1 IPCP:Address 194.183.201.3 (0x0306C2B7C903) 
   *Mar 1 00:06:13.400:BR0:1 IPCP:State is Open 
   *Mar 1 00:06:13.400:Di1 IPCP:Install negotiated IP interface address
   194.183.201.3 
   *Mar 1 00:06:13.412:BR0:1 DDR:dialer protocol up 
   *Mar 1 00:06:13.416:Di1 IPCP:Install route to 194.183.201.1 
   *Mar 1 00:06:14.360:%LINEPROTO-5-UPDOWN:Line protocol on Interface BRI0:1,
   changed state to up 
   *Mar 1 00:06:19.276:%ISDN-6-CONNECT:Interface BRI0:1 is now connected to 6122
   unknown



関連するシスコ サポート コミュニティ ディスカッション

シスコ サポート コミュニティは、どなたでも投稿や回答ができる情報交換スペースです。


関連情報




Document ID: 14562