ブロードバンド ケーブル : 無線周波数(RF)光ファイバ / 同軸ハイブリッド(HFC)

Cisco CMTS のケーブル変調プロファイルの設定

2003 年 3 月 5 日 - ライター翻訳版
その他のバージョン: PDFpdf | 機械翻訳版 (2013 年 8 月 21 日) | 英語版 (2005 年 11 月 22 日) | フィードバック

目次


概要

Cisco Cable Modem Termination System(CMTS; ケーブルモデム終端システム)には、音声およびデータを扱うケーブル モデム プラントの RF 設定用の変調プロファイルを処理する能力があります。Cisco IOS(R) ソフトウェアに付属するデフォルトの変調プロファイルは、ほとんどの条件で最適となるように設計されています。したがって、デフォルトの設定の変更はお勧めできません。ただし、Cisco IOS に付属している変調プロファイルがユーザーの要望と異なる場合は、ユーザーの要望に合わせて変調プロファイルをカスタマイズおよび設定することができます。

注意: これらのパラメータの変更は、変調の変更および DOCSIS の仕様について理解している熟練者のみが行うことをお勧めします。これらのコマンドは物理層に影響を与えるため、熟練者以外がこれらの変更を行った場合、サービスの障害または質の低下が発生する可能性があります。

この文書では、変調プロファイルの変更に必要な設定コマンドと、設定されたパラメータの検証に使用される show コマンドについて説明します。

Cisco CMTS の IOS リリースでは、事前設定された 1 つの変調プロファイルがメモリに常駐しています。この変調プロファイルにより、Quadrature Phase Shift Keying(QPSK; 4 位相偏移変調)変調の典型的なプロファイルが定義されます。Cisco uBR7100、uBR7200、および uBR10000 シリーズ CMTS は、最大 8 つのケーブル変調プロファイルをサポートします。デフォルトはプロファイル 1 です。

次のコマンドを使用すると、デフォルトで設定されているすべてのパラメータが表示されます。

ubr7246#show cable modulation-profile

 Mod IUC     Type Preamb Diff FEC    FEC   Scrambl Max  Guard Last Scrambl Preamb

                  length enco T      CW    seed    B    time  CW           offset

                              BYTES  size          size size  short

 1   request qpsk 64     no   0x0    0x10  0x152   0    8     no   yes     952

 1   initial qpsk 128    no   0x5    0x22  0x152   0    48    no   yes     896

 1   station qpsk 128    no   0x5    0x22  0x152   0    48    no   yes     896

 1   short   qpsk 72     no   0x5    0x4B  0x152   6    8     no   yes     944

 1   long    qpsk 80     no   0x8    0xDC  0x152   0    8     no   yes     936   

構文の説明

変調プロファイルを定義するには、cable modulation-profile グローバル設定コマンドを使用します。指定された変調プロファイルを削除するには、このコマンドの no 形式を使用します。

cable modulation-profile profile [ iuc | mix | qam-16 | qpsk ] fec-tbytes fec-len burst-len guard-t mod scrambler seed diff pre-len last-cw uw-len

no cable modulation-profile profile [ iuc | mix | qam-16 | qpsk ] fec-tbytes fec-len burst-Len guard-t mod scrambler seed diff pre-Len last-cw uw-len

注: これらのオプションはすべて、Cisco IOS バージョン 12.1(1)EC 以降でサポートされます。これ以前のバージョンでは、initial、long、request、short、または station オプションのみが使用できます。この修正は、Bug ID CSCdm07759 および CSCdm56067 の後に行われています。今後すべての機能が組み込まれた IOS 12.0T または 12.0SC がリリースされる見込みです。

パラメータ 記述

profile

変調プロファイル番号。値は 1 〜 8 で、1 がデフォルトの変調プロファイルです。

注:   このコマンドを正しく使用するには、1 行に各アップストリーム バースト タイプのすべてのパラメータを入力します。バースト プロファイルが不完全な場合、動作の信頼性が低下したり、モデム接続が失われたりする原因となります。

mix デフォルトの QPSK/16-QAM 混合変調プロファイルを作成します。この混合変調プロファイルでは、ショート グラントおよびロング グラントのバーストは 16-QAM を使用して送信され、要求、初期レンジング、およびステーション メンテナンスのバーストは QPSK を使用して送信されます。バースト パラメータは、各バースト タイプのデフォルトの値に設定されます。
qam-16 デフォルトの 16-QAM 変調プロファイルを作成します。この変調プロファイルでは、すべてのバーストが 16-QAM を使用して送信されます。バースト パラメータは、各バースト タイプのデフォルトの値に設定されます。
qpsk デフォルトの QPSK 変調プロファイルを作成します。この変調プロファイルでは、すべてのバーストが QPSK を使用して送信されます。バースト パラメータは、各バースト タイプのデフォルトの値に設定されます。

iuc

内部使用コード。有効なエントリは initial、long、request、short、または station です。

fec-tbytes

Forward Error Correction(FEC; 転送エラー訂正)コードワードごとに訂正できるバイト数。有効値は 0 〜 10 で、0 は FEC なしを意味します。これは FEC デコーダが 1 コードワード内で訂正できるバイト数です。コードワードは、情報バイト、呼び出し k バイト、およびエラー訂正用のパリティ バイトから成ります。パリティ バイト数は、訂正可能なエラー(T)数の 2 倍です。T のサイズはチャネル障害によって決まります。

fec-len

FEC コードワードの情報バイト長。 有効値は 16 〜 253 バイトです。
この値は、FEC コードワード当たりの情報バイト数(k)を指定します。

Burst-Len

ミニスロットの最大バースト長。有効値は 0 〜 255 で、0 は制限なしを意味します。これは、ショート データ グラント バースト プロファイルを使用するパケットと、ロング データ グラント バースト プロファイルを使用するパケットの区切りを判別するために使用します。パケットの伝送に必要なアップストリーム時間がこの値より大きい場合は、ロング データ グラント バースト プロファイルが使用されます。所要時間がこの値以下の場合は、ショート データ グラント バースト プロファイルが使用されます。

guard-t

ガード タイム(シンボル数)。バーストから次のバーストまでの時間です。有効値は 0 〜 255 シンボルです。1 つのバーストが確実に終了してから次のバーストが始まるように、バースト伝送の最後に発生するブランクの時間を表します。

mod

変調。有効なエントリは 16qam および qpsk です。変調タイプは、変調シンボル当たり 4 ビット(QAM-16)、または変調シンボル当たり 2 ビット(QPSK)のいずれかを選択する際に使用されます。QAM-16 では、位相と振幅の両方を使用して情報を伝送します。QPSK では、信号搬送波の位相で情報を伝送します。QAM-16 で QPSK と同じ BER を達成するには約 7 dB 高い C/N が必要ですが、QAM-16 では QPSK の 2 倍の速度で情報が伝送されます。

scrambler

スクランブラを有効または無効にします。有効なエントリは scrambler および no-scrambler です。スクランブラは、ほぼランダムな伝送シンボル シーケンスを作成するために使用されます。これにより、チャネル内で伝送されるエネルギーのスペクトル分布が均一になります。スクランブラ シードは、ビットをスクランブルする疑似ランダム機能を開始するための初期値です。送信装置と受信装置の両方でシード値がわかっているので、受信装置で逆スクランブルを実行し、オリジナル データのみを残すことができます。

seed

16 進形式のスクランブラ シード。有効値は 0x0000〜0x7FFF です。

diff

差分符号化を有効または無効にします。差分符号化は、シンボルの絶対位相ではなく、2 つの変調シンボル間の位相変化によって情報を伝送する手法です。この技術により、受信信号の絶対位相が重要ではなくなり、同じ C/N で BER が 2 倍になります。

pre-Len

プリアンブル長(ビット数)。有効な値は 2 〜 128 です。プリアンブル長(およびプリアンブル オフセット)は、変調シンボルの同期文字列の定義に使用されます。これらの文字列は、送信されたバーストの位相およびタイミングを受信装置に認識させるために使用されます。

last-cw

最終コードワードの FEC の取り扱い。有効なエントリは、固定コードワード長を表す fixed と、短縮された最終コードワードを表す shortened です。

uw-len

アップストリーム固有ワード長。uw8(8 ビット固有ワード)または uw16(16 ビット固有コードワード)を入力します。

表 1:cable modulation-profile コマンドのパラメータの定義

デフォルト設定

変調プロファイル #1

コマンド モード

グローバル設定

コマンド ヒストリ

リリース 変更

11.3 NA

このコマンドが導入されました。

12.0(7)XR2

このコマンドが使用されました。

12.0(6)SC および 12.1(3a)EC1

mix、qpsk、および qam-16 オプションが追加されました。

表 2

使用上のガイドライン

変調プロファイルは、Upstream Channel Descriptor(UCD) メッセージで送信される 6 つのバースト プロファイルの集合で、次のアップストリーム メッセージ タイプのモデム伝送パラメータを設定します。

  • request
  • initial maintenance
  • station maintenance
  • short grant
  • long grant

変調プロファイル 1 以外の変調プロファイルをすべて削除するには、no cable modulation-profile コマンドを使用します。変調プロファイル 1 の場合は、no cable modulation-profile コマンドを使用するとバースト内のパラメータがすべてデフォルト値に設定されます。

注意: 変調プロファイルを変更すると、物理層に対する変更が発生します。物理層の特性の変更はルータのパフォーマンスおよび機能に影響するため、熟練ユーザ以外はこの作業を実行しないでください。

cable modulation-profile コマンドを正しく使用するには、1 行に各アップストリーム バースト タイプのすべてのパラメータを入力します。バースト プロファイルが不完全な場合、動作の信頼性が低下したり、モデム接続が失われたりする原因となります。

スクランブラをオフにするとパケット損失が発生する可能性があります。オフ設定はラボにおけるテスト環境でのみ使用します。

バースト プロファイルの設定にエラーや不備があると、モデムが接続を解除したり、ショートまたはロング データ パケットを廃棄したり、モデムからネットワークへの接続が失敗したりすることがあります。バースト プロファイルの設定によっては、DOCSIS 受信装置の実装がモデムからのデータを受信できなくなる可能性もあります。

160 K シンボル/秒および 2560 K シンボル/秒のデータ レートでは、固有ワード長、プリアンブル長、および FEC サイズの影響を受けやすくなります。これらの値が正しく選択されていないと、これらのシンボル レートでの接続性が低下するか、まったく接続できなくなることがあります。

設定例

カスタマイズの例

次の例は、16 Quadrature Amplitude Modulation(QAM; 直交振幅変調)の変調プロファイルです。このプロファイルでは、初期、要求、およびステーション メンテナンスのメッセージは Quadrature Phase-Shift Keying(QPSK; 4 位相偏移変調)として送信され、ショートおよびロングのデータ パケットは 16QAM として送信されます。16QAM 変調は QPSK に比べて帯域効率に優れていますが、QPSK は 16QAM よりも安定しています。

次の例では、要求バーストは次のように定義されています。

  • fec-tbytes = 0
  • fec-len = 16 KB
  • Burst-Len = 1
  • guard-t = 8
  • mod 値 = qpsk
  • scrambler が有効、seed 値 = 152
  • 差分符号化が無効(no-diff)
  • pre-Len = 64 ビット
  • 固定コードワード長(fixed)
  • アップストリーム固有ワード長が 8 ビット固有ワード(uw8)

それ以外の初期、ステーション、ショート、およびロング バーストは、プロファイル 2 と同様に定義されています。

ubr7246#config t


 Enter configuration commands, one per line.  End with CNTL/Z.


 ubr7246(config)#cable modulation-profile 2 request 0 16 1 8 qpsk scrambler 152 no-diff 64 fixed uw8 

 ubr7246(config)#cable modulation-profile 2 initial 5 34 0 48 qpsk scrambler 152 no-diff 128 fixed uw16

 ubr7246(config)#cable modulation-profile 2 station 5 34 0 48 qpsk scrambler 152 no-diff 128 fixed uw16 

 ubr7246(config)#cable modulation-profile 2 short 6 75 6 8 16qam scrambler 152 no-diff 144 fixed uw8

 ubr7246(config)#cable modulation-profile 2 long 8 220 0 8 16qam scrambler 152 no-diff 160 fixed uw8 

 ubr7246(config)#^Z

 ubr7246#


 

注:変調プロファイル コマンドを使用して、この変調プロファイルのすべてのバースト(要求、初期、ステーション、ショートおよびロング)を作成する必要があります。これを怠った場合、パフォーマンスの問題またはサービスの中断が発生する可能性があります。

この例は次の機器を使用しています。

名称 モデル 用途 S/W のバージョン イメージ名
ケーブル ヘッド端末 uBR7246 ケーブル モデム終端システム 12.1(1a) ubr7200-ik1st-mz.121-1a.T1
ホーム オフィス uBR924 ケーブル モデム 12.2(1) ubr920-k8o3v6y5-mz.122-1.bin
  PC DHCP サーバ WinNT Server4.0 CiscoNetworkRegistrar 3.5
    TFTP サーバ " Cisco TFTP
    TOD サーバ " 任意の NTP/ TOD サーバが動作


次に、uBR7246 の設定全体を示します。太字のコマンドが、変調プロファイルの設定に関係するコマンドです。

uBR7246 の設定
ubr7246#show run

 Building configuration...

 Current configuration:

 !

 version 12.1

 no service pad

 service timestamps debug uptime

 service timestamps log uptime

 no service password-encryption

 service compress-config

 !

 hostname ubr7246

 !

 enable password ww

 !

 cable modulation-profile 2 request 0 16 1 8 qpsk scrambler 152 no-diff 64 fixed uw8

 cable modulation-profile 2 initial 5 34 0 48 qpsk scrambler 152 no-diff 128 fixed uw16

 cable modulation-profile 2 station 5 34 0 48 qpsk scrambler 152 no-diff 128 fixed uw16

 cable modulation-profile 2 short 6 75 6 8 16qam scrambler 152 no-diff 144 fixed uw8

 cable modulation-profile 2 long 8 220 0 8 16qam scrambler 152 no-diff 160 fixed uw8

 no cable qos permission create

 no cable qos permission update

 cable qos permission modems

 cable time-server

 !

 !

 !

 !

 ip subnet-zero

 no ip domain-lookup

 !

 interface Ethernet2/0

  ip address 172.16.30.20 255.255.255.192

 !

 interface Cable3/0

  ip address 192.168.5.1 255.255.255.0 secondary

  ip address 10.2.3.1 255.255.255.0

  no keepalive

  cable downstream rate-limit token-bucket shaping

  cable downstream annex B

  cable downstream modulation 256qam

  cable downstream interleave-depth 32

  cable upstream 0 frequency 20000000

  cable upstream 0 power-level 0

  cable upstream 0 modulation-profile 2

  no cable upstream 0 shutdown

  cable upstream 1 shutdown

  cable upstream 2 shutdown

  cable upstream 3 shutdown

  cable upstream 4 shutdown

  no cable upstream 5 shutdown

  cable source-verify dhcp

  cable dhcp-giaddr policy

  cable helper-address 172.16.30.3

 !

 ip classless

 ip route 0.0.0.0 0.0.0.0 172.16.30.1

 no ip http server

 !

 !

 line con 0

  transport input none

 line aux 0

 line vty 0 4

  password ww

  login tacacs

 !

 end

 

この文書において完全に説明するため、ケーブル モデム uBR924 のうちの 1 台の設定を次に示します。これは、ケーブル モデムがオンラインになり、DHCP サーバから IP アドレスを取得した後の基本的なブリッジ設定です。

uBR924 の設定
uBR924-445b#show run

 Building configuration...



 version 12.2

 no service single-slot-reload-enable

 no service pad

 service timestamps debug uptime

 service timestamps log uptime

 no service password-encryption

 !

 hostname uBR924-445b

 !

 logging rate-limit console 10 except errors

 !

 clock timezone - -8

 ip subnet-zero

 no ip routing

 no ip finger

 !

 ip audit notify log

 ip audit PO max-events 100

 no ip dhcp-client network-discovery

 call RSVP-sync

 !

 !

 !

 interface Ethernet0

  ip address 10.2.3.3 255.255.255.0

  no ip route-cache

  bridge-group 59

  bridge-group 59 spanning-disabled

 !

 interface cable-modem0

  no ip route-cache

  bridge-group 59

  bridge-group 59 spanning-disabled

  h323-gateway voip interface

  h323-gateway voip id 3620-gk ipaddr 172.16.30.5 1718

  h323-gateway voip h323-id test2

 !

 ip classless

 ip http server

 no ip http cable-monitor

 !

 snmp-server packetsize 4096

 snmp-server manager

 !

 voice-port 0

  input gain -2

  output attenuation 0

 !

 voice-port 1

  input gain -2

  output attenuation 0

 !

 dial-peer voice 1 pots

  destination-pattern 3333

  port 0

 !

 dial-peer voice 2 pots

  destination-pattern 4444

  port 1

 !

 dial-peer voice 10 voip

  destination-pattern 1111

  session target ras

 !

 gateway

 !

 !

 line con 0

  transport input none

 line vty 0 4

 !

 end

 

変調プロファイルの組み込みテンプレート

新しい変調プロファイルを定義するプロセスを簡略化するには、cable modulation-profile コマンドを使用します。このコマンドを使用すると、事前定義された 3 つのテンプレートのいずれかをベースにして、完全な変調プロファイルをすばやく作成できます。テンプレートには次の 3 つがあります。

  • qpsk:このテンプレートは、すべての IUC で QPSK を使用するために最適化された変調プロファイルです。
  • mix:このテンプレートは、データ トラフィックで QAM-16、メンテナンスおよび要求トラフィックで QPSK を使用するために最適化された変調プロファイルです。
  • QAM-16:このテンプレートは、すべての IUC で 16-QAM を使用するために最適化された変調プロファイルです。シスコではこの変調プロファイルを使用することを推奨しません。

メンテナンス トラフィックで QPSK の安定性を利用し、データ トラフィックで 16-QAM のスピードを活用するためには、「mix」を使用します。これらのテンプレートのいずれかを使用して新しい変調プロファイルを作成する場合は、cable modulation-profile コマンドを次の形式で使用します。

QPSK 変調プロファイルの例

QPSK テンプレートを使用して Cisco CMTS を設定する場合は、グローバル設定でコマンド cable modulation-profile <n> qpsk を入力するだけです。これを次の出力例で示します。

ubr7246#conf t

 Enter configuration commands, one per line.  End with CNTL/Z.


 ubr7246(config)#cable modulation-profile 2 qpsk

 ubr7246(config)#end

このコマンドを入力すると、事前設定されたこのプロファイルの設定が CMTS にロードされ、設定に表示されます。

ubr7246#show run | include modulation-profile 2

 cable modulation-profile 2 request 0 16 0 8 qpsk scrambler 152 no-diff 64 fixed uw8

 cable modulation-profile 2 initial 5 34 0 48 qpsk scrambler 152 no-diff 128 fixed uw16

 cable modulation-profile 2 station 5 34 0 48 qpsk scrambler 152 no-diff 128 fixed uw16

 cable modulation-profile 2 short 5 75 6 8 qpsk scrambler 152 no-diff 72 fixed uw8

 cable modulation-profile 2 long 8 220 0 8 qpsk scrambler 152 no-diff 80 fixed uw8

すべての IUC が自動的に QPSK 変調で作成された点に注意してください。cable modulation-profile <n> {qpsk|QAM-16|mix} を入力した後で、パラメータを手動でも変更できます。

QAM-16 変調プロファイルの例

QAM-16 テンプレートを使用してシスコの CMTS を設定するには、グローバル設定でコマンド cable modulation-profile <n> qam-16k を入力するだけです。これを次の出力例で示します。

ubr7246#conf t

 ubr7246(config)#cable modulation-profile 3 QAM-16

 ubr7246(config)#end

このコマンドを入力すると、事前設定されたこのプロファイルの設定が CMTS にロードされ、設定に表示されます。

ubr7246#show run | include modulation-profile 3 

 cable modulation-profile 3 request 0 16 0 8 16qam scrambler 152 no-diff 128 fixed uw16

 cable modulation-profile 3 initial 5 34 0 48 16qam scrambler 152 no-diff 256 fixed uw16

 cable modulation-profile 3 station 5 34 0 48 16qam scrambler 152 no-diff 256 fixed uw16

 cable modulation-profile 3 short 6 75 6 8 16qam scrambler 152 no-diff 144 fixed uw8

 cable modulation-profile 3 long 8 220 0 8 16qam scrambler 152 no-diff 160 fixed uw8

 ubr7246#

QPSK と QAM16 の混合変調プロファイルの例

QPSK と QAM-16 の変調プロファイルを組み合せた、より堅牢で高速なテンプレートも実装されています。

mix テンプレートを使用して Cisco CMTS を設定する場合は、グローバル設定でコマンド cable modulation-profile <n> mix を入力するだけです。これを次の出力例で示します。

ubr7246#conf t


 Enter configuration commands, one per line.  End with CNTL/Z.


 ubr7246(config)#cable modulation-profile 4 mix

 ubr7246(config)#end

このコマンドを入力すると、事前設定されたこのプロファイルの設定が CMTS にロードされ、設定に表示されます。

ubr7246#show run | include modulation-profile 4

 cable modulation-profile 4 request 0 16 0 8 qpsk scrambler 152 no-diff 64 fixed uw16

 cable modulation-profile 4 initial 5 34 0 48 qpsk scrambler 152 no-diff 128 fixed uw16

 cable modulation-profile 4 station 5 34 0 48 qpsk scrambler 152 no-diff 128 fixed uw16

 cable modulation-profile 4 short 6 75 6 8 16qam scrambler 152 no-diff 144 fixed uw8

 cable modulation-profile 4 long 8 220 0 8 16qam scrambler 152 no-diff 160 fixed uw8    

この場合は、ショートおよびロング IUC が QAM-16 を使用し、request、initial、および station が QPSK を使用する点に注意してください。

注: 16-QAM mix プロファイルでは、ロングおよびショート IUC のデフォルトの固有ワード設定は 8 ビット固有ワード(UW8)です。シスコでは UW16 の使用をお勧めします。より長い固有ワードを使用した方が、ノイズが多い状況で有利であり、また訂正できない FEC エラーの発生が減少します。

固有ワード長を UW8 から UW16 に変更するには、コマンド cable modulation-profile <n> を使用します。次に、固有ワード長を UW8 から UW16 に変更した後の show run | include modulation-profile 4 の出力を示します。

ubr7246#show run | include modulation-profile 4

       cable modulation-profile 4 request 0 16 0 8 qpsk scrambler 152 no-diff 64 fixed uw16

        cable modulation-profile 4 initial 5 34 0 48 qpsk scrambler 152 no-diff 128 fixed uw16

        cable modulation-profile 4 station 5 34 0 48 qpsk scrambler 152 no-diff 128 fixed uw16

        cable modulation-profile 4 short 6 75 6 8 16qam scrambler 152 no-diff 144 fixed uw16

        cable modulation-profile 4 long 8 220 0 8 16qam scrambler 152 no-diff 160 fixed uw16

次の「関連コマンド」の項で、show cable modulation-profile コマンドの使用について詳しく説明します。このコマンドは、変調プロファイルを設定した後、入力したすべてのパラメータが CMTS で正しく理解されたかどうかを確認するために使用します。

関連コマンド

cable upstream modulation-profile

変調プロファイルをインターフェイスに割り当てるには、cable upstream modulation-profile インターフェイス設定コマンドを使用します。デフォルトのプライマリ変調プロファイル(profile #1)をインターフェイスに割り当てる場合は、このコマンドの no 形式を使用します。

Cable upstream n modulation-profile primary-profile-number secondary-profile-number

no cable upstream n modulation-profile primary-profile-number secondary-profile-number

構文の説明

n

ケーブル モデム スロットのポート番号(ポート番号は 0 で始まります)。

primary-profile number

このインターフェイスに追加されるデフォルトの変調プロファイル。

secondary-profile number

このインターフェイスに追加される追加の変調プロファイル。

表 4

デフォルト設定

プライマリ変調プロファイル(profile #1)

コマンド モード

インターフェイス設定

コマンド ヒストリ

リリース 変更

11.3 NA

このコマンドが初めて導入されました。

12.0(7)XR2 および 12.1(1a)T1

このコマンドが 12.x 群に導入されました。

12.1(3a)EC1 このコマンドが変更され、Dynamic Upstream Modulation 機能を有効にするための primary-profile-number および secondary-profile-number パラメータが追加されました。
12.1(5)EC このコマンドが Cisco uBR7100 シリーズ ユニバーサル ブロードバンド ルータに対応しました。

12.1(7)CX

このコマンドが Cisco uBR-MC16S ラインカード向けに拡張されました。

表 5

使用上のガイドライン

変調プロファイルは、固定アップストリーム周波数を用いて設定することも、インターフェイス上で割り当てられたスペクトル グループを用いて設定することもできます。Dynamic Upstream Modulation 機能では、変調プロファイルを使用してアップストリーム信号品質を追跡します。この機能は、アップストリーム信号が、設定されている変調方式をサポートできるかどうかをチェックし、必要に応じてより安定した変調方式に調整します。リターン パスの状態が改善されると、アップストリーム チャネルはより高度な変調方式に戻されます。

Cisco uBR-MC1xC および Cisco uBR-MC16S ケーブル モデム カードでは、同じインターフェイスに Dynamic Upstream Modulation とスペクトル グループが設定されている場合、修正アクションとして最初に変調プロファイルの切り替え、次に周波数ホッピング、最後にチャネル幅の縮小が行われます。

次の例では、プライマリ変調プロファイル 2 およびセカンダリ変調プロファイル 1 をポート(インターフェイス)0 に割り当てます。

Router(config-if)# cable upstream 0 modulation-profile 2 1

show cable modulation-profile

show cable modulation-profile [profile] [iuc-code]

構文の説明

profile

(オプション)プロファイル番号。有効な値は、1 から 8 です。

iuc-code

(オプション)内部使用コード。次のオプションが有効です。

  • initial - 初期レンジング バースト
  • long - ロング グラント バースト
  • request - 要求バースト
  • reqdata - 要求/データ バースト
  • short ・ショート グラント バースト
  • station - ステーション レンジング バースト
表 6

デフォルト設定

デフォルトの動作または値はありません。

コマンド モード

特権 EXEC

コマンド履歴

リリース 変更

11.3 XA

このコマンドが初めて導入されました。

12.(0)7XR2

このコマンドが使用されました。

12.1(3a)EC1

このコマンドがサポートされ、要求/データ タイプが追加されました。

表 7

使用上のガイドライン

show cable modulation-profile コマンドを使用すると、変調プロファイル グループの情報が表示されます。変調プロファイルは、UCD メッセージで送信される 6 つのバースト プロファイルの集合で、次のアップストリーム メッセージ タイプのモデム伝送パラメータを設定します。

  • request
  • reqdata
  • initial maintenance
  • station maintenance
  • short grant
  • long grant

次に、show cable modulation-profile コマンドからの出力例を示します。

ubr7246#show cable modulation-profile 1

 Mod IUC     Type Preamb Diff FEC    FEC   Scrambl Max  Guard Last Scrambl Preamb

                  length enco T      CW    seed    B    time  CW           offset

                              BYTES  size          size size  short

 1   request qpsk 64     no   0x0    0x10  0x152   1    8     no   yes     952

 1   initial qpsk 128    no   0x5    0x22  0x152   0    48    no   yes     896

 1   station qpsk 128    no   0x5    0x22  0x152   0    48    no   yes     896

 1   short   qpsk 72     no   0x5    0x4B  0x152   6    8     no   yes     944

 1   long    qpsk 80     no   0x8    0xDC  0x152   0    8     no   yes     936

 

次の表に、show cable modulation-profile コマンド出力のフィールドの説明を示します。

フィールド 記述

Mo

変調プロファイル グループ番号。変調プロファイル グループとは、さまざまなタイプのアップストリーム伝送クラスに対して、アップストリーム伝送の特性を定義するバースト プロファイルのセットです。

IUC

内部使用コード。各アップストリーム伝送バーストは、IUC と呼ばれる番号を持つクラスに属します。アップストリーム タイムスロットの割り当てに使用される IUC コード別に、メッセージが帯域幅にマップされます。現在は次のタイプが定義されています。

  • initial - 初期レンジング バースト
  • long - ロング グラント バースト
  • request - 要求バースト
  • reqdata - 要求/データ バースト
  • short ・ショート グラント バースト
  • station - ステーション レンジング バースト

Type

変調タイプ

Preamb length

プリアンブル長

Diff enco

差分符号化が有効(yes)または無効(no)。

FEC T bytes

各 FEC コードワードごとに訂正できるバイト数。

FEC k bytes FEC コードワード当たりの情報バイト数。

FEC CW size

ポスト FEC コードワードのサイズ(バイト)。これは通常 k + 2T バイト、つまり、FEC 情報バイト数(k)に、各 FEC コードワード内で訂正できるバイト数(T)の 2 倍を足した値です。

Scrambl seed

16 進形式のスクランブラ シード値。

Max B size

最大バースト サイズ。

Guard time size

バーストから次のバーストまでの時間(シンボル)。

Last CW short

短縮された最終コードワードの FEC の取り扱い。

Scrambl

スクランブラが有効(yes)または無効(no)。

Preamb offset

プリアンブル値に使用されるビット。

表 8

設定した変調プロファイルのパラメータが適切かどうかを検証するため、プロファイル #2 に show cable modulation-profile を使用します。



 ubr7246#show cable modulation-profile 2

 Mod IUC     Type Preamb Diff FEC    FEC   Scrambl Max  Guard Last Scrambl Preamb

                  length enco T      CW    seed    B    time  CW           offset

                              BYTES  size          size size  short

 2   request qpsk 64     no   0x0    0x10  0x152   1    8     no   yes     440

 2   initial qpsk 128    no   0x5    0x22  0x152   0    48    no   yes     384

 2   station qpsk 128    no   0x5    0x22  0x152   0    48    no   yes     384

 2   short   qam  144    no   0x6    0x4B  0x152   6    8     no   yes     864

 2   long    qam  160    no   0x8    0xDC  0x152   0    8     no   yes     848      

関連するシスコ サポート コミュニティ ディスカッション

シスコ サポート コミュニティは、どなたでも投稿や回答ができる情報交換スペースです。


関連情報


Document ID: 23710