IP : IP ルーティング

ブロードキャスト メディア上のOSPFの初期設定

2003 年 1 月 17 日 - ライター翻訳版
その他のバージョン: PDFpdf | 機械翻訳版 (2013 年 8 月 21 日) | 英語版 (2007 年 7 月 6 日) | フィードバック

イーサネットおよびその他のブロードキャスト メディア上では、OSPFはブロードキャスト ネットワーク タイプとして動作します。このネットワーク タイプは、デフォルトでイネーブルに設定されています。この資料では、ブロードキャスト メディア上のOSPFのコンフィギュレーション例を示します。OSPFを実行しているインターフェイスのネットワーク タイプを確認するには、show ip ospf interfaceコマンドを使用します。

ネットワークダイアグラム

Network Diagram

設定

R2-AGS R6-2500
     interface Loopback0
        ip address 5.5.5.5 255.255.255.255
       !
       interface Ethernet0
        ip address 1.1.1.2 255.255.255.0
       !
  
       router ospf 1
        network 1.1.1.0 0.0.0.255 area 0
       !
  
     interface Loopback0
        ip address 6.6.6.6 255.255.255.255
        no ip directed-broadcast
       !
       interface Ethernet0
        ip address 1.1.1.1 255.255.255.0
        ip directed-broadcast
       !
       router ospf 1
        network 1.1.1.0 0.0.0.255 area 0
       !
  

確認のためのヒント

R2-AGSに関するshowコマンドの出力を示します。

R2-AGS#show ip ospf neighbor
        
       Neighbor ID     Pri   State           Dead Time   Address         Interface
       6.6.6.6           1   FULL/DR         0:00:34     1.1.1.1         Ethernet0
  
       
  R2-AGS#show ip ospf interface e0
       Ethernet0 is up, line protocol is up 
         Internet Address 1.1.1.2 255.255.255.0, Area 0 
         Process ID 1, Router ID 5.5.5.5, Network Type BROADCAST, Cost: 10
         Transmit Delay is 1 sec, State BDR, Priority 1 
         Designated Router (ID) 6.6.6.6, Interface address 1.1.1.1
         Backup Designated router (ID) 5.5.5.5, Interface address 1.1.1.2
         Timer intervals configured, Hello 10, Dead 40, Wait 40, Retransmit 5
           Hello due in 0:00:07
         Neighbor Count is 1, Adjacent neighbor count is 1 
           Adjacent with neighbor 6.6.6.6  (Designated Router)
  

R6-2500に関する出力は、次のとおりです。

R6-2500#show ip ospf neighbor
        
       Neighbor ID     Pri   State           Dead Time   Address         Interface
       5.5.5.5           1   FULL/BDR        00:00:33    1.1.1.2         Ethernet0
  
       
  R6-2500#show ip ospf interface e0
       Ethernet0 is up, line protocol is up 
         Internet Address 1.1.1.1/24, Area 0 
         Process ID 1, Router ID 6.6.6.6, Network Type BROADCAST, Cost: 10
         Transmit Delay is 1 sec, State DR, Priority 1 
         Designated Router (ID) 6.6.6.6, Interface address 1.1.1.1
         Backup Designated router (ID) 5.5.5.5, Interface address 1.1.1.2
         Timer intervals configured, Hello 10, Dead 40, Wait 40, Retransmit 5
           Hello due in 00:00:01
         Neighbor Count is 1, Adjacent neighbor count is 1 
           Adjacent with neighbor 5.5.5.5  (Backup Designated Router)
         Suppress hello for 0 neighbor(s)
  


関連するシスコ サポート コミュニティ ディスカッション

シスコ サポート コミュニティは、どなたでも投稿や回答ができる情報交換スペースです。


関連情報


Document ID: 13686