IP : IP ルーティング

OSPF を使用した、大規模なサービス プロバイダーのダイヤル ネットワークの設計

2005 年 8 月 10 日 - ライター翻訳版
その他のバージョン: PDFpdf | 機械翻訳版 (2013 年 8 月 21 日) | 英語版 (2005 年 8 月 10 日) | フィードバック

目次

概要
ネットワーク トポロジ
ISP のダイヤルアップ プール
      スタティック プール
      中央プール
スタティック プールを使用してダイヤルアップを設計する方法
      プールのアドレス範囲に対して、null 0 をポイントするスタティック ルートを作成する方法
      OSPF ポイントツーポイント ネットワーク タイプが設定された NAS のループバックにプール アドレスを割り当てる方法
      プール アドレスの ABR 上のスタティック ルートが NAS(ASBR)をポイントするように設定する方法
中央アドレス プールからダイナミックに IP アドレスを割り当ててダイヤルアップを設計する方法
エリアのスケーラビリティの問題
結論
関連するシスコ サポート コミュニティ ディスカッション
関連情報

概要

ダイヤル ネットワークの設計は、Internet Service Provider(ISP; インターネット サービス プロバイダー)にとって困難な課題となっています。 ダイヤル ネットワークの設計は、ISP ごとに独自の方法で行われていますが、設計時には、どの ISP でも次のような点に注意する必要があります。

  • プール ルートを ISP のコアにどのように伝搬するか。

  • それらのルートをコアに伝送するために、どのルーティング プロトコルを使用するか。

  • それらのダイヤルアップ ルートをコアに送信する前に、集約する必要があるか。

  • プールが配布されるときには、何を考慮に入れる必要があるか。

  • プールがスタティックである場合には、どうすればよいか。

このドキュメントでは、前述のほとんどの質問について説明します。また、Interior Gateway Protocol(IGP; 内部ゲートウェイ プロトコル)の Open Shortest Path First(OSPF)を ISP のダイヤル環境で使用する場合の設計方法についても説明します。 多くの場合、ISP のコア ネットワークには OSPF が使用されています。 このドキュメントでは、ダイヤル プールのルートの伝送に別のプロトコルを導入することは避けて、OSPF を使用してコアに伝搬しています。

ネットワーク トポロジ

次の図は、一般的な ISP ダイヤル ネットワークのトポロジを示しています。 ダイヤルアップ サービスを提供する ISP には、通常、一連の Network Access Server(NAS; ネットワーク アクセス サーバ)があり、一般的には AS5300 か AS5800 が使用されています。 これらのサーバには、ISP にダイヤルしてインターネット サービスを利用するすべてのユーザに IP アドレスを提供する役割があります。 NAS サーバは、次に集約デバイスに接続されており、通常は Cisco 6500 ルータが使用されています。 6500 ルータは、ダイヤルアップ ルートをコアに伝搬して、コア ルータからエンドユーザにインターネット サービスを提供できるようにします。 次の図は、一般的な Point Of Presence(POP; ポイント オブ プレゼンス)のシナリオを示しています。

ispdial.jpg

ISP のダイヤルアップ プール

通常、ISP は次のタイプの IP アドレスのプールを使用しています。

  • スタティック

  • 中央

スタティック プール

スタティック プールを使用する場合、ISP は、固有の IP アドレス セットを NAS サーバごとに専用に設定します。 ユーザは NAS に到達すると、その NAS に専用で割り当てられているプールから 1 つの IP アドレスを取得します。 たとえば、NAS1 のスタティック プール アドレスの範囲が 192.168.0.0/22 の場合は、およそ 1023 個の IP アドレスがあり、ユーザが NAS1 に到達するたびに、192.168.0.0 から 192.168.3.254 の範囲のアドレスを 1 つ取得します。

中央プール

中央プールを使用する場合、ISP は、1 つの POP 内のすべての NAS 全体に配布される、より広範囲な IP アドレスを設定します。 ユーザは NAS に到達すると、非常に広範囲に設定されている中央プールから 1 つの IP アドレスを取得します。 たとえば、中央プールのアドレスの範囲が 192.168.0.0/18 に設定されており、14 台の NAS サーバにアドレスが分散されている場合、IP アドレスはおよそ 14000 あります。

スタティック プールを使用してダイヤルアップを設計する方法

ルーティングの観点からすれば、スタティック プールを管理する方が簡単です。 NAS にスタティック プールが定義されている場合は、ルーティングのために、プールをコアに伝搬する必要があります。

NAS からダイヤルアップ ルートを伝搬するには、次の方法を使用します。

  • プールの IP アドレス範囲に対して、null 0 をポイントするようなスタティック ルートを作成して、プール アドレスが NAS で再配布されるようにする。

  • OSPF エリアにループバックが含まれた OSPF ポイントツーポイント ネットワーク タイプが設定された NAS 上で、プールの IP アドレスをループバックに割り当てる。

  • プール IP アドレス用の Area Border Router(ABR; エリア境界ルータ)のスタティック ルートが、NAS Autonomous System Boundary Router(ASBR; 自律システム境界ルータ)をポイントするように設定する。ABR で集約が行えるので、この方法をお勧めします。

プールのアドレス範囲に対して、null 0 をポイントするスタティック ルートを作成する方法

この方法を使用する場合は、NAS ごとにスタティック ルートを作成する必要があります。 この null 0 をポイントするスタティック ルートは、プール アドレスの範囲と正確に一致している必要があります。たとえば、スタティック プール アドレスが 192.168.0.0/22 の場合は、次のようなスタティック ルートを NAS に設定する必要があります。

NAS1(config)# ip route 192.168.0.0 255.255.252.0 null0
NAS1(config)# router ospf 1
NAS1(config-router)# redistribute static subnets
NAS1(config-router)# end

このプール アドレスが OSPF に再配布され、OSPF は、タイプ 5 の外部 Link-State Advertisement(LSA; リンクステート アドバタイズメント)の形式で、この情報をコアに伝搬します。

OSPF ポイントツーポイント ネットワーク タイプが設定された NAS のループバックにプール アドレスを割り当てる方法

この方法を使用する場合には、スタティック ルートは必要ありません。 プール アドレスは、ループバック インターフェイス上のサブネットとして割り当てられます。 ループバック インターフェイスのデフォルト ネットワーク タイプは LOOPBACK です。RFC 2328 leavingcisco.com によれば、このネットワーク タイプは、/32 として OSPF でアドバタイズする必要があります。ループバックのネットワーク タイプをポイントツーポイントに変更する必要があるのはこのためです。 ポイントツーポイント ネットワーク タイプを使用すると、ループバックのサブネット アドレス(この例では、192.168.0.0/22)が OSPF で強制的にアドバタイズされます。この場合は、次のように設定します。

NAS1(config)# interface loopback 1
NAS1(config-if)# ip addreess 192.168.0.1 255.255.252.0
NAS1(config-if)# ip ospf network-type point-to-point
NAS1(config-if)# router ospf 1
NAS1(config-router)# network 192.168.0.0 0.0.3.255 area 1
NAS1(config-router)# end

このように設定すると、ルータの LSA にルータ スタブ リンクが作成され、外部 OSPF ルートとしてではなく、内部 OSPF ルートとして伝搬されます。

プール アドレスの ABR 上のスタティック ルートが NAS(ASBR)をポイントするように設定する方法

注:Area Border Router(ABR; エリア境界ルータ)で集約が実行できるので、この方法を使用することをお勧めします。

この方法を使用する場合は、NAS には何も設定する必要がありません。 設定はすべて ABR つまり集約デバイスで行われます。 アドレス プールがスタティックなので、スタティック ルートを簡単に生成でき、それぞれの NAS つまり Autonomous System Boundary Router(ASBR; 自律システム境界ルータ)をネクストホップに設定できます。 これらのスタティック ルートは、OSPF 配下で再配布されるスタティック サブネットを使用して OSPF に再配布する必要があります。次に、例を示します。

ABR(config)# ip route 192.168.0.0 255.255.252.0 <next-hop ip address (NAS1)>
ABR(config)# ip route 192.168.4.0 255.255.252.0 <next-hop ip address (NAS2)>

! --- 残りの 12 NAS デバイスについても同様に指定します。

ABR(config)# router ospf 1
ABR(config-router)# redistribute static subnets
ABR(config-router)# end

集約を ABR で実行できるので、この方法を使用することをお勧めします。 前述の 2 つの方法でも集約できますが、NAS ごとに集約の設定が必要になります。この方法を使用すれば、このルータに集約を設定するだけで済みます。

スタティック プールが連続したブロックに設定されている場合は、すべてのスタティック ルートが ABR 上にあるので、ABR で集約できます。次に、例を示します。

ABR(config)# router ospf 1
ABR(config-router)# summary-address 192.168.0.0 255.255.192.0
ABR(config-router)# end

中央アドレス プールからダイナミックに IP アドレスを割り当ててダイヤルアップを設計する方法

この方法でダイヤルアップを設計する場合は、IP アドレスの中央プールが Remote Authentication Dial-In User Service(RADIUS)サーバに設定されていることが前提となります。 POP ごとに Dialed Number Information Service(DNIS; 着信番号情報サービス)の番号が設定されており、RADIUS サーバには DNIS ごとに別々の IP アドレス プールが設定されています。 さらに、DNIS のコールが終端するすべての NAS が同じエリアにあり、同じ集約ルータとやり取りしています。

IP アドレスの中央プールを使用すると、ルーティング プロトコルの設計が少し複雑になります。 この場合、POP の DNIS 番号をダイヤルしても、どの NAS に接続されるかはわからず、その DNIS 用の IP アドレスの中央プールからどの IP アドレスが割り当てられるかもわかりません。そのため、DNIS のプールから割り当てられたアドレスを、NAS ごとに集約することはできません。 ABR つまり集約デバイスにすべての情報を NAS が伝搬できるようにするためには、再配布済みで接続済みのサブネットが各 NAS に必要です。 この設計には 1 つの問題点があります。外部 LSA を集約できるのは ASBR だけですが、この設計では NAS サーバが ASBR になっています。NAS から入ってくる外部ルートの集約が、ABR でどのように行われるのでしょうか。

この設計上の問題を解決するためには、次の図に示すように、NAS サーバが所属するエリアを Not So Stubby Area(NSSA; 準スタブエリア)に設定することをお勧めします。

ispdial2.jpg

OSPF の NSSA の詳細については、『OSPF Not-So-Stubby Area(NSSA)』を参照してください。

エリアを NSSA として定義すると、次の利点があります。

  • ABR では LSA タイプ 7 から LSA タイプ 5 への再生成または変換を行えるので、すべての NAS ルートを ABR で集約できる。

  • NSSA では外部 LSA が使用できないので、各 POP では別の POP に属するルートは転送されない。

すべての NAS にまたがる IP アドレス プールはスタティックではなく、IP アドレスの中央プールの範囲内の任意の IP アドレスを任意の NAS が使用できるので、再配布済みで接続済みのサブネットをすべての NAS に設定する必要があります。

NAS1(config)# router ospf 1
NAS1(config-router)# redistribute connected subnets
NAS1(config-router)# end

ABR では、すべての LSA タイプ 7 が再生成されて LSA タイプ 5 に変換されるので、すべての NAS でこの設定が実行されると、集約の設定が ABR で実行されます。 ABR はまったく新しい LSA タイプ 5 を生成して ABR ルータの ID をルータ ID としてアドバタイズするので、ABR が ASBR の機能を果たすことになり、(NAS を発信元とする)以前 LSA タイプ 7 であったルートの集約が可能になります。

ABR(config)# router ospf 1
ABR(config-router)# summary-address 192.168.0.0 255.255.192.0
ABR(config-router)# end

ABR と NAS の間のエリアが NSSA であることに注意してください。このエリアは、次のように設定できます。

ABR(config)# router ospf 1
ABR(config-router)# network 10.10.10.0 0.0.0.255 area 1 nssa
ABR(config-router)# end

エリアのスケーラビリティの問題

1 つのエリアに多くの NAS サーバがある場合、1000 以上のルートが各 NAS によってエリアに再配布されます。ここで問題となるのは、何台の NAS サーバを各エリアに含める必要があるのかという点です。 すべての NAS サーバが同じエリアにあれば、すべての NAS サーバから 1000 以上のルートを転送する必要があるためにエリアが不安定になる可能性があります。 この例では 14 台の NAS サーバがあるので、14000 という膨大な数のルートが再配布される可能性があります。 エリアのスケーラビリティを向上させるためには、次の例に示すように数個のエリアに分割して、1 つのエリアが不安定な状態になっても、他のエリアに影響が及ばないようにすることをお勧めします。

ispdial3.jpg

何台の NAS サーバを 1 つのエリアに入れるかは、各 NAS サーバから入ってくるルートの数に応じて決めます。 各 NAS サーバから入ってくるルートの数が 3000 以上の場合には、1 つのエリアに 3 台の NAS サーバで十分と推測されます。 エリアの数が多くなりすぎると、各エリアの集約を作成するために ABR が過負荷になる可能性があるので、各エリアに設定する NAS サーバの数が少なくなりすぎないようにしてください。 ただし、すべてのエリアを、エリアに入ってくる集約ルートの再配布をいっさい許可しない全体としてスタブな NSSA にすれば、この問題を解決できます。 このように設定すれば、各 NAS が自分の 1000 以上のルートに追加して転送する情報量が減少し、各エリアに集約 LSA を再配布するための ABR の転送負荷が減少します。 この設定を実行するには、ABR の設定に no-summary というキーワードを、次のように追加します。

ABR#(config)# router ospf 1
ABR#(config-router)# network 10.10.10.0 0.0.0.255 area 1 nssa no-summary
ABR#(config-router)# end

ABR と NAS サーバの間のリンクは、各エリアの外に知らせる必要はないので、これらの接続済みのルートに対しては、各エリア内の集約を ABR で作成する必要はありません。 NSSA の主な利点は、NSSA は外部 LSA を転送しないので、1 つのエリア内の 3000 以上のすべてのルートが他のエリアにリークしないことです。 ABR がすべての NSSA LSA タイプ 7 をエリア 0 に変換するときにも、NSSA の特性に従って、ABR は LSA タイプ 5 を他のエリアには送信しません。

結論

ISP のダイヤル ネットワークの設計は、困難な課題となる場合がありますが、いくつかの点を考慮すれば、改良を加えてよりスケーラブルなソリューションを実現できます。 NSSA を使用すれば、NAS ごとに転送が必要なルートの数を、NSSA を使用しない場合と比べて大幅に減らすことができるので、スケーラビリティを管理する上で効果的です。 また、NAS サーバでは、redistribute connected 設定コマンドを実行する必要があるので、特に IP アドレスの中央プールを使用する場合には、集約を利用してルーティング テーブルのサイズを小さくするのも効果的です。 各 NAS で連続した IP アドレス ブロックを割り当てれば、各 POP を 1 つの大きなブロックに集約し、過剰な数のルートをコアが転送する必要がないようにして、集約作業を効率化することもできます。


関連するシスコ サポート コミュニティ ディスカッション

シスコ サポート コミュニティは、どなたでも投稿や回答ができる情報交換スペースです。


関連情報


Document ID: 44944