IP : IP ルーティング

Enhanced IGRP

2005 年 4 月 19 日 - ライター翻訳版
その他のバージョン: PDFpdf | 機械翻訳版 (2013 年 8 月 21 日) | 英語版 (2005 年 9 月 9 日) | フィードバック

目次

概要
EIGRP の動作理論
      プロトコルの主要リビジョン
      基本的な理論
      隣接ルータ検出とメンテナンス
      トポロジ テーブルの作成
      EIGRP メトリック
      到達可能距離、報告距離、およびフィージブル サクセサ
      パスにループがないことを確認
スプリット ホライズンとポイズン リバース
      起動モード
      トポロジ テーブルの変更
      クエリー
Stuck In Active ルート
      SIA ルートのトラブルシューティング
再配布
      2 つの EIGRP Autonomous System(AS; 自律システム)間での再配布
      2 つの異なる AS にある EIGRP と IGRP 間での再配布
      同じ AS にある EIGRP と IGRP 間での再配布
      その他のプロトコルとの間での再配布
      インターフェイスへのスタティック ルートの再配布
集約
      自動集約
      手動集約
      外部ルートの自動集約
クエリーの処理と範囲
      集約ポイントがクエリー範囲に与える影響
      AS の境界がクエリー範囲に与える影響
      配布リストがクエリー範囲に与える影響
パケットのペーシング
デフォルト ルーティング
ロード バランシング
メトリックの使用
再配布における管理タグの使用
EIGRP コマンド出力について
      show ip eigrp topology
      show ip eigrp topology <network>
      show ip eigrp topology [active | pending | zero-successors]
      show ip eigrp topology all-links
関連するシスコ サポート コミュニティ ディスカッション
関連情報

概要

Enhanced IGRP(EIGRP)は、さまざまなトポロジやメディアに適した Interior Gateway Protocol(IGP; 内部ゲートウェイ プロトコル)です。 高度に設計されたネットワークでは、EIGRP が適切にスケーリングされて、きわめて高速なコンバージェンス タイムが最低限のネットワーク トラフィックで提供されます。

EIGRP の動作理論

数ある EIGRP の利点のいくつかを次に示します。

  • 通常の動作中はネットワーク リソースの使用量はきわめて少なく、安定したネットワークでは HELLO パケットだけが送信される。

  • 変更が行われると、ルーティング テーブル全体ではなくルーティング テーブルの変更だけが伝播され、これによりネットワーク上のルーティング テーブルそのものの負荷が減少する。

  • ネットワーク トポロジの変更に対するコンバージェンス タイムが迅速である(コンバージェンスはほとんど一瞬の場合もある)。

EIGRP は高度な距離ベクトル型プロトコルであり、Diffused Update Algorithm(DUAL)を使用してネットワーク内の送信先への最短パスが計算されます。

プロトコルの主要リビジョン

EIGRP には、バージョン 0 とバージョン 1 の 2 つの主要リビジョンがあります。Cisco IOS の 10.3(11)、11.0(8)、および 11.1(3) より前のバージョンでは EIGRP のバージョン 0 が実行されます。この文書の一部の記述は、この初期バージョンには適用されない場合があります。 EIGRP のバージョン 1 では、パフォーマンスや安定性の改良点が多数含まれるため、シスコではこちらを使用することを強くお勧めします。

基本的な理論

通常の距離ベクトル型プロトコルでは、送信先への最適なパスを計算する際に、距離(ホップ カウントなどのメトリックまたは距離の合計)とベクトル(ネクストホップ)の情報が保存されます。 たとえば、図 1 のネットワーク内のすべてのルータは Routing Information Protocol(RIP; ルーティング情報プロトコル)を実行しています。 ルータ 2 は、それぞれの空いているパスでホップ カウントを調べて、ネットワーク A へのパスを選択します。

eigrp1.gif

ルータ 3 を通るパスのホップは 3 であり、ルータ 1 を通るパスのホップは 2 であるため、ルータ 2 は ルータ 1 を通るパスを選択し、ルータ 3 で学習した情報を破棄します。 ルータ 1 とネットワーク A の間のパスが停止すると、ルーティング テーブルのルートがタイムアウトするまで(3 アップデート期間、または 90 秒)ルータ 2 ではこの宛先とのすべての接続が不通になり、ルータ 3 はルートを再度アドバタイズします(RIP では 30 秒ごとに発生)。 ルータ 2 がパスをルータ 1 からルータ 3 へ切り換えるのに、90 秒から 120 秒間かかります。これにはホールドダウン時間は含まれません。

EIGRP は、定期アップデートを使用して再コンバージする代わりに、隣接ルータの各アドバタイズメントからトポロジ テーブルを作成して(データを破棄するのではなく)、トポロジ テーブル内でループがないと思われるルートを探すか、他にルートがないことがわかっている場合は隣接ルータにクエリーして、コンバージを行います。 ルータ 2 は、ルータ 1 とルータ 3 から受信した情報を保管します。 ルータ 1 を通るパスを最適なパス(サクセサ)として選択し、ルータ 3 を通るパスをループのないパス(フィージブル サクセサ)として選択します。 ルータ 1 を通るパスが使用できなくなった場合、ルータ 2 はトポロジ テーブルを調べて、フィージブル サクセサを見つけると、すぐにルータ 3 を通るパスを使用します。

この簡単な説明からわかるとおり、EIGRP では次の機能が提供されます。

  • 任意時に必要なアップデートだけが送信されるシステム。これは隣接ルータの検出とメンテナンスにより実現されます。

  • ルータが学習したパスからループのないパスを調べる方法。

  • ネットワーク上にあるすべてのルータのトポロジ テーブルから問題のあるルートを削除するプロセス。

  • 隣接ルータに、不通になった送信先へのパスを探すようにクエリーするプロセス。

次に、これらの各要件を順に説明します。

隣接ルータ検出とメンテナンス

ルーティング情報をネットワーク全体に配布するために、EIGRP では非定期的な差分ルーティング更新が使用されます。 つまり、EIGRP ではこれらのパスが変更されたとき、変更されたパスに関するルーティング更新だけが送信されます。

ルーティング更新だけを送信する場合の根本的な問題は、隣接ルータを通じたパスが使用できなくなったときに、それが分からない場合があることです。 新しいルーティング テーブルが隣接ルータから送信されることを期待して、ルートをタイムアウトすることはできません。 EIGRP では隣接関係を利用して、ルーティング テーブルの変更がネットワーク全体に伝播されます。2 台のルータは、互いに相手の HELLO パケットを共通のネットワークで識別すると隣接ルータとなります。

EIGRP では、HELLO パケットが高帯域幅リンクでは 5 秒ごと、低帯域幅マルチポイント リンクでは 60 秒ごとに送信されます。

  • 5 秒ごとの HELLO:

    • ブロードキャスト メディア(イーサネット、トークン リング、FDDI など)

    • ポイントツーポイント シリアル リンク(PPP や HDLC の専用回線、フレーム リレー ポイントツーポイント サブインターフェイス、および ATM ポイントツーポイント サブインターフェイス)

    • 高帯域幅(T1 以上)マルチポイント回線(ISDN PRI およびフレームリレー)

  • 60 秒ごとの HELLO:

    • マルチポイント回線 T1 帯域幅またはそれ以下(フレーム リレー マルチポイント インターフェイス、ATM マルチポイント インターフェイス、ATM 相手先選択接続、および ISDN BRI)

EIGRP が HELLO パケットを送信する割合は HELLO インターバルと呼ばれ、インターフェイスごとに ip hello-interval eigrp コマンドで調整できます。 待機時間は、ルータが HELLO パケットを受信しなくても隣接ルータが稼動していると見なす時間の長さです。 待機時間は通常は HELLO インターバルの 3 倍で、デフォルトでは 15 秒と 180 秒です。 待機時間は ip hold-time eigrp コマンドで調節できます。

HELLO インターバルを変更しても、この変更に合わせて待機時間は自動的に調節されないので注意してください。設定された HELLO インターバルを反映するために待機時間を手作業で調整する必要があります。

2 台のルータは、HELLO タイマーとホールド タイマーが一致しなくても EIGRP 隣接ルータになることができます。 HELLO パケットには待機時間が含まれているので、各隣接ルータは HELLO インターバル タイマーとホールド タイマーが一致しなくても稼動状態に置かれます。

ルータ上の HELLO インターバルの値を直接調べることはできませんが、隣接ルータでの show ip eigrp neighbor の出力結果から推測できます。

ご使用のシスコ デバイスからの show ip eigrp neighbor コマンドの出力データがあれば、アウトプットインタープリタ登録ユーザのみ)を使用して、今後予想される障害や修正を表示できます。 アウトプットインタープリタを使用するには、ユーザとしてログインしている必要があります。

一部ツールについては、ゲスト登録のお客様にはアクセスできない場合がありますことを、ご了承ください。

router# show ip eigrp neighbor
 IP-EIGRP neighbors for process 1
 H   Address       Interface   Hold Uptime   SRTT   RTO  Q  Seq  Type
                                         (sec)         (ms)       Cnt Num
 1   10.1.1.2      Et1           13 12:00:53   12   300  0  620
 0   10.1.2.2      S0           174 12:00:56   17   200  0  645
 rp-2514aa# show ip eigrp neighbor
 IP-EIGRP neighbors for process 1
 H   Address        Interface   Hold Uptime   SRTT   RTO  Q  Seq  Type
                                         (sec)         (ms)       Cnt Num
 1   10.1.1.2       Et1           12 12:00:55   12   300  0  620
 0   10.1.2.2       S0           173 12:00:57   17   200  0  645
 rp-2514aa# show ip eigrp neighbor
 IP-EIGRP neighbors for process 1
 H   Address        Interface   Hold Uptime   SRTT   RTO  Q  Seq  Type
                                         (sec)         (ms)       Cnt Num
 1   10.1.1.2       Et1           11 12:00:56   12   300  0  620
 0   10.1.2.2       S0           172 12:00:58   17   200  0  645
 

コマンド出力の Hold カラムの値は待機時間を超えることはなく、待機時間から HELLO インターバルを引いた値より小さくなることもありません(当然、HELLO パケットがない場合を除きます)。 Hold カラムの範囲が通常 10 〜 15 秒の間であれば、HELLO インターバルは 5 秒で待機時間は 15 秒です。 Hold カラムの範囲が通常 120 〜 180 秒のように大きい場合、HELLO インターバルは 60 秒で待機時間は 180 秒です。 数値がデフォルト タイマー設定値のどれにも合わない場合、隣接ルータの問題のインターフェイスを調べます。HELLO タイマーとホールド タイマーが手動で設定されている場合があります。

注: 

  • EIGRP では、二次アドレスでピア関係が構築されることはありません。 すべての EIGRP トラフィックは、インターフェイスの一次アドレスを送信元としています。

  • マルチアクセス フレームリレー ネットワーク(ポイントツーマルチポイントなど)に EIGRP を設定する場合は、frame-relay map 文にキーワード broadcast を設定します。 キーワード broadcast がなければ、2 つの EIGRP ルータ間に隣接関係を確立できません。 詳細は、『フレームリレーの設定とトラブルシューティング』を参照してください。

  • EIGRP がサポートできる隣接ルータの数には制限がありません。 実際にサポートされる隣接ルータの数は、次のようなデバイスの機能に依存しています。

    • メモリ容量

    • 処理能力

    • 送信されるルートの数など、交換情報の量

    • トポロジの複雑性

    • ネットワークの安定性

トポロジ テーブルの作成

これらのルータが互いに通信状態になったとき、ルータ同士で何が交信されているのでしょうか。 いうまでもなく、各ルータのトポロジ テーブルです。 EIGRP は、RIP や IGRP とは異なり、ルータのルーティング(または転送)テーブルを使用して動作に必要なすべての情報を保持しません。 その代わりに、第 2 の表として、トポロジ テーブルを作成し、そこからルートをルーティング テーブルに挿入します。

注:Cisco IOS バージョン 12.0T および 12.1 では、RIP は専用のデータベースを保持しており、そこからルーティング テーブルにルートを挿入します。

EIGRP を実行しているルータのトポロジ テーブルの基本形式を表示するには、show ip eigrp topology コマンドを実行します。 トポロジ テーブルには、到達可能な各ネットワークへの距離とベクトルの組み合せを構築するのに必要な情報が記載されます。テーブルには次の情報があります。

  • 上流隣接ルータによってレポートされたこの送信先へのパスの最低帯域幅

  • 遅延合計

  • パスの信頼性

  • パスの負荷

  • パスの最小の Maximum Transmission Unit(MTU; 最大伝送ユニット)

  • 到達可能距離

  • 報告距離

  • ルートの送信元(外部ルートはマークされます)

到達可能距離および報告距離」は、このセクションで後ほど説明します。

ご使用のシスコ デバイスからの show ip eigrp topology コマンドの出力データがあれば、アウトプットインタープリタ登録ユーザのみ)を使用して、今後予想される障害や修正を表示できます。 アウトプットインタープリタを使用するには、ユーザとしてログインしている必要があります。

一部ツールについては、ゲスト登録のお客様にはアクセスできない場合がありますことを、ご了承ください。

EIGRP メトリック

EIGRP では、送信先ネットワークへのパスの最小帯域幅と合計遅延を使用して、ルーティング メトリックが計算されます。 別のメトリックも設定できますが、ネットワーク内にルーティング ループが発生する場合があるため、シスコではこれを推奨していません。 帯域幅と遅延のメトリックは、送信先ネットワークへのパス上のルータのインターフェイスに設定された値によって求められます。

たとえば次に示す図 2 では、ルータ 1 はネットワーク A への最適なパスを計算しています。

eigrp2.gif

このネットワークでは 2 つのアドバタイズメントで開始されます。1 つは、ルータ 4 を通り最小帯域幅 56 および合計遅延 2200 のアドバタイズメント、もう 1 つはルータ 3 を通り最小帯域幅が 128 で遅延は 1200 のアドバタイズメントです。 ルータ 1 では、メトリックが最も低いパスが選択されます。

メトリックの計算を始めましょう。 EIGRP では、帯域幅と遅延のメトリックをスケーリングすることにより、複合メトリックが計算されます。 EIGRP では、帯域幅のスケーリングに、次の数式が使用されます。

  • 帯域幅 =(10000000/帯域幅(i))* 256

    ここで、帯域幅(i)は、宛先ネットワークへのルート上のすべての発信インターフェイスの最小帯域幅で、キロビットで表されます。

EIGRP では、遅延のスケーリングに、次の数式が使用されます。

  • 遅延 = 遅延(i) * 256

    ここで、遅延(i)は、宛先ネットワークへのルート上のインターフェイスで設定されている遅延の合計で、10 マイクロ秒によって表されます。 show ip eigrp topologyshow interface コマンドで表示される遅延はマイクロ秒単位であるため、10 で割ってからこの数式で使用する必要があります。 この文書の中では、インターフェイスに設定され表示されている遅延を使用します。

EIGRP では、これらのスケーリングされた値を使用して、ネットワークへの複合メトリックが求められます。

  • メトリック = [K1 * 帯域幅 +(K2 * 帯域幅)/(256 ? 負荷)+ K3 * 遅延] * [K5 /(信頼性 + K4)]

注:これらの K の値は、慎重に計画して使用する必要があります。 K の値のミスマッチによって、隣接関係を作ることができず、ネットワークがコンバージできない原因になります。

注:K5 = 0 の場合、メトリック = [K1 * 帯域幅 +(K2 * 帯域幅)/(256 - 負荷)+ K3 * 遅延] となります。

K のデフォルト値は、次のとおりです。

  • K1 = 1

  • K2 = 0

  • K3 = 1

  • K4 = 0

  • K5 = 0

デフォルトの動作の場合、数式を次のように簡単にできます。

metric = bandwidth + delay 

シスコのルータは浮動小数点計算をしないため、計算の各段階でメトリックを正しく計算するには、小数点以下を切り捨てる必要があります。 この例では、ルータ 4 を通る合計コストは、次のとおりです。

この例では、ルータ 4 を通る合計コストは、次のとおりです。

minimum bandwidth = 56k
 total delay = 100 + 100 + 2000 = 2200
 [(10000000/56) + 2200] x 256 = (178571 + 2200) x 256 = 180771 x 256 = 46277376
 

さらに、ルータ 3 を通る合計コストは次のとおりです。

minimum bandwidth = 128k
 total delay = 100 + 100 + 1000 = 1200
 [(10000000/128) + 1200] x 256 = (78125 + 1200) x 256 = 79325 x 256 = 20307200
 

したがってネットワーク A に到達するために、ルータ 1 はルータ 3 を通るルートを選択します。

ここで使用した帯域幅と遅延の値は、ルータが宛先ネットワークへのネクストホップへ到達するために通るインターフェイスに設定した値であることに注意してください。 たとえば、ルータ 2 はイーサネット インターフェイスで設定された遅延によって、ネットワーク A のアドバタイズを行い、ルータ 4 は自分のイーサネットで設定された遅延を追加し、ルータ 1 は自分のシリアルで設定された遅延を追加しました。

到達可能距離、報告距離、およびフィージブル サクセサ

到達可能距離は送信先ネットワークへのパスの最適なメトリックであり、このパスをアドバタイズしている隣接ルータのメトリックが含まれます。 報告距離は、上流隣接ルータによってアドバタイズされる送信先ネットワークへのパスの複合メトリックです。 フィージブル サクセサとは、報告距離が到達可能距離より小さなパスです(現在の最適パス)。 図 3 では、このプロセスを説明します。

eigrp3.gif

ルータ 1 は、ネットワーク A へのルートが 2 つあることを認識しています。1 つはルータ 3 を通り、もう 1 つはルータ 4 を通ります。

  • ルータ 4 を通るルートのコストは 46277376 で、報告距離は 307200 です。

  • ルータ 3 を通るルートのコストは 20307200 で、報告距離は 307200 です。

それぞれのケースで EIGRP は、ネットワークへのルートをアドバタイズしているルータからの報告距離を計算することに注意してください。 つまり、ルータ 4 からの報告距離はルータ 4 からネットワーク A へ到達するメトリックで、ルータ 3 からの報告距離はルータ 3 からネットワーク A に到達するメトリックになります。 EIGRP はルータ 3 を通るルートを最適なパスに選択し、ルータ 3 を通るメトリックを到達可能距離として使用します。 このネットワークへのルータ 4 を通る報告距離は到達可能距離より小さいため、ルータ 1 はルータ 4 を通るパスをフィージブル サクセサと見なします。

ルータ 1 とルータ 3 の間のリンクが停止すると、ルータ 1 は把握しているネットワーク A への各パスを調べてルータ 4 にフィージブル サクセサがあることを見つけます。 ルータ 1 はこのルートを使用し、ルータ 4 を通るメトリックを新しい到達可能距離として使用します。 ネットワークはただちにコンバージして、下流隣接ルータのアップデートがルーティング プロトコルからの唯一のトラフィックになります。

図 4 では、もう少し複雑なシナリオを見て行きましょう。

eigrp4.gif

ルータ 1 からネットワーク A まではルートが 2 つあり、1 つはルータ 2 を通りメトリックが 46789376 で、もう 1 つはルータ 4 を通りメトリックは 20307200 です。 ルータ 1 では、この 2 つのメトリックの低い方がネットワーク A へのルートに選択され、このメトリックが到達可能距離になります。 次に、ルータ 2 を通るパスを検討して、フィージブル サクセサとなり得るかどうかを調べましょう。 ルータ 2 からの報告距離は 46277376 でこれは到達可能距離の値より高いため、このパスはフィージブル サクセサではありません。 この時点でルータ 1 のトポロジ テーブルを見ると(show ip eigrp topology を使用)、ルータ 4 を通るネットワーク A のエントリが 1 つだけ表示されているのが分かります。 (実際には、ルータ 1 ではトポロジ テーブルの中に 2 つのエントリがありますが、1 つだけがフィージブル サクセサになるため、もう一方は show ip eigrp topology では表示されません。フィージブル サクセサではないルートは show ip eigrp topology all-links を使用すると表示できます)。

ここで、ルータ 1 とルータ 4 の間のリンクが停止すると想定しましょう。 ルータ 1 はネットワーク A への唯一のルートが不通になったことを認識し、各隣接ルータ(この場合はルータ 2 だけ)にクエリーを送り、ネットワーク A へのルートがあるかどうかを調べます。ルータ 2 にはネットワーク A へのルートがあるため、このクエリーに応答します。 ルータ 1 はルータ 4 を通る適切なルートがないため、ルータ 2 を通るネットワーク A へのこのルートを受け入れます。

パスにループがないことを確認

EIGRP は到達可能距離、報告距離、フィージブル サクセサの概念をどう使用して、パスが有効か、ループがないかを判断するのでしょうか。 図 4a では、ルータ 3 はネットワーク A へのルートを調べます。スプリット ホライズンが無効になっているため(たとえば、マルチポイント フレーム リレー インターフェイスがあるような場合)、ルータ 3 はネットワーク A へのルートとして、ルータ 4 を通るパス、ルータ 2 を通るパス(パスは 2、1、3、4)、およびルータ 1 を通るパス(パスは 1、2、3、4)の 3 つを表示します。

eigrp21.gif

ルータ 3 がこれらすべてのルートを受け入れると、ルーティング ループが発生します。 ルータ 3 はルータ 2 経由でネットワーク A へ到達できると考えますが、ルータ 2 を経由するパスはネットワーク A に到達するのにルータ 3 を経由します。ルータ 4 とルータ 3 の間の接続がダウンすると、ルータ 3 は他のパスのいずれかを通ってネットワーク A に到達できる考えます。しかし、フィージブル サクセサを決定するルールがあるため、これらのパスが代替として使用されることはありません。 メトリックで、その理由を調べましょう。

  • ルータ 4 を経由するネットワーク A への複合メトリック:20281600

  • ルータ 2 を経由するネットワーク A への複合メトリック:47019776

  • ルータ 1 を経由するネットワーク A への複合メトリック:47019776

ルータ 4 を通るパスが最適なメトリックなので、ルータ 3 はこのルートを転送テーブルに設定し、20281600 をネットワーク A への到達可能距離として使用します。次に、ルータ 3 では、ルータ 2 およびルータ 1 経由でネットワーク A に到達する報告距離として、ルータ 2 経由のパスの 47019776 と、ルータ 1 経由のパスの 47019776 を算出します。 これらのメトリックはどちらも到達可能距離より大きいため、ルータ 3 では、どちらのルートもネットワーク A のフィージブル サクセサとしては設定されません。

ルータ 3 とルータ 4 の間のリンクが停止していると仮定します。 ルータ 3 は各隣接ルータにネットワーク A への代替ルートをクエリーします。ルータ 2 はクエリーを受信し、このクエリーがサクセサから送信されているため、トポロジ テーブル内の他の各エントリを検索してフィージブル サクセサがあるかどうかを確認します。 トポロジ テーブル内にある他の唯一のエントリはルータ 1 からのもので、報告距離はルータ 3 を通る最後の既知の最適メトリックと等しくなります。 ルータ 1 を通る報告距離は最後の既知の到達可能距離より小さくないため、ルータ 2 はこのルートを到達不能にマークして各隣接ルータ(この場合はルータ 1 だけ)にネットワーク A へのパスをクエリーします。

ルータ 3 はネットワーク A のクエリーをルータ 1 にも送信します。 ルータ 1 は自分のトポロジ テーブルを調べて、ネットワーク A への他の唯一のパスが、ルータ 2 を通るものであり、その報告距離がルータ 3 を通る最後の既知の到達可能距離と等しいことが分かります。 もう一度繰り返しますが、ルータ 2 を通る報告距離は最後の既知の到達可能距離より小さくないため、このルートはフィージブル サクセサにはなりません。 ルータ 1 はこのルートを到達不能にマークして、他の唯一の隣接ルータであるルータ 2 にネットワーク A へのパスをクエリーします。

これは第一段階のクエリーです。 ルータ 3 はネットワーク A へのルートを見つけるために、各隣接ルータにクエリーしています。次に、ルータ 1 とルータ 2 では、そのルートを到達不能にマークして、ネットワーク A へのパスを見つけるために、残りの各隣接ルータにクエリーしています。ルータ 2 はルータ 1 のクエリーを受信すると、自身のトポロジ テーブルを調べて宛先が到達不能にマークされていることを確認します。 ルータ 2 はルータ 1 にネットワーク A は到達不能であると応答します。 ルータ 1 もまた、ルータ 2 のクエリーを受信すると、ネットワーク A が到達不能であると応答します。 これでルータ 1 と 2 は両方ともネットワーク A は到達不能であると判断し、元のルータ 3 のクエリーに応答します。 ネットワークはコンバージして、すべてのルートはパッシブ状態に戻ります。

スプリット ホライズンとポイズン リバース

前の例では、スプリット ホライズンが有効でない場合を想定し、ルートがループしているかどうかを判断するために EIGRP で到達可能距離と報告距離がどのように使用されるのかを示しました。 しかし、状況によっては、EIGRP では、スプリット ホライズンを使用することで同様にルーティング ループが回避されます。 EIGRP におけるスプリット ホライズンの使用方法について詳しく説明する前に、スプリット ホライズンとは何か、どのように動作するのかを見てみます。 スプリット ホライズンの規則は次のとおりです。

  • ルートを学習したインターフェイスから同じルートをアドバタイズしない。

たとえば、図 4a でルータ 1 が単一のマルチポイント インターフェイス(フレームリレーなど)を通じてルータ 2 とルータ 3 に接続しているとします。ここでルータ 1 がネットワーク A についてルータ 2 から学習した場合、ルータ 1 はネットワーク A へのルートを同じインターフェイスからルータ 3 にアドバタイズすることはありません。 ルータ 1 は、ルータ 3 がネットワーク A についてルータ 2 から直接学習すると想定します。

eigrp21.gif

ポイズン リバースはルーティング ループを回避するもう 1 つの方法です。 ポイズン リバースの規則は次のとおりです。

  • インターフェイスを通じてルートを学習したら、同じインターフェイスから、そのルートを到達不能としてアドバタイズする。

図 4a の各ルータではポイズン リバースが有効にされているとします。 ルータ 1 はネットワーク A についてルータ 2 から学習すると、ルータ 2 およびルータ 3 へのリンクを通じてネットワーク A を到達不能としてアドバタイズします。 ルータ 3 がルータ 1 を経由したネットワーク A へのパスを保持している場合、ルータ 3 は到達不能アドバタイズメントを受信したことでそのパスを削除します。 EIGRP では、これら 2 つの規則を組み合せることによりルーティング ループが回避されます。

EIGRP では、次のような場面ではスプリット ホライズンが使用されるか、あるいはルートが到達不能としてアドバタイズされます。

  • 2 台のルータが起動モードにある(トポロジ テーブルを初めて交換する)。

  • トポロジ テーブルの変更をアドバタイズする。

  • クエリーを送信する。

それぞれの状況について検討して行きます。

起動モード

2 台のルータが初めて隣接ルータとなる場合、両ルータは起動モード中にトポロジ テーブルを交換します。 ルータは起動モード中に受信したテーブル エントリごとに、同じエントリを最大メトリックで新しい隣接ルータにアドバタイズし戻します(ポイズン ルート)。

トポロジ テーブルの変更

図 5 で、ルータ 1 は 2 つのシリアル リンク(ルータ 2 とルータ 4 を接続する 56k リンクと、ルータ 3 とルータ 4 を接続する 128k リンク)の間でネットワーク A 宛てのトラフィックのバランスをとるためにバリアンスを使用します(バリアンスに関する説明については「ロード バランシング」のセクションを参照)。

eigrp5.gif

ルータ 2 はルータ 3 を経由するパスを、実行可能なサクセサと見なしています。 ルータ 2 とルータ 4 の間のリンクがダウンした場合、ルータ 2 は単にルータ 3 を経由するパス上で再コンバージします。 スプリット ホライズン規則により、ルートを学習したインターフェイスから同じルートがアドバタイズされないため、通常、ルータ 2 はアップデートを送信しません。 ただし、それではルータ 1 のトポロジ テーブルに無効なエントリが残ります。 ルータのトポロジ テーブル内で、ルータがあるネットワークに到達する際に経由するインターフェイスが変わった場合、スプリット ホライズンはオフになり、古いルートがすべてのインターフェイスからポイズン リバースされます。 このケースでは、ルータ 2 はこのルートのスプリット ホライズンをオフにし、ネットワーク A を到達不能としてアドバタイズします。 ルータ 1 はこのアドバタイズメントを受信し、ルータ 2 を経由してネットワーク A に至るルートをルーティング テーブルからフラッシュします。

クエリー

クエリーによってスプリット ホライズンが発生するのは、クエリー内で宛先へのサクセサとして使用しているルータからクエリーまたはアップデートを受信した場合だけです。 図 6 のネットワークを参照してください。

eigrp6.gif

ルータ 3 はルータ 4 から 10.1.2.0/24(ルータ 3 はルータ 1 を経由してこのネットワークに到達する)に関するクエリーを受信します。 リンクのフラップやネットワークの一時的な状況により、ルータ 3 にこの宛先へのサクセサがない場合、ルータ 3 は各隣接ルータ(このケースではルータ 1、2、および 4)にクエリーを送信します。 ただし、ルータ 3 がルータ 1 から宛先 10.1.2.0/24 に関するクエリーまたはアップデート(メトリックの変更など)を受信した場合は、ルータ 3 はルータ 1 にクエリーを送り返しません。これは、ルータ 3 にとって、ルータ 1 がこのネットワークへのサクセサであるためです。 その結果、ルータ 3 はルータ 2 とルータ 4 にだけクエリーを送信します。

Stuck In Active ルート

状況によっては、クエリーの応答に非常に時間がかかる場合があります。 実際に長時間応答がなければ、クエリーを発行したルータは応答の回収を中止し、応答が得られなかったルータとの接続を解除して、その隣接ルータとのセッションを再起動します。 これを Stuck In Active(SIA)ルートと呼びます。 最も基本的な SIA ルートは、クエリーがネットワークの反対側に到達して応答が戻ってくるまでに単に時間がかかりすぎる場合に発生します。 たとえば、図 7 でルータ 1 はルータ 2 から数多くの SIA ルートを記録しているとします。

eigrp7.gif

調査の結果、問題はルータ 2 とルータ 3 を接続する衛星リンク上の遅延にあることがわかりました。 この種の問題には 2 通りの解決策があります。 1 つは、ルータがクエリーを送信してから SIA ルートを宣言するまでの時間を長くすることです。 この設定を変更するには、timers active-time コマンドを使用します。

しかし、さらに優れた解決策として、クエリーの範囲が狭くなる(つまり、ごく小数のクエリーしか衛星リンクを通過しない)ようにネットワークを再設計するという方法があります。 クエリーの範囲については、「クエリーの処理と範囲」のセクションで説明します。 ただし、クエリー範囲自体は、SIA ルートが報告される一般的な原因ではありません。 よく見られるのは、ネットワーク上の一部のルータが次のいずれかの原因でクエリーに応答できない場合です。

  • ルータが過度のビジー状態にあり、クエリーに応答できない(CPU 高使用率が発生しているケースが多い)。

  • ルータのメモリに問題があり、クエリーの処理または応答パケットの組み立てにメモリを割り当てることができない。

  • 2 台のルータ間の回線が良好な状態にない。隣接ルータとの関係を維持できるだけのパケットは流れていても、一部のクエリーや応答がルータ間で失われている。

  • 単方向リンク(障害のためにトラフィックが一方向にしか流れないリンク)。

SIA ルートのトラブルシューティング

SIA ルートのトラブルシューティングには一般に 3 つのステップがあります。

  1. 常に SIA として報告されるルートを特定する。

  2. これらのルートに関するクエリーにまったく応答していないルータを特定する。

  3. そのルータがクエリーを受信できない、またはクエリーに応答できない原因を特定する。

最初のステップは非常に簡単です。 コンソール メッセージをログに記録していれば、ログにざっと目を通すだけで、頻繁に SIA としてマークされているルートがわかります。 2 番目のステップは 1 番目のステップほど簡単ではありません。 この情報を収集するコマンドは show ip eigrp topology active です。

Codes: P - Passive, A - Active, U - Update, Q - Query, R - Reply,
        r - Reply status
 A 10.2.4.0/24, 0 successors, FD is 512640000, Q
     1 replies, active 00:00:01, query-origin: Local origin
          via 10.1.2.2 (Infinity/Infinity), Serial1
     1 replies, active 00:00:01, query-origin: Local origin
          via 10.1.3.2 (Infinity/Infinity), r, Serial3
     Remaining replies:
          via 10.1.1.2, r, Serial0

まだ応答していない隣接ルータは R で示されます(アクティブ タイマーによって、そのルートがどれくらいの時間アクティブであるかがわかります)。 これらの隣接ルータには Remaining replies セクションが表示されない場合があります。このセクションは他の RDB の中に表示される可能性があります。 未受信の応答があるルートで、ある一定の時間(通常は 2 〜 3 分)アクティブであるルートには特に注意してください。 このコマンドを複数回実行すれば、どの隣接ルータがクエリーに応答していないか(または、どのインターフェイスに未応答のクエリーが多いか)がわかります。 この隣接ルータを調べて、そのルータが自身の隣接ルータのいずれかからの応答を待ち続けているのかどうかを確認します。 このプロセスを繰り返して、クエリーにまったく応答していないルータを特定します。 ルータが特定されたら、その隣接ルータへのリンクや、メモリまたは CPU の使用率などに問題がないかを調べます。

クエリー範囲が問題であるように思われる場合は、SIA タイマーを増やすのではなく、クエリー範囲を狭くするのが常に最良の方法です。

再配布

このセクションでは、再配布に関するいくつかの異なるシナリオを検討します。 ただし、以下に示すのは、再配布の設定に必要とされる最低限の例であることに注意してください。 再配布によって、最適ではないルーティング、ルーティング ループ、コンバージェンス遅延などの問題が発生する可能性があります。 これらの問題を回避するには、「ルーティング プロトコルの再配送」の「再配送を原因とする問題の回避」を参照してください。

2 つの EIGRP Autonomous System(AS; 自律システム)間での再配布

図 8 では、ルータは次のように設定されます。

eigrp8.gif

ルータ 1

router eigrp 2000
 
 !---「2000」は AS です。 
 
  network 172.16.1.0 0.0.0.255
 

ルータ 2

router eigrp 2000
  redistribute eigrp 1000 route-map to-eigrp2000
  network 172.16.1.0 0.0.0.255
 !
 router eigrp 1000
  redistribute eigrp 2000 route-map to-eigrp1000
  network 10.1.0.0 0.0.255.255
 route-map to-eigrp1000 deny 10
 match tag 1000
 !
 route-map to-eigrp1000 permit 20
 set tag 2000
 !
 route-map to-eigrp2000 deny 10
 match tag 2000
 !
 route-map to-eigrp2000 permit 20
 set tag 1000

ルータ 3

router eigrp 1000
  network 10.1.0.0 0.0.255.255

ルータ 3 は AS 1000 を通してネットワーク 10.1.2.0/24 をルータ 2 にアドバタイズします。ルータ 2 はこのルートを AS 2000 に再配布して、ルータ 1 にアドバタイズします。

注:EIGRP 1000 からのルートは、EIGRP 2000 に再配布される前に 1000 とタグ付けされます。EIGRP 2000 からのルートが EIGRP 1000 に再配布される際に、1000 とタグ付けされたルートは拒否されるので、ループ皆無のトポロジが保証されます。 ルーティング プロトコルの再配送の詳細は、『ルーティング プロトコルの再配送』を参照してください。

ルータ 1 には次のように表示されます。

one# show ip eigrp topology 10.1.2.0 255.255.255.0
 IP-EIGRP topology entry for 10.1.2.0/24
   State is Passive, Query origin flag is 1, 1 Successor(s), FD is 46763776
   Routing Descriptor Blocks:
   20.1.1.1 (Serial0), from 20.1.1.1, Send flag is 0x0
       Composite metric is (46763776/46251776), Route is External
       Vector metric:
         Minimum bandwidth is 56 Kbit
         Total delay is 41000 microseconds
         Reliability is 255/255
         Load is 1/255
         Minimum MTU is 1500
         Hop count is 2
       External data:
         Originating router is 10.1.2.1
         AS number of route is 1000
         External protocol is EIGRP, external metric is 46251776
         Administrator tag is 1000 (0x000003E8)

ルータ 1 とルータ 2 間のリンクの帯域幅が 1.544Mb であるにもかかわらず、このトポロジ テーブル エントリに表示される最低帯域幅は 56k であることに注意してください。 このことから、EIGRP が 2 つの EIGRP AS 間で再配布を行う際には、すべてのメトリックを保存していることがわかります。

2 つの異なる AS にある EIGRP と IGRP 間での再配布

図 9 では、設定を次のように変更しています。

eigrp9.gif

ルータ 1

router eigrp 2000
  network 172.16.1.0

ルータ 2

router eigrp 2000
  redistribute igrp 1000 route-map to-eigrp2000
  network 172.16.1.0
 !
 router igrp 1000
  redistribute eigrp 2000 route-map to-igrp1000
  network 10.0.0.0
 !
 route-map to-igrp1000 deny 10
 match tag 1000
 !
 route-map to-igrp1000 permit 20
 set tag 2000
 !
 route-map to-eigrp2000 deny 10
 match tag 2000
 !
 route-map to-eigrp2000 permit 20
 set tag 1000

ルータ 3

router igrp 1000
  network 10.0.0.0

ルータ 1 の設定を次に示します。

one# show ip eigrp topology 10.1.2.0 255.255.255.0 
 IP-EIGRP topology entry for 10.1.2.0/24
   State is Passive, Query origin flag is 1, 1 Successor(s), FD is 46763776
   Routing Descriptor Blocks:
   20.1.1.1 (Serial0), from 20.1.1.1, Send flag is 0x0
       Composite metric is (46763776/46251776), Route is External
       Vector metric:
         Minimum bandwidth is 56 Kbit
         Total delay is 41000 microseconds
         Reliability is 255/255
         Load is 1/255
         Minimum MTU is 1500
         Hop count is 1
       External data:
         Originating router is 10.1.1.1
         AS number of route is 1000
         External protocol is IGRP, external metric is 180671
         Administrator tag is 1000 (0x000003E8)

IGRP メトリックは、ルートが別の AS を持つ EIGRP 内に再配布された場合は保存されますが、IGRP メトリックに定数 256 を掛けることでスケーリングされます。IGRP と EIGRP 間の再配布に関して、注意点が 1 つあります。 再配布を実行しているルータにネットワークが隣接している場合、このネットワークはメトリック 1 でルートをアドバタイズします。

たとえば、ネットワーク 10.1.1.0/24 がルータ 2 に隣接していて、IGRP がこのネットワークにルーティングしているとします(ルータ IGRP の下に、このインターフェイスについて述べたネットワーク ステートメントがあります)。 EIGRP はこのネットワークのルーティングプロトコルではないので、IGRP からの再配布を介して、この隣接したインターフェイスについて学習します。 ルータ 1 では、10.1.1.0/24 のトポロジ テーブル エントリが次のように表示されます。

one# show ip eigrp topology 10.1.1.0 255.255.255.0 
 IP-EIGRP topology entry for 10.1.1.0/24
   State is Passive, Query origin flag is 1, 1 Successor(s), FD is 2169856
   Routing Descriptor Blocks:
   20.1.1.1 (Serial0), from 20.1.1.1, Send flag is 0x0
       Composite metric is (2169856/1), Route is External
       Vector metric:
         Minimum bandwidth is 1544 Kbit
         Total delay is 20000 microseconds
         Reliability is 0/255
         Load is 1/255
         Minimum MTU is 1500
         Hop count is 1
       External data:
         Originating router is 10.1.1.1
         AS number of route is 1000
         External protocol is IGRP, external metric is 0
         Administrator tag is 1000 (0x000003E8)

太字で示される、ルータ 2 からの報告距離が 1 インチ(2.54 cm)であることに注意してください。

同じ AS にある EIGRP と IGRP 間での再配布

図 10 では、ルータ設定には、次の変更が追加されています。

eigrp10.gif

ルータ 1

router eigrp 2000
  network 172.16.1.0 

ルータ 2

router eigrp 2000
  network 172.16.1.0
 !
 router igrp 2000
  network 10.0.0.0

ルータ 3

router igrp 2000
  network 10.0.0.0

ルータ 1 は次のように設定されます。

one# show ip eigrp topology 10.1.2.0 255.255.255.0 
 IP-EIGRP topology entry for 10.1.2.0/24
   State is Passive, Query origin flag is 1, 1 Successor(s), FD is 46763776
   Routing Descriptor Blocks:
   20.1.1.1 (Serial0), from 20.1.1.1, Send flag is 0x0
       Composite metric is (46763776/46251776), Route is External
       Vector metric:
         Minimum bandwidth is 56 Kbit
         Total delay is 41000 microseconds
         Reliability is 255/255
         Load is 1/255
         Minimum MTU is 1500
         Hop count is 1
       External data:
         Originating router is 10.1.1.1
         AS number of route is 2000
         External protocol is IGRP, external metric is 180671
         Administrator tag is 0 (0x00000000)

この設定は、前述した、IGRP と EIGRP を実行する 2 つの異なる AS 間の再配布の出力とよく似ています。 隣接する 10.1.1.0/24 ネットワークは、両シナリオで同じように処理されます。

one# show ip eigrp topology 10.1.1.0 255.255.255.0 
 IP-EIGRP topology entry for 10.1.1.0/24
   State is Passive, Query origin flag is 1, 1 Successor(s), FD is 2169856
   Routing Descriptor Blocks:
   20.1.1.1 (Serial0), from 20.1.1.1, Send flag is 0x0
       Composite metric is (2169856/1), Route is External
       Vector metric:
         Minimum bandwidth is 1544 Kbit
         Total delay is 20000 microseconds
         Reliability is 255/255
         Load is 1/255
         Minimum MTU is 1500
         Hop count is 1
       External data:
         Originating router is 10.1.1.1
         AS number of route is 2000
         External protocol is IGRP, external metric is 0
         Administrator tag is 0 (0x00000000)

そのため、ルータ 1 と隣接するこのネットワークは、IGRP から EIGRP に、1 のメトリックで再配布されます。これは、2 つの異なる AS 間で再配布を行う場合と同じメトリックです。

同じ AS 内での EIGRP/IGRP 再配布に関して、注意点が 2 つあります。

  • 内部 EIGRP ルートは、外部 EIGRP/IGRP ルートよりも常に優先されます。

  • 外部 EIGRP ルートのメトリックは、スケーリングされた IGRP メトリックと比較されます(アドミニストレーティブ ディスタンスは無視されます)。

これらの注意点について、図 11 で検証します。

eigrp11.gif

ルータ 1 は IGRP AS 100 で 10.1.4.0/24 をアドバタイズします。ルータ 4 は EIGRP AS 100 で 10.1.4.0/24 を外部ネットワークとしてアドバタイズします。ルータ 2 は AS 100 で、EIGRP と IGRP を両方とも動作させます。

ルータ 4 によってアドバタイズされる EIGRP ルートを無視した場合(たとえばルータ 2 とルータ 4 間のリンクをシャットダウンするなどして)、ルータ 2 に次のように表示されます。

two# show ip route 10.1.4.0
 Routing entry for 10.1.4.0/24
   Known via "igrp 100", distance 100, metric 12001
   Redistributing via igrp 100, eigrp 100
   Advertised by igrp 100 (self originated)
                 eigrp 100
   Last update from 10.1.1.2 on Serial1, 00:00:42 ago
   Routing Descriptor Blocks:
   * 10.1.1.2, from 10.1.1.2, 00:00:42 ago, via Serial1
       Route metric is 12001, traffic share count is 1
       Total delay is 20010 microseconds, minimum bandwidth is 1000 Kbit
       Reliability 1/255, minimum MTU 1 bytes
       Loading 1/255, Hops 0

アドミニストレーティブ ディスタンスが 100 であることに注意してください。EIGRP ルートを追加すると、ルータ 2 に次のように表示されます。

two# show ip route 10.1.4.0
 Routing entry for 10.1.4.0/24
   Known via "eigrp 100", distance 170, metric 3072256, type external
   Redistributing via igrp 100, eigrp 100
   Last update from 10.1.2.2 on Serial0, 00:53:59 ago
   Routing Descriptor Blocks:
   * 10.1.2.2, from 10.1.2.2, 00:53:59 ago, via Serial0
       Route metric is 3072256, traffic share count is 1
       Total delay is 20010 microseconds, minimum bandwidth is 1000 Kbit
       Reliability 1/255, minimum MTU 1 bytes
       Loading 1/255, Hops 1

これら 2 つのルートのメトリックは、IGRP から EIGRP にスケーリングされた後、同じになります(「メトリックの使用」のセクションを参照してください)。

  • 12001 x 256 = 3072256

上記の式で、12001 はルータ 1 を通る IGRP メトリック、3072256 はルータ 4 を通る EIGRP メトリックです。

ルータ 2 は、(スケーリング後の)同じメトリックの EIGRP 外部ルートと、大きい方のアドミニストレーティブ ディスタンスを優先させます。 同じ AS にある EIGRP と IGRP 間で自動再配布が行われた場合は、常にそうなります。 ルータは常に、最低のコスト メトリックのパスを優先させ、アドミニストレーティブ ディスタンスは無視します。

その他のプロトコルとの間での再配布

EIGRP と、その他のプロトコル(たとえば RIP、OSPF など)との間の再配布は、すべての再配布と同じように行われます。 プロトコル間の再配布には、デフォルトのメトリックを使用するのが常に最適の方法とされます。 EIGRP とその他のプロトコルの間で再配布を行う場合は、次の 2 つの問題に注意する必要があります。

  • EIGRP に再配布されるルートは、常に集約されるわけではありません。「集約」のセクションの説明を参照してください。

  • 外部 EIGRP ルートでは、アドミニストレーティブ ディスタンスは 170 です。

インターフェイスへのスタティック ルートの再配布

スタティック ルートをインターフェイスに設定して、このスタティック ルートを含む router eigrp を使ってネットワーク ステートメントを設定する場合、EIGRP はルートが直接インターフェイスに接続しているかのように、このルートを再配布します。 図 12 のネットワークを見てみましょう。

eigrp12.gif

ルータ 1 には、インターフェイス シリアル 0 を介して設定されたネットワーク 172.16.1.0/24 へのスタティック ルートがあります。

ip route 172.16.1.0 255.255.255.0 Serial0

そしてルータ 1 には、このスタティック ルートの宛先に向けられたネットワーク ステートメントもあります。

router eigrp 2000
  network 10.0.0.0
  network 172.16.0.0
  no auto-summary 

ルータ 1 はスタティック ルートを再配布しないにもかかわらず、このルートは再配布します。これは、EIGRP がこのルートを、隣接したネットワークとみなすためです。 このときルータ 2 の表示は次のようになります。

two# show ip route
     ....
         10.0.0.0/8 is variably subnetted, 2 subnets, 2 masks
     C       10.1.1.0/24 is directly connected, Serial0
     D       10.1.2.0/24 [90/2169856] via 10.1.1.1, 00:00:47, Serial0
          172.16.0.0/24 is subnetted, 1 subnets
     D       172.16.1.0 [90/2169856] via 10.1.1.1, 00:00:47, Serial0

172.16.1.0/24 へのルートは、ルータ 2 では内部 EIGRP ルートとして表示されることに注意してください。

集約

EIGRP には、自動集約と手動集約の、2 つの集約形式があります。

自動集約

EIGRP では、2 つの異なる主要ネットワークの境界を横断するごとに、自動集約が実行されます。 たとえば図 13 では、ルータ 2 は 10.0.0.0/8 ネットワークだけをルータ 1 に アドバタイズします。これは、ルータ 2 がルータ 1 に達するために使用するインターフェイスが、別のメジャー ネットワークの中にあるからです。

eigrp13.gif

ルータ 1 には次のように表示されます。

one# show ip eigrp topology 10.0.0.0
 IP-EIGRP topology entry for 10.0.0.0/8
   State is Passive, Query origin flag is 1, 1 Successor(s), FD is 11023872
   Routing Descriptor Blocks:
   172.16.1.1 (Serial0), from 172.16.1.2, Send flag is 0x0
       Composite metric is (11023872/10511872), Route is Internal
       Vector metric:
         Minimum bandwidth is 256 Kbit
         Total delay is 40000 microseconds
         Reliability is 255/255
         Load is 1/255
         Minimum MTU is 1500
         Hop count is 1

このルートは内部ルートのように見られ、どのような場合も集約ルートとしてはマークされません。 集約ルートの中で、このメトリックは最も優れたメトリックです。 10.0.0.0 ネットワークには、帯域幅が 56k のリンクがありますが、このルートの最小帯域幅は 256k であることに注意してください。

集約を実行しているルータでは、集約アドレスに対して null0 へのルートが作成されます。

two# show ip route 10.0.0.0
 Routing entry for 10.0.0.0/8, 4 known subnets
   Attached (2 connections)
   Variably subnetted with 2 masks
   Redistributing via eigrp 2000
 C       10.1.3.0/24 is directly connected, Serial2
 D       10.1.2.0/24 [90/10537472] via 10.1.1.2, 00:23:24, Serial1
 D       10.0.0.0/8 is a summary, 00:23:20, Null0
 C       10.1.1.0/24 is directly connected, Serial1

10.0.0.0/8 へのルートは、Null0 を介して、集約としてマークされます。 この集約ルートのトポロジ テーブル エントリは次のようになります。

two# show ip eigrp topology 10.0.0.0 
 IP-EIGRP topology entry for 10.0.0.0/8
   State is Passive, Query origin flag is 1, 1 Successor(s), FD is 10511872
   Routing Descriptor Blocks:
   0.0.0.0 (Null0), from 0.0.0.0, Send flag is 0x0
           (note: the 0.0.0.0 here means this route is originated by this router)
       Composite metric is (10511872/0), Route is Internal
       Vector metric:
         Minimum bandwidth is 256 Kbit
         Total delay is 20000 microseconds
         Reliability is 255/255
         Load is 1/255
         Minimum MTU is 1500
         Hop count is 0

ルータ 2 に、集約の代わりに 10.0.0.0 ネットワークのコンポーネントをアドバタイズさせるには、ルータ 2 の EIGRP プロセスに no auto-summary を設定します。

ルータ 2 の表示:

router eigrp 2000
  network 172.16.0.0
  network 10.0.0.0
  no auto-summary

auto-summary をオフにすることで、ルータ 1 には 10.0.0.0 ネットワークのすべてのコンポーネントが表示されます。

one# show ip eigrp topology
 IP-EIGRP Topology Table for process 2000
 Codes: P - Passive, A - Active, U - Update, Q - Query, R - Reply,
        r - Reply status
 P 10.1.3.0/24, 1 successors, FD is 46354176
          via 20.1.1.1 (46354176/45842176), Serial0
 P 10.1.2.0/24, 1 successors, FD is 11049472
          via 20.1.1.1 (11049472/10537472), Serial0
 P 10.1.1.0/24, 1 successors, FD is 11023872
          via 20.1.1.1 (11023872/10511872), Serial0
 P 172.16.1.0/24, 1 successors, FD is 2169856
          via Connected, Serial0

外部ルートの集約の処理に関して、注意点がいくつかあります。これらについては、後ほど「外部ルートの自動集約」のセクションで説明します。

手動集約

EIGRP では、手動集約を使用することで、内部ルートと外部ルートを事実上どのビット境界でも集約することが可能です。 たとえば図 14 では、ルータ 2 は 192.1.1.0/24、192.1.2.0/24、192.1.3.0/24 を CIDR ブロック 192.1.0.0/22 に集約します。

eigrp14.gif

ルータ 2 の設定を次に示します。

two# show run
 ....
 !
 interface Serial0
  ip address 10.1.50.1 255.255.255.0
  ip summary-address eigrp 2000 192.1.0.0 255.255.252.0
  no ip mroute-cache
 !
 ....
 two# show ip eigrp topology
 IP-EIGRP Topology Table for process 2000
 Codes: P - Passive, A - Active, U - Update, Q - Query, R - Reply,
        r - Reply status
 P 10.1.10.0/24, 1 successors, FD is 45842176
          via Connected, Loopback0
 P 10.1.50.0/24, 1 successors, FD is 2169856
          via Connected, Serial0
 P 192.1.1.0/24, 1 successors, FD is 10511872
          via Connected, Serial1
 P 192.1.0.0/22, 1 successors, FD is 10511872
          via Summary (10511872/0), Null0
 P 192.1.3.0/24, 1 successors, FD is 10639872
          via 192.1.1.1 (10639872/128256), Serial1
 P 192.1.2.0/24, 1 successors, FD is 10537472
          via 192.1.1.1 (10537472/281600), Serial1

インターフェイス Serial0 下の ip summary-address コマンド、および Null0 を介した集約ルートに注目してください。 ルータ 1 では、以下は内部ルートとして表示されます。

  one# show ip eigrp topology
 IP-EIGRP Topology Table for process 2000
 Codes: P - Passive, A - Active, U - Update, Q - Query, R - Reply,
        r - Reply status
 P 10.1.10.0/24, 1 successors, FD is 46354176
          via 10.1.50.1 (46354176/45842176), Serial0
 P 10.1.50.0/24, 1 successors, FD is 2169856
          via Connected, Serial0
 P 192.1.0.0/22, 1 successors, FD is 11023872
          via 10.1.50.1 (11023872/10511872), Serial0

外部ルートの自動集約

EIGRP は、同じメジャー ネットワークのコンポーネントがあり、それが内部ルートでない限りは、外部ルートの自動集約を実行しません。 これについて、図 15 で説明します。

eigrp15.gif

ルータ 3 は、以下の設定に示すとおり、redistribute connected コマンドを使って外部ルートを 192.1.2.0/26 と 192.1.2.64/26 を EIGRP に投入します。

ルータ 3

interface Ethernet0
  ip address 192.1.2.1 255.255.255.192
 !
 interface Ethernet1
  ip address 192.1.2.65 255.255.255.192
 !
 interface Ethernet2
  ip address 10.1.2.1 255.255.255.0
 !router eigrp 2000
  redistribute connected
  network 10.0.0.0
  default-metric 10000 1 255 1 1500

この設定をルータ 3 に行うと、ルータ 1 のルーティング テーブルの表示は次のようになります。

  one# show ip route
 ....
      10.0.0.0/8 is subnetted, 2 subnets
 D       10.1.2.0 [90/11023872] via 10.1.50.2, 00:02:03, Serial0
 C       10.1.50.0 is directly connected, Serial0
      192.1.2.0/26 is subnetted, 1 subnets
 D EX    192.1.2.0 [170/11049472] via 10.1.50.2, 00:00:53, Serial0
 D EX    192.1.2.64 [170/11049472] via 10.1.50.2, 00:00:53, Serial0

通常は、ルータ 3 では自動集約により 192.1.2.0/26 と 192.1.2.64/26 のルートが主要ネット送信先(192.1.1.0/24)に集約されますが、この場合は、両方とも外部ルートなので、ルータ 3 ではこれが行われません。 しかし、ルータ 2 とルータ 3 間のリンクを 192.1.2.128/26 に再設定して、このネットワークのネットワーク ステートメントをルータ 2 および 3 に追加した場合は、ルータ 2 上に 192.1.2.0/24 自動集約が生成されます。

ルータ 3

 interface Ethernet0
  ip address 192.1.2.1 255.255.255.192
 !
 interface Ethernet1
  ip address 192.1.2.65 255.255.255.192
 !
 interface Serial0
  ip address 192.1.2.130 255.255.255.192
 !
 router eigrp 2000
  network 192.1.2.0

ルータ 2 が 192.1.2.0/24 の集約を生成します。

two# show ip route
 ....
 D       192.1.2.0/24 is a summary, 00:06:48, Null0
 ....

ルータ 1 には集約ルートのみが表示されます。

 one# show ip route 
 ....
      10.0.0.0/8 is subnetted, 1 subnets
 C       10.1.1.0 is directly connected, Serial0
 D    192.1.2.0/24 [90/11023872] via 10.1.50.2, 00:00:36, Serial0

クエリーの処理と範囲

ルータが隣接ルータからのクエリーを処理するときには、次の規則が適用されます。

クエリー元

ルートの状態

アクション

隣接ルータ
(現行の
サクセサ以外)

パッシブ

現行のサクセサの情報を返信する。

サクセサ

パッシブ

新しいサクセサの検索を試みる。検索できた場合は新しい情報を返信する。検索に失敗した場合は、宛先を到達不能にマークして、元のサクセサを除くすべての隣接ルータにクエリーする。

任意の
隣接ルータ

クエリーより先に、この隣接ルータを通るパスはない。

現時点で最適とされるパスを返信する。

任意の
隣接ルータ

クエリー前は不明

宛先が到達不能であると応答する。

隣接ルータ
(現行の
サクセサ以外)

アクティブ

この宛先に現在サクセサがない場合(通常はそうなります)、到達不能と応答する。

適切なサクセサがある場合は現在のパス情報を返信する。

サクセサ

アクティブ

新しいサクセサの検索を試みる。検索できた場合は新しい情報を返信する。検索に失敗した場合は、宛先を到達不能にマークして、元のサクセサを除くすべての隣接ルータにクエリーする。

上表の各アクションによって、ネットワークが新しいトポロジでコンバージする前に、このクエリーを受信および返信するルータの数が決定されます。そのため、これらのアクションは、ネットワーク内のクエリー範囲に影響します。 図 16 の通常の条件下で動作しているネットワークを取り上げて、これらの規則がクエリーの処理方法にどのように影響するかを調べます。

eigrp16.gif

ネットワーク 192.168.3.0/24(右端)では、次のことが予測されます。

  • ルータ 1 には、192.168.3.0/24 へのパスが 2 つあります。

    • ルータ 2 を経由 - 距離 46533485、報告距離 20307200。

    • ルータ 3 を経由 - 距離 20563200、報告距離 20307200。

  • ルータ 1 はルータ 3 を通るパスを選択し、ルータ 2 を通るパスをフィージブル サクセサとして保持します。

  • ルータ 2 および 3 は、ルータ 4 を経由する 192.168.3.0/24 への 1 つのパスを示します。

192.168.3.0/24 に障害が起きたと仮定します。 このネットワークにはどのようなアクティビティがみられるでしょうか。 図 16a 〜 16h でこのプロセスを説明します。

ルータ 5 が 192.168.3.0/24 を到達不能にマークし、ルータ 4 にクエリーします。

eigrp16a.gif

ルータ 4 は、サクセサからクエリーを受信すると、このネットワークに到達可能な新しいサクセサを探そうとします。 見つからなかった場合、ルータ 4 は 192.168.3.0/24 を到達不能にマークし、ルータ 2 と 3 にクエリーします。

eigrp16b.gif

するとルータ 2 と 3 が 192.168.3.0/24 への唯一の到達可能なルートを喪失したことを確認し、このルートを到達不能にマークします。2 と 3 の両方がルータ 1 にクエリーを送信します。

eigrp16c.gif

簡単にするために、ルータ 1 が最初にルータ 3 からクエリーを受信し、このルートを到達不能にマークしたと想定します。 するとルータ 1 はルータ 2 からクエリーを受信します。 他の順番でも可能ですが、結果は同じになります。

eigrp16d.gif

ルータ 1 は両方のクエリーに対して、到達不能と応答します。これでルータ 1 は 192.168.3.0/24 に対してパッシブになります。

eigrp16e.gif

ルータ 2 と 3 が、ルータ 4 からのクエリーに応答します。このときルータ 2 と 3 は、192.168.3.0/24 に対してパッシブになっています。

eigrp16f.gif

ルータ 5 は、ルータ 4 からの応答を受信すると、ルータ 5 のルーティング テーブルからネットワーク 192.168.3.0/24 を削除します。ルータ 5 はネットワーク 192.168.3.0/24 に対してパッシブになります。ルータ 5 はルータ 4 にアップデートを送信します。すると、残りのルータのトポロジおよびルーティング テーブルから、このルートが削除されます。

eigrp16g.gif

この他のクエリーパスや処理の順番もあり得ますが、リンクがダウンした場合は、ネットワーク内のすべてのルータがネットワーク 192.168.3.0/24 のクエリーを処理することを理解しておくことが重要です。 複数のクエリーを処理することになるルータもあります(この例ではルータ 1)。 実際に、クエリーが別の順番でルータに達するのであれば、一部のルータが 3 つまたは 4 つのクエリーを処理することになるはずです。 これは、EIGRP ネットワークでのクエリーの範囲が制限されていないことを示すよい例です。

集約ポイントがクエリー範囲に与える影響

次に、同じネットワークにある 10.1.1.0/24 へのパスについて調べます。

  • ルータ 2 は、10.1.1.0/24 ネットワークへのトポロジ テーブル エントリを保持します。コストはルータ 1 経由で 46251885 です。

  • ルータ 3 は、10.1.1.0/24 ネットワークへのトポロジ テーブル エントリを保持します。コストはルータ 1 経由で 20281600 です。

  • ルータ 4 は、ルータ 3 経由で 10.0.0.0/8 ネットワークのトポロジ テーブル エントリを保持し(ルータ 2 と 3 がメジャー ネットワーク境界に自動集約しているため)、メトリックは 20307200 です(ルータ 2 を経由した報告距離は、ルータ 3 を経由した複合メトリックよりも高いため、ルータ 2 経由のパスはフィージブル サクセサではありません)。

eigrp17.gif

ルータ 1 は 10.1.1.0/24 がダウンすると、これを到達不能にマークし、このネットワークへの新しいパスをそれぞれの隣接ルータ(ルータ 2 と 3)にクエリーします。

eigrp17a.gif

ルータ 2 は、ルータ 1 からのクエリーを受信すると、このルートを到達不能にマークし(クエリーがルータ 2 のサクセサからのものであるため)、この後ルータ 4 と 3 にクエリーします。

eigrp17b.gif

ルータ 3 は、ルータ 1 からのクエリーを受信すると、この宛先を到達不能にマークし、ルータ 2 と 4 にクエリーします。

eigrp17c.gif

ルータ 4 は、ルータ 2 および 3 からのクエリーを受信すると、10.1.1.0/24 が到達不能であると応答します。(注:ルータ 4 には 10.0.0.0/8 のルートしかないため、問題のサブネットは認識されていません。)

eigrp17d.gif

ルータ 2 と 3 は、10.1.1.0/24 が到達不能であることを相互に応答し合います。

eigrp17e.gif

これでルータ 2 と 3 に未処理のクエリーがなくなったので、両ルータはルータ 1 に 10.1.1.0/24 が到達不能であると応答します。

eigrp17f.gif

この場合クエリーは、ルータ 2 と 3 での自動集約によって範囲を制限されています。 ルータ 5 はクエリーのプロセスには参加せず、ネットワークの再コンバージェンスにも関与しません。 手動集約、自動システム ボーダー、配布リストなどによってクエリーの範囲を制限することも可能です。

AS の境界がクエリー範囲に与える影響

2 つの EIGRP AS 間でルートを再配布する場合、ルータは通常の処理規則の範囲内でクエリーに応答し、他の AS に新しいクエリーを開始します。 たとえば、ルータ 3 に接続するネットワークへのリンクがダウンした場合、ルータ 3 はこのルートを到達不能にマークし、ルータ 2 に対して新しいパスをクエリーします。

eigrp18.gif

ルータ 2 はこのネットワークが到達不能であると応答し、AS 200 へのクエリーをルータ 1 に向けはじめます。 ルータ 3 は、初めのクエリーに対する応答を受信すると、このルートをテーブルから削除します。 ルータ 3 は、このネットワークに対してパッシブになります。

eigrp18a.gif

ルータ 1 がルータ 2 に応答した後、ルートがパッシブになります。

eigrp18b.gif

最初のクエリーが(AS ボーダーによって範囲を制限されていた)ネットワークの全体には伝搬されなかった一方で、そのクエリーは新しいクエリーという形で、2 番目の AS に流出します。 この技法では、クエリーに対する応答がなされる前に、このクエリーが通過する必要のあるルータ数が制限されるため、ネットワーク内の Stuck In Active(SIA)障害の防止に役立ちます。ただし、それぞれのルータがクエリーを処理しなければならないという全体的な問題が解決するわけではありません。 実際、クエリーの範囲を制限するこの手法によって、集約されていたはずのルートの自動集約がなされないために、問題が悪化する場合もあります(メジャー ネットワークに外部コンポーネントがなければ、外部ルートは集約されません)。

配布リストがクエリー範囲に与える影響

EIGRP の配布リストでは、クエリーの伝搬をブロックするのでなく、クエリーに対するどの返信も、到達不能にマークされます。 図 19 を例にとって説明します。

eigrp19.gif

上図では、次のことが言えます。

  • ルータ 3 には、そのシリアル インターフェイスに対する配布リストが適用されており、これによってネットワーク B をアドバタイズすることだけが許可されています。

  • ルータ 1 とルータ 2 では、ネットワーク A がルータ 3 経由で到達可能であるとは認識されていません(ルータ 3 はルータ 1 とルータ 2 間の通過ポイントとしては使用されません)。

  • ルータ 3 は、ルータ 1 をネットワーク A への優先パスとして使用し、ルータ 2 をフィージブル サクセサとしては扱いません。

ルータ 1 は、ネットワーク A への接続を失うと、このルートを到達不能にマークし、ルータ 3 にクエリーを送信します。 ルータ 3 は、そのシリアル ポート上に配布リストがあるため、ネットワーク A へのパスをアドバタイズしません。

eigrp19a.gif

ルータ 3 はこのルートを到達不能にマークしてから、ルータ 2 にクエリーします。

eigrp19b.gif

ルータ 2 はトポロジ テーブルを検査して、ネットワーク A への有効な接続が有ることを検出します。このクエリーは、ルータ 3 の配布リストによる影響を受けていないことに注意してください。

eigrp19c.gif

ルータ 2 は、ネットワーク A が到達可能であると応答します。ルータ 3 には有効なルートがあります。

eigrp19d.gif

ルータ 3 は、ルータ 1 からのクエリーに対する応答を作成します。しかし、配布リストがあるために、ルータ 3 は、実際にはネットワーク A への有効なルートがあるにもかかわらず、ネットワーク A が到達不能と応答してしまいます。

eigrp19e.gif

パケットのペーシング

一部のルーティング プロトコルでは、低帯域幅リンクでの使用可能なすべての帯域幅が、コンバージ中に(ネットワークの変更への適合を行っている間)消費されてしまいます。 EIGRP では、ネットワーク上でのパケットの送信速度をペーシングし、使用可能帯域幅の一部のみを使用するようにすることにより、この輻輳が回避されます。 EIGRP のデフォルト設定では、使用可能帯域幅の最大 50 % までが使用されるようになっています。しかしこれは、次のコマンドを使って変更できます。

router(config-if)# ip bandwidth-percent eigrp 2 ? 
   <1-999999>  Maximum bandwidth percentage that EIGRP may use

EIGRP では、インターフェイス上に送信するパケットをキューに入れる場合は、基本的に毎回次の公式を使用して、パケットを送信するまでの待ち時間が割り出されます。

  • (8 * 100 * パケット サイズ [バイト])/(帯域幅 [kbps] * 帯域幅 [%])

たとえば、帯域幅 56k のシリアル インターフェイスで送信する 512 バイトのパケットをキューに入れる場合、EIGRP での待機時間は次のようになります。

  • (8 * 100 * 512 バイト)/(56000 bps * 帯域幅 50 %)(8 * 100 * 512)/(56000 * 50)409600 / 2800000 0.1463 秒

これにより、EIGRP がそのパケットを送信する前に、少なくとも 512 バイトの 1 パケット(またはパケットのグループ)をこのリンクで送信することができます。 パケットの送信されるタイミングはペーシング タイマーが決定し、通常ミリ秒単位でこれを表示します。 上記の例では、パケットのペーシング タイムは 0.1463 秒です。 show ip eigrp interface には、次に示すとおり、ペーシング タイマーを表示するフィールドがあります。

router# show ip eigrp interface
 IP-EIGRP interfaces for process 2	                    Xmit Queue   Mean   Pacing Time   Multicast    Pending
 Interface    Peers  Un/Reliable  SRTT   Un/Reliable   Flow Timer   Routes
 Se0            1        0/0        28       0/15         127           0
 Se1            1        0/0        44       0/15         211           0
 router#

表示されるタイムは、このインターフェイスで送信可能な最大のパケットを指す、maximum transmission unit(MTU; 最大伝送ユニット)のペーシング間隔です。

デフォルト ルーティング

EIGRP にデフォルト ルートを投入する方法は 2 つあります。スタティック ルートの再配布、または 0.0.0.0/0 への集約です。 未知の宛先へのすべてのトラフィックを、ネットワーク コアのデフォルト ルートに向けたい場合は、前者の方法を使用してください。 この方法は、インターネットへの接続をアドバタイズする場合に効果的です。 次に例を示します。

ip route 0.0.0.0 0.0.0.0 x.x.x.x (next hop to the internet)
 !
 router eigrp 100
  redistribute static
  default-metric 10000 1 255 1 1500

EIGRP に再配布されるスタティック ルートは、ネットワーク 0.0.0.0 である必要はありません。 別のネットワークを使用する場合は、ip default-network コマンドを使用して、このネットワークをデフォルト ネットワークにマークする必要があります。 詳細は『IP コマンドを使用したラスト リゾート ゲートウェイの設定』を参照してください。

デフォルト ルートへの集約は、リモート サイトにデフォルト ルートを供給する場合にのみ有効です。 集約はインターフェイスごとに設定されるので、配布リストやその他のメカニズムを使用して、デフォルト ルートのネットワーク コアへの伝搬を防ぐ必要はありません。 0.0.0.0/0 への集約は、他のルーティング プロトコルから学習したデフォルト ルートを無効にすることに注意してください。 この方法を使ってルータにデフォルト ルートを設定する唯一の方法は、スタティック ルートを 0.0.0.0/0 に設定することです。(Cisco IOS ソフトウェア 12.0(4)T から、summary-address コマンドの最後にアドミニストレーティブ ディスタンスも設定できるようになったため、ローカルな集約により 0.0.0.0/0 ルートが無効にされることはありません。)

router eigrp 100
  network 10.0.0.0
 !
 interface serial 0
  encapsulation frame-relay
  no ip address
 !
 interface serial 0.1 point-to-point
  ip address 10.1.1.1
  frame-relay interface-dlci 10
  ip summary-address eigrp 100 0.0.0.0 0.0.0.0

ロード バランシング

EIGRP がルーティング テーブルに最大 4 つまでの等コスト ルートを挙げた時点で、これらのルートはルータによってロード バランスされます。 ロード バランシングのタイプ(パケット単位または宛先単位)は、ルータで実行されるスイッチングのタイプによります。 しかし、EIGRP は不等コストのリンクでもロード バランスを行います。

注:max-paths を使用すれば、EIGRP に最大 6 つまでの等コストのルートの使用を設定できます。

任意の宛先にたとえば 4 つのパスがあるとすると、これらのパスのメトリックは次のようになります。

  • パス 1:1100

  • パス 2:1100

  • パス 3:2000

  • パス 4:4000

ルータは、デフォルトにより、トラフィックをパス 1 とパス 2 の両方に流します。また、EIGRP を使用することで、variance コマンドを使用して、ルータにトラフィックをパス 3 とパス 4 にも流すように指示できます。このバリアンスは乗数として扱われます。最適パスをこのバリアンスで乗算した結果よりも小さいメトリックを持つ任意のリンクに、トラフィックが流されます。 パス 1、2、3 上でロード バランスを行うには、バリアンス 2 を使用します。これは 1100 x 2 = 2200 がパス 3 を通るメトリックよりも大きいためです。同様に、パス 4 も追加するには、router eigrp コマンドでバリアンス 4 を実行してください。 詳細は、『IGRP および EIGRP における不等コスト パスの負荷バランシング(バリアンス)』を参照してください。

トラフィックは、これらのルータのパス間でどのように分配されるのでしょうか。 ルータは最大メトリックを、各パスからのメトリックで割り、最も近い整数に切り捨てます。そしてこの数字をトラフィック シェア カウントとして使用します。

router# show ip route 10.1.4.0
 Routing entry for 10.1.4.0/24
   Known via "igrp 100", distance 100, metric 12001
   Redistributing via igrp 100, eigrp 100
   Advertised by igrp 100 (self originated)
                 eigrp 100
   Last update from 10.1.2.2 on Serial1, 00:00:42 ago
   Routing Descriptor Blocks:
   * 10.1.2.2, from 10.1.2.2, 00:00:42 ago, via Serial1
       Route metric is 12001, traffic share count is 1
       Total delay is 20010 microseconds, minimum bandwidth is 1000 Kbit
       Reliability 1/255, minimum MTU 1 bytes
       Loading 1/255, Hops 0

この例で、トラフィック シェア カウントは次のようになります。

  • パス 1 および 2:4000/1100 = 3

  • パス 3:4000/2000 = 2

  • パス 4:4000/4000 = 1

ルータは最初の 3 パケットをパス 1 で、次の 3 パケットをパス 2 で、そして次の 2 パケットをパス 3 で送信し、次のパケットをパス 4 で送信します。それから再び、次の 3 パケットをパス 1 から送信し、これを繰り返します。

注:EIGRP ではバリアンスが設定されている場合でも、当該ルートの到達可能距離よりも報告距離の方が大きいと、不等コスト パスでのトラフィック送信は行われません。 詳細は、「到達可能距離、報告距離、およびフィージブル サクセサ」のセクションを参照してください。

メトリックの使用

EIGRP の初期設定で EIGRP メトリックを調整する場合は、次の 2 つの基本的な規則を覚えておいてください。

  • 帯域幅は常に、そのインターフェイスの本当の帯域幅に設定する必要があります。ただし、マルチポイント シリアル リンク、またはその他のメディア速度のミスマッチ状況は、この規則の例外となります。

  • EIGRP のルーティング決定を調整する場合は、常に遅延を使用する必要があります。

EIGRP では、インターフェイス帯域幅によりパケットの送信速度が決定されるので、これらの設定を正しく行うことが重要です。 EIGRP の選択するパスを調整する必要がある場合は、常に遅延を使用してください。

帯域幅が小さいほど、その帯域幅が複合メトリックに与える影響は大きくなります。帯域幅が大きいほど、遅延が複合メトリックに与える影響は大きくなります。

再配布における管理タグの使用

外部管理タグは、EIGRP とその他のプロトコル間の再配布ルーティング ループを遮断するのに役立ちます。 ルートが EIGRP に再配布されるとき、このルートにタギングすることで、EIGRP から外部プトロコルへの再配布をブロックできます。 次に、これらのタグの基本的な設定例を示します。ただし、この例は再配布ループの遮断に使用される設定全体を示しているわけではありません。

eigrp20.gif

EIGRP に接続するルートを再配布するルータ 3 には、次のように表示されます。

three# show run
 ....
 interface Loopback0
  ip address 172.19.1.1 255.255.255.0
 !
 interface Ethernet0
  ip address 172.16.1.1 255.255.255.0
  loopback
  no keepalive
 !
 interface Serial0
  ip address 172.17.1.1 255.255.255.0
 ....
 router eigrp 444
  redistribute connected route-map foo
  network 172.17.0.0
  default-metric 10000 1 255 1 1500
 ....
 access-list 10 permit 172.19.0.0 0.0.255.255
 route-map foo permit 10
  match ip address 10
  set tag 1
 ....
 three# show ip eigrp topo
 IP-EIGRP Topology Table for process 444
 Codes: P - Passive, A - Active, U - Update, Q - Query, R - Reply,
        r - Reply status
 P 172.17.1.0/24, 1 successors, FD is 2169856
          via Connected, Serial0
          via Redistributed (2169856/0)
 P 172.16.1.0/24, 1 successors, FD is 281600
          via Redistributed (281600/0)
 P 172.19.1.0/24, 1 successors, FD is 128256, tag is 1
          via Redistributed (128256/0)

EIGRP からのルートを RIP に再配布するルータ 2 には、次のように表示されます。

two# show run 
 ....
 interface Serial0
  ip address 172.17.1.2 255.255.255.0
 !
 interface Serial1
  ip address 172.18.1.3 255.255.255.0
 ....
 router eigrp 444
  network 172.17.0.0
 !
 router rip
  redistribute eigrp 444 route-map foo
  network 10.0.0.0
  network 172.18.0.0
  default-metric 1
 !
 no ip classless
 ip route 1.1.1.1 255.255.255.255 Serial0
 route-map foo deny 10
  match tag 1
 !
 route-map foo permit 20
 ....
 two# show ip eigrp topo
 IP-EIGRP Topology Table for process 444
 Codes: P - Passive, A - Active, U - Update, Q - Query, R - Reply,
        r - Reply status
 P 172.17.1.0/24, 1 successors, FD is 2169856
          via Connected, Serial0
 P 172.16.1.0/24, 1 successors, FD is 2195456
          via 172.17.1.1 (2195456/281600), Serial0
 P 172.19.1.0/24, 1 successors, FD is 2297856, tag is 1
          via 172.17.1.1 (2297856/128256), Serial0

172.19.1.0/24 のタグ 1 に注目してください。

ルータ 2 によって再配布される RIP ルートを受信するルータ 1 には、次のように表示されます。

one# show run
 ....
 interface Serial0
  ip address 172.18.1.2 255.255.255.0
  no fair-queue
  clockrate 1000000
 router rip
  network 172.18.0.0
 ....
 one# show ip route
 Gateway of last resort is not set
 R    172.16.0.0/16 [120/1] via 172.18.1.3, 00:00:15, Serial0
 R    172.17.0.0/16 [120/1] via 172.18.1.3, 00:00:15, Serial0
      172.18.0.0/24 is subnetted, 1 subnets
 C       172.18.1.0 is directly connected, Serial0

172.19.1.0/24 がないことに注目してください。

EIGRP コマンド出力について

show ip eigrp topology

このコマンドはフィージブル サクセサのみを表示します。 トポロジ テーブルのすべてのエントリを表示するには、show ip eigrp topology all-links コマンドを使用します。 表には、各出力フィールドの説明が付けられています。

show ip eigrp topology

eigrp22.gif

設定の説明

A は「アクティブ」を意味します。 ここに「P」が表示されていれば、「パッシブ」を意味します。

10.2.4.0/24 は宛先またはマスクです。

0 successors は、この宛先で使用可能なサクセサ(またはパス)の数を示します。Successors が大文字の場合、このルートが移行中であることを示します。

FD is 512640000 は、到達可能距離を示します。到達可能距離は、この宛先に到達するための最適なメトリック、もしくはルータがアクティブになった時点での既知の最適なメトリックです。

tag is 0x0 は、set tag および match tag コマンドでルートマップを使用して設定またはフィルタできます。

Q は、クエリーが保留中であることを意味します。 他にこのフィールドに入る項目は次のとおりです。「U」はアップデートが保留の場合、「R」は応答が保留の場合です。

1 replies は、未処理の応答数を示します。

active 00:00:01 は、このルートがアクティブであった期間を指しています。

query origin: Local origin は、このルートがクエリーを発信したことを示しています。 他にこのフィールドに入る項目は次のとおりです。Multiple origins は、複数の隣接ルータがこの宛先にクエリーを送信したが、サクセサによる送信はなかったことを意味します。Successor origin は、サクセサがクエリーの送信元であることを意味します。

via 10.1.2.2 は、IP アドレス 10.1.2.2 の隣接ルータからこのルートを学習したことを示します。 他にこのフィールドに入る項目は次のとおりです。Connected は、ネットワークがこのルータに直接接続されている場合、Redistributed は、このルートがこのルータの EIGRP に再配布されている場合、Summary は、このルートがこのルータで生成された集約ルートである場合です。

(Infinity/Infinity)は、最初のフィールドでこの隣接ルータを介してこのパスに到達するためのメトリックを示し、および 2 番目のフィールドでこの隣接ルータを介して報告された距離を示します。

r は、この隣接ルータへすでにクエリーしており、応答を待っていることを示します。

Q はこのルートの送信フラグで、保留中のクエリーがあることを意味します。 他にこのフィールドに入る項目は次のとおりです。「U」は、保留中のアップデートがあることを意味し、「R」は、保留中の応答があることを意味します。

Serial1 は、この隣接ルータに到達できるインターフェイスです。

Via 10.1.1.2 は、応答の待たれる隣接ルータを示します。

r は、この隣接ルータにルートについてクエリーたが、まだ応答を受信していないことを示します。

Serial0 は、この隣接ルータに到達できるインターフェイスです。

Via 10.1.2.2(512640000/128256), Serial1 は、使用するのはこのルートであることを示しています(次のパスまたは宛先が、複数の等コストのルートのうち、どのパスを通るかを示します。)

show ip eigrp topology <network>

このコマンドは、フィージブル サクセサだけでなく、この宛先のトポロジ テーブルにあるすべてのエントリを表示します。 表には、各出力フィールドの説明が付けられています。

show ip eigrp topology network

eigrp23.gif

設定の説明

State is Passive はネットワークがパッシブ状態にあることを意味します。つまり、このネットワークへのパスは検索の対象外です。 安定したネットワークでは、ルートは必ずといってよいほどパッシブ状態にあります。

Query origin flag is 1 このフィールドは、このルートがアクティブの場合、このクエリーの発信者の情報を提供します。

  • 0: このルートはアクティブですが、このルートに向けて発信されたクエリーはありません。(ローカルで到達可能後続を検索します。)

  • 1: このルータが、このルートに対するクエリーを発信しました(またはルートがパッシブになっています)。

  • 2: このクエリーに対する複数の拡散計算 このルータは複数の送信元から、このルートに対する複数のクエリーを受信しました。

  • 3: このネットワークへのパスの学習元であるルータが、別のルートをクエリーしています。

  • 4: このルートに対する複数のクエリー送信元があります(このルートの学習時に経由したルータも含みます)。 2 と似ていますが、これはこのパスに対する未処理のクエリーについて記述した、クエリー送信元ストリングがあることも意味します。

2 Successor(s)は、このネットワークに到達可能なパスが 2 つあることを意味します。

FD is 307200 は、このネットワークへの最適な現行メトリックを示します。 ルートがアクティブの場合は、以前このネットワークにパケットをルーティングするために使用していたパスの、メトリックを示します。

Routing Descriptor Blocks 次のエントリはそれぞれ、ネットワークに通じる 1 つのパスについて説明したものです。

  • 10.1.1.2(Ethernet1)はネットワークへのネクストホップ、およびネクストホップに到着するために経由するインターフェイスです。

  • from 10.1.2.2 はこのパス情報の送信元です。

  • Send flag is

    • 0x0: このエントリに関連して送信する必要のあるパケットがあれば、そのパケットのタイプを示します。

    • 0x1: このルータは、このネットワークへのクエリーを受信していて、ユニキャスト応答を送信する必要があります。

    • 0x2: このルートはアクティブで、マルチキャスト クエリーを送信する必要があります。

    • 0x3: このルートは変更されており、マルチキャスト アップデートを送信する必要があります。

Composite metric is(307200/281600)は、ネットワークへの合計計算コストを示します。 括弧内の最初の数字は、このパスを経由した場合のネットワークへの合計コストで、ネクストホップへのコストも含まれます。 括弧内の 2 番目の数字は、報告距離、つまり、ネクストホップが使用するコストです。

Route is Internal は、このルートの発信元がこの EIGRP AS(自律システム)の中にあることを意味しています。 ルートがこの EIGRP AS に再配布された場合は、このフィールドは ルートが External であることを示します。

Vector metric は、ネットワークへのコストを計算するために EIGRP が使用する個々のメトリックを示します。 EIGRP は、ネットワークの全体に合計コスト情報を伝搬するわけではありません。ベクター メトリックが伝搬されて、各ルータがコストと報告距離を個別に計算します。

  • Minimum bandwidth is 10000 Kbit は、このネットワークに向かうパスの最低帯域幅を示します。

  • Total delay is 2000 microseconds は、このネットワークに向かうパスの遅延の合計を示します。

  • Reliability is 0/255 は信頼性係数を示します。 この数字は動的に計算されますが、メトリック計算のデフォルトでは使用されません。

  • Load is 1/255 は、リンクが伝送しているロードの量を示します。 この数字は動的に計算され、EIGRP がこのパスの使用コストを計算する際には、デフォルトでは使用されません。

  • Minimum MTU is 1500 このフィールドはメトリック計算では使用されません。

  • Hop count is 2 これはメトリック計算では使用されませんが、EIGRP AS の最大サイズを制限します。 EIGRP が許容する最大ホップ数はデフォルトで 100 ですが、最大数はメトリック最大ホップによって 220 に設定できます。

この外部ルートである場合には、次の情報が含まれます。 表には、各出力フィールドの説明が付けられています。

外部ルート

eigrp24.gif

設定の説明

Originating Router は、これがこのルートを EIGRP AS に投入したルータであることを示しています。

External AS は、このルートの発信元である AS(ある場合)を示しています。

External Protocol は、このルートの発信元のプロトコル(ある場合)を示します。

external metric は、外部プロトコルの内部メトリックを示します。

Administrator Tag は、set tag および match tag コマンドでルートマップを使用して設定またはフィルタできます。

show ip eigrp topology [active | pending | zero-successors]

show ip eigrp topology と同じ出力形式ですが、トポロジ テーブルの一部も表示されます。

show ip eigrp topology all-links

show ip eigrp topology と同じ出力形式ですが、フィージブル サクセサだけではなく、トポロジ テーブルにあるすべてのリンクが表示されます。


関連するシスコ サポート コミュニティ ディスカッション

シスコ サポート コミュニティは、どなたでも投稿や回答ができる情報交換スペースです。


関連情報


Document ID: 16406