IP : IP ルーティング

IP ルーティングに関する FAQ

2008 年 12 月 4 日 - ライター翻訳版
その他のバージョン: PDFpdf | 機械翻訳版 (2013 年 8 月 21 日) | 英語版 (2008 年 4 月 30 日) | フィードバック

目次

概要
同じインターフェイス上で、ファースト スイッチングまたはオートノマス スイッチングを「enabled」または「disabled」にすると、どうなりますか。
キャパシティの等しい 2 つの並列回線にロード バランシングが設定されているとき、この 2 つの回線の間でロードはどのように分散されますか。
経路集約とは何ですか。
Cisco のルータがソース クエンチ(始点抑制要求)を生成するのはどのようなときですか。
Cisco のルータがインターフェイスの外部にルーティング要求を開始するのは、どのようなときですか。
ip default-gateway、ip default-network、ip route 0.0.0.0/0 の各コマンドの違いを教えてください。
ブートストラップ プロトコル(BOOTP)フレームを転送するには、ip helper-address コマンドをどのように使用したらよいでしょうか。
Enhanced Interior Gateway Routing Protocol(EIGRP)は IGRP IP ルーティング プロトコルで自動的に再配布されます。EIGRP には Routing Information Protocol(RIP; ルーティング情報プロトコル)の IP ルーティング プロトコルとの相互作用もありますか。
ルートが 2 つの送信元から学習される場合、Open Shortest Path First(OSPF)ルートを EIGRP ルートよりも優先するように設定するにはどうしたらよいでしょうか。
拡張 IP アクセス コントロール リスト(ACL)を使用して、通常のルーティング アップデート(OSPF など)をフィルタリングできますか。ルーティング プトロコルの適切な動作を保証するために、ルーティング プロトコルでアップデート用に使用されるマルチキャスト IP(OSPF の場合は 224.0.0.5 および 224.0.0.6)を明示的に許可する必要がありますか。
インターフェイス サブコマンドの「no arp arpa」により、ルータ インターフェイスで ARP 機能は無効にされますか。
ルータの設定で、イーサネットを 255.255.254.0 と、さらにシリアルのサブネットを 255.255.252.0 と設定することはできますか。IGRP/RIPv1 では、可変サブネットをサポートしていますか。
1 つのインターフェイスに複数の「ip access-group」文を設定することはできますか。
同じサブネットに 2 つのインターフェイス(t0 = 142.10.46.250/24 および t1 142.10.46.251/24)を設定できますか。
同じルータに属する 2 つのシリアル インターフェイスに、重複した IP アドレスを設定することはできますか。
イーサネット インターフェイスにプライマリとびセカンダリの IP アドレスを設定し、ルータで RIP(ディスタンスベクター ルーティング プロトコル)を実行しています。スプリット ホライズンは、ルーティング更新にどのように影響しますか。
拡張 ACL で IP アクセス リストのキーワードである established を使用した場合に、パフォーマンス面での利点はありますか。「established」の使用によって、アクセス リストがより脆弱になることはありますか。使用法についての具体的な例はありますか。
同じ宛先に対してコストが等価の 4 つのパラレル パスがあります。2 つのリンクでファースト スイッチングを行い、残りの 2 つでプロセス スイッチングを行っています。この状況で、パケットはどのようにルーティングされますか。
Unicast Reverse Path Forwarding (uRPF; ユニキャスト リバース パス転送)とは何ですか。uRPF チェックを実行するために、デフォルト ルート 0.0.0.0/0 を使用できますか。
宛先へのリンクが複数あるときに、ロード バランシングを実行するのは、Cisco Express Forwarding(CEF)とルーティング プロトコルのどちらですか。
ルータ インターフェイスには、最大何個のセカンダリ IP アドレスを設定できますか。
ポーズ コントロール カウンタとは何ですか。
VLAN インターフェイスとトンネル インターフェイスに同じ IP アドレスを設定できますか。
Virtual Routing and Forwarding(VRF)とは何ですか。
2 つの異なる ISP を接続して、異なるトラフィックを別々の ISP にルーティングするにはどうすればよいのですか。
スタティック ルートを作成する 2 つの方法の違いは何ですか。
ポート 2228 と 56506 の目的は何ですか。
ポイントツーポイント サブインターフェイスとマルチポイント サブインターフェイスの違いは何ですか。
同じメイン インターフェイスの複数のサブインターフェイスに異なる MTU を設定できますか。このシナリオでは、75000 ルータ、GSR ルータ、または ESR ルータはどのように動作するのですか。
お客様がネットワークにアクセスする場合のセッション数を制限するにはどうすればよいのですか。
アカウンティング データ経過時間はどのように計算されるのですか。
IP SLA 動作における「しきい値」と「タイムアウト」という用語の意味は何ですか。
ルーティング テーブル エントリにおける時間(Time)の重要性は何ですか。
Network Descriptor Block(NDB; ネットワーク記述子ブロック)とは何ですか。
関連するシスコ サポート コミュニティ ディスカッション
関連情報

概要

このドキュメントでは、IP ルーティングに関する FAQ への回答を示しています。

注:ドキュメント表記の詳細は、『シスコ テクニカル ティップスの表記法』を参照してください。

Q. 同じインターフェイス上でファースト スイッチングまたはオートノマス スイッチングを「enabled」または「disabled」にすると、どうなりますか。

A. 次の例を参照してください。

Ethernet 6 is up, line protocol is up
      Internet address is 192.192.15.1, subnet mask is 255.255.255.0       
      Broadcast address is 192.192.15.255
      Address determined by non-volatile memory MTU is 1500 bytes
      Helper address is 192.192.12.5
      Outgoing access list is not set
      Proxy ARP is enabled
      Security level is default
      Split horizon is enabled
      ICMP redirects are always sent
      ICMP unreachables are always sent
      ICMP mask replies are never sent
      
      IP autonomous switching is enabled
     IP autonomous switching on the same interface is disabled 
      ^^^^^^^^^^^^^^^^^^^^^^^^^^^
      Gateway Discovery is disabled
      IP accounting is disabled
      TCP/IP header compression is disabled
      Probe proxy name replies are disabled

1 つのインターフェイスでファースト スイッチングまたはオートノマス スイッチングを有効にした場合は、ルータ上のそれ以外のインターフェイスから発信されたパケットが、このインターフェイスにファースト スイッチング(またはオートノマス スイッチング)されます。同じインターフェイス上でファースト スイッチングまたはオートノマス スイッチングを有効にした場合は、送信元アドレスと宛先アドレスが同じパケットがファースト スイッチングまたはオートノマス スイッチングされます。

同じメイン インターフェイス上に、フレームリレーまたは Asynchronous Transfer Mode(ATM; 非同期転送モード)WAN リンクをサブインターフェイスとして設定している場合は、同じインターフェイス上でのファースト スイッチングまたはオートノマス スイッチングを使用できます。また、IP アドレスの移行中に LAN インターフェイスでセカンダリ ネットワークを使用しているような場合にも、同じインターフェイス上でのファースト スイッチングまたはオートノマス スイッチングの使用が適しています。同じインターフェイス上でファースト スイッチングを有効にするには、ip route-cache same-interface 設定コマンドを使用します。

Q. キャパシティの等しい 2 つの並列回線にロード バランシングが設定されているとき、この 2 つの回線の間でロードはどのように分散されますか。

A. IP の場合、ルータがファースト スイッチングであれば、宛先ごとにロード バランスを行います。ルータがプロセス スイッチングの場合は、パケットごとにロード バランスを行います。詳細は、『ロード バランシングの機能のしくみ』を参照してください。Cisco IOS(R) ソフトウェアでは、Cisco Express Forwarding(CEF)によるパケットごとと宛先ごとの両方のロード バランシングもサポートされています。詳細は、『CEF によるロード バランシング』および『Cisco Express Forwarding(CEF)を使用したパラレル リンクでのロード バランシングに関するトラブルシューティング』を参照してください。

Q. 経路集約とは何ですか。

A. 経路集約とは、マスクの長い多数のルートを縮小して、よりマスクの短い、別のルートを作成するプロセスのことです。詳細は、『OSPF と経路集約』および『Enhanced IGRP』の「集約」セクションを参照してください。auto-summary コマンドは、隣接するサブネットがある場合にのみ機能します。隣接していないサブネットを使用する場合は、経路集約を設定するルーティング プロセスに関与するすべてのインターフェイスで、ip summary-address インターフェイス設定コマンドを使用する必要があります。

Q. Cisco のルータがソース クエンチ(始点抑制要求)を生成するのはどのようなときですか。

A. Cisco IOS(R) ソフトウェア リリース 11.3 および 12.0 よりも前では、Cisco のルータはパケットをキューイングするためのバッファ スペースがない場合にのみ、ソース クエンチ(始点抑制要求)を生成していました。ルータは、ルーティングされたパケットを出力インターフェイスのキューにキューイングできない場合に、ソース クエンチ(始点抑制要求)を生成し、出力インターフェイスにてアウトプット ドロップ カウンタをインクリメントします。ルータで輻輳が発生していなければ、ソース クエンチ(始点抑制要求)は生成されません。

送信されたソース クエンチ(始点抑制要求)については、show ip traffic コマンドの出力を参照できます。さらに、ドロップがあるかどうかを確認するには、show interface コマンドの出力を参照してください。ドロップがなければ、ソース クエンチ(始点抑制要求)は表示されません。

Cisco IOS ソフトウェア リリース 11.3 および 12.0 以降のリリースには、ソース クエンチ(始点抑制要求)機能はありません。

Q. Cisco のルータがインターフェイスからのルーティング要求を開始するのは、どのようなときですか。

A. ディスタンスベクトル ルーティング プロトコルを実行する Cisco のルータでは、次の条件のいずれかが満たされると、インターフェイスからのルーティング要求の送信が開始されます。

  • インターフェイスがダウンした。

  • router グローバル設定コマンドに変更があった。

  • metric 設定コマンドに変更があった。

  • clear ip route EXEC コマンドが使用された。

  • shutdown インターフェイス設定コマンドが使用された。

  • ルータがブートされた。

  • ip address コマンドに変更があった。

ルーティング要求は、この要求が生成されたインターフェイスに関係なく、この特定のプロトコルが設定されたすべてのインターフェイスから送信されます。要求が 1 つのインターフェイスにしか送信されないとすると、そのインターフェイスがこのプロトコルが設定された唯一のインターフェイスであるということになります。

debug ip igrp events または debug ip igrp transactions コマンドが有効になっている場合には、前述のいずれの状況でも次のように表示されます。

IGRP: broadcasting request on Ethernet0 
IGRP: broadcasting request on Ethernet1 
IGRP: broadcasting request on Ethernet2 
IGRP: broadcasting request on Ethernet3

Q. ip default-gateway、ip default-network、ip route 0.0.0.0/0 の各コマンドの違いを教えてください。

A. ip default-gateway コマンドは、ルータで IP ルーティングが無効になっている場合に使用されます。ip default-networkip route 0.0.0.0/0 はルータで IP ルーティングが有効な場合に有効で、ルーティング テーブルに完全に一致するルートがないパケットのルーティングに使用されます。詳細は、『IP コマンドを使用したラスト リゾート ゲートウェイの設定』を参照してください。

Q. ブートストラップ プロトコル(BOOTP)フレームを転送するには、ip helper-address コマンドをどのように使用したらよいでしょうか。

A. ip helper-address コマンドは、Bootstrap Protocol(BOOTP; ブートストラップ プロトコル)サーバの IP アドレス、または BOOTP サーバが常駐するセグメントのダイレクト ブロードキャスト アドレスのどちらかを引数とします。また、複数の BOOTP サーバがある場合は、異なる IP アドレスについて複数のインスタンスでコマンドを実行できます。ip helper address コマンドは、個々のサブ インターフェイスでも使用できます。

Q. Enhanced Interior Gateway Routing Protocol(EIGRP)は IGRP IP ルーティング プロトコルで自動的に再配布されます。EIGRP には Routing Information Protocol(RIP; ルーティング情報プロトコル)の IP ルーティング プロトコルとの相互作用もありますか。

A. EIGRP では、redistribute コマンドを使用して RIP と相互に対話できます。RIP と EIGRP は根本的に異なっているため、自動的に相互対話を行うと予期しない結果、および好ましくない結果をもたらすことがあります。しかし、EIGRP と IGRP の間では自動的な相互対話が可能です。これは、これらのアーキテクチャが似通っているためです。詳細は、『ルーティング プロトコルの再配送』を参照してください。

Q. ルートが 2 つの送信元から学習される場合、Open Shortest Path First(OSPF)ルートを EIGRP ルートよりも優先するように設定するにはどうしたらよいでしょうか。

A. 簡潔に回答すると、ルーティング プロセスで distance コマンドを使用することです。内部ルートに関して、OSPF のデフォルトのアドミニストレーティブ ディスタンスは 110 で、EIGRP のデフォルトのアドミニストレーティブ ディスタンスは 90 です。2 つのルーティング プロトコルから同じルートのプレフィクスが学習された場合は、アドミニストレーティブ ディスタンスがより小さい(90 は 110 よりも少ない)ために、EIGRP から学習されるルートが IP ルーティング テーブルにインストールされます。EIGRP ルートではなく OSPF ルートが Routing Information Base(RIB; ルーティング情報ベース)にインストールされるようにするには、distance ospf コマンドを使用して、OSPF のアドミニストレーティブ ディスタンスを EIGRP のそれよりも小さくします。アドミニストレーティブ ディスタンスについての詳細は、『アドミニストレーティブ ディスタンスの概要』を参照してください。

Q. 拡張 IP アクセス コントロール リスト(ACL)を使用して、通常のルーティング アップデート(OSPF など)をフィルタリングできますか。ルーティング プトロコルの適切な動作を保証するために、ルーティング プロトコルがルーティング更新用に使用するマルチキャスト IP(OSPF の場合は 224.0.0.5 および 224.0.0.6)を明示的に許可する必要がありますか。

A. インターフェイス上のすべての IP Access Control List(ACL; アクセス コントロール リスト)は、そのインターフェイス上のすべての IP トラフィックに適用されます。すべての IP ルーティング アップデート パケットはインターフェイス レベルで通常の IP パケットとして処理されるため、access-list コマンドを使用してこのインターフェイスで定義される ACL と照合されます。ルーティング アップデートが ACL によって拒否されないようにするには、次の文を使用してこれらを許可します。

RIP を許可するには、次の文を使用します。

access-list 102 permit udp any any eq rip 

IGRP を許可するには、次の文を使用します。

access-list 102 permit igrp any any

EIGRP を許可するには、次の文を使用します。

access-list 102 permit eigrp any any 

OSPF を許可するには、次の文を使用します。

access-list 102 permit ospf any any 

Border Gateway Protocol(BGP; ボーダーゲートウェイ プロトコル)を許可するには、次の文を使用します。

access-list 102 permit tcp any any eq 179
access-list 102 permit tcp any eq 179 any

ACL の詳細は、『IP アクセス リストの設定』および『一般的に使用される IP ACL の設定』を参照してください。

Q. インターフェイス サブコマンドの「no arp arpa」により、ルータ インターフェイスで ARP 機能は無効にされますか。

A. Advanced Research Projects Agency(ARPA; 高等研究計画局)ARP は「イーサネット インターフェイス」を意味します。ARP ARPA はデフォルトでは no arp snap で設定されています。つまり、送信には ARPA スタイルの ARPが用いられ、応答についてはARPA と Subnetwork Access Protocol(SNAP; サブネットワーク アクセス手順)の両方に対して行います。no arp arpa を設定すると ARP 要求は無効にされますが、ARP 要求が試みられるすべてのステーションに対してヌル エントリが作成されます。有効にする対象としては、SNAP のみ、ARPA のみ(デフォルト)、または SNAP と ARPA 両方(毎回 2 つの ARP を送信)があります。または、SNAP と ARPA の両方を無効にできます(他の ARP を設定しないで no arp arpa を設定した場合)。

Q. ルータの設定で、イーサネットを 255.255.254.0 と、さらにシリアルのサブネットを 255.255.252.0 と設定することはできますか。IGRP/RIPv1 では、可変サブネットをサポートしていますか。

A. はい。これらのサブネット マスクは設定可能です。Cisco のルータでサブネットを設定するには、サブネットのビットが連続的である必要があります。したがって、255.255.253.0(11111111.11111111.11111101.00000000)は有効ではありませんが、225.255.252.0(11111111.11111111.11111100.00000000)は有効です。ホスト部分から、1 ビットを除くすべてのビットを取り入れてサブネット化することは禁止されています。また従来から、1 ビットでサブネット化することは禁止されています。上記のマスクは、次の条件を満たしています。詳細は、『IP のアドレッシングとサブネット化について(新規ユーザ向け)』を参照してください。

IGRP と RIP バージョン 1 では、Variable Length Subnet Masking(VLSM; 可変長サブネット マスキング)をサポートしていません。これらのプロトコルのいずれかを実行する単一のルータでは、可変長サブネット化を使用しても正常に動作します。設定済みサブネットの 1 つに向けられた着信パケットは、正常にルーティングされて、正しい宛先インターフェイスに配信されます。しかし、VLSM および非連続ネットワークが IGRP ドメイン内の複数のルータにまたがって設定されている場合は、ルーティング障害の原因になります。詳細は、『RIP および IGRP が非隣接ネットワークをサポートしない理由』を参照してください。

新しい IP ルーティング プロトコルの EIGRP、ISIS、OSPF および RIP バージョン 2 は VLSM をサポートするため、ネットワーク設計にはこれらのプロトコルを推奨します。すべての IP ルーティング プロトコルの詳細は、『IP ルーティング プロトコルに関するテクニカル サポート ページ』を参照してください。

Q. 1 つのインターフェイスに複数の「ip access-group」文を設定することはできますか。

A. Cisco IOS バージョン 10.0 以降では、各インターフェイスに 2 つ(各方向に 1 つ)の ip access-group コマンドを使用できます。

interface ethernet 0
        ip access-group 1 in
        ip access-group 2 out

1 つの access-group が着信トラフィックに使用され、もう 1 つが発信トラフィックに使用されます。ACL の詳細は、『一般的に使用される IP ACL の設定』および『IP アクセス リストの設定』を参照してください。

Q. 同じサブネットに 2 つのインターフェイス(t0 = 142.10.46.250/24 および t1 142.10.46.251/24)を設定できますか。

A. できません。ルーティングが動作するには、各インターフェイスは異なるサブネットにある必要があります。しかし、IP ルーティングを行わず、ブリッジングだけを行う場合には、同じサブネット上に 2 つのインターフェイスを設定できます。

Q. 同じルータに属する 2 つのシリアル インターフェイスに、重複した IP アドレスを設定することはできますか。

A. はい、シリアル インターフェイスには重複した IP アドレスを設定できます。これはリンクをバンドルする場合(つまり MLPPP)の効率的な方法であり、またアドレス レンジを節約する適切な方法です。重複した IP アドレスを割り当てるには、カプセル化をデフォルトの HDLC から PPP に変更します。

Q. イーサネット インターフェイスにプライマリおよびセカンダリ IP アドレスを設定し、ルータで RIP(ディスタンスベクター ルーティング プロトコル)を実行しています。スプリット ホライズンは、ルーティング アップデートにどのように影響しますか。

A. セカンダリ アドレスが関与する場合の、RIP/IGRP ルーティング アップデートに対するスプリット ホライズンの影響について』を参照してください。

Q. 拡張 ACL で IP アクセス リストのキーワードである established を使用した場合に、パフォーマンス面での利点はありますか。「established」の使用によって、アクセス リストがより脆弱になることはありますか。使用法についての具体的な例はありますか。

A. 実際のパフォーマンス面での利点はありません。キーワード established は単に、確認応答(ACK)またはリセット(RST)ビット セット付きパケットを通過させることを意味します。ACL 全般に関する詳細は、『IP アクセス リストの設定』を参照してください。

キーワード established は、内部のホストが外部との TCP 接続を行えるようにし、返信制御トラフィックを受信できるようにするものです。ほとんどのシナリオでは、ファイアウォールの設定でこのタイプの ACL が必須となっています。リフレクシブ ACL(reflexive access list)やコンテキストベース アクセス コントロールを使用しても、同じ結果が得られます。設定例については、『一般的に使用される IP ACL の設定』を参照してください。

Q. 同じ宛先に対してコストが等価の 4 つのパラレル パスがあります。2 つのリンクでファースト スイッチングを行い、残りの 2 つでプロセス スイッチングを行っています。この状況で、パケットはどのようにルーティングされますか。

A. IP ネットワークのセットに対してコストが等価の 4 つのパスがあると仮定します。インターフェイス 1 と 2 はファースト スイッチングを行い(インターフェイスで ip route-cache が有効化)、3 と 4 は行いません。(no ip route-cache)。ルータはまず、1 つのリストに 4 つの等コスト パスを確立させます(パス 1、2、3、4)。show ip route x.x.x.x を実行すると、x.x.x.x への 4 つの「ネクスト ホップ」が表示されます。

インターフェイス 1 では、ポインタは interface_pointer と呼ばれます。interface_pointer は、インターフェイスを巡回し、1-2-3-4-1-2-3-4-1 のような決まった順序でルーティングします。show ip route x.x.x.x の出力では、「next hop」の左に「*」が付いています。これは、interface_pointer によって、キャッシュ内に見つからなかった宛先アドレスに対して使用されます。interface_pointer を使用するたびに、このポインタは次のインターフェイスまたはルートに進みます。

より分かりやすく説明するために、次の繰り返しループを例に挙げます。

  • 4 つのパラレル パスを利用できるネットワークを宛先とするパケットが着信しました。

  • ルータは、キャッシュ内に存在するかどうかを確認します(はじめは、キャッシュは空です)。

  • キャッシュに存在する場合、ルータはキャッシュに格納されているインターフェイスに送信します。キャッシュに存在しない場合、ルータは interface_pointer があるインターフェイスに送信し、リストの次のインターフェイスに interface_pointer を移動します。

  • ルータがパケットを送信したインターフェイスがルートキャッシュを実行している場合、そのルータはインターフェイス ID と宛先 IP アドレスをキャッシュに格納します。同じ宛先に向けられた後続のすべてのパケットは、ルート キャッシュ エントリを使ってスイッチングされます(したがって、これらはファースト スイッチングされます)。

2 つのルートキャッシュ インターフェイスと 2 つの非ルートキャッシュ インターフェイスがあった場合、キャッシュされていないエントリがキャッシュ機能を有するインターフェイスに着信し、そのインターフェイスに宛先がキャッシュされる確率は 50 % です。時間が経過すれば、ファースト スイッチング(ルートキャッシュ)を実行しているインターフェイスは、キャッシュにない宛先を除き、すべてのトラフィックを伝送します。これは、宛先へのパケットがインターフェイス上でプロセス交換された後は、interface_pointer が移動して、リストにある次のインターフェイスをポイントするためです。このインターフェイスにもプロセス交換が実行される場合は、2 番目のパケットがこのインターフェイス上でプロセス交換されます。interface_pointer はさらに進んで、この次のインターフェイスをポイントします。プロセス交換されたインターフェイスは 2 つしかないため、3 つ目のパケットはファースト スイッチングされたインターフェイスにルーティングされます。すると今度は、そのインターフェイスがキャッシュします。IP ルートキャッシュでキャッシュされた後は、同じ宛先に向かうすべてのパケットに、ファースト スイッチングが実行されます。よって、キャッシュにないエントリが、キャッシュ機能を有するインターフェイスに着信し、そのインターフェイスに宛先がキャッシュされる確率は 50 % です。

プロセススイッチング インターフェイスに障害があった場合は、ルーティング テーブルが更新され、コストが同じ 3 つのパスが残ります(2 つのファースト スイッチング パスと 1 つのプロセス交換パス)。時間が経過すれば、ファースト スイッチング(ルートキャッシュ)を実行しているインターフェイスは、キャッシュにない宛先を除き、すべてのトラフィックを伝送します。2 つのルートキャッシュ インターフェイスと 1 つの非ルートキャッシュ インターフェイスがあった場合、キャッシュされていないエントリが、キャッシュ機能を有するインターフェイスに着信し、そのインターフェイスに宛先がキャッシュされる確率は 66 % です。時間が経過すれば、2 つのファースト スイッチング インターフェイスがすべてのトラフィックを伝送すると予想できます。

同様に、ファースト スイッチング インターフェイスに障害が生じた場合は、コストが同じ 3 つのパスが残ります(1 つのファーストスイッチング パスと 2 つのプロセススイッチング パス)。時間が経過すれば、ファースト スイッチング(ルートキャッシュ)を実行しているインターフェイスが、キャッシュにない宛先を除くすべてのトラフィックを伝送するようになります。キャッシュにないエントリが、キャッシュ機能を有するインターフェイスに着信し、そのインターフェイスに宛先がキャッシュされる確率は 33 % です。この場合、時間が経過すれば、キャッシュ機能を有する 1 つのインターフェイスがすべてのトラフィックを伝送すると予想できます。

ルート キャッシュを実行しているインターフェイスがない場合、ルータでは、トラフィックはパケットごとにラウンドロビン方式で処理されます。

結論は次のようになります。1 つの宛先に対してコストが同じ複数のパスが存在する場合、一部はプロセススイッチングされ、残りはファースト スイッチングされます。この後時間が経過すれば、トラフィックの大部分がファースト スイッチングされたインターフェイスだけで伝搬されるようになります。このような方法で達成されるロード バランシングは最適ではなく、場合によってはパフォーマンスを低下させる可能性があります。したがって、次のどちらかを実施することを推奨します。

  • パラレル パスのすべてのインターフェイスでルート キャッシュを使用するか、またはいずれのインターフェイスでもルート キャッシュを使用しないでください。

    または

  • 時間が経過すれば、キャッシュ機能を持つインターフェイスがすべてのトラフィックを伝送するようになることを想定してください。

Q. Unicast Reverse Path Forwarding (uRPF; ユニキャスト リバース パス転送)とは何ですか。uRPF チェックを実行するために、デフォルト ルート 0.0.0.0/0 を使用できますか。

A. 送信元アドレスのスプーフィングを防止するために使用されるユニキャスト リバース パス転送とは、ルータ インターフェイスで受信した IP パケットが、パケットの送信元アドレスに対する最善のリターン パス(リターン ルート)で到着したかどうかを確認する、ルータによる「後方確認」機能です。パケットを最善のリバース パス ルートの 1 つから受信した場合、パケットは正常なものとして転送されます。パケットを受信した同じインターフェイス上にリバース パス ルートが存在しない場合、ip verify unicast reverse-path list interface 設定コマンドで Access Control List(ACL; アクセス コントロール リスト)が指定されているかどうかによって、パケットはドロップまたは転送されます。詳細は、『Cisco IOS セキュリティ設定ガイド、リリース 12.2』の「ユニキャスト リバース パス転送の設定」の章を参照してください。

uRPF チェックを実行するため、デフォルト ルート 0.0.0.0/0 を使用することはできません。たとえば、送信元アドレスが 10.10.10.1 のパケットを Serial 0 インターフェイスで受信し、10.10.10.1 に一致する唯一のルートがルータ上の Serial 0 をポイントするデフォルト ルート 0.0.0.0/0 だった場合、uRPF チェックは失敗し、対象パケットはドロップされます。

Q. 宛先へのリンクが複数あるときに、ロード バランシングを実行するのは、Cisco Express Forwarding(CEF)かルーティング プロトコルのどちらですか。

A. EIGRP、RIP、Open Shortest Path First(OSPF)などのルーティング プロトコルによってデータが設定されたルーティング テーブルに基づいてパケットのスイッチングを行うのは CEF です。ルーティング プロトコル テーブルの計算が完了していれば、CEF がロード バランシングを行います。ロード バランシングの詳細は、『ロード バランシングの機能のしくみ』を参照してください。

Q. ルータ インターフェイスには、最大何個のセカンダリ IP アドレスを設定できますか。

A. ルータ インターフェイスに設定するセカンダリ IP アドレスの数に制限はありません。詳細は、『IP アドレスの設定』を参照してください。

Q. ポーズ コントロール カウンタとは何ですか。

A. ポーズ コントロール カウンタは、ルータから他のルータにトラフィックの速度を落とすように要求した回数を示します。たとえば、ルータ A とルータ B という 2 つのルータが、フロー制御が有効になっているリンクで接続されているとします。ルータ B でトラフィックのバーストが発生した場合、リンクがオーバーサブスクリプションになっているためトラフィックの速度を落とすようにルータ A に指示するポーズ出力パケットがルータ B から送信されます。ルータ A は、ルータ B から送信された要求を通知するポーズ入力パケットを受信します。ポーズ出力パケットおよびポーズ入力パケットは、問題やエラーではありません。これらは単に 2 つのデバイス間でフロー制御を行うためのパケットです。

Q. VLAN インターフェイスとトンネル インターフェイスに同じ IP アドレスを設定できますか。

A. いいえ。トンネルでは IP トラフィックを GRE ヘッダーでカプセル化する必要がありますが、レイヤ 2 のトラフィックはカプセル化できないため、トンネルを使用したブリッジングはサポートされていません。

Q. Virtual Routing and Forwarding(VRF)とは何ですか。

A. Virtual Routing and Forwarding(VRF)は IP ネットワーク ルータに含まれているテクノロジーであり、これによりルータ内にルーティング テーブルの複数のインスタンスを保持し、それらを同時に使用できます。これにより複数のデバイスを使用しなくてもネットワーク パスをセグメント化できるため、機能性が向上します。また、VRF ではトラフィックが自動的に分離されるため、ネットワークのセキュリティが向上し、暗号化や認証を行う必要がなくなります。多くの場合 Internet Service Provider(ISP; インターネット サービス プロバイダー)では、お客様に別々の Virtual Private Network(VPN; バーチャル プライベート ネットワーク)を構築するために VRF を活用しています。そのため、このテクノロジーは VPN ルーティングおよび転送とも呼ばれています。

VRF の動作は論理ルータと似ていますが、論理ルータでは数多くのルーティング テーブルを使用できるのに対して、1 つの VRF インスタンスで使用できるのは 1 つのルーティング テーブルだけです。さらに、VRF では、各データ パケットのネクストホップを指定する転送テーブル、パケット転送時にコール可能なデバイスのリスト、およびパケットの転送方法を制御する一連のルールおよびルーティング プロトコルが必要です。これらのテーブルによって、トラフィックが特定の VRF パス外に転送されることを防止したり、VRF パス外で転送される必要があるトラフィックを排除したりできます。

Q. 2 つの異なる ISP を接続して、異なるトラフィックを別々の ISP にルーティングするにはどうすればよいのですか。

A. 送信元アドレスに基づいて異なる ISP にトラフィックをルーティングできる機能に、Policy based routing(PBR; ポリシーベース ルーティング)があります。

Q. スタティック ルートを作成する 2 つの方法の違いは何ですか。

A: スタティック ルートを作成する方法には次の 2 つがあります。

  • ip route 10.1.1.1 255.255.255.0 eth 0/0 コマンドでは、ネクストホップの IP アドレスを検索する ARP ブロードキャストが生成されます。

  • ip route 10.1.1.1 255.255.255.0 172.16.1.1 コマンドでは、ARP 要求は生成されません。この場合、ルーティング プロセスでレイヤ 2 は使用されません。

Q. ポート 2228 と 56506 の目的は何ですか。

A. 2228 および 56506 は、登録されたポート番号ではありません。任意のアプリケーションで使用できるポートです。一部のアプリケーションでは、これらのポート番号を使用して接続が開始されます。このため、show ip sockets コマンドの出力にポート番号が示されます。これらのポート番号をブロックする必要がある場合は、ポート番号をブロックするためのアクセス リストを設定します。

Q. ポイントツーポイント サブインターフェイスとマルチポイント サブインターフェイスの違いは何ですか。

A. ポイントツーポイント インターフェイスはシリアル通信で使用されます。この種類の接続は、反対側の終端にあるステーションにのみ送信する目的で使用されます。ポイントツーポイントの例には、EIA/TIA 232、EIA/TIA 449、X.25、フレームリレー、T キャリア、OC3 - OC192 があります。

ポイントツーマルチポイントでは、1 つのステーションが他の複数のステーションに接続されます。ポイントツーマルチポイントには次の 2 種類があります。

  • ポイントツーマルチポイント非ブロードキャスト

  • ポイントツーマルチポイント ブロードキャスト

ポイントツーマルチポイント非ブロードキャストでは、通信がすべてのリモート ステーションに対して複製されます。この複製された通信を受信できるのは、特定の選択されたステーションだけです。この例として、フレームリレーや ATM があります。

ポイントツーマルチポイント ブロードキャストの特徴は、すべてのマシンに物理メディアが接続され、すべてのステーションですべての通信が受信されることです。

Q. 同じメイン インターフェイスの複数のサブインターフェイスに異なる MTU を設定できますか。このシナリオでは、75000 ルータ、GSR ルータ、または ESR ルータはどのように動作するのですか。

A. ip mtu コマンドを使用すると、異なる IP MTU を別々のサブインターフェイスに設定できます。あるサブインターフェイスの MTU を変更すると、ルータによってメイン インターフェイスの MTU がチェックされます。メイン インターフェイスに設定された MTU の値がサブインターフェイスに設定された MTU の値よりも小さい場合は、ルータによってメイン インターフェイスの MTU の値がサブインターフェイスと同等の MTU の値に変更されます。したがって、mtu コマンドでメイン インターフェイスに設定された物理 MTU は、サブインターフェイスに設定される IP MTU よりも大きい値である必要があります。

パケット メモリは、75000 または GSR に設定された MTU のうち最高の値に基づいて調整されます。ただし、Engine 4 以上のラインカードは例外であり、MTU の変更に応じてバッファを調整する必要がありません。ESR では、パケット メモリはブート時に調整されるため、MTU 設定によっては影響を受けません。そのため、MTU を変更しても、ESR には影響がありません。

Q. お客様がネットワークにアクセスする場合のセッション数を制限するにはどうすればよいのですか。

A. お客様が同じ IP アドレスを使用する場合は、ppp ipcp address unique コマンドを使用して、お客様が使用するセッション数を減少できます。

Q. アカウンティング データ経過時間はどのように計算されるのですか。

A. アカウンティング データ経過時間は、IP アカウンティングが有効にされたときから 1 分ごとに値が 1 ずつ増加します。clear ip accounting コマンドが発行されるまではこれが続きますが、このコマンドが発行されると値が 0 にリセットされます。

Q. IP SLA 動作における「しきい値」と「タイムアウト」という用語の意味は何ですか。

A. しきい値では、IP SLA 動作の対応するイベントを生成して履歴情報を格納する上昇しきい値が設定されます。

タイムアウトでは、IP SLA 動作で要求パケットに対する応答を待機する時間が設定されます。

Q. ルーティング テーブル エントリにおける時間(Time)の重要性は何ですか。

A. これは、ルーティング テーブル内のルートの経過時間です。つまり、そのルートがルーティング テーブル内に存在している時間です。

Q. Network Descriptor Block(NDB; ネットワーク記述子ブロック)とは何ですか。

A. これは、Routing Descriptor Block(RDB; ルーティング記述子ブロック)とともに「ルーティング テーブル」に格納されるネットワーク情報です。IP ルーティング テーブルの学習されたプレフィクスを保持するメモリは、NDB と RDB に分けられます。Routing Information Base(RIB; ルーティング情報ベース)内の各ルートでは、それぞれのパスに対して 1 つの NDB と 1 つの RDB が必要です。ルートがサブネット化されている場合は、NDB を保持するために追加のメモリが必要です。IP RIB による直接のメモリ使用状況は、show ip route summary コマンドで表示できます。


関連するシスコ サポート コミュニティ ディスカッション

シスコ サポート コミュニティは、どなたでも投稿や回答ができる情報交換スペースです。


関連情報


Document ID: 28745