アベイラビリティ : ハイ アベイラビリティ

Object Tracking を使用したスタティックルーティングバックアップ設定例

2006 年 6 月 29 日 - 日本オリジナル版
その他のバージョン: PDFpdf | フィードバック

1. ネットワーク構成図

設定の前提となるネットワーク構成図になります。

※ 画像をクリックすると、大きく表示されます。popup_icon


2. システムの前提条件

2つの拠点にて Cisco ISR サービス統合型ルータを使用し、広域イーサネットサービスを接続します。回線障害時に、バックアップ回線として ISDN を使用するための設定を行います。

3. 想定する環境

本店、支店を広域イーサネットサービスを用いて接続します。また障害時のバックアップ回線として、支店側では BRI で INS64 を使用し、本店側では PRI で INS1500 を使用します。

ルーティングプロトコルはスタティックルートを使用し、支店より本店の広域イーサネットの接続インターフェースを ICMP にて監視を行います。
これにより、インターフェースのダウンを伴わない、支店 LAN - TA - 広域イーサネット間の回線障害、広域イーサネット網障害、本店LAN - TA - 広域イーサネットの回線障害、本店ルータインターフェースダウン、ルータダウンなどの障害時にも、支店側では障害を検知し、ISDN にてバックアップを行います。

4. 必要なハードウェア/ソフトウェア要件

Cisco ISR サービス統合型ルータ シリーズは全てオンボードにて 2FE(もしくは 2GE)を具備します。Cisco ISR シリーズにて本構成が実現可能なハードウェア / ソフトウェアの組み合わせは下記になります。
※下記はルータにて BRI インターフェース、PRI インターフェースを具備した場合の構成となります。Serial インターフェースなどで TA と接続する際には HWIC-4T などが必要となります。

支店側(BRI インターフェース)

プラットホーム モジュール T トレイン メイントレイン
1812J Onboad 12.4(2)T 以上 N/A
1841/2801 WIC-1B-S/T-V3
WIC-1B-U-V2
12.3(8)T 以上 12.4(1)以上
2811/2821/2851 WIC-1B-S/T-V3
WIC-1B-U-V2
NM-4B-S/T
NM-4B-U
NM-8B-S/T
NM-8B-U
12.3(8)T 以上 12.4(1)以上
3825/3845 WIC-1B-S/T-V3
WIC-1B-U-V2
NM-4B-S/T
NM-4B-U
NM-8B-S/T
NM-8B-U
12.3(11)T 以上 12.4(1)以上


本店側(PRI インターフェース)

プラットホーム モジュール T トレイン メイントレイン
2811/2821/2851 NM-1CE1T1-PRI
NM-2CE1T1-PRI
12.3(8)T 以上 12.4(1)以上
3825/3845 NM-1CE1T1-PRI
NM-2CE1T1-PRI
12.3(11)T 以上 12.4(1)以上

本設定例では、支店側 1812-J 12.4(4)T、本店側 2811 NM-1CET1-PRI 12.4(2)T2 を使用しています。

5. サンプルコンフィグレーション

1. 1812J-A


hostname C1812J-A
!
ip subnet-zero
!
ip cef
!
ip sla 1
icmp-echo 192.168.254.254 source-interface FastEthernet0
timeout 5
frequency 10
ip sla schedule 1 life forever start-time now
!
isdn switch-type ntt
!
username C2811 password 0 cisco
!
track 101 rtr 1 reachability

!
interface Loopback0
ip address 192.168.255.1 255.255.255.255
!
interface FastEthernet0
ip address 192.168.254.1 255.255.255.0
duplex full
speed 100
!
interface BRI0
no ip address
encapsulation ppp
dialer pool-member 1
isdn switch-type ntt
ppp authentication chap

!
interface FastEthernet3
switchport access vlan 10
!
interface Vlan10
ip address 192.168.10.254 255.255.255.0
!
interface Dialer1
ip unnumbered Loopback0
encapsulation ppp
dialer pool 1
dialer remote-name TLS
dialer string 12345678
dialer-group 1
ppp authentication chap
ppp chap hostname C1812J-A
ppp chap password 0 cisco
!
ip local policy route-map LOCAL-POLICY

ip classless
ip route 0.0.0.0 0.0.0.0 192.168.254.254 track 101
ip route 0.0.0.0 0.0.0.0 Dialer1 254

!
access-list 101 permit icmp any host 192.168.254.254 echo
dialer-list 1 protocol ip permit

!
route-map LOCAL-POLICY permit 10
match ip address 101
set interface Null0
set ip next-hop 192.168.254.254

!
end

2. 2811


hostname C2811
!
card type t1 1
!
ip subnet-zero
!
ip cef
!
isdn switch-type primary-ntt
!
username C1812J-A password 0 cisco
!
controller T1 1/0
framing esf
linecode b8zs
cablelength long 0db
pri-group timeslots 1-24

!
interface Loopback0
ip address 192.168.255.254 255.255.255.255
!
interface FastEthernet0/0
ip address 192.168.254.254 255.255.255.0
duplex full
speed 100
!
interface FastEthernet0/1
ip address 192.168.1.254 255.255.255.0
duplex auto
speed auto
!
interface Serial1/0:23
no ip address
encapsulation ppp
dialer pool-member 1
isdn switch-type primary-ntt
ppp authentication chap
!
interface Dialer1
ip unnumbered Loopback0
encapsulation ppp
dialer pool 1
dialer remote-name C1812J-A
dialer idle-timeout 10 inbound
dialer-group 1
ppp authentication chap
ppp chap hostname C2811
ppp chap password 0 cisco

!
ip classless
ip route 192.168.10.0 255.255.255.0 192.168.255.1
ip route 192.168.10.0 255.255.255.0 192.168.254.1 254
!
dialer-list 1 protocol ip permit

!
end

6. キーとなるコマンドの解説

----------------------------
"username C2811 password 0 cisco"
<コマンド種別>
グローバルコンフィグレーションコマンド
<コマンドの機能>
ユーザ名およびパスワードを指定します。これはPPPセッション確立時に使用されます。
本設定例ではパスワードは簡略化のために暗号化なし(0)で記載しております。必要に応じ暗号化(7)にて設定してください。
----------------------------
"interface Dialer1"
<コマンド種別>
グローバルコンフィグレーションコマンド
<コマンドの機能>
Dialer 1 論理 インタフェースを定義します。PPP セッションは、この Dialer インタフェースにより終端されます。また、PPP セッションはダイアラーの動作により確立要求されます。
----------------------------
"ip unnumbered Loopback0"
<コマンド種別>
インタフェースコンフィグレーションコマンド
<コマンドの機能>
PPP セッション確立時に使用する IP アドレスとしてループバック 0 を指定します。
----------------------------
" encapsulation ppp"
<コマンド種別>
インタフェースコンフィグレーションコマンド
<コマンドの機能>
このインタフェースは PPP カプセル化によりパケットの入出力をします。
----------------------------
"dialer pool 1"
<コマンド種別>
インタフェースコンフィグレーションコマンド
<コマンドの機能>
Dialer1 論理インタフェースと実際 にPPP 接続する物理インタフェースが紐付けられます。
"dialer pool 1" と BRI0 インタフェースの" dialer pool-member 1"コマンドの番号 1 が対応します。
----------------------------
"dialer-group 1"
<コマンド種別>
インタフェースコンフィグレーションコマンド
<コマンドの機能>
"dialer-list 1"で定義されたトラフィックパターンを本 Dialer インタフェースに適用します。
このトラフィックがダイアル対象として認識され本 Dialer インタフェースから出て行くときに、PPP セッションの確立要求を起動します。
----------------------------
"ppp authentication chap"
<コマンド種別>
インタフェースコンフィグレーションコマンド
<コマンドの機能>
接続先にアクセスする際の認証方法を CHAP に指定します。
----------------------------
"ppp chap hostname C1812J-A"
<コマンド種別>
インタフェースコンフィグレーションコマンド
<コマンドの機能>
PPP の CHAP または PAP 認証(本事例では CHAP)を行なう際に必要なユーザー名を設定します。
----------------------------
"ppp chap password 0 cisco"
<コマンド種別>
インタフェースコンフィグレーションコマンド
<コマンドの機能>
PPP の CHAP または PAP 認証(本事例では CHAP)を行なう際に必要なパスワードを設定します。本事例では、"cisco"というパスワードを設定しています。
----------------------------
"dialer remote-name C2811"
<コマンド種別>
インタフェースコンフィグレーションコマンド
<コマンドの機能>
PPP のピアルータ名を指定します。
----------------------------
"dialer string 12345678"
<コマンド種別>
インタフェースコンフィグレーションコマンド
<コマンドの機能>
PPP のピアルータの電話番号を指定します。
----------------------------
"dialer idle-timeout 10 inbound"
<コマンド種別>
インタフェースコンフィグレーションコマンド
<コマンドの機能>
インバウンドパケットに対しアイドルタイムアウト秒を指定します。
支店より本店に対してのトラフィック回線上を流れない際には、10 秒で切断されます。
----------------------------
"isdn switch-type ntt"
<コマンド種別>
インタフェースコンフィグレーションコマンド
<コマンドの機能>
ISDN のスイッチタイプを指定します。
----------------------------
"ip route 0.0.0.0 0.0.0.0 Dialer1 254"
<コマンド種別>
グローバルコンフィグレーションコマンド
<コマンドの機能>
デフォルトルートとして Dialer1 が指定し、ディスタンスメトリックを 254 に指定します。
----------------------------
"dialer-list 1 protocol ip permit"
<コマンド種別>
グローバルコンフィグレーションコマンド
<コマンドの機能>
すべての IP トラフィックをダイアルアップ対象にします。
----------------------------
"ip sla 1"
<コマンド種別>
グローバルコンフィグレーションコマンド
<コマンドの機能>
IP の SLAを定義します。
----------------------------
"icmp-echo 192.168.254.254 source-interface FastEthernet0"
<コマンド種別>
IP SLA コンフィグレーションコマンド
<コマンドの機能>
icmp-echo を送信する宛先 IP アドレスおよび送信元になるインタフェースを指定します。
----------------------------
"timeout 5"
<コマンド種別>
グローバルコンフィグレーションコマンド
<コマンドの機能>
Icmp Echo リクエストに対する応答を待つ時間をミリ秒で指定します。
ご使用になるネットワークの状態により調整をして下さい。
----------------------------
"frequency 10"
<コマンド種別>
config-ip-sla コンフィグレーションコマンド
<コマンドの機能>
icmp-echo リクエストを送信する周期を秒で指定します。
----------------------------
"ip sla schedule 1 life forever start-time now"
<コマンド種別>
グローバルコンフィグレーションコマンド
<コマンドの機能>
定義された IP SLA スケジュールの動作時間を無期限に、 開始時間を"now"と指定し、sla プロセスを開始します。
----------------------------
"track 101 rtr 1 reachability"
<コマンド種別>
グローバルコンフィグレーションコマンド
<コマンドの機能>
トラックするオブジェクトを指定し、定義された IP SLA 番号を割り当てます。
----------------------------
"ip route 0.0.0.0 0.0.0.0 192.168.254.254 track 101"
<コマンド種別>
グローバルコンフィグレーションコマンド
<コマンドの機能>
デフォルトルートにトラックするオブジェクト番号を指定します。
----------------------------
"route-map LOCAL-POLICY permit 10"
<コマンド種別>
グローバルコンフィグレーションコマンド
<コマンドの機能>
ルートマップを作成します。
----------------------------
"match ip address 101"
<コマンド種別>
config-route-map コンフィグレーションコマンド
<コマンドの機能>
マッチ条件としてアクセスリスト番号を指定します。
----------------------------
"set ip next-hop 192.168.254.254"
<コマンド種別>
config-route-map コンフィグレーションコマンド
<コマンドの機能>
マッチ条件に一致した場合のアクションとしてネクストホップを指定します。
----------------------------
"set interface Null0"
<コマンド種別>
config-route-map コンフィグレーションコマンド
<コマンドの機能>
マッチ条件に一致した場合のアクションとしてインタフェースを指定します。
----------------------------
"ip local policy route-map LOCAL-POLICY"
<コマンド種別>
グローバルコンフィグレーションコマンド
<コマンドの機能>
ルートマップの定義をルータローカルのポリシーとして指定します。
----------------------------
"access-list 101 permit icmp any host 192.168.254.254 echo"
<コマンド種別>
グローバルコンフィグレーションコマンド
<コマンドの機能>
ルートマップのマッチ条件に使用されるアクセスリストを定義します。
----------------------------
"controller T1 1/0"
<コマンド種別>
グローバルコンフィグレーションコマンド
<コマンドの機能>
設定する CT1/PRI インターフェースを選択します。
----------------------------
"framing esf"
<コマンド種別>
コントローラーコマンド
<コマンドの機能>
ISDN 回線に使用するフレーム形式を指定します。
INS ネット 1500 の場合は"esf"を指定します。
----------------------------
"linecode b8zs"
<コマンド種別>
コントローラーコマンド
<コマンドの機能>
ISDN 回線に使用するフレーム形式を指定します。
INS ネット 1500 の場合は"esf"を指定します。
----------------------------
"cablelength long 0db"
<コマンド種別>
コントローラーコマンド
<コマンドの機能>
送信シグナルの減衰値を指定します。デフォルトでは 0db です。
----------------------------
"pri-group timeslots 1-24"
<コマンド種別>
コントローラーコマンド
<コマンドの機能>
ISDN 回線に使用するダイアルアップ用のチャンネル数を指定します。指定した後は、ダイアルアップ用のインタフェース(Interface Serial0:23)が作成されます。
INS ネット 1500 の場合は"timeslots 1-24"を指定します。
----------------------------

7. 設定に際しての注意点

ルータと接続する LAN-TA のインターフェースにあわせ、speed や duplex の設定を行ってください。

1812J や 871 の様な SW 内蔵のプラットホームまたは HWIC-4ESW/HWIC-9DESW などのスイッチモジュールを使用し、vlan を使用する際には、vlan database コマンドにて追加する vlan を指定する必要があります。

支店にて生成された ICMP が Dialer インターフェース側を通らないように、route-map を作成しているのを注意してください。

BRIインターフェースには下記DDTSが存在します。

CSCei13743 BRI interface unable to make calls (send INFO 1)
本 DDTS が修正されている、 12.4(3.6)、12.4(3.6)T、12.3(11)T08、12.3(16.7)、12.4(03a) 以降の IOS の使用を推奨します。

ip sla コマンドは 12.3(14)T、12.4(1)より変更になっております。
変更前のコマンドは下記のとおりです。

Command in Cisco IOS Release 12.3 Replacement Command in Cisco IOS Release 12.4
rtr operation-id ip sla monitor operation-number
rtr schedule ip sla monitor schedule

実際に導入し、運用される際には障害解析などの観点により下記の様なコマンドも追加する事を推奨いたします。

service timestamps debug datetime localtime msec
service timestamps log datetime localtime msec
clock timezone JST 9
!
logging buffered 512000 debugging
!
clock calendar-valid


Updated: Jun 29, 2006 Document ID: jtac_20060127_15