マルチプロトコル ラベル スイッチング(MPLS) : VPN 用マルチプロトコル ラベル スイッチング(MPLS for VPN)

IP-VPN(MPLS VPN サービス)接続を実現するカスタマーエッジルータ設定例

2006 年 1 月 27 日 - 日本オリジナル版
その他のバージョン: PDFpdf | フィードバック

1. ネットワーク構成図

設定の前提となるネットワーク構成図になります。

※ 画像をクリックすると、大きく表示されます。popup_icon


2.システムの前提条件

IP-VPN(MPLS VPN)サービスへの接続において、Cisco ISR サービス統合型ルータシリーズを利用し、拠点間通信を実現する為の設定を行います。

3.想定する環境

IP-VPN(MPLS VPN)サービス利用し、各拠点間で BGP を用いて接続します。IP-VPN へのアクセス回線はイーサネットを想定します。

4. 必要なハードウェア/ソフトウェア要件

Cisco ISR サービス統合型ルータ シリーズは全てオンボードにて 2FE(もしくは 2GE)を具備します。Cisco ISR シリーズにて本構成が実現可能なハードウェア/ソフトウェアの組み合わせは下記になります。

プラットホーム T トレイン メイントレイン
871 12.4(2)T 以上 N/A
1812J 12.4(2)T 以上 N/A
1841 12.3(8)T 以上 12.4(1)以上
2800 シリーズ
(2801/2811/2821/2851)
12.3(8)T 以上 12.4(1)以上
3800 シリーズ
(3825/3845)
12.3(11)T 以上 12.4(1)以上

本設定例においては、本社側:Cisco2811 IOS12.4(2)T2、支社側:Cisco1812J IOS12.4(2)T2 を使用しています。


5. サンプルコンフィグレーション

1. 1812J-A


hostname 1812J-A
!
ip subnet-zero
!
ip cef
!
policy-map shaping
class class-default
shape average 3000000
!
interface FastEthernet0
bandwidth 3000
ip address 192.168.10.1 255.255.255.0
speed 10
full-duplex
service-policy output shaping
!
interface FastEthernet3
switchport access vlan 10

!
interface Vlan10
ip address 192.168.1.254 255.255.255.0
!
router bgp 65000

no synchronization
bgp log-neighbor-changes
network 192.168.1.0
neighbor 192.168.10.2 remote-as 109

no auto-summary
!
ip classless

2. 2811


hostname 2811
!
ip subnet-zero
!
ip cef
!
policy-map shaping
class class-default
shape average 3000000
!
interface FastEthernet0/0
bandwidth 3000
ip address 192.168.20.1 255.255.255.0
duplex full
speed 10
service-policy output shaping
!
interface FastEthernet0/1
ip address 192.168.101.254 255.255.255.0

duplex auto
speed auto
!
router bgp 65000
no synchronization
bgp log-neighbor-changes
network 192.168.101.0
neighbor 192.168.20.2 remote-as 109

no auto-summary
!
ip classless

6. キーとなるコマンドの解説

----------------------------
"ip cef"
<コマンド種別>
 グローバルコンフィグレーションコマンド
<コマンドの機能>
ルーター上で Cisco Express Forwarding (CEF) を有効にします。(デフォルトで有効)
----------------------------
"policy-map policy-name"
<コマンド種別>
グローバルコンフィグレーションコマンド
<コマンドの機能>
トラフィックポリシーを作成します。下記 class コマンドにて定義された QoS アクションを実施します。
----------------------------
"class class-default"
<コマンド種別>
ポリシーマップコンフィグコマンド
<コマンドの機能>
class-map にて定義されたもの以外のトラフィッククラスを指定します。定義のない場合はトラフィックはこのデフォルトクラスを使用します。
----------------------------
"shape average mean-rate "
<コマンド種別>
ポリシーマップコンフィグコマンド
<コマンドの機能>
指定したレートにトラフィックをシェーピングします。単位は bit/s です。
----------------------------
"service-policy output policy-map-name"
<コマンド種別>
インターフェースコマンド
<コマンドの機能>
設定したトラフィックポリシーを出力インターフェースに割り当てます。
----------------------------
"interface vlan Vlan interface number"
<コマンド種別>
グローバルコンフィグレーションコマンド
<コマンドの機能>
設定した VLAN の論理インターフェースを設定します。
----------------------------
"switchport access vlan VLAN ID"
<コマンド種別>
インターフェースコマンド
<コマンドの機能>
物理インターフェースに、設定した VLAN を割り当てます。
----------------------------
"router bgp Autonomous system number"
<コマンド種別>
グローバルコンフィグレーションコマンド
<コマンドの機能>
BGP を有効にし、ローカル AS(自律システム)番号を指定します。
----------------------------
"neighbor Neighbor address remote-as Autonomous system number"
<コマンド種別>
ルータ BGP コマンド
<コマンドの機能>
異なる自律システムにあるルータとローカルルータ間のピアリングを行います。ピアリングする対向のインターフェース IP アドレス、対向の AS 番号を指定します。
----------------------------
"network Network number mask Network mask"
<コマンド種別>
ルータ BGP コマンド
<コマンドの機能>
自律システムからアドバタイズしたいネットワークを指定します。
----------------------------
"no synchronization"
<コマンド種別>
ルータ BGP コマンド
<コマンドの機能>
BGP テーブルとIPテーブルの同期を off にします(デフォルトで有効)。このコマンドにより IBGP により学習されたルート情報は IGP により学習されなくても広報することが可能になります。
----------------------------
"bgp log-neighbor-changes"
<コマンド種別>
ルータ BGP コマンド
<コマンドの機能>
BGP ピアの起動時、障害時、またはリセット時に生成されるメッセージをログに書き込みます(デフォルトで有効)。
----------------------------
"no auto-summary"
<コマンド種別>
ルータ BGP コマンド
<コマンドの機能>
BGP のクラスフルな自動経路集約を off にします(デフォルトで有効)。指定しない場合はデフォルトクラスの集約ルートがPEルータに広報されます。
----------------------------

7. 設定に際しての注意点

IP-VPN サービスを導入する際には、BGP の AS 番号や IP-VPN サービスに広報するネットワークを事前に申し込む必要があります。

ルータと接続する LAN-TA のインターフェースにあわせ、speed や duplex の設定を行ってください。

1812J や 871 の様な SW 内蔵のプラットホームまたは HWIC-4ESW/HWIC-9DESW などのスイッチモジュールを使用し、vlan を使用する際には、vlan database コマンドにて追加する vlan を指定する必要があります。

実際に導入し、運用される際には障害解析などの観点により下記の様なコマンドも追加する事を推奨いたします。

service timestamps debug datetime localtime msec
service timestamps log datetime localtime msec
clock timezone JST 9
!
logging buffered 512000 debugging
!

Jan 27, 2006 Document ID: jtac_20060127_12