音声とユニファイド コミュニケーション : Cisco Unified Border Element

Cisco Unified Communications Manager(CUCM)を使用した Unified Border Element(CUBE)の設定例

2016 年 10 月 27 日 - 機械翻訳について
その他のバージョン: PDFpdf | ライター翻訳版 (2008 年 12 月 8 日) | 英語版 (2015 年 8 月 22 日) | フィードバック


目次


概要

Cisco Unified Border Element を使用すると、企業向ユニファイド コミュニケーションの Session Initiation Protocol(SIP; セッション開始プロトコル)トランクと公衆電話交換網(PSTN)との間にシンプルでコストパフォーマンスのよい接続を確立できます。 企業に会うように設計し、(SBC は) service-provider セッション ボーダー コントローラ デバイスが必要とする、Cisco Unified Border Element (CUBE)統合 Cisco IOS ですか。 動作するソフトウェアアプリケーション:

  • Cisco 2800 シリーズ サービス統合型ルータ

  • Cisco 3800 シリーズ サービス統合型ルータ

  • Cisco 2600XM シリーズ マルチサービス プラットフォーム

  • Cisco 3700 シリーズ ルータ

  • Cisco 7200VXR シリーズ ルータ

  • Cisco 7301 ルータ

  • Cisco AS5400XM および AS5350XM アクセス ゲートウェイ

従来の公衆電話交換網(PSTN)の時分割多重(TDM)による相互接続と比べ、ユニファイド コミュニケーション ネットワーク間の直接 IP 接続は、新しいサービスにより柔軟に対応できます。

Cisco Unified Border Element では、次の目的のためのネットワーク間相互接続点が提供されます。

  • シグナリング インターワーキング:H.323、SIP

  • メディア インターワーキング:DTMF(Dual Tone MultiFrequency)、FAX、モデム、コーデック変換

  • アドレスおよびポートの変換:プライバシーとトポロジの隠蔽

  • 請求および呼詳細レコード(CDR)の正規化

  • Quality of Service(QoS)および帯域幅の管理:Differentiated Service Code Point(DSCP)またはタイプ オブ サービス(ToS)を使用した QoS マーキング、リソース予約プロトコル(RSVP)およびコーデック フィルタリングを使用した帯域幅強制

Cisco Unified Border Element は、Cisco Unified Communications Manager や Cisco Unified Communications Manager Express を使用する高度なエンタープライス音声/ビデオ サービスから、シンプルなトール バイパス アプリケーションや VoIP(Voice over IP)転送アプリケーションまで、多種多様なアプリケーション環境内にある多種多様なネットワーク要素(音声ゲートウェイ、IP 電話、コール制御サーバなど)と相互運用します。

Cisco Unified Border Element は組織に対し、ネットワーク層にすべての境界コントローラ機能を統合して提供し、エンタープライズとサービスプロバイダー間の音声とビデオの統合された通信用アーキテクチャを相互接続します。 企業や中小規模の組織は Cisco Unified Border Element を使用して、SIP PSTN アクセスと SIP および H.323 による企業の統合された通信用ネットワークとを相互接続します。

前提条件

要件

このドキュメントに関する固有の要件はありません。

使用するコンポーネント

このドキュメントの情報は、Cisco Unified Border Element(CUBE)に基づくものです。

このドキュメントの情報は、特定のラボ環境にあるデバイスに基づいて作成されたものです。 このドキュメントで使用するすべてのデバイスは、クリアな(デフォルト)設定で作業を開始しています。 ネットワークが稼働中の場合は、コマンドが及ぼす潜在的な影響を十分に理解しておく必要があります。

表記法

ドキュメント表記の詳細は、『シスコ テクニカル ティップスの表記法』を参照してください。

設定

この項では、このドキュメントで説明する機能の設定に必要な情報を提供します。

このセクションで使用されているコマンドの詳細を調べるには、Command Lookup Tool登録ユーザ専用)を使用してください。

設定

この設定により、プラットフォーム上で基本的な Cisco Unified Border Element 機能を有効にできます。 この機能により、着信 VoIP コールが終端され、発信 VoIP ダイヤルピアを使用してこのコールが再発信されます。 コールは H.323 から SIP、または SIP から SIP です。

voice service voip
allow-connections h323 to sip
allow-connections sip to h323
allow-connections sip to sip
allow-connections h323 to h323

該当するプロトコル、DTMF タイプ、およびコーデック情報を使用して着信および発信ダイヤルピアを設定します。

dial-peer voice 1 voip
session target ipv4:10.13.8.150
incoming called-number 8...
dtmf-relay h245-alphanumeric
codec g711ulaw
!
dial-peer voice 2 voip
destination-pattern 8...
session protocol sipv2
session target ipv4:10.13.8.16
dtmf-relay rtp-nte
codec g711ulaw

SIP ユーザ エージェントの設定

登録と認証のための SIP ユーザ エージェント(UA)の設定

SIP ユーザ エージェント(UA)
sip-ua
registrar ipv4:10.1.1.10
or
registrar dns:csps.cisco.com
authentication username xyz password xyz realm cisco.com

Cisco Unified Communications Manager との相互接続

Cisco Unified Communications Manager は、H.323 や SIP のユニファイド コミュニケーション トランクを使用して Cisco Unified Border Element と相互接続できます。

Cisco Unified Border Element への H.323 トランク

Cisco Unified Communications Manager で Cisco Unified Border Element に H.323 トランクを定義する方法には、次の 2 種類があります。

  • ゲートキーパーあり:Cisco Unified Border Element に対する H.225 トランク(GK 制御)を設定します。

  • ゲートキーパーなし:Cisco Unified Border Element を H.323 ゲートウェイとして設定します。

メディア ターミネーション ポイント(MTP)の要件:

  • Cisco Unified Border Element が H.323 から H.323 へのコールを行う場合、Cisco Unified Border Element のリリースが 12.4(6)T 以降で Cisco Unified Communications Manager がバージョン 4.1 以降であれば、MTP は必須ではありません。

  • ハードウェアまたはソフトウェア MTP は、Cisco Unified Border Element と同じルータに共存できます(CUCM MTP をサポートするルータ プラットフォーム上。これには Cisco 2800 シリーズや 3800 シリーズの ISR があります)。

H.323 Fast Start の要件:

  • Cisco Unified Border Element が Cisco Unified Communications Manager のために H.323 から SIP へのインターワーキングを行う場合、大部分の SIP プロキシ サーバでは SIP コールがアーリー オファー(Early Offer)である必要があります。 つまり、H.323 側が H.323 Fast Start である必要があります。 そのため、Cisco Unified Communications Manager は着信および発信 H.323 Fast Start 用に設定する必要があり、MTP も必要になります。

図 1 は、Cisco Unified Communications Manager で H.323 ゲートウェイとして定義された Cisco Unified Border Element の設定を示しています。

図 1. Cisco Unified Communications Manager で H.323 ゲートウェイとして定義された Cisco Unified Border Element の設定

/image/gif/paws/99863/cube-config01.gif

cube-config02.gif

図 2 は、前述の Cisco Unified Communications Manager 設定に適合する Cisco Unified Border Element の設定を示しています。

図 2. H.323 トランクのための Cisco Unified Border Element の設定

cube-config03.gif

Cisco Unified Border Element への SIP トランク

Cisco Unified Border Element に対するユニファイド コミュニケーション SIP トランクを定義するためには、Cisco Unified Communications Manager バージョン 5.x 以降が必要です。

MTP の要件:

  • MTP なしの SIP トランク:ディレイド メディア(delayed media)または SDP なしの INVITE が許可される場合、MTP なしのユニファイド コミュニケーション SIP トランクを設定します。

  • MTP ありの SIP トランク:アーリー メディア(early media)または SDP ありの INVITE が必須である場合、ユニファイド コミュニケーション SIP トランク(MTP あり)を設定します(G.711 コールのみ)。

図 3 は、Cisco Unified Communications Manager へのユニファイド コミュニケーション SIP トランクで定義された Cisco Unified Border Element の設定を示しています。

図 3: Cisco Unified Communications Manager への SIP トランクでの Cisco Unified Border Element の設定

/image/gif/paws/99863/cube-config04.gif

図 4 は、前述の Cisco Unified Communications Manager 設定に適合する Cisco Unified Border Element の設定を示しています。

図 4. SIP トランクのための Cisco Unified Border Element の設定

/image/gif/paws/99863/cube-config05.gif

Cisco Unified Border Element との MTP の共存

ソフトウェア MTP が Cisco Unified Communications Manager 設定に必要である場合、これは Cisco Unified Border Element に使用するのと同じルータ上で設定できます。

Cisco Unified Border Element での MTP の設定を次に示します。

sccp local FastEthernet0/1

sccp ccm 15.5.34.1 identifier 1 version 4.1

sccp

!

sccp ccm group 1

associate ccm 1 priority 1

associate profile 1 register MTP

!

dspfarm profile 1 mtp

codec g711ulaw

maximum sessions software 100

associate application SCCP

Cisco Unified Border Element のトランスコーディング

Cisco Unified Border Element は G.729 の G.711? law/a 関連法規とさまざまなフレーバーの間でトランスコードすることをすることができます。 トランスコーディングは、Cisco Unified Communications Manager から PSTN へ発信されたコールであるか PSTN から Cisco Unified Communications Manager へ発信されたコールであるかを問わず、すべてのコールに対して起動できます。 主な基準は、Cisco Unified Border Element での 2 つのコールレッグが別々のコーデック(G.711 と G.729)であるかどうかです。 Cisco Unified Border Element でトランスコーディングを設定するには、プラットフォーム上で DSP が使用可能である必要があります。

Cisco Unified Border Element でのトランスコーディングの設定を次に示します。

voice-card 2

dspfarm

dsp services dspfarm

sccp local FastEthernet 0/0

sccp ccm 200.1.1.100 identifier 1

sccp

!

sccp ccm group 1

associate ccm 1 priority 1

associate profile 1 register MTP123456782012

keepalive retries 5

switchover method immediate

switchback method immediate

switchback interval 15

!

dspfarm profile 1 transcode

codec g711ulaw

codec g711alaw

codec g729ar8

codec g729abr8

codec gsmfr

codec g729r8

maximum sessions 5

associate application SCCP

telephony-service

load 7960-7940 P00303020214

max-ephones 48

max-dn 48

ip source-address 200.1.1.100 port 2000

sdspfarm units 1

sdspfarm transcode sessions 50

sdspfarm tag 1 MTP123456782012

create cnf-files version-stamp 7960 Jul 29 2002 13:50:03

Cisco Unified Border Element での Tcl IVR の使用

Cisco Unified Border Element は Tcl スクリプトをサポートします。これらのスクリプトは VoIP ダイヤルピア上で設定できます。 Tcl 機能の使用に DSP は不要です。 Cisco IOS ソフトウェアには多数の Tcl アプリケーションがすでに組み込まれており、Cisco Unified Border Element の配備に使用できます。 コールの認証と認可を提供するために、Cisco IOS の AAA(認証、認可、アカウンティング)機能を Tcl スクリプトと Cisco Unified Border Element とともに使用することもできます。

aaa new-model

!

aaa authentication login h323 group radius

aaa authorization exec h323 local group radius

aaa accounting exec h323 start-stop group radius

!

application

service debitcard tftp://15.5.27.11/app_debitcard.2.0.2.8.tcl

paramspace english index 1

paramspace english language en

paramspace english location tftp://15.5.27.11/prompts/en/

param pid-len 4

paramspace english prefix en

param uid-len 6

!

gw-accounting aaa

!

radius-server host 15.5.27.11 auth-port 1645 acct-port 1646

radius-server timeout 10

radius-server key lab

radius-server vsa send accounting

radius-server vsa send authentication

全体の設定例

router#show run
Building configuration...
Current configuration : 1122 bytes
!
version 12.3
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname IPIPGW-1
!
boot-start-marker
boot-end-marker
!
no network-clock-participate aim 0
no network-clock-participate aim 1
no aaa new-model
ip subnet-zero
ip cef
!
! aaa new-model
!
aaa authentication login h323 group radius
aaa authorization exec h323 local group radius
aaa accounting exec h323 start-stop group radius
!
application
service debitcard tftp://15.5.27.11/app_debitcard.2.0.2.8.tcl
paramspace english index 1
paramspace english language en
paramspace english location tftp://15.5.27.11/prompts/en/
param pid-len 4
paramspace english prefix en
param uid-len 6
!
gw-accounting aaa
!
radius-server host 15.5.27.11 auth-port 1645 acct-port 1646
radius-server timeout 10
radius-server key lab
radius-server vsa send accounting
radius-server vsa send authentication
!
no ip domain lookup
no ftp-server write-enable
!
voice service voip
allow-connections h323 to sip 

!--- key command

allow-connections sip to h323 

!--- key command

allow-connections sip to sip 

!--- key command

allow-connections h323 to h323 

!--- key command

!
interface FastEthernet0/0
ip address 200.1.1.100 255.255.255.0
duplex auto
speed auto
!
interface FastEthernet0/1
no ip address
shutdown
duplex auto
speed auto
!
ip classless
ip route 0.0.0.0 0.0.0.0 200.1.1.1
ip http server
!
control-plane
!
dial-peer voice 1 voip
application debitcard 

!--- TCL Application

session target ipv4:9.13.8.150
incoming called-number 8...
dtmf-relay h245-alphanumeric 

!--- DTMF config for h.245 alphanumeric

codec g711ulaw
!
dial-peer voice 2 voip
destination-pattern 8...
session protocol sipv2
session target ipv4:9.13.8.16
dtmf-relay rtp-nte 

!--- DTMF config for RFC2833

codec g711ulaw
!
gatekeeper
shutdown
sip-ua
registrar ipv4:200.1.1.10 or registrar dns:csps.cisco.com
authentication username xyz password xyz realm cisco.com
!
line con 0
line aux 0
line vty 0 4
login
!
end

確認

現在、この設定に使用できる確認手順はありません。

トラブルシューティング

ここでは、設定のトラブルシューティングに役立つ情報について説明します。

トラブルシューティングのためのコマンド

Output Interpreter Tool(OIT)(登録ユーザ専用)では、特定の show コマンドがサポートされています。 OIT を使用して、show コマンド出力の解析を表示できます。

debug コマンドを使用する前に、『debug コマンドの重要な情報』を参照してください。

  • logging:この例のように Cisco Unified Border Element で logging が設定されていることを確認するとともに、デバッグ コマンドは多岐にわたるので、できる限り非ピーク時間中にデバッグを実行することが重要です。

    logging console informational
    logging buffer 200000 debug
    service sequence-number
    service timestamp debug date msec
  • show:関連出力を次に示します。

    show version
    show run
    show voip rtp connection (once the call is up)
    show call active voice brief (once the call is up)
  • debug:デバッギングのコールを行う前に必ずログをクリアしてから、コールの実行後に show logging コマンドの出力を取得するようにしてください。

    H.323 から H.323 へのシナリオ

    debug h225 asn1
    debug h225 q931
    debug h225 events
    debug h245 asn1
    debug h245 events
    debug h225 q931
    debug cch323 all
    debug voip ipipgw
    debug voip ccapi inout

    H.323 から SIP へのシナリオ

    debug h225 asn1
    debug h225 q931
    debug h225 events
    debug h245 asn1
    debug h245 events
    debug cch323 all
    debug voip ipipgw
    debug voip ccapi inout
    debug ccsip all

    SIP から SIP へのシナリオ

    debug ccsip all
    debug voip ccapi inout
  • debug:前述のシナリオに基づくデバッグ コマンドに加え、次のトランスコーダ デバッグ コマンドも有効にする必要があります。

    debug dspfarm all
    debug sccp messages
  • debug voip rtp session named-events:RFC2833(dtmf-relay rtp-nte)を使用する場合、この debug コマンドも有効にする必要があります。


関連情報


Document ID: 99863