スイッチ : Cisco Catalyst 6500 シリーズ スイッチ

Polycom 電話会議システム向けの Catalyst スイッチ設定

2016 年 10 月 27 日 - 機械翻訳について
その他のバージョン: PDFpdf | ライター翻訳版 (2013 年 5 月 17 日) | 英語版 (2015 年 10 月 20 日) | フィードバック


目次


概要

このドキュメントでは、Polycom IP Conference Station 7935/7936 および Polycom SoundPoint IP 430 に接続するための Catalyst スイッチの設定例を紹介します。 このドキュメントには、インライン電源および Quality of Service(QoS)の設定は含まれません。

前提条件

要件

この設定を行う前に、次の要件が満たされていることを確認します。

使用するコンポーネント

この文書に記載されている情報は Supervisor Engine 720 および実行することが付いている Cisco Catalyst 6500 シリーズ スイッチに Cisco IOS を基づいていますか。 Supervisor Engine 2 および Cisco CatOS ソフトウェア リリース 8.4(4) を実行することを用いるソフトウェア リリース 12.2(18)SXD6 および Cisco Catalyst 6500 シリーズ スイッチ。

このドキュメントの情報は、特定のラボ環境にあるデバイスに基づいて作成されたものです。 このドキュメントで使用するすべてのデバイスは、クリアな(デフォルト)設定で作業を開始しています。 ネットワークが稼働中の場合は、コマンドが及ぼす潜在的な影響を十分に理解しておく必要があります。

関連製品

この設定は、Cisco IOS ソフトウェアが稼働する Cisco Catalyst スイッチ(Cisco 2900XL および 3500XL シリーズを除く)でも使用できます。 CatOS 設定は、Catalyst OS ソフトウェアが稼働するすべての Cisco Catalyst スイッチで使用できます。

表記法

ドキュメント表記の詳細は、『シスコ テクニカル ティップスの表記法』を参照してください。

背景説明

このドキュメントでは、PC と IP フォン Polycom SoundPoint IP 430 をスイッチ ポートで接続するスイッチの設定について説明します。 このドキュメントでは、Polycom IP Conference Station 7935/7936 スイッチ ポートに接続するスイッチの設定についても説明します。

Polycom IP Conference Station 7935/7936 は、RJ-45 ケーブル インターフェイスを介してシングル 10/100BaseTx イーサネット LAN 接続でネットワークに接続しており、その他の Cisco Unified IP フォン 7900 シリーズとは異なり、PC への接続に 10/100BaseTx イーサネット LAN 接続を使用しません。

Cisco 7935/7936 IP Conference Phone では 10/100BaseTx イーサネット LAN 接続での PC への接続に対応していないため、音声または補助 VLAN の概念が直接適用され、これにより問題が生じることがあります。 Cisco IP Conference Station 7935/7936 のシングル 10/100BaseTx イーサネット LAN 接続は、このデバイスをスイッチ ポートに接続するために使用されます。 この接続では音声トラフィックのみが伝送されるため、スイッチ ポートはシングル VLAN に属している必要があります。

Polycom SoundPoint IP 430 にはデュアル 10/100 Mbps イーサネット ポートが装備されています。 1 つのポートがスイッチに接続し、もう 1 つのポートが PC に接続します。 この接続では、ポートは以下の 2 つの VLAN 間のトラフィックを伝送します。

  • データ トラフィック(PC)

  • 音声トラフィック(IP フォン)

このシナリオでは、複数 VLAN のトラフィックを渡すためにトランク ポートが必要です。

Polycom IP Conference Station 7935/7936 には外部電源がないため、スイッチから PoE ポートを介して電力を供給するか、または別個のパワー インジェクタを使用する必要があります。

設定

この項では、このドキュメントで説明する機能の設定に必要な情報を提供します。

このセクションで使用されているコマンドの詳細を調べるには、Command Lookup Tool登録ユーザ専用)を使用してください。

ネットワーク図

このドキュメントでは、次のネットワーク構成を使用しています。

http://www.cisco.com/c/dam/en/us/support/docs/switches/catalyst-6500-series-switches/97229-config-cat-switches-polycom.gif

Cisco IOS の設定例

このドキュメントでは次の設定を使用しています。

  • Catalyst 6500

ネイティブ Cisco IOS モードの Catalyst 6500
Cat6500#show running-config 
 Building configuration...
Current configuration : 5869 bytes
!
version 12.1 
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname cat6500
!

boot system sup-bootflash:s72033-psv-mz.122-18.SXD6.bin


main-cpu
 auto-sync standard
ip subnet-zero
!
!
no ip finger
!
!
!
!
vlan 1
name DataVlan
!
vlan 2
name VoiceVlan
!
interface FastEthernet4/1
 no ip address 
 switchport
 switchport trunk encapsulation dot1q
 switchport trunk native vlan 1
 switchport trunk allowed vlan 1,2
 switchport mode trunk
 spanning-tree portfast

!--- Use PortFast only when you connect a single end station to a
!--- Layer 2 access port. Otherwise, you create a network loop.
!--- Refer to Using Portfast and Other Commands to Fix Workstation Startup
!--- Connectivity Delays for more information on how to enable portfast.

!
interface FastEthernet4/2
 no ip address
 switchport
 switchport access vlan 2
 switchport mode access
 spanning-tree portfast

!--- Use PortFast only when you connect a single end station to a 
Layer 2 access port. Otherwise, you create a network loop.

!
interface FastEthernet4/3
 no ip address
 shutdown
!

!--- Output suppressed.

!
ip classless
no ip http server
!
!
!
line con 0
transport input none
line vty 0 4 
!
end

CatOS の設定例

この例では、PC と IP フォン Polycom SoundPoint IP 430 をスイッチ ポートで接続するハイブリッド モードのスイッチの設定について説明します。 このドキュメントでは、Polycom IP Conference Station 7935/7936 スイッチ ポートに接続するスイッチの設定についても説明します。 この設定では、前述の例と同じダイアグラムを使用します。

ハイブリッド モードの Catalyst 6500

!--- Set the VLAN Trunk Protocol (VTP) mode.
!--- In this example, the mode is set to transparent.
!--- Dependent upon your network, set the VTP mode accordingly.
!--- Refer to Understanding and Configuring VLAN Trunk Protocol (VTP) 
!--- for more information on VTP.

Catalyst6500> (enable) set vtp mode transparent
VTP domain modified


!--- Add VLAN 2. VLAN 1 already exists by default.
 
Catalyst6500> (enable) set vlan 2
VLAN 2 configuration successful


!--- Add port 4/2 to VLAN 2.

Catalyst6500> (enable) set vlan 2 4/2
VLAN 2 modified.
VLAN 1 modified.
VLAN  Mod/Ports
---- -----------------------
2     4/2


!--- Enable trunking on port 4/1.

Catalyst6500> (enable) set trunk 4/1 1,2 dot1q on
Vlan(s) 1,2 already allowed on the trunk
Please use the 'clear trunk' command to remove vlans from allowed list.
Port(s)  4/1 trunk mode set to on.
Port(s)  4/1 trunk type set to dot1q.
Catalyst6500> (enable) 


!--- Enable spanning tree portfast on the ports. Refer to 
!--- Using Portfast and Other Commands to Fix Workstation Startup Connectivity Delays
!--- for more information on how to enable portfast.

Catalyst6500> (enable) set spantree portfast 4/1 enable

Warning: Connecting Layer 2 devices to a fast start port can cause
temporary spanning tree loops. Use with caution.

Spantree port  4/1 fast start enabled.
Catalyst6500> (enable) set spantree portfast 4/2 enable

Warning: Connecting Layer 2 devices to a fast start port can cause
temporary spanning tree loops. Use with caution.

Spantree port  4/2 fast start enabled.
Catalyst6500> (enable)


!--- If you want to ONLY allow VLAN 1 and VLAN 2 on trunk port 4/1, do this.
!--- A trunk port allows all VLANs by default.

Catalyst6500> (enable) show trunk 4/1
* - indicates vtp domain mismatch
# - indicates dot1q-all-tagged enabled on the port
$ - indicates non-default dot1q-ethertype value
Port      Mode         Encapsulation  Status        Native vlan
--------  -----------  -------------  ------------  -----------
 4/1      on           dot1q          not-trunking  1

Port      Vlans allowed on trunk
--------  ---------------------------------------------------------------------
 4/1      1-4094

Port      Vlans allowed and active in management domain 
--------  ---------------------------------------------------------------------
 4/1      1

Port      Vlans in spanning tree forwarding state and not pruned
--------  ---------------------------------------------------------------------
 4/1       
Catalyst6500> (enable) clear trunk 4/1 1-4094
Removing Vlan(s) 1-4094 from allowed list.
Port  4/1 allowed vlans modified to none.


!--- Allow only VLAN 1 and VLAN 2 on trunk port 4/1.

Catalyst6500> (enable) set trunk 4/1 1,2 dot1q on
Adding vlans 1,2 to allowed list.
Port(s)  4/1 allowed vlans modified to 1,2.
Port(s)  4/1 trunk mode set to on.
Port(s)  4/1 trunk type set to dot1q.

Catalyst6500> (enable) show trunk 4/1
* - indicates vtp domain mismatch
# - indicates dot1q-all-tagged enabled on the port
$ - indicates non-default dot1q-ethertype value
Port      Mode         Encapsulation  Status        Native vlan
--------  -----------  -------------  ------------  -----------
 4/1      on           dot1q          not-trunking  1

Port      Vlans allowed on trunk
--------  ---------------------------------------------------------------------
 4/1      1,2

Port      Vlans allowed and active in management domain 
--------  ---------------------------------------------------------------------
 4/1      1

Port      Vlans in spanning tree forwarding state and not pruned
--------  ---------------------------------------------------------------------
 4/1       

!--- Refer to Configuring Ethernet VLAN Trunks for more
!--- information on how to configure trunk ports. 


!--- Issue the show config <module_number> command 
!--- in order to check the configuration.

Catalyst6500> (enable) show config 4
This command shows non-default configurations only.
Use 'show config <mod> all' to show both default and non-default configurations.
.................................
begin
!
# ***** NON-DEFAULT CONFIGURATION *****
!
!
#time: Thu Jun 21 2007, 23:37:51 
!
# default port status is enable
!
!
#module 4 : 16-port 1000BaseX Ethernet
set vlan 2    4/2
clear trunk 4/1  1-9,11-39,41-4094
set trunk 4/1  on dot1q 1,2
set spantree portfast    4/1-2 enable
end
Catalyst6500> (enable) 

確認

現在、この設定に使用できる確認手順はありません。

トラブルシューティング

このセクションでは、設定のトラブルシューティングに役立つ情報を提供します。

Polycom IP フォンによるスパニング ツリー ループ

IP フォンをスイッチに接続すると、STP ループが発生することがあります。STP ループが発生すると、スイッチの CPU の使用率が 100 % に達します。 IP フォンが接続するスイッチ ポートで PortFast を有効にしていても、STP ループが発生することがあります。

  1. スイッチ ポートの設定を確認します。 IP フォンが接続しているポートが err-disabled 状態になる場合、および物理ループが発生していない場合は、ポートを err-disabled 状態から回復できます。 詳細は、『Cisco IOS プラットフォームでの errdisable ポート状態からの復旧』を参照してください。

  2. エンド ユーザが誤って物理ループを発生させる可能性がある場合にポートが err-disabled 状態にならないようにするには、err-disable からの復旧を有効にします。これにより、無効になったポートを手動でリセットする必要がなくなります。 STP ループ ガードについての詳細は、『ループ ガードと BPDU スキュー検出機能によるスパニング ツリー プロトコルの拡張機能』を参照してください。


関連情報


Document ID: 97229