スイッチ : Cisco Catalyst 3750 シリーズ スイッチ

VLAN 間で Wake-On-LAN をサポートするための Catalyst レイヤ 3 スイッチの設定例

2016 年 10 月 28 日 - 機械翻訳について
その他のバージョン: PDFpdf | ライター翻訳版 (2010 年 5 月 7 日) | 英語版 (2015 年 10 月 7 日) | フィードバック


目次


概要

このドキュメントでは、Catalyst レイヤ 3 スイッチを使用して VLAN 間で Wake-on-LAN(WoL)をサポートするための設定例を紹介します。

前提条件

要件

この設定を開始する前に、次の項目に関する知識を得ておくことを推奨します。

使用するコンポーネント

このドキュメントの情報は、次のソフトウェアとハードウェアのバージョンに基づくものです。

  • Catalyst 3750 シリーズ スイッチ Cisco IOS を実行するか。 システムソフトウェアリリース 12.2(25r)SEC

  • Cisco IOS システム ソフトウェア リリース 12.1(19)EA1a が稼動する Catalyst 2950 シリーズ スイッチ

  • Microsoft Windows 2000 オペレーティング システムが稼働する PC

  • SolarWinds から提供されているフリーウェア版の Wake-On-LAN ユーティリティ leavingcisco.com

    シスコはどのような Wake-on-LAN(WoL)ユーティリティも推奨していません。

このドキュメントの情報は、特定のラボ環境にあるデバイスに基づいて作成されたものです。 このドキュメントで使用するすべてのデバイスは、クリアな(デフォルト)設定で作業を開始しています。 ネットワークが稼働中の場合は、コマンドが及ぼす潜在的な影響を十分に理解しておく必要があります。

表記法

ドキュメント表記の詳細は、『シスコ テクニカル ティップスの表記法』を参照してください。

背景説明

Wake-On-LAN

Wake-on-LAN(WoL)は、スリープ中のシステムを起動するハードウェアとソフトウェアのテクノロジーの組み合わせです。 WOL は、マジック パケットという特別にコード化されたネットワーク パケットを、これらのパケットに応答するように装備されて有効になっているシステムに送信します。 この付加機能によって、管理者は、ユーザがシステムの電源を落としてしまった場合でもシステムのメンテナンスを実行できます。 WoL 機能によって、管理者は、更新を受信できるようにスリープ中のすべてのマシンの電源をリモートから立ち上げることができます。 WoL は、PC がシャットダウンされたときでも NIC が依然として電力を受け取り、マジック パケットの到着をネットワーク上でリスニングし続けるという原理に基づいています。 このマジック パケットは、さまざまなコネクションレス プロトコル(UDP、IPX)経由で送信できますが、最も一般的に使用されるのは UDP です。

リモート ネットワークから WOL パケットを送信する場合は、ダイレクト ブロードキャストを許可するようにルータを設定する必要があります。 これを行わなければならない理由は次の 2 つです。

  • スリープ状態の PC には IP アドレスがないため、ルータからの Address Resolution Protocol(ARP; アドレス解決プロトコル)に応答できません。 このため、ARP なしでセグメント上を送信されるのは、ローカル サブネットの IP ブロードキャスト パケットのみです。

  • 現在のほとんどのネットワークが該当するようにルータと PC の間にレイヤ 2 スイッチが存在する場合、スイッチは PC が物理的にどのポートに接続されているかを認識できません。 レイヤ 2 ブロードキャストまたは不明なユニキャスト フレームだけがすべてのスイッチ ポートに送信されます。 すべての IP ブロードキャスト パケットは、ブロードキャスト MAC アドレス宛てに送信されます。

警告:ダイレクト ブロードキャスト

IP ダイレクト ブロードキャストは、一般によく知られている SMURF サービス拒否攻撃で使用され、それに関連する攻撃にも使用できます。

IP ダイレクト ブロードキャストとは、送信元のマシンが直接接続していないサブネットのブロードキャスト アドレスに送信されるデータグラムです。 ダイレクト ブロードキャストは、ユニキャスト パケットとしてネットワーク上をルーティングし、最終的にターゲット サブネットに到達すると、そこでリンクレイヤ ブロードキャストに変換されます。 IP アドレス設定アーキテクチャの特性上、ターゲット サブネットに直接接続されているチェーンの最後のルータだけが最終的にダイレクト ブロードキャストを識別できます。 ダイレクト ブロードキャストは、正当な目的のために使用される場合もありますが、そのような使用方法は金融サービス業界以外では一般的ではありません。

SMURF 攻撃では、攻撃者は偽装した送信元アドレスからダイレクト ブロードキャスト アドレスに ICMP エコー要求を送信します。 その結果、ターゲット サブネット上に存在するすべてのホストが、偽装された送信元に応答を返信します。 そのような要求のストリームを継続的に送信することによって、攻撃者は膨大な応答ストリームを作り出すことができます。 これによって、アドレスが偽装されたホストを満杯状態にすることになります。

Cisco のインターフェイスが no ip directed-broadcast コマンドで設定されていると、そのインターフェイスでリンクレイヤ ブロードキャストに展開されるはずであったダイレクト ブロードキャストが廃棄されるようになります。 これは、宛先のサブネットに接続されているすべてのルータのすべてのインターフェイスで no ip directed-broadcast コマンドを設定する必要があることを意味しています。 ファイアウォール ルータに設定するだけでは不十分です。 no ip directed-broadcast コマンドは、Cisco IOS ソフトウェア リリース 12.0 以降ではデフォルトになっています。 それよりも前のリリースでは、正当なダイレクト ブロードキャストを転送するかどうかが不明なすべての LAN インターフェイスに対してこのコマンドを適用する必要があります。

設定

この項では、このドキュメントで説明する機能の設定に必要な情報を提供します。

このセクションで使用されているコマンドの詳細を調べるには、Command Lookup Tool登録ユーザ専用)を使用してください。

ネットワーク図

このドキュメントでは、次のネットワーク構成を使用しています。

http://www.cisco.com/c/dam/en/us/support/docs/switches/catalyst-3750-series-switches/91672-catl3-wol-vlans1.gif

このネットワーク構成の詳細は、次のとおりです。

  • PC 1、2、3 が起動する必要のあるクライアント PC です。

  • PC 4 は WOL サーバ兼 DHCP サーバです。

  • PC 4 には、172.16.3.2/24 という固定 IP アドレスが割り当てられています。

  • クライアント PC は DHCP サーバから IP アドレスを取得するように設定されています。

  • DHCP サーバ(PC 4)では、VLAN 2、3、および 4 に接続するクライアントに対して 3 つの IP スコープが設定されています。

  • SW-1 と SW-2(Catalyst 2950)は、レイヤ 2 スイッチとして使用され、L3(Catalyst 3750)はレイヤ 3 スイッチとして使用されます。

  • PC 1 と 4 は、同一の VLAN(VLAN 3)内で接続されています。

  • PC 2 と 3 は、それぞれ VLAN 2 と 4 で接続されています。

スイッチの設定

このドキュメントでは、次のスイッチ設定を使用します。

  • レイヤ 3 スイッチ - L3

  • レイヤ 2 スイッチ - SW-1 および SW-2

L3
Switch>en
Switch#configure terminal
Enter configuration commands, one per line.  End with CNTL/Z.
Switch(config)#hostname L3
L3(config)#ip routing
L3(config)#vtp mode server
Device mode already VTP SERVER.
L3(config)#vtp domain cisco
Changing VTP domain name from NULL to cisco
L3(config)#vlan 2
L3(config-vlan)#vlan 3
L3(config-vlan)#vlan 4
L3(config)#interface gigabitEthernet 2/0/1
L3(config-if)#switchport trunk encapsulation dot1q
L3(config-if)#switchport mode trunk
L3(config-if)#interface gigabitEthernet 2/0/2
L3(config-if)#switchport trunk encapsulation dot1q
L3(config-if)#switchport mode trunk
L3(config-if)#exit
L3(config)#access-list 101 permit udp host 172.16.3.2 any eq 7

!--- This accepts directed broadcasts only from PC 4.

L3(config)#ip forward-protocol udp 7 

!--- Specifies the protocol and port to be forwarded.
!--- Capture the WOL packet with any network sniffer to determine the UDP port
!--- to use in this command. The port number varies with the WOL utility used.

L3(config-if)#interface vlan 2
L3(config-if)#ip address 172.16.2.1 255.255.255.0
L3(config-if)#ip helper-address 172.16.3.2

!--- Enables BOOTP broadcast forwarding to the DHCP server.

L3(config-if)#ip directed-broadcast 101

!--- Enables the translation of a directed broadcast to physical broadcasts.

L3(config-if)#interface vlan 3
L3(config-if)#ip address 172.16.3.1 255.255.255.0
L3(config-if)#ip helper-address 172.16.2.255
L3(config-if)#ip helper-address 172.16.4.255

!-- Enables forwarding of WoL packets to clients.
!-- Works in conjunction with the ip forward-protocol command.
L3(config-if)#interface vlan 4
L3(config-if)#ip address 172.16.4.1 255.255.255.0
L3(config-if)#ip helper-address 172.16.3.2

!--- Enables BOOTP broadcast forwarding to the DHCP server.

L3(config-if)#ip directed-broadcast 101

!--- Enables the translation of a directed broadcast to physical broadcasts.

L3(config)#^Z
L3#wr
Building configuration...
[OK]
L3#

SW-1
Switch>en
Switch#configure terminal
Enter configuration commands, one per line.  End with CNTL/Z.
Switch(config)#hostname SW-1
SW-1(config)#vtp mode client
Setting device to VTP CLIENT mode.
SW-1(config)#vtp domain cisco
Changing VTP domain name from NULL to cisco
SW-1(config)#interface fastEthernet 0/1
SW-1(config-if)#spanning-tree portfast
%Warning: portfast should only be enabled on ports connected to a single
 host. Connecting hubs, concentrators, switches, bridges, etc... to this
 interface  when portfast is enabled, can cause temporary bridging loops.
 Use with CAUTION

%Portfast has been configured on FastEthernet0/1 but will only
 have effect when the interface is in a non-trunking mode.
SW-1(config-if)#switchport mode access
SW-1(config-if)#switchport access vlan 4
SW-1(config-if)#interface fastEthernet 0/2
SW-1(config-if)#spanning-tree portfast
%Warning: portfast should only be enabled on ports connected to a single
 host. Connecting hubs, concentrators, switches, bridges, etc... to this
 interface  when portfast is enabled, can cause temporary bridging loops.
 Use with CAUTION

%Portfast has been configured on FastEthernet0/2 but will only
 have effect when the interface is in a non-trunking mode.
SW-1(config-if)#switchport mode access
SW-1(config-if)#switchport access vlan 3
SW-1(config-if)#interface gigabitethernet 0/1
SW-1(config-if)#switchport mode trunk
SW-1(config-if)#^Z
SW-1#wr
Building configuration...
[OK]
SW-1#

SW-2
Switch>en
Switch#configure terminal
Enter configuration commands, one per line.  End with CNTL/Z.
Switch(config)#hostname SW-2
SW-2(config)#vtp mode client
Setting device to VTP CLIENT mode.
SW-2(config)#vtp domain cisco
Changing VTP domain name from NULL to cisco
SW-2(config)#interface fastEthernet 0/1
SW-2(config-if)#spanning-tree portfast
%Warning: portfast should only be enabled on ports connected to a single
 host. Connecting hubs, concentrators, switches, bridges, etc... to this
 interface  when portfast is enabled, can cause temporary bridging loops.
 Use with CAUTION

%Portfast has been configured on FastEthernet0/1 but will only
 have effect when the interface is in a non-trunking mode.
SW-2(config-if)#switchport mode access
SW-2(config-if)#switchport access vlan 3
SW-2(config-if)#interface fastEthernet 0/2
SW-2(config-if)#spanning-tree portfast
%Warning: portfast should only be enabled on ports connected to a single
 host. Connecting hubs, concentrators, switches, bridges, etc... to this
 interface  when portfast is enabled, can cause temporary bridging loops.
 Use with CAUTION

%Portfast has been configured on FastEthernet0/2 but will only
 have effect when the interface is in a non-trunking mode.
SW-2(config-if)#switchport mode access
SW-2(config-if)#switchport access vlan 2
SW-2(config)#interface gigabitethernet 0/1
SW-2(config-if)#switchport mode trunk
SW-2(config-if)#^Z
SW-2#wr
Building configuration...
[OK]
SW-2#

クライアント PC の設定

最近のマザーボードには NIC が組み込まれている場合が多く、WOL 機能をサポートしているものがほとんどです。 一部のコンピュータでは WOL がデフォルトで無効になっています。 その場合、WoL を有効にするには Basic Input Output System(BIOS)オプションに移動します。 次に、クライアント PC で WoL を有効にする手順を示します。

  1. コンピュータの Power On Self Test(POST; 電源投入時自己診断テスト)中に BIOS 設定画面に移動します。

    通常、F10 キーまたは Delete キーを押すと BIOS 設定に移動します。

  2. BIOS 画面で、[Advanced] 設定まで移動してから [Device Options] を選択します。

  3. この画面で、Wake-on-LAN に関連する設定を探し、それを有効にします。

  4. BIOS 設定を保存して終了します。

    BIOS で利用可能な WoL を有効にする正確な手順とオプションはコンピュータ製造元によって異なります。 BIOS 設定の詳細は、各コンピュータで提供されるマザーボードのマニュアルを参照してください。

  5. WoL 機能が有効になっていることを確認するには、ネットワーク カードの詳細プロパティを表示します。

    1. [Start] > [Settings] > [Network and Dial-up Connections] の順に選択して、[Local Area Connection] を右クリックします。

    2. [Properties] をクリックして [Configure] を選択します。

    3. [Advanced] タブまで移動します。 [Wake Up Capabilities] プロパティを [Both] に、[WOL Speed] を [Auto] に設定します。

      http://www.cisco.com/c/dam/en/us/support/docs/switches/catalyst-3750-series-switches/91672-catl3-wol-vlans2.gif

    4. [Power Management] タブをクリックし、[Allow this device to bring the computer out of standby] ボックスにチェックマークを付けます。

      http://www.cisco.com/c/dam/en/us/support/docs/switches/catalyst-3750-series-switches/91672-catl3-wol-vlans3.gif

      Microsoft Windows XP マシンでは、 [Only allow management stations to bring the computer out of standby] というもう 1 つのオプションがあります。 この最後のオプションにチェックマークを付けると、WOL マジック パケットを受信した場合にのみコンピュータの電源がオンになります。 このオプションにチェックマークが入っていない場合、ネットワーク アダプタに何らかのトラフィックが届くと、PC は起動されます。

クライアントが DHCP サーバから IP アドレスを取得するために、次の手順を実行します。

  1. [Start] > [Settings] > [Network and Dial-up Connections] の順にクリックし、[Local Area Connection] を右クリックして [Properties] を選択します。

  2. [General] タブで、[Internet Protocol (TCP/IP)] をクリックし、[Properties]をクリックします。

  3. [Obtain an IP address automatically] を選択します。

    http://www.cisco.com/c/dam/en/us/support/docs/switches/catalyst-3750-series-switches/91672-catl3-wol-vlans4.gif

サーバ PC の設定

WOL サーバを設定するには、次の手順を実行します。

  1. Wake-On-LAN ユーティリティをダウンロードしてインストールします。

  2. PC に固定 IP アドレス 172.16.3.2/24 を設定します。

  3. PC を DHCP サーバとして設定します。

  4. 次のように 3 つのスコープを作成します。

    範囲 IP の範囲 IP 除外範囲
    VLAN2 172.16.2.1 - 172.16.2.254 マスク:255.255.255.0 172.16.2.1
    VLAN3 172.16.3.1 - 172.16.3.254 マスク:255.255.255.0 172.16.3.1 と 172.16.3.2
    VLAN 4 172.16.4.1 - 172.16.4.254 マスク:255.255.255.0 172.16.4.1

    DHCPサーバコンフィギュレーションで詳細については Windows サーバ 2003 年のワークグループで DHCPサーバをleavingcisco.com インストールし設定する方法を参照して下さい。

確認

このセクションでは、設定が正常に機能していることを確認します。

次の手順を実行します。

  1. PC の電源をオンにして、「ネットワーク ダイアグラム」に示すとおりに各スイッチに接続します。

  2. 各 PC にログインして、その MAC アドレスと IP アドレスをメモします。

    MAC アドレスと IP アドレスを確認するには、コマンド プロンプトを開いて、ipconfig /all コマンドを入力します。

  3. PC 間の接続を確認するには ping を使用します。

  4. 接続が正常であることを確認した後は、すべてのクライアント PC(PC 1、PC 2、PC 3)の電源をオフにします。

  5. サーバ PC(PC 4)で WOL ユーティリティを起動します。

  6. 次に示すように、「起動(ウェイクアップ)」させる PC の MAC アドレスと IP アドレスを入力します。

    http://www.cisco.com/c/dam/en/us/support/docs/switches/catalyst-3750-series-switches/91672-catl3-wol-vlans5.gif

    IP アドレスは、クライアント PC が接続されている VLAN サブネット範囲内にあれば任意のアドレスで(サブネット ブロードキャストであっても)かまいません。 一致する必要があるのは、クライアント PC の MAC アドレスだけです。

  7. デバイスの電源をオンにするために、ターゲット PC に一連のマジック パケットを送信するには、[Wake UP PC] アイコンをクリックします。

    http://www.cisco.com/c/dam/en/us/support/docs/switches/catalyst-3750-series-switches/91672-catl3-wol-vlans6.gif

  8. リモート デバイスが起動命令メッセージを受信し、その電源がオンになると、次のメッセージが表示されます。

    http://www.cisco.com/c/dam/en/us/support/docs/switches/catalyst-3750-series-switches/91672-catl3-wol-vlans7.gif

    この時点で、クライアント PC の電源がオンになっています。

トラブルシューティング

現在のところ、この設定に関する特定のトラブルシューティング情報はありません。


関連情報


Document ID: 91672