Cisco インターフェイスとモジュール : Cisco Catalyst 6500 シリーズ / 7600 シリーズ ワイヤレス サービス モジュール(WiSM)

初期 Wireless Services Module(WiSM)セットアップのトラブルシューティングと設定

2016 年 10 月 27 日 - 機械翻訳について
その他のバージョン: PDFpdf | 英語版 (2015 年 8 月 22 日) | フィードバック


目次


概要

このドキュメントでは、WiSM の初期設定を確認し、トラブルシューティングするために使用するコマンドについて説明します。 このドキュメントでは、Catalyst 6500 スーパバイザ エンジン 720(Sup720)が、このエンジンに装着されている WiSM モジュールと通信するように設定するために必要な基本手順についても説明します。

前提条件

要件

ワイヤレス LAN コントローラとその設定に関する基本知識と、スーパーバイザ 720 および EtherChannel リンク集約(LAG)などの機能が稼働する Cisco Catalyst 6500 スイッチに関する基本知識を有していることを確認します。 その他には、このドキュメントに関する特別な要件はありません。

使用するコンポーネント

この文書に記載されている情報は Catalyst 6500 Supervisor エンジン 720 にインストールされるネイティブ Cisco IOS を実行する Cisco WiSM モジュールに基づいていますか。 ソフトウェア リリース 12.2(18)SXF2、しかしコマンドはスーパバイザ 720 および WiSM カードをサポートするすべての IOSバージョンに適用します。

このドキュメントの情報は、特定のラボ環境にあるデバイスに基づいて作成されたものです。 このドキュメントで使用するすべてのデバイスは、クリアな(デフォルト)設定で作業を開始しています。 ネットワークが稼働中の場合は、コマンドが及ぼす潜在的な影響を十分に理解しておく必要があります。

表記法

ドキュメント表記の詳細は、『シスコ テクニカル ティップスの表記法』を参照してください。

背景説明

Cisco WiSM は、シスコ ワイヤレス LAN コントローラ ファミリの製品です。 Cisco Aironet Lightweight アクセス ポイント、Cisco WCS、および Cisco Wireless Location Appliance と連携し、ワイヤレス データ、音声、およびビデオ アプリケーションをサポートするセキュアなユニファイド ワイヤレス ソリューションを提供します。

Cisco WiSM は、Cisco Catalyst 6500 シリーズ スイッチと Cisco Catalyst 6500 スーパーバイザ エンジン 720 にスムーズに統合します。 スーパバイザ エンジン 720 のすべてのバージョンがサポートされています。 また、WiSM は、Cisco IOS ソフトウェア リリース 12.2(18)SXF5 が稼働している Cisco 7600 ルータでもサポートされています。

次の表に、Cisco Catalyst 6500 で Cisco WiSM に対応しているスロットを示します。

スロット 6503-E 6504-E 6506 6509 6513
1-3 X X X X  
4   X X X  
5-6     X X  
7-8       X  
9       X X
10-13         X

Cisco 6509 スイッチのシャーシは、他のサービス モジュールが装着されていなければ最大 7 個の Cisco WiSM をサポートできます。スーパバイザ 720 を備えた Catalyst 6506 では最大 4 個の Cisco WiSM がサポートされ、その他の Cataylst 6500 シリーズ スイッチ シャーシでは最大 6 個の Cisco WiSM をサポートできます。 サービス モジュールが 1 つ以上インストールされている場合、シャーシがサポート可能なサービス モジュールの数は最大 4 個となります(WiSM を含む)。 これらの最大設定には、冗長スーパーバイザは使用できません。

Cisco WiSM は、2 台の Cisco 4404 コントローラで構成されているため、IT 担当員は 1 つのモジュールに 2 つの個別コントローラがあることに注意する必要があります。 1 つ目のコントローラを WiSM-A カードとし、2 つ目のコントローラを WiSM-B カードとします。 インターフェイスと IP アドレスの割り当ては、それぞれのカードで別々に考慮する必要があります。 WiSM-A では 150 のアクセス ポイントを管理します。また、WiSM-B では別の 150 のアクセス ポイントを管理します。 これらのコントローラは、モビリティ グループで一緒にグループ化して、クラスタを構成できます。

Cisco WiSM の各コントローラには複数の種類のインターフェイスがあり、 そのうちの 3 つは事前定義タイプであり、セットアップの時点で存在し、設定される必要があります。

  • 管理インターフェイス(事前定義、必須)

  • AP マネージャ インターフェイス(事前定義、必須)

  • 仮想インターフェイス(事前定義、必須)

  • オペレータ定義インターフェイス(ユーザ定義)

  • サービス ポート インターフェイス(事前定義、必須)

各タイプのインターフェイスについての詳細は、『Cisco Wireless Services Module およびワイヤレス コントロール システムの設定』を参照してください。

WiSM では、スーパバイザ エンジンと WiSM の同期にサービス ポートが使用されます。

スーパバイザ 720 と Cisco WiSM 間の通信の設定

1 ~ 1000 の範囲の VLAN を含む WiSM トランクを使用しているが、使用する予定の VLAN は 1 ~ 10 だけである場合は、次のコマンドを入力します。 no wism module x controller y allowed-vlan 11-1000

Cisco WiSM コントローラをスロットに装着し、スーパーバイザによってこのコントローラが検出されたら、スーパーバイザ エンジンで WiSM と通信するための設定が完了しています。

  1. Catalyst WiSM のサービス ポートの DHCP スコープを作成します。

    ip dhcp excluded-address 192.168.10.1 192.168.10.2
    
    !
    ip dhcp pool wism-service-port
     
    network 192.168.10.0 255.255.255.0
    
    default-router 192.168.10.1
    
    

    あるいは、セッションを使用するか(session slot X proc 1 または 2)またはコンソールを直接使用して WiSM にアクセスし、スタティック IP アドレスを設定します(config Interface Address Service-Port)。

    サービス ポートの IP アドレスが、ネットワーク内でルーティング可能な IP アドレスではないことを確認してください。これは、サービス ポートの IP アドレスは Sup 720 と WiSM 間の通信専用であるためです。

  2. WiSM サービス ポート ゲートウェイを作成し、IP アドレスを割り当てます。

    VLAN をスーパーバイザ 720 に作成します。 この VLAN は、シャーシに対してローカルであり、スーパーバイザのギガビット インターフェイスと Cisco WiSM のサービス ポートを介した Cisco WiSM および Catalyst Supervisor 720 間の通信に使用されます。

    interface Vlan192
    
    Description WiSM Service Port Gateway or Management Interface on CAT6K
    ip address 192.168.10.1 255.255.255.0
    
    

    Cat6K に到達するには、ネットワーク管理 VLAN インターフェイスがすでに存在している必要があります。

  3. WiSM サービス ポートを VLAN に割り当てます。

    VLAN 192 を使用してサービス ポートと通信するようにこのコマンドを設定します。

    wism service-vlan 192
    
    

    wism service-wlan X で定義される VLAN の interface vlan は、コントローラと同じシャーシ上にある必要があります。また DHCP スコープは、WiSM が接続しているのと同じシャーシで定義されている必要があります。 DHCP 割り当てが機能するためには、DHCP スコープを定義するスイッチに interface vlan XX が必要です。

  4. Cat6k で WiSM Management/AP マネージャ ゲートウェイ インターフェイスを作成します。

    次に設定例を示します。

    interface vlan40
    
    Description WiSM Management/AP-Manager Interface Gateway
    ip address 40.1.1.1
    
    

    ソフトウェア リリース 12.2(18)SXF5 で、自動 LAG ポート(200 番台の高い番号の範囲)で使用する新しい WiSM コマンドが導入されました。 手順 5 と 6 の代わりにこれらのコマンドを使用できます。

    非 VSS 環境では、wism module <module/slot no> controller 1 native-vlan 40 wism module <module/slot no> controller 1 allowed-vlan native vlan id(40), vlan id1, vlan2, etc...

    コマンドを発行します。 VSS 環境では、wism switch<module/slot no> controller 1 native-vlan 40 wism switch<module/slot no> controller 1 allowed-vlan native vlan id(40), vlan id1, vlan2, etc... コマンドを発行します。 このコマンドを入力した後、サービスが一時的に中断することがあります(およそ ping 2 回分)。

    次のコマンドを入力して、インターフェイスの QoS trust を設定します。

     wism module <module/slot no> controller 1 qos-trust dscp
  5. Cat6k で dot1q トランキング、trust dscp、およびネイティブ VLAN を使用して 2 ポート チャネル インターフェイスを作成します。これにより、管理ポートからのタグなしパケットが許可されます。

    Cisco WiSM の 2 つの独立コントローラのための 2 つのポートチャネル インターフェイスを作成し、ネイティブ インターフェイスとして VLAN 40 を割り当てます。

    interface Port-channel X
    
    switchport trunk encapsulation dot1q
    switchport trunk native vlan 40
    
    switchport mode trunk
    mls qos trust dscp
    spanning-tree portfast trunk
    

    同様に、WiSM の他のコントローラのために別のポート チャネル インターフェイスを作成します。

  6. WiSM コントローラ 1 と 2 のインターフェイスを設定します。

    最初にスーパーバイザによって Cisco WiSM コントローラが検出されるとすぐに、8 つのギガビット インターフェイスが作成されます。これは Gig<モジュールが装着されているスロットの番号>/1Gig<スロット番号>/8 です。

    VLAN 40 をネイティブ VLAN として使用して、これらのギガビット インターフェイスをトランク ポートとして設定します。 Cisco WiSM を設定するときに、ネイティブ VLAN がタグ付けされていないことを確認します。 この設定例を示します。

    router(config)# interface range gigabitEthernet
    <slot>/1 – 4 
    or 
    router(config)# interface range gigabitEthernet 
    <slot>/5 – 8
    
    switchport trunk encapsulation dot1q
    switchport trunk native vlan 40
     
    switchport mode trunk
    mls qos trust dscp
    spanning-tree portfast trunk
    channel-group <port-channel no> mode on
    

    Cisco IOS ソフトウェア リリース 12.2.33SXI が稼働するスイッチに WiSM が装着されている場合、スイッチでポートチャネルを手動で定義し、ギガビット インターフェイスに適用する操作は機能しません。 自動 lag を使用する必要があります。

確認手順

ここでは、WiSM セットアップの検証に使用するコマンドについて説明します。

  1. 実行中のネイティブ(IOS)バージョンを確認するため、show version コマンドを発行します。

    Router#show version
    Cisco Internetwork Operating System Software 
    IOS (tm) s72033_rp Software (s72033_rp-ADVENTERPRISEK9_WAN-M), Version 12.2(18)SXF5, RELEASE SOFTWARE (fc3)
    Technical Support: http://www.cisco.com/techsupport
    Copyright (c) 1986-2006 by cisco Systems, Inc.
    Compiled Sat 08-Jul-06 02:54 by kellythw
    Image text-base: 0x40101040, data-base: 0x42D88000
    
    ROM: System Bootstrap, Version 12.2(14r)S1, RELEASE SOFTWARE (fc1)
    BOOTLDR: s72033_rp Software (s72033_rp-ADVENTERPRISEK9_WAN-M), Version 12.2(18)SXF5, RELEASE SOFTWARE (fc3)
    
    ... skip ...
    
    cisco WS-C6503-E (R7000) processor (revision 1.1) with 458720K/65536K bytes of memory.
    Processor board ID FOX0920047A
    SR71000 CPU at 600Mhz, Implementation 0x504, Rev 1.2, 512KB L2 Cache
    Last reset from power-on
    SuperLAT software (copyright 1990 by Meridian Technology Corp).
    X.25 software, Version 3.0.0.
    Bridging software.
    TN3270 Emulation software.
    3 Virtual Ethernet/IEEE 802.3 interfaces
    20 Gigabit Ethernet/IEEE 802.3 interfaces
    1917K bytes of non-volatile configuration memory.
    8192K bytes of packet buffer memory.
    
    65536K bytes of Flash internal SIMM (Sector size 512K).
    Configuration register is 0x2102

    WiSM には、ネイティブ IOS バージョン 12.2(18) SXF2 以降が稼働しているスーパーバイザ 720 が必要です。

  2. Cat6k にスーパーバイザ 720 と WiSM カードが装着されていることを確認するため、show module コマンドを実行します。

    Router#show module
    Mod Ports Card Type                              Model              Serial No.
    --- ----- -------------------------------------- ------------------ -----------
      1    2  Supervisor Engine 720 (Active)         WS-SUP720-BASE     SAD0717003H
      3   10  WiSM WLAN Service Module               WS-SVC-WISM-1-K9   SAD09280AZU
    
    
    Mod MAC addresses                       Hw    Fw           Sw           Status
    --- ---------------------------------- ------ ------------ ------------ -------
      1  000c.ce63.eb0c to 000c.ce63.eb0f   2.1   7.7(1)       12.2(18)SXF5 Ok
      3  0030.f274.ae36 to 0030.f274.ae45   0.3   12.2(14r)S5  12.2(18)SXF5 Ok
    
    
    Mod  Sub-Module                  Model              Serial       Hw     Status 
    ---- --------------------------- ------------------ ----------- ------- -------
      1  Policy Feature Card 3       WS-F6K-PFC3A       SAD071902DP  1.1    Ok
      1  MSFC3 Daughterboard         WS-SUP720          SAD071700L3  1.2    Ok
      3  Centralized Forwarding Card FARFEL             SAD0929038U  0.3    Ok
    
    Mod  Online Diag Status 
    ---- -------------------
      1  Pass
      3  Pass

    スイッチからの show module コマンドの出力に、10 個のポートを備えた WISM が示されます。 ただし、port-channel 設定の port-channel1 および port-channel2 に使用されているポートは 8 個だけです。 他の 2 個のポートはサービス ポートとして使用されています。

  3. WiSM が装着されているスロットを確認するため、show wism status コマンドを発行します。 このコマンドの出力例を次に示します。

    Router#sh wism status
    Service Vlan : 158, Service IP Subnet : 172.16.158.131/255.255.255.128
    WLAN
    Slot Controller Service IP Management IP SW Version Status
    ----+-----------+----------------+----------------+-----------+---------
    3 1 172.16.158.142 140.1.3.10 3.2.116.21 Oper-Up
    3 2 172.16.158.143 140.1.3.11 3.2.116.21 Oper-Up
    

    6503-E ではスロット 1 ~ 3 だけが機能します。 6504 ~ 6506 ではスロット 1 ~ 4 だけが機能します。 6509 ではスロット 1 ~ 9 だけが機能します。 6913 ではこれとは対照的に、 スロット 9 ~ 13 だけが機能します。 詳細については、『WiSM のトラブルシューティングに関するFAQ(よくある質問)』を参照してください。

  4. Cat6k 側から WiSM のステータスを確認するには、show wism module X controller Y status コマンドを発行し、使用中の Oper-Up ポートと LAG ポートを確認します(LAG ポートを検証します)。 サービス IP アドレスがないかどうかを確認するため、サービス VLAN の DHCP セットアップを検証します。 あるいは、モジュールに対するセッションを使用するか(session slot x proc 1 または 2)、またはコンソールを直接使用して WiSM にアクセスし、スタティック IP アドレスを確認します。

    Router#show wism module 3 controller 1 status 
    
    WiSM Controller 1 in Slot 3
    Operational Status of the Controller : Oper-Up
    Service VLAN                         : 250
    Service Port                         : 9
    Service Port Mac Address             : 0014.a9bd.d9a2
    Service IP Address                   : 172.16.158.142
    Management IP Address                : 140.1.3.10
    Software Version                     : 3.2.116.21
    Port Channel Number                  : 285
    Allowed vlan list                    : 5,10,15,25,35,45,55
    Native VLAN ID                       : 5
    WCP Keep Alive Missed                : 0
  5. WiSM および VLAN へのトランキングが定義されていることを確認するため、show interface trunk コマンドを発行します。 このコマンドの出力例を次に示します。

    Router#show interface trunk
             Port  Mode   Encapsulation Status Native vlan
             Po1   on     802.1q trunking 140
             Po2   on     802.1q trunking 140
  6. 正しいロード バランシング アルゴリズム(config #port-channel load-balance src-dst-ip)を検証するため、show etherchannel load-balance コマンドを発行します。 このコマンドの出力例を次に示します。

    Router#show etherchannel load balance
    EtherChannel Load-Balancing Configuration:
                       src-dst-ip
    

    EtherChannel の正しいポートを確認するため、show etherchannel load-balance コマンドを発行します。 次に出力例を示します。

    Router#show etherchannel summary
    Group Port-channel Protocol Ports
    ------+-------------+-----------+-----------------------------------------
    1     Po1(SU)        -      Gi3/1(P) Gi3/2(P) Gi3/3(P) Gi3/4(P)
    2     Po2(SU)        -      Gi3/5(P) Gi3/6(P) Gi3/7(P) Gi3/8(P)
  7. WiSM 側からステータスを確認するため、セッションを使用するか(session slot x proc 1 または 2)、またはコンソールを直接使用して WiSM にアクセスし、show interface summary(または [Controller] -> [Interfaces] - > [edit (management interface)])で LAG ステータスを確認します。 [Physical Information] に「The interface is attached to a LAG.」と表示されます。 次に例を示します。

    (WiSM-slot3-1) >show interface
    		  summary
    Interface Name     Port  Vlan Id   IP Address   Type   Ap Mgr
    --------------------------------   ----      -------   -------- ------- 
             ap-manager         LAG  untagged   192.168.3.9   Static   Yes
             management         LAG  untagged   192.168.3.10  Static    No

    スイッチで Cisco IOS ソフトウェア リリース 12.2.(18)SXF11, 12.2.(33)SXH 以降が稼働しており、自動 LAG を設定している場合は、show run コマンドの出力には、WiSM のギガビット インターフェイスは表示されません。


関連情報


Document ID: 91473