ワイヤレス / モビリティ : ワイヤレス LAN(WLAN)

ワイヤレス LAN コントローラおよび???Lightweight AP による???QoS の設定例

2016 年 1 月 16 日 - 機械翻訳について
その他のバージョン: PDFpdf | ライター翻訳版 (2010 年 3 月 10 日) | 英語版 (2015 年 12 月 20 日) | フィードバック


目次


概要

このドキュメントで示す設定例では、Cisco Wireless LAN Controller(WLC; ワイヤレス LAN コントローラ)および Lightweight Access Point(LAP; Lightweight アクセス ポイント)を使用して、Cisco Unified Wireless Network で Quality of Service(QoS)を設定する方法を紹介します。

前提条件

要件

この設定を行う前に、次の要件が満たされていることを確認します。

  • LAP および Cisco WLC の設定に関する基本的な知識

  • 有線ネットワークでの基本的なルーティングおよび QoS の設定方法に関する知識

使用するコンポーネント

このドキュメントの情報は、次のソフトウェアとハードウェアのバージョンに基づくものです。

  • ファームウェア リリース 4.0 が稼働している Cisco 2006 WLC

  • Cisco 1000 シリーズ LAP

  • ファームウェア リリース 2.6 が稼働している Cisco 802.11a/b/g ワイヤレス クライアント アダプタ

  • Cisco IOS を実行する Cisco 3725 ルータか。 ソフトウェア リリース 12.3(4)T1

  • Cisco IOS ソフトウェア リリース 12.2(26) が稼働する Cisco 3640 ルータ

  • Cisco IOS ソフトウェア リリース 12.0(5)WC3b が稼働する Cisco 3500 XL シリーズ スイッチ 2 台

このドキュメントの情報は、特定のラボ環境にあるデバイスに基づいて作成されたものです。 このドキュメントで使用するすべてのデバイスは、クリアな(デフォルト)設定で作業を開始しています。 ネットワークが稼働中の場合は、コマンドが及ぼす潜在的な影響を十分に理解しておく必要があります。

表記法

ドキュメント表記の詳細は、『シスコ テクニカル ティップスの表記法』を参照してください。

背景説明

QoS とは、一連のユーザまたはアプリケーションに、他のユーザまたはアプリケーションを犠牲にして、より良いサービスまたは特殊なサービスをネットワークが提供できる能力のことです。

QoS を使用すれば、WLAN および WAN も含め、LAN 全体に渡って帯域幅をより効率よく管理できます。 これにより、QoS では、次のような機能強化された信頼性の高いネットワーク サービスが提供されます。

  • 重要なユーザおよびアプリケーションを対象とした専用の帯域幅のサポート

  • ジッタおよび遅延(リアルタイム トラフィックに必要)の管理

  • ネットワークの輻輳の管理と最小化

  • ネットワーク トラフィックの整形によるトラフィック フローの平滑化

  • ネットワーク トラフィックの優先順位の設定

WLAN は以前、低帯域幅のデータ アプリケーション トラフィックの転送に主に使用されていました。 現在では、WLAN は、垂直環境(小売り、財務、教育など)およびエンタープライズ環境に拡張されているため、時間依存型のマルチメディア アプリケーションとともに高帯域幅のデータ アプリケーションを転送するのに使用されています。 この要件を満たすために、ワイヤレス QoS が必要になったのです。

この規格の定義は、IEEE 802.11 標準委員会の IEEE 802.11e ワーキング グループによって実施されました。 ただし、802.11e 規格の採用は現在その初期段階であり、また多数の規格が存在しているため、オプション コンポーネントも多数存在しています。 802.11i における 802.11 セキュリティで発生した事柄と同じように、Wi-Fi Alliance のようなインダストリ グループやシスコのような業界リーダーが現在、WLAN QoS における主要な要件を、それぞれの Wi-Fi MultiMedia(WMM)プログラムおよび Cisco Compatible Extensions(CCX)プログラムにより定義しています。 そのため、主要機能および相互運用性の提供が、それぞれの認定プログラムにより確実に行われます。

Cisco Unified Wireless Products でサポートしている WMM は、Wi-Fi Alliance によって公開されている IEEE 802.11e ドラフトに基づく QoS システムです。

該当するコントローラでは、次の 4 つの QoS レベルをサポートしています。

  • Platinum/Voice:voice over wireless 用の高品質のサービスを提供します。

  • Gold/Video:高品質のビデオ アプリケーションをサポートします。

  • Silver/Best Effort:クライアント用の通常の帯域幅をサポートします。 これがデフォルト設定です。

  • Bronze/Background:ゲスト サービス用の最小の帯域幅を提供します。

Voice over IP(VoIP)クライアントは Platinum、Gold、または Silver に、低帯域幅クライアントは Bronze に設定する必要があります。

QoS プロファイルを使用して各 QoS レベルの帯域幅を設定した後、それらのプロファイルを WLAN に適用することができます。 プロファイルの設定値は、該当する WLAN に関連付けられているクライアントにプッシュされます。 また、QoS ロールを作成し、通常のユーザおよびゲスト ユーザの帯域幅レベルを指定することもできます。

GUI による QoS プロファイルの設定方法については、『GUI による QoS プロファイルの設定』を参照してください。

CLI による QoS プロファイルの設定方法については、『CLI による QoS プロファイルの設定』を参照してください。

Cisco Unified Wireless Network における QoS の機能の詳細は、『エンタープライズ モビリティ設計ガイド』の「Cisco Unified Wireless の QoS」セクションを参照してください。

このドキュメントで示す設定例では、コントローラ上で QoS を設定する方法と、QoS を使用して設定された有線ネットワークと通信する方法について説明します。

レイヤ 3 QoS パケット マーキングの機能拡張

Cisco Unified Wireless Network では、WLC および LAP によって送信されたパケットに対するレイヤ 3 IP Differentiated Services Code Point(DSCP; DiffServ コード ポイント)によるマーキングをサポートしています。 この機能により Access Point(AP; アクセス ポイント)がこのレイヤ 3 情報を使用する方法が機能拡張され、パケットは AP からワイヤレス クライアントにいたる正確な地上波(Over-the-Air)プライオリティ設定を受信します。

中央集中型の WLAN アーキテクチャの場合、WLAN データは AP ~ WLC 間で、Lightweight Access Point Protocol(LWAPP; Lightweight アクセス ポイント プロトコル)によりトンネリングされます。 このトンネル全体に渡って元の QoS 分類を維持するために、カプセル化されたデータ パケットの QoS 設定を、外側のトンネル パケットのレイヤ 2(802.1p)およびレイヤ 3(IP DSCP)に適切にマッピングする必要があります。

元のパケット自体に DSCP 値も 802.1P 値もない場合、コントローラ~ LAP 間でパケットに DSCP タグを付けることはできません。

コントローラはそれ自体の QoS を適用しません。 WLC 上の QoS サポートにより、WLC はワイヤ(またはアプリケーション)上で設定されているのと同じ優先順位を適用することができます。

そのため、WLC または AP が実行する唯一のアクションは、元のパケットの値を、LWAPP パケットの外側のヘッダーにコピーすることです。 WLC 上の Gold、Silver、および Bronze の QoS オプションの目的は、802.11e/802.1p UP の値と IP DSCP の値の間で適切な QoS 変換(使用するアプリケーションおよび規格によって異なる)を実行することです。 この場合も、WLC 上の QoS により、パケットは端から端まで適切な QoS 処理を確実に受けます。 コントローラはそれ自体の QoS 動作を実行しません。 そこにサポートが存在していて、QoS がすでに存在していて、ワイヤレス パケットに優先順位を適用する必要がある場合、コントローラは先例に従います。コントローラ上に QoS を単に存在させるというのはできません。

コントローラでは、WLAN 設定に基づく Class of Service(CoS; サービス クラス)のマーキング値を、レイヤ 2 LWAPP モードでサポートしていません。 CoS QoS を実装するには、レイヤ 3 LWAPP を使用するよう推奨します。

WLC での QoS の動作方法の例を次に示します。 アプリケーション(CallManager など)が QoS 値を High に設定しているものとします。 その場合、アプリケーションからの元のデータ パケットは IP ヘッダーによってカプセル化され、その DSCP 値は High に設定されます。 該当するパケットが、コントローラに到着します。 該当するパケットが、SSID Test を通過します。 ただし、QoS プロファイル Bronze で設定されているコントローラで SSID Test が実行される場合、コントローラから AP への LWAPP パケットがカプセル化されたパケットの IP ヘッダーは、値 Bronze を持ちます(ただし、アプリケーションからの元のパケットを囲む IP ヘッダーは High という優先順位を持つ)。 このドキュメントでは、アプリケーションによって設定される DSCP と、コントローラ上の SSID の QoS プロファイルが同じであると仮定します。 ただし、いつもそうであるとは限りません。

/image/gif/paws/81831/qos-wlc-lap1.gif

たとえば、802.11e トラフィックは、WLAN クライアントによって送信される場合、フレーム内に User Priority(UP; ユーザ プライオリティ)分類を持ちます。 AP は、この 802.11e 分類を、該当フレームを搬送する LWAPP パケットの DSCP 値にマッピングする必要があります。 該当パケットはそれにより、WLC への途上で適切な優先順位が与えられます。 これに類似したプロセスは、AP に行く LWAPP パケットに対して WLC でも発生する必要があります。 また、非 802.11e クライアントの AP および WLC のトラフィックを分類する(それらの LWAPP パケットに適切な優先順位が与えられる)ためのメカニズムも必要です。 各デバイスでのパケットの処理方法を、次の表に示します。

# 送信元 管理ユーザを認証するための TACACS+ の設定方法については、 UP(802.1p/802.11e) IP DSCP
1 コントローラ アクセス ポイント 着信パケットの DSCP 値が AVVID 802.1p UP 値に変換されない。 DSCP 値は、パケット内に存在する場合、パケットに入った状態で透過的に送信される。 着信パケットから DSCP 値がコピーされる。
2 アクセス ポイント ワイヤレス クライアント WMM クライアント: 着信の LWAPP パケットの DSCP 値を、802.11e UP 値に変換する。 値のポリシングを実行し、該当クライアントに割り当てられている WLAN QoS ポリシーで許可されている最大値を超えないようにする。 UP 値に適した 802.11 Tx キューにパケットを格納する。 通常のクライアント: 該当クライアントに割り当てられている WLAN QoS ポリシーのデフォルトの 802.11 Tx キューにパケットを格納する。 該当なし(元の DSCP 値が保持される)
3 アクセス ポイント コントローラ 該当なし(アクセス ポイントが 802.1Q/802.1p タグをサポートしていない) WMM クライアント: 802.11e UP 値のポリシングを実行し、該当クライアントに割り当てられている QoS ポリシーで許可されている最大値を超えないようにする。 該当値を DSCP 値に変換する。 通常のクライアント: 該当クライアントに割り当てられている QoS ポリシーの 802.11e UP 値を使用する。 該当値を DSCP 値に変換する。
4 コントローラ イーサネット スイッチ 着信の LWAPP パケットの DSCP 値を 802.1p UP 値に変換する。 該当なし(元の DSCP 値が保持される)

802.11e/802.1p UP 値と IP DSCP 値の間で発生する変換を、次の表に示します。 Cisco の Architecture for Voice, Video and Integrated Data(AVVID)では 802.1 UP から IP DSCP への変換、IEEE では IP DSCP から 802.11e UP への変換を定義しているため、2 種類の変換を使用する必要があります。

Cisco AVVID 802.1p UP - 基本のトラフィック タイプ Cisco AVVID IP DSCP Cisco AVVID 802.1p UP IEEE 802.11e UP 注意事項
ネットワーク管理 - 7 - ネットワーク管理専用に予約
ネットワーク間管理 48 6 7 (AC_VO) LWAPP 管理
音声 46 (EF) 5 6 (AC_VO) コントローラ: Platinum QoS プロファイル
ビデオ 34 (AF41) 4 5 (AC_VI) コントローラ: Gold QoS プロファイル
音声制御 26 (AF31) 3 4 (AC_VI) -
ベスト エフォート 0 (BE) 0 3 (AC_BE) 0 (AC_BE) コントローラ: 銀 QoS プロファイル-
バックグラウンド(Cisco AVVID Gold バックグラウンド) 18 (AF21) 2 2 (AC_BK) -
バックグラウンド(Cisco AVVID Silver バックグラウンド) 10 (AF11) 1 1 (AC_BK) コントローラ: Bronze QoS プロファイル

注: IEEE 802.11e は表で DSCP の 3 つの MSB ビットの考慮によって計算される述べられない DSCP 値の値を活動化します。 たとえば、DSCP 32 (バイナリの 100 000)の値の上の IEEE 802.11e は 4.である MSB の十進法変換後の値です(100)。 DSCP 32 の値の上の 802.11e は 4.です。

ネットワーク構成

このドキュメントでは、次のネットワーク構成を使用しています。

  • 有線ネットワークを構成する 2 つのルータ Router1 および Router2 の間では OSPF が動作します。 有線ホストは、FTP サーバ(F1)、音声クライアント(V1)、およびビデオ クライアント(Vi1)から構成されます。 有線ホストは、ルータ R1 のファスト イーサネットに接続されるレイヤ 2 スイッチを介してネットワークに接続されます。

  • ワイヤレス ネットワークは、のように、Router2 を介してネットワークに接続されます。 ワイヤレス ホストは、FTP クライアント(非 WMM 対応)、音声クライアント V1(7920 Phone)、およびビデオ クライアント Vi1(WMM 対応)から構成されます。

  • 優先順位は、音声パケットに最高のものを、ビデオ パケットにはその次のものを与える必要があります。 FTP パケットには、最も低い優先順位を与える必要があります。

  • 有線ネットワークの場合は、QoS を実装するために、Weighted Random Early Detection(WRED; 重み付けランダム早期検出)が使用されます。 DSCP 値に基づいて、さまざまなトラフィック タイプが分類され、優先順位付けされています。 優先順位のあるパケットに対しては、WRED が実装されます。

  • ワイヤレス ネットワークの場合は、トラフィック タイプごとに 3 つの WLAN を作成し、適切な QoS プロファイルを有効にする必要があります。

    • WLAN 1:FTP クライアント: Bronze QoS プロファイル

    • WLAN 2:ビデオ クライアント: Gold QoS プロファイル

    • WLAN 3:音声クライアント: Platinum QoS プロファイル

有線ネットワークでもワイヤレス ネットワークでも、基本的な IP 接続用のデバイスと有効な QoS を設定する必要があります。

/image/gif/paws/81831/qos-wlc-lap4.gif

設定

この項では、このドキュメントで説明する機能の設定に必要な情報を提供します。

注: このドキュメントで使用されているコマンドの詳細を調べるには、Command Lookup Tool登録ユーザ専用)を使用してください。

このセットアップ用にデバイスを設定するには、次の処理を実行する必要があります。

QoS のためのワイヤレス ネットワークの設定

WLC 上の QoS の設定を行う前に、WLC の基本動作を設定し、WLC に LAP を登録する必要があります。 このドキュメントでは、基本動作用に WLC が設定されており、WLC に LAP が登録されていることを前提としています。 WLC で LAP との基本動作を初めて設定する場合は、「Wireless LAN Controller(WLC)への Lightweight AP(LAP)の登録」を参照してください。

WLC に LAP を登録し終えたら、次のタスクを実行して、このセットアップ用に LAP および WLC を設定します。

  1. さまざまなトラフィック クラスに適した WLAN の設定

  2. WLAN に適した QoS プロファイルの有効化

次のステップを実行し、音声クライアントに適した WLAN を WLC 上で作成します。

  1. WLAN を作成するために、コントローラの GUI で [WLANs] をクリックします。

  2. 新しい WLAN を設定するために [New] をクリックします。

    この例では、WLAN に VoiceClients という名前を付け、WLAN ID を 1 に設定します。

  3. [Apply] をクリックします。

    qos-wlc-lap5.gif

  4. [WLAN > Edit] ウィンドウで、WLAN VoiceClients に固有のパラメータを定義します。

    1. WLAN に対し、[Interface Name] フィールドから適切なインターフェイスを選択します。

      この例では、インターフェイス Voice を WLAN VoiceClients にマッピングします。

    2. Quality of Service (QoS) プル ダウン メニューで、WLAN に適した QoS プロファイルを選択します。

      この例では、QoS プロファイル Platinum を選択します。 これにより、音声 WLAN に最高の優先順位が与えられます。

    3. 7920 Phone Support パラメータに対しては、Call Admission Control(CAC; コール アドミッション制御)のタイプを選択します。

      この例では、AP CAC Limit を指定します。

    4. 設計要件に従って、他のパラメータを選択します。

      この例では、デフォルト値を使用します。

    5. [Apply] をクリックします。

      qos-wlc-lap6.gif

      注: ネットワークで Cisco 7920 Phone を使用する場合は、WMM モードを有効にしないでください。 同一の WLAN 上で、WMM モードとクライアント制御型の CAC モードを両方とも有効にすることはできません。 AP 制御型の CAC が有効な場合、AP は標準の QBSS IE を送出せず、Cisco 独自の CAC Information Element(IE; 情報要素)を送出します。

WLAN のインフラストラクチャ上で音声を展開する場合は、WLAN 上で QoS を提供するというシンプルな場合に比べ、多くの事柄が関与します。 音声 WLAN では、サイト調査によるカバレッジ要件、ユーザの動作、ローミング要件、およびアドミッション制御を考慮する必要があります。 これは Cisco Unified IP Phone 7900 シリーズ 設計の指針でカバーされます。

同様に、ビデオ クライアントおよび FTP クライアント用の WLAN を作成します。 ビデオ クライアントはダイナミック インターフェイス ビデオ、FTP クライアントはダイナミック インターフェイス FTP にマッピングします。 スクリーンショットについては、後述の図を参照してください。

注: WLC 上で VLAN を作成する方法は、このドキュメントで説明しません。 WLC でダイナミック インターフェイスを設定する方法については、『無線 LAN コントローラでの VLAN の設定例』を参照してください。

/image/gif/paws/81831/qos-wlc-lap7.gif

qos-wlc-lap8.gif

注: WLAN クライアントにおける WMM のサポートは、クライアント トラフィックが WMM から自動的に利点が得られるという意味ではありません。 WMM の利点を求めるアプリケーションは、各自のトラフィックに適切な優先順位分類を割り当て、オペレーティング システムは該当する分類を WLAN インターフェイスに渡す必要があります。 VoWLAN 受話器のような専用デバイスの場合、この処理は設計の一部として実行されます。 ただし、PC のような汎用的なプラットフォームに実装する場合は、アプリケーションのトラフィック分類と OS によるサポートがないと、WMM 機能の効果が望めません。

ビデオ クライアントの場合は、QoS プロファイル Gold を選択し、WMM を有効にします。 FTP クライアントの場合は、QoS プロファイルとして Bronze を選択し、WMM を無効にします(この例では、FTP クライアントが WMM をサポートしていないため)。

qos-wlc-lap9.gif

qos-wlc-lap10.gif

注: コントローラがレイヤ 2 モードで、WMM が有効な場合、AP にコントローラへの加入を許可するには、AP をトランク ポートに置く必要があります。

CLI を使用し、WLC 上で WLAN および QoS を設定するには、次のコマンドを発行します。

  • config wlan create <wlan-id> <wlan-name> コマンド:新しい WLAN を作成する際に発行します。 wlan-id に対して、1 ~ 16 の ID を入力します。 wlan-name に対して、31 文字以下の英数字で SSID を入力します。

  • config wlan enable <wlan-id> コマンド:WLAN を有効にする際に発行します。

  • config wlan qos wlan-id {bronze | シルバー | ゴールド | platinum} コマンド:QoS レベルを WLAN に割り当てる際に発行します。

  • config wlan wmm {disabled | allowed | required} wlan-idコマンド:WMM モードを有効にする際に発行します。

  • config wlan 7920-support client-cac-limit {enabled | disabled} wlan-idコマンド:クライアント制御型の CA が必要な電話の場合に発行します。

  • config wlan 7920-support ap-cac-limit {enabled | disabled} wlan-idコマンド:AP 制御型の CAC が必要な電話の場合に発行します。

QoS のための有線ネットワークの設定

この構成用に有線ネットワークを設定するには、基本的な接続用のルータを設定し、有線ネットワーク内で QoS を有効にする必要があります。 ユニキャスト ルーティング プロトコルとして、OSPF を使用します。

有線ネットワークに QoS を実装するために、WRED 機能を使用します。 DiffServ 準拠の WRED 機能を使用すると、パケットの廃棄確率を計算する際、WRED で DSCP 値を使用できます。

ルータ R1 および R2 の設定を、次に示します。

Router1
Router1#show run
Building configuration...

Current configuration : 2321 bytes
!
version 12.2
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname Router1
!
!
ip subnet-zero
!
!
!
call rsvp-sync
!

!
class-map match-all FTP

!--- Classifies FTP Packets based on Access List 103.

  match access-group 103
class-map match-all Video

!--- Classifies Video Packets based on Access List 102.

  match access-group 102
class-map match-all Voice

!--- Classifies Voice Packets based on Access List 101.

  match access-group 101
!
!
policy-map Marking-For-FTP

!--- Sets DSCP value af11 for FTP packets.

  class FTP
   set ip dscp af11
policy-map Marking-For-Voice

!--- Sets DSCP value ef for Voice packets.

  class Voice
   set ip dscp ef
policy-map Marking-For-Video

!--- Sets DSCP value af41 for Video packets.

  class Video
   set ip dscp af41
!
!
!
interface Serial2/0
 description Connected to Router2
 ip address 10.2.3.2 255.255.255.0
 random-detect dscp-based 

!--- Enables WRED based on DSCP Value of the packet.

 random-detect dscp 10 30 40

!--- Sets the Minimum and Maximum Threshold of Packets 
!--- to 30 and 40 packets for the DSCP value 10.

 random-detect dscp 34 40 50

!--- Sets the Minimum and Maximum Threshold of Packets 
!--- to 40 and 50 packets for the DSCP value 34.

 random-detect dscp 46 50 60

!--- Sets the Minimum and Maximum Threshold of Packets 
!--- to 50 and 60 packets for the DSCP value 46.

 clockrate 56000
!
interface Serial2/1
 no ip address
 shutdown
!
interface Serial2/2
 no ip address
 shutdown
!
interface Serial2/3
 no ip address
 shutdown
!
interface Serial2/4
 no ip address
 shutdown
!
interface Serial2/5
 no ip address
 shutdown
!
interface Serial2/6
 no ip address
 shutdown
!
interface Serial2/7
 no ip address
 shutdown
!
interface FastEthernet3/0
 no ip address
 duplex auto
 speed auto
!
interface FastEthernet3/0.1
 description Connected to Voice Clients
 encapsulation dot1Q 10
 ip address 192.168.0.1 255.255.0.0
 service-policy output Marking-For-Voice

!--- Applies the policy Marking-For-Voice to the interface.

!
interface FastEthernet3/0.2
 description Connected to Video Clients
 encapsulation dot1Q 20
 ip address 172.16.0.1 255.255.0.0
 service-policy output Marking-For-Video

!--- Applies the policy Marking-For-Video to the interface.

!
interface FastEthernet3/0.3
 description Connected to FTP Server
 encapsulation dot1Q 30
 ip address 30.0.0.1 255.0.0.0
 service-policy output Marking-For-FTP

!--- Applies the policy Marking-For-FTP to the interface.

!
interface FastEthernet3/1
 no ip address
 shutdown
 duplex auto
 speed auto
!
router ospf 1

!--- Configures OSPF as the routing protocol.

 log-adjacency-changes
 network 10.0.0.0 0.255.255.255 area 0
 network 30.0.0.0 0.0.0.255 area 0
 network 172.16.0.0 0.0.255.255 area 0
 network 192.168.0.0 0.0.255.255 area 0
!
ip classless
ip http server
!
access-list 101 permit ip 192.168.0.0 0.0.255.255 any

!--- Access list used to classify Voice packets.

access-list 102 permit ip 172.16.0.0 0.0.255.255 any

!--- Access list used to classify Video packets.

access-list 103 permit ip 30.0.0.0 0.0.0.255 any

!--- Access list used to classify FTP packets.

!
voice-port 1/0/0
!
voice-port 1/0/1
!
voice-port 1/1/0
!
voice-port 1/1/1
!
dial-peer cor custom
!
!
!
dial-peer voice 1 pots
 destination-pattern 4085551234
 port 1/0/0
!
!
line con 0
line aux 0
line vty 0 4
!
end

Router2
Router2#show run
Building configuration...

Current configuration : 1551 bytes
!
version 12.3
service config
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname Router2
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
ip subnet-zero
!

!
interface FastEthernet0/0
 ip address dhcp
 duplex auto
 speed auto
!
interface FastEthernet0/0.1
 description Connected to Voice Clients
 encapsulation dot1Q 40
 ip address 20.0.0.1 255.0.0.0
!
interface FastEthernet0/0.2
 description Connected to Video Clients
 encapsulation dot1Q 50
 ip address 40.0.0.1 255.0.0.0
!
interface FastEthernet0/0.3
 description Connected to FTP Clients
 encapsulation dot1Q 60
 ip address 50.0.0.1 255.0.0.0
!
interface Serial0/0
 description Connected to Router1
 ip address 10.2.3.1 255.255.255.0
 random-detect dscp-based

!--- Enables WRED based on DSCP Value of the packet.

 random-detect dscp 10 30 40

!--- Sets the Minimum and Maximum Threshold of Packets 
!--- to 30 and 40 packets for the DSCP value 10.

 random-detect dscp 34 40 50

!--- Sets the Minimum and Maximum Threshold of Packets 
!--- to 40 and 50 packets for the DSCP value 34.

 random-detect dscp 46 50 60

!--- Sets the Minimum and Maximum Threshold of Packets 
!--- to 50 and 60 packets for the DSCP value 46.

!
interface FastEthernet0/1
 no ip address
 shutdown
 duplex auto
 speed auto
!
interface Service-Engine2/0
 no ip address
 shutdown
 hold-queue 60 out
!
router ospf 1

!--- Configures OSPF as the routing protocol.

 log-adjacency-changes
 network 10.0.0.0 0.255.255.255 area 0
 network 20.0.0.0 0.255.255.255 area 0
 network 40.0.0.0 0.255.255.255 area 0
 network 50.0.0.0 0.255.255.255 area 0
!
ip http server
ip classless
!
!
control-plane
!
!
voice-port 1/0/0
!
voice-port 1/0/1
!
gatekeeper
 shutdown
!
!
line con 0
line 65
 no activation-character
 no exec
 transport preferred none
 transport input all
 transport output all
line aux 0
line vty 0 4
!
!
end

確認とトラブルシューティング

ワイヤレス ネットワークおよび有線ネットワークの基本的な接続の設定が完了し、QoS を実装したら、トラフィック タイプごとに設定されているポリシーに基づいて、パケットの分類、マーキング、および送信が実行されます。

QoS 機能の適用は、負荷が軽いネットワークでは検出されにくい場合があります。 QoS 機能は、ネットワークの負荷が増えるに従ってアプリケーションのパフォーマンスに影響を与え始めます。 QoS は、選択されたトラフィック タイプの遅延、ジッタ、および損失を、妥当な範囲内に維持しようとします。

WMM 対応のビデオ クライアントの場合:

有線側のビデオ クライアントがワイヤレス側のビデオ クライアントにデータを送信する際は、次のような順序で一連のイベントが発生します。

  1. Router1 上のファストイーサネット インターフェイスで、Marking-For-Video ポリシーがビデオ パケットに適用され、DSCP 値 AF41 でパケットがマーキングされます。

  2. マーキングされたビデオ パケットが、Router1 上の S3/0 および Router2 上の S0/0 というシリアル インターフェイスを通過します。 この場所で、パケットの廃棄確率が、WRED で設定されているしきい値に照らしてチェックされます。 キューの平均長が最小のしきい値(ビデオ パケットの場合は 40 パケット)に到達すると、WRED は DSCP 値が AF41 のパケットをいくつかランダムに廃棄します。 それと同様に、キューの平均長が最大のしきい値(ビデオ パケットの場合は 50 パケット)に到達すると、WRED は DSCP 値が AF41 のパケットをすべて廃棄します。

  3. ビデオ パケットが Router2 上のファストイーサネットを介して WLC に到達すると、WLC は着信パケットの DSCP 値を AVVID 802.1p UP 値に変換し、着信パケットの DSCP 値を図のように LWAPP パケットにコピーします。 この例の場合は、DSCP 値 AF41 が、対応する 802.1p 値 4 に変換されます。

    qos-wlc-lap11.gif

  4. パケットが LAP に到達すると、LAP は着信の LWAPP パケットの DSCP 値を 802.11e UP 値に変換し、該当クライアントに割り当てられている WLAN QoS ポリシーで許可されている最大値を超えないようにするために該当値のポリシングを実行します。 LAP はその後、該当パケットを UP 値に適した 802.11 Tx キューに格納します。 この例の場合は、DSCP 値 AF41 が、対応する 802.11e UP 値 5 に変換されます。

    /image/gif/paws/81831/qos-wlc-lap12.gif

ワイヤレス側のビデオ クライアントが有線側にデータを送信する際は、次のような順序で一連のイベントが発生します。

  1. WMM 対応のクライアントが LAP にパケットを送信すると、LAP は該当クライアントに割り当てられている QoS ポリシーで許可されている最大値を超えないようにするために 802.11e UP 値のポリシングを実行します。 その後、該当値を DSCP 値に変換します。 この例では、ビデオ WLAN が QoS プロファイル Gold で設定されています(802.11e UP 値は 4)。 この値が、対応する DSCP 値 AF41 に変換され、コントローラに送信されます。

    /image/gif/paws/81831/qos-wlc-lap13.gif

  2. コントローラが図のように着信の LWAPP パケットの DSCP 値を 802.1p UP 値に変換します。元の DSCP 値も、変更されずに送信されます。

    /image/gif/paws/81831/qos-wlc-lap14.gif

  3. Router2 のファストイーサネットで DSCP 値が af41 のパケットが、Router2 および Router1 上のシリアル インターフェイスを通過し、有線側のビデオ クライアントに到達します。 該当パケットがシリアル インターフェイスを通過する際は、パケットの廃棄確率が、WRED で設定されているしきい値に照らしてチェックされます。

WMM 非対応の FTP クライアントの場合:

有線側の FTP サーバがワイヤレス側の FTP クライアントにデータを送信する際は、次のような順序で一連のイベントが発生します。

  1. Router1 上のファストイーサネット インターフェイスで、Marking-For-FTP ポリシーが FTP パケットに適用され、DSCP 値 AF11 でパケットがマーキングされます。

  2. マーキングされた FTP パケットが、Router1 上の s3/0 および Router2 上の S0/0 というシリアル インターフェイスを通過します。 この場所で、パケットの廃棄確率が、WRED で設定されているしきい値に照らしてチェックされます。 キューの平均長が最小のしきい値(FTP パケットの場合は 30 パケット)に到達すると、WRED は DSCP 値が AF11 のパケットをいくつかランダムに廃棄します。 それと同様に、キューの平均長が最大のしきい値(FTP パケットの場合は 40 パケット)に到達すると、WRED は DSCP 値が AF11 のパケットをすべて廃棄します。

  3. FTP パケットが Router2 上のファストイーサネットを介して WLC に到達すると、WLC は着信パケットの DSCP 値を AVVID 802.1p UP 値に変換し、着信パケットの DSCP 値を図のように LWAPP パケットにコピーします。 この例の場合は、DSCP 値 AF11 が、対応する 802.1p 値 1 に変換されます。

  4. 該当パケットが LAP に到達すると、LAP は該当クライアントに割り当てられている WLAN QoS ポリシーのデフォルトの 802.11 Tx キューにパケットを格納します。 この例の場合、該当パケットは Bronze QoS プロファイルのキューに格納されます。

ワイヤレス側の FTP クライアントが有線側にデータを送信する際は、次のような順序で一連のイベントが発生します。

  1. ワイヤレス ネットワーク上の FTP クライアントが LAP にパケットを送信すると、LAP は該当クライアントに割り当てられている QoS ポリシーの 802.11e UP 値を使用します。 次に、LAP は該当値を DSCP 値に変換し、該当パケットをコントローラに送信します。 FTP クライアントが QoS プロファイル Bronzeに属しているため、IEEE 802.11e UP 値 1 が DSCP 値 AF11 に変換されます。

  2. コントローラが図のように着信の LWAPP パケットの DSCP 値を 802.1p UP 値に変換します。元の DSCP 値も、変更されずに送信されます。 該当パケットはその後、レイヤ 2 スイッチを介して、Router2 に転送されます。

  3. Router2 のファストイーサネットで DSCP 値が AF11 のパケットが、Router2 および Router1 上のシリアル インターフェイスを通過し、有線側のビデオ クライアントに到達します。 該当パケットがシリアル インターフェイスを通過する際は、パケットの廃棄確率が、WRED で設定されているしきい値に照らしてチェックされます。

音声パケットが有線ネットワークからワイヤレス ネットワークに通過する場合も、ワイヤレス ネットワークから有線ネットワークに通過する場合も、同様な手順が実行されます。

トラブルシューティングのためのコマンド

Output Interpreter Tool(OIT)(登録ユーザ専用)では、特定の show コマンドがサポートされています。 OIT を使用して、show コマンド出力の解析を表示できます。

注: debug コマンドを使用する前に、『debug コマンドの重要な情報』を参照してください。

ルータ上で次の Cisco IOS コマンドを発行すると、QoS 設定のトラブルシューティングおよび確認が行えます。

  • show queue {interface-name interface-number}:インターフェイス上のキューで待機中のパケットに関する情報がリストされます。

  • show queueing random-detect interface {interface-name interface-number}:インターフェイス上のキューイング ツールに関する設定情報および統計情報がリストされます。

  • show policy-map interface {interface-name interface-number}:インターフェイスに接続されている入力ポリシーおよび出力ポリシーの統計および設定が表示されます。 このコマンドは、適切な EXEC モードで使用する必要があります。

    Router1#show policy-map interface F3/0.1
     FastEthernet3/0.1
    
      Service-policy output: Marking-For-Voice
    
        Class-map: Voice (match-all)
          18 packets, 1224 bytes
          5 minute offered rate 0 bps, drop rate 0 bps
          Match: access-group 101
          QoS Set
            dscp ef
              Packets marked 18
    
        Class-map: class-default (match-any)
          2 packets, 128 bytes
          5 minute offered rate 0 bps, drop rate 0 bps
          Match: any
  • debug qos set:QoS パケット マーキングに関する情報が表示されます。

WLC の場合、このコマンドは QoS プロファイルの設定値を表示する際に発行します。

  • show qos {bronze/silver/gold/platinum}:WLAN で設定されている QoS プロファイルの情報が得られます。

    show qos コマンドの出力例を次に示します。

    (Cisco Controller) >show qos Platinum
    
    Description...................................... For Voice Applications
    Average Data Rate................................   0
    Burst Data Rate..................................   0
    Average Realtime Data Rate.......................   0
    Realtime Burst Data Rate.........................   0
    Maximum RF usage per AP (%)...................... 100
    Queue Length..................................... 100
    protocol......................................... none
    
    (Cisco Controller) >show qos Gold
    
    Description...................................... For Video Applications
    Average Data Rate................................   0
    Burst Data Rate..................................   0
    Average Realtime Data Rate.......................   0
    Realtime Burst Data Rate.........................   0
    Maximum RF usage per AP (%)...................... 100
    Queue Length.....................................  75
    protocol......................................... none
    
    (Cisco Controller) >show qos Bronze
    
    Description...................................... For Background
    Average Data Rate................................   0
    Burst Data Rate..................................   0
    Average Realtime Data Rate.......................   0
    Realtime Burst Data Rate.........................   0
    Maximum RF usage per AP (%)...................... 100
    Queue Length.....................................  25
    protocol......................................... none
  • show wlan WLAN-ID:WLAN に関する情報が表示されます。 次に出力例を示します。

    (Cisco Controller) >show wlan 1
    
    WLAN Identifier.................................. 1
    Network Name (SSID).............................. VoiceClients
    Status........................................... Enabled
    MAC Filtering.................................... Disabled
    Broadcast SSID................................... Enabled
    AAA Policy Override.............................. Disabled
    Number of Active Clients......................... 0
    Exclusionlist Timeout............................ 60 seconds
    Session Timeout.................................. 1800 seconds
    Interface........................................ management
    WLAN ACL......................................... unconfigured
    DHCP Server...................................... Default
    DHCP Address Assignment Required................. Disabled
    Quality of Service............................... Platinum (voice)
    WMM.............................................. Disabled
    CCX - AironetIe Support.......................... Enabled
    CCX - Gratuitous ProbeResponse (GPR)............. Disabled
    Dot11-Phone Mode (7920).......................... Disabled
    Wired Protocol................................... None
    IPv6 Support..................................... Disabled
    Radio Policy..................................... All
    Security
    
       802.11 Authentication:........................ Open System
       Static WEP Keys............................... Disabled
       802.1X........................................ Enabled
       Encryption:..................................... 104-bit WEP
       Wi-Fi Protected Access (WPA/WPA2)............. Disabled
       CKIP ......................................... Disabled
       IP Security Passthru.......................... Disabled
       Web Based Authentication...................... Disabled
       Web-Passthrough............................... Disabled
       Auto Anchor................................... Disabled
       H-REAP Local Switching........................ Disabled
       Management Frame Protection................... Enabled (Global MFP Disabled)

関連するシスコ サポート コミュニティ ディスカッション

シスコ サポート コミュニティは、どなたでも投稿や回答ができる情報交換スペースです。


関連情報


Document ID: 81831