スイッチ : Cisco Catalyst 6500 シリーズ スイッチ

PVST+ から MST へスパニングツリーを移行するための設定例

2015 年 11 月 26 日 - 機械翻訳について
その他のバージョン: PDFpdf | ライター翻訳版 (2006 年 12 月 13 日) | 英語版 (2015 年 10 月 7 日) | フィードバック


目次


概要

このドキュメントでは、キャンパス ネットワークで PVST+ から Multiple Spanning Tree(MST)へスパニング ツリー モードを移行するための設定例を説明します。

前提条件

要件

MST を設定する前に『Multiple Spanning Tree Protocol(802.1s)の概要』を参照してください。

次の表に、Catalyst スイッチにおける MST のサポートと、サポートに必要な最低限のソフトウェアを示します。

Catalyst プラットフォーム RSTP を実装した MST
Catalyst 2900XL および 3500XL 該当なし
Catalyst 2950 および 3550 Cisco IOS(R) 12.1(9)EA1
Catalyst 3560 Cisco IOS 12.1(9)EA1
Catalyst 3750 Cisco IOS 12.1(14)EA1
Catalyst 2955 すべての Cisco IOS のバージョン
Catalyst 2948G-L3 および 4908G-L3 該当なし
Catalyst 4000、2948G、および 2980G(Catalyst OS(CatOS)) 7.1
Catalyst 4000 および 4500(Cisco IOS) 12.1(12c)EW
Catalyst 5000 および 5500 該当なし
Catalyst 6000 および 6500(CatOS) 7.1
Catalyst 6000 および 6500(Cisco IOS) 12.1(11b)EX、12.1(13)E、12.2(14)SX
Catalyst 8500 該当なし

  • Catalyst 3550/3560/3750: Cisco IOS リリース 12.2(25)SEC における MST の実装は、IEEE 802.1s 標準に基づいています。 それよりも前の Cisco IOS リリースにおける MST の実装は標準化以前のものです。

  • Catalyst 6500(IOS): Cisco IOS リリース 12.2(18)SXF における MST の実装は、IEEE 802.1s 標準に基づいています。 それよりも前の Cisco IOS リリースにおける MST の実装は標準化以前のものです。

使用するコンポーネント

この資料は Cisco IOS ソフトウェア リリース 12.2(25) および CatOS で 8.5(8) 作成されますが、設定は表で述べられる最小 IOSバージョンに適当です。

このドキュメントの情報は、特定のラボ環境にあるデバイスに基づいて作成されたものです。 このドキュメントで使用するすべてのデバイスは、クリアな(デフォルト)設定で作業を開始しています。 ネットワークが稼働中の場合は、コマンドが及ぼす潜在的な影響を十分に理解しておく必要があります。

表記法

ドキュメント表記の詳細は、『シスコ テクニカル ティップスの表記法』を参照してください。

背景説明

MST 機能は IEEE 802.1s で、802.1Q に対する追補です。 MST は、802.1w Rapid Spanning Tree(RST)アルゴリズムを複数のスパニング ツリーに拡張します。 この拡張により、VLAN 環境における高速コンバージェンスとロード バランシングの両方が実現されます。 PVST+ と Rapid-PVST+ は、各 VLAN でスパニング ツリー インスタンスを実行します。 MST では、複数の VLAN を 1 つのインスタンスにグループ化できます。 MST は Bridge Protocol Data Unit(BPDU; ブリッジ プロトコル データ ユニット)バージョン 3 を使用しますが、これは BPDU バージョン 0 を使用する 802.1D STP と下位互換性があります。

MSTP の設定: 設定には領域の名前、リビジョン番号、および MST の VLAN からインスタンスへの割り当てマップが含まれます。 ある領域に対してスイッチを設定するには、spanning-tree mst configuration グローバル設定コマンドを使用します。

MST 領域: MST 領域は、同じ MST 設定を持つ相互接続されたブリッジから構成されます。 ネットワーク内の MST 領域の数には制限がありません。

MST 領域内のスパニング ツリー インスタンス: インスタンスとは spanning-tree mst configuration コマンドでマッピングされた VLAN のグループにすぎません。 デフォルトではすべての VLAN が IST0 にグループ化され、これは Internal Spanning Tree(IST; 内部スパンニングツリー)と呼ばれます。 1 〜 4094 に番号付けされたインスタンスを手動で作成でき、これらのインスタンスには MSTn(n は 1 〜 4094)というラベル付けがされますが、領域でサポートできるのは最大で 65 のインスタンスまでです。 一部のリリースでは、サポートされるインスタンスは 16 しかありません。 スイッチ プラットフォームのソフトウェア設定ガイドを参照してください。

IST/CST/CIST: IST は、MST ネットワーク内で BPDU を送受信できる唯一のインスタンスです。 MSTn インスタンスは領域に対してローカルです。 異なる領域の IST は、Common Spanning Tree(CST)を介して相互接続されます。 各 MST 内の IST の集合、および IST を接続している CST は Common and Internal Spanning Tree(CIST)と呼ばれます。

下位互換性: MST は PVST+、Rapid-PVST+、および、標準策定前の MST(MISTP; Multi-Instance Spanning Tree Protocol)と下位互換性があります。 MST スイッチは、Common Spanning Tree(CST)により、他の STP(PVST+ および Rapid-PVST+)スイッチに接続されます。 その他の STP(PVST+ および Rapid-PVST+)スイッチでは、MST 領域が 1 つのスイッチとして認識されます。 標準策定前の MST スイッチを標準の MST スイッチに接続する場合は、標準の MST スイッチのインターフェイスで spanning-tree mst pre-standard を設定する必要があります。

設定

次の例には 2 つのセクションが含まれています。 第 1 のセクションには現在の PVST+ の設定が示されています。 第 2 のセクションには PVST+ から MST への移行を行う設定が示されています。

注: このセクションで使用されているコマンドの詳細を調べるには、Command Lookup Tool登録ユーザ専用)を使用してください。

ネットワーク構成図

このドキュメントでは、次のネットワーク構成を使用しています。

下記の図には次のスイッチが含まれています。

  • ディストリビューション レイヤ内にある Distribution1 および Distribution2

  • Access1(IOS)および Access2(CatOS)と呼ばれる 2 台のアクセスレイヤ スイッチ

  • Services1 および Services2 と呼ばれる 2 台のサーバ集約スイッチ

VLAN 10、30、および 100 がデータ トラフィックを伝送します。 VLAN 20、40、および 200 が音声トラフィックを伝送します。

/image/gif/paws/72844/MST-1.gif

設定

このドキュメントでは、次の設定を使用します。

PVST+ の設定

スイッチは、ネットワーク ダイアグラムにあるように、PVST+ でデータおよび音声トラフィックを伝送するように設定されています。 次に設定の簡潔な要約を示します。

  • Distribution1 スイッチは Distribution1(config)# spanning-tree vlan 10,30,100 root primary コマンドを使用してデータ VLAN 10、30、および 100 のプライマリ ルート ブリッジになるよう設定されていて、また音声 VLAN 20、40、および 200 のセカンダリ ルート ブリッジには Distribution1(config)# spanning-tree vlan 20,40,200 root secondary コマンドが使用されています。

  • Distribution2 スイッチは Distribution2(config)# spanning-tree vlan 20,40,200 root primary コマンドを使用して音声 VLAN 20、40、および 200 のプライマリ ルート ブリッジになるよう設定されていて、またデータ VLAN 10、30、および 100 のセカンダリ ルート ブリッジには Distribution2(config)# spanning-tree vlan 10,30,100 root secondary コマンドが使用されています。

  • ネットワークで間接的なリンク障害が発生した場合に、より迅速に STP をコンバージするため、すべてのスイッチ上で spanning-tree backbonefast コマンドが設定されています。

  • 直接的なアップリンク障害が発生した場合に、より迅速に STP をコンバージするため、アクセスレイヤ スイッチ上で spanning-tree uplinkfast コマンドが設定されています。

Distribution1
Distribution1#show running-config 
 Building configuration...
spanning-tree mode pvst
spanning-tree extend system-id
spanning-tree backbonefast
spanning-tree vlan 10,30,100 priority 24576
spanning-tree vlan 20,40,200 priority 28672
!
vlan 10,20,30,40,100,200
!
interface FastEthernet1/0/1
 switchport trunk encapsulation dot1q
 switchport mode trunk
 switchport trunk allowed vlan 10,20
!
interface FastEthernet1/0/3
 switchport trunk encapsulation dot1q
 switchport mode trunk
 switchport trunk allowed vlan 30,40
!
interface FastEthernet1/0/5
 switchport trunk encapsulation dot1q
 switchport mode trunk
 switchport trunk allowed vlan 100,200
!
interface FastEthernet1/0/23
 switchport trunk encapsulation dot1q
 switchport mode trunk
 switchport trunk allowed vlan 10,20,30,40,100,200
!
interface FastEthernet1/0/24
 switchport trunk encapsulation dot1q
 switchport mode trunk
 switchport trunk allowed vlan 10,20,30,40,100,200
!
 !
 end

ポート Fa1/0/24 が spanning-tree vlan 20,40,200 port-priority 64 コマンドを使用して設定されていることが確認できます。 Distribution2 は VLAN 20、40、および 200 の設定済みルート(root)です。 Distribution2 に Distribution1 への 2 つのリンクがあります: Fa1/0/23 および Fa1/0/24。 Distribution2 は VLAN 20、40、および 200 のルート(root)なので、両方のポートはこれらの VLAN の代表ポートです。 両方のポートのプライオリティは 128(デフォルト)で同じです。 また、これら二つのリンクに Distribution1 からの同じコストがあります: fa1/0/23 および fa1/0/24。 Distribution1 は、ポートをフォワーディング ステートに設定するため、2 つのポートから最も低いポート番号を選択します。 最も低いポート番号は Fa1/0/23 ですが、ネットワーク ダイアグラムにあるように、音声 VLAN 20、40、および 200 は Fa1/0/24 を通過できます。 これは次の方法で実現できます。

  1. Distribution1 のポート コストを減少させて下さい: Fa1/0/24.

  2. Distribution2 のポートプライオリティを減少させて下さい: Fa1/0/24.

次の例では、fa1/0/24 を経由して VLAN 20、40、200 を転送するため、ポート プライオリティが小さくなっています。

Distribution2
Distribution2#show running-config 
 Building configuration...
!
spanning-tree mode pvst
spanning-tree extend system-id
spanning-tree backbonefast
spanning-tree vlan 10,30,100 priority 28672
spanning-tree vlan 20,40,200 priority 24576
!
vlan 10,20,30,40,100,200
!
interface FastEthernet1/0/2
 switchport trunk encapsulation dot1q
 switchport mode trunk
 switchport trunk allowed vlan 10,20
!
interface FastEthernet1/0/4
 switchport trunk encapsulation dot1q
 switchport mode trunk
 switchport trunk allowed vlan 30,40
!
interface FastEthernet1/0/6
 switchport trunk encapsulation dot1q
 switchport mode trunk
 switchport trunk allowed vlan 100,200
!
interface FastEthernet1/0/23
 switchport trunk encapsulation dot1q
 switchport mode trunk
 switchport trunk allowed vlan 10,20,30,40,100,200
!
interface FastEthernet1/0/24
 switchport trunk encapsulation dot1q
 switchport mode trunk
 spanning-tree vlan 20,40,200 port-priority 64
 switchport trunk allowed vlan 10,20,30,40,100,200

end

Services1 のポート Fa0/5、および Services2 の Fa0/6 と Fa0/48 の両方にスパニング ツリーのポート コストおよびポート プライオリティの設定があることが確認できます。 この場合、Services1 と Services2 の VLAN 100 および 200 が、それらの間のトランク リンクを通過できるよう STP が調整されています。 この設定が適用されていない場合、Services1 と 2 は、それらの間のトランク リンク経由でトラフィックを受け渡すことができません。 その代わりに、Distribution1 と Distribution2 を経由するパスが選択されます。

Services2 は VLAN 100 に 2 つの等コスト パスが定着するのを見ます(Distribution1): 1 直通 Services1 および第 2 1 直通 Distribution2。 STP は最適パス(ルート パス)を次の順序で選択します。

  1. パス コスト

  2. フォワーディング スイッチのブリッジ ID

  3. 最も低いポート プライオリティ

  4. 最も低い内部ポート番号

この例では、両方のパスはコストが同じですが、VLAN 100 に関して Distribution2(24576)は Services1(32768)よりもプライオリティが低いため、Services2 は Distribution2 を選択します。 この例では、Services1 のポート コスト: fa0/5 は Services1 を選択するように Services2 がする一定下部のです。 パス コストは、フォワーディング スイッチのプライオリティ番号よりも優先されます。

Services1
Services1#show running-config 
 Building configuration...
spanning-tree mode pvst
spanning-tree portfast bpduguard default
spanning-tree extend system-id
spanning-tree backbonefast
!
vlan 100,200
!
interface FastEthernet0/5
 switchport trunk encapsulation dot1q
 switchport mode trunk
 spanning-tree vlan 100 cost 18
 switchport trunk allowed vlan 100,200
!
interface FastEthernet0/47
 switchport trunk encapsulation dot1q
 switchport mode trunk
 switchport trunk allowed vlan 100,200
!
interface FastEthernet0/48
 switchport trunk encapsulation dot1q
 switchport mode trunk
 switchport trunk allowed vlan 100,200
!
!
 end

同じ概念は Services1 にも当てはまり、VLAN 200 の転送に Services2 が選択されます。 Services2 の fa0/6 で VLAN 200 のコストを小さくすると、Services1 は VLAN 200 の転送に fa0/47 を選択します。 ここでの条件は、fa0/48 を経由して VLAN 200 を転送することです。 これは次の 2 つの方法で実現できます。

  1. Services1 のポート コストを減少させて下さい: Fa0/48.

  2. Services2 のポートプライオリティを減少させて下さい: Fa0/48.

この例では、fa0/48 経由で VLAN 200 を転送するために、Services2 のポート プライオリティが小さくなっています。

Services2
Services2#show running-config 
 Building configuration...
spanning-tree mode pvst
spanning-tree portfast bpduguard default
spanning-tree extend system-id
spanning-tree backbonefast
!
vlan 100,200
!
interface FastEthernet0/6
 switchport trunk encapsulation dot1q
 switchport mode trunk
 spanning-tree vlan 200 cost 18
 switchport trunk allowed vlan 100,200
!
interface FastEthernet0/47
 switchport trunk encapsulation dot1q
 switchport mode trunk
 switchport trunk allowed vlan 100,200
!
interface FastEthernet0/48
 switchport trunk encapsulation dot1q
 switchport mode trunk
 spanning-tree vlan 200 port-priority 64
 switchport trunk allowed vlan 100,200
!
 !
 end

Access1
Access1#show running-config 
 Building configuration...
!
spanning-tree mode pvst
spanning-tree portfast bpduguard default
spanning-tree extend system-id
spanning-tree uplinkfast
spanning-tree backbonefast
!
vlan 10,20
!
interface FastEthernet0/1
 switchport trunk encapsulation dot1q
 switchport mode trunk
 switchport trunk allowed vlan 10,20
!
interface FastEthernet0/2
 switchport trunk encapsulation dot1q
 switchport mode trunk
 switchport trunk allowed vlan 10,20
!
 end

Access2
Access2> (enable)show config all 

#mac address reduction
set spantree macreduction enable
!
#stp mode
set spantree mode pvst+
!
#uplinkfast groups
set spantree uplinkfast enable rate 15 all-protocols off
!
#backbonefast
set spantree backbonefast enable
!
#vlan parameters
set spantree priority 49152  1
set spantree priority 49152  30
set spantree priority 49152  40
!
#vlan(defaults)
set spantree enable  1,30,40
set spantree fwddelay 15     1,30,40
set spantree hello    2      1,30,40
set spantree maxage   20     1,30,40
!
#vtp
set vlan 1,30,40
!
#module 3 : 48-port 10/100BaseTX Ethernet
set trunk 3/3  on dot1q 30,40
set trunk 3/4  on dot1q 30,40
!
 end

MST への移行

企業ネットワークのすべてのスイッチを同時に MST に変更することは困難です。 下位互換性により、この変更は段階的に行うことができます。 スパニング ツリーの再設定はトラフィック フローを中断させることがあるため、スケジュールされたメンテナンス時間帯に変更を実施します。 MST を有効にすると、RSTP も有効になります。 スパニング ツリーの UplinkFast および BackboneFast 機能は PVST+ の機能であり、これらの機能は RSTP 内部に構築され、MST は RSTP に依存しているため、ユーザが MST を有効にすると無効になります。 移行中、IOS ではこれらのコマンドを削除できます。 CatOS の BackboneFast と UplinkFast では、コマンドは設定から自動的にクリアされますが、PortFast、bpduguard、bpdufilter、ルート ガード、およびループ ガードなどの機能の設定は MST モードでも適用されます。 これらの機能の使用法は、PVST+ モードと同じです。 PVST+ モードですでにこれらの機能を有効にしている場合、MST モードへの移行の後も、これらの機能はアクティブなままになります。 MST を設定する際には、次のガイドラインと制限事項に従ってください。

  • 802.1s/w への移行の第一段階は、ポイントツーポイントとエッジ ポートを正しく識別することです。 急速な遷移が求められるスイッチツースイッチ リンクが、すべて全二重になっていることを確認します。 エッジ ポートは、PortFast 機能で定義します。

  • ネットワーク内のすべてのスイッチで共有する設定名とリビジョン番号を選択します。 Cisco は単一領域にできるだけ多くのスイッチを置くことを推奨します; 別々の領域にネットワークをセグメント化することは有利ではないです。

  • インスタンスが論理トポロジに変換されることを念頭において、スイッチド ネットワーク内で必要なインスタンスの数を慎重に決定します。 インスタンス 0 に VLAN をマッピングすることは避けてください。 それらのインスタンスにどの VLAN をマップするかを決定し、慎重に各インスタンスのルート(root)とバックアップ ルート(back-up root)を選択します。

  • インスタンスにマップされているすべての VLAN をトランクが伝送するようにするか、このインスタンスの VLAN をまったく伝送しないようにします。

  • MST は PVST+ が稼働している従来のブリッジとポート単位で相互対話できます。したがって、ブリッジのタイプが混在しても、相互対話が明確に認識されていれば問題ありません。 CST と IST のルートは常に領域の中に置くようにします。 トランクを通して PVST+ ブリッジと相互対話する場合、MST ブリッジがそのトランク上で許可されているすべての VLAN のルートになっていることを確認します。 PVST ブリッジは CST のルートとしては使用しないでください。

  • すべての PVST スパニング ツリー ルート ブリッジが、CST ルート ブリッジよりもプライオリティが低くなる(数字上は大きくなる)ようにしてください。

  • PVST ブリッジの VLAN 上ではスパニング ツリーを無効にしないでください。

  • アクセス リンクは VLAN を分割する可能性があるため、スイッチの接続にはアクセス リンクを使用しないでください。

  • 現行または新しい論理 VLAN ポートを多数含む MST 設定は、すべてメンテナンス時間帯に完了する必要があります。これは、インスタンスへの新しい VLAN の追加や、インスタンスにまたがる VLAN の移動などのすべての段階的変更により、MST データベース全体が再初期化されるためです。

この例では、キャンパス ネットワークには region1 という名前の 1 つの MST 領域と、MST1(データ VLAN 10、30、および 100)と MST2(音声 VLAN 20、40、および 200)という 2 つのインスタンスがあります。 MST は 2 つのインスタンスのみを実行しますが、PVST+ は 6 つのインスタンスを実行することが確認できます。 Distribution1 は CIST 領域のルートとして選択されています。 つまり、Distribution1 は IST0 のルートです。 図のようにネットワーク内でトラフィックをロード バランスするために、Distribution1 は MST1(データ VLAN のインスタンス)のルートとして設定され、Distribution2 は MST2(音声 VLAN のインスタンス)のルートとして設定されています。

まず移行する必要があるのはコア部分で、続いてアクセス スイッチに移ります。 スパニング ツリーのモードを変更する前に、スイッチ上で MST の設定を行います。 続いて STP の種類を MST に変更します。 この例では、移行は次の順序で行われます。

  1. Distribution1 と Distribution2

  2. Services1 と Services2

  3. Access1

  4. Access2

  1. Distribution1 と Distribution2 の移行:

    
    !--- Distribution1 configuration:
    
    Distribution1(config)#spanning-tree mst configuration
    Distribution1(config-mst)#name region1
    Distribution1(config-mst)#revision 10
    Distribution1(config-mst)#instance 1 vlan 10, 30, 100
    Distribution1(config-mst)#instance 2 vlan 20, 40, 200
    Distribution1(config-mst)#exit
    Distribution1(config)#spanning-tree mst 0-1 root primary
    Distribution1(config)#spanning-tree mst 2 root secondary
    
    
    !--- Distribution2 configuration:
    
    Distribution2(config)#spanning-tree mst configuration
    Distribution2(config-mst)#name region1
    Distribution2(config-mst)#revision 10
    Distribution2(config-mst)#instance 1 vlan 10, 30, 100
    Distribution2(config-mst)#instance 2 vlan 20, 40, 200
    Distribution2(config-mst)#exit
    Distribution2(config)#spanning-tree mst 2 root primary
    Distribution2(config)#spanning-tree mst 0-1 root secondary
    
    
    !--- Make sure that trunks carry all the VLANs that are mapped to an instance.
    
    
    Distribution1(config)#interface FastEthernet1/0/1
    Distribution1(config-if)#switchport trunk allowed vlan 10,20,30,40,100,200
    !
    Distribution1(config)#interface FastEthernet1/0/3
    Distribution1(config-if)#switchport trunk allowed vlan 10,20,30,40,100,200
    !
    Distribution1(config)#interface FastEthernet1/0/5
    Distribution1(config-if)#switchport trunk allowed vlan 10,20,30,40,100,200
    !
    Distribution1(config)#interface FastEthernet1/0/23
    Distribution1(config-if)#switchport trunk allowed vlan 10,20,30,40,100,200
    !
    Distribution1(config)#interface FastEthernet1/0/24
    Distribution1(config-if)#switchport trunk allowed vlan 10,20,30,40,100,200
    
    Distribution2(config)#interface FastEthernet1/0/2
    Distribution2(config-if)#switchport trunk allowed vlan 10,20,30,40,100,200
    !
    Distribution2(config)#interface FastEthernet1/0/4
    Distribution2(config-if)#switchport trunk allowed vlan 10,20,30,40,100,200
    !
    Distribution2(config)#interface FastEthernet1/0/6
    Distribution2(config-if)#switchport trunk allowed vlan 10,20,30,40,100,200
    !
    Distribution2(config)#interface FastEthernet1/0/23
    Distribution2(config-if)#switchport trunk allowed vlan 10,20,30,40,100,200
    !
    Distribution2(config)#interface FastEthernet1/0/24
    Distribution2(config-if)#switchport trunk allowed vlan 10,20,30,40,100,200
    
    
    !--- STP mode conversion.
    
    Distribution1(config)#spanning-tree mode mst
    Distribution2(config)#spanning-tree mode mst
    
    
    !--- MST tuning - to load balance data and voice VLAN traffic.
    
    Distribution2(config)#interface FastEthernet1/0/24
    Distribution2(config-if)#spanning-tree mst 2 port-priority 64
    
    
    !--- PVST+ cleanup.
    
    Distribution1(config)#no spanning-tree backbonefast
    Distribution2(config)#no spanning-tree backbonefast
    Distribution2(config)#interface FastEthernet1/0/24
    Distribution2(config-if)#no spanning-tree vlan 20,40,200 port-priority 64
    

    注: MST0 のルートは、手動で設定することをお勧めします。 この例では、Distribution1 が MST0 のルートとして選択されているため、Distribution1 が CIST のルートになります。

    現時点でネットワークは混合設定状態になっています。 ネットワークは次の図のように表示できます。

    MST-2.gif

    Distribution1 と Distribution2 は MST region1 内にあり、PVST+ スイッチでは region1 が 1 つのブリッジとして認識されます。 再コンバージ後のトラフィック フローを図 2 に示します。 ユーザはまだ、PVST+(スパニング ツリー VLAN X コスト)スイッチを調整して図 1 のようにデータと音声のトラフィックをロード バランスすることができます。 ステップ 2 から 4 にあるようにその他すべてのスイッチを移行した後は、図 1 のような最終的なスパニング ツリー トポロジになります。

  2. Services1 と Services2 の移行:

    
    !--- Services1 configuration:
    
    Services1(config)#spanning-tree mst configuration
    Services1(config-mst)#name region1
    Services1(config-mst)#revision 10
    Services1(config-mst)#instance 1 vlan 10, 30, 100
    Services1(config-mst)#instance 2 vlan 20, 40, 200
    Services1(config-mst)#exit
    
    
    !--- Services2 configuration:
    
    Services2(config)#spanning-tree mst configuration
    Services2(config-mst)#name region1
    Services2(config-mst)#revision 10
    Services2(config-mst)#instance 1 vlan 10, 30, 100
    Services2(config-mst)#instance 2 vlan 20, 40, 200
    Services2(config-mst)#exit
    
    
    !--- Make sure that trunks carry all the 
    !--- VLANs that are mapped to an instance.
    
    Services1(config)#interface FastEthernet0/5
    Services1(config-if)#switchport trunk allowed vlan 10,20,30,40,100,200
    !
    Services1(config)#interface FastEthernet0/47
    Services1(config-if)#switchport trunk allowed vlan 10,20,30,40,100,200
    !
    Services1(config)#interface FastEthernet0/48
    Services1(config-if)#switchport trunk allowed vlan 10,20,30,40,100,200
    !
    Services2(config)#interface FastEthernet0/6
    Services2(config-if)#switchport trunk allowed vlan 10,20,30,40,100,200
    !
    Services2(config)#interface FastEthernet0/47
    Services2(config-if)#switchport trunk allowed vlan 10,20,30,40,100,200
    !
    Services2(config)#interface FastEthernet0/48
    Services2(config-if)#switchport trunk allowed vlan 10,20,30,40,100,200
    
    
    
    !--- STP Mode conversion:
    
    Services1(config)#spanning-tree mode mst
    Services2(config)#spanning-tree mode mst
    
    
    !--- MST tuning - to load balance data and voice VLAN traffic:
    
    Services1(config)#interface fastEthernet 0/46
    Services1(config-if)#spanning-tree mst 2 cost 200000
    Services1(config-if)#exit
    Services1(config)#interface fastEthernet 0/47
    Services1(config-if)#spanning-tree mst 2 cost 100000
    Services1(config-if)#exit
    
    Services2(config)#interface FastEthernet 0/6
    Services2(config-if)#spanning-tree mst 1 cost 500000
    Services2(config-if)#exit
    
    
    !--- PVST+ cleanup:
    
    Services1(config)#no spanning-tree uplinkfast
    Services1(config)#no spanning-tree backbonefast
    Services1(config)#interface FastEthernet0/5
    Services1(config-if)#no spanning-tree vlan 100 cost 18
    Services1(config-if)#exit
    
    Services2(config)#no spanning-tree uplinkfast
    Services2(config)#no spanning-tree backbonefast
    Services2(config)#interface FastEthernet0/6
    Services2(config-if)#no spanning-tree vlan 200 cost 18
    Services2(config-if)#exit
    Services2(config)#interface FastEthernet0/48
    Services2(config-if)#no spanning-tree vlan 200 port-priority 64
    Services2(config-if)#exit
    
  3. Access1 の移行:

    
    !--- Access1 configuration:
    
    Access1(config)#spanning-tree mst configuration
    Access1(config-mst)#name region1
    Access1(config-mst)#revision 10
    Access1(config-mst)#instance 1 vlan 10, 30, 100
    Access1(config-mst)#instance 2 vlan 20, 40, 200
    Access1(config-mst)#exit
    
    
    !--- Make sure that trunks carry all the VLANs that are mapped to an instance.
    
    Access1(config)#interface FastEthernet0/1
    Access1(config-if)#switchport trunk allowed vlan 10,20,30,40,100,200
    !
    Access1(config)#interface FastEthernet0/2
    Access1(config-if)#switchport trunk allowed vlan 10,20,30,40,100,200
    
    !--- STP mode conversion:
    
    Access1(config)#spanning-tree mode mst
    
    
    !--- PVST+ cleanup:
    
    Access1(config)#no spanning-tree uplinkfast
    Access1(config)#no spanning-tree backbonefast
    
  4. Access2 の移行:

    
    !--- Access2 configuration:
    
    Access2> (enable) set spantree mst config name region1 revision 10
    Edit Buffer modified.
    Use 'set spantree mst config commit' to apply the changes
    
    Access2> (enable) set spantree mst 1 vlan 10,30,100
    Edit Buffer modified.
    Use 'set spantree mst config commit' to apply the changes
    
    Access2> (enable) set spantree mst 2 vlan 20,40,200
    Edit Buffer modified.
    Use 'set spantree mst config commit' to apply the changes
    
    Access2> (enable) set spantree mst config commit
    
    
    !--- Ensure that trunks carry all the VLANs that are mapped to an instance:
    
    Access2> (enable)set trunk 3/3  on dot1q 10,20,30,40,100,200
    Access2> (enable)set trunk 3/4  on dot1q 10,20,30,40,100,200
    
    
    STP mode conversion
    
    Access2> (enable) set spantree mode mst
    PVST+ database cleaned up.
    Spantree mode set to MST.
    
    
    !--- Backbonefast and uplinkfast configurations are cleaned up automatically.
    
    

確認

設定が変更されるたびにスパニング ツリー トポロジを確認することをお勧めします。

Distribution1 スイッチがデータ VLAN 10、30、および 100 のルート ブリッジであり、スパニング ツリーの転送パスが図のパスのように一致することを確認してください。

 Distribution1# show spanning-tree mst 0

##### MST0    vlans mapped:   1-9,11-19,21-29,31-39,41-99,101-199,201-4094
Bridge        address 0015.63f6.b700  priority      24576 (24576 sysid 0)
Root          this switch for the CIST
Operational   hello time 2 , forward delay 15, max age 20, txholdcount 6
Configured    hello time 2 , forward delay 15, max age 20, max hops    20

Interface        Role Sts Cost      Prio.Nbr Type
---------------- ---- --- --------- -------- --------------------------------
Fa1/0/1          Desg FWD 200000    128.1    P2p
Fa1/0/3          Desg FWD 200000    128.3    P2p
Fa1/0/5          Desg FWD 200000    128.5    P2p 
Fa1/0/23         Desg FWD 200000    128.23   P2p
Fa1/0/24         Desg FWD 200000    128.24   P2p


Distribution1#show spanning-tree mst 1

##### MST1    vlans mapped:   10,30,100
Bridge        address 0015.63f6.b700  priority      24577 (24576 sysid 1)
Root          this switch for MST1

Interface        Role Sts Cost      Prio.Nbr Type
---------------- ---- --- --------- -------- --------------------------------
Fa1/0/1          Desg FWD 200000    128.1    P2p
Fa1/0/3          Desg FWD 200000    128.3    P2p
Fa1/0/5          Desg FWD 200000    128.5    P2p 
Fa1/0/23         Desg FWD 200000    128.23   P2p
Fa1/0/24         Desg FWD 200000    128.24   P2p

Distribution1#show spanning-tree mst 2

##### MST2    vlans mapped:   20,40,200
Bridge        address 0015.63f6.b700  priority      28674 (28672 sysid 2)
Root          address 0015.c6c1.3000  priority      24578 (24576 sysid 2)
              port    Gi1/0/24        cost          200000    rem hops 4

Interface        Role Sts Cost      Prio.Nbr Type
---------------- ---- --- --------- -------- --------------------------------
Gi1/0/1          Desg FWD 200000    128.1    P2p
Gi1/0/3          Desg FWD 200000    128.3    P2p
Gi1/0/23         Altn BLK 200000    128.23   P2p
Gi1/0/24         Root FWD 200000    128.24   P2p

Distribution2#show spanning-tree mst 0

##### MST0    vlans mapped:   1-9,11-19,21-29,31-39,41-99,101-199,201-4094
Bridge        address 0015.c6c1.3000  priority      28672 (28672 sysid 0)
Root          address 0015.63f6.b700  priority      24576 (24576 sysid 0)
              port    Fa1/0/23        path cost     0
Regional Root address 0015.63f6.b700  priority      24576 (24576 sysid 0)
                                      internal cost 200000    rem hops 19
Operational   hello time 2 , forward delay 15, max age 20, txholdcount 6
Configured    hello time 2 , forward delay 15, max age 20, max hops    20

Interface        Role Sts Cost      Prio.Nbr Type
---------------- ---- --- --------- -------- --------------------------------
Fa1/0/2          Desg FWD 200000    128.54   P2p
Fa1/0/4          Desg FWD 200000    128.56   P2p
Fa1/0/6          Desg FWD 200000    128.58   P2p
Fa1/0/23         Root FWD 200000    128.75   P2p
Fa1/0/24         Altn BLK 200000    128.76   P2p


!--- CIST root is Distribution1. All the 
!--- switches are in the same region "region1".
!--- Hence in all the switches in the region1 you can see the path cost as 0.


Distribution2#show spanning-tree mst 1

##### MST1    vlans mapped:   10,30,100
Bridge        address 0015.c6c1.3000  priority      28673 (28672 sysid 1)
Root          address 0015.63f6.b700  priority      24577 (24576 sysid 1)
              port    Gi2/0/23        cost          200000    rem hops 1

Interface        Role Sts Cost      Prio.Nbr Type
---------------- ---- --- --------- -------- --------------------------------
Gi2/0/2          Desg FWD 200000    128.54   P2p
Gi2/0/4          Desg FWD 200000    128.56   P2p
Gi2/0/23         Root FWD 200000    128.75   P2p
Gi2/0/24         Altn BLK 200000    128.76   P2p

Distribution2#show spanning-tree mst 2

##### MST2    vlans mapped:   20,40,200
Bridge        address 0015.c6c1.3000  priority      24578 (24576 sysid 2)
Root          this switch for MST2

Interface        Role Sts Cost      Prio.Nbr Type
---------------- ---- --- --------- -------- --------------------------------
Gi2/0/2          Desg FWD 200000    128.54   P2p
Gi2/0/4          Desg FWD 200000    128.56   P2p
Gi2/0/6          Desg FWD 200000    128.58   P2p
Gi2/0/23         Desg FWD 200000    128.75   P2p
Gi2/0/24         Desg FWD 200000     64.76   P2p

Access2> (enable) show spantree mst 1
Spanning tree mode          MST
Instance                    1
VLANs Mapped:               10,30,100

Designated Root             00-15-63-f6-b7-00
Designated Root Priority    24577  (root priority: 24576, sys ID ext: 1)
Designated Root Cost        200000     Remaining Hops 19
Designated Root Port        3/3

Bridge ID MAC ADDR          00-d0-00-50-30-00
Bridge ID Priority          32769  (bridge priority: 32768, sys ID ext: 1)

Port                     State         Role Cost      Prio Type
------------------------ ------------- ---- --------- ---- --------------------
 3/3                     forwarding    ROOT    200000   32 P2P
 3/4                     blocking      ALTR    200000   32 P2P

Access2> (enable) show spantree mst 2
Spanning tree mode          MST
Instance                    2
VLANs Mapped:               20,40,200

Designated Root             00-15-c6-c1-30-00
Designated Root Priority    24578  (root priority: 24576, sys ID ext: 2)
Designated Root Cost        200000     Remaining Hops 19
Designated Root Port        3/4

Bridge ID MAC ADDR          00-d0-00-50-30-00
Bridge ID Priority          32770  (bridge priority: 32768, sys ID ext: 2)

Port                     State         Role Cost      Prio Type
------------------------ ------------- ---- --------- ---- --------------------
 3/3                     blocking      ALTR    200000   32 P2P
 3/4                     forwarding    ROOT    200000   32 P2P

トラブルシューティング

現在のところ、この設定に関する特定のトラブルシューティング情報はありません。

関連するシスコ サポート コミュニティ ディスカッション

シスコ サポート コミュニティは、どなたでも投稿や回答ができる情報交換スペースです。


関連情報


Document ID: 72844