ロング リーチ イーサネット(LRE)とデジタル加入者線(xDSL) : 非対称デジタル加入者線(ADSL)

Cisco DSL ルータの設定とトラブルシューティング ガイド - 単一の固定 IP アドレスによる RFC1483 ルーティング

2016 年 10 月 27 日 - 機械翻訳について
その他のバージョン: PDFpdf | 英語版 (2015 年 8 月 22 日) | フィードバック


目次


概要

Cisco Digital Subscriber Line(DSL; デジタル加入者線)ルータには、Internet Service Provider(ISP; インターネット サービス プロバイダー)から単一の固定パブリック IP アドレスが割り当てられます。

ヒント: Ciscoデバイスを設定する方法についてよくわからないし、ステップバイステップ設定に続くことを望んだら単一 静的IP アドレスとルーティングする RFC1483 のステップバイステップ設定を参照して下さい。

前提条件

要件

このドキュメントに関する固有の要件はありません。

使用するコンポーネント

このドキュメントは、特定のソフトウェアやハードウェアのバージョンに限定されるものではありません。

表記法

ドキュメント表記の詳細は、『シスコ テクニカル ティップスの表記法』を参照してください。

実行する作業

  • プライベート LAN の IP アドレス割り当て方式を設計します。

  • Cisco DSL ルータイーサネットインターフェイスの IP アドレスおよびサブネット マスクを手動で設定して下さい。

  • ATM 相手先固定接続(PVC)、カプセル化および IP アドレスで Cisco DSL ルータの ATMインターフェイスを(Asymetric デジタル加入者線(ADSL)インターフェイス)設定して下さい。

  • ネットワーク アドレス変換(NAT)の設定: ATMインターフェイスの静的なパブリックIPアドレスの共有を許可するために Cisco DSL ルータの NAT を設定して下さい。

    • オプション: ISP から追加の IP アドレスを提供されている場合は NAT プール。

    • オプション: インターネット ユーザが内部サーバにアクセスする必要がある場合はスタティック NAT。

  • IP アドレス、サブネット マスク、デフォルト ゲートウェイ、およびドメイン ネーム システム(DNS)サーバを使用して各ホスト PC を設定します。

    Dynamic Host Configuration Protocol(DHCP)の設定: また Cisco DSL ルータに PC クライアントにダイナミック IP アドレスを割り当ててほしかったら DHCP によって IP アドレスおよび DNS サーバを自動的に得るために各 PC を設定して下さい。

設定

この項では、このドキュメントで説明する機能の設定に必要な情報を提供します。

このドキュメントで使用されているコマンドの詳細を調べるには、Command Lookup Tool登録ユーザ専用)を使用してください。

設定

ヒント: Ciscoデバイスを設定する方法についてよくわからないし、ステップバイステップ設定に続くことを望んだら単一 静的IP アドレスとルーティングする RFC1483 のステップバイステップ設定を参照して下さい。

静的IP アドレスおよび NAT の Cisco DSL ルータ

!--- Comments contain explanations and additional information.


service timestamps debug datetime msec
service timestamps log datetime msec
ip subnet-zero
!

!--- For DHCP:

ip dhcp excluded-address <ip address of ethernet0>
ip dhcp pool <dhcp pool name>
 network <ip network address of ethernet0> <subnet mask>
 default-router <ip address of ethernet0>
 dns-server <ip address of dns server>
!
interface ethernet0
 no shut
 ip address <ip address> <subnet mask>
 ip nat inside
 no ip directed-broadcast
!
interface atm0
 no shut
 no ip address
 no ip directed-broadcast
 no atm ilmi-keepalive
!
interface atm0.1 point-to-point
 ip address <ip address> <subnet mask>

!--- For NAT:

 ip nat outside
 pvc <vpi/vci>
  encapsulation aal5snap
 
!--- Common PVC values supported by ISPs are 0/35 or 8/35.
 !--- Confirm your PVC values with your ISP.

 !
!

!--- For NAT:

ip nat inside source list 1 interface atm0.1 overload

!--- If you have a pool (a range) of public IP addresses provided 
!--- by your ISP, you can use a NAT Pool. Replace 
!--- ip nat inside source list 1 interface atm0.1 overload

 
 

!--- with these two configuration statements:
!--- ip nat inside source list 1 pool <nat pool name> overload
!--- ip nat pool <nat pool name> <first ip address> <last ip address> 
!---  netmask <subnet mask>




!--- If Internet users require access to an internal server, you can 
!--- add this static NAT configuration statement:
!--- ip nat inside source static tcp <inside ip address of server> {80 or 25} 
!--- <outside well-known ip address of server> {80 or 25} extendable
!--- Note: TCP port 80 (HTTP/web) and TCP port 25 (SMTP/mail) are used 
!--- for this example. You can open other TCP or UDP ports, if needed.

! 
ip classless 
ip route 0.0.0.0 0.0.0.0 <default gateway to isp>

!--- For NAT:

access-list 1 permit <ip network address of ethernet0> <wildcard mask>

!--- In this configuration, access-list 1 defines a standard access list 
!--- that permits the addresses that NAT translates. For example, if  
!--- your private IP network is 10.10.10.0, configure 
!--- access-list 1 permit 10.10.10.0 0.0.0.255 in order to allow NAT to translate 
!--- packets with source addresses between 10.10.10.0 and 10.10.10.255.

!
end

確認

現在、この設定に使用できる確認手順はありません。

トラブルシューティング

ADSLサービスがきちんとはたらかない場合ルーティングするトラブルシューティング RFC1483 を参照して下さい。


関連情報


Document ID: 71132