ロング リーチ イーサネット(LRE)とデジタル加入者線(xDSL) : 非対称デジタル加入者線(ADSL)

Cisco DSL ルータの設定とトラブルシューティング ガイド - スタティック IP アドレス ブロックを使った RFC1483 Routing の段階的な設定

2015 年 11 月 26 日 - 機械翻訳について
その他のバージョン: PDFpdf | ライター翻訳版 (2004 年 9 月 1 日) | 英語版 (2015 年 8 月 22 日) | フィードバック


目次


概要

ご使用中の Cisco Digital Subscriber Line(DSL; デジタル加入者線)ルータには、Internet Service Provider(ISP; インターネット サービス プロバイダー)から固定パブリック IP アドレスが割り当てられています。

前提条件

要件

このドキュメントに関する特別な要件はありません。

使用するコンポーネント

このドキュメントは、特定のソフトウェアやハードウェアのバージョンに限定されるものではありません。

表記法

ドキュメント表記の詳細は、『シスコ テクニカル ティップスの表記法』を参照してください。

設定手順

重要: 始める前に、COM ポートのモニタリングを実行している可能性のある、PC 上のすべてのプログラムを終了します。 PDA やデジタル カメラなどのデバイスによってプログラムがシステム トレイに配置され、これにより、Cisco DSL ルータの設定が原因で COM ポートが使用できなくなる場合が多くあります。

Cisco DSL ルータと PC の接続

ロール型ケーブルを使用してコンソールを接続します。これによって Cisco DSL ルータのコンソール ポートと PC の COM ポートが接続されます。 Cisco DSL ルータに用意されているコンソール ケーブルは、明るい青色のフラット ケーブルです。 ロール型ケーブルのピン割り当て、または RJ-45 から DB9 コンバータへのピン割り当ての詳細については、『コンソールおよび AUX ポートのためのケーブル接続ガイド』を参照してください。

  1. シスコ コンソール ケーブルの一端の RJ-45 コネクタを Cisco DSL ルータのコンソール ポートへ接続します。

  2. コンソール ケーブルのもう一端の RJ-45 コネクタを、RJ-45 から DB9 へのコンバータに接続します。

  3. この DB9 コネクタを PC の空いている COM ポートに接続します。

HyperTerminal の起動とセットアップ

次の手順を実行します。

  1. PC で HyperTerminal プログラムを起動します。

  2. HyperTerminal セッションをセットアップします。

    1. セッションに名前を割り当て、[OK] をクリックします。

    2. [Connect To] ウィンドウで [Cancel] をクリックします。

    3. [File] > [Properties] の順に選択します。

    4. [Properties] ウィンドウで [Connect Using] リストに移動し、コンソール ケーブルの DB9 側を接続する COM ポートを選択します。

    5. [Properties] ウィンドウで [Configure] をクリックし、次の値を入力します。

      • ビット/秒: 9600

      • データ ビット: 8

      • パリティ: なし

      • ストップ ビット: 1

      • フロー制御: なし

    6. [OK] をクリックします。

    7. [Call] メニューで [Disconnect] をクリックします。

    8. [Call] メニューで [Call] をクリックします。

    9. [HyperTerminal] ウィンドウ上にルータ プロンプトが表示されるまで、Enter キーを押します。

Cisco DSL ルータ上の既存の設定のクリア

次の手順を実行します。

  1. 特権モードを開始するために、ルータ プロンプトで enable と入力します。

    Router>enable
    Router#
    
    !--- The # symbol indicates that you are in privileged mode.
    
    
  2. ルータ上の既存の設定をクリアします。

    Router#write erase
    
  3. ルータをリロードすると、ルータはブランクのスタートアップ コンフィギュレーションを使用して起動します。

    Router#reload
    System configuration has been modified. Save? [yes/no]:no
    Proceed with reload? [confirm]yes
    
    !--- The router reload can take a few minutes.
    
    
  4. ルータのリロード後、イネーブル モードを再度開始します。

    Router>enable
    Router#

Cisco DSL ルータの設定

次の手順を実行します。

  1. トラブルシューティング セクションの debug 出力を適切に記録して表示するために、service timestamp を設定します。

    Router#configure terminal
    Router(config)#service timestamps debug datetime msec
    Router(config)#service timestamps log datetime msec
    Router(config)#end
    
  2. ルータの設定中にトリガーされる可能性のあるコンソール メッセージを非表示にするために、Cisco DSL ルータ上でロギング コンソールを無効にします。

    Router#configure terminal
          Router(config)#no logging console
          Router(config)#end
    
  3. ルーティング設定オプションに柔軟性を持たせるために、ip routingip subnet-zero、および ip classless を設定します。

    Router#configure terminal
    Router(config)#ip routing
    Router(config)#ip subnet-zero
    Router(config)#ip classless
    Router(config)#end
    
  4. Cisco DSL ルータのイーサネット インターフェイスで IP アドレスとサブネット マスクを設定します。

    Router#configure terminal
          Router(config)#interface ethernet 0
          Router(config-if)#ip address <ip address> <subnet mask>
          Router(config-if)#no shut
          Router(config-if)#end
    
  5. no shut コマンド 始動で Cisco DSL ルータの ATMインターフェイスをインターフェイス設定して下さい。

    Router#configure terminal
    Router(config)#interface atm 0
    Router(config-if)#no shut
    Router(config-if)#end
    
  6. ATM 相手先固定接続(PVC)、エンキャプシュレーションタイプおよび非番号 Ethernet0 IP アドレスで Cisco DSL ルータの ATM サブインターフェイスを設定して下さい。

    Router#configure terminal
    Router(config)#interface atm 0.1 point-to-point
    Router(config-subif)#ip unnumbered ethernet0
    Router(config-subif)#pvc <vpi/vci>
    Router(config-subif-atm-vc)#encapsulation aal5snap
    Router(config-subif-atm-vc)#end
    
  7. アウトバウンドインターフェイスで ATM0.1 を使用してデフォルト ルートを設定して下さい。

    Router#configure terminal
    Router(config)#ip route 0.0.0.0 0.0.0.0 atm0.1
    Router(config)#end
    
  8. Dynamic Host Configuration Protocol(DHCP)の設定: (オプション)Cisco DSL ルータのイーサネット インターフェイスに接続されたホストへ割り当てる IP アドレスのプールを備えた DHCP サーバとして、Cisco DSL ルータを設定します。 DHCP サーバによって、IP アドレス、DNS、およびデフォルト ゲートウェイ IP アドレスが、ホストに動的に割り当てられます。

    Router#configure terminal
    Router(config)#ip dhcp excluded-address <ip address of ethernet0>
    Router(config)#ip dhcp pool <dhcp pool name>
    Router(dhcp-config)#network <ip network address of ethernet0> <subnet mask>  
    Router(dhcp-config)#default-router <ip address of ethernet0> 
    Router(dhcp-config)#dns-server <ip address of primary dns server> 
     <ip address of secondary dns server>
    Router(dhcp-config)#end
    
  9. Cisco DSL ルータの logging console を有効に し、メモリへのすべての変更を書いて下さい。

    Router#configure terminal
    Router(config)#logging console
    Router(config)#end
    *Jan 1 00:00:00.100: %SYS-5-CONFIG_I: Configured from console by console
    Router#write memory
    Building configuration... [OK]
    Router#

設定

これは、このドキュメントの「設定手順」セクションの手順を完了した後に作成した設定です。

静的な IP アドレスのブロックが付いている Cisco DSL ルータ

!--- Comments contain explanations and additional information.


service timestamps debug datetime msec
service timestamps log datetime msec
ip subnet-zero
!

!--- For DHCP:

ip dhcp excluded-address <ip address of ethernet0>
ip dhcp pool <dhcp pool name>
 network <ip network address of ethernet0> <subnet mask>
 default-router <ip address of ethernet0>
 dns-server <ip address of dns server>
!
interface ethernet0
 no shut
 ip address <ip address> <subnet mask>
 no ip directed-broadcast
!
interface atm0
 no shut
 no ip address
 no ip directed-broadcast
 no atm ilmi-keepalive
!
interface atm0.1 point-to-point
 ip unnumbered ethernet0
 pvc <vpi/vci>
  encapsulation aal5snap
 
!--- Common PVC values supported by ISPs are 0/35 or 8/35.
 !--- Confirm your PVC values with your ISP.

 !
!
ip classless 
ip route 0.0.0.0 0.0.0.0 <default gateway to isp>
ip route <default gateway to isp> 255.255.255.255 atm0.1
!
end

確認

これで、Cisco DSL ルータは非対称デジタル加入者線(ADSL)サービスに対応して稼働しています。 設定を確認するには、show run コマンドを実行します。

Router#show run
Building configuration...

Output Interpreter Tool(OIT)(登録ユーザ専用)では、特定の show コマンドがサポートされています。 OIT を使用して、show コマンド出力の解析を表示できます。

トラブルシューティング

ADSLサービスがきちんとはたらかない場合ルーティングするトラブルシューティング RFC1483 を参照して下さい。

関連するシスコ サポート コミュニティ ディスカッション

シスコ サポート コミュニティは、どなたでも投稿や回答ができる情報交換スペースです。


関連情報


Document ID: 71131