ロング リーチ イーサネット(LRE)とデジタル加入者線(xDSL) : 非対称デジタル加入者線(ADSL)

Cisco DSL ルータの設定とトラブルシューティング ガイド - 固定 IP アドレスが割り当てられた PPPoE クライアントとして機能する Cisco DSL ルータ

2015 年 11 月 26 日 - 機械翻訳について
その他のバージョン: PDFpdf | ライター翻訳版 (2008 年 4 月 23 日) | 英語版 (2015 年 8 月 22 日) | フィードバック


目次


概要

Cisco Digital Subscriber Line(DSL; デジタル加入者線)ルータには、Internet Service Provider(ISP; インターネット サービス プロバイダー)から単一の固定パブリック IP アドレスが割り当てられます。

ヒント: Cisco 製デバイスの設定に不慣れで、最初から最後まで手順を追った説明が必要な場合は、『固定 IP アドレスによる PPPoE の段階的設定』を参照してください。

前提条件

要件

このドキュメントに関する特別な要件はありません。

使用するコンポーネント

このドキュメントは、特定のソフトウェアやハードウェアのバージョンに限定されるものではありません。

表記法

ドキュメント表記の詳細は、『シスコ テクニカル ティップスの表記法』を参照してください。

実行する作業

  • プライベート LAN の IP アドレス割り当て方式を設計します。

  • Cisco DSL ルータのイーサネット インターフェイスに IP アドレス、サブネット マスク、および TCP 最大セグメント サイズ(MSS)調整を設定します。

  • Cisco DSL ルータの ATM インターフェイス(Asymmetric Digital Subscriber Line(ADSL; 非対称デジタル加入者線)インターフェース)に ATM Permanent Virtual Circuit(PVC; 相手先固定接続)とカプセル化を設定します。

  • Cisco IOS のための Point-to-Point Protocol over Ethernet(PPPoE) 仮想 な プライベートデータネットワーク(VPDN)グループを設定して下さいか。 12.2(13)T よりソフトウェア 以降。

  • 固定 IP アドレスを使用する PPPoE を利用するために Cisco DSL ルータのダイヤラ インターフェイスを作成して設定します。

  • ネットワーク アドレス変換(NAT)の設定: ダイヤラーインターフェイスのダイナミック パブリックIPアドレスの共有を許可するために Cisco DSL ルータの NAT を設定して下さい。

    • オプション: ISP から追加の IP アドレスを提供されている場合は NAT プール。

    • オプション: インターネット ユーザが内部サーバにアクセスする必要がある場合はスタティック NAT。

  • 各 PC クライアントで IP アドレス、サブネット マスク、デフォルト ゲートウェイ、Domain Name System(DNS; ドメイン ネーム システム)サーバを設定します。

    Dynamic Host Configuration Protocol(DHCP)の設定: また Cisco DSL ルータに PC クライアントにダイナミック IP アドレスを割り当ててほしかったら DHCP によって IP アドレスおよび DNS サーバを自動的に得るために各 PC を設定して下さい。

PC で必要な可能性がある設定手順

Cisco DSL ルータ ソフトウェアが ip tcp adjust-mss 1452 または ip adjust-mss 1452 設定コマンドをサポートしている場合、この後の作業は必要ないため、「設定」セクションに進んでください。

Cisco DSL ルータ ソフトウェアが ip tcp adjust-mss 1452 または ip adjust-mss 1452 設定コマンドをサポートしていない場合は、Cisco DSL ルータを介してインターネットにアクセスする LAN 内の各 PC で Maximum Transmission Unit(MTU; 最大伝送ユニット)サイズを変更する必要があります。 MTU サイズを変更するには次の手順を実行します。

  1. 最新バージョンの Dr. TCP ユーティリティを http://www.dslreports.com/front/drtcp.html からダウンロードします。leavingcisco.com

  2. 最新のページが表示されるようにブラウザ ページを更新します。

  3. Dr. TCP ユーティリティを実行します。

  4. メニューからイーサネット アダプタを選択します。

  5. [MTU] フィールドに 1492 と入力します。

  6. [Apply] をクリックして変更を保存した後、[Exit] をクリックします。

  7. PPPoE PC クライアントをリブートします。

レジストリの変更はこの手順が完了した時点で保存されます。 そのため、このユーティリティは各 PC につき 1 回だけ実行する必要があります。

設定

この項では、このドキュメントで説明する機能の設定に必要な情報を提供します。

注: このドキュメントで使用されているコマンドの詳細を調べるには、Command Lookup Tool登録ユーザ専用)を使用してください。

設定

ヒント: Cisco 製デバイスの設定に不慣れで、最初から最後まで手順を追った説明が必要な場合は、『固定 IP アドレスによる PPPoE の段階的設定』を参照してください。

固定 IP アドレスが割り当てられた Cisco DSL ルータ

!--- Comments contain explanations and additional information.


service timestamps debug datetime msec
service timestamps log datetime msec
vpdn enable
 no vpdn logging
  vpdn-group pppoe
   request-dialin
    protocol pppoe

!--- These commands are needed only on Cisco IOS Software earlier than than 12.2(13)T.

!
!
ip subnet-zero
!

!--- For DHCP:


ip dhcp excluded-address <ip address of ethernet0>
ip dhcp pool <dhcp pool name>
 network <ip network address of ethernet0> <subnet mask>
 default-router <ip address of ethernet0>
 dns-server <ip address of dns server> 
!
interface ethernet0  
 no shut  
 ip address <ip address> <subnet mask> 
 ip tcp adjust-mss 1452 
 
!--- If the ip tcp adjust-mss 1452 command is not supported, try this
 !--- configuration statement: ip adjust-mss 1452. If this command is not
 !--- supported in your current Cisco DSL Router software release, upgrade to the 
 !--- latest Cisco DSL Router software or follow the procedure in the
 !--- "Possible Required Configuration Steps on the PC" section of this document. 


!--- For NAT:

 ip nat inside
 no ip directed-broadcast
!
interface atm0
 no ip address
 bundle-enable
 dsl operating-mode auto
!
interface atm0.1 point-to-point
 no ip address
 no ip directed-broadcast
 no atm ilmi-keepalive
 pvc <vpi/vci>
  pppoe-client dial-pool-number 1
 
!--- Common PVC values supported by ISPs are 0/35 or 8/35.
 !--- Confirm your PVC values with your ISP.

 !
!
interface dialer1
 ip address <ip address> <subnet mask>
 mtu 1492

!--- For NAT:

 ip nat outside
 encapsulation ppp
 dialer pool 1
 ppp chap hostname <username>
 ppp chap password <password>
 ppp pap sent-username <username> password <password>
!

!--- For NAT:

ip nat inside source list 1 interface dialer1 overload

!--- If you have a pool (a range) of public IP addresses provided 
!--- by your ISP, you can use a NAT Pool. Replace 
!--- ip nat inside source list 1 interface dialer1 overload

 
 

!--- with these two configuration statements:
!--- ip nat inside source list 1 pool <nat pool name> overload
!--- ip nat pool <nat pool name> <first ip address> <last ip address> 
!---  netmask <subnet mask>




!--- If Internet users require access to an internal server, you can 
!--- add this static NAT configuration statement:
!--- ip nat inside source static tcp <inside ip address of server> {80 or 25} 
!---  <outside well-known ip address of server> {80 or 25} extendable
!--- Note: TCP port 80 (HTTP/web) and TCP port 25 (SMTP/mail) are used 
!--- for this example. You can open other TCP or UDP ports, if needed.

! 
ip classless
ip route 0.0.0.0 0.0.0.0 interface dialer1

!--- For NAT:

access-list 1 permit <ip network address of ethernet0> <wildcard mask>

!--- In this configuration, access-list 1 defines a standard access list 
!--- that permits the addresses that NAT translates. For example, if  
!--- your private IP network is 10.10.10.0, configure 
!--- access-list 1 permit 10.10.10.0 0.0.0.255 in order to allow NAT to translate 
!--- packets with source addresses between 10.10.10.0 and 10.10.10.255.

!
end

確認

現在、この設定に使用できる確認手順はありません。

トラブルシューティング

DSL サービスが適切に動作しない場合は、『Cisco DSL ルータ PPPoE クライアントのトラブルシューティング』を参照してください。

関連するシスコ サポート コミュニティ ディスカッション

シスコ サポート コミュニティは、どなたでも投稿や回答ができる情報交換スペースです。


関連情報


Document ID: 71122