ロング リーチ イーサネット(LRE)とデジタル加入者線(xDSL) : 非対称デジタル加入者線(ADSL)

Cisco DSL ルータの設定とトラブルシューティング ガイド - ダイナミック IP アドレスによる PPPoE の段階的設定

2015 年 11 月 26 日 - 機械翻訳について
その他のバージョン: PDFpdf | 英語版 (2015 年 8 月 22 日) | フィードバック


目次


概要

ご使用中のシスコのデジタル加入者線(DSL)ルータには、インターネット サービス プロバイダー(ISP)からダイナミック パブリック IP アドレスが割り当てられています。

前提条件

要件

このドキュメントに関する特別な要件はありません。

使用するコンポーネント

このドキュメントは、特定のソフトウェアやハードウェアのバージョンに限定されるものではありません。

表記法

ドキュメント表記の詳細は、『シスコ テクニカル ティップスの表記法』を参照してください。

設定手順

重要: 始める前に、COM ポートのモニタリングを実行している可能性のある、PC 上のすべてのプログラムを終了します。 PDA やデジタル カメラなどのデバイスによってプログラムがシステム トレイに配置され、これにより、Cisco DSL ルータの設定が原因で COM ポートが使用できなくなる場合が多くあります。

Cisco DSL ルータと PC の接続

ロール型ケーブルを使用してコンソールを接続します。これによって Cisco DSL ルータのコンソール ポートと PC の COM ポートが接続されます。 Cisco DSL ルータに用意されているコンソール ケーブルは、明るい青色のフラット ケーブルです。 ロール型ケーブルのピン割り当て、または RJ-45 から DB9 コンバータへのピン割り当ての詳細については、『コンソールおよび AUX ポートのためのケーブル接続ガイド』を参照してください。

  1. シスコ コンソール ケーブルの一端の RJ-45 コネクタを Cisco DSL ルータのコンソール ポートへ接続します。

  2. コンソール ケーブルのもう一端の RJ-45 コネクタを、RJ-45 から DB9 へのコンバータに接続します。

  3. この DB9 コネクタを PC の空いている COM ポートに接続します。

HyperTerminal の起動とセットアップ

次の手順を実行します。

  1. PC で HyperTerminal プログラムを起動します。

  2. HyperTerminal セッションをセットアップします。

    1. セッションに名前を割り当て、[OK] をクリックします。

    2. [Connect To] ウィンドウで [Cancel] をクリックします。

    3. [File] > [Properties] の順に選択します。

    4. [Properties] ウィンドウで [Connect Using] リストに移動し、コンソール ケーブルの DB9 側を接続する COM ポートを選択します。

    5. [Properties] ウィンドウで [Configure] をクリックし、次の値を入力します。

      • ビット/秒: 9600

      • データ ビット: 8

      • パリティ: なし

      • ストップ ビット: 1

      • フロー制御: なし

    6. [OK] をクリックします。

    7. [Call] メニューで [Disconnect] をクリックします。

    8. [Call] メニューで [Call] をクリックします。

    9. [HyperTerminal] ウィンドウ上にルータ プロンプトが表示されるまで、Enter キーを押します。

Cisco DSL ルータ上の既存の設定のクリア

次の手順を実行します。

  1. 特権モードを開始するために、ルータ プロンプトで enable と入力します。

    Router>enable
    Router#
    
    !--- The # symbol indicates that you are in privileged mode.
    
    
  2. ルータ上の既存の設定をクリアします。

    Router#write erase
    
  3. ルータをリロードすると、ルータはブランクのスタートアップ コンフィギュレーションを使用して起動します。

    Router#reload
    System configuration has been modified. Save? [yes/no]:no
    Proceed with reload? [confirm]yes
    
    !--- The router reload can take a few minutes.
    
    
  4. ルータのリロード後、イネーブル モードを再度開始します。

    Router>enable
    Router#

Cisco DSL ルータの設定

次の手順を実行します。

  1. トラブルシューティング セクションの debug 出力を適切に記録して表示するために、service timestamp を設定します。

    Router#configure terminal
    Router(config)#service timestamps debug datetime msec
    Router(config)#service timestamps log datetime msec
    Router(config)#end
    
  2. ルータの設定中にトリガーされる可能性のあるコンソール メッセージを非表示にするために、Cisco DSL ルータ上でロギング コンソールを無効にします。

    Router#configure terminal
          Router(config)#no logging console
          Router(config)#end
    
  3. ルーティング設定オプションに柔軟性を持たせるために、ip routingip subnet-zero、および ip classless を設定します。

    Router#configure terminal
    Router(config)#ip routing
    Router(config)#ip subnet-zero
    Router(config)#ip classless
    Router(config)#end
    
  4. グローバル な Point-to-Point Protocol over Ethernet(PPPoE) パラメータを設定して下さい。

    Router#configure terminal
    Router(config)#vpdn enable
    Router(config)#no vpdn logging
    Router(config)#vpdn-group pppoe
    Router(config-vpdn)#request-dialin
    Router(config-vpdn-req-in)#protocol pppoe
    Router(config-vpdn-req-in)#end
    
  5. Cisco DSL ルータのイーサネット インターフェイスで IP アドレスとサブネット マスクを設定します。

    ネットワーク アドレス変換(NAT)の設定: (イーサネットインターフェイスのオプションの)イネーブル NAT 中。

    Router#configure terminal
    Router(config)#interface ethernet 0
    Router(config-if)#ip tcp adjust-mss 1452
    
    !--- If the ip tcp adjust-mss 1452 command is not supported, try 
    !--- ip adjust-mss 1452. If this command is not supported, 
    !--- upgrade to the latest Cisco DSL Router software or follow the 
    !--- procedure in the Possible Required Configuration Steps on the PC.
    
    Router(config-if)#ip address <ip address> <subnet mask>
    
    !--- For NAT:
    
    Router(config-if)#ip nat inside
    Router(config-if)#no shut
    Router(config-if)#end
    
  6. Cisco DSL ルータの ATM インターフェイスに、ATM 相手先固定接続(PVC)、カプセル化タイプ、およびダイヤラ プールを設定します。

    Router#configure terminal
    Router(config)#interface atm 0
    Router(config-if)#pvc <vpi/vci>
    Router(config-if-atm-vc)#pppoe-client dial-pool-number 1
    Router(config-if-atm-vc)#no shut
    Router(config-if-atm-vc)#end
    
  7. 割り当てられるべきダイナミックIPアドレスを有効に するために ATM (PPPoA)上のポイントツーポイント プロトコルのための Cisco DSL ルータのダイヤラーインターフェイスを設定して下さい。

    NAT の設定 (オプション)ダイヤラ インターフェイスで外部 NAT をイネーブルにします。

    Router#configure terminal
    Router(config)#interface dialer 1
    Router(config-if)#ip address negotiated
    Router(config-if)#mtu 1492
    Router(config-if)#no ip directed-broadcast
    
    !--- For NAT:
     
    Router(config-if)#ip nat outside
    Router(config-if)#encapsulation ppp
    Router(config-if)#dialer pool 1  
    Router(config-if)#ppp chap hostname <username>
    Router(config-if)#ppp chap password <password>
    Router(config-if)#ppp pap sent-username <username> password <password>
    Router(config-if)#end
    
  8. Dialer1 を発信インターフェイスとして使用して、デフォルト スタティック ルートを設定します。

    Router#configure terminal
    Router(config)#ip route 0.0.0.0 0.0.0.0 dialer1
    Router(config)#end
    
  9. NAT の設定 ダイヤラ インターフェイスのダイナミック パブリック IP アドレスを共有できるように、Cisco DSL ルータのグローバルの NAT コマンドを設定します。

    Router#configure terminal
    Router(config)#ip nat inside source list 1 interface dialer1 overload
    Router(config)#access-list 1 permit <ip network address of ethernet0> 
     <wildcard mask>
    Router(config)#end
    

    オプション設定

    ISP から追加の IP アドレスを提供されている場合は NAT プール。

    Router(config)#ip nat inside source list 1 interface dialer1 overload 
    Router(config)#ip nat pool <nat pool name> <first ip address> 
     <last ip address> netmask <subnet mask>
    Router(config)#end
    

    インターネット ユーザが内部サーバにアクセスする必要がある場合はスタティック NAT。

    Router(config)#ip nat inside source static tcp <inside ip address of server> 
     {80 or 25} <outside well-known ip address of server> {80 or 25} extendable
    Router(config)#end
    
  10. Dynamic Host Configuration Protocol(DHCP)の設定: (オプション)Cisco DSL ルータのイーサネット インターフェイスに接続されたホストへ割り当てる IP アドレスのプールを備えた DHCP サーバとして、Cisco DSL ルータを設定します。 DHCP サーバによって、IP アドレス、DNS、およびデフォルト ゲートウェイ IP アドレスが、ホストに動的に割り当てられます。

    Router#configure terminal
    Router(config)#ip dhcp excluded-address <ip address of ethernet0>
    Router(config)#ip dhcp pool <dhcp pool name>
    Router(dhcp-config)#network <ip network address of ethernet0> <subnet mask>  
    Router(dhcp-config)#default-router <ip address of ethernet0> 
    Router(dhcp-config)#dns-server <ip address of primary dns server> 
     <ip address of secondary dns server>
    Router(dhcp-config)#end
    
  11. Cisco DSL ルータの logging console を有効に し、メモリへのすべての変更を書いて下さい。

    Router#configure terminal
    Router(config)#logging console
    Router(config)#end
    *Jan 1 00:00:00.100: %SYS-5-CONFIG_I: Configured from console by console
    Router#write memory
    Building configuration... [OK]
    Router#

設定

これは、このドキュメントの「設定手順」セクションの手順を完了した後に作成した設定です。

ダイナミック IP アドレスが割り当てられた Cisco DSL ルータ

!--- Comments contain explanations and additional information.


service timestamps debug datetime msec
service timestamps log datetime msec
vpdn enable
 no vpdn logging
 vpdn-group pppoe
  request-dialin
   protocol pppoe
!
!
ip subnet-zero
!

!--- For DHCP:

ip dhcp excluded-address <ip address of ethernet0>
ip dhcp pool <dhcp pool name>
 network <ip network address of ethernet0> <subnet mask>
 default-router <ip address of ethernet0>
 dns-server <ip address of dns server> 
!
interface ethernet0  
 no shut  
 ip address <ip address> <subnet mask> 
 ip tcp adjust-mss 1452 
 
!--- If the ip tcp adjust-mss 1452 command is not supported, try 
 !--- this configuration statement:
 !--- ip adjust-mss 1452

   

 
!--- If this command is not supported in your current Cisco DSL Router software
 !--- release, either upgrade to the latest Cisco DSL Router software or follow the 
 !--- procedure in Possible Required Configuration Steps on the PC.

 

!--- For NAT:

ip nat inside
 no ip directed-broadcast
!
interface atm0
 no shut
 no ip address
 bundle-enable
 dsl operating-mode auto
!
interface atm0.1 point-to-point
 no ip address
 no ip directed-broadcast
 no atm ilmi-keepalive
 pvc <vpi/vci>
 pppoe-client dial-pool-number 1
 
!--- Common PVC values supported by ISPs are 0/35 or 8/35.
 !--- Confirm your PVC values with your ISP.

 !
!
interface dialer1
 ip address negotiated
 mtu 1492

!--- For NAT:

 ip nat outside
 encapsulation ppp
 dialer pool 1
 ppp chap hostname <username>
 ppp chap password <password>
 ppp pap sent-username <username> password <password>
!

!--- For NAT:

ip nat inside source list 1 interface dialer1 overload

!--- If you have a pool (a range) of public IP addresses provided 
!--- by your ISP, you can use a NAT Pool. Replace 
!--- ip nat inside source list 1 interface dialer1 overload

 
 

!--- with these two configuration statements:
!--- ip nat inside source list 1 pool <nat pool name> overload
!--- ip nat pool <nat pool name> <first ip address> 
!---  <last ip address> netmask <subnet mask>



!--- If Internet users require access to an internal server, you can 
!--- add this static NAT configuration statement:
!--- ip nat inside source static tcp <inside ip address of server> {80 or 25} 
!--- <outside well-known ip address of server> {80 or 25} extendable
!--- Note: TCP port 80 (HTTP/web) and TCP port 25 (SMTP/mail) are used 
!--- for this example. You can open other TCP or UDP ports, if needed.

! 
ip classless
ip route 0.0.0.0 0.0.0.0 interface dialer 1

!--- For NAT:

access-list 1 permit <ip network address of ethernet0> <wildcard mask>

!--- In this configuration, access-list 1 defines a standard access list 
!--- that permits the addresses that NAT translates. For example, if  
!--- your private IP network is 10.10.10.0, configure 
!--- access-list 1 permit 10.10.10.0 0.0.0.255 in order to allow NAT to translate 
!--- packets with source addresses between 10.10.10.0 and 10.10.10.255.

!
end

確認

これで、Cisco DSL ルータは非対称デジタル加入者線(ADSL)サービスに対応して稼働しています。 設定を確認するには、show run コマンドを実行します。

Router#show run
Building configuration...

Output Interpreter Tool(OIT)(登録ユーザ専用)では、特定の show コマンドがサポートされています。 OIT を使用して、show コマンド出力の解析を表示できます。

トラブルシューティング

ADSLサービスがきちんとはたらかない場合 PPPoE トラブルシューティングを参照して下さい。

関連するシスコ サポート コミュニティ ディスカッション

シスコ サポート コミュニティは、どなたでも投稿や回答ができる情報交換スペースです。


関連情報


Document ID: 71119