ロング リーチ イーサネット(LRE)とデジタル加入者線(xDSL) : 非対称デジタル加入者線(ADSL)

Cisco DSL ルータの設定とトラブルシューティング ガイド - 固定 IP アドレスによる IRB

2016 年 10 月 28 日 - 機械翻訳について
その他のバージョン: PDFpdf | 英語版 (2015 年 8 月 22 日) | フィードバック


目次


概要

ご使用中の Cisco DSL ルータには、インターネット サービス プロバイダー(ISP)から固定パブリック IP アドレスが割り当てられています。

ヒント: Cisco 製デバイスの設定に不慣れで、最初から最後まで手順を追った説明が必要な場合は、『固定 IP アドレスによる IRB の段階的設定』を参照してください。

前提条件

要件

このドキュメントに関する固有の要件はありません。

使用するコンポーネント

このドキュメントは、特定のソフトウェアやハードウェアのバージョンに限定されるものではありません。

表記法

ドキュメント表記の詳細は、『シスコ テクニカル ティップスの表記法』を参照してください。

実行する作業

次の例に、2 種類の設定を示します。

  • DHCP(Dynamic Host Configuration Protocol)サーバ

  • ネットワーク アドレス変換(NAT)。

実行する作業は次のとおりです。

  • プライベート LAN の IP アドレス割り当て方式を設計します。

  • Cisco DSL ルータのイーサネット インターフェイスで IP アドレスとサブネット マスクを設定します。

  • Cisco DSL ルータの ATM インターフェイス(Asymmetric Digital Subscriber Line(ADSL; 非対称デジタル加入者線)インターフェース)に ATM Permanent Virtual Circuit(PVC; 相手先固定接続)とカプセル化を設定します。

  • Integrated Routing and Bridging(IRB)をイネーブルにします。

  • 固定 IP アドレスを使用して、IRB 用 Cisco DSL ルータのブリッジ グループ仮想インターフェイス(BVI)を作成、設定します。

  • NAT の設定 BVI インターフェイスのスタティック パブリック IP アドレスを共有できるように、Cisco DSL ルータで NAT を設定します。

    • オプション: ISP から追加の IP アドレスを提供されている場合は NAT プール。

    • オプション: インターネット ユーザが内部サーバにアクセスする必要がある場合はスタティック NAT。

  • IP アドレス、サブネット マスク、デフォルト ゲートウェイ、およびドメイン ネーム システム(DNS)サーバを使用して各ホスト PC を設定します。

    DHCP サーバの設定: Cisco DSL ルータによって PC クライアントのダイナミック IP アドレスを割り当てる場合は、DHCP を使用して自動的に IP アドレスと DNS サーバを取得するように各 PC を設定します。

設定

この項では、このドキュメントで説明する機能の設定に必要な情報を提供します。

このドキュメントで使用されているコマンドの詳細を調べるには、Command Lookup Tool登録ユーザ専用)を使用してください。

設定

ヒント: Cisco 製デバイスの設定に不慣れで、最初から最後まで手順を追った説明が必要な場合は、『固定 IP アドレスによる IRB の段階的設定』を参照してください。

固定 IP アドレスが割り当てられた Cisco DSL ルータ

!--- Comments contain explanations and additional information.


service timestamps debug datetime msec
service timestamps log datetime msec
!
bridge irb
!
ip subnet-zero
!

!--- For DHCP Server:


ip dhcp excluded-address <ip address of ethernet0>
ip dhcp pool <dhcp pool name>
 network <ip network address of ethernet0> <subnet mask>
 default-router <ip address of ethernet0>
 dns-server <ip address of dns server>

!
interface ethernet0
 no shut
 ip address <ip address> <subnet mask>
 
!--- For NAT:


 ip nat inside
 no ip directed-broadcast
!
interface atm0
 no shut
 no ip address
 no ip directed-broadcast
 no atm ilmi-keepalive
 pvc <vpi/vci>
  encapsulation aal5snap
 
!--- Common PVC values supported by ISPs are 0/35 or 8/35.
 !--- Confirm your PVC values with your ISP.

 !
 bridge-group 1
!
interface bvi1
 ip address <ip address> <subnet mask>

!--- For NAT:


 ip nat outside
 no ip directed-broadcast
!

!--- For NAT:


ip nat inside source list 1 interface bvi1 overload

!--- If you have a pool (a range) of public IP addresses provided 
!--- by your ISP, you can use a NAT Pool. Replace 
!--- ip nat inside source list 1 interface bvi1 overload
!--- with these two configuration statements:
!--- ip nat inside source list 1 pool <nat pool name> overload
!--- ip nat pool <nat pool name> <first ip address> <last ip address> 
!--- netmask <subnet mask>



!--- If Internet users require access to an internal server, you can 
!--- add this static NAT configuration statement:
!--- ip nat inside source static tcp <inside ip address of server> {80 or 25} 
!---  <outside well-known ip address of server> {80 or 25} extendable
!--- Note: TCP port 80 (HTTP/web) and TCP port 25 (SMTP/mail) are used 
!--- for this example. You can open other TCP or UDP ports, if needed.

! 
ip classless 
ip route 0.0.0.0 0.0.0.0 <default gateway to isp>

!--- For NAT:


access-list 1 permit <ip network address of ethernet0> <wildcard mask>

!--- In this configuration, access-list 1 defines a standard access list 
!--- that permits the addresses that NAT translates. For example, if  
!--- your private IP network is 10.10.10.0, the configuration of  
!--- access-list 1 permit 10.10.10.0 0.0.0.255 allows NAT to translate 
!--- packets with source addresses between 10.10.10.0 and 10.10.10.255.

!
bridge 1 protocol ieee
 bridge 1 route ip
!
end

確認

現在、この設定に使用できる確認手順はありません。

トラブルシューティング

ADSL サービスが適切に動作しない場合、『IRB を使用した RFC1483 ブリッジングのトラブルシューティング』を参照してください。

この設定とトラブルシューティング ガイドの以前のページに戻ります(『RFC1483 ブリッジングと IRB 実装オプションと』)。

『Cisco DSL ルータの設定とトラブルシューティング ガイド』のメイン ページに戻ります。


関連情報


Document ID: 71103