ロング リーチ イーサネット(LRE)とデジタル加入者線(xDSL) : 非対称デジタル加入者線(ADSL)

Cisco DSL ルータの設定とトラブルシューティング ガイド - ダイナミック IP アドレスによる IRB

2015 年 11 月 26 日 - 機械翻訳について
その他のバージョン: PDFpdf | 英語版 (2015 年 8 月 22 日) | フィードバック


目次


概要

ご使用中のシスコのデジタル加入者線(DSL)ルータには、インターネット サービス プロバイダー(ISP)からダイナミック パブリック IP アドレスが割り当てられています。

ヒント: Ciscoデバイスを設定する方法についてよくわからないし、ステップバイステップ設定に続くことを望んだ場合ダイナミックIPアドレスの IRB のステップバイステップ設定を参照して下さい。

前提条件

要件

このドキュメントに関する特別な要件はありません。

使用するコンポーネント

このドキュメントは、特定のソフトウェアやハードウェアのバージョンに限定されるものではありません。

表記法

ドキュメント表記の詳細は、『シスコ テクニカル ティップスの表記法』を参照してください。

実行する作業

注: このドキュメントで使用されているコマンドの詳細を調べるには、Command Lookup Tool登録ユーザ専用)を使用してください。

注: この例はコンフィギュレーションの 2 つの型を強調表示したものです:

  • ダイナミック ホスト コンフィギュレーション プロトコル サーバ

  • ネットワーク アドレス変換(NAT)を受けないようにします。

タスク:

  • プライベート LAN の IP アドレス割り当て方式を設計します。

  • Cisco DSL ルータのイーサネット インターフェイスで IP アドレスとサブネット マスクを設定します。

  • Cisco DSL ルータの ATM インターフェイス(Asymmetric Digital Subscriber Line(ADSL; 非対称デジタル加入者線)インターフェース)に ATM Permanent Virtual Circuit(PVC; 相手先固定接続)とカプセル化を設定します。

  • Integrated Routing and Bridging (IRB)を有効に して下さい。

  • ネゴシエートされた IP アドレスで IRB のための Cisco DSL ルータのブリッジグループ 仮想インターフェイス (BVI) インターフェイスを作成し、設定して下さい。

  • (NAT のために) — BVI インターフェイスのダイナミック パブリックIPアドレスの共有を許可するために Cisco DSL ルータの NAT を設定して下さい。

    • オプション: ISP から追加の IP アドレスを提供されている場合は NAT プール。

    • オプション: インターネット ユーザが内部サーバにアクセスする必要がある場合はスタティック NAT。

  • IP アドレス、サブネット マスク、デフォルト ゲートウェイおよび Domain Name System (DNS)サーバで各ホスト PC を設定して下さい。

    (DHCPサーバのために) —また Cisco DSL ルータに PC クライアントのダイナミック IP アドレスを割り当ててほしかったら DHCP によって IP アドレスおよび DNS サーバを自動的に得るために各 PC を設定して下さい。

設定

ヒント: Ciscoデバイスを設定する方法についてよくわからないし、ステップバイステップ設定に続くことを望んだ場合ダイナミックIPアドレスの IRB のステップバイステップ設定を参照して下さい。

ダイナミック IP アドレスが割り当てられた Cisco DSL ルータ

!--- Comments contain explanations and additional information.


service timestamps debug datetime msec
service timestamps log datetime msec
!
bridge irb
!
ip subnet-zero
!

!--- For the DHCP Server:


ip dhcp excluded-address <ip address of ethernet0>
ip dhcp pool <dhcp pool name>
 network <ip network address of ethernet0> <subnet mask>
 default-router <ip address of ethernet0>
 dns-server <ip address of dns server>
!
interface ethernet0
 no shut
 ip address <ip address> <subnet mask>

!--- For NAT:


 ip nat inside
 no ip directed-broadcast
!
interface atm0
 no shut
 no ip address
 no ip directed-broadcast
 no atm ilmi-keepalive
 pvc <vpi/vci>
  encapsulation aal5snap
 
!--- Common PVC values supported by ISPs are 0/35 or 8/35.
 !--- Confirm your PVC values with your ISP.

 !
 bridge-group 1
!
interface bvi1
 mac-address <address from line 2 of show interface bvi1>
 ip address dhcp client-id ethernet0

!--- For NAT:


 ip nat outside
 no ip directed-broadcast
!

!--- For NAT:


ip nat inside source list 1 interface bvi1 overload

!--- If you have a pool (a range) of public IP addresses provided 
!--- by your ISP, you can use a NAT Pool. Replace 
!--- ip nat inside source list 1 interface bvi1 overload 

 

!--- with these two configuration statements:
!--- ip nat inside source list 1 pool <nat pool name> overload
!--- ip nat pool <nat pool name> <first ip address> <last ip address> 
!---  netmask <subnet mask>



!--- If Internet users require access to an internal server, you can 
!--- add these static NAT configuration statements:
!--- ip nat inside source static tcp <inside ip address of server> {80 or 25} 
!--- <outside well-known ip address of server> {80 or 25} extendable
!--- Note: TCP port 80 (HTTP/web) and TCP port 25 (SMTP/mail) are used 
!--- for this example. You can open other TCP or UDP ports, if needed.

! 
ip classless 
ip route 0.0.0.0 0.0.0.0 <default gateway to isp>

!--- For NAT:


access-list 1 permit <ip network address of ethernet0> <wildcard mask>

!--- In this configuration, access-list 1 defines a standard access list 
!--- that permits the addresses that NAT translates. For example, if  
!--- your private IP network is 10.10.10.0, the configuration of  
!--- access-list 1 permit 10.10.10.0 0.0.0.255 allows NAT to translate 
!--- packets with source addresses between 10.10.10.0 and 10.10.10.255.

!
bridge 1 protocol ieee
 bridge 1 route ip
!
end  

確認

現在、この設定に使用できる確認手順はありません。

トラブルシューティング

ADSLサービスがきちんとはたらかない場合 IRB と繋ぐトラブルシューティング RFC1483 を参照して下さい。

このコンフィギュレーション および トラブルシューティング ガイドの前 ページに- IRB インプリメンテーション オプションと繋ぐ RFC1483 戻って下さい。

Cisco DSL ルータ設定 および トラブルシューティングガイドのメイン ページに戻って下さい。

関連するシスコ サポート コミュニティ ディスカッション

シスコ サポート コミュニティは、どなたでも投稿や回答ができる情報交換スペースです。


関連情報


Document ID: 71100