ワイヤレス / モビリティ : ワイヤレス LAN(WLAN)

Wireless LAN Controller Module(WLCM)の設定例

2016 年 1 月 16 日 - 機械翻訳について
その他のバージョン: PDFpdf | 英語版 (2015 年 12 月 20 日) | フィードバック


目次


概要

Cisco WLAN コントローラ(WLC)モジュール(WLCM)により、Cisco ISR および Cisco 3700 シリーズ ルータは最大 6 台のワイヤレス LAN(WLAN)アクセス ポイント(AP)を管理でき、WLAN の展開と管理が簡素化されます。 これは、NM フォーム ファクタの Cisco WLC 2006 に相当します。 唯一の違いは、NM-WLC(WLCM モジュール)には、内部的にホスト ルータに接続されたファスト イーサネット ポートが 1 つだけあり、NM の前面プレートの外部ファスト イーサネット ポートは無効で使用できないことです。 このドキュメントでは、さまざまなシナリオで WLCM を設定する方法について説明します。

前提条件

要件

この設定を行う前に、次の要件が満たされていることを確認します。

  • Lightweight アクセス ポイント プロトコル(LWAPP)に関する基礎知識

  • WLC と Lightweight AP(LAP)に関する基礎知識

使用するコンポーネント

このドキュメントは、特定のソフトウェアやハードウェアのバージョンに限定されるものではありません。

表記法

ドキュメント表記の詳細は、『シスコ テクニカル ティップスの表記法』を参照してください。

基本設定

ここで NM-WLC は、WLAN コントローラ インターフェイスと呼ばれるルータのファスト イーサネット インターフェイスに内部的に接続されたファスト イーサネット(FE)インターフェイス(ポート 1)を 1 つだけ備えた外部 WLC(2006)と します。 次の図に例を示します。

注: Cisco WLC モジュールの前面プレートにある外部ファスト イーサネット ポートはサポートされていません。

/image/gif/paws/70530/nm-wlc-config-guide-1.gif

一般的に、モジュールへの接続は、ルータ内部で service-module session コマンドを使用して行われます。

  1. NM-WLC モジュールをルータに挿入し、有効なイメージを使ってルータを起動します。

    すべてのイメージ(ipbase から adventerprisek9 まで)が NM-WLC モジュールをサポートできます。 この機能は、Cisco IOS ソフトウェア リリース 12.4(2)XA1(ルータ ソフトウェア)で導入されました。 コントローラ ファームウェアは最小バージョンとして 3.2.78.0(コントローラ ソフトウェア)が必要です。

  2. interface wlan-controller 1/0 で IP アドレスを設定します。 ここでは、ルータのスロット 1 にモジュールが装着されているものとします。 シャットダウン状態の場合は no shut を実行します。

    c2811#configure terminal
    Enter configuration commands, one per line.  End with CNTL/Z.
    c2811(config)#
    c2811(config)#interface wlan-controller 1/0
    c2811(config-if)#ip address 192.168.99.254 255.255.255.0
    c2811(config-if)#no shut
    c2811(config-if)#end
    c2811#
  3. 特権 EXEC プロンプトで、service-module session コマンドを使用してコントローラへのセッションを開きます。

    c2811#service-module wlan-controller 1/0 session 
    Trying 192.168.99.254, 2066 ... Open

    注: WLCM モジュール用の Cisco IOS コマンドは、Cisco IOS ソフトウェア リリース 12.4(15)T 以降を実行しているルータによって異なります。 詳細については、『ルータでの Cisco WLCM の設定』を参照してください。

事前設定されていないコントローラを初めて起動した場合は、自動的に CLI ウィザードが表示され、一連の設定情報の入力が要求されます。 このウィザードはバイパスできないため、要求されたすべての情報を入力する必要があります。 設定完了時の状態を事前に把握しておけば、質問への回答が容易になります。 要求される情報の一部は、関連性が低いためすぐには使用されませんが、無効な入力は受け付けられず、バイパスもできないため、すべてを入力する必要があります。 出力は次の表のようになります。

Cisco Controller
Welcome to the Cisco Wizard Configuration Tool
Use the '-' character to backup
System Name [Cisco_ff:f6:a0]: NMWLC
Enter Administrative User Name (24 characters max): admin
Enter Administrative Password (24 characters max): *****
 
Management Interface IP Address: 192.168.99.24
Management Interface Netmask: 255.255.255.0
Management Interface Default Router: 192.168.99.254 
Management Interface VLAN Identifier (0 = untagged): 0
Management Interface Port Num [1]: 1
Management Interface DHCP Server IP Address: 192.168.99.24
 
AP Manager Interface IP Address: 192.168.99.25
 
AP-Manager is on Management subnet, using same values
AP Manager Interface DHCP Server (192.168.99.24): 192.168.99.24
 
Virtual Gateway IP Address: 1.1.1.1
 
Mobility/RF Group Name: mg1
 
Network Name (SSID): wl15
Allow Static IP Addresses [YES][no]: no
 
Configure a RADIUS Server now? [YES][no]: no
Warning! The default WLAN security policy requires a RADIUS server.
Please see documentation for more details.
 
Enter Country Code (enter 'help' for a list of countries) [US]: US
 
Enable 802.11b Network [YES][no]: YES
Enable 802.11a Network [YES][no]: YES
Enable 802.11g Network [YES][no]: YES
Enable Auto-RF [YES][no]: no
Configuration saved!
Resetting system with new configuration...

設定が完了すると、ルータが新しい設定で自動的にリブートし、ユーザ名とパスワードを入力する [User:] プロンプトで停止します。 その後で、[(シスコ コントローラ)>] プロンプトが表示されます。

User:admin
Password:*****
(Cisco Controller) >

コントローラ プロンプトでは、CLI ウィザード経由で行った設定に対する追加の設定または変更を行うことができます。 ? を使用すると ヘルプが表示されます。

ルータに戻るには、Ctrl+Shift+6 を押してから放して、x を押します。 これで、ルータ プロンプトが表示されます。 セッションは失われないため、Enter キーを押すと、コントローラに戻ります。 セッションを完全にクリアするには、ルータ プロンプトで disconnect を入力します。

コントローラが物理ポート(ポート 1)を 1 つしか備えていない場合でも、その上に静的または動的な論理インターフェイスをいくつでも作成することができるうえ、それらのインターフェイスを VLAN タグ付きまたはタグなしに設定できます。 デフォルトで、コントローラは静的でタグなしの 2 つのインターフェイスを備えています。

  • 管理インターフェイス

  • AP マネージャ インターフェイス

管理インターフェイスは管理目的に使用します。 Web ベースの GUI インターフェイスを使用して WLCM を管理する場合は、管理インターフェイス上で IP アドレスを設定して、ユーザが管理対象にするワークステーションから到達可能にする必要があります。

注: デフォルトで、コントローラ上の HTTP サーバは無効になっていますが、セキュア HTTP は有効になっています。 そのため、コントローラの管理 IP アドレスへの URL は https://mgt-ip-address の形式にする必要があります。

AP マネージャ インターフェイスは、コントローラが LAP と対話するときに使用されます。 管理インターフェイスと AP マネージャ インターフェイスは両方ともタグなしなので、それらをルータ上のインターフェイス WLC と同じ IP サブネットに配置する必要があります。

(Cisco Controller) >config
(Cisco Controller) config>interface address management 
                           192.168.99.24 255.255.255.0 192.168.99.254
(Cisco Controller) config>interface address ap-manager 
                           192.168.99.25 255.255.255.0 192.168.99.254

CLI は次の 2 とおりの方法で設定できます。 1 つは CLI の標準プロンプトから config を使用して設定する方法です。 もう 1 つは、config コマンドを使用して config プロンプトに移動してから、config という単語を使用せずに CLI を発行する方法です。 次に、例を示します。

 (Cisco Controller) >config
(Cisco Controller) config>interface address management 
                           192.168.99.24 255.255.255.0 192.168.99.254

または

(Cisco Controller)>config interface address management 
                        192.168.99.24 255.255.255.0 192.168.99.254

この例では、IP アドレス 192.168.99.24/24 を使用して管理インターフェイスを設定して、デフォルト ゲートウェイを 192.168.99.254 として定義します。

注: 管理と AP マネージャのデフォルト ゲートウェイは WLCM イーサネット ポートの IP アドレスを指している必要があります。

注: ウィザード経由でこれらの IP アドレスを設定した場合は、このコマンドは必要ありません。 これは、これらの IP アドレスの両方が同じサブネットに属しているからであって、コマンド ライン経由で設定することもできます。

いずれの場合も、最後の IP アドレス(192.168.99.254)がデフォルト ゲートウェイ IP アドレスです。 コントローラ外部ではホスト ルータを経由する経路しかないため、デフォルト ゲートウェイはルータ上のインターフェイス wlan-controller1/0 の IP アドレスにする必要があります。 この設定だけで、ルータからコントローラの管理インターフェイス IP アドレスに ping することができます。

c2811#ping 192.168.99.24
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 192.168.99.24, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 1/2/4 ms
c2811# 

例 1:AP がルータのオンボード ファスト イーサネット/ギガビット イーサネットに接続された基本設定

ルータのオンボード ギガビット イーサネットインターフェイス(g0/0)に接続された LAP の電源をオンにすると、IP アドレスに対する DHCP 要求が送信されます。 この例では、ルータが 192.168.100.0/24 ネットワークの IP アドレス プールを備えた DHCP サーバとして設定されます。 そのため、LAP には 192.168.100.101 の IP アドレスが割り当てられます。 DHCP オファーは、コントローラ IP アドレスが 192.168.99.24(コントローラの管理 IP アドレス)であることも(オプション 43 経由で)LAP に通知します。 ここで、LAP がコントローラ ディスカバリ メッセージ ユニキャストを 192.168.99.24 に送信します。 コントローラが登録を要請し、その結果、LAP がコントローラに登録されます。

WLCM に登録された LAP を表示するには、show ap summary コマンドを使用します。

(Cisco Controller) >show ap summary

AP Name             Slots  AP Type    MAC Addr           Location          Port
------------------  -----  ---------  -----------------  ---------------- 	----
AP11                 2     Cisco      00:0b:85:01:03:30                   	1

この例では、後述するように、コントローラが 2 つの WLAN(wl15 と wl16)を使って設定されます。

クライアント C1 が SSID wl15 でアソシエーション要求を送信します。 そして、ルータ上で設定された DHCP サーバから 192.168.15.101 の IP アドレスと 192.168.15.1 のデフォルト ゲートウェイをアソシエートして取得します。

クライアント C2 も SSID wl16 でアソシエーション要求を送信します。 そして、192.168.16.101 の IP アドレスと 192.168.16.1 のデフォルト ゲートウェイをアソシエートして取得します。 この時点で、2 つのクライアントは別々のサブネットに配置されています。 それらの通信は、次の図に示すように、2 つのサブインターフェイス(wlc1/0.15 と wlc1/0.16)間でルーティングを実行するルータによって可能になります。

このセットアップのためにデバイス上で必要な設定は、このドキュメントの「コントローラの設定」の項を参照してください。

/image/gif/paws/70530/nm-wlc-config-guide-2.gif

コントローラの設定

ここでは、コントローラ モジュール上で必要な設定について説明します。

  1. VLAN 15 と VLAN 16 でそれぞれ vl15vl16 という名前の 2 つの動的インターフェイスを作成します。

    (Cisco Controller) >config interface create vl15 15
    (Cisco Controller) >config interface create vl16 16
    
  2. これらの VLAN インターフェイスの IP アドレス、ネットマスク、およびデフォルト ゲートウェイを割り当てます。

    (Cisco Controller) >config interface address vl15 
                                  192.168.15.254 255.255.255.0 192.168.15.1
    
    (Cisco Controller) >config interface address vl16 
                                  192.168.16.254 255.255.255.0 192.168.16.1
    

    注: 動的インターフェイスのデフォルト ゲートウェイは、対応する VLAN 用のルータ上のサブインターフェイス IP アドレスにする必要があります。

  3. SSID wl15wl16 に対応する 2 つの WLAN 1516 を作成します。

    (Cisco Controller) >wlan create 15 wl15
    (Cisco Controller) >wlan create 16 wl16
    
  4. これらの WLAN と作成した対応する VLAN インターフェイス(有線側)をバインドします。

    (Cisco Controller) >wlan interface 15 vl15
    (Cisco Controller) >wlan interface 16 vl16
    
  5. 作成した動的インターフェイスを、クライアント DHCP 要求の転送先 DHCP サーバ IP アドレスで設定します。

    DHCP サーバはルータ上で設定されているため、ルータの対応するサブインターフェイス IP アドレスを指している必要があります。 外部 DHCP サーバを使用している場合は、その IP アドレスを指している必要があります。

    (Cisco Controller) >interface dhcp vl15 192.168.15.1
    (Cisco Controller) >interface dhcp vl16 192.168.16.1
    
  6. デフォルトで、認証方式として dot1X が有効になります。 オープン認証を使用するには、両方の WLAN に対して次のコマンドを使用して dot1X を無効にします。

    (Cisco Controller) >wlan security 802.1X disable 15
    (Cisco Controller) >wlan security 802.1X disable 16
    

この設定は、より多くの VLAN/WLAN、認証(Lightweight Extensible Authentication Protocol(LEAP)、EAP)、QoS などのニーズに基づいて拡張することができます。

注: WLCM を使用した場合は、LAP が IP サブネット ブロードキャスト経由で WLCM を検出するのが困難になります。 この原因は WLCM をバックプレーンに組み込む方法であり、LAP に直接接続された 2800 ルータのギガビット インターフェイスと LAP を同じサブネット上に配置する必要があります。 IP サブネット ブロードキャストを正常に検出するには、ip helper-address/ip forward-protocol udp 12223 コマンドを使用します。 これらのコマンドの本来の目的は、すべての IP ブロードキャスト フレームを転送/リレーすることです。 WLC が LAP に応答を返すようにさせるには、そのフレームを WLC 管理インターフェイスにリレーして宛先を指示するだけで十分のはずです。

注: 管理インターフェイスに IP アドレス、ネットマスク、およびゲートウェイ情報が設定されていれば、この項のコントローラ設定のすべてを Web ブラウザの GUI アクセス経由で簡単に実行できます。 また、ブラウザ ステーションからコントローラに到達可能にするためにネットワークで必要なすべてのルーティングが実行されます。 GUI ページを開くための URL は https://192.168.99.24 です。

ルータの設定

この項で説明したセットアップ用にルータを設定するには、次の手順を実行します。

  1. LAP に接続されたルータ上のインターフェイス G0/0 を設定します。

  2. インターフェイス wlan-controller 1/0 を 192.168.99.0/24 ネットワークの IP アドレスで設定し、サブインターフェイス VLAN 15 の w1/0.15 と VLAN 16 の w1/0.16 をネットワーク 192.168.15.0/24 と 192.168.16.0/24 の IP アドレスで設定します。

  3. 複数のプールが定義されたルータ上の DHCP サーバを設定します。

    • プール lwapp-ap が、接続先のコントローラ IP アドレスを AP に通知する DHCP オプション 43 を含む 192.168.100.0/24 ネットワークから IP アドレスを AP に割り当てます。

    • プール client-15 が、192.168.15.0/24 ネットワークから VLAN 15 内のクライアント(有線/無線)に IP アドレスを割り当てます。

    • プール client-16 が、192.168.16.0/24 ネットワークから VLAN 16 内のクライアント(有線/無線)に IP アドレスを割り当てます。

次の出力に、ルータ上の設定を示します。

ルータ
!		
interface GigabitEthernet0/0								
Description: Connected to AP							
 ip address 192.168.100.1 255.255.255.0						
 load-interval 30									
 duplex auto									
 speed auto
									
!										
ip dhcp excluded-address 192.168.100.1 192.168.100.100
!
ip dhcp pool lwapp-ap

!--- Creates a DHCP pool for the LAP.

network 192.168.100.0 255.255.255.0
default-router 192.168.100.1 
option 43 ascii "192.168.99.24"
!
ip dhcp pool vlan-15

!--- Creates a DHCP pool for users that connect to WLAN wl15.

network 192.168.15.0 255.255.255.0
default-router 192.168.15.1 
!
ip dhcp pool vlan-16

!--- Creates a DHCP pool for users that connect to WLAN wl16.

network 192.168.16.0 255.255.255.0
default-router 192.168.16.1 
!										
interface wlan-controller1/0								
 ip address 192.168.99.254 255.255.255.0							
!										
interface wlan-controller1/0.15

!--- Creates a sub-interface for VLAN 15.
						
encapsulation Dot1q 15								
ip address 192.168.15.1 255.255.255.0							
!										
interface wlan-controller 1/0.16

!--- Creates a sub-interface for VLAN 16.
					
encapsulation Dot1q 16								
ip address 192.168.16.1 255.255.255.0							
!

例 2:AP が外部スイッチに接続された VLAN 設定

ルータに装着された WLCM は、次の図に示すように、イーサネット インターフェイス経由でルータに接続された外部 WLC と論理的に同じであると見なすことができます。 ネットワーク モジュールがルータのスロット 1 に装着されていると仮定すると、標準的な接続は以下で構成されます。

  • インターフェイス wlan-controller 1/0 経由でルータに接続された WLCM。

  • ルータのオンボード ギガビット イーサネット インターフェイス G0/0 に接続されたレイヤ 2 スイッチ。

  • スイッチに接続された Lightweight AP プロトコル(LWAPP)AP。

  • AP とアソシエートした無線クライアント C1 と C2、一方は WLAN 15 内、もう一方は WLAN 16 内。

この例では、2 つの無線 VLAN または WLAN(wl15 と wl16)を対応する有線側の VLAN 15 と VLAN 16 にマッピングされたコントローラ上で作成する方法と、VLAN 15 と VLAN 16 間のルーティングをルータが dot1Q サブインターフェイス経由で実行する方法を示します。

ルータでは、すべての VLAN の WLC インターフェイス(インターフェイス コンフィギュレーション モード)で 1 つずつのサブインターフェイスを作成し、それを対応する VLAN に割り当て、それぞれのサブネットから IP アドレスを設定します。

このセットアップのためにデバイス上で必要な設定については、このドキュメントの「コントローラの設定」の項を参照してください。

/image/gif/paws/70530/nm-wlc-config-guide-3.gif

コントローラの設定

このセットアップのためにコントローラ モジュール上で次の手順を実行します。

  1. コントローラで、すべての VLAN に対して、1 つずつの動的インターフェイスを対応する VLAN 内に作成し、それぞれのサブネットから IP アドレス、ネットマスク、およびデフォルト ゲートウェイを割り当てます。

    (Cisco Controller)#configure interface create vl15 15
    (Cisco Controller)#configure interface create vl16 16
    
    (Cisco Controller)#configure interface address 
                      Vl15 192.168.15.254 255.255.255.0 192.168.15.1
    (Cisco Controller)#configure interface address 
                      Vl16 192.168.16.254 255.255.255.0 192.168.16.1
    
  2. SSID wl15wl16 に対応する 2 つの WLAN 1516 を作成します。

    (Cisco Controller)#configure wlan create 15 wl15
    (Cisco Controller)#configure wlan create 16 wl16
    
  3. これらの WLAN と作成した対応する VLAN インターフェイス(有線側)をバインドします。

    (Cisco Controller)#configure wlan interface 15 Vl15
    (Cisco Controller)#configure wlan interface 16 Vl16
    
  4. ルータ上のそれぞれのサブインターフェイス IP アドレスを指しているコントローラのインターフェイス(無線クライアント用)で DHCP サーバ情報を設定します。

    (Cisco Controller)#configure interface dhcp vl15 192.168.15.1
    (Cisco Controller)#configure interface dhcp Vl16 192.168.16.1
    

これらの設定を使用すれば、適切なセキュリティ設定も実施されたという前提で、2 つの WLAN 内で 2 つの無線クライアントがアップして動作するはずです。 WLAN 15 内のクライアントから WLAN 16 内のクライアントへのトラフィックは、ルータ上のサブインターフェイス w1/0.15 と w1/0.16 間でルーティングされます。 同じ設定をコントローラに対してサポートされている VLAN の最大数(16)まで、任意の数の VLAN に拡張できます。

スイッチの設定

すべての有線クライアントが、LAN 間ルーティング用のインターフェイス Gig 1/0/1 経由でルータにトランクされるスイッチ(cat3750 など)に接続されているという前提で、LWAPP AP をスイッチ上のインターフェイス F1/0/1 に接続し、それを VLAN 100 用に設定します。

Interface Fastethernet 1/0/1
Description: Connected to LWAPP AP
Switchport access vlan 100
Switchport mode access
!
Interface Gigabitethernet 1/0/1
Description: Connected to Router
Switchport trunk encapsulation dot1Q
Switchport mode trunk

ルータの設定

ルータ上で次の手順を実行します。

  1. スイッチに接続されたインターフェイス G0/0 と、有線 LAN の VLAN 間ルーティングに必要なサブインターフェイスも設定します。

  2. インターフェイス wlan-controller 1/0 を 192.168.99.0/24 ネットワークの IP アドレスで設定し、サブインターフェイス VLAN 15 の w1/0.15 と VLAN 16 の w1/0.16 をネットワーク 192.168.15.0/24 と 192.168.16.0/24 の IP アドレスで設定します。

  3. 複数のプールが定義されたルータ上の DHCP サーバを設定します。

    • プール lwapp-ap が、接続先のコントローラ IP アドレスを AP に通知する DHCP オプション 43 を含む 192.168.100.0/24 ネットワークから IP アドレスを AP に割り当てます。

    • プール client-15 が、192.168.15.0/24 ネットワークから VLAN 15 内のクライアント(有線/無線)に IP アドレスを割り当てます。

    • プール client-16 が、192.168.16.0/24 ネットワークから VLAN 16 内のクライアント(有線/無線)に IP アドレスを割り当てます。

    注: AP とクライアントで別々のプールが必要です。

ルータ
ip dhcp excluded-address 192.168.100.1 192.168.100.100
ip dhcp pool lwapp-ap
network 192.168.100.0 255.255.255.0
default-router 192.168.100.1 
option 43 ascii "192.168.99.24"
								
ip dhcp pool client-15
network 192.168.15.0 255.255.255.0
default-router 192.168.15.1 

ip dhcp pool client-16
network 192.168.16.0 255.255.255.0
default-router 192.168.16.1 
!
interface GigabitEthernet0/0
Description: Connected to AP
No ip address							
 load-interval 30									
 duplex auto									
 speed auto
!
interface GigabitEthernet0/0.100
encapsulation dot1Q 100
ip address 192.168.100.1 255.255.255.0	
interface wlan-controller1/0								
 ip address 192.168.99.254 255.255.255.0							
!										
interface wlan-controller1/0.15								
encapsulation Dot1q 15								
ip address 192.168.15.1 255.255.255.0							
!										
interface wlan-controller 1/0.16							
encapsulation Dot1q 16								
ip address 192.168.16.1 255.255.255.0

注: コントローラでクライアント用の DHCP サービスを実行することもできます。 ただし、コントローラは、本格的な DHCP サーバではなく、Cisco CallManager Express などのアプリケーションに必要な TFTP サーバのようなオプションをバイパスできないため、ルータ上で実行することをお勧めします。

この設定では、AP が IP アドレスを取得して、コントローラを検索し、そのコントローラに登録できます。 2 つの無線クライアント C1 と C2 は、AP とアソシエートして、それぞれのサブネットから IP アドレスを取得できるはずです。

例 3:AP がルータ上の EtherSwitch に接続された設定と有線 LAN と無線 LAN からの対応する VLAN のマージ

このシナリオでは、ISR HWIC スロット 0 に EtherSwitch HWIC が装着され、NM スロット 1 に NM-WLC が装着されます。有線クライアント C3 は IP アドレスが 192.168.16.102 の VLAN 15 内のインターフェイス F0/0/1 に接続され、有線クライアント C4 は IP アドレスが 192.168.15.102 の VLAN 16 内のインターフェイス F0/0/2 に接続されます。

LWAPP AP は IP アドレスが 192.168.100.1 の VLAN 100 内のインターフェイス F0/0/0 に接続されます。 ルータは AP に IP アドレスを供給する DHCP サーバとして設定されます。 たとえば、AP は、オプション 43 経由で、192.168.100.101 の IP アドレス、192.168.100.1 のデフォルト ゲートウェイ、および 192.168.99.24 のコントローラ IP アドレスを受け取ります。

注: コントローラに必要な設定は、ここで説明する設定ではなく、前の例で説明した設定と似ています。 残りの項では、ルータ上で必要な設定について説明します。

/image/gif/paws/70530/nm-wlc-config-guide-4.gif

無線クライアント C1 と C2 がそれぞれ wl15 内と wl16 内の LAP とアソシエートします。 無線クライアント C1 と C2 は、ルータ上で設定された DHCP サーバまたはそれらのサブネット用の IP プールを備えた外部 DHCP サーバから割り当てられる 192.168.15.101 と 192.168.16.101 の IP アドレスも取得します。 DHCP サーバが外部の場合は、IP ヘルパー アドレスを対応する VLAN とサブインターフェイス上で設定する必要があります。 ルータの観点から、それはインターフェイス VLAN 15 とインターフェイス VLAN 16 で表現される 2 つの有線 VLAN と、ルータ上の WLC インターフェイスの下の dot1Q サブインターフェイス w1/0.15 と w1/0.16 で表現される 2 つの無線 VLAN を備えています。

有線 VLAN 15 と無線 WLAN 15 を集約するには、ブリッジ グループ 15 などの共通ブリッジ グループの下でインターフェイス VLAN 15 とインターフェイス w1/0.15 を設定します。 同様に、有線 VLAN 16 と無線 WLAN 16 を集約するには、ブリッジ グループ 16 などの共通ブリッジ グループの下でインターフェイス VLAN 16 とインターフェイス w1/0.16 を設定します。 この設定によって、対応する有線 VLAN と無線 VLAN が同じ IP サブネットの 192.168.15.0/24 と 192.168.16.0/24 に属し、ブリッジ グループ内で相互に対話できます。 ただし、2 つの異なるブリッジ グループ内のクライアントが相互に通信するには、ルータ上で統合ルーティングおよびブリッジング(IRB)を有効にして、それぞれのブリッジ グループ内の BVI インターフェイス経由で通信できるようにします。

注: この設定は、有線 LAN 用の EtherSwitch HWIC または NM-ESW がルータ上に存在するという前提に基づきます。 NM/HWIC ではなく EtherSwitch サービス モジュール(NME-ESW)が存在する場合は、VLAN インターフェイスがルータ上のギガビット イーサネット インターフェイスの下の対応する dot1Q サブインターフェイスに置き換えられ、設定の残りの部分は同じままになります。

ルータの設定
!

ip dhcp excluded-address 192.168.100.1 192.168.100.100
ip dhcp excluded-address 192.168.15.1 192.168.15.100
ip dhcp excluded-address 192.168.16.1 192.168.16.100
!
ip dhcp pool lwapp-ap
network 192.168.100.0 255.255.255.0
default-router 192.168.100.1 
option 43 ascii "192.168.99.24"
!
ip dhcp pool vlan-15
network 192.168.15.0 255.255.255.0
default-router 192.168.15.1 
!
ip dhcp pool vlan-16
network 192.168.16.0 255.255.255.0
default-router 192.168.16.1 


interface FastEthernet0/0/0								
Description: Connected to AP
Switchport mode access
Switchport access vlan 100
!
interface FastEthernet0/0/1								
Description: Connected to C3
Switchport mode access
Switchport access vlan 15
!
interface FastEthernet0/0/2								
Description: Connected to C4
Switchport mode access
Switchport access vlan 16
!
Interface vlan 15
Bridge-group 15
!
Interface vlan 16
Bridge-group 16

Interface vlan 100							
 ip address 192.168.100.1 255.255.255.0						
 load-interval 30									
 !
interface wlan-controller1/0								
 ip address 192.168.99.254 255.255.255.0							
!										
interface wlan-controller1/0.15								
encapsulation Dot1q 15								
bridge-group 15							
!										
interface wlan-controller 1/0.16							
encapsulation Dot1q 16								
bridge-group 16									
!										
Bridge irb
Bridge 15 route ip
Bridge 15 protocol ieee
Bridge 16 route ip
Bridge 16 protocol ieee

Interface bvi 15
Ip address 192.168.15.1 255.255.255.0
!
Interface bvi 16
Ip address 192.168.16.1 255.255.255.0

例 4:NM-WLC 上の無線 VLAN とマージされた NME-ESW 上の有線 VLAN の設定

ISR NM スロット 2 に EtherSwitch サービス モジュール(NME-ESW)が装着され、NM スロット 1 に NM-WLC が装着されたこのシナリオを検討します。 NME-ESW は、ギガビット イーサネット リンク経由でルータに接続された外部スイッチと同等と考えることができます。 有線クライアント C3 は IP アドレスが 192.168.15.102 の VLAN 15 内のインターフェイス F0/0/1 に接続され、有線クライアント C4 は IP アドレスが 192.168.16.102 の VLAN 16 内の F0/0/2 に接続されます。

LWAPP AP は VLAN 100 内のインターフェイス F0/0/3 に接続されます。 EtherSwitch 内部インターフェイス(G1/0/2)は、インターフェイス ギガビット イーサネット 2/0 でホスト ルータに内部的に接続されます。 スイッチ内に複数の VLAN が存在するため、スイッチとルータ間の内部リンクをトランクとして設定する必要があります。 ルータは、IP アドレスを AP とクライアント(有線と無線)に供給するための複数プールを備えた DHCP サーバとして設定されます。

AP は、オプション 43 経由で、192.168.100.101 の IP アドレス、192.168.100.1 のデフォルト ゲートウェイ、および 192.168.99.24 のコントローラ IP アドレスを取得して、コントローラを検出し、そのコントローラに登録します。 無線クライアント C1 と C2 は、WLAN 15 と 16 内の LAP とアソシエートして、IP アドレスの 192.168.15.101 と 192.168.16.101 をそれぞれ取得します。 VLAN 15 と 16 内の有線クライアント C3 と C4 は、DHCP サーバから 192.168.15.102 と 192.168.16.102 の IP アドレスも取得します。

有線 WLAN 15 と無線 VLAN 15 をマージするために、共通ブリッジ グループ 15 の下でインターフェイス G2/0.15 とインターフェイス w1/0.15 を設定します。 同様に、ブリッジ グループ 16 の下でインターフェイス G2/0.16 と W1/0.16 を設定します。 2 つのブリッジ グループは、BVI のインターフェイス BVI15 と BVI16 を介して相互に通信します。

コントローラの設定は以前のシナリオと同じままです。

/image/gif/paws/70530/nm-wlc-config-guide-5.gif

ルータの設定

ルータの設定
!

ip dhcp excluded-address 192.168.100.1 192.168.100.100
ip dhcp excluded-address 192.168.15.1 192.168.15.100
ip dhcp excluded-address 192.168.16.1 192.168.16.100
!
ip dhcp pool lwapp-ap
network 192.168.100.0 255.255.255.0
default-router 192.168.100.1 
option 43 ascii "192.168.99.24"
!
ip dhcp pool vlan-15
network 192.168.15.0 255.255.255.0
default-router 192.168.15.1 
!
ip dhcp pool vlan-16
network 192.168.16.0 255.255.255.0
default-router 192.168.16.1 
!
interface GigabitEthernet2/0								
Description: Internally connected to Etherswitch
IP address 20.0.0.1 255.255.255.0
load-interval 30
!
Interface GigabitEthernet2/0.100
Encapsulation dot1Q 100							
 ip address 192.168.100.1 255.255.255.0						

Interface GigabitEthernet2/0.15
Encapsulation dot1Q 15							
 Bridge-group 15
!
Interface GigabitEthernet2/0.16
Encapsulation dot1Q 16							
Bridge-group 16									
 !
interface wlan-controller1/0								
 ip address 192.168.99.254 255.255.255.0							
!										
interface wlan-controller1/0.15								
encapsulation Dot1q 15								
bridge-group 15							
!										
interface wlan-controller 1/0.16							
encapsulation Dot1q 16								
bridge-group 16									
!										
Bridge irb
Bridge 15 route ip
Bridge 15 protocol ieee
Bridge 16 route ip
Bridge 16 protocol ieee

Interface bvi 15
Ip address 192.168.15.1 255.255.255.0
!
Interface bvi 16
Ip address 192.168.16.1 255.255.255.0

スイッチの設定

service-module session コマンドを使用して、ルータから EtherSwitch サービス モジュールへのセッションを開きます。 その後で、次の出力に示すように、スイッチを設定します。

!
Interface GigabitEthernet 1/0/2
Description: Internally connected to router G2/0 interface.
Switchport trunk encapsulation dot1Q
Switchport mode trunk

!
Interface Fastethernet 0/0/1
Description: Connected to Client C3 in vlan 15
Switchport access vlan 15
Switchport mode access
!
Interface Fastethernet 0/0/2
Description: Connected to Client C4 in vlan 16
Switchport access vlan 16
Switchport mode access
!
Interface Fastethernet 0/0/3
Description: Connected to Client LWAPP AP in vlan 100
Switchport access vlan 100
Switchport mode access

関連するシスコ サポート コミュニティ ディスカッション

シスコ サポート コミュニティは、どなたでも投稿や回答ができる情報交換スペースです。


関連情報


Document ID: 70530