アベイラビリティ : Cisco ONS 15454 SDH Multiservice Provisioning Platform (MSPP)

ONS 15454 上の ML カードと Catalyst スイッチを使用する RPR を介した EtherChannel の設定

2015 年 11 月 26 日 - 機械翻訳について
その他のバージョン: PDFpdf | ライター翻訳版 (2013 年 10 月 3 日) | 英語版 (2015 年 8 月 22 日) | フィードバック


目次


概要

このドキュメントでは、Cisco ONS 15454 環境において Cisco Catalyst 3500XL スイッチと ML シリーズ カードを使用して、復元パケット リング(RPR)を介した EtherChannel と 802.1Q トンネリングを設定する手順について説明しています。

前提条件

要件

次の項目に関する知識があることが推奨されます。

  • Cisco ONS 15454

  • Cisco ONS 15454 ML シリーズ イーサネット カード

  • Catalyst 3500XL スイッチ

使用するコンポーネント

このドキュメントの情報は、次のソフトウェアとハードウェアのバージョンに基づくものです。

  • Cisco ONS 15454 バージョン 6.x

  • Catalyst 3500XL スイッチ Cisco IOS を実行するか。 ソフトウェア リリース 12.0(5)XC

  • ML (ONS 15454 6.0 リリースの一部として組み込まれる)その実行 Cisco IOS か。 ソフトウェアリリース 12.2(27)SV およびそれ以降

このドキュメントの情報は、特定のラボ環境にあるデバイスに基づいて作成されたものです。 このドキュメントで使用するすべてのデバイスは、クリアな(デフォルト)設定で作業を開始しています。 ネットワークが稼働中の場合は、コマンドが及ぼす潜在的な影響を十分に理解しておく必要があります。

表記法

ドキュメント表記の詳細は、『シスコ テクニカル ティップスの表記法』を参照してください。

ネットワーク構成図

このドキュメントでは、2 つの ONS 15454 ノードと 2 つの Catalyst 3500 XL スイッチで構成されるラボ演習用の設定を使用します。 各 ONS 15454 には 1 つの ML 1000-2 カードが搭載され、このカードを介して ONS 15454 間に復元パケット リング(RPR)が構築されています。 Catalyst 3500 XL の 2 つのギガビット イーサネット ポートは、ML 1000-2 カードの 2 つのギガビット イーサネット ポートにそれぞれ接続されています。 図 1 にネットワーク図を示します。

図 1: ネットワーク図

/image/gif/paws/69342/f1.gif

設定

RPR の設定

RPR を構築するには次の手順を完了します。

  1. ONS 15454 A の ML1000-2 の POS 0 と ONS 15454 B の ML1000-2 の POS 1 間に回線を作成します。

  2. ONS 15454 A の ML1000-2 の POS 1 と ONS 15454 B の ML1000-2 の POS 0 間に回線を作成します。

  3. ONS 15454 A.の ML1000-2 カードを設定して下さい。

    1. IRB(統合ルーティングおよびブリッジング)を有効にします。

      bridge irb
      
    2. bridge 1 を作成します。

      Bridge 1 protocol rstp  
    3. SRP インターフェイスを設定します。

      interface SPR1
       no ip address
       no keepalive
       spr station-id 3
       spr topology discovery
       hold-queue 150 in
      !
      interface SPR1.1
       encapsulation dot1Q 1 native
       no snmp trap link-status
       bridge-group 1
       bridge-group 1 spanning-disabled
      !
    4. インターフェイス POS0 を設定します。

      !
      interface POS0
       no ip address
       load-interval 30
       spr interface-id 1
       spr keepalive
       crc 32
      !
      
    5. インターフェイス POS1 を設定します。

      !
      interface POS1
       no ip address
       load-interval 30
       spr interface-id 1
       spr keepalive
       crc 32
      !
      
  4. ONS 15454 B で ML1000-2 カードを設定します。

    1. IRB(統合ルーティングおよびブリッジング)を有効にします。

      bridge irb
      
    2. bridge 1 を作成します。

      Bridge 1 protocol rstp
      
    3. SRP インターフェイスを設定します。

      interface SPR1
       no ip address
       no keepalive
       spr station-id 4
       spr topology discovery
       hold-queue 150 in
      !
      interface SPR1.1
       encapsulation dot1Q 1 native
       no snmp trap link-status
       bridge-group 1
       bridge-group 1 spanning-disabled
      !
      
    4. インターフェイス POS0 を設定します。

      !
      interface POS0
       no ip address
       load-interval 30
       spr interface-id 1
       spr keepalive
       crc 32
      !
      
    5. インターフェイス POS1 を設定します。

      !
      interface POS1
       no ip address
       load-interval 30
       spr interface-id 1
       spr keepalive
       crc 32
      !
      

EtherChannel の設定

EtherChannel を構築するには次の手順を完了します。

  1. CAT3500_A でインターフェイス GigabitEthernet0/1 と GigabitEthernet0/2 を設定します。

    !
    interface GigabitEthernet0/1
     port group 1 distribution destination
     switchport trunk encapsulation dot1q
     switchport mode trunk
    !
    interface GigabitEthernet0/2
     port group 1 distribution destination
     switchport trunk encapsulation dot1q
     switchport mode trunk
    !
    
  2. CAT3500_B でインターフェイス GigabitEthernet0/1 と GigabitEthernet0/2 を設定します。

    !
    interface GigabitEthernet0/1
     port group 1 distribution destination
     switchport trunk encapsulation dot1q
     switchport mode trunk
    !
    interface GigabitEthernet0/2
     port group 1 distribution destination
     switchport trunk encapsulation dot1q
     switchport mode trunk
    !
    
  3. ONS 15454 A.の ML1000-2 を設定して下さい。

    1. インターフェイス GigabitEthernet0 と GigabitEthernet1 を設定します。

      !
      interface GigabitEthernet0
       no ip address
       channel-group 1
       mode dot1q-tunnel
       l2protocol-tunnel cdp
       l2protocol-tunnel stp
       l2protocol-tunnel vtp
       no cdp enable
      !
      interface GigabitEthernet1
       no ip address
       channel-group 1
       mode dot1q-tunnel
       l2protocol-tunnel cdp
       l2protocol-tunnel stp
       l2protocol-tunnel vtp
       no cdp enable
      !
      
    2. Port-Channel を設定します。

      !
      interface Port-channel1
       no ip address
       hold-queue 225 in
      !
      interface Port-channel1.1
       encapsulation dot1Q 1 native
       no snmp trap link-status
       bridge-group 1
       bridge-group 1 spanning-disabled
      !
      
  4. ONS 15454 B で ML1000-2 を設定します。

    1. インターフェイス GigabitEthernet0 と GigabitEthernet1 を設定します。

      !
      interface GigabitEthernet0
       no ip address
       channel-group 1
       mode dot1q-tunnel
       l2protocol-tunnel cdp
       l2protocol-tunnel stp
       l2protocol-tunnel vtp
       no cdp enable
      !
      interface GigabitEthernet1
       no ip address
       channel-group 1
       mode dot1q-tunnel
       l2protocol-tunnel cdp
       l2protocol-tunnel stp
       l2protocol-tunnel vtp
       no cdp enable
      !
      
    2. Port-Channel を設定します。

      !
      interface Port-channel1
       no ip address
       hold-queue 225 in
      !
      interface Port-channel1.1
       encapsulation dot1Q 1 native
       no snmp trap link-status
       bridge-group 1
       bridge-group 1 spanning-disabled
      !
      

確認

次の手順を実行して設定を確認します。

  1. ONS 15454 A.の ML1000-2 からの show interfaces port-channel コマンドを発行して下さい。 このコマンドで、EtherChannel に 2 つのギガビット イーサネット ポートがある(太字で表示)ことがわかります。

    15454A_ML1000-2>show interface port-channel 1
    
    Port-channel1 is up, line protocol is up 
    
      Hardware is GEChannel, address is 000d.28bd.0b34 (bia 0000.0000.0000)
    
      MTU 1500 bytes, BW 2000000 Kbit, DLY 10 usec, 
    
         reliability 255/255, txload 1/255, rxload 1/255
    
     Encapsulation: ARPA, loopback not set
    
      Keepalive set (10 sec)
    
      ARP type: ARPA, ARP Timeout 04:00:00
    
        No. of active members in this channel: 2 
    
            Member 0 : GigabitEthernet0 , Full-duplex, 1000Mb/s
    
            Member 1 : GigabitEthernet1 , Full-duplex, 1000Mb/s
    
      Last input 00:00:00, output 00:00:00, output hang never
    
      Last clearing of "show interface" counters never
    
      Input queue: 0/150/0/0 (size/max/drops/flushes); Total output drops: 0
    
      Queueing strategy: fifo
    
      Output queue: 0/80 (size/max)
    
      5 minute input rate 4000 bits/sec, 7 packets/sec
    
      5 minute output rate 2000 bits/sec, 4 packets/sec
    
         495875 packets input, 33757916 bytes
    
         Received 493640 broadcasts (0 IP multicast)
    
         0 runts, 0 giants, 0 throttles
    
         0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored
    
         0 watchdog, 0 multicast
    
         0 input packets with dribble condition detected
    
         55924 packets output, 4080533 bytes, 0 underruns
    
         0 output errors, 0 collisions, 0 interface resets
    
         0 babbles, 0 late collision, 0 deferred
    
         0 lost carrier, 0 no carrier
    
         0 output buffer failures, 0 output buffers swapped out
    
  2. ONS 15454 B の ML1000-2 から show interfaces port-channel コマンドを発行します。 このコマンドで、EtherChannel に 2 つのギガビット イーサネット ポートがある(太字で表示)ことがわかります。

    15454B_ML1000-2>show int port-channel 1
    
    Port-channel1 is up, line protocol is up 
    
      Hardware is GEChannel, address is 0013.60f8.65f4 (bia 0000.0000.0000)
    
      MTU 1500 bytes, BW 2000000 Kbit, DLY 10 usec, 
    
         reliability 255/255, txload 1/255, rxload 1/255
    
     Encapsulation: ARPA, loopback not set
    
      Keepalive set (10 sec)
    
      ARP type: ARPA, ARP Timeout 04:00:00
    
        No. of active members in this channel: 2 
    
            Member 0 : GigabitEthernet0 , Full-duplex, 1000Mb/s
    
            Member 1 : GigabitEthernet1 , Full-duplex, 1000Mb/s
    
      Last input 00:00:00, output 00:00:00, output hang never
    
      Last clearing of "show interface" counters never
    
      Input queue: 0/150/0/0 (size/max/drops/flushes); Total output drops: 0
    
      Queueing strategy: fifo
    
      Output queue: 0/80 (size/max)
    
      5 minute input rate 3000 bits/sec, 5 packets/sec
    
      5 minute output rate 3000 bits/sec, 6 packets/sec
    
         1970114 packets input, 143644364 bytes
    
         Received 1969971 broadcasts (0 IP multicast)
    
         0 runts, 0 giants, 0 throttles
    
         0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored
    
         0 watchdog, 0 multicast
    
         0 input packets with dribble condition detected
    
         2256335 packets output, 164715496 bytes, 0 underruns
    
         0 output errors, 0 collisions, 0 interface resets
    
         0 babbles, 0 late collision, 0 deferred
    
         0 lost carrier, 0 no carrier
    
         0 output buffer failures, 0 output buffers swapped out
    
    
  3. CAT3500_A で show cdp neighbor コマンドを発行します(図 2 を参照)。 このコマンドでは、CAT3500_B が EtherChannel を介したネイバーとして表示されます。

    図 2: CAT3500_A での show cdp neighbor コマンド

    f2.gif

  4. CAT3500_B で show cdp neighbor コマンドを発行します(図 3 を参照)。 このコマンドでは、CAT3500_A が EtherChannel を介したネイバーとして表示されます。

    図 3: CAT3500_B での show cdp neighbor コマンド

    f3.gif

  5. ping テストを実行します。

    1. CAT3500_A で VLAN2 の IP アドレスを 192.168.0.2 に設定します。

      !
      interface VLAN2
       ip address 192.168.0.2 255.255.255.0
       no ip directed-broadcast
       no ip route-cache
      !
      
    2. CAT3500_B で VLAN2 の IP アドレスを 192.168.0.4 に設定します。

      !
      interface VLAN2
       ip address 192.168.0.4 255.255.255.0
       no ip directed-broadcast
       no ip route-cache
      !
      
    3. CAT3500_A で ping コマンドを発行します(図 4 を参照)。

      ping 192.168.0.4
      
      図 4: CAT3500_A から CAT3500_B への ping テスト

      /image/gif/paws/69342/f4.gif

    4. CAT3500_B で ping コマンドを発行します(図 5 を参照)。

      ping 192.168.0.2
      
      図 5: CAT3500_B から CAT3500_A への ping テスト

      /image/gif/paws/69342/f5.gif

関連するシスコ サポート コミュニティ ディスカッション

シスコ サポート コミュニティは、どなたでも投稿や回答ができる情報交換スペースです。


関連情報


Document ID: 69342