音声とユニファイド コミュニケーション : Cisco Unified Communications Manager(CallManager)

コールをオフサイト転送できない - 発信側デバイス番号の問題

2016 年 10 月 27 日 - 機械翻訳について
その他のバージョン: PDFpdf | 英語版 (2015 年 8 月 22 日) | フィードバック


目次


概要

このドキュメントでは、外部から内部へのコールを外部サイトに転送できない 1 つの原因について説明し、Cisco CallManager 環境での解決策を提供します。

前提条件

要件

Cisco CallManager に関する基本的な知識があることが推奨されます。

使用するコンポーネント

このドキュメントの情報は、Cisco CallManager 4.x に基づくものです。

このドキュメントの情報は、特定のラボ環境にあるデバイスに基づいて作成されたものです。 このドキュメントで使用するすべてのデバイスは、クリアな(デフォルト)設定で作業を開始しています。 ネットワークが稼働中の場合は、コマンドが及ぼす潜在的な影響を十分に理解しておく必要があります。

表記法

ドキュメント表記の詳細は、『シスコ テクニカル ティップスの表記法』を参照してください。

背景説明

発呼側 の 選択はアウトバウンドコールのためのゲートウェイのアウトバウンドコールで送信 される ディレクトリ番号を選択します。 これらのオプションはどのディレクトリ番号が送信 されるか規定 します:

  • 発信元—呼び出し側のデバイスのディレクトリ番号を送信 します。

  • 最初リダイレクトは number —リダイレクト デバイスのディレクトリ番号を送信 します。

  • 最後のリダイレクトは number — コールをリダイレクトするために最後のデバイスのディレクトリ番号を送信 します。

  • 最初リダイレクト数(外部) —リダイレクト デバイスの外部ディレクトリ番号を送信 します。

  • 最後のリダイレクト数(外部) —最後のデバイスの外部ディレクトリ番号をコールをリダイレクトするために送信 します。

問題

Call Forward No Answer (CFNA)は外部 呼び出し側のデバイスが内蔵デバイスを呼出し、受信者のデバイスが外部デバイスにコールを転送しないとはたらきません。 このリストは 3 つのシナリオ テストが含まれています。 最初の 2 つは成功し、第 3 1 つは失敗します。

  • 内蔵デバイスから別の内蔵デバイスに内部を呼出させる、デバイスが両方とも同じサイトにあるとき、受信側デバイスは CFNA 状態の外部デバイスに正常にコールを転送します。 たとえば、サイト A の電話 1 は外部電話 B.にサイト A の電話 2 を呼出し、サイト A の 2 つに正常に転送しますコールを電話をかけます。

  • 内蔵デバイスから別の内蔵デバイスに内部を呼出させる、デバイスが同じ組織に異なるサイトにあるとき、受信側デバイスは CFNA 状態の外部デバイスに正常にコールを転送します。 たとえば、サイト B の電話 1 は外部電話 B.にサイト A の電話 2 を呼出し、サイト A の 2 つに正常に転送しますコールを電話をかけます。

  • 外部デバイスから内蔵デバイスに内部を呼出させるとき受信側デバイスは CFNA 状態の外部デバイスにコールを転送しません。 たとえば、外部電話 A は呼出し、サイト A の電話 1 を電話をかけますサイト A の 1 つに外部電話 B.にコールを転送しません。

図 1:トポロジ

failure-fwd-calls-offst-1.gif

原因

この問題は外部デバイスから内部を呼出させる、内蔵デバイスが CFNA 状態の別の外部デバイスに発信者番号としてオリジナル外部デバイス数の使用によってコールを転送すると発生します。 この発信者番号が定期講読された Direct Inward Dial (DID)数の一部ではないので、キャリアは無効 な 電話番号の原因で電話を拒否します。

問題は T1 がアカウント コードによって基づく長距離に呼出すことのために設定されることです。 発信者番号は T1 定期講読された数の 1 つではないので、請求問題を引き起こしています。 従って、キャリアはコールを否定します。

解決策

ゲートウェイの発呼側 の 選択はあらゆるアウトバウンドコールのためのディレクトリ番号情報を送信できます。 このフィールドはどのディレクトリ番号が送信 されるか判別します。 問題が起こるとき、このパラメータは発信元として設定 されます。 オリジナル呼出す電話番号(外部電話番号)は呼出すディレクトリ番号として使用されます。 それが定期講読された DID の数の一部ではないので、キャリアは無効 な 電話番号の原因でコールを否定します。

発呼側 の 選択をように最初に問題を解決するためにリダイレクトしますゲートウェイのための数を設定 して下さい。 これによりゲートウェイは電話番号として CFNA 状態の DID の電話番号(内蔵デバイス数)を使用します。 この電話番号は定期講読された電話番号の範囲に落ちます。 キャリアは受信者にコールを転送します。

次の手順を実行します。

  1. Cisco CallManager Administration を開始して下さい。

  2. メニューバーの Device タブのドロップダウン リストから『Gateway』 を選択 して下さい。

  3. 発呼側 の 選択 ドロップダウン リスト ボックスから『First Redirect Number』 を選択 して下さい(のレッド長方形ボックスを 2)参照して下さい。

    図 2 —アウトバウンドコール

    failure-fwd-calls-offst-2.gif


関連情報


Document ID: 69047