ワイヤレス / モビリティ : WLAN セキュリティ

内部 DHCP とオープン認証を使用する 1800 ISR ワイヤレス ルータの設定例

2015 年 11 月 26 日 - 機械翻訳について
その他のバージョン: PDFpdf | 英語版 (2015 年 8 月 22 日) | フィードバック


目次


概要

このドキュメントでは、Cisco 1800 サービス統合型ルータ(ISR)での無線 LAN(WLAN)の設定例を紹介します。

前提条件

要件

このドキュメントに関する特別な要件はありません。

使用するコンポーネント

このドキュメントの情報は、次のソフトウェアとハードウェアのバージョンに基づくものです。

  • Cisco IOS の 1800 ISR か。 高度 IP サービス 機能セットのソフトウェア リリース 12.3 または それ 以降

    注: ISR の何れかに同じ 設定を適用できます。 設定は 1800 シリーズに特定ではないです。

  • これらの無線ネットワークカードがある PC:

    • 802.11a

    • 802.11b

    • 802.11b/g a/b/g

このドキュメントの情報は、特定のラボ環境にあるデバイスに基づいて作成されたものです。 このドキュメントで使用するすべてのデバイスは、クリアな(デフォルト)設定で作業を開始しています。 ネットワークが稼働中の場合は、コマンドが及ぼす潜在的な影響を十分に理解しておく必要があります。

表記法

ドキュメント表記の詳細は、『シスコ テクニカル ティップスの表記法』を参照してください。

設定

この項では、このドキュメントで説明する機能の設定に必要な情報を提供します。

注: このドキュメントで使用されているコマンドの詳細を調べるには、Command Lookup Tool登録ユーザ専用)を使用してください。

ネットワーク構成図

このドキュメントでは、次のネットワーク構成を使用しています。

ルータへの無線接続

1800_isr_wireless1.gif

設定

手順説明

次の手順を実行します。

  1. DHCP スコープを設定し、アドレスを除きました。

    注: 除かれたアドレスはオプションです。

    Cisco IOSソフトウェアの DHCPサーバのより多くの詳細な説明のための Cisco IOS DHCPサーバを参照して下さい。

  2. Integrated Routing and Bridging をつけ、ブリッジグループを設定して下さい。

  3. Bridge-Group Virtual Interface 1 (BVI1)をインターフェイスさせるために IP アドレスを割り当てて下さい。

  4. ワイヤレスを設定して下さい。

    1. ブリッジグループ 1.にインターフェイス Dot11Radio0 か Dot11Radio1 を割り当てて下さい。

    2. Service Set Identifier (SSID)を無線インターフェイスに割り当て、次にオープン認証を定義して下さい。

設定

このドキュメントでは次の設定を使用しています。

1800 シリーズ ISR ワイヤレスおよび DHCPコンフィギュレーション
1800-ISR#show running-config 
 Building configuration...
 .
 .
!
hostname 1800-ISR
!

!--- Output suppressed.

!
ip subnet-zero
!
!
ip dhcp excluded-address 192.168.2.1 192.168.2.100

!--- This sets up DHCP and excluded addresses. Excluded addresses are optional.

!
ip dhcp pool 1800-ISR
   network 192.168.2.0 255.255.255.0
!
!
bridge irb

!--- Turn on integrated routing and bridging.

!
!
interface Dot11Radio0

!--- This is the wireless radio interface configuration.

 no ip address
 !
 ssid Cisco

!--- Here, the SSID is given as "Cisco".
  
    authentication open 

!--- This defines the authentication as open.

 !
 speed basic-1.0 basic-2.0 basic-5.5 6.0 9.0 basic-11.0 12.0 18.0 24.0 36.0 48.0 54.0
 station-role root
 bridge-group 1
 bridge-group 1 subscriber-loop-control
 bridge-group 1 spanning-disabled
 bridge-group 1 block-unknown-source
 no bridge-group 1 source-learning
 no bridge-group 1 unicast-flooding
!
!
interface BVI1
 ip address 192.168.2.1 255.255.255.0
!
ip classless
!

!--- Note: Configure the bridge 1 protocol IEEE and the bridge 1 route IP 
!--- before you create interface BVI1 or add the radio interface to bridge group 1.

!
bridge 1 protocol ieee
bridge 1 route ip
!
line con 0
line aux 0
line vty 0 4
!
no scheduler allocate
end

確認

ここでは、設定が正常に動作していることを確認します。

Output Interpreter Tool(OIT)(登録ユーザ専用)では、特定の show コマンドがサポートされています。 OIT を使用して、show コマンド出力の解析を表示できます。

適切な DHCP およびワイヤレス オペレーションを確認するためにこれらのコマンドを使用して下さい:

  • show dot11 associations

  • show ip dhcp binding

MAC および IP アドレスは show dot11 associations コマンドの出力および show ip dhcp binding コマンドの出力で一致する必要があります。 次に例を示します。

1800-ISR#show dot11 associations

802.11 Client Stations on Dot11Radio0: 

SSID [Cisco] : 

MAC Address??? ?IP address????? Device??????? ???Name??????????Parent???????? State??? ?
0040.96ac.345c  192.168.2.101?? CB21AG/PI21AG??? WLCLIENT? ??? self?????????? Associated
!

!--- Output suppressed.

!
1800-ISR#show ip dhcp binding 
Bindings from all pools not associated with VRF:
IP address????????? Client-ID/????????????? Lease expiration?????? Type
?????????????????????Hardware address/
?????????????????????User name
192.168.2.101??     0100.4096.ac34.5c?????? Dec 18 2005 05:07 PM?? Automatic
1800-ISR#

トラブルシューティング

ここでは、設定に関するトラブルシューティングについて説明します。

トラブルシューティング コマンド

注: debug コマンドを使用する前に、『debug コマンドの重要な情報』を参照してください。

Ip dhcp server をデバッグするために debug ip dhcp server packet コマンドを発行して下さい。 非暗号化オープン認証 WLAN によって、このコマンドは解決すること最も速いのおよびほとんどの有効な方式を提供したものです。

debug ip dhcp server packet コマンドはこれらのデータ トランザクションを示します:

/image/gif/paws/68099/1800_isr_wireless2.gif

debug ip dhcp server packet コマンドのこの出力は正常な DHCP 要求の例です:

1800-ISR#debug ip dhcp server packet

*Dec 17 15:40:50.379: DHCPD: DHCPREQUEST received from client 0100.4096.ac34.5c.
!

!--- This shows the client DHCP discover packet that is sent to the router.

!
*Dec 17 15:40:50.379: DHCPD: No default domain to append - abort update
*Dec 17 15:40:50.379: DHCPD: Sending DHCPACK to client 0100.4096.ac34.5c (192.168.2.101)
!

!--- This shows the router DHCP acknowledgment (ACK) that is sent back to the client.

!
*Dec 17 15:40:50.379: DHCPD: creating ARP entry (192.168.2.101, 0040.96ac.345c).
*Dec 17 15:40:50.379: DHCPD: unicasting BOOTREPLY to client 0040.96ac.345c (192.168.2.101)

トラブルシューティング手順

debug ip dhcp server packet コマンドの出力の DHCP オファーを見ない場合、802.11 プロトコルのトラブルシューティングを実行し始めて下さい。 次の手順を実行します。

  1. 無線クライアント設定、SSID およびセキュリティ/暗号化設定を確認しないで下さい。

    注: SSID は ISR およびクライアントに同じである必要があります。 この場合、SSID は「Cisco」です。 図 1 および図 2 Cisco Aironet 両方デスクトップ ユーティリティ(ADU)および Aironet Client Utility (ACU)で SSID 設定を示して下さい。 見るウィンドウは使用するファームウェアのバージョンおよび無線クライアント カードによって決まります。

    図 1 – Cisco ADU SSID 設定

    1800_isr_wireless3.gif

    図 2 – Cisco ACU SSID 設定

    1800_isr_wireless4.gif

    図 3 – Windows ワイヤレス ゼロ設定

    /image/gif/paws/68099/1800_isr_wireless5.gif

  2. Wi-Fi 互換性を確認して下さい。

    使用するleavingcisco.com Wireless Network Interface Card (NIC)の Wi-Fi 互換性を確認するために Wi-Fi 同盟ページを参照して下さい。

  3. それ以上の技術サポートに関しては Cisco テクニカル サポートに連絡して下さい。

関連するシスコ サポート コミュニティ ディスカッション

シスコ サポート コミュニティは、どなたでも投稿や回答ができる情報交換スペースです。


関連情報


Document ID: 68099