音声とユニファイド コミュニケーション : Cisco Unity Express

Cisco CME の基本的自動着信呼分配と Cisco Unity Express 自動応答の相互運用の設定例

2016 年 10 月 27 日 - 機械翻訳について
その他のバージョン: PDFpdf | 英語版 (2015 年 8 月 22 日) | フィードバック


目次


概要

このドキュメントでは、Cisco CallManager Express(CME)の基本自動着信呼分配(ACD)と Cisco Unity Express の自動受付(AA)の機能を使用するための設定例を紹介します。

前提条件

要件

Cisco CME および Cisco Unity Express コンフィギュレーションの全般的な精通が必要となります。 この資料は Cisco CME 基本 ACD および Cisco Unity Express AA 相互にコンフィギュレーションとりわけ焦点を合わせます。

以下はこの設定例に説明がある機能性のためのミニマムリリースです:

  • Cisco CME 3.3

  • Cisco IOS(R) ソフトウェア リリース 12.4.3

  • Cisco Unity Express 2.1.3

使用するコンポーネント

このドキュメントの情報は、次のソフトウェアとハードウェアのバージョンに基づくものです。

  • Cisco CME および Cisco Unity Express を経営する Cisco 2821 ルータ

  • Cisco IOS ソフトウェア リリース 12.4.3

  • Cisco CME 3.3

  • 基本的な ACD スクリプトバージョン 2.1.0.0

  • Cisco Unity Express 2.1.3

  • IP 音声 Cisco IOSフィーチャセット

このドキュメントの情報は、特定のラボ環境にあるデバイスに基づいて作成されたものです。 このドキュメントで使用するすべてのデバイスは、クリアな(デフォルト)設定で作業を開始しています。 ネットワークが稼働中の場合は、コマンドが及ぼす潜在的な影響を十分に理解しておく必要があります。

関連製品

この設定も Cisco 2600XM、Cisco 3700、Cisco 2800、または Cisco IOS ソフトウェア リリース 12.4.1 またはそれ以降の Cisco 3800 シリーズ ルータによって使用することができます。

表記法

ドキュメント表記の詳細は、『シスコ テクニカル ティップスの表記法』を参照してください。

背景説明

この 3 つのシナリオはこの資料で当たります:

  • Cisco CME AA 1 を使用してシナリオおよび音声メール 宛先としてだけ Cisco Unity Express の ACD グループ

  • その AA 内の「サブメニュー」として主要な AA エントリポイントおよび Cisco CME AA として Cisco Unity Express 2 を使用してシナリオ

  • AA の一部として適用範囲が広い「発表」を提供する主要な AA エントリポイントおよび Cisco Unity Express AA として Cisco CME AA 3 を使用してシナリオ

シナリオ1 は Cisco CME AA が ACD グループにダイレクト コールへメニューを提供することに制限されるとき最も適当です。 このシナリオでは、Cisco CME は着信コールのために AA 宛先として使用され、ACD エージェントが利用できないし、ある程度の時間の呼び出しに応答しないとき Cisco Unity Express は音声メールサーバとして特に使用されます。 Cisco Unity Express AA はこのシナリオで使用されません。

シナリオ 2 は Cisco CME 基本 ACD および Cisco Unity Express AA を統合ための最も適用範囲が広く全面的な設定です。 設計は一般の通話処理 オートメーションと呼び出しに ACD エージェントを離れて渡すことのためにシナリオ 2 機能 Cisco Unity Express AA で使用しました。 このシナリオでは、Cisco Unity Express は着信コールのために AA 宛先として使用されます; Cisco Unity Express はまた発信者にいろいろなメニュー選択を提供します(dial-by-name、ダイヤルによ拡張およびレコード情報セグメントのような)。 これらの選択の 1 つは Cisco CME ACD グループにいくつかの呼び出しを送信します。 Cisco Unity Express 音声メールはシナリオ1 として同じような方法で使用されます。

シナリオ 3 は Cisco CME が着信コールのために AA 宛先として AA 使用され、ACD が AA の必要な主な機能のシナリオ1 の変化です。 ただし、Cisco Unity Express AA は Cisco CME AA と「発表 サーバ」として使用されます。 これは利用可能ではないいくつかの発表を追加する機能を提供しま(営業時間か位置のような) Cisco だけ CME AA 使用します。

このパブリケーションで提供される GUI ベース コンフィギュレーション手順が資料の全体にわたって説明されている機能を設定するのにこの設定例と関連付けられるインプリメンテーション プロセスを説明し、必要とされるステップを要約するのに使用されています。 ただし、完全なステップバイステップ手順は提供されません。 このパブリケーションは Cisco CME および Cisco Unity Express GUI とのはたらく習熟度がある、また Cisco IOS CLI の実際上の知識と仮定します。 手順およびコマンドの使い方の明示的 な詳細については Cisco CME および Cisco Unity Express 適切な管理者ガイド、コンフィギュレーション ガイドおよびコマンドレファレンスを参照して下さい。

設定

この項では、このドキュメントで説明する機能の設定に必要な情報を提供します。

このセクションで使用されているコマンドの詳細を調べるには、Command Lookup Tool登録ユーザ専用)を使用してください。

ネットワーク図

このドキュメントでは、次のネットワーク構成を使用しています。

図 1 Cisco CME 基本 ACD および Cisco Unity Express AA のためのネットワークダイアグラム

/image/gif/paws/67907/135345.jpg

設定

3 つのコンフィギュレーションシナリオにすべてこれらの一般的な特性があります:

  • シングル サイト Cisco CME システム

  • Cisco CME ルータで統合 PSTN トランク

  • 設定は 2000 年から 2010 範囲の IP Phone 拡張を用いる 4桁ダイヤリングプランを、21 XX 範囲の 2020 から 2099 範囲および Cisco Unity Express エントリポイントの非電話拡張(ハント グループのような)定義します。

  • 9 IP 電話は、拡張 2000 年に 2009 年定義されます。

  • ACD セットアップは各グループで 3 IP 電話と 3 人のハント グループを使用します。

  • また ACD グループの 9 IP 電話の一部である 2 人の受付係は定義されます。

ネットワークコンフィギュレーションはこれらの特性と Cisco 2821 ルータを使用します:

  • IP アドレス b .168.1.1 による IPネットワーク アクセス

  • 9 IP 電話の Cisco CME 設定--それぞれ 4桁拡張(2010)とへの 2001 年

  • NM-CUE

  • Cisco Unity Express IP アドレス .1.11.2

このドキュメントでは、次の設定を使用します。

概要実装 設定に関する注記

この設定で使用される PSTN 接続は外国為替事務所 (FXO) トランクによってあります。 PRI トランクがある場合、コンフィギュレーション一見はこれらの設定 エントリの付加が付いているこの出版物で丁度同じ設定例で与えられたそれらと、示しました:

controller T1 2/1
 framing esf
 linecode b8zs
 pri-group timeslots 1-24
!
interface Serial2/1:23
 no ip address
 isdn switch-type primary-ni
 isdn incoming-voice voice
 no cdp enable
!
voice-port 2/1:23
!
dial-peer voice 777 pots
 incoming called-number .
 direct-inward-dial
 port 2/1:23

このパブリケーションで示される例で使用する Cisco Unity Express AA スクリプトは非常に簡単で、この資料によって説明される機能性を実現させるために明確にするために機能の最小番号が含まれています。 実稼働中 の ネットワークで展開される Cisco Unity Express AA スクリプトはラボ テスト ネットワークと比較されるかなり多くの通話処理機能があるはずです。 追加通話処理「ステップ」は次を含むことができます:

  • 発信者がメニューにないディジットを押す時改善されたエラー処理(のような)

  • タイムアウト処理(メニューを繰り返すことのような時の固定番号)

  • 外部 PSTN 宛先への呼び出しの外部転送をブロックする能力(通話料の不正を避けるため)。

シナリオ1 - Cisco Unity Express 音声メールとの Cisco CME 基本 ACD の使用

シナリオ1 では、着信コールは Cisco CME AA (発信者に 3 つのオプションを歓迎されたメッセージおよびメニューに与える 2040) 拡張に送信されます。 発信者の選択に基づいて、コールは 3 人の ACD ハント グループの 1 つに送信されます。 呼び出しが ACD グループで応答されない場合メッセージを残すために、呼び出しは一般の配信メールボックス(GDM)に転送されます。

各ユーザのメールボックスにできません(分配リストと同じような)コピーされるべき GDM を設定。

このセクションに説明があるこのシナリオでは単一 GDM は ACD グループの 9 つの ACD エージェントがすべてログインにおよび取得する メッセージできるように使用されます。 シナリオ 2 の一部として記述されている他のバリエーションでは ACD グループごとのユーザー GDM を持つ機能は探索されます。

コールフロー

このセクションの設定のコールフローは図 2.説明されます。

図 2 Cisco CME 基本的な ACD シナリオ1 コールフローを用いる Cisco Unity Express AA

/image/gif/paws/67907/135346.jpg

シナリオ1 設定に関する注記

FXO ポート(0/3/0)から PSTN 呼び出しは Cisco CME AA パイロット番号に(接続 plar-opx 2040 コマンドによって) autoterminated (2040)。 Cisco CME AA は 3 つのオプションの歓迎されたメッセージおよび歓迎されたメニューを表示します--プロンプトの話されていたコンテンツはコールフロー ピクチャで図 2.屈服します。 記録された歓迎された句はフラッシュファイル en_bacd_welcome.au に記録されたメニュー句はファイル en_bacd_options_menu.au に常駐するが、常駐します。

拡張 2070 年のための GDM メッセージは次の通りです: 「弊社販売代理店に問い合わせるためにありがとう; 誰も今は利用可能ではないです。 メッセージを残せば」。できるとすぐコールを戻します

GDM のメッセージのためのメッセージ ウェイティング インジケータ(MWI)は音声メールパイロットへ CFA (call forward all)である中間拡張への Cisco CME AA (パラメーター音声メール 2070 コマンド)の転送によって実現します(2070) (2105)。 このフォワーディングは音声メールパイロットを Cisco CME AA を直接指すかわりにされます--実行されるかどれがパラメーター音声メール 2105 コマンドで。 拡張 2070 年はエージェント電話のボタン 2 であり、このボタンは ACD hunt-group 第(2020、2021 または 2022)とのより拡張 2070--rather と関連付けられる GDM のための MWI を示します。 「最終的な」数は AA フォワーディング数(パラメーター音声メール コマンド)を支持して hunt-group でので ACD ロジック バイパス最終番号設定されません。

それがスクリプトへの変更を行なう、アプリケーションをロードする必要があります。

Cisco CME AA スクリプトはループバックIPアドレスと関連付けられます(Tool Command Language (TCL)スクリプトを確認する .1.1.1) a は常にあります--LAN インターフェイス(dial-peer voice 2040 voip コマンド)の状態に関係なく。 続けてダイヤル ピアは Cisco CME AA エントリポイントへのダイレクト コールに使用されます(2040) PSTN 発信者(、またローカルIP 電話) AA (dial-peer voice 2041 voip コマンド)を呼出すことができるようにするため。

シナリオ1 のための Cisco CME を設定して下さい

これらのステップはシナリオ1 の Cisco CME のための設定を要約します:

  1. > Cisco CME AA の 3 つのメニューオプションと関連付けられる 3 つの ACD hunt-group 2020、2021、および 2022 を設定するシステムパラメータ 『Configure』 を選択 して下さい。 図 3.参照して下さい。

    図 3 Cisco Unity Express ACD ハント グループを規定 して下さい

    /image/gif/paws/67907/135352.jpg

  2. > エージェントで hunt-group 2020 のための詳細を 2001 年、2002 年、および 2003 年設定するシステムパラメータ 『Configure』 を選択 して下さい。 図 4.参照して下さい。

    図 4 ハント グループ 2020 のための詳細を設定して下さい

    /image/gif/paws/67907/135353.jpg

  3. > 電話『Configure』 を選択 し、変更したいと思う電話の MAC アドレスをクリックして下さい。 変更 Phone ウィンドウは現われます(図を 5)参照して下さい。

  4. GDM のメッセージのための MWI を得るために ACD エージェントの電話のエクステンションを 2070 入力して下さい。

    図 5 特定のボタンに拡張を関連付けて下さい

    /image/gif/paws/67907/135354.jpg

以下は特定の変更からの基礎設定への結果シナリオ1 のための完全な(注釈される) Cisco CME ルータ CLI 設定であり。

CME-2821#show running-config
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname CME-2821
!
boot-start-marker
boot system flash:
boot-end-marker
!
no aaa new-model
!
resource policy
!
ip subnet-zero
!
!
ip cef
no ip dhcp use vrf connected
ip dhcp excluded-address b.168.1.1 b.168.1.10
!
ip dhcp pool ITS
   network b.168.1.0 255.255.255.0
   option 150 ip a.1.11.1 
   default-router b.168.1.1 
!
no ip domain lookup
!
voice-card 0
 no dspfarm
!
voice service voip 
 allow-connections h323 to h323
 allow-connections h323 to sip
 supplementary-service h450.12 advertise-only
!

!--- Define the parameters for the Cisco CME ACD TCL script. 
!--- The hunt groups for the
!--- ACD are 2020, 2021, and 2022.

!
application
 service acd flash:app-b-acd-2.1.0.0.tcl
  param queue-cme-debugs 1
  param aa-hunt1 2020
  param aa-hunt2 2021
  param number-of-hunt-grps 3
  param aa-hunt3 2022
  param queue-len 30
 !

!--- Define the parameters for the Cisco CME AA TCL script. 
!--- The pilot number is 2040.
!--- The voice-mail destination is extension 2070, which is call forward all
!--- (CFA) routed to voice mail (2105).

!
 service cme-aa flash:app-b-acd-aa-2.1.0.0.tcl
  param max-time-call-retry 60
  param voice-mail 2070
  paramspace english index 0
  param service-name acd
  param number-of-hunt-grps 3
  param handoff-string cme-aa
  paramspace english language en
  param max-time-vm-retry 1
  paramspace english location flash:
  param aa-pilot 2040
  param second-greeting-time 30
  paramspace english prefix en
  param call-retry-timer 20
!

!--- Define the loopback address to which the TCL script is attached.

!
interface Loopback0
 ip address a.1.11.1 255.255.255.252
!
interface GigabitEthernet0/0
 no ip address
 shutdown
 duplex auto
 speed auto
!
interface GigabitEthernet0/1
 no ip address
 shutdown
 duplex auto
 speed auto
!
interface FastEthernet0/1/0
 switchport access vlan 10
!
interface FastEthernet0/1/1
 switchport access vlan 10
!
interface FastEthernet0/1/2
 switchport access vlan 10
!
interface FastEthernet0/1/3
 switchport access vlan 10
!
interface FastEthernet0/1/4
 switchport access vlan 10
!
interface FastEthernet0/1/5
 switchport access vlan 10
!
interface FastEthernet0/1/6
 switchport access vlan 10
!
interface FastEthernet0/1/7
 switchport access vlan 10
!
interface FastEthernet0/1/8
 switchport access vlan 10
!
interface Service-Engine1/0
 ip unnumbered Loopback0
 service-module ip address a.1.11.2 255.255.255.252
 service-module ip default-gateway a.1.11.1
!
interface Vlan1
 no ip address
!
interface Vlan10
 ip address b.168.1.1 255.255.255.0
!
ip classless
ip route a.1.11.2 255.255.255.255 Service-Engine1/0
!
ip http server
ip http path flash:
!
tftp-server flash:P00305000600.bin
tftp-server flash:P00305000600.sbn
!
control-plane
!

!--- PSTN calls are auto-terminated on the Cisco CME AA pilot number 2040.

!
voice-port 0/3/0
 connection plar opx 2040
!
voice-port 0/3/1
 connection plar opx 2040
!
voice-port 0/3/2
!
voice-port 0/3/3
!

!--- Calls to Cisco CME AA pilot number 2040 are associated with a loopback address
!--- a.1.11.1 to ensure that the TCL script is always up.

!
dial-peer voice 2040 voip
 destination-pattern 2040
 session target ipv4:a.1.11.1
 dtmf-relay h245-alphanumeric
 codec g711ulaw
 no vad
!

!--- The back-to-back dial-peer for Cisco CME AA 
!--- pilot number 2040 points to the
!--- AA TCL script and ensures that all PSTN and 
!--- internal callers can reach the AA.

!
dial-peer voice 2041 voip
 service cme-aa
 incoming called-number 2040
 dtmf-relay h245-alphanumeric
 codec g711ulaw
 no vad
!

!--- All calls in the 21xx range are directed to Cisco Unity Express.

!
dial-peer voice 2105 voip
 destination-pattern 21..
 session protocol sipv2
 session target ipv4:a.1.11.2
 dtmf-relay sip-notify
 codec g711ulaw
 no vad
!
telephony-service
 load 7960-7940 P00305000300
 max-ephones 48
 max-dn 192
 ip source-address a.1.11.1 port 2000
 max-redirect 20
 auto assign 1 to 10
 system message CISCO SYSTEMS
 create cnf-files version-stamp 7960 Aug 05 2005 00:00:32
 voicemail 2105
 max-conferences 8 gain -6
 moh music-on-hold.au
 dn-webedit 
 time-webedit 
 transfer-system full-consult
 transfer-pattern 210. blind
 transfer-pattern 2040 blind
!

!--- The following section shows nine ACD agents' extensions.

!
ephone-dn  1  dual-line
 number 2001
 name User21
 call-forward busy 2105
 call-forward noan 2105 timeout 10
!
ephone-dn  2  dual-line
 number 2002
 name User22
 call-forward busy 2105
 call-forward noan 2105 timeout 10
!
ephone-dn  3  dual-line
 number 2003
 name User23
 call-forward busy 2105
 call-forward noan 2105 timeout 10
!
ephone-dn  4  dual-line
 number 2004
 name User24
 call-forward busy 2105
 call-forward noan 2105 timeout 10
!
ephone-dn  5  dual-line
 number 2005
 name User25
 call-forward busy 2105
 call-forward noan 2105 timeout 10
!
ephone-dn  6  dual-line
 number 2006
 name User26
 call-forward busy 2105
 call-forward noan 2105 timeout 10
!
ephone-dn  7  dual-line
 number 2007
 name User27
 call-forward busy 2105
 call-forward noan 2105 timeout 10
!
ephone-dn  8  dual-line
 number 2008
 name User28
 call-forward busy 2105
 call-forward noan 2105 timeout 10
!
ephone-dn  9  dual-line
 number 2009
 name User29
 call-forward busy 2105
 call-forward noan 2105 timeout 10
!

!--- Extension 2070 is associated with the GDM. 
!--- This extension is used to get MWI
!--- on the ACD agents' phone.

!
ephone-dn  11
 number 2070
 description GDM
 name Cust Svc GDM
 call-forward all 2105
!
ephone-dn  100
 number 8000....
 mwi on
!
ephone-dn  101
 number 8001....
 mwi off
!

!--- The following section shows phone definitions for the nine ACD agents.
!--- Ephone-dn 11 (2070) is defined as button 2 on each phone, so that all
!--- agents can get MWI for the GDM.

!
ephone  1
 username "user21" password null
 mac-address 0012.0034.81B7
 type 7960
 button  1:1 2:11
!
ephone  2
 username "user22" password null
 mac-address 0011.2032.C876
 type 7960
 button  1:2 2:11
!
ephone  3
 username "user23" password null
 mac-address 0012.01E8.875F
 type 7960
 button  1:3 2:11
!
ephone  4
 username "user24"
 mac-address 0003.AAAA.0004
 type 7960
 button 1:4 2:11
!
ephone 5
 username "user25"
 mac-address 0003.AAAA.0005
 type 7960
 no auto-line
 button 1:5 2:11
!
ephone 6
 username "user26"
 mac-address 0003.AAAA.0006
 type 7960
 button 1:6 2:11
!
ephone 7
 username "user27"
 mac-address 0003.AAAA.0007
 type 7960
 button 1:7 2:11
!
ephone 8
 username "user28"
 mac-address 0003.AAAA.0008
 type 7960
 button 1:8 2:11
!
ephone  9
 username "user29"
 mac-address 0003.AAAA.0009
 type 7960
 button 1:9 2:11
!

!--- Three hunt-groups are used by the ACD scripts. 
!--- There are three agents in each group.

!
ephone-hunt 1 longest-idle
 pilot 2020
 list 2001, 2002, 2003
 timeout 5
!
ephone-hunt 2 longest-idle
 pilot 2021
 list 2004, 2005, 2006
 timeout 5
!
ephone-hunt 3 longest-idle
 pilot 2022
 list 2007, 2008, 2009
 timeout 5
!
line con 0
 logging synchronous
line aux 0
line 66
 no activation-character
 no exec
 transport preferred none
 transport input all
 transport output all
line vty 0 4
 login
!
scheduler allocate 20000 1000
ntp master
!
end

シナリオ1 のための Cisco Unity Express を設定して下さい

これらのステップはシナリオ1 の Cisco Unity Express のための設定を要約します:

  1. > Groups を『Configure』 を選択 して下さい。 それからそのグループ(custservice)を編集したいと思いますクリックして下さい。 グループ プロファイル ウィンドウは現われます(図を 6)参照して下さい。

  2. Profile タブはデフォルト ディスプレイです。 拡張 2070 年と関連付けられる custservice グループを設定して下さい。

    図 6 グループ プロファイルを設定して下さい

    142424.jpg

  3. 所有者/Members タブをクリックして下さい(図を 7)参照して下さい。

  4. custservice グループのメンバー(すべての 9 人の ACD エージェント ユーザ)を設定して下さい。

    図 7 グループ メンバーを設定して下さい

    135356.jpg

以下は特定の変更からの基礎設定への結果シナリオ1 のための完全な(注釈される) Cisco Unity Express CLI 設定であり、:

cue#show running-config
Generating configuration:
clock timezone America/Los_Angeles
hostname cue
ip domain-name cisco.com
ntp server a.1.11.1
groupname Administrators create
groupname Broadcasters create
!

!--- The custservice group is defined as all the 
!---users that have access to the GDM.

!
groupname custservice create
!

!--- Nine ACD agents are defined as users.

!
username admin create
username user21 create
username user22 create
username user23 create
username user24 create
username user25 create
username user26 create
username user27 create
username user28 create
username user29 create
!

!--- The custservice group (and therefore GDM) 
!--- is associated with extension 2070.

!
groupname custservice phonenumber "2070"
username user21 phonenumber "2001"
username user22 phonenumber "2002"
username user23 phonenumber "2003"
username user24 phonenumber "2004"
username user25 phonenumber "2005"
username user26 phonenumber "2006"
username user27 phonenumber "2007"
username user28 phonenumber "2008"
username user29 phonenumber "2009"
groupname Administrators member admin
!

!--- Nine ACD agents users are members of the 
!--- custservice group, so they can have
!--- access to the GDM to retrieve messages.

!
groupname custservice member user21
groupname custservice member user22
groupname custservice member user23
groupname custservice member user24
groupname custservice member user25
groupname custservice member user26
groupname custservice member user27
groupname custservice member user28
groupname custservice member user29
groupname Administrators privilege superuser
groupname Administrators privilege ManagePrompts
groupname Administrators privilege ManagePublicList
groupname Administrators privilege ViewPrivateList
groupname Broadcasters privilege broadcast
calendar biz-schedule systemschedule
 closed day 1 from 00:00 to 24:00
 open day 2 from 09:00 to 17:00
 open day 3 from 09:00 to 17:00
 open day 4 from 09:00 to 17:00
 open day 5 from 09:00 to 17:00
 open day 6 from 09:00 to 17:00
 closed day 7 from 00:00 to 24:00
end schedule
!

!--- The Cisco Unity Express system AA is defined 
!--- in the system by default, but
!--- is not used in this scenario.

!
ccn application autoattendant
 description "autoattendant"
 enabled
 maxsessions 8
 script "aa.aef"
 parameter "busOpenPrompt" "AABusinessOpen.wav"
 parameter "holidayPrompt" "AAHolidayPrompt.wav"
 parameter "busClosedPrompt" "AABusinessClosed.wav"
 parameter "allowExternalTransfers" "false"
 parameter "MaxRetry" "3"
 parameter "operExtn" "2001"
 parameter "welcomePrompt" "AAWelcome.wav"
 parameter "businessSchedule" "systemschedule"
 end application
ccn application ciscomwiapplication
 description "ciscomwiapplication"
 enabled
 maxsessions 8
 script "setmwi.aef"
 parameter "strMWI_OFF_DN" "8001"
 parameter "strMWI_ON_DN" "8000"
 parameter "CallControlGroupID" "0"
 end application
ccn application promptmgmt
 description "promptmgmt"
 enabled
 maxsessions 1
 script "promptmgmt.aef"
 end application
ccn application voicemail
 description "voicemail"
 enabled
 maxsessions 8
 script "voicebrowser.aef"
 parameter "logoutUri" "http://localhost/voicemail/vxmlscripts/mbxLogout.jsp"
 parameter "uri" "http://localhost/voicemail/vxmlscripts/login.vxml"
 end application
ccn engine
 end engine
ccn subsystem jtapi
 ccm-manager address 0.0.0.0 
 end subsystem
ccn subsystem sip
 gateway address "a.1.11.1"
 end subsystem
ccn trigger sip phonenumber 2102
 application "autoattendant"
 enabled
 maxsessions 8
 end trigger
ccn trigger sip phonenumber 2105
 application "voicemail"
 enabled
 maxsessions 8
 end trigger
ccn trigger sip phonenumber 2106
 application "promptmgmt"
 enabled
 maxsessions 1
 end trigger
voicemail default language en_US
voicemail default mailboxsize 3000
voicemail broadcast recording time 300
voicemail operator telephone 2001
!

!--- Define the GDM associated with 2070, 
!--- associated with the custservice group.

!
voicemail mailbox owner "custservice" size 3000
 description "custservice mailbox"
 end mailbox
!

!--- Define personal mailboxes for nine ACD agents.

!
voicemail mailbox owner "user21" size 3000
 end mailbox
voicemail mailbox owner "user22" size 3000
 end mailbox
voicemail mailbox owner "user23" size 3000
 end mailbox
voicemail mailbox owner "user24" size 3000
description "user24 mailbox"
end mailbox
voicemail mailbox owner "user25" size 3000
description "user25 mailbox"
end mailbox
voicemail mailbox owner "user26" size 3000
description "user26 mailbox"
end mailbox
voicemail mailbox owner "user27" size 3000
description "user27 mailbox"
end mailbox
voicemail mailbox owner "user28" size 3000
description "user28 mailbox"
end mailbox
voicemail mailbox owner "user29" size 3000
description "user29 mailbox"
end mailbox
end

シナリオ 2 -第 2 層メニューとして最初の層メニューおよび基本 ACD として Cisco Unity Express AA を使用して下さい

シナリオ 2 では、着信コールは Cisco Unity Express カスタム AA (発信者に 4 つのオプションを歓迎されたメッセージおよびメニューに与える 2100) パイロット番号に送信されます。 発信者の選択に基づいて、コールは Cisco CME ACD (1) オプション、2 つのに発表(一般ビジネスの 1 つメールボックス(2080)へのオプション 2 および 3)、または受付係(4) オプションと関連付けられる拡張のための GDM 送信されます。

発信者が 1 つを『Option』 を選択 する場合、コールは Cisco CME ACD に Cisco CME AA がシナリオ1 に類似したである第 2 層メニューを提供するところで渡されます。

シナリオ 2 コールフロー

このセクションの設定のコールフローは図 8.説明されます。

図 8 シナリオ 2 のためのコールフロー

135360.jpg

シナリオ 2 つの設定に関する注記

FXO ポート(0/3/0)から PSTN 呼び出しは Cisco Unity Express AA に autoterminated (2100)。

最初の層メニュー(「ウィジェット システムを呼出すためにありがとう; 弊社販売代理店のために『1』 を押して下さい; オフィスの場所のために『2』 を押して下さい; 営業時間の間『3』 を押して下さい; 音声 メッセージを残すために『4』 を押して下さい。」) Cisco Unity Express カスタム AA (ファイル S10_Main_Menu.wav)によって提供されます。

二番目の層メニュー(「コールのリダイレクトを助けるため: ハードウェア関連質問のために『1』 を押して下さい; ソフトウェア関連の質問のために『2』 を押して下さい; 一般的な質問のために『3』 を押して下さい。」) Cisco CME AA プロンプト ファイルによって提供されます。 最初の句はフラッシュファイル en_bacd_welcome.au で(「コール」のリダイレクトを助けるため)手順の残りはシナリオ1 設定から不変で、フラッシュファイル en_bacd_options_menu.au で含まれているが、含まれています。

によって削除することバイパス Cisco CME ソフトウェアがメッセージをバイパスします)全体で Cisco CME 歓迎された挨拶を小さい空 ファイルを記録することまたはからファイルをルータのフラッシュする(できます。 このセクションで描写されるシナリオ 2 例では Cisco Unity Express および Cisco CME 敏速なファイルと関連付けられるメニュー句は発信者に単一 AA としてフローするために構成されました。 Cisco CME AA をバイパスしている間また Cisco CME ACD にコールを直接転送するパラメータ ドロップするによオプション number コマンドの使用によって Cisco CME AA を(歓迎されたグリーティングおよびオプション選択)全体でバイパスできます。

拡張 2080 年および関連する GDM は設定に受付係に一般のメールボックスを提供するために追加されます。 このメールボックスは最初の層メニューから 4 つを『Option』 を選択 することによって入り、Cisco Unity Express の内で完全に処理されます。 拡張 2080 年は IP 電話 受付係である 2 人の従業員と対応づけられる 2001 年および 2004--the 電話に追加されました(、また ACD エージェント)。

発信者が最初の層メニューから『1』 を選択 し、が ACD グループに指示されれば、コールが未解答に残る場合、コールは 2070 ACD エージェントのための GDM である内線番号に転送されます。

シナリオ 2 のための Cisco CME を設定して下さい

これらのステップはシナリオ 2 の Cisco CME のための設定を要約します:

  1. > 電話『Configure』 を選択 して下さい。 それから変更したいと思う電話の MAC アドレスをクリックして下さい。 変更 Phone ウィンドウは現われます(図を 9)参照して下さい。

  2. ACD GDM はボタン 2.に残るが、エクステンション 2080 年から受付係の電話のボタン 3 を入力して下さい。 このセットアップによって、従業員は受付係および ACD GDM メールボックス両方のための MWI を得ます。

    図 9 受付係の電話に拡張 ボタンを追加して下さい

    /image/gif/paws/67907/135361.jpg

以下は特定の変更からの基礎設定への結果シナリオ 2 のための Cisco 完全な(注釈される) CME ルータの CLI 設定であり。

CME-2821#show running-config
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname CME-2821
!
boot-start-marker
boot system flash:
boot-end-marker
!
no aaa new-model
!
resource policy
!
ip subnet-zero
!
ip cef
no ip dhcp use vrf connected
ip dhcp excluded-address b.168.1.1 b.168.1.10
!
ip dhcp pool ITS
   network b.168.1.0 255.255.255.0
   option 150 ip a.1.11.1 
   default-router b.168.1.1 
!
no ip domain lookup
!
voice-card 0
 no dspfarm
!
voice service voip 
 allow-connections h323 to h323
 allow-connections h323 to sip
 supplementary-service h450.12 advertise-only
!
application
 service acd flash:app-b-acd-2.1.0.0.tcl
  param queue-cme-debugs 1
  param aa-hunt1 2020
  param aa-hunt2 2021
  param number-of-hunt-grps 3
  param aa-hunt3 2022
  param queue-len 30
 !
 service cme-aa flash:app-b-acd-aa-2.1.0.0.tcl
  param max-time-call-retry 60
  param voice-mail 2070
  paramspace english index 0
  param service-name acd
  param number-of-hunt-grps 3
  param handoff-string cme-aa
  paramspace english language en
  param max-time-vm-retry 1
  paramspace english location flash:
  param aa-pilot 2040
  param second-greeting-time 30
  paramspace english prefix en
  param call-retry-timer 20
!
interface Loopback0
 ip address a.1.11.1 255.255.255.252
!
interface GigabitEthernet0/0
 no ip address
 shutdown
 duplex auto
 speed auto
!
interface GigabitEthernet0/1
 no ip address
 shutdown
 duplex auto
 speed auto
!
interface FastEthernet0/1/0
 switchport access vlan 10
!
interface FastEthernet0/1/1
 switchport access vlan 10
!
interface FastEthernet0/1/2
 switchport access vlan 10
!
interface FastEthernet0/1/3
 switchport access vlan 10
!
interface FastEthernet0/1/4
 switchport access vlan 10
!
interface FastEthernet0/1/5
 switchport access vlan 10
!
interface FastEthernet0/1/6
 switchport access vlan 10
!
interface FastEthernet0/1/7
 switchport access vlan 10
!
interface FastEthernet0/1/8
 switchport access vlan 10
!
interface Service-Engine1/0
 ip unnumbered Loopback0
 service-module ip address a.1.11.2 255.255.255.252
 service-module ip default-gateway a.1.11.1
!
interface Vlan1
 no ip address
!
interface Vlan10
 ip address b.168.1.1 255.255.255.0
!
ip classless
ip route a.1.11.2 255.255.255.255 Service-Engine1/0
!
ip http server
ip http path flash:
!
tftp-server flash:P00305000600.bin
tftp-server flash:P00305000600.sbn
!
control-plane
!

!--- PSTN calls are auto-terminated on the Cisco CUE AA pilot number 2100.

!
voice-port 0/3/0
 connection plar opx 2100
!
voice-port 0/3/1
 connection plar opx 2100
!
voice-port 0/3/2
!
voice-port 0/3/3
!
dial-peer voice 2040 voip
 destination-pattern 2040
 session target ipv4:a.1.11.1
 dtmf-relay h245-alphanumeric
 codec g711ulaw
 no vad
!
dial-peer voice 2041 voip
 service cme-aa
 incoming called-number 2040
 dtmf-relay h245-alphanumeric
 codec g711ulaw
 no vad
!
dial-peer voice 2105 voip
 destination-pattern 21..
 session protocol sipv2
 session target ipv4:a.1.11.2
 dtmf-relay sip-notify
 codec g711ulaw
 no vad
!
telephony-service
 load 7960-7940 P00305000300
 max-ephones 48
 max-dn 192
 ip source-address a.1.11.1 port 2000
 max-redirect 20
 auto assign 1 to 10
 system message CISCO SYSTEMS
 create cnf-files version-stamp 7960 Aug 05 2005 00:00:32
 voicemail 2105
 max-conferences 8 gain -6
 moh music-on-hold.au
 dn-webedit 
 time-webedit 
 transfer-system full-consult
 transfer-pattern 210. blind
 transfer-pattern 2040 blind
!
ephone-dn  1  dual-line
 number 2001
 name User21
 call-forward busy 2105
 call-forward noan 2105 timeout 10
!
ephone-dn  2  dual-line
 number 2002
 name User22
 call-forward busy 2105
 call-forward noan 2105 timeout 10
!
ephone-dn  3  dual-line
 number 2003
 name User23
 call-forward busy 2105
 call-forward noan 2105 timeout 10
!
ephone-dn  4  dual-line
 number 2004
 name User24
 call-forward busy 2105
 call-forward noan 2105 timeout 10
!
ephone-dn  5  dual-line
 number 2005
 name User25
 call-forward busy 2105
 call-forward noan 2105 timeout 10
!
ephone-dn  6  dual-line
 number 2006
 name User26
 call-forward busy 2105
 call-forward noan 2105 timeout 10
!
ephone-dn  7  dual-line
 number 2007
 name User27
 call-forward busy 2105
 call-forward noan 2105 timeout 10
!
ephone-dn  8  dual-line
 number 2008
 name User28
 call-forward busy 2105
 call-forward noan 2105 timeout 10
!
ephone-dn  9  dual-line
 number 2009
 name User29
 call-forward busy 2105
 call-forward noan 2105 timeout 10
!

!--- Extension 2080 is associated with the receptionists' GDM. 
!--- This extension is used to get MWI on the receptionists' phones.

!
ephone-dn  10
 number 2080
 description Reception GDM
 name Reception GDM
 call-forward all 2105
!
ephone-dn  11
 number 2070
 description GDM
 name Cust Svc GDM
 call-forward all 2105
!
ephone-dn  100
 number 8000....
 mwi on
!
ephone-dn  101
 number 8001....
 mwi off
!

!--- Ephone-dn 10 (2080) is defined as button 3 on 
!--- phones 2001 and 2004 so that all
!--- receptionists (ephones 1 and 4) get MWI for the GDM.

!
ephone  1
 username "user21" password null
 mac-address 0012.0034.81B7
 type 7960
 button  1:1 2:11 3:10
!
ephone  2
 username "user22" password null
 mac-address 0011.2032.C876
 type 7960
 button  1:2 2:11
!
ephone  3
 username "user23" password null
 mac-address 0012.01E8.875F
 type 7960
 button  1:3 2:11
!
ephone  4
 username "user24"
 mac-address 0003.AAAA.0004
 type 7960
 button 1:4 2:11 3:10
!
ephone 5
 username "user25"
 mac-address 0003.AAAA.0005
 type 7960
 no auto-line
 button 1:5 2:11
!
ephone 6
 username "user26"
 mac-address 0003.AAAA.0006
 type 7960
 button 1:6 2:11
!
ephone 7
 username "user27"
 mac-address 0003.AAAA.0007
 type 7960
 button 1:7 2:11
!
ephone 8
 username "user28"
 mac-address 0003.AAAA.0008
 type 7960
 button 1:8 2:11
!
ephone  9
 username "user29"
 mac-address 0003.AAAA.0009
 type 7960
 button 1:9 2:11
!
ephone-hunt 1 longest-idle
 pilot 2020
 list 2001, 2002, 2003
 timeout 5
!
ephone-hunt 2 longest-idle
 pilot 2021
 list 2004, 2005, 2006
 timeout 5
!
ephone-hunt 3 longest-idle
 pilot 2022
 list 2007, 2008, 2009
 timeout 5
!
line con 0
 logging synchronous
line aux 0
line 66
 no activation-character
 no exec
 transport preferred none
 transport input all
 transport output all
line vty 0 4
 login
!
scheduler allocate 20000 1000
ntp master
!
end

シナリオ 2 のための Cisco Unity Express を設定して下さい

これらのステップはシナリオ 2 の Cisco Unity Express のための設定を要約します:

  1. Cisco Unity Express スクリプト エディタ ユーティリティを開き、カスタム Cisco Unity Express スクリプトを作成して下さい。 図 10 を参照してください。

    図 10 上層メニューのための Cisco Unity Express AA スクリプトを設定して下さい

    /image/gif/paws/67907/135362.jpg

  2. パイロット番号 2100 によってスクリプト(S10_CUE-AA-BACD-script.aef)を Voice Mail > Auto Attendant の順に選択 し、関連付けて下さい。 図 11 を参照してください。

    図 11 パイロット番号によってスクリプトを関連付けて下さい

    /image/gif/paws/67907/135363.jpg

  3. AA スクリプトのためのすべてのプロンプトを記録して下さい。 このオフ・ラインを記録し、正しいファイル名を用いる Cisco Unity Express に .wav ファイルをアップロードできますまたはテレフォニー(AVT)によって管理によってそれを記録できます。

  4. AVT を使用する場合(オプションの)、Cisco Unity Express は望ましいファイル名に続いて変更できる一般的 な ファイル名を割り当てます。 システム ファイル名を Voice Mail > Prompts の順に選択 し、クリックして下さい。

  5. (オプションの)ファイル名(s)をダイアログボックスで必要に応じて編集し、『OK』 をクリック して下さい。 音声メール > プロンプト ウィンドウはリストで今訂正されたファイル名(s)を表示します(図 12 参照して下さい)。

    図 12 AA スクリプト プロンプトのリスト

    /image/gif/paws/67907/135364.jpg

  6. ステップ 1.で構築される AA を『Script』 を選択 し、パラメータをスクリプトの正しいパラメータと関連付けます敏速なファイル名を Voice Mail > Auto Attendant の順に選択 し、開いて下さい。

  7. > Groups を『Configure』 を選択 し、そのグループ(受信)を編集したいと思いますクリックして下さい。 グループ プロファイル ウィンドウは現われます(図 13 のトップに部分的なウィンドウを参照して下さい)。 Profile タブはデフォルト ディスプレイです。

  8. メンバーを設定するために所有者/Members タブをクリックして下さい。

    図 13 受信グループを定義して下さい

    142217.jpg

以下は特定の変更からの基礎設定への結果シナリオ 2 のための完全な(注釈される) Cisco Unity Express CLI 設定であり。

cue#show running-config
Generating configuration:
clock timezone America/Los_Angeles
hostname cue
ip domain-name cisco.com
ntp server a.1.11.1

!--- Add the reception group.

!
groupname Administrators create
groupname Broadcasters create
groupname custservice create
groupname reception create
username admin create

username user21 create
username user22 create
username user23 create
username user24 create
username user25 create
username user26 create
username user27 create
username user28 create
username user29 create
!

!--- The reception group (and therefore GDM) is associated with extension 2080.

!
groupname custservice phonenumber "2070"
groupname reception phonenumber "2080"
username user21 phonenumber "2001"
username user22 phonenumber "2002"
username user23 phonenumber "2003"
username user24 phonenumber "2004"
username user25 phonenumber "2005"
username user26 phonenumber "2006"
username user27 phonenumber "2007"
username user28 phonenumber "2008"
username user29 phonenumber "2009"
!

!--- Add membership to group "reception".

!
groupname Administrators member admin
groupname custservice member user21
groupname custservice member user22
groupname custservice member user23
groupname custservice member user24
groupname custservice member user25
groupname custservice member user26
groupname custservice member user27
groupname custservice member user28
groupname custservice member user29
groupname reception member user21
groupname reception member user24
groupname Administrators privilege superuser
groupname Administrators privilege ManagePrompts
groupname Administrators privilege ManagePublicList
groupname Administrators privilege ViewPrivateList
groupname Broadcasters privilege broadcast

!--- Define a 09:00-17:00 Monday-Friday business schedule for the AA.

!
calendar biz-schedule systemschedule
 closed day 1 from 00:00 to 24:00
 open day 2 from 09:00 to 17:00
 open day 3 from 09:00 to 17:00
 open day 4 from 09:00 to 17:00
 open day 5 from 09:00 to 17:00
 open day 6 from 09:00 to 17:00
 closed day 7 from 00:00 to 24:00
end schedule
ccn application autoattendant
 description "autoattendant"
 enabled
 maxsessions 8
 script "aa.aef"
 parameter "busOpenPrompt" "AABusinessOpen.wav"
 parameter "holidayPrompt" "AAHolidayPrompt.wav"
 parameter "busClosedPrompt" "AABusinessClosed.wav"
 parameter "allowExternalTransfers" "true"
 parameter "MaxRetry" "3"
 parameter "operExtn" "2001"
 parameter "welcomePrompt" "AAWelcome.wav"
 parameter "businessSchedule" "systemschedule"
 end application
ccn application ciscomwiapplication
 description "ciscomwiapplication"
 enabled
 maxsessions 8
 script "setmwi.aef"
 parameter "strMWI_OFF_DN" "8001"
 parameter "strMWI_ON_DN" "8000"
 parameter "CallControlGroupID" "0"
 end application
ccn application promptmgmt
 description "promptmgmt"
 enabled
 maxsessions 1
 script "promptmgmt.aef"
 end application
!

!--- Add the custom AA script for the first-tier menu.

!
ccn application s10-cue-aa-bacd
 description "s10-cue-aa-bacd"
 enabled
 maxsessions 8
 script "s10-cue-aa-bacd-script.aef"
 parameter "S10_StoreHours" "S10_StoreHours.wav"
 parameter "S10_CustomerService" "2040"
 parameter "S10_GDM" "2080"
 parameter "S10_StoreLocation" "S10_StoreLocation.wav"
 end application
ccn application voicemail
 description "voicemail"
 enabled
 maxsessions 8
 script "voicebrowser.aef"
 parameter "logoutUri" "http://localhost/voicemail/vxmlscripts/mbxLogout.jsp"
 parameter "uri" "http://localhost/voicemail/vxmlscripts/login.vxml"
 end application
ccn engine
 end engine
ccn subsystem jtapi
 ccm-manager address 0.0.0.0 
 end subsystem
ccn subsystem sip
 gateway address "a.1.11.1"
 end subsystem
!

!--- Associate the custom AA script with the pilot number 2100.

!
ccn trigger sip phonenumber 2100
 application "s10-cue-aa-bacd"
 enabled
 maxsessions 8
 end trigger
ccn trigger sip phonenumber 2102
 application "autoattendant"
 enabled
 maxsessions 8
 end trigger
ccn trigger sip phonenumber 2105
 application "voicemail"
 enabled
 maxsessions 8
 end trigger
ccn trigger sip phonenumber 2106
 application "promptmgmt"
 enabled
 maxsessions 1
 end trigger
voicemail default language en_US
voicemail default mailboxsize 3000
voicemail broadcast recording time 300
voicemail operator telephone 2001
!

!--- Add the GDM for "reception"

!
voicemail mailbox owner "reception" size 3000
 description "Receptionists mailbox"
 end mailbox
voicemail mailbox owner "custservice" size 3000
 description "custservice mailbox"
 end mailbox
voicemail mailbox owner "user21" size 3000
 end mailbox
voicemail mailbox owner "user22" size 3000
 end mailbox
voicemail mailbox owner "user23" size 3000
 end mailbox
voicemail mailbox owner "user24" size 3000
description "user24 mailbox"
end mailbox
voicemail mailbox owner "user25" size 3000
description "user25 mailbox"
end mailbox
voicemail mailbox owner "user26" size 3000
description "user26 mailbox"
end mailbox
voicemail mailbox owner "user27" size 3000
description "user27 mailbox"
end mailbox
voicemail mailbox owner "user28" size 3000
description "user28 mailbox"
end mailbox
voicemail mailbox owner "user29" size 3000
description "user29 mailbox"
end mailbox
end

シナリオ 2 設定 変化 1 -ハント グループ 1人あたりのユーザー GDMs

前のセクションに説明がある主要な シナリオのための設定は 3 つの ACD グループ(ハードウェアサポート、ソフトウェアサポートおよび一般的な質問)に発信者が残すすべてのメッセージのための単一 GDM を定義します。 この細かさは 1 グループのためのエージェントが(ソフトウェアサポートのような)ソフトウェアサポートに関するメッセージを見つける前にハードウェアおよび一般支援団体のために残されるメッセージを通って渡りたいと思わないかもしれませんのでいくつかの状況のために十分ではないかもしれません。 メッセージの音量が高い場合、各 ACD グループのための別途のメールボックスがあることができます。

Cisco 正常な CME hunt-group で(時ない ACD を使用して)、hunt-group で GDMs が番号を付けるユーザーの関連付けによって各ハント グループのための別途のメールボックスを定義できま(2020、2021、2022)および hunt-group の「最終的な」宛先を音声メールを指します--次の設定例に示すように。

シナリオ 2 変化 1 のための Cisco CME を設定して下さい

以下はユーザー GDMs のための Cisco CME 設定バリエーションです:

ephone-hunt 1 sequential
 pilot 2020
 list 2001, 2002, 2003
 final 2105
 timeout 10
!
!
ephone-hunt 2 sequential
 pilot 2021
 list 2004, 2005, 2006
 final 2105
 timeout 10
!
!
ephone-hunt 3 sequential
 pilot 2022
 list 2007, 2008, 2009
 final 2105
 timeout 10

シナリオ 2 変化 1 のための Cisco Unity Express を設定して下さい

これらのステップはシナリオ 2 変化 1 のための Cisco Unity Express のグループおよび GDMs の設定を要約します:

  1. 個々の グループは 3 人の hunt-group のそれぞれのための Cisco Unity Express で定義されます。 グループを定義するために > Groups を『Configure』 を選択 して下さい。 図 14 を参照してください。

    図 14 個々の グループを定義して下さい

    135357.jpg

  2. から > Groups を、クリックしますグループ(ハードウェア)を編集したいと思う設定して下さい。 Default Profile タブ ウィンドウは現われます(図 15 の上を参照して下さい)。

    図 15 特定のグループを設定して下さい

    /image/gif/paws/67907/135358.jpg

  3. 所有者/Members タブを(図 15 の下部のを参照して下さい)選択し、左で所有者およびメンバーを選択するためにチェックボックスをクリックして下さい。

    以下はユーザー GDMs のための Cisco Unity Express 設定バリエーションです:

    groupname hardware create
    groupname software create
    groupname general create
    groupname hardware phonenumber "2020"
    groupname software phonenumber "2021"
    groupname general phonenumber "2022"
    groupname hardware member user21
    groupname hardware member user22
    groupname hardware member user23
    groupname software member user24
    groupname software member user25
    groupname software member user26
    groupname general member user27
    groupname general member user28
    groupname general member user29
    voicemail mailbox owner "general" size 5520
     description "general mailbox"
     end mailbox
    voicemail mailbox owner "hardware" size 5520
     description "Hardware mailbox"
     end mailbox
    voicemail mailbox owner "software" size 5520
     description "software mailbox"
     end mailbox

シナリオ 2 設定 変化 2 - ACD グループごとのユーザー GDMs

「ハント グループ 1人あたりのシナリオ 2 設定 変化 1 ユーザー GDMs」セクションで要約される 2 つの欠点が設定へあります。

  • それは hunt-group が ACD としてとき ACD パイロット番号使用されるとき hunt-group が直接問い合わせられるときだけはたらきます(拡張 2020 は、2021 2022)、はたらかないし(2040)呼出されます

  • それは hunt-group 数がボタンとして電話に置くことができないのでエージェントに MWI を提供することの手段(方法)を提供しません。

設定を提供するためにこれら二つの欠点を解決する、Cisco Unity Express で xfermailbox システムスクリプトを使用できます。 Cisco Unity Express (ハードウェア、ソフトウェアおよび概要のための 1 それぞれ)の 3 グループを定義し、暫時拡張と各グループを関連付けて下さい(エージェント電話に現われるボタンとして置くことができる 2030、2031、および 2032) (およびその結果 MWI を提供するため)。 グループ、拡張および電話のこの設定は表 2.で要約されます。

エージェント 拡張子 Hunt-Group 数 ACD グループ グループ メールボックス
user21 2001 2020 ハードウェア 2030
user22 2002 2020 ハードウェア 2030
user23 2003 2020 ハードウェア 2030
user24 2004 H33 ソフトウェア 2031
user25 2005 H33 ソフトウェア 2031
user26 2006 H33 ソフトウェア 2031
user27 2007 2022 一般 2032
user28 2008 2022 一般 2032
user29 2009 2022 一般 2032

この修正されたセットアップ用の調節されたコールフローは図 16 説明されます。

図 16 xfermailbox スクリプト変化のための調節されたコールフロー

/image/gif/paws/67907/135359.jpg

Cisco Unity Express のユーザー GDMs にダイレクト コールを xfermailbox システムスクリプトを呼出すカスタムスクリプトを必要とします。 Cisco CME ACD へのコールは Cisco Unity Express に単一パラメータ音声メール number コマンドの使用によってしか転送することができません(hunt-group の個々の最終 宛先は ACD コールフローに使用することができません)。 このコマンドはメールボックス(前述の設定の拡張 2070 年)にエントリのための Cisco Unity Express に単一 拡張を提供したものです。 Cisco Unity Express に意図された受信側はどの hunt-group であるないし、入るべきか 3 GDMs のどれを判別できませんか区別する方法が。

その代り、カスタムスクリプト(s12-xfer-to-mbox.aef)を入力する Cisco Unity Express パイロット番号に Cisco CME ACD 音声メール宛先を指示して下さい(2110)。 このパイロット番号はメッセージが残すことができるグループの選択を提供しているユーザにメニューを提供します(ハードウェア、ソフトウェア、または概要)。 このメニューのコンテンツはコールフローの下部ので図 16 示されています。 発信者の応答に基づいて、mbox 変数は適切な拡張に設定 されます(2030、2031、または 2032)、およびコールは 3 GDMs の 1 に(xfermailbox システムスクリプトによって)渡されます。

表 2 で説明されているコンフィギュレーション変更を処理するためにシナリオ 2 設定の修正と関連付けられるステップは次のステップに図 16 説明があり、:

  1. Cisco Unity Express スクリプト エディタ ユーティリティを開き、s12-xfer-to-mbox.aef と呼ばれるカスタム Cisco Unity Express スクリプトを書いて下さい。 図 17 を参照してください。

    図 17 カスタム Cisco Unity Express スクリプト作成ウィンドウ

    /image/gif/paws/67907/135347.jpg

  2. Voice Mail > Auto Attendant の順に選択 して下さい。 図 18 を参照してください。 新しいオートアテンダントを追加し、ステップ 1.で構築されるスクリプトと関連付けて下さい。

  3. パイロット番号によってカスタム s12-xfer-to-mbox.aef Cisco Unity Express スクリプトを 2110 関連付けて下さい。 図 18 を参照してください。

    図 18 パイロット番号によってカスタム Cisco Unity Express スクリプトを関連付けて下さい

    /image/gif/paws/67907/135348.jpg

  4. 新しい AA スクリプトのためのプロンプトを(この場合 S12_Main_Menu.wav と指名される)記録して下さい。 このオフ・ラインを記録し、正しいファイル名を用いる Cisco Unity Express に .wav ファイルをアップロードできますまたはテレフォニー(AVT)によって管理によってそれを記録できます。

  5. AVT を使用する場合(オプションの)、Cisco Unity Express は望ましいファイル名に続いて変更できる一般的 な ファイル名を割り当てます。 システム ファイル名を Voice Mail > Prompts の順に選択 し、クリックして下さい。

  6. (オプションの)ダイアログボックスのファイル名を必要として編集し、『OK』 をクリック して下さい。 音声メール > プロンプト ウィンドウはリストで今訂正されたファイル名を表示します(図 19 参照して下さい)。

  7. ステップ 2.の間に構築される AA を『Script』 を選択 し、パラメータをスクリプトの正しいパラメータと関連付けます敏速なファイル名を Voice Mail > Auto Attendant の順に選択 し、開いて下さい。

    図 19 記録されたプロンプトのリスト

    135349.jpg

  8. > これらの拡張のそれぞれと GDMs を関連付けるために拡張 2030、2031、および 2032 を定義する拡張 『Configure』 を選択 して下さい。 図 20 を参照してください。

    図 20 ACD Hunt-Group と GDMs を関連付けるために拡張を定義して下さい

    /image/gif/paws/67907/135350.jpg

  9. > 電話『Configure』 を選択 し、変更したいと思う電話の MAC アドレスをクリックして下さい。 変更 Phone ウィンドウは現われます(図 21 参照して下さい)。

  10. MWI を提供する ACD エージェント電話の 2030、2031、か 2032 のための Add ボタン。

    図 21 説明するウィンドウ ボタンを追加します

    /image/gif/paws/67907/135351.jpg

以下は「シナリオ 2"のための Cisco CME の設定と関連付けられる基礎シナリオ 設定への Cisco CME 設定の変更および付加のための注釈された Cisco CME ルータ CLI 設定 セクションです。


!--- Set the Cisco CME AA voice mail destination 
!--- to 2110, the Cisco Unity Express
!--- script entrypoint for the transfer-to-mailbox functionality.

!
 service cme-aa flash:app-b-acd-aa-2.1.0.0.tcl
  param max-time-call-retry 60
  param voice-mail 2110
  paramspace english index 0
  param service-name acd
  param number-of-hunt-grps 3
  param handoff-string cme-aa
  paramspace english language en
  param max-time-vm-retry 1
  paramspace english location flash:
  param aa-pilot 2040
  param second-greeting-time 30
  paramspace english prefix en
  param call-retry-timer 20
!

!--- Define the group extensions (2030, 2031 and 2032) to 
!--- be used as button appearances
!--- on the agent phones so they can get MWI for the GDMs. 
!--- Put these extension in CFA
!--- so they never ring and do not disturb the agents.

!
ephone-dn  12
 number 2030
 description HW Cust Svc Mbox
 name HW Cust Svc Mbox
 call-forward all 2110
!
ephone-dn  13
 number 2031
 description SW Cust Svc Mbox
 name SW Cust Svc Mbox
 call-forward all 2110
!
ephone-dn  14
 number 2032
 description Gen Cust Svc Mbox
 name Gen Cust Svc Mbox
 call-forward all 2110
!

!--- Add a button appearance of the appropriate 
!--- group extension to each of the
!--- ACD Agent phones.

!
ephone  1
 username "user21" password null
 mac-address 0012.0034.81B7
 type 7960
 button  1:1 2:12 3:10
!
ephone  2
 username "user22" password null
 mac-address 0011.2032.C876
 type 7960
 button  1:2 2:12
!
ephone  3
 username "user23" password null
 mac-address 0012.01E8.875F
 type 7960
 button  1:3 2:12
!
ephone  4
 username "user24"
 mac-address 0003.AAAA.0004
 type 7960
 button 1:4 2:13 3:10
!
ephone 5
 username "user25"
 mac-address 0003.AAAA.0005
 type 7960
 no auto-line
 button 1:5 2:13
!
ephone 6
 username "user26"
 mac-address 0003.AAAA.0006
 type 7960
 button 1:6 2:13
!
ephone 7
 username "user27"
 mac-address 0003.AAAA.0007
 type 7960
 button 1:7 2:14
!
ephone 8
 username "user28"
 mac-address 0003.AAAA.0008
 type 7960
 button 1:8 2:14
!
ephone  9
 username "user29"
 mac-address 0003.AAAA.0009
 type 7960
 button 1:9 2:14

以下は「シナリオ 2"のための Cisco Unity Express の設定と関連付けられる基礎シナリオ 設定への設定の変更および付加のための注釈された Cisco Unity Express CLI 設定 セクションおよび先行する GUI 変更です:


!--- Define the three new groups, Hardware, Software and General.

!
groupname hardware create
groupname software create
groupname general create
!

!--- Define the new groups (and therefore GDMs) are associated with 
!--- extensions 2030, 2031 and 2032.

!
groupname hardware phonenumber "2030"
groupname software phonenumber "2031"
groupname general phonenumber "2032"
!

!--- Define the membership of  the Hardware, Software and General groups.

!
groupname hardware member user21
groupname hardware member user22
groupname hardware member user23
groupname software member user24
groupname software member user25
groupname software member user26
groupname general member user27
groupname general member user28
groupname general member user29
!

!--- Define the custom AA script that will branch 
!--- to the xfermailbox.aef system script
!--- when the caller selects the correct GDM from the menu.

!
ccn application s12-xfer-to-mbox
 description "s12-xfer-to-mbox"
 enabled
 maxsessions 8
 script "s12_cue-aa-bacd-script.aef"
 end application
!

!--- Define the pilot number 2110 to the custom script.

!
ccn trigger sip phonenumber 2110
 application "s12-xfer-to-mbox"
 enabled
 maxsessions 8
 end trigger
!

!--- Define the GDMs for each of the groups.

!
voicemail mailbox owner "hardware" size 3000
 description "hardware mailbox"
 end mailbox
voicemail mailbox owner "software" size 3000
 description "software mailbox"
 end mailbox
voicemail mailbox owner "general" size 3000
 description "general mailbox"
 end mailbox

シナリオ 2 設定 変化 3 - CD 機能性によってドロップするを使用して下さい

Cisco CME ACD の機能を通したドロップするが Cisco CME AA メニューをバイパスし、ACD にコールを直接転送するのに使用することができます。 この機能を使うと、全体の AA メニューは Cisco Unity Express AA スクリプトで強化することができます。 この機能を使用しながらが Cisco CME ルータの追加設定を必要とする、Cisco Unity Express AA (層 1 メニュー)間のメニューおよび発表 記録物の分割と比較される AA スクリプト(メニュー)および Cisco CME AA (層 2 メニュー)のメンテナンスを簡素化します。

シナリオ 2 変化 3 設定では、AA メニューの層は両方とも Cisco Unity Express AA スクリプトで次の通り含まれています:

  • ウィジェット システムを呼出すためにありがとう

    • 弊社販売代理店のために『1』 を押して下さい

      • ハードウェア関連質問のために『1』 を押して下さい

      • ソフトウェア関連質問のために『2』 を押して下さい

      • 一般的な質問のために『3』 を押して下さい

    • オフィスの場所のために『2』 を押して下さい

    • 営業時間の間『3』 を押して下さい

    • 音声 メッセージを残すために『4』 を押して下さい

層 2 メニュー選択は Cisco Unity Express にこれらのグループのそれぞれのための Cisco 個々の CME ACD パイロット番号に渡されるコールという結果に終ります:

  • ハードウェア— Cisco CME ACD パイロット番号 2040

  • ソフトウェア— Cisco CME ACD パイロット番号 2041

  • 概要— Cisco CME ACD パイロット番号 2042

以前にこの資料で表記されたコンフィギュレーションは単一 ACD パイロット番号を定義しました(2040)。 この設定 変化では、Cisco 3 つの異なる CME ACD パイロット番号は定義されます(2040、2041、および 2042)。 この変化は機能性によってドロップするをどのように有効に することができるか説明します。 機能を通したドロップするを使用する Cisco CME AA メニューをバイパスし、続く特定のオプションを規定 します(対応した CLI コマンドで規定 されて)。 システムは発信者が CLI で静的に 規定 された オプションを押したように機能します。 このシナリオでは、Cisco CME AA 設定は次の適応が含まれています:

  • ACD パイロット番号 2040 のための設定はパラメーター ドロップするによオプション 1 コマンドが含まれています

  • ACD パイロット番号 2041 のための設定はパラメーター ドロップするによオプション 2 コマンドが含まれています

  • ACD パイロット番号 2042 のための設定はパラメーター ドロップするによオプション 3 コマンドが含まれています

シナリオ 2 変化 3 のための Cisco CME を設定して下さい

これらのステップはシナリオ 2 変化 3 の Cisco CME のための設定を要約します:

  1. 」CLI ドロップするによって「を使用して追加 Cisco CME AA およびパイロット番号 2040、2041 および 2042 のための ACD TCL 設定を、追加して下さい。

  2. 新しいパイロット番号 2040、204,1 および 2042 にダイヤルすることを有効に するためにダイヤル ピアを追加して下さい。

    以下は「シナリオ 2"のための Cisco CME の設定と関連付けられる基礎シナリオの Cisco CME 設定への変更および付加のための注釈された Cisco CME ルータ CLI 設定 セクションです。

    application
     service acd flash:app-b-acd-2.1.0.0.tcl
      param queue-cme-debugs 1
      param aa-hunt1 2020
      param aa-hunt2 2021
      param number-of-hunt-grps 3
      param aa-hunt3 2022
      param queue-len 30
    !
    
    !--- Define the TCL configuration for the Hardware group, using pilot number 2040 
    !--- and "drop-through-option 1". Extension 2030 is associated with the GDM for
    !--- the Hardware group, so this is the voice mail destination.
    
    !
     service hardware-aa flash:app-b-acd-aa-2.1.0.0.tcl
      param max-time-vm-retry 1
      paramspace english index 0
      param max-time-call-retry 60
      param voice-mail 2030
      param aa-pilot 2040
      param number-of-hunt-grps 1
      paramspace english language en
      param handoff-string hardware-aa
      param call-retry-timer 20
      paramspace english location flash:
      param service-name acd
      param drop-through-option 1
      param second-greeting-time 30
      paramspace english prefix en
    !
    
    !--- Define the TCL configuration for the Software group, 
    !--- using pilot number 2041 
    !--- and "drop-through-option 2". Extension 2031 is associated with the GDM for
    !--- the Software group, so this is the voice mail destination.
    
    !
     service software-aa flash:app-b-acd-aa-2.1.0.0.tcl
      param number-of-hunt-grps 1
      paramspace english index 0
      param handoff-string software-aa
      paramspace english language en
      param call-retry-timer 20
      param service-name acd
      paramspace english location flash:
      param drop-through-option 2
      param second-greeting-time 30
      param max-time-vm-retry 1
      param voice-mail 2031
      paramspace english prefix en
      param max-time-call-retry 60
      param aa-pilot 2041
    !
    
    !--- Define the TCL configuration for the General group, using pilot number 2042 
    !--- and "drop-through-option 3". Extension 2032 is associated with the GDM for
    !--- the General group, so this is the voice mail destination.
    
    !
     service general-aa flash:app-b-acd-aa-2.1.0.0.tcl
      param call-retry-timer 20
      paramspace english index 0
      param max-time-call-retry 60
      param voice-mail 2032
      param service-name acd
      param number-of-hunt-grps 1
      param drop-through-option 3
      paramspace english language en
      param handoff-string general-aa
      param max-time-vm-retry 1
      paramspace english location flash:
      param aa-pilot 2042
      param second-greeting-time 30
      paramspace english prefix en
    !
    
    !--- Define the dial-peers for pilot number 2040 and attach the Hardware
    !--- TCL script to this number.
    
    !
    dial-peer voice 2040 voip
     destination-pattern 2040
     session target ipv4:a.1.11.1
     dtmf-relay h245-alphanumeric
     codec g711ulaw
     no vad
    !
    dial-peer voice 20400 voip
     service hardware-aa
     incoming called-number 2040
     dtmf-relay h245-alphanumeric
     codec g711ulaw
     no vad
    !
    
    !--- Define the dial-peers for pilot number 2041 and attach the Software
    !--- TCL script to this number.
    
    !
    dial-peer voice 2041 voip
     destination-pattern 2041
     session target ipv4:a.1.11.1
     dtmf-relay h245-alphanumeric
     codec g711ulaw
     no vad
    !
    dial-peer voice 20410 voip
     service software-aa
     incoming called-number 2041
     dtmf-relay h245-alphanumeric
     codec g711ulaw
     no vad
    ?
    
    !--- Define the dial-peers for pilot number 2042 and attach the General
    !--- TCL script to this number.
    
    !
    dial-peer voice 2042 voip
     destination-pattern 2042
     session target ipv4:a.1.11.1
     dtmf-relay h245-alphanumeric
     codec g711ulaw
     no vad
    !
    dial-peer voice 20420 voip
     service general-aa
     incoming called-number 2042
     dtmf-relay h245-alphanumeric
     codec g711ulaw
     no vad

シナリオ 2 変化 3 のための Cisco Unity Express を設定して下さい

これらのステップはシナリオ 2 変化 3 の Cisco Unity Express のための設定を要約します:

  1. Cisco Unity Express スクリプト エディタ ユーティリティを開き、AA メニューの両方の層が含まれているためにスクリプト s10-cue-aa-bacd.aef を調節して下さい。 図 22 参照して下さい。

    図 22 両方のメニュー層のための Cisco Unity Express AA スクリプトを設定して下さい

    /image/gif/paws/67907/142220.jpg

  2. パイロット番号 2100 によって新しいスクリプト(S10A_CUE-AA-BACD-script.aef)を Voice Mail > Auto Attendant の順に選択 し、関連付けて下さい。 図 23 を参照してください。

    図 23 パイロット番号によってスクリプトを関連付けて下さい

    /image/gif/paws/67907/142221.jpg

  3. AA スクリプトに必要なすべてのプロンプトを記録して下さい。 これらのオフ・ラインを記録し、正しいファイル名を用いる Cisco Unity Express に .wav ファイルをアップロードできますまたはテレフォニー(AVT)によって管理によってそれを記録できます。

  4. AVT を使用する場合(オプションの)、Cisco Unity Express は望ましいファイル名に続いて変更できる一般的 な ファイル名を割り当てます。 システム ファイル名を Voice Mail > Prompts の順に選択 し、クリックして下さい。

  5. (オプションの)ダイアログボックスのファイル名(s)を必要として編集し、『OK』 をクリック して下さい。 音声メール > プロンプト ウィンドウはリストで今訂正されたファイル名を表示します。

以下はシナリオ 2 セクションのための Cisco Unity Express の設定と関連付けられる基礎シナリオ 設定の Cisco Unity Express 設定への変更および付加のための注釈された Cisco Unity Express CLI 設定です。


!--- Define a new AA with script s10a-cue-aa-bacd.aef.

!
ccn application s10a-cue-aa-bacd
 description "s10a-cue-aa-bacd"
 enabled
 maxsessions 8
 script "s10a_cue-aa-bacd-script.aef"
 parameter "S10_Hardware" "2040"
 parameter "S10_StoreHours" "S10_StoreHours.wav"
 parameter "S10_Software" "2041"
 parameter "S10_General" "2042"
 parameter "S10_GDM" "2080"
 parameter "S10_StoreLocation" "S10_StoreLocation.wav"
 end application
!

!--- Associate AA pilot number 2100 with the new script.

!
ccn trigger sip phonenumber 2100
 application "s10a-cue-aa-bacd"
 enabled
 maxsessions 8
 end trigger

シナリオ 3 -最初の層メニューとして基本 ACD および第 2 層メニューとして Cisco Unity Express AA を使用して下さい

この資料で示される第 3 シナリオでは着信コールは Cisco CME AA (パイロット番号 2040)丁度次 シナリオ1 に送信されます。 唯一の違いはメインメニューからの第 3 オプションは店の住所および営業時間を記述する発表にアクセスすることであるがたった 2 つの ACD グループ(ハードウェア および ソフトウェア)があることです。

Cisco CME AA との自由形式の発表を含むことはできません。 Cisco Unity Express カスタムスクリプトが代りに必要となります。

シナリオ 2.の変化のこの同じ結果を(発信者の観点から)実現できます。 シナリオ 3 例は渡すことによって Cisco Unity Express AA に処理する Cisco CME ACD からのコールを離れてアプリケーションを構成する別の方法を説明するために与えられます。 シナリオ 2 の変化を使用するこのアプリケーションを構築するより典型的な方法はおそらくあります。

シナリオ 3 コールフロー

このセクションの設定のコールフローは図 24 説明されます。

図 24 シナリオ 3 コールフロー

135510.jpg

シナリオ 3 つの設定に関する注記

FXO ポート(0/3/0)から PSTN 呼び出しは Cisco CME AA に自動終了します(2040)。

Cisco CME ACD にエージェントの 2 グループだけあります(2020 および 2021)。 メニューの Option 3 がコールに発表のための Cisco Unity Express AA を手渡すのに使用されています。 hunt-group 数をリストするかわりに発信者が 3 つをシステム 『Option』 を選択 するとき、Cisco Unity Express AA パイロット番号に発信者を指示します(パラメーター aa-hunt3 2100 コマンドの使用に 2100)起因する。

シナリオ 3 のための Cisco CME を設定して下さい

Cisco CME ルータのための CLI 設定は次の例で示されています:

CME-2821#show running-config
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname CME-2821
!
boot-start-marker
boot system flash:
boot-end-marker
!
no aaa new-model
!
resource policy
!
ip subnet-zero
!
ip cef
no ip dhcp use vrf connected
ip dhcp excluded-address b.168.1.1 b.168.1.10
!
ip dhcp pool ITS
   network b.168.1.0 255.255.255.0
   option 150 ip a.1.11.1 
   default-router b.168.1.1 
!
no ip domain lookup
!
voice-card 0
 no dspfarm
!
voice service voip 
 allow-connections h323 to h323
 allow-connections h323 to sip
 supplementary-service h450.12 advertise-only
!

!--- Point option 3 of the menu (aa-hunt3) to the 
!--- Cisco Unity Express AA (2100).

!
application
 service acd flash:app-b-acd-2.1.0.0.tcl
  param queue-cme-debugs 1
  param aa-hunt1 2020
  param aa-hunt2 2021
  param number-of-hunt-grps 3
  param aa-hunt3 2100
  param queue-len 30
 !
 service cme-aa flash:app-b-acd-aa-2.1.0.0.tcl
  param max-time-call-retry 60
  param voice-mail 2070
  paramspace english index 0
  param service-name acd
  param number-of-hunt-grps 3
  param handoff-string cme-aa
  paramspace english language en
  param max-time-vm-retry 1
  paramspace english location flash:
  param aa-pilot 2040
  param second-greeting-time 30
  paramspace english prefix en
  param call-retry-timer 20
!
interface Loopback0
 ip address a.1.11.1 255.255.255.252
!
interface GigabitEthernet0/0
 no ip address
 shutdown
 duplex auto
 speed auto
!
interface GigabitEthernet0/1
 no ip address
 shutdown
 duplex auto
 speed auto
!
interface FastEthernet0/1/0
 switchport access vlan 10
!
interface FastEthernet0/1/1
 switchport access vlan 10
!
interface FastEthernet0/1/2
 switchport access vlan 10
!
interface FastEthernet0/1/3
 switchport access vlan 10
!
interface FastEthernet0/1/4
 switchport access vlan 10
!
interface FastEthernet0/1/5
 switchport access vlan 10
!
interface FastEthernet0/1/6
 switchport access vlan 10
!
interface FastEthernet0/1/7
 switchport access vlan 10
!
interface FastEthernet0/1/8
 switchport access vlan 10
!
interface Service-Engine1/0
 ip unnumbered Loopback0
 service-module ip address a.1.11.2 255.255.255.252
 service-module ip default-gateway a.1.11.1
!
interface Vlan1
 no ip address
!
interface Vlan10
 ip address b.168.1.1 255.255.255.0
!
ip classless
ip route a.1.11.2 255.255.255.255 Service-Engine1/0
!
ip http server
ip http path flash:
!
tftp-server flash:P00305000600.bin
tftp-server flash:P00305000600.sbn
!
control-plane
!
voice-port 0/3/0
 connection plar opx 2040
!
voice-port 0/3/1
 connection plar opx 2040
!
voice-port 0/3/2
!
voice-port 0/3/3
!
dial-peer voice 2040 voip
 destination-pattern 2040
 session target ipv4:a.1.11.1
 dtmf-relay h245-alphanumeric
 codec g711ulaw
 no vad
!
dial-peer voice 2041 voip
 service cme-aa
 incoming called-number 2040
 dtmf-relay h245-alphanumeric
 codec g711ulaw
 no vad
!
dial-peer voice 2105 voip
 destination-pattern 21..
 session protocol sipv2
 session target ipv4:a.1.11.2
 dtmf-relay sip-notify
 codec g711ulaw
 no vad
!
telephony-service
 load 7960-7940 P00305000300
 max-ephones 48
 max-dn 192
 ip source-address a.1.11.1 port 2000
 max-redirect 20
 auto assign 1 to 10
 system message CISCO SYSTEMS
 create cnf-files version-stamp 7960 Aug 05 2005 00:00:32
 voicemail 2105
 max-conferences 8 gain -6
 moh music-on-hold.au
 dn-webedit 
 time-webedit 
 transfer-system full-consult
 transfer-pattern 210. blind
 transfer-pattern 2040 blind
!
ephone-dn  1  dual-line
 number 2001
 name User21
 call-forward busy 2105
 call-forward noan 2105 timeout 10
!
ephone-dn  2  dual-line
 number 2002
 name User22
 call-forward busy 2105
 call-forward noan 2105 timeout 10
!
ephone-dn  3  dual-line
 number 2003
 name User23
 call-forward busy 2105
 call-forward noan 2105 timeout 10
!
ephone-dn  4  dual-line
 number 2004
 name User24
 call-forward busy 2105
 call-forward noan 2105 timeout 10
!
ephone-dn  5  dual-line
 number 2005
 name User25
 call-forward busy 2105
 call-forward noan 2105 timeout 10
!
ephone-dn  6  dual-line
 number 2006
 name User26
 call-forward busy 2105
 call-forward noan 2105 timeout 10
!
ephone-dn  11
 number 2070
 description GDM
 name Cust Svc GDM
 call-forward all 2105
!
ephone-dn  100
 number 8000....
 mwi on
!
ephone-dn  101
 number 8001....
 mwi off
!
ephone  1
 username "user21" password null
 mac-address 0012.0034.81B7
 type 7960
 button  1:1 2:11
!
ephone  2
 username "user22" password null
 mac-address 0011.2032.C876
 type 7960
 button  1:2 2:11
!
ephone  3
 username "user23" password null
 mac-address 0012.01E8.875F
 type 7960
 button  1:3 2:11
!
ephone  4
 username "user24"
 mac-address 0003.AAAA.0004
 type 7960
 button 1:4 2:11
!
ephone 5
 username "user25"
 mac-address 0003.AAAA.0005
 type 7960
 no auto-line
 button 1:5 2:11
!
ephone 6
 username "user26"
 mac-address 0003.AAAA.0006
 type 7960
 button 1:6 2:11
!
ephone-hunt 1 longest-idle
 pilot 2020
 list 2001, 2002, 2003
 timeout 5
!
ephone-hunt 2 longest-idle
 pilot 2021
 list 2004, 2005, 2006
 timeout 5
!
line con 0
 logging synchronous
line aux 0
line 66
 no activation-character
 no exec
 transport preferred none
 transport input all
 transport output all
line vty 0 4
 login
!
scheduler allocate 20000 1000
ntp master
!
end

シナリオ 3 のための Cisco Unity Express を設定して下さい

これらのステップはシナリオ 3 の Cisco Unity Express のための設定を要約します:

  1. Cisco Unity Express スクリプト エディタ ユーティリティを開き、カスタム Cisco Unity Express スクリプトを書いて下さい。 図 25 を参照してください。

    図 25 営業時間および Location スクリプト

    /image/gif/paws/67907/135367.jpg

  2. AA スクリプト(S11_CUE-AA-BACD-script.aef)のためのプロンプトを(この場合 S11_Announcement.wav と指名される)記録して下さい。 このオフ・ラインを記録し、正しいファイル名を用いる Cisco Unity Express に .wav ファイルをアップロードできますまたはテレフォニー(AVT)によって管理によってそれを記録できます。

  3. AVT を使用する場合(オプションの)、Cisco Unity Express は望ましいファイル名に続いて変更できる一般的 な ファイル名を割り当てます。 システム ファイル名を Voice Mail > Prompts の順に選択 し、クリックして下さい。

  4. (オプションの)ダイアログボックスのファイル名を編集し、『OK』 をクリック して下さい。 音声メール > プロンプト ウィンドウはリストで今訂正されたファイル名を表示します(図 26 参照して下さい)。

  5. ステップ 2.の間に構築される AA を『Script』 を選択 し、パラメータをスクリプトの正しいパラメータと関連付けます敏速なファイル名を Voice Mail > Auto Attendant の順に選択 し、開いて下さい。

    図 26 ウィンドウ表示敏速なオプション

    135368.jpg

  6. AA パイロット番号 2100 によってスクリプトを Voice Mail > Auto Attendant の順に選択 し、関連付けて下さい。 図 27 を参照してください。

    図 27 AA パイロット番号へのスクリプトのウィンドウ表示アソシエーション

    /image/gif/paws/67907/135369.jpg

Cisco Unity Express システムのための CLI 設定は次の例で示されています:

cue# 
show running-config
Generating configuration:
clock timezone America/Los_Angeles
hostname cue
ip domain-name cisco.com
ntp server a.1.11.1
groupname Administrators create
groupname Broadcasters create
groupname custservice create
username admin create
username user21 create
username user22 create
username user23 create
username user24 create
username user25 create
username user26 create
groupname custservice phonenumber "2070"
username user21 phonenumber "2001"
username user22 phonenumber "2002"
username user23 phonenumber "2003"
username user24 phonenumber "2004"
username user25 phonenumber "2005"
username user26 phonenumber "2006"
groupname Administrators member admin
groupname custservice member user21
groupname custservice member user22
groupname custservice member user23
groupname custservice member user24
groupname custservice member user25
groupname custservice member user26
groupname Administrators privilege superuser
groupname Administrators privilege ManagePrompts
groupname Administrators privilege ManagePublicList
groupname Administrators privilege ViewPrivateList
groupname Broadcasters privilege broadcast
calendar biz-schedule systemschedule
 closed day 1 from 00:00 to 24:00
 open day 2 from 09:00 to 17:00
 open day 3 from 09:00 to 17:00
 open day 4 from 09:00 to 17:00
 open day 5 from 09:00 to 17:00
 open day 6 from 09:00 to 17:00
 closed day 7 from 00:00 to 24:00
end schedule
ccn application autoattendant
 description "autoattendant"
 enabled
 maxsessions 8
 script "aa.aef"
 parameter "busOpenPrompt" "AABusinessOpen.wav"
 parameter "holidayPrompt" "AAHolidayPrompt.wav"
 parameter "busClosedPrompt" "AABusinessClosed.wav"
 parameter "allowExternalTransfers" "true"
 parameter "MaxRetry" "3"
 parameter "operExtn" "2001"
 parameter "welcomePrompt" "AAWelcome.wav"
 parameter "businessSchedule" "systemschedule"
 end application
ccn application ciscomwiapplication
 description "ciscomwiapplication"
 enabled
 maxsessions 8
 script "setmwi.aef"
 parameter "strMWI_OFF_DN" "8001"
 parameter "strMWI_ON_DN" "8000"
 parameter "CallControlGroupID" "0"
 end application
ccn application promptmgmt
 description "promptmgmt"
 enabled
 maxsessions 1
 script "promptmgmt.aef"
 end application
!

!--- Define the AA script that will provide the announcement.

!
ccn application s11-cue-aa-bacd
 description "s11-cue-aa-bacd"
 enabled
 maxsessions 8
 script "s11_cue-aa-bacd-script.aef"
 end application
ccn application voicemail
 description "voicemail"
 enabled
 maxsessions 8
 script "voicebrowser.aef"
 parameter "logoutUri" "http://localhost/voicemail/vxmlscripts/mbxLogout.jsp"
 parameter "uri" "http://localhost/voicemail/vxmlscripts/login.vxml"
 end application
ccn engine
 end engine
ccn subsystem jtapi
 ccm-manager address 0.0.0.0 
 end subsystem
ccn subsystem sip
 gateway address "a.1.11.1"
 end subsystem
!

!--- Associate the script with the 2100 AA pilot number.

!
ccn trigger sip phonenumber 2100
 application "s11-cue-aa-bacd"
 enabled
 maxsessions 8
 end trigger
ccn trigger sip phonenumber 2102
 application "autoattendant"
 enabled
 maxsessions 8
 end trigger
ccn trigger sip phonenumber 2105
 application "voicemail"
 enabled
 maxsessions 8
 end trigger
ccn trigger sip phonenumber 2106
 application "promptmgmt"
 enabled
 maxsessions 1
 end trigger
voicemail default language en_US
voicemail default mailboxsize 3000
voicemail broadcast recording time 300
voicemail operator telephone 2001
voicemail mailbox owner "custservice" size 3000
 description "custservice mailbox"
 end mailbox
voicemail mailbox owner "user21" size 3000
 end mailbox
voicemail mailbox owner "user22" size 3000
 end mailbox
voicemail mailbox owner "user23" size 3000
 end mailbox
voicemail mailbox owner "user24" size 3000
description "user24 mailbox"
end mailbox
voicemail mailbox owner "user25" size 3000
description "user25 mailbox"
end mailbox
voicemail mailbox owner "user26" size 3000

description "user26 mailbox"
end mailbox
end

確認

現在、この設定に使用できる確認手順はありません。

トラブルシューティング

ここでは、設定のトラブルシューティングに役立つ情報について説明します。

遊ばない単一 自動転送のための BACD プロンプト

BACD ファイルがフラッシュするにあれば: /bacdprompt/ フォルダは、paramspace 英国位置 フラッシュするを発行します: AA サービスの /bacdprompt/ コマンド。


関連情報


Document ID: 67907